Registry Guide for Windows

Registry Guide for Windows Registry Guide for Windows
Part of the WinGuides Network 		WinGuides Network and Software
Registry tweaks, tricks & hacks to optimize, enhance and secure Microsoft Windows.

The Windows Registry Guide provides an extensive range registry tips, tricks & tweaks for optimizing, enhancing and securing the Windows operating system. Get started by exploring the categorized tweaks below or visit us online at http://www.winguides.com/

Categories

Hardware Hardware
Hardware and Peripheral Enhancements

Network Network
Network and Connectivity Enhancements

Security Security
Security Restrictions and System Policies

Software Software
Enhancements for Windows Applications

Tips and Tricks Tips and Tricks
Windows Tips, Tricks and Shortcuts

Windows Windows
Windows Operating System Enhancements

WinGuides Software for Windows

Tweak Manager - Customize, tweak and secure Windows Tweak Manager
Make your Windows computer faster, more efficient and more user-friendly using hundreds of powerful tweaks and hidden registry settings. Easily customize the appearance, speed and security of your computer with just a few mouse clicks.

Registry Mechanic - Registry Cleaner for Windows Registry Mechanic New
With Registry Mechanic for Windows you can safely clean and repair Windows registry problems with a few simple mouse clicks! Fix problems with the Windows registry that are a common cause of Windows crashes and error messages.

Guides and Articles from WinGuides

Windows Registry Tutorial Windows Registry Tutorial
The Windows Registry Tutorial provides an insight into the functionality and components that form the Windows registry, the central storage area for all common Windows configuration settings.

Security Guide for Windows Security Guide for Windows External Link
The Security Guide for Windows provides information and resources to secure the Windows operating system and networks with details about the latest vulnerabilities and fixes, articles and technical support.

Support Forums for Windows Support Forums for Windows External Link
If you have a question or require help with a Windows technical support problem visit the Support Forums and access the wealth of Windows information provided by the WinGuides community.

Software Guide for Windows Software Guide for Windows External Link
The Software Guide for Windows provides a large selection of Windows applications, utilities and tweaks for managing the Windows operating system.

Scripting Guide for Windows Scripting Guide for Windows External Link
The Scripting Guide for Windows provides technical resources, information and source code to help you automate your system using Windows Script Host (WSH) and the VBScript and JScript scripting languages.

Driver Guide for Windows Driver Guide for Windows External Link
The Driver Guide for Windows provides technical resources and support for locating and updating driver software for Windows compatible hardware devices and peripherals.

Return to Index Copyright © 1998-2003. All Rights Reserved. License


Registry Guide : Hardware

Home : Hardware

Disk Drives Disk Drives
Fixed and Removable Disk Drives

Mice and Keyboards Mice and Keyboards
Mice, Keyboards and Joystick Enhancements

Network and Modems Network and Modems
Network Peripherals, Modems and Fax Enhancements

Printers and Plotters Printers and Plotters
Printer and Plotter Enhancements

Processor and Motherboard Processor and Motherboard
Central Processor and Motherboard Enhancements

Video and Graphics Video and Graphics
Video, Graphics and 3D Enhancements

Disable Universal Plug and Play Services (Windows XP)
Windows XP includes support for Universal Plug and Play (UnPnP) which allows UnPnP devices to be connected over a network. There are currently limited UnPnP devices available and due to a recent security flaw it may be advisable to disable these services.

Show Detailed Information in Device Manager (Windows 2000/XP)
If you require additional information about a device that is not typically displayed in Device Manager, you can use this tweak to make Device Manager show detailed device information.

Remove the Eject Option from the Start Menu (Windows 2000)
This tweak allows you to remove the "Eject PC" option from the Windows 2000 Start menu.

Show All Hidden Devices in Device Manager (Windows 2000/XP)
Devices that are installed but are not currently connected to the computer (such as a Universal Serial Bus (USB) device or "ghosted" devices) are not normally displayed in Device Manager. This tweak causes all devices to be shown.

Disable PC Card Removal Warnings (All Windows)
This setting can be used to disable the PC Card warning messages shown when a PCMCIA device is removed from the socket without first being stopped.

PC Speaker Beeping on Errors (All Windows)
If you get annoyed by the beeps and noises coming from your PC speaker but can't find a way to turn it off, then use this tip to disable it.

Power the Computer Off After Shutdown (Windows NT/2000/XP) Popular
This setting controls whether Windows should automatically power down or reboot your computer once it has finished the shutdown process.


Registry Guide : Hardware : Disk Drives

Home : Hardware : Disk Drives

Change Drive Name and Icon (All Windows) Popular
This tweak allows you to change the name and icon shown in Explorer for a specific drive letter.

Convert an IEEE 1394 Device to a Dynamic Disk Drive (Windows XP)
This tweak allows you to convert an Institute of Electrical and Electronics Engineers, Inc. (IEEE) 1394 (FireWire) disk drive to a dynamic disk drive.

Enable 48-bit LBA Support for Large Hard Drives (Windows 2000/XP)
By default Windows 2000 SP2, Windows XP and earlier versions of Windows do not support 48-bit Logical Block Addressing (LBA) for drives larger than 137GB as defined in the ATA/ATAPI 6.0 specification.

Enable UDMA66 Mode on Intel Chipsets (Windows 2000/XP) Popular
If you have a computer with an Intel chipset that supports UDMA66, you will still find that UDMA66 mode is disabled by default on Windows 2000 computers. This tweak allows you to enable or disable it.

Control the CD-ROM Autorun Function (Windows NT/2000/XP) Popular
Normally when you insert a disc into your CD-ROM drive, the contents are automatically launched. This tweak allows you to disable this behavior.

Configure Protected-Mode Hard Disk Interrupt Handling (Windows 95/98/Me)
This switch allows Windows to terminate interrupts from the hard disk controller, bypassing the ROM routine that handles these interrupts. Some hard drives might require that this setting be disabled in order for interrupts to be processed correctly. If this setting is disabled, the ROM routine handles the interrupts.

Hard Disk Free Space Warning (Windows NT/2000/XP)
By default Windows sends an administrative alert when the amount of free space remaining on a hard disk drive falls below 10 percent. This percentage can be configured using this setting.

Disable CD Burning (Windows XP)
This restriction is used to disable the use of the inbuilt CD recording functions of Windows.


Registry Guide : Hardware : Mice and Keyboards

Home : Hardware : Mice and Keyboards

Change Mouse Double-Click Sensitivity (All Windows)
This setting controls the amount of mouse movement allowed between clicks, for two consecutive clicks to be registered as a double-click.

Change Mouse Wheel Scroll Settings (All Windows)
This tweak determines the number of lines scrolled for each rotation of the mouse wheel on a Microsoft IntelliMouse (or compatible) when no modifier keys (such as [Ctrl] or [Shift]) are pressed.

Active Window Tracking (All Windows)
This tweak allows you to bring running programs to the foreground just by moving you mouse of the application window. This is similar to the X-Mouse feature found on UNIX operating systems.

Change the Keyboard Preferences (All Windows)
These settings allow you to configure the repeat rate, blink rate and repeat delay of your keyboard.

Increase Application Keyboard Response Time (Windows 95/98/Me)
When running more than one application at a time, you may find that your system's keyboard response is slower. To alleviate this, you can adjust the amount of time allocated to processing keystrokes.

Disable the Windows Key (Windows NT/2000/XP) Popular
This tweak disables the Windows key that is found between the Ctrl and Alt keys on a Windows enhanced keyboard.

Detect Accidental Double Clicks (All Windows)
This setting is used to control whether explorer should attempt to automatically detect accidental double mouse clicks.

Change Wheel Mouse Detection (Windows NT/2000/XP)
This setting controls whether the driver should attempt to detect and enable the wheel on the mouse device. The mouse wheel provides rapid scrolling and other control features.

PS2 Mouse Port Rate Adjustment (Windows NT)
Ever noticed how your mouse cursor flickers sometimes or doesn't run as smoothly as you would like? That's because the refresh rate is set too low, modify this key to speed things up and make your mouse cursor move smoothly.

Change the Keyboard Buffer Size (Windows NT/2000/XP)
Occasionally Windows may report an error relating to an overflow in the keyboard buffer. This tweak can be used to increase the size of the buffer, and avoid this problem.

Change the Mouse Buffer Size (Windows NT/2000/XP)
Occasionally Windows may report an error relating to an overflow in the mouse buffer. This tweak can be used to increase the size of the buffer, and avoid this problem.

Display Mouse Pointer Trails (All Windows)
This setting allows you to control whether trails are shown behind the movement of the mouse pointer to increase visibility.

Reverse the Mouse Buttons (All Windows)
By default the left mouse button is the primary mouse button and the right is the secondary. This tweak lets you swap those buttons around to make the right the primary, which may be useful for left handed users.

Control the Mouse "Snap To" Feature (All Windows)
When enabled, this setting causes the mouse pointer to snap-to the default button of the active application window.


Registry Guide : Hardware : Network and Modems

Home : Hardware : Network and Modems

Speed-up Modem and Serial Connections (Windows 95/98/Me)
Windows is normally limited to a default maximum speed of 115,200 bps for serial communications. By using compression and high-speed UARTS modern modems may reach this limit and not be allowed to operate at full speed. This tweak allows Windows to communicate with speeds of 230400, 460800 and 921600 bps.

Load Balance Network Adapters (Windows NT/2000/XP)
If you have two or more network cards in your system this setting allows you to distribute the number of connections, or sessions among the adapters according to a randomizing algorithm.

Configuring Unimodem Support (Windows NT)
Windows NT 4.0 and greater support Unimodem modems, if your device is not supported though Windows can be configured to use the MODEM.INF file instead.

PCMCIA Network Power Management (Windows 95/98/Me)
When using a PC Card network adapter you might not be able to connect the computer to the network, and under Control Panel > System there is a yellow exclamation mark "!" next to the card.

Enable Random Adapter Responses (Windows 95/98/Me)
For a computer with multiple network adapters, this setting specifies whether to respond with an IP address selected randomly from the range of addresses on the computer or whether to return the IP address of the adapter that the request came in upon.

Enable the Network Adapter Onboard Processor (Windows 2000/XP) Popular
If your network adapter has an onboard processor, designed to offload network processing from the system CPU, it is disabled by default. This setting allows you to enable it and increase the processing speed of your system.

Disable Automatic Modem Connections at Startup (All Windows)
If remote connections are enabled in Windows, the system may try to initiate an Internet connection at Windows startup or at the start of many applications. This setting disables that behaviour.

Speed Up ISP Logon Time (Windows 95/98/Me) Popular
On some systems it can take a long time to connect to the Internet, you can decrease the time required to connect to your ISP by trying these simple steps.

Faster Modem Dialing (Windows 95/98/Me) Popular
Waiting to long for your modem to dial? This tip lets you reduce the time it takes your modem to dial, and increase your overall modem connection speed.

Configure the TCP/IP Settings of a Network Adapter (Windows NT/2000/XP) Popular
These values control the TCP/IP parameters of the network interface cards. Configurable parameters include IP Address, Subnet Mask and Default Gateway.


Registry Guide : Hardware : Printers and Plotters

Home : Hardware : Printers and Plotters

Change the Printer Spooler Priority (Windows NT/2000/XP)
Normally the printer spooler runs at the same priority as other services on a system. If your system is being mainly used for printing or handles a large number of print jobs you can use this tweak to change the priority class the print spooler.

Enable Wide Text Printing in Microsoft Word (All Windows)
When you print a document that contains extended characters, such as Greek symbols, to certain printers that do not support Unicode characters, the extended characters may be printed as square boxes. This tweak should resolve the problem on most printers.

Disable Web Printing (Windows 2000/XP)
This restriction enables and disables server support for Internet printing. Internet printing lets you display printers on Web pages so they can be viewed, managed, and used across the Internet or an intranet.

Disable Print Job Notification in Event Viewer (Windows NT/2000/XP)
By default Windows NT server adds an entry in the event log for every print job occurring on the spooler. This can quickly fill up the event log with redundant information.

Define the Scheduler Priority (Windows NT/2000/XP)
This setting controls the overall priority of the printer scheduler.

Disable the Printer Server Browse Thread (Windows NT/2000/XP)
When this option is enabled, the print spooler does not send shared printer information to other print servers.

Beep on Printer Errors (Windows NT/2000/XP)
When this setting is enabled the machine will beep every few seconds when a remote job error occurs on a print server.

Changing the Default Printer Spool Directory (Windows NT/2000/XP)
Windows uses the hard drive to store information before sending it to a printer. If the system is acting as a print server it is possible that the default location may cause insufficient disk space.

Enable Print Job Notification Messages (Windows NT/2000/XP)
By default Windows notifies a user with a popup message that their print job has been completed on the printer. This setting controls that behavior.

Specify Where to Display Printer Notifications (Windows NT/2000/XP)
This setting controls whether print job notification should be sent to the local computer or the computer that the user first logged on to.

Specify the Printer Browser Timeout (Windows NT/2000/XP)
This setting is used to specify the time a network printer should remain in the browse list before it is removed.

Specify the Print Server Broadcast Timeout (Windows NT/2000/XP)
This setting is used to specify the timeout period between broadcasts of a print servers resources.

Show Cascading Printers Folder (Windows 2000/Me/XP)
This tweak controls whether the 'Printers' sub-folder under 'Settings' on the Start Menu, is displayed as a cascading folder.

Change a Users Default Printer (All Windows)
This setting will allow you the change the default printer of a user by modifying the registry.


Registry Guide : Hardware : Processor and Motherboard

Home : Hardware : Processor and Motherboard

Increase the USB Polling Interval (Windows 98/Me/2000/XP)
By default the USB polling interval is once every millisecond (ms). Even if no USB devices are connected the polling operation is still performed and the processor may not be able to enter power-saving state. Use this tweak to increase the polling interval.

Optimize Large Second Level Cache (Windows NT/2000/XP) Popular
Windows is optimized for a 256KB secondary cache by default. With most computers now having L2 caches larger than that it pays to take the time to change the setting to correspond to the size of the cache memory installed.

Manage the CPU Task Priority (Windows 95/98/Me)
This setting allows you to manage how the system processor should prioritize foreground and background tasks.

System Board and Memory Optimizations (Windows 95/98/Me)
These settings allow you to optimize the AGP and PCI buses along with the system memory by reducing the number of wait states (idle time).

View System BIOS Information (Windows NT/2000/XP) Popular
This registry key stores information about the system BIOS, including the release date, version number and video BIOS date.

View System Processor Information (Windows NT/2000/XP)
These values contain information about the system processor, including speed, brand and model.

Fix Problem with Athlon Hanging AGP Programs (Windows 2000/XP) Popular
Windows may stop responding when you use an Accelerated Graphics Port (AGP) program with an AMD Athlon processor. This is due to the memory allocated by the video adapter driver becoming corrupted.

Enable UDMA66 Mode on Intel Chipsets (Windows 2000/XP) Popular
If you have a computer with an Intel chipset that supports UDMA66, you will still find that UDMA66 mode is disabled by default on Windows 2000 computers. This tweak allows you to enable or disable it.

Manage Native Processor Performance Control (Windows XP)
Windows includes built-in processor performance control to manage the microprocessor so it is more efficiently utilized. This tweak allows you to modify this feature.

Modify the Paged and Non Paged Pool Memory Sizes (Windows NT/2000/XP)
Windows normally calculates the paged and non paged pool memory sizes using complex algorithms based on physical memory size. These settings allow you to override and manually specify values.

Improve Core System Performance (Windows NT/2000/XP) Popular
On systems with large amount of RAM this tweak can be enabled to force the core Windows system to be kept in memory and not paged to disk.


Registry Guide : Hardware : Video and Graphics

Home : Hardware : Video and Graphics

Fix Problem with Athlon Hanging AGP Programs (Windows 2000/XP) Popular
Windows may stop responding when you use an Accelerated Graphics Port (AGP) program with an AMD Athlon processor. This is due to the memory allocated by the video adapter driver becoming corrupted.

DirectDraw and Direct3D Settings (Windows 98/Me/2000/XP)
These DirectX settings allow you to change some of the DirectDraw and Direct3D video acceleration parameters.


Registry Guide : Network

Home : Network

Clients Clients
Network Workstation Enhancements

Internet and Remote Access Internet and Remote Access
Remote Access & Internet Settings

Protocols Protocols
Network Protocol Enhancements

Servers Servers
Network Server Enhancements

Increase Network Performance and Throughput (Windows NT/2000) Popular
If you increase the number of buffers that the redirector reserves for network performance, it may increase your network throughput. Each extra execution thread that you configure will take 1k of additional nonpaged pool memory, but only if your applications actually use them.

Display Network Error Statistics (Windows 2000/XP)
This tweak allows you display error statistics on the Network Connection Status page for LAN and WAN connections. This information may be useful in diagnosing the network reliability.

Manage Network Bridge Feature (Windows XP)
Windows XP includes a new feature called Network Bridge, which lets you connect disparate media types into one seamless network. This tweak allows you to control forwarding and settings associated with this feature.

Manage the Reserved QoS Bandwidth (Windows 2000/XP)
This setting determines the percentage of connection bandwidth that the system can reserve for QoS traffic. By default, the Packet Scheduler limits the system to 20 percent of the bandwidth of a connection.

Manage the QoS Packet Queuing (Windows 2000/XP)
This setting specifies the maximum number of outstanding packets permitted on the system. When the number of outstanding packets reaches this limit, the Packet Scheduler postpones all submissions to network adapters until the number falls below this limit.

Specify Users to Receive Administrative Alerts (Windows NT/2000/XP)
This setting is used to specify a list of users and/or computers that should receive administrative alerts.

Load Balance Network Adapters (Windows NT/2000/XP)
If you have two or more network cards in your system this setting allows you to distribute the number of connections, or sessions among the adapters according to a randomizing algorithm.

Change the IRP Stack Size (Windows NT)
When you access shares on a computer running Windows NT Server from a Windows NT client and the IRPstackSize parameter is set too low on the server, you may receive the following error message: "Not enough server storage is available to process this command." This tweak should resolve the problem.

Control Network Browser Elections (Windows NT/2000/XP) Popular
A browser election is a normal network occurrence and provides a means to guarantee there is never more than one master browser present in a domain or workgroup.

Define the Slow Link Time-Out (Windows NT/2000)
Windows uses this value to define what should be classified as low speed and what is a high speed connection. The default time-out is 2000 milliseconds, any connection slower is considered a low speed link.

Automatically Detect Slow Network Connections (Windows NT/2000)
Windows will normally attempt to detect the time-out on network links to determine their speed (high or low). This functionality can be disabled if Windows is having problems determining the speed of your link.

Specifying a Preferred Netware Server (Windows 95/98/Me)
This setting allows you to specify a default Netware.

Removing or Adding Items to Your Persistent Connections List (All Windows)
Windows stores the names of previously mapped drives in the registry, this can be a security threat if vulnerable hidden shares are listed. An advantage is that this key can also be used to set default items for list, if for example inexperienced users were required to map common drives, you could store them here.

Manage the Domain Controller Cannot Be Reached Message (Windows NT/2000/XP)
When Windows is unable to contact a domain controller during a users login a popup error message may be displayed, this message can be controlled by modifying this setting.

Remove the Hand Icon for Shared Resources (All Windows)
Normally when you share a local resource on the network a hand icon is placed under the item to show it is shared. With this tweak you can remove the icon.

Specify the Schedule for Alerter Service (Windows NT/2000/XP)
This setting is used to specify how often the server checks alert conditions and sends any required alert messages to administrative users.

Disable Mapped Drive Reconnect Warning (Windows 95/98/Me)
This setting is used to disable the mapped drive reconnect warning shown at startup when a network drive is unavailable.

Enable Random Adapter Responses (Windows 95/98/Me)
For a computer with multiple network adapters, this setting specifies whether to respond with an IP address selected randomly from the range of addresses on the computer or whether to return the IP address of the adapter that the request came in upon.

Enable the Network Adapter Onboard Processor (Windows 2000/XP) Popular
If your network adapter has an onboard processor, designed to offload network processing from the system CPU, it is disabled by default. This setting allows you to enable it and increase the processing speed of your system.


Registry Guide : Network : Clients

Home : Network : Clients

Disable File Caching for the Workstation Service (Windows 2000/XP)
If you are experiencing problems with workstations flushing data to the server, then you can use this tweak to disable or enable file caching.

Automatic Logon for Novell Netware Clients (All Windows)
These settings allow you to configure the Novell NetWare client to automatically logon to a Windows network.

Change the Client-Side DNS Caching Timeouts (Windows 2000/XP/.NET)
Windows contains a client-side Domain Name System (DNS) cache with stores recent domain lookup entries. If you are experiencing caching or lookup problems you can disable or change the cache timeout.

Delete Cached Copies of Roaming Profiles (Windows NT/2000/XP)
This setting enables Windows to delete the cached profile of any roaming users when they log off the system. This will help to maintain profile integrity and save disk space where that are numerous mobile users.

Prevent Uploading Folders to a Users Server Profile (Windows NT/2000/XP)
When profiles are used and a user logs off from a Windows domain certain folders are uploaded to the central user profile on the server. This setting allows you to stop any time consuming or non-essential folders (e.g. Temporary Internet Files) from being transferred.

Use System-Wide Proxy Settings (All Windows)
This setting allows you to change the scope of the Internet proxy configuration and specify whether all users should share system-wide or individual settings.

Speed-up Browsing Remote Computers (Windows 2000/XP) Popular
When you browse a Windows 95, 98 or Me machine from a Windows 2000 or XP computer extra time is taken to determine if any scheduled tasks or printers are enabled on the destination computer.

Dynamic Domain Name Updates (Windows 2000/XP)
Windows 2000 and XP support dynamic Domain Name System (DDNS) updates and is enabled by default. This setting allows you to control whether network adapters should send updates.

Display Domain Logon Confirmation (Windows 95/98/Me)
When this option is enabled, a popup dialog message is shown when the user successfully authenticates with a Windows domain.

Control Keep Alive Parameters (Windows 95/98/Me)
These settings control how Windows manages connection keep alive transmissions. Including the timeout before keepalives are sent, the interval between keepalive transmissions and how often to send session keepalive packets on active sessions.

Disable SAP Packets for Netware Networks (Windows 95/98/Me)
By default Windows will send SAP packets to advertise available file and print shares when 'File and Print Sharing for Netware Networks' is enabled, this setting controls those packets.

Disable Automatic Netware Logon (Windows 95/98/Me)
This setting disables automatically logging on to Netware servers.

Change the Number of Simultaneous Connections (Windows 95/98/Me)
This setting specifies the maximum number of concurrent connections accepted.

Control the Timeout for LMHOST Name Resolution (Windows 95/98/Me)
This setting controls the period of time the system will wait before timing out when seeking LMHOSTS for name resolution.

Control the DNS Port Used for Lookups (Windows 95/98/Me)
This setting controls which port is used for DNS lookup requests. The default is port 53, but in some firewall situations the settings can be useful to specify an alternate port.

Binding Multiple IP Address to a Single Network Card (Windows 95/98/Me)
The Windows 9x GUI does not accept having multiple IP addresses specified for a single network adapter. This tweak allows you to add additional IP addresses using the registry.

Specify the WinSock Database Files Location (Windows NT/2000/XP)
This parameter specifies the path to the standard internet database files (HOSTS, LMHOSTS, NETWORKS, PROTOCOLS) used by the Windows Sockets interface.

Manage Persistent Connections (Windows NT/2000/XP)
This setting controls whether new network mappings should be created as persistent connections that are automatically reconnected at logon.

Speed Up ISP Logon Time (Windows 95/98/Me) Popular
On some systems it can take a long time to connect to the Internet, you can decrease the time required to connect to your ISP by trying these simple steps.


Registry Guide : Network : Internet and Remote Access

Home : Network : Internet and Remote Access

Disable Internet Access (All Windows)
By using this tweak you are able to restrict access to the Internet when using Internet Explorer and other Microsoft compatible products such as Office.

Cable Modem and DSL Speed Tweak to Increase Performance (Windows 95/98/Me) Popular
These settings allow you to boost the speed of your broadband Internet connection when using a Cable Modem or DSL Router with Windows 95, 98 and Millennium Edition.

Dial-Up Networking Password Box Greyed Out (Windows 95/98/Me)
If you are having problems trying to get DUN to remember your password and you find the option grayed out then there are a few things you can try.

Configure Internet Connection Sharing (ICS) (Windows 98/Me)
Windows 98SE and Me include a feature called Internet Connection Sharing (ICS) which enables networked PCs to easily share a single Internet connection. These settings allow you to configure some ICS parameters.

Enable Remote Assistance (Windows XP)
The Remote Assistance feature is a convenient way for an administrator to remotely connect to a computer and with permission view the screen, move the mouse, use the keyboard and chat online.

Optimize Broadband Cable Modem and DSL Connections (Windows 2000/XP) Popular
These settings allow you to boost the speed of your broadband Internet connection when using a Cable Modem or DSL Router with Windows 2000 and Windows XP.

Enable IP Packet Forwarding (Windows NT/2000/XP)
By default, TCP/IP forwarding is not enabled in Windows, this setting can be used to enable TCP/IP forwarding for all network connections that are installed and used by the computer.

Speed-up Modem and Serial Connections (Windows 95/98/Me)
Windows is normally limited to a default maximum speed of 115,200 bps for serial communications. By using compression and high-speed UARTS modern modems may reach this limit and not be allowed to operate at full speed. This tweak allows Windows to communicate with speeds of 230400, 460800 and 921600 bps.

Optimize the DefaultRcvWindow & DefaultTTL Settings (Windows 95/98/Me) Popular
The optimization of RcvWindow and DefaultTTL along with other registry settings such as MaxMTU and MaxMSS can speed up TCPIP modem and Internet connections.

Optimize Internet Connection Speed (Windows 95/98/Me) Popular
By optimizing the MaxMTU & MaxMSS settings along with the RWIN and TTL settings you can increase dialup modem and broadband connection reliability and performance by as much as 200%.

Keep Remote Connections Active After Logging Off (Windows NT/2000/XP)
When you log off from a Windows client any Remote Access Service (RAS) connections will be automatically disconnected. Enable this setting to remain connected after logging off.

Modify the Internet Auto-Dial Settings (All Windows)
Windows has the option to automatically dial your Internet Service Provider (ISP) to establish an Internet connection. This option can be controlled using this tweak.

Optimize Broadband PPPoE Connections (Windows Me)
This setting optimized the IP MTU value so that there is reduced packet fragmentation when using a broadband connection with PPPoE (Point-to-Point Protocol over Ethernet).

Increase Transfer Rates with ICS and Broadband Connections (Windows 98)
If you are using Internet Connection Sharing ("ICS") with a broadband connection then remove this key to increase the performance.

Disable Automatic Modem Connections at Startup (All Windows)
If remote connections are enabled in Windows, the system may try to initiate an Internet connection at Windows startup or at the start of many applications. This setting disables that behaviour.

Cable Modem and DSL Speed Tweak to Increase Performance (Windows NT)
Use these settings with your Cable Modem or DSL broadband Internet connection, to boost network throughput performance with Windows NT.


Registry Guide : Network : Protocols

Home : Network : Protocols

TCP-IP TCP-IP
Transmission Control Protocol Internet Protocol Enhancements
WINS WINS
Windows Internet Name Service Enhancements

Disable SSDP Discovery in Windows Messenger (Windows 2000/XP)
Windows Messenger uses the Simple Service Discovery Protocol (SSDP) to attempt to locate upstream Internet gateways on UDP port 1900. This tweak allows you to disable Universal Plug and Play Network Address Translation discovery to reduce bandwidth and increase security.

Change the Number of Simultaneous HTTP Sessions (All Windows) Popular
Windows normally limits the number of simultaneous connections made to a single web server. This behavior can be seen in Internet Explorer when downloading multiple files from a web site and only a certain number will be active at any one time.

Change the RPC Packet Size (Windows 2000/XP)
This setting allows you to modify the size limit of incoming Microsoft Remote Procedure Call (RPC) packets.

Specify the NetBIOS Name Resolution Mode (Windows 95/98/Me)
There are several modes used in the resolution of NetBIOS, including WINS and LMHOSTS lookups and broadcast queries. This setting controls which mode is used.

Specify the NetBIOS Name Cache Timeout Period (Windows 95/98/Me)
This setting specifies the period that NetBIOS names are cached before requiring an additional name query.

Specify the Timeout Period for Broadcast Queries (Windows 95/98/Me)
This setting allows you to specify the period of time the system will wait before timing out broadcast name queries.

Specify the Number of Broadcast Name Resolution Attempts (Windows 95/98/Me)
This setting controls the number of attempts to resolve a NetBIOS name using a broadcast query.

Specify the Number of NetBIOS Entries to Store (Windows 95/98/Me)
These settings control the maximum number of NetBIOS entries to store in the name and session tables.


Registry Guide : Network : Protocols : TCP-IP

Home : Network : Protocols : TCP-IP

Change the TIME_WAIT Timeout to Increase Connections (Windows NT/2000/XP)
This setting determines the length of time that a connection will stay in the TIME_WAIT state before being closed. The default is 240 seconds which on a busy server will limit the maximum connections to around 200/sec. Reducing this setting will increase the maximum connection limit.

Harden the TCP/IP Stack for Denial of Service Attacks (Windows 2000/XP)
Denial of service attacks are network attacks that are aimed at making a computer or a particular service unavailable to network users. These settings can be used to increase the ability for Windows to defend against these attacks when connected directly to the Internet.

Disables DHCP Router Discovery (All Windows)
The ICMP Router Discovery Protocol (IRDP) comes enabled by default for Windows clients using DHCP. This can be a security issue because by spoofing IRDP Router Advertisements, an attacker can remotely add default route entries on a remote system.

Protect Against SYN Flood Attacks (Windows NT/2000/XP)
Windows includes protection that allows it to detect and adjust when the system is being targeted with a SYN flood attack (a type of denial of service attack). When enabled the connection responses time out more quickly in the event of an attack.

Configure DHCP Server for Unicast (Windows NT/2000/XP)
By default, the Windows DHCP server sends all DHCP responses as IP broadcasts to the limited broadcast address (255.255.255.255). However, the DHCP server can be configured send to unicast responses by applying this tweak.

Specify the Router Buffer Size (Windows NT/2000/XP)
This parameter determines how much memory IP allocates to store packet data in the router packet queue. When this buffer space is filled, the router begins discarding packets at random from its queue.

Offload IP Security Task Processing (Windows 2000/XP)
This setting is used to control whether IP Security (IPSEC) tasks should be offloaded to a network card with IP security capabilities.

Enable IP Packet Forwarding (Windows NT/2000/XP)
By default, TCP/IP forwarding is not enabled in Windows, this setting can be used to enable TCP/IP forwarding for all network connections that are installed and used by the computer.

Control RFC 1323 Time Stamp and Window Scaling (Windows NT/2000/XP)
This setting controls RFC 1323 timestamps and window scaling options. Timestamps and Window scaling are enabled by default, but can be manipulated with flag bits.

Control Selective Acknowledgement (SACK) Operation (Windows NT/2000/XP)
This parameter controls whether or not Selective ACK (SACK - RFC 2018) support is enabled. With SACK enabled (default), a packet or series of packets can be dropped, and the receiver informs the sender which data has been received, and where there may be "holes" in the data.

Control Windows Treatment of Priority TCP/IP Data (Windows NT/2000/XP)
This parameter determines whether TCP uses the RFC 1122 specification for urgent data or the mode used by BSD- derived systems. The two mechanisms interpret the urgent pointer in the TCP header and the length of the urgent data differently.

Specify the Router Packet Queue Size (Windows NT/2000/XP)
This parameter determines the number of IP packet headers allocated for the router packet queue. When all headers are in use, the router will begin to discard packets at random from the queue.

Control Keep Alive Parameters (Windows NT/2000/XP)
These settings control how Windows manages connection keep alive transmissions. Including the timeout before keepalives are sent and the interval between keepalive transmissions.

Specify the Conformance Level for IP Multicast (Windows NT/2000/XP)
This parameter determines to what extent the system supports IP multicasting and participates in the Internet Group Management Protocol, RFC 1112.

Enable Dead Gateway Detection (Windows NT/2000/XP)
This setting specifies whether Windows should automatically detect and use an alternate gateway in the event of transmiting a segment several times without receiving a response.

Change the PPPOE MTU Size (Windows XP)
By default, a Windows XP PPPoE connection uses an MTU size that is 20 bytes less than the IP MTU of the LAN adapter over which the PPPoE packets are sent, which in most cases is 1480 bytes. If a lower MTU is required, then this tweak can be used to change the value.

Control the Number of TCP/IP Connection Attempts (Windows 95/98/Me)
This setting controls the number of TCP/IP connection attempts (SYN packets) to be transmitted before timing out.

Modify the Number of Duplicate ACKs for Fast Retransmit (Windows 2000/XP)
This parameter determines the number of duplicate ACKs that must be received for the same sequence number of sent data before "fast retransmit" is triggered to resend the segment that has been dropped in transit.

Specify the Conformance Level for IP Multicast (Windows 95/98/Me)
This parameter determines to what extent the system supports IP multicasting and participates in the Internet Group Management Protocol, RFC 1112.

Detect Black Hole Routers During Path MTU Discovery (Windows NT/2000/XP)
Specifies whether the stack will attempt to detect Maximum Transmission Unit (MTU) routers that do not send back ICMP fragmentation-needed messages.

Enable Path MTU Discovery (Windows NT/2000/XP)
Enabling the setting causes TCP to attempt to discover the Maximum Transmission Unit (MTU or largest packet size) over the path to a remote host. By discovering the Path MTU and limiting TCP segments to this size, TCP can eliminate fragmentation at routers along the path that connect networks with different MTUs.

Disable TCP/IP Source Routing (Windows NT 4.0)
Normally, on a computer running Windows NT 4.0, you cannot disable the source routing feature for the TCP/IP protocol. By using this tweak it is possible to disable it.

Specify System-wide TCP Receive Window Size (Windows 2000/XP)
The TcpWindowSize parameter can be used to set the receive window on a per-interface basis. This parameter can be used to set a global limit for the TCP window size on a system-wide basis.

Enable Dead Gateway Detection (Windows 95/98/Me)
This setting specifies whether Windows should automatically detect and use an alternate gateway in the event of a failed gateway.

Specify the Maximum Number of TCP/IP Connections (Windows NT/2000)
This parameter specifies the maximum number of connections that TCP may have open simultaneously.

Optimize Windows TCP/IP Data Retransmissions (Windows NT/2000/XP)
This parameter controls the number of times TCP will retransmit an individual data segment (not connection request segments) before aborting the connection.

Control RFC 1323 Time Stamp and Window Scaling Options (Windows 95/98/Me)
This setting controls RFC 1323 time stamps and window scaling options for TCP/IP packets.

Specify the Default Time to Live for TCP/IP Packets (Windows NT/2000/XP)
Specifies the default Time To Live (TTL) value set in the header of outgoing IP packets. The TTL determines the maximum amount of time an IP packet may live in the network without reaching its destination. It is effectively a limit on the number of routers an IP packet may pass through before being discarded.

Enable MTU Discovery (Windows 95/98/Me)
This setting specifies whether the TCP/IP stack will attempt to perform path MTU discovery as specified in RFC 1191.

Enable MTU Black Hole Detection (Windows 95/98/Me)
Specifies whether the stack will attempt to detect Maximum Transmission Unit (MTU) routers that do not send back ICMP fragmentation-needed messages.

Control Windows Treatment of Priority TCP/IP Data (Windows 95/98/Me)
This value specifies how Windows should handle urgent data transfers, either in a same manner to some UNIX systems or as specified by RFC 1122.

Specify the TCP/IP Receive Window Size (Windows 95/98/Me) Popular
This setting controls the size of the TCP/IP receive Window. In general, larger receive windows work better with high-delay, high-bandwidth data.

Optimize Windows TCP/IP Connection Retransmissions (Windows NT/2000/XP)
This parameter determines the number of times TCP will retransmit a connect request (SYN) before aborting the attempt. The retransmission timeout is doubled with each successive retransmission in a given connect attempt.

Specify the Default TCP/IP Time to Live (Windows 95/98/Me)
This setting specifies the default time to live (TTL) value for IP packets generated by the Windows TCP/IP stack.

Optimize the Windows TCP/IP Window Size (Windows NT/2000) Popular
This parameter determines the maximum TCP receive window size offered by the system. The receive window specifies the number of bytes a sender may transmit without receiving an acknowledgment.

Change the Maximum Transmission Unit (MTU) Size (Windows NT/2000/XP) Popular
This parameter specifies the Maximum Transmission Unit (MTU) for a network interface. By optimizing the MTU setting you can gain substantial network performance increases, especially when using dial-up modem connections.

Enable Source Routing on Token Ring Networks (Windows NT/2000)
Setting this parameter to 1 will force TCP/IP to transmit ARP queries with source routing enabled on Token Ring networks. By default, the stack transmits ARP queries without source routing first and retries with source routing enabled if no reply was received.

Specify System-wide TCP Receive Window Size (Windows 98)
The TcpWindowSize parameter can be used to set the receive window on a per-interface basis. This parameter can be used to set a global limit for the TCP window size on a system-wide basis.

Modify the Initial Retransmission Timeout (Windows NT/2000)
This parameter controls the initial retransmission timeout used by TCP on each new connection. It applies to the connection request (SYN) and to the first data segment(s) sent on each connection.

Change TCP/IP Broadcast Address (Windows NT/2000)
This setting allows Windows to be configured to use zeros-broadcasts (0.0.0.0) instead of ones-broadcasts (255.255.255.255). Most systems use ones-broadcasts, but some systems derived from BSD implementations use zeros-broadcasts.

Transmit Ethernet Packets Using 802.3 SNAP Encoding (Windows NT/2000)
Enabling this setting forces TCP/IP to transmit Ethernet packets using 802.3 SNAP encoding. By default, the stack transmits packets in DIX Ethernet format. It will always receive both formats.

Specify the Default TCP/IP Type of Service (TOS) (Windows NT)
This setting specifies the default type of service (TOS) for IP packets generated by the TCP/IP stack. This can be used to manage quality of service (QOS) throughout a network.

Configure the TCP/IP Settings of a Network Adapter (Windows NT/2000/XP) Popular
These values control the TCP/IP parameters of the network interface cards. Configurable parameters include IP Address, Subnet Mask and Default Gateway.

Specify the Default TCP/IP Type of Service (TOS) (Windows 95/98/Me)
This setting specifies the default type of service (TOS) for IP packets generated by the TCP/IP stack. This can be used to manage quality of service (QOS) throughout a network.

Control the Number of TCP/IP Transmission Retries (Windows 95/98/Me)
This setting defines the number of transmission retries will be transmitted before the connection is aborted.

Control TCP/IP Routing Parameters (Windows 95/98/Me)
These settings control IP routing features including the total amount of buffer space to allocate for routing packets and the maximum number of packets that can be routed simultaneously.

Override the Default Broadcast Address (Windows 95/98/Me)
This setting overrides the default broadcast address that is derived from the IP address and subnet mask. Primarily the broadcast address is used for NetBIOS name queries.

Configure the DHCP Settings of a Network Adapter (Windows NT/2000/XP)
This setting controls whether TCP/IP should use DHCP to automatically assign an IP address, or if it should use the statically defined address.


Registry Guide : Network : Protocols : WINS

Home : Network : Protocols : WINS

Configure LMHOSTS Lookup Options (Windows NT/2000/XP)
The LMHOSTS file is used within Windows networking to specify domain resolution and lookup information. These settings allow you to configure the use of the LMHOSTS file.

Control Network Adapter Responses to a WINS Query (Windows 95/98/Me)
In computers with multiple network adapters this setting specifies whether to send all IP addresses or only one IP address in response to a WINS query request.

Control the WINS Refresh Period (Windows 95/98/Me)
This setting control the initial WINS refresh timeout value.

Control Network Adapter Responses to a WINS Query (Windows NT/2000/XP)
In computers with multiple network adapters this setting specifies whether to send all IP addresses or only one IP address in response to a WINS query request.

Enable WINS Proxy Agent (Windows 95/98/Me)
This setting controls whether the current computer should act as a WINS proxy agent and forward WINS name queries.

Specify the WINS Port Number (Windows 95/98/Me)
This setting allows you to specify an alternate port number to use with all WINS name queries and registration requests.

Control WINS Query Settings (Windows 95/98/Me)
These settings control the WINS query parameters including the number of query attempts and query timeout.

Specify Response Mode for Multi-Adapter Computers (Windows 95/98/Me)
For a computer with multiple network adapters, this setting specifies whether to send all IP addresses on a name query request from WINS.


Registry Guide : Network : Servers

Home : Network : Servers

Optimize the Windows Server Service (Windows NT/2000/XP)
This setting can be used to manually optimize the Windows server functionality. By selecting the appropriate value you can optimize the service for memory usage, network throughput or a balance of both.

Display Configure Your Server Wizard (Windows 2000)
You can modify your user profile to determine whether the "Windows 2000 Configure Your Server" dialog box appears at startup.

Support Browse Lists for Multiple Domains (Windows NT/2000/XP)
By default, the Computer Browser service only maintains a list of servers on the local network. To allow clients to browse computers on other domains you may need to add the other domains names using this tweak.

Control Automatic DNS Server Cache Updates (Windows NT/2000/XP)
This value disables that automatic cache updated from the DNS root servers. Useful when there is a problem with the root servers, or if you wish to completely control DNS updates.

Support Long Filenames on Netware Servers (Windows 95/98/Me)
This setting controls whether long filenames (LFN) are supported on Netware servers, and if supported which versions.

Change LAN Auto-disconnect Timeout (Windows NT/2000/XP)
Windows can be configured to automatically disconnect idle LAN sessions are a set number of minutes.

Control MS-DOS File Control Blocks (FCBs) Usage on Servers (Windows NT/2000)
Specifies whether MS-DOS File Control Blocks (FCBs) are folded together, so multiple remote opens are performed as a single open on the server to save resources.

Specify the Idle Timeout for Server Connnections (Windows NT/2000/XP)
Specifies the amount of idle time that a circuit is allowed before being disconnected. If this parameter is set to a low value, it saves server resources but reduces performance because of client overhead in reconnecting.

Include a Comment in the Server Announcement (Windows NT/2000/XP)
This setting allows you to specify a comment which is sent in server announcements and returned to NetServerGetInfo requests.

Specify the Server Announcement Variation (Windows NT/2000/XP)
This parameter specifies the time by which the server announcement period can vary. This helps to prevent several servers from continuously announcing simultaneously, thereby reducing network load peaks.

Specify the Server Announcement Frequency (Windows NT/2000/XP)
Specifies how often a non-hidden server announces itself to the network. More frequent announcements keep client server tables more up to date, but may increase network overhead and processing on client computers, because the clients must process every announcement.

Search for Network Folders and Printers (All Windows)
This setting controls whether Windows should automatically attempt to locate available file shares and printers by crawling the local network.

Disable the Printer Server Browse Thread (Windows NT/2000/XP)
When this option is enabled, the print spooler does not send shared printer information to other print servers.


Registry Guide : Security

Home : Security

Active Desktop Active Desktop
Active Desktop Security and Restrictions

Control Panel Control Panel
Control Panel Security Restrictions

Desktop and Explorer Desktop and Explorer
Desktop and Explorer Restrictions

Login and Authentication Login and Authentication
Login and Authentication Settings

Network Network
Network and Workgroup Security Settings

Privacy Privacy
Security settings to manage privacy

Remote Access Remote Access
Remote Access Security Settings

Start Menu and Taskbar Start Menu and Taskbar
Start Menu and Taskbar Restrictions

System System
System Security Restrictions and Settings

Prevent Access to the Contents of Selected Drives (Windows 2000/Me/XP)
This restriction prevents users from using My Computer or Explorer to access the content of selected drives. Also, they cannot use Run, Map Network Drive, or the Dir command to view the directories on these drives.

Disable Registry Editing Tools (All Windows) Popular
This restriction disables the ability to interactively run the standard Microsoft registry editing tools such as REGEDIT and REGEDT32.

Disable the Shut Down Command (All Windows)
This option allows you to stop users from being able to shutdown the computer by disabling the shut down command.

Disable the Windows Hotkeys (All Windows)
This restriction allows you to disable the use of the Windows hotkey combinations that provide shortcuts to the Start Menu and task swapping.

Restrict Access to the Windows Update Feature (All Windows)
The Windows Update feature allows users to easily update Windows components and software over the Internet. These settings allow can be used to grant or restrict access to this function.

Manage System Policy Updates (Windows NT/2000/XP)
Windows normally makes a connection to the NETLOGON share of the validating domain controller and checks for the existence of the policy file. These settings control how system policies are applied to a Windows machine when on a network.

Hide Drives in My Computer (All Windows) Popular
This setting allows you to control which drives are visible in My Computer and Explorer. It is possible to hide all drives or just selected ones.

Reset the Screen Saver Password (Windows 95/98/Me)
If you have misplaced your Windows screen saver password you can reset it by using this tweak.

Restrict Applications Users Can Run (All Windows) Popular
Windows gives the ability to restrict the applications that can be run by users on a workstation.

Change Alternate Installation Credential Settings (Windows 2000/XP)
These settings control whether users are prompted to enter alternate logon credentials when installing software as a non administrative user.

Restrict Changes to User Folder Locations (Windows 2000/Me/XP)
These restrictions disable the ability for users to change the location of user-specific folders such as My Documents, My Pictures, My Music and Favorites.

Disable User Profiles (Windows 95/98/Me)
This setting can be used to disable the use of user profiles.

Implement a User Based Custom Shell (Windows 2000/XP)
Windows allows you to selectively specify the system shell based on the logged in user. For example this allows one user to use the standard explorer interface and another to use the legacy progman shell.

Disable Run Commands Specified in the Registry (Windows 98/Me/2000/XP)
This restriction is used to disable the ability to run startup programs specified in the registry when Windows launches.

Restrict Users from Running Specific Applications (Windows 2000/Me/XP)
This setting allows you to specify applications and filenames that users are restricted from running.


Registry Guide : Security : Active Desktop

Home : Security : Active Desktop

Force the Use of Active Desktop (All Windows)
The user is normally given the option of disabling Active Desktop through the display properties. This tweak removes the ability to disable Active Desktop.

Active Desktop Restrictions (All Windows)
Features of the Windows Active Desktop can be selectively controlled by modifying options in the Windows registry. Following the instructions in this tweak.

Remove Active Desktop Options from the Settings Menu (All Windows)
The tweak will remove the Active Desktop options from Settings on the Start Menu.

Restrict Changes to Active Desktop Settings (All Windows)
This tweak allows you to have Active Desktop enabled, but to restrict any changes to the settings.

Disable Active Desktop (All Windows)
This tweak will disable the use of the Active Desktop feature.


Registry Guide : Security : Control Panel

Home : Security : Control Panel

Display Display
Display Properties Restrictions

Network Network
Network Properties Restrictions

Passwords Passwords
Password Properties Restrictions

Printers Printers
Printer Properties Restrictions

System System
System Properties Restrictions

Show Administrative Tools in Control Panel (Windows XP)
This tweak allows you to change whether the "Administrative Tools" applet is shown in the Control Panel.

Hide Set Program Access and Defaults in Add/Remove Programs (Windows 2000/XP)
This restriction is used to hide "Set Program Access and Defaults" on the Add or Remove Programs page. This feature was introduced with Windows XP SP1 and Windows 2000 SP3 to allow users to configure the default applications used on the PC.

Disable Control Panel (Windows 2000/Me/XP) Popular
This setting allows you to restrict user access to the Control Panel options and settings.

Hide Control Panel Applets (Windows NT/2000/XP) Popular
This tweak allows you to show or hide specific applets found in the Windows Control Panel.

Hide Control Panel, Printer and Network Settings (All Windows) Popular
This restriction removes the Control Panel, Printers and Network Connection settings from the Start menu. If the Taskbar settings are also hidden it causes the Settings menu to be completely removed.

Force the Control Panel Display Style (Windows XP)
This setting specifies the visual style of the Control Panel. Allowing you to either force the use of the new XP style, classic style or allow the user to select the preferred style.

Add or Remove Programs Restrictions (Windows 2000/XP)
These restrictions apply to the Add/Remove Programs feature of Control Panel. They allow you to entirely or individually disable components.

Disable Printers Control Panel Icon (Windows 95/98/Me)
This option disables access to the Printers icon in control panel, therefore stopping users from changing Printer settings.

Disable Network Control Panel (Windows 95/98/Me)
Enabling this option disables access to the Network Control Panel icon.

Deny Access to the Display Settings (All Windows)
This option disables the display settings control panel icon, and stops users from accessing any display settings.

Hide Control Panel Applets (Windows 95/98/Me) Popular
This tweak allows you to show or hide any of the applets found in the Windows Control Panel.


Registry Guide : Security : Control Panel : Display

Home : Security : Control Panel : Display

Restrict Desktop Theme Controls (Windows XP)
These restrictions control access to the desktop theme settings including the Windows styles, buttons, schemes and fonts.

Hide the Themes Settings Page (Windows XP)
This option hides the Themes tag which prevents the user from selecting an alternate theme. Themes normally include a background plus sounds, icons and other elements.

Hide the Keyboard Navigation Settings (Windows 2000/XP)
This restriction disables the "Hide keyboard navigation indicators until I use the ALT key" option in the Display Control Panel.

Restrict Changes to Animation Settings (Windows 2000/XP)
This restriction prevents users from selecting the option to animate the movement of windows and menus.

Hide the Display Settings Page (All Windows)
This option hides the Settings page from the display properties control.

Hide the Screen Saver Settings Page (All Windows)
This option hides the screen saver page from the display settings control, which stops users having access to change screen saver settings.

Hide the Display Background Page (All Windows)
This option hides the background page stopping users from changing any background display settings.

Hide the Display Appearance Page (All Windows)
When enabled this setting hides the display settings appearance page.


Registry Guide : Security : Control Panel : Network

Home : Security : Control Panel : Network

Hide Network Access Control Page (Windows 95/98/Me)
The Access Control Page, defines whether the computer support User-Level access or Share-Level access, enabling this option removes access to the Access Control Page.

Hide Network Identification Page (Windows 95/98/Me)
The Network Identification page include options to set the Computer Name, Workgroup and Description, enabling this option disables access to the Network ID page.

Hide the File and Printer Sharing Controls (Windows 95/98/Me)
Enabling this options hides the file and printer sharing controls, stopping users from disabling or creating new file or printer shares.


Registry Guide : Security : Control Panel : Passwords

Home : Security : Control Panel : Passwords

Restrict Access to the Passwords Control Panel (Windows 95/98/Me)
This option disables access to the Passwords icon on the control panel, therefore stopping users from changing security related settings.

Hide the User Profiles Page (Windows 95/98/Me)
The user profile page controls whether all users share or have separate user profiles, access to this page can be disabled by enabling this setting.

Hide the Remote Administration Page (Windows 95/98/Me)
Enabling this function stops users from being able to change the remote administration settings for the computer.

Hide the Change Passwords Page (Windows 95/98/Me)
When this setting is enabled, users are no longer able to access the Change Passwords page.


Registry Guide : Security : Control Panel : Printers

Home : Security : Control Panel : Printers

Disable the Addition of Printers (All Windows)
Any user can add a new printer their system, this option once enabled disables the addition of new printers to the computer.

Disable the Deletion of Printers (All Windows)
Printers can be deleted simply by any user pressing the delete key, enabling this setting stops users from being able to delete printers.

Hide the General and Details Printer Pages (Windows 95/98/Me)
This option hides the printer details and general printer information pages. Once enabled this option stops users from changing specific printer settings.


Registry Guide : Security : Control Panel : System

Home : Security : Control Panel : System

Hide the Virtual Memory Button (Windows 95/98/Me)
This option hides the Virtual Memory button from the System icon on the Control Panel.

Hide the File System Button (Windows 95/98/Me)
This option hides the File System button from the System icon on the Control Panel.

Hide the Hardware Profiles Page (Windows 95/98/Me)
This setting when enabled hides the Hardware Profiles page from the System icon on the Control Panel.

Hide the Device Manager Page (Windows 95/98/Me)
This setting controls whether the Device Manager is visible, under System in the Control Panel.


Registry Guide : Security : Desktop and Explorer

Home : Security : Desktop and Explorer

Disable the Ability to Right Click on the Desktop (All Windows) Popular
This tweak removes the context menu that would normally appear when the user right clicks on the desktop or in the Explorer right results pane.

Enable Advanced File System and Sharing Security (Windows XP Professional)
This setting is used to enable the ability to control advanced NTFS permissions on local and shared files.

Restrict the Screen Saver (Windows 2000/XP)
This restriction can be used to specify the screen saver or to stop screen savers from running. Also, the Screen Saver settings page is disabled, so users cannot change the screen saver options.

Screen Saver Password Protection Policy (Windows 2000/XP)
This restriction determines whether the screen saver is password protected and prevents users from changing the password-protection setting.

Specify the Background Image and Wallpaper Style (Windows 2000/Me/XP)
These settings allow you to specify the background wallpaper and display style. When this setting is defined users can not choose an alternative background image.

Enforce Shell Extension Security (All Windows)
This restriction can be used to limit the system to only run files that have an approved shell extension.

Secure Desktop Restriction (Windows 2000/XP)
This restriction is used to stop interactive users from snooping on other user sessions by exploiting a Windows vulnerability. This feature is enabled by default but may interfere with some software applications.

Remove the Distributed File System Tab (Windows 2000/XP)
This restriction removes the Distributed File System (DFS) tab from Windows explorer. This prevents users from viewing or changing the properties of local DFS shares.

Remove the Security Tab (Windows XP)
This restriction removes the Security tab from Windows explorer which prevents users from accessing or changing the security permissions of folder and file objects.

Remove the Hardware Tab (Windows 2000/XP)
This restriction removes the hardware tab from applicable items in the Control Panel and from the local drive properties. This prevents users from changing the hardware device properties.

Disable the New Menu Item (All Windows)
This tweak can be used to disable the ability to use the New menu item to create new objects using explorer.

Disable the Ability to Customize Toolbars (All Windows)
By right clicking on a toolbar you are usually given the option to Customize, which allows you to change which functions are available from the toolbar. This tweak allows you to disable that function.

Remove the Option to Change or Hide Toolbars (All Windows)
By default users are able to select which toolbars are displayed either be right clicking the toolbar itself, or by changing the options from the View menu. This tweak locks the toolbars, removing the ability to change which are displayed.

Remove File Menu from Explorer (All Windows)
This setting is used to Remove the File option from the Explorers toolbar.

Hide the Network Neighborhood Icon (All Windows)
The Network Neighborhood icon is shown on the Windows desktop whenever Windows networking is installed, by enabling this setting the icon will be hidden.

Disable Folder Options Menu (All Windows)
This tweak allows you to hide the Folder Options function from the folder Tools menu. Allowing you to restrict access to numerous advanced folder features.

Remove Properties from My Computer (Windows XP)
This restriction remove the properties option from My Computer and hides the "System Properties" screen.

Remove the Ability to Modify File Types (Windows 2000/XP)
This setting allows you to remove the ability to change, add or delete file types using explorer the Folder Options interface.

Hide All Items on the Desktop (All Windows)
Enabling this options hides all the items and programs on the Windows desktop.


Registry Guide : Security : Login and Authentication

Home : Security : Login and Authentication

Automatic Logon to Windows 95, 98 and Me (Windows 95/98/Me) Popular
This setting allows Windows clients to automatically logon without entering a user name or password, therefore bypassing the logon box.

Automatic Logon to Windows NT, 2000 and XP (Windows NT/2000/XP) Popular
Windows includes a feature that allows you to configure the computer to automatically logon to the network, bypassing the Winlogon dialog box.

Enable Shutdown from Authentication Dialog Box (Windows NT/2000/XP)
When this setting is enabled a [Shutdown] button is displayed in authentication dialog box when the system first starts. This allows you to shutdown a system without logging in. The button is shown by default on a workstation and removed on a server installation.

Automatic Administrative Logon to Recovery Console (Windows 2000/XP)
The recovery console is a command line environment that is used to recover from system problems. This setting controls whether the administrator account will be logged on automatically or be required to enter a password when the recovery console is invoked during startup.

Disable Password Caching in Internet Explorer (All Windows)
When you attempt to view a password-protected site, you are normally prompted to type your username and password with an option to "Save this password in your password list". This tweak can be used to disable the ability for users to save passwords.

Limit the Number of Automatic Logins (Windows NT/2000/XP)
This setting is used to limit the number of automatic logins, once the limit has been reached the auto logon feature will be disabled and the system will display the standard authentication box.

Modify the Number of Cached Logins (Windows NT/2000/XP)
This value controls the number of allowable cached login attempts when the network domain controller is unavailable.

Legal Notice Dialog Box Before Logon (All Windows) Popular
Use these fields to create a dialog box that will be presented to any user before logging onto the system. This is useful where you are required by law to warn people that it is illegal to attempt to logon without being an authorized user.

Set the Minimum Password Length (All Windows)
You can force Windows to reject passwords that do not meet a minimum password length. Useful to help stop people from using trivial passwords where security is an issue.

Customize the Windows Logon and Security Dialog Title (Windows NT/2000/XP) Popular
This setting allows you to add additional text to the title of the standard Windows Logon and Windows Security dialog boxes.

Show Verbose Security Status Messages (Windows 2000/XP)
This setting allows you to configure Windows so that you receive verbose startup, shutdown, logon, and logoff status messages. This may be helpful to in troubleshooting slow startup, shutdown, logon, or logoff behaviour.

Force the Use of Automatic Logon (Windows 2000/XP) Popular
Normally when a Windows machine is configured to automatically logon to a specified account users can bypass this and enter alternate account information. This tweak forces the machine to auto logon and to ignore any bypass attempts.

Disable Password Caching (All Windows)
Normally Windows caches a copy of the users password on the local system to allow for additional automation, this leads to a possible security threat on some systems. Disabling caching means the users passwords are not cached locally. This setting also removes the second Windows password screen and also remove the possibility of networks passwords to get out of sync.

Require Alphanumeric Windows Password (All Windows)
Windows by default will accept anything as a password, including nothing. This setting controls whether Windows will require a alphanumeric password, i.e. a password made from a combination of alpha (A, B, C...) and numeric (1, 2 ,3 ...) characters.

Disable the Change Password Button (Windows NT/2000)
This setting disables the 'Change Password' button on the Windows Security dialog box. Enabling this setting stops casual users from being able to change the password.

Disable the Lock Workstation Button (Windows NT/2000/XP)
Add this setting to the registry to stop unauthorized users from locking machines from the Windows Security dialog box.

Disable the Auto Logon Shift Override Feature (Windows NT/2000/XP)
When using the automatic login feature it is possible for a user to hold the Shift key to bypass the login sequence and enter a username and password. This feature disables the ability to override the function.

Require Users to Press Ctrl+Alt+Delete Before Logon (Windows 2000/XP)
This setting controls whether users are required to press Ctrl + Alt + Delete as a security precaution before logging into the system.

Restrict Showing the Last Username (Windows 2000/XP)
This restriction removes the ability to view which user was last logged onto a computer by clearing the username box on the login screen.

Use Active Authentication for Unlock and Screen Saver (Windows NT/2000/XP)
This setting controls whether a full login should be performed when a workstation is unlocked or a password is used with the screen saver. Normally Windows will not check some settings such as whether the account has been locked out.

Change the Message Shown on the Logon Box (Windows NT/2000/XP) Popular
You can personalize (or legalize) the message displayed on the logon box above the user name and password.

Allow Portables to Undock Before Logon (Windows XP)
This setting controls whether users with portable computers have the option to undock the system before they have logged onto the computer.

Start Windows Without Prompting for a Password (Windows 95/98/Me) Popular
Does Windows prompt you for a password every time you boot up even though you're the only one using the PC? Follow these instructions to make Windows automatically start up without prompting you for a password.

Force Users to Logon to Windows (Windows 95/98/Me) Popular
Usually users can simply press 'Cancel' at the Windows logon box to bypass the login process and gain access to the local computer. This tweak will logout the user if the authentication fails or the user clicks Cancel.


Registry Guide : Security : Network

Home : Security : Network

Network Connection Restrictions (Windows 2000/XP)
These restrictions control access to the features and properties of LAN, RAS and other network connections.

Remove Log Off from the Start Menu (All Windows)
This tweak allows you to remove the Log Off [Username] option from the Start menu.

Disable File and Printer Sharing (Windows 95/98/Me)
When file and printer sharing is installed it allows users to make services available to other users on a network, this functionality can be disabled by changing this setting.

Harden the TCP/IP Stack for Denial of Service Attacks (Windows 2000/XP)
Denial of service attacks are network attacks that are aimed at making a computer or a particular service unavailable to network users. These settings can be used to increase the ability for Windows to defend against these attacks when connected directly to the Internet.

Disables DHCP Router Discovery (All Windows)
The ICMP Router Discovery Protocol (IRDP) comes enabled by default for Windows clients using DHCP. This can be a security issue because by spoofing IRDP Router Advertisements, an attacker can remotely add default route entries on a remote system.

Protect Against SYN Flood Attacks (Windows NT/2000/XP)
Windows includes protection that allows it to detect and adjust when the system is being targeted with a SYN flood attack (a type of denial of service attack). When enabled the connection responses time out more quickly in the event of an attack.

Disable Web Printing (Windows 2000/XP)
This restriction enables and disables server support for Internet printing. Internet printing lets you display printers on Web pages so they can be viewed, managed, and used across the Internet or an intranet.

Disable Recent Shares in Network Places (Windows 2000/XP)
This restriction stops remote shared folders from being added to Network Places whenever you open a document in the shared folder.

Offload IP Security Task Processing (Windows 2000/XP)
This setting is used to control whether IP Security (IPSEC) tasks should be offloaded to a network card with IP security capabilities.

Specify Users to Receive Administrative Alerts (Windows NT/2000/XP)
This setting is used to specify a list of users and/or computers that should receive administrative alerts.

Send Plain Text Passwords (All Windows)
When connecting to some SMB servers, such as Samba and LAN Manager for UNIX, you may be required to send unencypted password. This setting enables that functionality.

Disable Save Password Option in Dial-Up Networking (Windows NT/2000)
When you dial a phonebook entry in Dial-Up Networking (DUN), you can use the 'Save Password' option so that your DUN password is cached and you will not need to enter it on successive dial attempts. This key disables that option.

Restrict Anonymous User Access (Windows NT/2000/XP)
Windows has a feature where anonymous users can list domain user names and enumerate share names. Users who want enhanced security may optionally restrict this functionality.

Changing LAN Manager Authentication on Windows NT (Windows NT)
Windows NT supports two kinds of challenge/response authentication: LanManager (LM) and Windows NT (NTLM). LM authentication is not as strong as Windows NT authentication so some customers may want to disable its use, because an attacker sniffing the network traffic could possibly attack the weaker protocol.

Disable TCP/IP Source Routing (Windows NT 4.0)
Normally, on a computer running Windows NT 4.0, you cannot disable the source routing feature for the TCP/IP protocol. By using this tweak it is possible to disable it.

Hide the Active Directory Folder in My Network Places (Windows 2000)
This restriction is used to remove the Active Directory folder from My Network Places. This still allows users to search but not browse the Active Directory.

Hide Computer from the Browser List (Windows NT/2000/XP)
If you have a secure server or workstation you wish to hide from the general browser list, then enable this setting.

Hide Entire Network in Network Neighborhood (All Windows)
Entire Network is an option under Network Neighborhood that allows users to see all the Workgroups and Domains on the network. Entire Network can be disabled, so users are confined to their own Workgroup or Domain.

Hide Workgroup Content from Network Neighborhood (All Windows)
Enabling this option hides all Workgroup contents from being displayed in Network Neighborhood.

Remove the Map and Disconnect Network Drive Options (Windows NT/2000/XP)
Prevents users from making additional network connections by removing the Map Network Drive and Disconnect Network Drive buttons from the toolbar in Explorer and also removing them from the Context menu of My Computer and the Tools menu of Explorer.

Disable Caching of Domain Password (Windows 95/98/Me)
Enabling this setting disables the caching of the domain passwords, and therefore passwords are required to be re-entered to access any additional domain resources.

Hide Share Passwords with Asterisks (All Windows)
This setting controls whether the password typed when accessing a file share is shown in clear text or as asterisks.

Hide Computers Near Me in Network Places (Windows 2000/Me/XP)
This setting allows you to show or hide the computers listed Near Me in My Network Places.

Disable the Ability to Remotely Shutdown the Computer Browser Service (Windows NT/2000/XP)
It is possible for a malicious user to shut down a computer browser, or all computer browsers, on the same subnet. If all of the computers on the same subnet are shut down, they can then declare their own computer the new master browser.

Automatic Hidden Shares (Windows NT/2000/XP)
When networking has been installed on a Windows machine, it will automatically create hidden shares to the local disk drives. It is possible to disable the sharing at run-time, but this tweak will stop the automatic sharing altogether.

Require Validation by Network for Windows Access (Windows 95/98/Me)
By default Windows 9x doesn't require a valid network username and password combination for a user to bypass the logon and gain access to the local machine. This functionality can be changed to require validation by the network before allowing access.

Changing the Password Expiry Warning Period (Windows NT/2000/XP)
This entry specifies the number of days before a user's password expires that a warning message is displayed.

Disable the Automatic Creation of a Default Network Route (Windows NT)
This tweak controls the default behavior of Windows to add a network route to 0.0.0.0 on multi-homed machines (e.g. proxy or firewall).


Registry Guide : Security : Privacy

Home : Security : Privacy

Clear the Page File at System Shutdown (Windows NT/2000/XP) Popular
Windows does not normally clear or recreate the page file. On a heavily used system this can be both a security threat and performance drop. Enabling this setting will cause Windows to clear the page file whenever the system is shutdown.

Reset Microsoft Word Settings and Recent Files (All Windows)
This setting can be used to reset the Word parameters back to the default if you are experiencing problems. For example if you start Word and one of your toolbars or menu bars is missing, or if your personalized settings are not retained.

Disable Network Messenger Service (Windows NT/2000/XP)
The Messenger service is normally used to transmit net send and Alerter service messages between clients and servers. Recently it has been employed by marketers for sending unsolicited advertising popups (SPAM) over the Internet. This tweak allows you to disable this service.

Clear Download Accelerator History (All Windows)
Download Accelerator Plus (DAP) is a tool used to retrieve files from Internet servers. It stores a history of the files downloaded and URLs visited. To increase privacy and security this tweak allows you to clear the history.

Disable Recent Files in Media Player (All Windows)
This restriction will stop Windows Media Player from storing the names of the played media in the recent file list.

Clear the Recent Play List in Media Player (All Windows)
This tweak allows you to clear the recent files, URL history and radio stations in Windows Media Player.

Empty Temporary Internet Files on Exit (All Windows)
This setting controls whether Internet Explorer should delete all of the temporary Internet files stored during the session when the browser is closed.

Clear the Cached Run Commands (All Windows)
Do you have a lot of items in the run command history on Start Menu? This tweak will allow you to clear the most-recently-used (MRU) list.

Clear the Internet Explorer Typed Address History (All Windows) Popular
Internet Explorer caches any URLs that are typed into the address bar. This may become a privacy issue on a shared computer, or a nuisance if there is a particular URL you want to remove without clearing the whole history.

Disable User Tracking (Windows 2000/XP)
This setting stops Windows from recording user tracking information including which applications a user runs and which files and documents are being accessed.

Clear the Netmeeting Call History (All Windows)
This tweak allows you to clear the stored call history in the Netmeeting drop down list.


Registry Guide : Security : Remote Access

Home : Security : Remote Access

Configure Remote Access Client Account Lockout (Windows 2000/XP)
You can use the remote access account lockout feature to specify how many times a remote access authentication has to fail against a valid user account before the user is denied access. Use this tweak to set the number of failed logins before the account is locked-out and the time before the lockout is reset.

Specify the Callback Pause Period (Windows NT/2000/XP)
When callback is required or requested this setting defines how long to wait before initiating the callback connection.

Automatically Disconnect Remote Access Callers (Windows NT/2000/XP)
Specifies the amount of idle time in minutes to wait before disconnecting the remote access client.

Time Limit for Remote Access Authentication (Windows NT/2000/XP)
A time limit can be enforced on the period available to logon via remote access before the connection is terminated.

Number of Remote Access Authentication Attempts (Windows NT/2000/XP)
This setting controls the number of authentication retries before a remote access connection is terminated.

Disable Dial-In Access (Windows 95/98/Me)
It's possible for users to setup a modem on a Windows machine, and by using Dial-up Networking allow callers to connect to the internal network. Especially in a corporate environment this can cause a major security risk.

Automatically Use Dial-Up Networking to Logon (Windows NT/2000)
There is an option that is available on the logon dialog box and allows you to dial into your logon server for authentication of your user account, this can be enabled by default.

Disable the "Log on using dial-up connection" Check Box (Windows NT/2000)
During logon Windows allows users to optionally connect to a Windows domain using dial-up networking, this tweak can be used to disable that option.


Registry Guide : Security : Start Menu and Taskbar

Home : Security : Start Menu and Taskbar

Documents and Folders Documents and Folders
Security Settings for Documents and Folders

Disable Menu Bars and the Start Button (Windows 95/98/Me/2000/XP)
This tweak can be used to disable the menu bar in standard Windows applications and the Start Button.

Hide or Display Administrative Tools Menu (Windows 2000/XP)
As with Windows NT, Windows 2000 has an 'Administrative Tools' folder on the Start Menu. This folder contains powerful administration utilities and therefore can be hidden to avoid accidental use.

Remove the Windows Security on Start Menu (Windows Terminal Server)
This setting is used to hide the Windows NT Security menu item on the Start Menu of a terminal server session.

Remove the Ability to Right Click on the Start Button (All Windows)
Usually when a user right clicks on the start button they are able to select Open, Explore or Find. Use this tweak to remove these options and secure your desktop.

Hide Control Panel, Printer and Network Settings (All Windows) Popular
This restriction removes the Control Panel, Printers and Network Connection settings from the Start menu. If the Taskbar settings are also hidden it causes the Settings menu to be completely removed.

Hide the Taskbar Settings on the Start Menu (All Windows)
This restriction removes the Taskbar and Start Menu item from the Control Panel, and it also removes the Properties item from the Start menu context menu.

Remove Common Program Groups from Start Menu (All Windows)
Disables the display of common groups when the user selects Programs from the Start menu.

Remove My Network Places from the Start Menu (Windows XP)
This restriction hides the My Network Places button on the Windows XP simple Start menu.

Force Logoff on the Start Menu (Windows 2000/XP)
This setting forces the Logoff button to appear on the Start menu and prevents users from removing or hiding it.

Restrict the Start Menu Log Off Option (Windows 2000/Me/XP)
This restriction removes the ability for a user to enable the "Log Off..." option on the Start Menu.

Disable Drag-and-Drop on the Start Menu (Windows 98/Me/2000/XP)
This restriction prevents users from modifying the Start menu by dragging and dropping items.

Remove Run from the Start Menu (All Windows)
Removes the ability to launch commands or processes from the Start menu by removing the Run option.

Remove Search from the Start Menu (All Windows)
This restriction removes the Search feature from the Start Menu.

Remove the Help Option from the Start Menu (Windows 2000/Me/XP)
This restriction removes the Help option from the Start Menu.

Remove Tray Items from Taskbar (Windows XP)
This setting removes and restricts access to the tray icons normally found next to the clock on the taskbar.

Remove the Toolbars on the Taskbar (Windows XP)
This restriction is used to remove all the toolbars, including Quick Launch, from the taskbar. It also restricts the ability to re-enable them.

Lock the Taskbar (Windows XP)
This restriction is used to force the locking of the taskbar and restrict users from making any changes to its position.

Force the Use of the Classic Start Menu (Windows XP)
This restriction forces users to use the classic Windows start menu, instead of the new format introduced with Windows XP.

Hide the Taskbar Clock (Windows XP)
This setting allows you to remove the clock from the system tray on the taskbar.


Registry Guide : Security : Start Menu and Taskbar : Documents and Folders

Home : Security : Start Menu and Taskbar : Documents and Folders

Remove Favorites from the Start Menu (All Windows) Popular
This tweak allows you to remove the Favorites folder from the Start Menu.

Remove Recent Documents from the Start Menu (All Windows) Popular
This setting can be used to remove the recent Documents folder from the Start Menu.

Increase Cache for Customized Folders (Windows XP)
Windows XP normally remembers the customized settings of a maximum of 400 folders. This tweak allows you to increase the number of folders that can be individually customized.

Remove Network Connections from the Start Menu (Windows 2000/Me/XP)
This tweak allows you to hide the Network and Dial-up Connections option on the Start Menu.

Disable Recent Documents History (All Windows) Popular
Normally when you open or access a document or file it is added to the list of recent documents on the Start Menu. This tweak will stop files from being added to the list.

Remove My Documents from the Start Menu (Windows 2000/Me/XP)
This restriction removes My Documents which is shown under the Documents folder on the Start Menu.

Remove My Pictures from the Start Menu (Windows 2000/Me/XP)
This restriction removes My Pictures from the Documents folder on the Start Menu.

Remove My Music from the Start Menu (Windows 2000/Me/XP)
This restriction removes My Music from the Documents folder on the Start Menu.


Registry Guide : Security : System

Home : Security : System

Disable Storage of Credentials and .NET Passwords (Windows XP)
This setting controls the storage of authentication credentials and .NET passwords on the local system. By disabling this feature, passwords will not be stored.

Disable System Restore Tools and Settings (Windows XP)
System Restore allows users to revert Windows settings and configuration changes to an earlier point in time (called Restore Points). This tweak can be used to restrict user access to the System Restore tools and settings.

Configure Windows Software Update Services (Windows 2000/XP)
These settings allow you to configure Windows client machines to use custom Microsoft Software Update Services (SUS) located on an internal corporate network instead of the Windows Update Internet site.

Restrict Shortcut and WinHelp Commands (Windows NT/2000/XP)
This restriction can be used to specify which directories contain Help files that can use the Shortcut and WinHelp commands. By clearing this setting you can also completely disable the help commands on the system.

Secure Access to Removable Drives (Windows NT/2000/XP)
This setting determines whether the ability to access removable drives is available to other users.

Restrict the Language and Locale Region (Windows 2000/XP)
This restriction is used to set the language used in menus and dialog boxes in Windows and prevent users from changing it. When enabled the system disables the menus and dialog boxes in the Regional Options in Control Panel.

Disable Group Policy Objects (Windows 2000/XP)
This setting is used to disable the use of group policy objects on the local computer.

Change Default Administrator Ownership (Windows XP)
Windows XP may assign the ownership of some file system objects to the Administrator account, instead of the Administrators group. This behaviour may not be desirable where there are multiple administrative users.

Reboot Windows After a Crash (Windows NT/2000/XP)
This parameter controls whether Windows should automatically reboot after a system failure or if the blue crash screen should be displayed.

Configure Windows Script Signature Security (All Windows)
This setting is used to define whether trusted and untrusted scripts should be executed when using signature verification. By requiring a signature the system will only execute scripts from verified authors.

Secure Access to Floppy Drives (Windows NT/2000/XP)
This setting determines whether data in the floppy disk drive is accessible to other users.

Secure Access to CD-ROM Drives (Windows NT/2000/XP)
This setting determines whether data in the CD-ROM drive is accessible to other users.

Specify Executable Files to be Lauched by Winlogon (Windows NT/2000/XP)
This setting specifies a list of executable files to be run by Winlogon in the system context when Windows starts.

Secure Network Access to the Windows Registry (Windows NT/2000/XP)
Windows supports accessing a remote registry via the Registry Editor across a network. The default setting allows for users to connect and modify data within the remote registry.

Restrict Access to Base System Objects (Windows NT/2000/XP)
In Windows the core operating system libraries are kept in virtual memory and shared between the programs running on the system. This has exposed a vulnerability that could allow a user to gain administrative privileges on the computer the user is interactively logged onto.

Specify a Replacement GINA Authentication DLL (Windows NT/2000/XP)
Windows is shipped to load and execute the standard Microsoft GINA DLL (Graphical Identification and Authentication dynamic-link library) called MSGina.dll. You can specify a replacement GINA DLL using this setting.

Restart the Shell Automatically (Windows NT/2000/XP)
By default if the Windows user interface or one of its components fails, the interface is restarted automatically, the can be changed so that you must restart the interface by logging off and logging on again manually.

Prompt for Password on Resume (Windows XP)
This setting allows you to configure the computer to always lock and require a password after resuming from hibernate or suspend mode.

Restrict Access to the Event Logs (Windows NT/2000/XP)
The Windows event log contains records documenting application, security and system events taking place on the machine. As these logs can contain sensitive data this tweak allows you to restrict access to administrators and system accounts only.

Disable CD Burning (Windows XP)
This restriction is used to disable the use of the inbuilt CD recording functions of Windows.


Registry Guide : Software

Home : Software

Internet Explorer Internet Explorer
Enhancements for Internet Explorer

Media Player Media Player
Enhancements for Windows Media Player

Microsoft Office Microsoft Office
Enhancements for Office Applications

Netmeeting Netmeeting
Enhancements for Netmeeting Conferencing

Outlook Express Outlook Express
Enhancements for Outlook Express

pcAnywhere pcAnywhere
Enhancements for Symantec pcAnywhere

Windows CE Windows CE
Enhancements for Windows CE and Pocket PC

Windows Messenger Windows Messenger
Enhancements for Windows Messenger

Change the ICQ Email Tagline (All Windows)
Newer versions of ICQ come with a handy email client. Unfortunately they add "Download ICQ at ..." to the end of every outgoing message. You can remove or change this in the registry to whatever you like.

Change the Default Mail Client (All Windows)
The setting allows you to change which program is opened and used to send an e-mail messages when you click on a "mailto:" link in a web page.

Clear Download Accelerator History (All Windows)
Download Accelerator Plus (DAP) is a tool used to retrieve files from Internet servers. It stores a history of the files downloaded and URLs visited. To increase privacy and security this tweak allows you to clear the history.

Control Active Server Pages Browser Buffering (All Windows)
This setting controls whether Active Server Pages (ASP) buffers output to a browser. If this setting is enabled then all output is collected before any is sent to the browser. This fixes some problems with incomplete and random data being sent to a browser using Internet Information Server (IIS).

Configure Symantec Live Update to Use Passive FTP (All Windows)
Norton LiveUpdate 1.3 and higher defaults to using active FTP. This tweak allows you to configure it to use passive FTP instead.

Disable the Norton Utilities Splash Screen (All Windows)
This setting will disable the Norton Utilities splash screen from being shown whenever the applications are run.

Disable the Norton AntiVirus Splash Screen (All Windows)
This setting will stop the Norton AntiVirus Scanner startup logo from being shown.

Disable ICQ Auto Update (All Windows)
When ICQ 2000 starts it checks whether a new update is available, depending on your network connection this may increase the time it takes to load. This setting lets you disable that check function.

Change the Maximum Number of AOL Buddies (All Windows)
This tweak allows you to increase (or decrease) the maximum number of AOL buddies allowed from the default of 160 on AOL Instant Messenger.

Change the Default Name and Company Information (All Windows) Popular
When you install a new application, using MS Setup, a default Name and Company are shown, these values can be changed when the details have changed or are incorrect.

Disable the Splash Screen on Adaptec DirectCD
The setting allows you to disable the splash screen shown when launching Adaptec DirectCD.


Registry Guide : Software : Internet Explorer

Home : Software : Internet Explorer

Appearance Appearance
Internet Explorer Appearance Enhancements

Network and Connections Network and Connections
Internet Explorer Network Settings

Search Features Search Features
Internet Explorer Search Enhancements

Security Security
Internet Explorer Security Restrictions

Disable the Internet Explorer HTML Source Editor Check (All Windows)
Internet Explorer will normally attempt to detect the program originally used to create a HTML document and modify the "Edit" option to use the same program for future editing. This tweak can be used to enable or disable the checking.

Open Internet Explorer Shortcuts in a New Window (All Windows)
This setting controls whether Internet shortcuts are opened in an existing available Internet Explorer window or whether a new window should be spawned.

Hide Links Folder on Favorites Menu (All Windows)
Internet Explorer persistently creates a Links folder on the Favorites menu, this tweak allows you to remove it.

View Source Not Working in Internet Explorer (All Windows)
When you attempt to view the source HTML of a web page in Internet Explorer it may not be displayed for several reasons. This article describes some of the common causes of this problem.

Change the Download Location for ActiveX Files (All Windows)
This tweak allows you to change the default folder to which ActiveX files are installed when you download an ActiveX control. The default path of this folder is "Windows\Downloaded Program Files."

Open TIF Images with Internet Explorer (All Windows)
When you click a link to download a Tagged Information File Format (TIFF) image from a Web site, the Open button in the File Download dialog box may be disabled. This tweak allows you to open the file using Internet Explorer.

Show My Pictures Toolbar in Internet Explorer (All Windows)
When displaying an image in Internet Explorer a floating toolbar is shown that allows you to Save, Print, E-mail or Open the My Pictures folder. This setting allows you to hide the toolbar.

Manage Partial Address Feature in Internet Explorer (All Windows)
The Internet Explorer partial address feature, scans common domains for a match to a keyword entered in the Address bar. The feature is limited by default to searching only .COM, .NET, .ORG and .EDU domains. This tip allows you to add new domains and modify their priorities.

Change the Auto Complete Mode (All Windows) Popular
This setting controls whether the automatic text completion (AutoComplete) feature of Windows Explorer appends the suggested text to the words as you are typing as well as showing a drop-down list of available values.

Force Plain Text Format in Internet Explorer (All Windows)
Internet Explorer may not use the "Text/Plain" Content-Type header field to properly open a text file on a Web site. This setting forces IE to treat those files as text files.

Launch Browser Windows in a Separate Process (All Windows)
This setting specifies whether a new process is created for each instance of Internet Explorer that you start. This can prevent one instance of Explorer from affecting other instances if it stops responding.

Hide the Internet Explorer Icon (All Windows)
This option hides the Internet Explorer icon from the Windows desktop.

Remove Windows Messenger from Internet Explorer (All Windows)
This tweak can be used to remove the integration of Windows Messenger into Internet Explorer. It will remove both the toolbar icon and Tools menu item.

Control the Internet Explorer Script Debugger (All Windows)
When an Internet Explorer detects an error on a page it has the ability to launch a script debugger to diagnose the problem. This setting controls the use of the Internet Explorer script debugging functions.

Use an Alternate Source Viewer with Internet Explorer (All Windows)
By default when you use the View Source feature of Internet Explorer it launches Windows notepad as the text editor. This tweak lets you choose which editor to use.

Check for Internet Explorer Updates (All Windows)
Internet Explorer 5 and higher has the ability to automatically check for software updates. This tweak controls that feature.

Internet Explorer Intercepts the FTP Command (All Windows)
When you enter a FTP command such as "FTP ftp.microsoft.com" Internet Explorer may launch instead of the DOS based FTP program.

Specify the Default Internet Explorer Download Directory (All Windows)
This setting is used to specify which directory should be used as the default location to save downloaded files retrieved using Internet Explorer.

Disable Internet Explorer Download Notification (All Windows)
This setting is used to disable download completion notification in Internet Explorer.

Specify the Location of the Online Support Site (All Windows)
When a user selects "Online Support" from the Internet Explorer help menu they are usually redirected to a Microsoft web page. This tweak allows you to specify an alternate URL and web site.

Change the Internet Explorer Navigation Sound
When you start navigating a web site with Internet Explorer it plays a WAV file, by default a click sound. This setting lets you change or remove that sound.

Add a Menu Option to Open Shortcuts in a New Window (All Windows)
This tweak adds a right-click menu option to enable you to open Internet shortcuts in a new Explorer window.

Control Internet Explorer Error Reporting (All Windows)
This setting allows you to control whether the error reporting tool, which reports browser debugging errors to Microsoft, is active in Internet Explorer 6.0.


Registry Guide : Software : Internet Explorer : Appearance

Home : Software : Internet Explorer : Appearance

Change the Internet Explorer & Outlook Express Toolbar Logo (All Windows) Popular
When you browse the Internet using Internet Explorer or read messages using Outlook Express, a logo is displayed indicating whether activity is taking place. With this tweak you can modify which logo is shown, customize it or reset it to the default.

Change Windows Update Text in Internet Explorer (All Windows)
This tweak allows you to rename or remove the "Windows Update" menu item by entering a custom text value.

Show "Shortcut to" Label on Internet Explorer Links (All Windows)
By default when you hover the mouse over a link in Internet Explorer it will display "Shortcut to filename.htm" in the status bar. This tweak controls that behaviour so that the full URL can be shown instead.

Lock the Internet Explorer Toolbars (All Windows)
This setting allows you to lock the Internet Explorer toolbars in place so they can not be moved by clicking-and-dragging.

Display a Background Bitmap on Explorer Toolbars (All Windows) Popular
This tweak allows you to choose a a bitmap image to display as the background for the explorer toolbars.

Add a Background Bitmap to the Internet Explorer Toolbar (All Windows)
Want to have you own bitmap shown on the Internet Explorer toolbar? It's simple with this registry setting.

Sort Start Menu and Favorites in Alphabetical Order (All Windows)
This tweak allows you to alphabetically sort the Start Menu and Favorites Menu.

Disable the Internet Explorer Splash Screen (All Windows)
When this setting is enabled the splash screen will not be shown when Internet Explorer is started.

Use Personalized Favorites Menu (All Windows)
Internet Explorer has a feature that automatically hides site that are rarely visited from the Favorites menu. This setting allows you to enable or disable the personalized menu feature.

Remove Selected Internet Explorer Toolbar Buttons (All Windows)
These settings allow you to hide and disable specific buttons on the Internet Explorer toolbar.

Disable the Go Button in Internet Explorer (All Windows)
This setting is used to remove the "Go" button from the Internet Explorer toolbar.

Change the Internet Explorer Window Title (All Windows) Popular
This setting allows you to customize Internet Explorer by using your own window title. For example you could rename IE to 'My Browser' or anything else you like!

Show Friendly HTTP Error Messages (All Windows)
By default Internet Explorer will show a friendly version of any HTTP errors it receives, for example Error 404 Page Moved. This tweak controls that functionality allowing it to be enabled or disabled.

Disable Expanding Internet Explorer New Menu (All Windows)
Usually when you click on the New menu in Internet Explorer it is expanded to include options like New Window, Message, Post and Internet Call. Using this tweak will stop the menu expanding and therefore only display the "New Window" option.

Reset Internet Explorer Window Location (All Windows)
Sometimes Internet Explorer may have problems with the location of the explorer window, possibly placing the window off the screen or only allowing you to minimize or maximize the window. This tweak should reset Internet Explorer to the default position.

Automatically Resize Images in Internet Explorer (All Windows)
This setting controls whether Internet Explorer attempts to automatically resize an image to fit within the window.

Use Smooth Scrolling in Internet Explorer (All Windows)
This setting controls whether the smooth scrolling function is used in Internet Explorer to increase the readability while navigating a page.

Show Expanded Add to Favorites Dialog Box (All Windows)
This setting controls whether an expanded or smaller dialog box is shown when a site is added to the Internet Explorer favorites.


Registry Guide : Software : Internet Explorer : Network and Connections

Home : Software : Internet Explorer : Network and Connections

Disable Internet Access (All Windows)
By using this tweak you are able to restrict access to the Internet when using Internet Explorer and other Microsoft compatible products such as Office.

Disable Internet Explorer Automatic Proxy Caching (All Windows)
When you configure Internet Explorer to use automatic proxy configuration it caches the returned information. If a proxy server fails you may therefore get an error message even though others are available. With this setting you can disable caching to ensure the browser always checks for the latest proxy information.

Change the Default Keep-Alive Time-Out in Internet Explorer (All Windows)
When Internet Explorer establishes a persistent HTTP connection with a Web server it reuses the same TCP/IP socket until the connection is idle for one minute. This tweak allows you to change the time-out period which is useful if you experience connection problems.

Change the Number of Simultaneous HTTP Sessions (All Windows) Popular
Windows normally limits the number of simultaneous connections made to a single web server. This behavior can be seen in Internet Explorer when downloading multiple files from a web site and only a certain number will be active at any one time.

Connect to Unicode Addresses with Internet Explorer (All Windows)
This setting allows you to control whether Internet Explorer should be able to connect to sites that use multibyte characters in the URL. This is useful when connecting to some foreign language sites.

Proxy Server Configuration (All Windows)
This tweak allows you to configure the proxy server settings for all programs that use the standard Windows Internet API, including Internet Explorer.

Use System-Wide Proxy Settings (All Windows)
This setting allows you to change the scope of the Internet proxy configuration and specify whether all users should share system-wide or individual settings.

Change the Internet Explorer User Agent String (All Windows) Popular
Whenever a web browser is used to connect to a remote web server it includes a User Agent string that contains details about browser and operating system. This tweak allows you to add or remove additional information from this string.

Internet Explorer FTP Mode (All Windows)
Internet Explorer has the ability to display FTP sites as if they were local folders. This tweak controls which mode IE uses for FTP.


Registry Guide : Software : Internet Explorer : Search Features

Home : Software : Internet Explorer : Search Features

Disable the Custom Search Page in Internet Explorer (All Windows)
This setting allows you to disable the use of the custom search page in Internet Explorer.

Use Classic Search in Internet Explorer (Windows XP)
This tweak allows you to disable the new Search Assistant and use the traditional search interface in Internet Explorer.

Search from the Address Bar in Internet Explorer (All Windows)
Save time with this tweak that allows you to specify the search engine to query by typing a request directly into the Internet Explorer address bar.

Change the Search Assistant in Internet Explorer (All Windows)
This tweak allows you to specify an alternate search assistant page, such as Google, in Internet Explorer.

Change the Internet Explorer Search Engine (All Windows)
Normally when you type 'go keyword' in the Internet Explorer address bar IE will search the web using a Microsoft selected search engine. By modifying this key you can select which search engine to use.

Change the Default Internet Explorer Search Page (All Windows)
By default a Microsoft search page is shown when a user clicks on the "Search" toolbar button in Internet Explorer. This tweak allows you to specify an alternate search URL.


Registry Guide : Software : Internet Explorer : Security

Home : Software : Internet Explorer : Security

Disable Local Stylesheets in Internet Explorer (All Windows)
Internet Explorer includes an option to load a local stylesheet to set browser based preferences for web page styles. This feature can be exploited by unauthorized programs to implement unrequested popups and malicious tracking of user activity. This tweak allows you to disable local stylesheets.

Internet Explorer Toolbar Restrictions (All Windows)
These restrictions allow you to selectively control which toolbars are available in Internet Explorer, including the Address, Tool and Links bars.

Restrict Import and Export of Internet Explorer Settings (All Windows)
This restriction can be used to disable the import and export of Internet Explorer cookies and favorites. When users utilize the "Import and Export" wizard on the File menu they will be shown a message when clicking "Finish".

Disable Password Caching in Internet Explorer (All Windows)
When you attempt to view a password-protected site, you are normally prompted to type your username and password with an option to "Save this password in your password list". This tweak can be used to disable the ability for users to save passwords.

Internet Explorer Restrictions (All Windows) Popular
These settings and restrictions allow you to selectively control a range of features available in Microsoft Internet Explorer 5 and 6.

Restrict ActiveX Applets in Internet Explorer (All Windows)
This tweak allows you to stop specific ActiveX controls from running in Internet Explorer. When the "kill bit" is set the specified ActiveX control will never be called or shown by Internet Explorer.

Empty Temporary Internet Files on Exit (All Windows)
This setting controls whether Internet Explorer should delete all of the temporary Internet files stored during the session when the browser is closed.

Clear the Internet Explorer Typed Address History (All Windows) Popular
Internet Explorer caches any URLs that are typed into the address bar. This may become a privacy issue on a shared computer, or a nuisance if there is a particular URL you want to remove without clearing the whole history.

Disable Caching of Secure Web Pages (All Windows)
This setting controls whether web pages encrypted using Secure Sockets Layer (SSL) should be stored on the hard disk in the temporary Internet cache.

Use System-based Internet Restrictions (All Windows)
Internet restrictions are normally dynamically loaded for each user, therefore settings for one user do not affect the settings of another. This tweak forces Windows to use the local machine settings rather than those of the current user.

Content Advisor Restrictions (All Windows)
These settings allow you to control the Content Advisor feature of Internet Explorer. Including the option to disable Content Advisor, require a supervisor password and view unrated content.

Remove the Content Advisor and Ratings Password (All Windows) Popular
If you have forgotten the Internet Explorer content advisor password and want to change the ratings settings then follow these instructions to change the settings back to their defaults.

Disable Save As Web Page Complete (All Windows)
This restriction disables the ability to save complete web pages including images, scripts, linked files and other elements in Internet Explorer.

Disable the Ability to Customize Toolbars (All Windows)
By right clicking on a toolbar you are usually given the option to Customize, which allows you to change which functions are available from the toolbar. This tweak allows you to disable that function.

Remove the Option to Change or Hide Toolbars (All Windows)
By default users are able to select which toolbars are displayed either be right clicking the toolbar itself, or by changing the options from the View menu. This tweak locks the toolbars, removing the ability to change which are displayed.

Internet Explorer Help Menu Restrictions (All Windows)
The menu items with the Internet Explorer "Help" menu can be individually removed or the menu disabled completely using this tweak.

Disable File Download in Internet Explorer (All Windows)
This setting allows you to restrict the ability to download files using Internet Explorer.

Disable Access to File URLs in Internet Explorer (All Windows)
Normally you can use the Internet Explorer address bar to access standard files and folders. This setting disables that functionality and only allows access to Internet URLs.

Internet Explorer Control Panel Restrictions (Part 1) (All Windows) Popular
These tweaks allows you to control access to the Internet Explorer setup and control panel functions (found under Tools -> Internet Options).

Internet Explorer Control Panel Restrictions (Part 2) (All Windows) Popular
The features available within the Internet Explorer control panel (Tools -> Internet Options) can be individually managed and disabled using this tweak.

Restrict Web Sites from Installing Software (All Windows)
These restrictions allow you to block unwanted web sites from downloading software onto your system. This can be useful in disabling the installation of some common "cursor" programs.

Block Comet Cursor (All Windows)
These settings allow you to block the installation of the Comet Cursor program which is sometimes installed automatically as an ActiveX control.


Registry Guide : Software : Media Player

Home : Software : Media Player

Speed-up Access to AVI Media Files (Windows XP)
Windows XP can run slowly when attempting to access a folder that contains a large number of AVI (Audio Video Interleave) media files. This tweak speeds the process up by stopping Windows from extracting file information from AVIs.

Disable Auto Upgrade with Windows Media Player (All Windows)
When Windows Media Player is used it will periodically check for newer versions via the Internet. This tweak allows you to turn off this checking and notification.

Disable Recent Files in Media Player (All Windows)
This restriction will stop Windows Media Player from storing the names of the played media in the recent file list.

Clear the Recent Play List in Media Player (All Windows)
This tweak allows you to clear the recent files, URL history and radio stations in Windows Media Player.

Disable Processing of HTML Scripts in Media Files (All Windows)
This setting is an optional security configuration feature that you can use to turn off the processing of HTML scripts that are contained in Windows Media files.

Change the MP3 Encoding Rates in Media Player (All Windows)
These settings allow you to change the MP3 encoding rates in Windows Media Player. The default is 56Kbps which is quite low quality, this tweak allows you to add higher rates such as 128Kbps or 192Kbps.

Lock the Selected Media Player Skin (All Windows)
This restriction allows you to define and lock the Windows Media Player skin. In addition the user cannot switch the player to full mode or use any features that are not available within the specified skin.

Hide Anchor Window in Media Player (All Windows)
This setting hides the anchor window which is normally shown when using Windows Media Player in compact or skin mode. It also restricts users from re-enabling the window.

Disable Codec Downloads in Media Player (All Windows)
This restriction prevents audio and video codecs from being downloaded in Windows Media Player. When enabled it also restricts the ability to re-enable downloads.

Enable DVD Features in Media Player (All Windows) Popular
This setting allows you to use Microsoft Media Player to Play and Open DVDs.

Disable Media Player Upgrade Message (All Windows)
This setting allows you to disable the automatic Media Player upgrade message that appears when a new version of the player has been released.

Remove Items from Media Player (All Windows)
This tweak allows you to remove the Radio Bar, Media Favorites and Finding New Station from Windows Media Player.

Change the Title of Windows Media Player (All Windows)
This tweak allows you to customize the title bar text shown on Windows Media Player.

Send User Identifier in Media Player (All Windows)
This setting controls whether Windows Media Player will send a globally unique identifier (GUID) when communicating with a remote media source.


Registry Guide : Software : Microsoft Office

Home : Software : Microsoft Office

Outlook Outlook
Tweaks and settings for Microsoft Outlook
Word Word
Tweaks and settings for Microsoft Word

Change the Number of Undo Levels in Access (All Windows)
This setting allows you to modify the maximum number of commands and operations that can be reversed using the Undo function in Microsoft Access 2002.

Change the Registered Owner in Microsoft Office (All Windows)
With previous versions of Microsoft Office it was necessary to re-install Office to change the registered company as shown on the splash screen and in the About dialog box. With Office 2000 and XP it can be changed in the registry.

Add Custom Places to the Office Dialog Box (All Windows)
This tweak can be used to add your own custom Places to the Office 2000 and Office XP "Open" and "Save As" dialog boxes.

Configure Office to Use the Standard System Font (All Windows)
This setting allows you to configure Microsoft Office to use the standard system font for the user interface instead of the default Office font.

Optimize Find Fast Index Updates (All Windows)
Microsoft Office includes a Find Fast Indexer to increase file searching speed. On large drives performance may be impacted when creating or updating an index. This setting is used to delay indexing for a specified amount of time between index updates and therefore minimize system activity and increase performance.

Block Linked Images in Office XP Documents (All Windows)
As an added security measure you can configure Office XP to block linked Hypertext Transfer Protocol (HTTP) images that are placed in documents. This is useful to avoid to ability for documents to be tracked using hidden images.

Hide the Office Clipboard Toolbar (All Windows)
When you copy multiple items in any of the Microsoft Office programs, the Office Clipboard appears, allowing you to collect and paste multiple items stored in the toolbar. This tweak allows you to prevent the toolbar from automatically appearing.

Customize Microsoft Access Identification (All Windows)
These settings allow you to change the title, icon, startup screen and help file of Microsoft Access. This is particularly useful if distributing an application and you want to modify Access to look like your product.

Disable Password Caching in Office 2000 (All Windows)
Office 2000 normally attempts to cache user authentication information when establishing connections with external data sources. Because the password is saved into a text file, this creates a potential security problem.

Disable Document Editing Time Tracking (All Windows)
Whenever you open a Office document the time open is tracked and added to the total "Edit Time". This tweak disables that tracking.

Disable Office 2000 Tune Up (All Windows)
This setting is used to disable the automatic Office 2000 tune up feature.

Remove Items from Office Places Bar (All Windows)
This tweak is used to remove items from the Places Bar in the Office 2000/XP Open and Save As dialog boxes.

Enable Four Digit Year in Microsoft Excel 2000 (All Windows)
When Excel formats a date, it uses one of several default formats, the most common is the system short date (yy). Therefore when a user types a 4-digit year (yyyy) date in Excel, it may be displayed in a 2-digit year (yy) format. This tweak changes to default the 4-digit format.

Disable the Office Assistants (All Windows)
Are you annoyed by those office assistants always popping-up when you least expect it? This tweak will let you remove them for good!

Use Personalized Menus in Microsoft Office 2000 (All Windows)
Microsoft Office 2000 introduced personalized menus (or adaptive menus) that remembers which items you use regularly and hides items you don't. This tweak allows you to enable or control this functionality.

Control the Office Assistants (All Windows)
These settings control the features and behavior of the Assistants in Office 97, 2000 and XP.

Change the Number of Undo Levels in Microsoft Excel (All Windows)
This tweak lets you modify the amount of undo history information that Excel will track. Increasing this value allows you to undo more than the default number of changes.

Hide the Office XP Toolbar Help (All Windows)
These settings can be used to hide the toolbar help feature in Office XP applications. Shown in the top right corner it normally allows users to "Type a question for help".

Control Error Reporting with Office XP (All Windows)
Office XP includes a feature which will send debug information to Microsoft if an error occurs in one of the Office XP applications. This can be disabled using this tweak.


Registry Guide : Software : Microsoft Office : Outlook

Home : Software : Microsoft Office : Outlook

Disable Secure E-mail Certificate Checking (All Windows)
When you send a secure message in Outlook 2002 or Outlook 2000, you may need to use a certificate that does not match your e-mail address. This tweak allows you to turn off e-mail matching for certificates.

Disable Password Caching for Outlook Internet Mail (All Windows)
As a security precaution, you may want to disable the password caching ability for all Internet mail protocols (IMAP, POP and Hotmail) in Outlook 2002. This setting will cause Outlook to request a password on each attempt to retrieve new mail.

Disable Windows Messenger in Outlook (All Windows)
This setting can be used to disable the integration of Windows (MSN) Messenger so that is does not start when using Microsoft Outlook.

Manage Attachment Security in Outlook (All Windows)
New security measures that improve the dialog box warnings for attachments were included in Microsoft Outlook beginning with Outlook 2000 (SR-1). The file extensions that trigger the more secure warnings can be managed through the registry.

Remove Deleted Information from Outlook (All Windows)
Even though an item may have been deleted in Outlook some remnants of it could still remain accessible in the raw data files. This setting causes Outlook 2000 and 2002 (XP) to completely remove all deleted data when it is shut down.

Set the Temporary Attachment Directory for Outlook (All Windows)
When you open an attachment in an Outlook the temporary attachment file is created in a known folder, this may present a possible security problem. This tweak allows you to change the temporary directory used for storing attachments.

Disable Outlook Today Page (All Windows)
This restriction is used to disable the "Outlook Today" page in Microsoft Outlook 2002. When this setting is applied the option to view Outlook Today will be removed.

Control Security Settings Feature in Outlook 98 (All Windows)
The Outlook 98 service packs introduced a security feature that disabled the ability to directly open executable (EXE) file. This tweak allows you to disable that functionality.

Read Messages as Plain Text in Outlook 2002 (All Windows)
This restriction is used to specify that all non-digitally-signed messages should be read as plain text. This is useful in avoiding a large number of security vulnerabilities caused by HTML viruses.

Disable Secondary Credentials Dialog Box in Outlook (All Windows)
This setting allows you to disable the secondary credentials dialog box that is displayed when you start Outlook 2002 and log on to a Microsoft Exchange Server computer that is in a different domain than the client.

Modify the Outlook Today Location (All Windows)
This setting allows you to specify an alternate URL to show instead of the default Outlook Today page in Microsoft Outlook 2000 and 2002.

Modify the Outlook 2002 and Office XP Attachment Restrictions (All Windows)
Microsoft Outlook 2002, included with Office XP, introduced new restrictions to stop possible unsafe e-mail attachments from being opened or saved. This tweak allows you to override those restrictions.

Minimize Outlook to System Tray
Like most applications Outlook 2002 (from Office XP) will normally minimize to the taskbar. This setting changes the default behaviour so that it will minimize to the system tray (next to the clock) instead.

Enable Internet Mail Logging in Outlook 2000 (All Windows)
To help diagnose POP3, SMTP and Internet mail problems, Microsoft included a logging option for Outlook 2000. This feature can be enabled through the registry.


Registry Guide : Software : Netmeeting

Home : Software : Netmeeting

Configure Netmeeting to Use a Gateway (All Windows)
These settings allow you to configure Netmeeting to use a H.323 gateway to place calls to a standard telephone over the PSTN.

Clear the Netmeeting Call History (All Windows)
This tweak allows you to clear the stored call history in the Netmeeting drop down list.

Change the Default Gatekeeper Discovery TTL (All Windows)
This setting controls the default Time-to-Live (TTL) for the gatekeeper multicast discovery packets in Microsoft Netmeeting.

Netmeeting Logging (All Windows)
This setting enables the debug logging functions in Microsoft Netmeeting. This may be useful to diagnose faults or connection issues.

Windows Netmeeting Policies and Restrictions (All Windows)
These restrictions and policies can be used to disable or restrict access to certain features of Windows Netmeeting.

Configuring Netmeeting to Use a Gatekeeper (All Windows)
These settings allow you to configure Netmeeting to use a H.323 gatekeeper to manage call addressing, billing and security.

Specify the User Parameters for Netmeeting (All Windows)
These values allow you to specify the user parameters, such as name, e-mail and account, for use in Netmeeting.

Enable the GSM Audio Codec in Netmeeting 2.1
By default Netmeeting does not include the GSM audio codec, this tweak enables the GSM codec to enhance interoperability with other GSM capable applications.


Registry Guide : Software : Outlook Express

Home : Software : Outlook Express

Remove Windows Messenger from Outlook Express (All Windows) Popular
This tweak is used to remove MSN Instant Messenger functionality and integration from Outlook Express.

Block Executable Attachments in Outlook Express (All Windows)
Outlook Express normally allows you to view and save all e-mail attachments. This tweak blocks executable files that potentially contain harmful viruses.

Change the Internet Explorer & Outlook Express Toolbar Logo (All Windows) Popular
When you browse the Internet using Internet Explorer or read messages using Outlook Express, a logo is displayed indicating whether activity is taking place. With this tweak you can modify which logo is shown, customize it or reset it to the default.

Backup Outlook Express Blocked Senders and Mail Rules (All Windows)
This article describes how to backup and restore your Blocked Senders list and other mail rules in Outlook Express 5 and later.

Change the Windows Address Book Location (All Windows)
This setting is used to specify the location of the Windows Address Book (WAB). The Windows Address Book is used by Outlook Express and Internet Mail and News to store contact details.

Disable the Outlook Express Splash Screen (All Windows) Popular
Sick of seeing the Outlook Express splash screen every time you open the program? This settings will allow you to remove it.

Change the Location of the Outlook Express Mail and News Files (All Windows)
This setting allows you to change the location of the mail and news files stored by Outlook Express to another directory or partition.

Disable Account Changes in Outlook Express (All Windows)
This setting disables the ability for users to create or modify any mail, news or directory accounts in Outlook Express.

Use Smooth Scrolling in Outlook Express (All Windows)
This setting controls whether smooth scrolling is used when viewing messages in Microsoft Outlook Express 5.0 and 6.0.

Change the Start Page for Outlook Express (All Windows)
This setting can be used to change the page that Outlook Express loads in the right-hand window when it first starts-up.

Control the Ability to Use HTTP Mail in Outlook Express (All Windows)
This tweak is used to specify whether HTTP mail servers, such as Hotmail, can be used or created in Outlook Express.

Outlook Express and IMAP Settings (All Windows)
This tweak allows you to correctly setup Outlook Express to use folders on the IMAP server for Drafts and Sent Mail instead of duplicating them with local folders.

Change the Outlook Express Window Title (All Windows)
This setting allows you to customize Outlook Express by using your own window title. For example you could rename Outlook Express to 'My Mail Reader' or anything else you like!

Colorful Message Backgrounds in Outlook Express (All Windows)
When enabled this setting allows the use of colorful message backgrounds in Outlook Express 4.0 or below.


Registry Guide : Software : pcAnywhere

Home : Software : pcAnywhere

Display Host in List (pcAnywhere) (All Windows)
The registry entry allows the host to respond to remote requests for names. Thus, by disabling the registry item, you can hide the host from users scanning the network.

Add an Additional Delay to Browse Packets (pcAnywhere) (All Windows)
Use this setting when remotes display an incomplete list of TCP/IP hosts in the host list over a WAN or LAN connection.

Connect to TCP/IP Hosts With Unknown Status (pcAnywhere) (All Windows)
This registry entry allows a remote to try to connect to a host if the host's status is unknown. The usual reason for not knowing the host's status is that direct packets have been filtered by a firewall between the host and the remote.

Configure the TCP/IP Data Port (pcAnywhere) (All Windows)
Use this setting to select which TCP data port pcANYWHERE32 uses.

Configure the TCP/IP Status Port (pcAnywhere) (All Windows)
Use this setting to select which TCP status port pcAnywhere uses.

Port Compatibility with Legacy Versions (pcAnywhere) (All Windows)
pcANYWHERE32 8.0 hosts and remotes can connect to earlier hosts and remotes without any registry changes. You may want to turn off compatibility to limit network traffic or allow third party applications that have registered the ports that earlier versions of pcANYWHERE32 7.x and pcAnywhere 2.0 were using.

TCP/IP Broadcast Mode (pcAnywhere) (All Windows)
Use this setting to turn off or modify pcANYWHERE32's broadcast options to limit network traffic when the remote browses for a host.

TCP/IP Query Interval (pcAnywhere) (All Windows)
Use this setting to limit network traffic. Sometimes the additional network queries to refresh the browse list will interfere with getting status lights or making connections.

Configure the Winsock Buffer Size (pcAnywhere) (All Windows) Popular
Use this registry item to set the size in bytes of TCP's Winsock buffer. Using a large value may increase the throughput of connections where the delay is large in relation to the bandwidth. This includes Internet, ISDN, RAS, dial-up networking, WAN and satellite connections.

Compatibility with the OnNet 2.1 TCP/IP Stack (pcAnywhere) (All Windows)
This registry item resolves an issue where pcAnywhere displayed the wrong host IP address when using FTP's OnNet 2.1 TCP/IP stack.

Prompt for TCP/IP Host (pcAnywhere) (All Windows)
This registry item allows a TCP/IP remote to specify an IP address or name when you leave the "Host To Connect To" field blank.

Adapter Binding Mode (pcAnywhere) (All Windows)
This registry item allows a waiting host to bind to a new adapter, such as a dial-up adapter, without reinitializing the host.

TCP/IP Host Binding Mode (pcAnywhere) (All Windows)
This registry item allows you to specify whether the host will wait on the first TCP/IP address given by the operating system, or whether it will wait on the TCP/IP index as indicated by TCPIPHostAddressIndex.

Specify Host Mode TCP/IP Address (pcAnywhere) (All Windows)
This registry item allows you to specify which TCP/IP address index the host will wait on.

Multicast Packet Delay (pcAnywhere) (All Windows)
This sets the delay in milliseconds between each send. This is useful if multicast error correction is disabled.

Configure the Multicast Data Port (pcAnywhere) (All Windows)
This setting selects the port that the multicast data is sent to.

Multicast Error Correction (pcAnywhere) (All Windows)
This sets the level of error correction used on the host. The host specifies which level of error correction the remotes will use.

Multicast Adapter Selection (pcAnywhere) (All Windows)
Use this registry item for a multihomed, multicast host that is not binding to the correct network card. This can be why none of the remotes receive the multicast packets.

Configure Multicast Send and Receive Buffers (pcAnywhere) (All Windows)
These registry items set the number of receive and send buffers when using an error correction multicast session. For slow remotes, a larger value may lead to less data loss.

Multicast Maximum Transmission Unit (pcAnywhere) (All Windows)
This registry item sets the Maximum Transmission Unit (MTU) in bytes. The MTU is the maximum bytes that may be sent as one IP multicast packet.

Multicast Winsock Receive Buffer (pcAnywhere) (All Windows)
This registry item sets the size in bytes of the Winsock receive buffer.

Ignore DSR on Serial Devices (pcAnywhere) (All Windows)
Use this item for modems or other serial devices that do not initialize correctly because their DSR is not initially set. It is also useful if the modem connection does not have a DSR line.

Change Serial 56K Connection Speed (pcAnywhere) (All Windows)
Use this item when a serial connection can be made at 38,400 bps and 115,000 bps, but not at 57,600 bps.

TAPI Modem Errors (pcAnywhere) (All Windows)
Each time you add a TAPI modem, it generates a unique TAPI Permanent Line ID which is stored in pcANYWHERE32's connection items. If you no longer have a modem with this unique ID, pcANYWHERE32 displays an error message. This registry key tells pcANYWHERE32 how to handle this situation.

Configure IPX Search Mode (pcAnywhere) (All Windows)
This registry item enables the SAP method of network search instead of using the bindery when making IPX connections.

Hide the Record Session Button (pcAnywhere) (All Windows)
Use this registry key to hide the Record Session icon from the remote session toolbar.

Remote Printer Inactivity Time-out (pcAnywhere) (All Windows)
Use this setting if a print job is being separated into multiple jobs during remote printing. This item sets the inactivity time-out for the remote printing facility.

Configure Legacy Remote Print Mode (pcAnywhere) (All Windows)
This setting specifies the default print destination when connecting to a pcAnywhere 2.0 or 5.0 host.

Show Full Screen Reminder Message (pcAnywhere) (All Windows)
This setting turns the Full Screen Reminder Message on or off.

Host Connection Time-Out (pcAnywhere) (All Windows)
If pcAnywhere host does not respond, hang up. This is useful for scripts that call systems where a modem will answer, but the pcAnywhere host may not be running.

Run Smart Setup (pcAnywhere) (All Windows)
This setting controls whether SmartSetup is run when pcAnywhere is loaded for the first time.

Run the pcAnywhere Service in Stealth Mode (pcAnywhere) (All Windows)
Use this setting to hide the Host Waiting icon and Waiting dialog.

Use Computer Name Instead of Caller Name (pcAnywhere) (All Windows)
When this key is set, if a host has the "Prompt to confirm connection" option checked, the host computer's prompt dialog will display the remote's computer name instead of the caller's name when a connection is made.

Wait for Call After Disconnect (pcAnywhere) (All Windows)
If enabled, the host will not wait for a call when the remote disconnects.

Configure Persistent Cache (pcAnywhere) (All Windows)
This setting turns pcAnywhere's persistent cache feature on or off.

Multi-Processor Options (pcAnywhere) (All Windows)
This registry item specifies which processors pcANYWHERE32 8.0 will run on.

Prompt If Logged Out (pcAnywhere) (All Windows)
This registry key allows you to specify how pcANYWHERE32 will handle a remote connection when the pcANYWHERE32 host is waiting at the Windows NT login screen and the "Prompt On Connection" and "Disconnect On Timeout" options have been checked.

Speed Send File Size Limits (pcAnywhere) (All Windows)
The minimum size a file must be for SpeedSend to work is 10K. You can change this value.

Confirm File Send (pcAnywhere) (All Windows)
When this setting is disabled, the remote does not display the confirm prompt when sending a file.

Confirm File Delete (pcAnywhere) (All Windows)
When this setting is disabled, the remote does not display the confirm prompt when deleting a file.


Registry Guide : Software : Windows CE

Home : Software : Windows CE

Remove the Menu Sliding Animation (Pocket PC 2002)
This tweak will remove the animated sliding menu effect found on the Pocket PC.

Change Internet Explorer to Appear as a Different Version (Pocket PC)
These settings allows you to change the way Pocket Internet Explorer appears to remote web sites. As some web site base the availability of SSL and other display parameters on this version information.

Control Windows Animation on Handheld Devices (Pocket PC)
The animation feature can make animated Windows look good, but it can also substantially slow down your handheld device. This setting allows you to control whether the function is enabled or disabled.

Modify the Graphic Cache Size (Pocket PC)
This setting controls the size of the glyph cache, by increasing this value you can increase graphics rendering speed by several times.

Automatically Hide the Taskbar (Pocket PC)
This setting controls whether the taskbar should be automatically hidden when not being accessed.

Control Script Errors on Pocket Internet Explorer (Pocket PC)
This setting allow you to control whether script errors generate a warning message on Pocket Internet Explorer.

Enable ClearType Technology (Pocket PC)
This setting controls the use of Clear Type text when rendering HTML documents with Pocket Internet Explorer.


Registry Guide : Software : Windows Messenger

Home : Software : Windows Messenger

Disable Background Notification Balloon in Messenger (All Windows)
This tweak can be used to disable the popup message that notifies the user that Windows (MSN) Messenger is still running in the background when you close it.

Remove Windows Messenger from Outlook Express (All Windows) Popular
This tweak is used to remove MSN Instant Messenger functionality and integration from Outlook Express.

Disable Windows Messenger in Outlook (All Windows)
This setting can be used to disable the integration of Windows (MSN) Messenger so that is does not start when using Microsoft Outlook.

Change the Messenger Warning Message (All Windows)
When you start a chat in Windows Messenger a warning is shown that says "Never give out your password or credit card number in an instant message conversation". This tweak allows you to customize this message for example to display your company chat policy.

Disable SSDP Discovery in Windows Messenger (Windows 2000/XP)
Windows Messenger uses the Simple Service Discovery Protocol (SSDP) to attempt to locate upstream Internet gateways on UDP port 1900. This tweak allows you to disable Universal Plug and Play Network Address Translation discovery to reduce bandwidth and increase security.

Disable MSN Instant Messenger (All Windows) Popular
This restriction is used to disable the ability to run the Microsoft MSN Instant Messenger client.

Remove Windows Messenger from Internet Explorer (All Windows)
This tweak can be used to remove the integration of Windows Messenger into Internet Explorer. It will remove both the toolbar icon and Tools menu item.

Change the MSN Messenger Background Image (All Windows)
This tweak allows you to change the background bitmap image in the MSN Messenger service.

MSN Instant Messenger Restrictions (All Windows)
These restrictions are used to disable various features of the Microsoft MSN Instant Messenger client.


Registry Guide : Tips and Tricks

Home : Tips and Tricks

Configuration Files Configuration Files
Tweaks Found in Other System Files

Customization Customization
Customization and System Modifications

Keyboard Shortcuts Keyboard Shortcuts
Windows Keyboard Shortcuts and Combinations

Hide Control Panel Applets (Windows 95/98/Me) Popular
This tweak allows you to show or hide any of the applets found in the Windows Control Panel.


Registry Guide : Tips and Tricks : Configuration Files

Home : Tips and Tricks : Configuration Files

AUTOEXEC.BAT
MS-DOS Startup Configuration File

BOOT.INI
Windows Bootup Configuration File

CONFIG.SYS
MS-DOS Startup Configuration File

MSDOS.SYS
Windows and DOS Configuration File

SYSTEM.INI
Windows Configuration File


Registry Guide : Tips and Tricks : Configuration Files : AUTOEXEC.BAT

Home : Tips and Tricks : Configuration Files : AUTOEXEC.BAT

Read Environment Variables in Autoexec.bat File (Windows NT/2000/XP)
When this value is enabled the variables declared in the Autoexec.bat file will be parsed and included in the current user environment.

Setting the Windows Temporary Directory (All Windows)
Depending on which version of Windows you run, temporary files are usually stored in C:\WINDOWS\TEMP. This tweak shows how to move the location of the temporary file directory.

Load Drivers and Programs into High Memory (Windows 3.1/DOS)
Programs and device drivers loaded from the AUTOEXEC.BAT file are normally loaded straight into low memory. This change allows them to be loaded high.

Remove Command Echoing (Windows 95/98/Me)
Normally when commands are read and executed from the AUTOEXEC.BAT file, there are echoed back to the screen. This setting turns the echo off, which means only message text will be shown, and not the originating command.


Registry Guide : Tips and Tricks : Configuration Files : BOOT.INI

Home : Tips and Tricks : Configuration Files : BOOT.INI

Using BOOT.INI Startup Switches (Windows NT/2000/XP)
Windows NT, 2000 and XP use a configuration file called BOOT.INI to control how the operating system is booted and any startup options. By modifying the startup switches you can manage the boot process including booting Windows in Safe mode, creating a log file, or disabling the splash screen.

Modify the Duration that the Startup List is Displayed (Windows NT/2000/XP) Popular
This setting allows you to change the default 30 second timeout for the Startup List which normally allows you time to choose and boot an alternative operating system.

Change the Default Operating System (Windows NT/2000/XP)
This setting in the BOOT.INI file controls which operating system the NT Boot Loader launches by default if none is selected.

Boot Windows NT with the Default VGA Video Driver (Windows NT)
This explains how to create an a safe VGA video mode start-up option, especially useful when your video adapter or driver is causing problems.

Boot Windows NT in Safe Mode (Windows NT)
Windows NT can be very temperamental sometimes are you add new software or install a new driver. The option allows you the create a Windows NT alternative to the Windows 9x Safe Mode. In this mode extra checks are performed and not all third party drivers are loaded.

Disable Detection of Devices on Serial Ports (Windows NT)
Windows NT attempts to probe the serial ports on boot-up to detect any serial mice. This can cause problems with other serial devices such as UPS's.

Enable the 4GT RAM Tuning Feature of NT Enterprise Edition (Windows NT)
With standard Windows NT Server, the per-process address limit is 2 gigabytes (GB) of random access memory (RAM). The 4GT feature of Windows NT Server/E increases this limit to 3 GB without introducing new APIs. 4GT does this by reducing the potential RAM allocated to the Windows NT kernel from 2 GB to 1 GB.


Registry Guide : Tips and Tricks : Configuration Files : CONFIG.SYS

Home : Tips and Tricks : Configuration Files : CONFIG.SYS

Load DOS Command Processor into High Memory (Windows 95/98/Me)
DOS is limited to 640kb low memory, as more device drivers are loaded that space is used up leaving less available memory for applications. This setting loads the DOS command processor into high memory, freeing some low memory for other applications.

Increase the Number Disk Buffers (Windows 3.1/DOS)
This setting can be used to increase the number of disk buffers available to DOS.

Load Device Drivers into Memory (Windows 3.1/DOS)
This setting is used to load specified device drivers into memory (or high memory).

Control the Number of File Control Blocks (FCBs) (Windows 3.1/DOS)
This setting specifies the number of file control blocks (FCBs) that the operating system can have open at the same time.

Controls the Number of Simultaneous Files (Windows 3.1/DOS)
This setting specifies the number of files that the operating system can access at one time.

Specify the Maximum Number of Drive Letters (Windows 3.1/DOS)
This setting control the maximum number of drivers accessible by a drive letter.

Control the Number of Data Stacks (Windows 3.1/DOS)
Support the dynamic use of data stacks to handle hardware interrupts.

Use Extended Memory (Windows 3.1/DOS)
Himem, an extended-memory manager, is a program that coordinates the use of your computer's extended memory, including the high memory area (HMA). It must be loaded before any application or device drivers can use extended memory.

Enable the Ability to Load Devices into Upper Memory (Windows 3.1/DOS)
Originally EMM386 was required to provide EMS memory, an alternate form of extended memory. Now with the sparse use of EMS, it's primary purpose is to provide support for loading real-mode device drivers in the upper memory area.


Registry Guide : Tips and Tricks : Configuration Files : MSDOS.SYS

Home : Tips and Tricks : Configuration Files : MSDOS.SYS

Force Computer to Boot in Safe Mode (Windows 95/98/Me)
This setting when enabled forces your computer to always boot in Safe Mode.

Control Whether the Windows Desktop is Loaded (Windows 95/98)
By default Windows automatically loads the Windows Desktop (or GUI) at startup. With this key you can control whether the GUI is loaded or if you just want the MS-DOS prompt.

Suppress Safe Mode Warning Message (Windows 95/98/Me)
Enabling this setting suppresses the safe mode warning message when booting up, and bypasses the Startup menu.

Allow Booting to the Previous Operating System (Windows 95/98/Me)
If you installed an upgrade version of Windows, you can normally press F4 to boot your previous version of Windows. This option can be disabled.

Change the Function Key Timeout (Windows 95/98/Me)
Windows normally enables the function keys during the boot sequence for 2 seconds, these keys allow you to control the boot process. The duration can be changed using this tweak.

Disable Function Keys During the Boot Sequence (Windows 95/98/Me)
By default Windows 9x enables the function keys on boot, these allow you to control the boot process. For example pressing F5 while the "Starting Windows 95..." message is displayed will boot Windows in Safe Mode.

Control Whether Scandisk is Run Automatically (Windows 95/98/Me)
When Windows is incorrectly shutdown, or the turn is power turned off, the system will attempt to run Scandisk on the next boot. This setting control whether automatic checking is disabled, prompts before running, or runs automatically.

Show the Windows Boot Menu (Windows 95/98/Me)
Windows does not display the boot menu normally unless a key is pressed during bootup (F8 for Windows 95 or CTRL for 98/Me). The boot menu allows you to selectively boot Windows in different modes, including Safe Mode and Command Prompt Mode.

Display the Windows Splash Screen While Loading (Windows 95/98/Me) Popular
When Windows is loading normally you see the Windows clouds splash screen, this can be disabled to show the background DOS boot process.

Modifying the [Paths] Section of MSDOS.SYS (Windows 95/98/Me)
The [Paths] section lists the locations for other Windows 95 files (such as the registry) and can be modified if files are moved.

Load Compression Driver into Low Memory (Windows 95/98/Me)
This setting controls whether double space (or drive space) is loaded into high memory. If you are having compatibility problems with software that makes assumptions about the available memory try changing this setting.


Registry Guide : Tips and Tricks : Configuration Files : SYSTEM.INI

Home : Tips and Tricks : Configuration Files : SYSTEM.INI

Increase Application Keyboard Response Time (Windows 95/98/Me)
When running more than one application at a time, you may find that your system's keyboard response is slower. To alleviate this, you can adjust the amount of time allocated to processing keystrokes.

Change the Number of Spare Stack Pages (Windows 95/98/Me)
Windows sets aside a number of extra memory pages (spare stack pages) to be used temporarily to prevent a system "crash" due to a stack overflow condition. Sometimes all the spare pages can be used, and an error message is shown, this tweak allows you to increase the number available.

Modify the Number of File Handles for DOS Programs (Windows Me)
This setting controls the number of file handles available to MS-DOS programs run in each virtual machine. In Windows Me, each MS-DOS VM is given the default value of 30 file handles.

Use High Memory for DOS Drivers (Windows 95/98/Me)
This setting causes Windows to load the local DOS devices into high memory and freeing up more low memory for DOS applications.

Use Crtl + Alt + Delete to Restart the Computer (Windows 3.1/95/98)
Normally when you press Ctrl + Alt + Delete the Windows task list is displayed. Using this tweak the key combination will instead reboot the computer.

End Tasks Without Restarting Windows (Windows 3.1/95/98)
This setting specifies whether you can press CTRL+ALT+DEL to quit applications that cause an unrecoverable errors in 386 enhanced mode, without restarting Windows.


Registry Guide : Tips and Tricks : Customization

Home : Tips and Tricks : Customization

Change the Start Button Text (All Windows) Popular
Would you like to change the Start button to say something else, perhaps your name, company or any other 5 or less letter word? This article explains the procedure to manually modify the text of the Windows Start button.

Show Computer Manufacturer and Support Information (All Windows) Popular
This tip lets you include company and support information on the System Properties page in Control Panel. This is especially useful if you run a computer store and want your customers to be reminded where they bought their PC and where to get technical support.

Change the Default Name and Company Information (All Windows) Popular
When you install a new application, using MS Setup, a default Name and Company are shown, these values can be changed when the details have changed or are incorrect.


Registry Guide : Tips and Tricks : Keyboard Shortcuts

Home : Tips and Tricks : Keyboard Shortcuts

Re-Initialize Your Registry Without Rebooting (All Windows) Popular
Some registry changes require you to restart Windows before they are enabled. This tip lets you re-initialize your registry and refresh your desktop without having to leave Windows.

Make the Columns Fit (All Windows) Popular
Want to quickly see all the column in explorer without having to resize them individually? This tip does it for you.

Close Parent Windows Automatically (All Windows)
Have you ever had a screen full of explorer windows on your desktop after digging through heaps of directories? This tip lets you close the current window and all it's parent windows in one easy step.

Expand and Contract Folders With Ease (All Windows)
It can be a time-consuming process to expand a folder by clicking on the (+) for each and every sub-directory. This tip lets you expand and contract them all at once, with one keystroke.

Change Directories Without Typing the Whole Name (Windows NT/2000)
Changing directories at the command prompt can be a hit and miss process when long filenames are involved. This tip let you change directories with ease, not matter how long the directory name.

Launch the Task Manager Quickly (Windows NT/2000/XP) Popular
Launching the Task Manager can sometimes be difficult depending on the situation. Some people didn't know that the Task Manager can actually be launched in at least three different ways to make it easier to use when you need it the most.


Registry Guide : Windows

Home : Windows

Accessories Accessories
Tweaks for Windows Accessories and components

Appearance Appearance
Windows Appearance and Display Settings

Desktop Desktop
Windows Desktop Enhancements

File System File System
File System and Storage Enhancements

Login and Authentication Login and Authentication
Login and Authentication Enhancements

Start Menu and Taskbar Start Menu and Taskbar
Start Menu and Taskbar Enhancements

Startup and Shutdown Startup and Shutdown
Enhancements for System Startup and Shutdown

System System
Windows System Parameters and Settings

Troubleshooting Troubleshooting
Tips and Tweaks to Fix System Problems

Windows Explorer Windows Explorer
Windows Explorer Enhancements and Settings

Change the Location of System and Special Folders (All Windows) Popular
Windows keeps a number of special folders such as "My Documents", "Desktop", "Favorites" and the "Start Menu". These folders can be moved anywhere on you system and the new location updated in this key.

Configure CoolSwitch Application Swapping (All Windows) Popular
CoolSwitch is a feature available within Windows to quickly switch between tasks and programs by using the Alt + TAB keys.

Use Windows Update Without Registration (Windows 98/Me/2000/XP) Popular
Windows Update is a useful feature but to ensure your privacy you may not want to register your personal details before being able to use it. With this tip you can bypass the registration process.

Change the Registered Owner and Organization (All Windows) Popular
If you entered the wrong registration information when you installed Windows you can change it and other miscellaneous settings such as ProductID and ProductName.

Change the Location of Windows Installation Files (All Windows) Popular
Modifying the string will change the path that the Windows setup program will look for the installation files.

Add Your Own Tips (All Windows) Popular
Are you sick of seeing the same tips again and again when you first logon to Windows? Now you can change them to whatever you want, whether it's quotes, jokes or a to-do list, anything is possible.

Creating Program Aliases in Windows (All Windows)
A hidden feature in the Windows registry allows you to create program aliases. Allowing you to create, for example, an alias called JBLOGGS.EXE that when executed actually runs another program, e.g. NOTEPAD.EXE


Registry Guide : Windows : Accessories

Home : Windows : Accessories

Command Processor Command Processor
Enhancements for the Command Processor

Dr Watson Dr Watson
Setting for the Dr Watson Diagnostic utility

Registry Editor Registry Editor
Settings for the Windows Registry Editor

Task Scheduler Task Scheduler
Settings and restrictions for Task Scheduler

Windows Installer Windows Installer
Settings to manage the Windows Installer

Configure Notepad to use Word Wrap (All Windows)
This setting controls whether text is wrapped onto the next line when the screen in full in Notepad. Although it can be configured by using the Edit menu in Notepad, this tweak allows you to change the word-wrap feature through the registry.

Allow Uninstall of Windows Components (Windows XP)
Windows includes a number of system components that are normally not available on the Add/Remove Windows Components list. This tweak allows you to display these items and therefore have the option to uninstall.

Enable the Scheduled Tasks Icon (Windows Me)
This tweak allows you to configure your computer so that the Scheduled Tasks icon is displayed on the taskbar in Windows Millennium Edition (Me).

Disable the Windows XP Tour (Windows XP)
After installing Windows XP you are prompted to run the Tour the first three times you log into the system. This tweak can be used to suppress the balloon prompts.

Save Changes to Notepad Configuration (All Windows)
The Notepad text editor included with Windows lets you configure the page setup including headers, footers and margins. These options are not normally saved between sessions but with this tweak Notepad can be made to save any changes.

Show Detailed Information in Device Manager (Windows 2000/XP)
If you require additional information about a device that is not typically displayed in Device Manager, you can use this tweak to make Device Manager show detailed device information.

Show All Hidden Devices in Device Manager (Windows 2000/XP)
Devices that are installed but are not currently connected to the computer (such as a Universal Serial Bus (USB) device or "ghosted" devices) are not normally displayed in Device Manager. This tweak causes all devices to be shown.

Disable Task Manager (Windows NT/2000/XP)
This setting controls the ability for users to start Task Manager and view processes, running applications and make changes to the priority or state of the individual processes.

Use Smooth Scrolling in Telnet (All Windows)
This tweak enables the smooth scrolling function in Windows Telnet.

Easily Use Notepad to Open a File (All Windows)
Enabling this setting will allow you to use Notepad to open a file by simply right clicking on the icon. Also the Notepad will be used to open the files by default if no association already exists.

Specify the Program to Play Inserted Audio CDs (All Windows)
This value is used to specify which program should be used to play an audio CD when it is inserted and the autostart feature is enabled.

Add the QuickView Option to All Files (All Windows)
If you ever wanted to add QuickView to the context menu of all file types, it may be a tedious task doing so using Windows Explorer's Options - File Type window. This tip shows how to do it in a couple of easy steps.


Registry Guide : Windows : Accessories : Command Processor

Home : Windows : Accessories : Command Processor

Disable the MS-DOS Command Prompt (Windows 95/98/Me)
This setting allows you to disable the use of the MS-DOS command prompt in Windows.

Enable Command Completion (Windows NT/2000/XP) Popular
Command completion allows you to type a portion of a file name, and then have the system complete the rest by pressing the specified key. This is similar to the UNIX shell command completion feature.

Change the Command Prompt (Windows NT/2000/XP)
This setting allows you to change the format of the command prompt to show additional information instead of just the current drive and path ("C:\>").

Allow UNC Paths at the Command Prompt (Windows NT/2000/XP)
The Command Processor normally checks and disallows UNC names from being used for the current directory in the Command Prompt as they may cause problems with launched child processes. This tweak can be used to allow UNC paths and remove the warning message.

Add Command Prompt Option to Every Folder (All Windows) Popular
If you still use the DOS prompt regularly then this setting creates a new right-click menu option to open a command prompt at the selected directory.

Change the Command Prompt Colors (Windows NT/2000/XP)
The value DefaultColor controls the foreground and background colors used in command prompt windows. It has a default value of 0, for standard white text on a black background.

Enable Directory Completion (Windows 2000/XP)
Directory completion allows you to specify a key, that when pressed, completes the remainder of a directory name, you can press the key multiple times to scroll through the choices.

Quick Edit the Command Prompt (Windows NT/2000/XP)
Quick Edit allows you to easily cut and paste text in the command prompt window using the mouse. The ability to use the Edit menu options is still possible.

Disable Command Prompt and Batch Files (Windows 2000/XP)
This restriction allows you to selectively disable the Command Prompt (CMD) and the ability to execute DOS batch files.

Disable Single Mode MS-DOS Applications (Windows 95/98/Me)
This setting allows you to disable the use of real mode DOS applications from within the Windows shell.

Run Startup Programs in a Command Prompt (Windows 2000/XP)
This setting allows you to specify commands or programs to be automatically executed whenever a command processor is launched. For example, to set environment variables or parameters using a batch file.

Modify the Number of File Handles for DOS Programs (Windows Me)
This setting controls the number of file handles available to MS-DOS programs run in each virtual machine. In Windows Me, each MS-DOS VM is given the default value of 30 file handles.

Use High Memory for DOS Drivers (Windows 95/98/Me)
This setting causes Windows to load the local DOS devices into high memory and freeing up more low memory for DOS applications.

Disable Command Processor Extensions (Windows 2000/XP)
This setting controls whether command extensions are enabled or disabled. When command extensions are used they change the behaviour of various standard command processor functions such as CD, MD, DEL, PROMPT and SET.

Enable Delayed Environment Variable Expansion (Windows 2000/XP)
This setting allows you to enable or disable delayed environment variable expansion in the command processor. If this feature is enabled then exclaimation characters can be used to substitute the value of an environment variable at execution time.


Registry Guide : Windows : Accessories : Dr Watson

Home : Windows : Accessories : Dr Watson

Specify the Dr Watson Log Directory (Windows NT/2000/XP)
This tweak is used to set the directory that stores the log files created by the Dr. Watson utility.

Changing the Behavior of the Dr Watson Utility (Windows NT/2000)
By default whenever an application error occurs in Windows NT, Dr Watson is launched and the debugger started automatically. The extra resources needed for the debugger can sometimes push the system over the edge. It is possible to stop the debugger from launching by changing this setting.

Specify the Number of Instructions to Record (Windows NT/2000/XP)
This tweak specifies the number of instructions for Dr. Watson to record during an application error.

Control Symbol Dumping in Dr Watson (Windows NT/2000/XP)
This tweak controls whether the Dr. Watson should dump the contents of the symbol tables during an application error.

Control Thread Dumping in Dr Watson (Windows NT/2000/XP)
This tweak controls whether the Dr. Watson utility should dump the contents of all threads during an application error.

Specify the Wave File for Sound Notification (Windows NT/2000/XP)
This tweak is used to specify the path and filename of the wave file to be played during an application error if sound notification has been enabled.

Control Whether Dr Watson Alerts Using Popups (Windows NT/2000/XP)
This tweak controls whether the Dr. Watson utility display a message box when it encounters an application error.

Control Whether Dr Watson Alerts Using Sound (Windows NT/2000/XP)
This tweak controls whether the Dr. Watson utility uses sound notification, i.e. a WAV file, to alert during an application error.

Specify the Location of the Dump File (Windows NT/2000/XP)
This tweak allows you to specify the path and filename to use when creating a crash dump file.

Control Whether Dr Watson Creates a Crash Dump (Windows NT/2000/XP)
This tweak controls whether the Dr. Watson utility creates a crash dump file after an application crash has occured.

Control the Log File Creation Method of Dr Watson (Windows NT/2000/XP)
This tweak controls whether the Dr. Watson utility creates a new log file or appends data to the old log file for each application error that occurs.

Specify an Alternate Debugging Utility (Windows NT/2000/XP)
By default Windows uses Dr Watson as the debugger when a system crash occurs. This setting allows you to specify an alternate utility such as Visual Studio or Norton CrashGuard.


Registry Guide : Windows : Accessories : Registry Editor

Home : Windows : Accessories : Registry Editor

Disable Registry Editing Tools (All Windows) Popular
This restriction disables the ability to interactively run the standard Microsoft registry editing tools such as REGEDIT and REGEDT32.

Specify Anonymous Remote Registry Access (Windows NT/2000/XP)
This tweak allows you to specify which keys under the HKEY_LOCAL_MACHINE hive that anonymous users are allowed to access remotely. This is useful because some services require remote access to the registry to function correctly.

Windows Registry Checker Settings (Windows 98/Me)
Windows 98 and Me include the Registry Checker tool which makes a daily backup copy of registry and other system files. These settings allow you to configure the behaviour of the Scanreg utility.

Prevent Regedit from Saving the Last Location (Windows 2000/XP)
By default, when you start Regedit.exe, it displays the last key you accessed the last time you ran Regedit. This tweak describes how to prevent this behavior.

Repair the Registry Editor (Windows 2000/Me/XP)
This tweak allows you to reset the location and parameters of the Registry Editor (REGEDIT) back to the system defaults. This is useful if Regedit is not being displayed correctly.

Avoid Accidental Registry Imports with Regedit (All Windows) Popular
By default if you double-click on a file with a '.REG' extension the file will be imported into the system registry. You can change the default so it opens the file for editing instead.


Registry Guide : Windows : Accessories : Task Scheduler

Home : Windows : Accessories : Task Scheduler

Receive Notification of Missed Tasks (All Windows)
By default when you are using Task Scheduler to automatically run programs you will not receive notification if a task is not run. This tweak can be used to cause Windows to show a pop-up message with the option to re-run any missed tasks.

Change the Scheduler Log File Settings (All Windows)
These settings specify where the Scheduling Agent (Task Scheduler) should write the log file and the maximum log file size (in KB).

Disable Task Scheduler (Windows 95/98/Me) Popular
Task Scheduler is automatically installed in some versions of Windows, and also when you install Internet Explorer. This tweak will remove it from your system.

Disable Drag and Drop Task Scheduling (Windows 2000/Me/XP)
This restriction disables the ability to drag and drop programs into the Scheduled Tasks folder. This also disables the functionality of the Cut, Copy and Paste shortcut items.

Disable Manual Task Control (Windows 2000/Me/XP)
This restriction disables the ability for users to manually start and stop scheduled tasks. Tasks will continue to run automatically as configured.

Remove Advanced Option from Task Scheduler Wizard (Windows 2000/Me/XP)
This setting removes the "Open advanced properties for this task when I click Finish" checkbox from the task creation wizard. This should be enabled to simplify the process for novice users.

Disable Changes to Task Properties (Windows 2000/Me/XP)
This setting restricts users from changing the properties of an existing item in Task Scheduler.

Disable Changes to Task Run Command (Windows 2000/Me/XP)
This setting restricts changes to the run command and disables the Browse button in the Task Scheduler properties.

Restrict Task Creation and Deletion (Windows 2000/Me/XP)
These settings allow you to restrict the creation and deletion of items in Task Scheduler.


Registry Guide : Windows : Accessories : Windows Installer

Home : Windows : Accessories : Windows Installer

Disable Windows Installer (All Windows)
This restriction allows you to prevent users from adding and removing software applications with Windows Installer.

Remote Administration of Windows Installer (Windows 2000/XP)
This setting allows administrators using Windows Terminal Services to remotely install and configure software using Windows Installer.

Windows Installer Logging (All Windows)
Windows Installer can use logging to help assist in troubleshooting issues with installing software packages. You can enable verbose logging with this setting.


Registry Guide : Windows : Appearance

Home : Windows : Appearance

Effects and Menus Effects and Menus
Effects and Menus Display Settings
Fonts and Icons Fonts and Icons
Icon and Font Display Settings

Change the Position of the Desktop Wallpaper (All Windows) Popular
Unfortunately Windows only gives you the limited options of center or tile for the placement of the desktop wallpaper. With this setting you can move the image anyway on your desktop.

Disable Image Preview (Windows XP)
When you open an image file in Windows XP the default action is to "Preview" it using the Windows Picture and Fax Viewer. This tweak can be used to disable the Preview image option.

Change the Thumbnail Image Settings (Windows XP)
These settings control the format of the saved thumbnail images, including the image size and quality.

Change the Color of Encrypted Files (Windows XP)
When a file or folder is encrypted it is normally shown using a different color in Explorer. This setting defines which color to use.

Change the Color of Compressed Files and Folders (Windows NT/2000/XP)
When a file is compressed in Windows there is an option in Explorer to display it in a different color to easily distinguish them. This setting defines what color to use, the default is blue.

Change the Color of Active File and Folder Links (All Windows)
This setting controls the link color of the active files and folders when using the web view (single-click) display method.

Show Compressed Files in an Alternate Color (Windows NT/2000/XP)
This setting controls whether compressed files and folders are shown in explorer using a different color to make them easily distinguishable.

DirectDraw and Direct3D Settings (Windows 98/Me/2000/XP)
These DirectX settings allow you to change some of the DirectDraw and Direct3D video acceleration parameters.

Open and Save Dialog Box Customization (Windows 2000/Me/XP)
These settings allow you to remove the places bar, most-recently-used (MRU) list and the back button from the common dialog boxes.

Control Whether Windows Performs Smooth Scrolling (All Windows) Popular
This setting allow you to disable the Windows smooth scrolling function, which on an low-powered system can cause performance degradation.


Registry Guide : Windows : Appearance : Fonts and Icons

Home : Windows : Appearance : Fonts and Icons

Change the Recycle Bin Icons (All Windows) Popular
Would you like to make you Recycle Bin into something a bit more exciting? Maybe a glowing toxic waste bin? With this tweak you can change the icon to be whatever you like.

Display High Color Icons (All Windows) Popular
If you like a bit more quality and detail in your icons, then this setting allows you to change the number of colors used to display icons. Show your Windows icons in all their high resolution glory.

Wrap Icon Titles (All Windows)
This setting controls whether the icon titles should be word wrapped over multiple lines or shown in one longer line.

Change the Vertical Icon Spacing (Windows NT/2000)
This setting specifies the number of pixels that appear vertically between icons. Windows determines the default based on the icon title font and the display you are using.

Automatically View Thumbnails of Bitmap Files (All Windows)
Makes Explorer show a thumbnail version of bitmaps files in the current folder rather than the generic icon ordinarily used. This is a great way to preview .BMP files without having to open them first.

Control the Font Smoothing Mode (Windows XP)
This setting controls what type of font smoothing is used. This allows you to select either Microsoft ClearType or the standard anti-aliased fonts.

Enable Font Smoothing (All Windows)
This setting controls whether fonts are anti-aliased to appear smoother when displayed within Windows.

Change the Size of Desktop Icons (All Windows)
Are your icons too small? Or too big? This setting will let you resize them to suit your desktop preference.


Registry Guide : Windows : Appearance : Effects and Menus

Home : Windows : Appearance : Effects and Menus

Display the Contents of Moving Windows (All Windows)
When enabled, this setting will cause Windows to display the current contents of a window while it is being dragged around the screen instead of just displaying the window outline.

Automatic Window Refresh (Windows 95/98/Me) Popular
Normally when the contents of a window change you may need to wait a few seconds, or press F5, to refresh the display to see the updated information. This tweak configures the system to perform faster automatic updates.

Change the Transition Effect for Menus and Tooltips (Windows XP)
This value controls which type of transitional effect to use when displaying Menus and Tooltips, allowing you to choose either the fade effect or the scroll effect.

Use Personalized Menus (Windows 2000/Me/XP)
Windows 2000 included a new feature called Personalized Menus, which remembers which items you use regularly and hides less used items. This tweak allows you to enable or disable this functionality.

Change the Menu Show Delay (All Windows) Popular
Windows normally delays menus before they are displayed. For regular users this delay can become annoying, with this setting you to change the delay time or remove it altogether.

Change the Alignment of Drop-Down Menus (All Windows)
By default, Windows drop-down menus are aligned to the left, with this tweak you can change the default behavior to align the menus to the right instead.

Remove the Minimize, Maximize and Close Tooltips (All Windows)
When you move your mouse over the three control boxes on a standard Window frame it will show tooltip text for each item. This tweak controls that function.

Control the Windows Animation Function (All Windows) Popular
Although the animation function can make animated Windows look good, it can also slow down your PC if you have a slower graphics card. This setting allows you to control whether the function is enabled or disabled.


Registry Guide : Windows : Desktop

Home : Windows : Desktop

Force Windows to Use the Classic Desktop (Windows 95/98/Me/NT/2000)
This tweak disables the various enhanced features of the Windows shell which are included in newer releases of Windows and Internet Explorer. It will remove features including Active Desktop, Web view, thumbnail views and the quick launch toolbar.

Disable Web Content in Explorer and Desktop (Windows XP)
This tweak can be used to disable the web content and tasks in Explorer, it will also remove the "Desktop" item from Display Properties.

Remove My Computer from the Desktop and Start Menu (Windows 2000/Me/XP)
This restriction removes My Computer from the desktop and Start menu.

Disable the Ability to Right Click on the Desktop (All Windows) Popular
This tweak removes the context menu that would normally appear when the user right clicks on the desktop or in the Explorer right results pane.

Change the Screen Saver Grace Period (Windows NT/2000/XP)
This setting determines when password protection of a screen saver becomes effective. By default, a brief period elapses within which the user can use the mouse or the keyboard to stop the screen saver without entering the password.

Choose the First Desktop Icon (Windows 2000/Me/XP)
This tweak allows you to choose the icon that you want to appear first on the desktop either My Documents or My Computer.

Change the Application Focus Settings (All Windows)
When Windows applications require user input or focus, they will either pop-up over the existing window, or their icon will flash on the taskbar waiting for user action. This tweak controls that behavior.

Active Window Tracking (All Windows)
This tweak allows you to bring running programs to the foreground just by moving you mouse of the application window. This is similar to the X-Mouse feature found on UNIX operating systems.

Show Windows Version on Desktop (All Windows) Popular
Early versions of Windows showed the version number on the desktop, this feature was removed in the released version. This tweak can be used to enable the feature and allow you to quickly locate which version of Windows is running.

Rename or Delete Special Folders (All Windows) Popular
This setting allows you to rename and delete special folders (such as the Recycle Bin) as if it was a normal folder by right-clicking the icon.

Change Desktop Icon Visibility (All Windows) Popular
This tweak allows you to control which icons are visible on your desktop. By modifying the desktop namespace you can add and remove special icons including My Computer, Inbox and Recycle Bin.

Show User and Computer Name on Desktop (Windows NT/2000/XP) Popular
This tweak will rename "My Computer" to "Username on Computername" making it simple to determine which computer you are logged on to and which username you are logged on as.

Launch Windows Desktop in a Separate Process (Windows 98/Me/2000/XP) Popular
By default Windows creates one multi-threaded Explorer process which contains the Desktop, Taskbar and all other explorer instances. If one of these instances fails, all instances will fail. When enabled, this setting causes Windows to create separate processes insulating them from other failures.

Show Pop-up Descriptions for Explorer and Desktop Items (All Windows)
This setting controls whether pop-up tool tip information and descriptions are shown when the mouse is hovered over desktop and explorer items.

Disable Desktop Cleanup Wizard (Windows XP)
By default Windows will run the Desktop Cleanup Wizard every 60 days to remove unused desktop items and shortcuts. This setting will disable it from running automatically.

Hide the Internet Explorer Icon (All Windows)
This option hides the Internet Explorer icon from the Windows desktop.

Remove My Documents from the Desktop (All Windows)
This setting is used to remove the My Documents folder from the Windows desktop.

Add Custom Folder to My Computer or the Desktop (All Windows) Popular
Create your own custom system folder, like "My Documents", that can not be deleted or renamed and place it on the desktop and My Computer.

Create a Desktop Shortcut to Hotmail (All Windows)
This tweak can be used to create a shortcut directly to your Hotmail e-mail account on your desktop.


Registry Guide : Windows : Windows Explorer

Home : Windows : Windows Explorer

Search Search
Windows Explorer Search Features Enhancements

Change Drive Name and Icon (All Windows) Popular
This tweak allows you to change the name and icon shown in Explorer for a specific drive letter.

Change Sort Order in Windows Explorer (All Windows)
Windows XP introduced a different ordering method when sorting numeric file listings in Windows Explorer. Instead of sorting character-by-character in the file name, any numeric string is now handled as a number.

Remove GoTo Option on Explorer Menu (Windows NT/2000)
This restriction can be used to remove the the GoTo menu from Tools in Explorer.

Restore Folder Windows at Startup (Windows XP)
This option controls whether Windows will attempt to re-open any folders that were already open when the system was last shutdown.

Remove Shared Documents from My Computer (Windows XP)
The Shared Documents folder allows users to easily share files and folders over a network. This restriction will remove the "Shared Documents" object from My Computer.

Speed-up Access to AVI Media Files (Windows XP)
Windows XP can run slowly when attempting to access a folder that contains a large number of AVI (Audio Video Interleave) media files. This tweak speeds the process up by stopping Windows from extracting file information from AVIs.

Add a Menu Option to Move or Copy to a Folder (All Windows)
This tweak allows you to easily move and copy files and folders by adding two new right-click menu options to "Move To Folder..." and "Copy To Folder...". Simply highlight the file, right-click the option and select the destination folder.

Change the Auto Complete Mode (All Windows) Popular
This setting controls whether the automatic text completion (AutoComplete) feature of Windows Explorer appends the suggested text to the words as you are typing as well as showing a drop-down list of available values.

Show Hidden Operating System Files (All Windows)
This setting controls whether the normally hidden operating system files should be displayed when using explorer to browse the file system.

Show Encryption Commands on the Shortcut Menu (Windows 2000/XP)
You may find it easier to use the Encrypting File System (EFS) by placing "Encrypt" and "Decrypt" commands on the Windows Explorer context menu when a file is right-clicked with the mouse.

Show Programs in the Open With Selection Box (All Windows)
This setting allows you to decide which programs are listed in "Open With" dialog box which is shown when an unknown file type is opened.

Change Program and Common Files Directory (All Windows)
This tweak allows you to change the directory used as the default location for software applications and shared files.

Launch Folder Windows in a Separate Process (All Windows)
This setting controls whether each folder window is launched as a separate explorer task. The benefit of this method is that if one window has an error and crashes the others should be not be affected. The disadvantage is that it takes more system resources for each folder.

Show or Hide "Open With" Program Checkbox (All Windows)
This setting allows you to control whether the checkbox to save the "Open With" program is available when an unknown file type is opened.

Automatically Expand Folders in Explorer (All Windows)
When using Windows Explorer the selected folder is automatically expanded in the left-hand folder list. This setting allows you to control that functionality.

Specify Unknown File Type Options (All Windows)
These settings allow you to specify a description and the application to launch to view files with an unknown extension.

Show "Send to" Context Menu (All Windows)
This setting allows you to control whether the "Send to" context menu is displayed when a file or directory object is right-clicked in Explorer.

Disable the Thumbnail Cache (Windows XP)
This setting is used to stop explorer from caching thumbnail pictures and instead refresh any images every time a folder is opened.

Show Attributes Column in Explorer (Windows 98/Me/2000/XP)
If you like to view your files using the detailed view option you may have noticed that the attributes column has disappeared. With the introduction of Windows 98 it was removed by default, this tweak adds it back.

Add Explore From Here to Every Folder (All Windows)
When you right click on any folder this will give you an option to Explore From Here, which will open up an Explorer window of that folder.

Show Hidden Folders and Files (All Windows)
This setting controls whether hidden files and folders are displayed in explorer when browsing the file system.

Disable Compressed Folders (Windows Me/XP)
Windows Me and XP include a built-in feature to manage compressed ZIP files and folders. This tweak allows you to disable it and install a third-party application.

Removing Item Types from the New Menu (All Windows)
When you right-click on your desktop or other selected applications there is a New sub-menu which contains a list a default templates. This list can be modified to include only the templates you want.


Registry Guide : Windows : File System

Home : Windows : File System

Caching and Memory Caching and Memory
File System Caching and Memory Settings

Files and Shortcuts Files and Shortcuts
Files and Shortcut Settings

Maintenance Maintenance
Error Checking and Defragmentation Settings

Change Drive Name and Icon (All Windows) Popular
This tweak allows you to change the name and icon shown in Explorer for a specific drive letter.

Do Not Move Deleted Files to the Recycle Bin (Windows XP)
When a file or folder is deleted in Windows Explorer, a copy of the file or folder is placed in the Recycle Bin. Using this setting, you can change this behavior.

Change the File Attribute for System Folders (Windows 95/98/Me/NT/2000)
Windows Explorer normally uses the Read-Only attribute to determine whether a folder is customized. This may cause file saving problems with some programs and not allow you to remove the attribute. This tweak allows you to force Windows to use the alternate System attribute.

Enable Advanced File System and Sharing Security (Windows XP Professional)
This setting is used to enable the ability to control advanced NTFS permissions on local and shared files.

Change the Default Disk Utilities (All Windows)
These settings control the default tools used for Windows disk management including Backup, Defrag, Repair and Cleanup. Changing these values will alter the programs used when you right-click a disk in My Computer and select Properties > Tools.

Windows NT Failure to Open Large Files (Windows NT)
When an application tries to open large files (over 100MB), the request may fail with one of the following error messages: Insufficient Resources or Invalid Handle. This tweak can be used to resolve the problem.

Show File and Folder Names Using the Correct Case (Windows 95/98/Me/2000/XP)
Some versions of Windows will attempt to adjust the capitalization of files and folders that are in all uppercase to make them more visually pleasing. For example, if you create a folder named "C:\ALLINCAPS" Windows will actually display it as "C:\Allincaps". This feature can be disabled using this tweak.

Change Copy and Move NTFS Permissions (Windows NT/2000/XP)
When you copy or move a file or folder to another volume, the object inherits the permissions of its new folder. This setting allows you to force Windows to preserve the current permissions instead.

Disable Encryption for Files Copied to a Server (Windows 2000)
This tweak allows you to prevent Encrypting File System (EFS) files from being copied to a server in an encrypted format. This provides the ability to share files on a central server in an unencrypted state.

Automatically Start CD-R and DVD-R Disks (All Windows)
This settings controls whether CD-R(W) and DVD-R(W) disks are automatically started when loaded into the computer.

Select the Drive Types to Start Automatically (All Windows)
When using AutoRun Windows can detect and automatically start programs when new media is inserted into a drive. By default, CD-ROM and hard drives will automatically launch, but removable and network drives will not.

Select the Disk Drives to Start Automatically (All Windows)
This setting controls which drives the AutoPlay feature is enabled on. When AutoRun is enabled, media is automatically started when it is inserted in the drive.

Manage the Encrypting File System (Windows 2000/XP)
When you use Encrypting File System (EFS), you can store data securely because selected NTFS file system files and folders can be encrypted. This setting allows you to enable or disable EFS.

Disable the NTFS Last Access Time Stamp (Windows NT/2000/XP)
When Windows accesses a directory on an NTFS volume, it updates the LastAccess time stamp on each directory it detects. Therefore, if there are a large number of directories, this can affect performance.

Enable 48-bit LBA Support for Large Hard Drives (Windows 2000/XP)
By default Windows 2000 SP2, Windows XP and earlier versions of Windows do not support 48-bit Logical Block Addressing (LBA) for drives larger than 137GB as defined in the ATA/ATAPI 6.0 specification.

Configure New File Sharing and Locking Semantics (Windows 95/98/Me)
This setting controls the file locking mechanisms of Windows, disable this setting only if you are currently experiencing problems with specific applications.

Configure Protected-Mode Hard Disk Interrupt Handling (Windows 95/98/Me)
This switch allows Windows to terminate interrupts from the hard disk controller, bypassing the ROM routine that handles these interrupts. Some hard drives might require that this setting be disabled in order for interrupts to be processed correctly. If this setting is disabled, the ROM routine handles the interrupts.

Configure 32-bit Protected Mode IO Drivers (Windows 95/98/Me)
This setting controls whether fixed disk access is performed through Windows protected mode drivers or through real mode drivers and BIOS routines. If you are experiencing drive IO errors enabling this setting may be a possible solution.

Disable CD Burning (Windows XP)
This restriction is used to disable the use of the inbuilt CD recording functions of Windows.

Disable the Recycle Bin (Windows 98/Me/2000/XP)
This setting is used to disable the use of the recycle bin and permanently remove all deleted items instead. This enables the same functionality as holding the Shift key while deleting items.


Registry Guide : Windows : File System : Caching and Memory

Home : Windows : File System : Caching and Memory

Optimize the System Cache Size (Windows NT/2000/XP) Popular
This setting controls whether the system cache is optimized for a Desktop computer or network server. Network servers usually require more memory dedicated to file caching, while desktop computers require more memory for running software applications.

Manage File System Caching Memory (Windows NT/2000) Popular
Windows will normally limit the amount of RAM that can be locked for file system operations. This setting allows you to modify the automatic value.

Change the Cache Write Delay (Windows 98/Me)
During the shutdown process the contents of the virtual cache are written to the hard drives. This setting specifies the timeout to wait for the cache to be written to the drive.

Double Buffering Hard Disk Support (Windows 95/98)
Windows 98 includes double buffering support, some systems may have an incompatibility between the computer's BIOS and the Dblbuff.sys file.

Use Asynchronous or Synchronous Buffer Commits (Windows 95/98/Me)
This setting changes function calls to the File-Commit API to return immediately back without checking the data has been correctly written to the disk drive. By default Windows uses synchronous buffer commits, this setting allows you to enable asynchronous as an alternative for applications that may need this functionality.

Optimize Swap File Performance (Windows 98/Me) Popular
On systems with larger amounts of memory, more than 128Mb, the hard disk based swap file is not needed as much. This tweak optimizes the use of the swap file on such systems.

Change the Size of the Virtual Disk Cache (Windows 95/98/Me) Popular
This tweak allows you control the minimum and maximum amount of memory being allocated as disk cache. It can be used to speed up your system and possibly avoid some memory problems.

Control Write Behind Caching (Windows 95/98/Me)
For increased performance write behind caching is used to write data to the fixed disks, this means that in the event of a system failure there is a possibility that data would not be completely written to the disk. If you have a system critical application you can disable this functionality to be sure that data is written directly to the disk bypassing the cache.


Registry Guide : Windows : File System : Files and Shortcuts

Home : Windows : File System : Files and Shortcuts

Short Filenames on NTFS Partitions (Windows NT/2000/XP)
This setting controls whether MS-DOS compatible 8.3 file names should be generated on NTFS partitions. Disabling this feature can increase the performance on high usage partitions that have large amount of files with long filenames.

Disable Tracking of Broken Shortcut Links (Windows 2000/XP)
The NTFS File System in Windows XP and Windows 2000 automatically attempts to locate broken shortcut destinations by searching all paths that are associated with it. This setting can be used to disable that feature.

Use Connected Web Files and Folders (Windows 2000/Me/XP)
The Windows file system includes a feature to connect web documents and their associated files. If an HTML document is moved or copied all its associated files, including images, JavaScript and style sheets, can also be automatically relocated.

Remove the Tildes in Short Filenames (Windows 95/98/Me)
When long filenames are shown in an application that only supports short filenames a tilde "~" is used to convert the long name into a compatible short name. This setting removes the use of tildes.

Comprehensive Search for Broken Shortcuts (Windows NT/2000/XP)
When the system cannot find the target file of a shortcut it searches all the associated paths. If still not found it performs a comprehensive search of the drive to locate the file. This setting can be used to disable the final search.

Disable Automatic Network Shortcut Resolution (All Windows)
When you create a shortcut to a resource on a mapped network drive, and then remap the same drive to a different network resource, Windows attempts to connect to the original network resource when you access the shortcut.

Control Long Filename Support (All Windows)
Windows allows the use of long filenames on FAT partitions. Some legacy software may be incompatible with this new file system design, and may require the use of 8.3 filenames. By enabling this setting you can turn off long filename support.

Manage Windows Short File Extensions (Windows NT/2000/XP)
Windows evaluates file extensions on the first three characters, therefore 'filename.html' is actually treated as 'filename.htm'. Therefore if you use a command such as 'del *.htm' to delete all the '.htm' files, you will also delete all '.html' files as well.

Extended Characters in Short Filenames (Windows NT/2000/XP)
This setting allows extended characters to be used in 8.3 filenames. Short file names with extended characters may not be viewable on computers that do not have the same character code page.

Remove or Change the Shortcut Arrow (All Windows) Popular
Would you prefer to display your shortcuts without the arrow in the bottom left hand corner? This tip will show you how to change the arrow icon or remove it completely.

Show Super Hidden File Extensions (All Windows)
Even when you have configured Windows to display all file extensions, there are still some which remain hidden. This allows potentially dangerous files to be masked as safe files, fooling the user into executing them. This tweak helps expose those file extensions.

Remove the 'Shortcut to...' Prefix on Shortcuts (All Windows) Popular
Don't like having 'Shortcut to...' appended to every Shortcut? You're not alone. With this tip you can stop Windows for adding this text when creating links.

Preserving Long Filenames for Legacy Applications (Windows 95/98/Me)
Windows normally preserves the long filenames of files accessed by legacy applications. This functionality can be disabled if you are experiencing LFN errors with a legacy application.

Creating a Shortcut to the System Folders (All Windows)
This function allow you to add a shortcut to various system folders on your Desktop or Start Menu.


Registry Guide : Windows : File System : Maintenance

Home : Windows : File System : Maintenance

Modifying the Autocheck Time-out Value (Windows NT/2000/XP)
When Windows is not shutdown correctly it will perform an AutoCheck using CHKDSK on the next restart. This setting controls the time delay before running Autochk or whether it is run at all.

Optimize the Contiguous File Allocation Size (Windows 95/98/Me) Popular
This setting optimizes the file system by specifying the minimum amount of free contiguous space needed before writing a file. Larger values are especially useful for disk intensive applications to reduce fragmentation.

Disk Defragmenter Options (Windows 95/98/Me)
These settings allow you to control the default options for the disk defragmenter (DEFRAG) utility.

Automatic Boot Disk Optimization (Windows XP)
Windows XP includes a new feature that will automatically optimize the the disks on boot if required. This setting controls whether this feature is enabled.

Disable Screen Saver When Disk Defragmenter Active (Windows 95/98/Me)
If the screen saver becomes active while using the disk defragmenter it can slow and interrupt the process. This tweak disables the screen saver when defrag is being used.

Disable Low Disk Space Notification (Windows XP)
This setting controls whether you receive a "Low Disk Space" warning when free disk space reaches less than 200 megabytes.

Disable ScanDisk After Improper Shutdown (Windows Me)
Normally if a system is shutdown improperly scandisk will run on the next reboot to ensure the contents of the hard disk are valid. This setting stops scandisk from running automatically when restarting.

Control How NTFS Reserves Space for its Master File Table (Windows NT/2000/XP)
The NTFS file system contains at its core a file called the master file table (MFT). For every file on an NTFS volume there is at least one entry in the MFT. This setting controls the amount of space reserved for the MFT so that it does not become fragmented and slow system performance.


Registry Guide : Windows : Login and Authentication

Home : Windows : Login and Authentication

Automatic Logon for Novell Netware Clients (All Windows)
These settings allow you to configure the Novell NetWare client to automatically logon to a Windows network.

Automatic Logon to Windows 95, 98 and Me (Windows 95/98/Me) Popular
This setting allows Windows clients to automatically logon without entering a user name or password, therefore bypassing the logon box.

Automatic Logon to Windows NT, 2000 and XP (Windows NT/2000/XP) Popular
Windows includes a feature that allows you to configure the computer to automatically logon to the network, bypassing the Winlogon dialog box.

Enable Shutdown from Authentication Dialog Box (Windows NT/2000/XP)
When this setting is enabled a [Shutdown] button is displayed in authentication dialog box when the system first starts. This allows you to shutdown a system without logging in. The button is shown by default on a workstation and removed on a server installation.

Hide the Welcome Screen (Windows 2000)
This setting hides the welcome screen that is normally displayed each time the user logs on to Windows 2000 or XP Professional.

Change the Login Window (Windows XP)
This setting controls which type of logon screen is shown, either the classic Windows NT/2000 format or the Windows XP welcome screen.

Allow Fast User Switching (Windows XP)
Fast user switching allows you to quickly switch to another user account without having to close any programs. This setting controls whether fast user switching is available.

Enable Monitor Power-off on the Logon Screen (All Windows)
Normally Windows will not automatically turn off the monitor if the system is waiting at the logon screen. This setting can be used to cause the monitor to be powered-down when not in use as per the default power-saving profile.

Disable Passport Balloon Reminder (Windows XP)
When you install Windows XP a balloon reminder is shown to prompt you to enter a Microsoft .NET Passport. This reminder can be disabled if you are not using Passport or MSN Messenger.

Change the Logon Screen Wallpaper (All Windows) Popular
When you setup a background wallpaper for your desktop, the initial logon screen wallpaper is not changed and stays as the default Windows appearance. This tweak allows you to change the default wallpaper.

Hide the Last User Name (All Windows) Popular
This setting can be used to blank the username box on the logon screen. This will prevent people that are logging on from knowing the last user to access the system.

Limit the Number of Automatic Logins (Windows NT/2000/XP)
This setting is used to limit the number of automatic logins, once the limit has been reached the auto logon feature will be disabled and the system will display the standard authentication box.

Modify the Number of Cached Logins (Windows NT/2000/XP)
This value controls the number of allowable cached login attempts when the network domain controller is unavailable.

Legal Notice Dialog Box Before Logon (All Windows) Popular
Use these fields to create a dialog box that will be presented to any user before logging onto the system. This is useful where you are required by law to warn people that it is illegal to attempt to logon without being an authorized user.

Change the Default Logon Screen Saver (Windows NT/2000/XP)
Windows has a default screen saver which is shown over the login screen even when no screen saver has been selected. These settings allow you to configure the default login screen saver.

Customize the Windows Logon and Security Dialog Title (Windows NT/2000/XP) Popular
This setting allows you to add additional text to the title of the standard Windows Logon and Windows Security dialog boxes.

Show Administrator on the Welcome Screen (Windows XP Professional)
When logging into Windows the Administrator account is not normally available on the Welcome screen. This tweak adds it to the Welcome screen and allows you to login like a normal account.

Change the Logon Screen Background Color (All Windows) Popular
When you change the color scheme and appearance of your desktop it does not change the background color of the logon screen to match. This tweak allows you to change that color as well.

Display Domain Logon Confirmation (Windows 95/98/Me)
When this option is enabled, a popup dialog message is shown when the user successfully authenticates with a Windows domain.

Force the Use of Automatic Logon (Windows 2000/XP) Popular
Normally when a Windows machine is configured to automatically logon to a specified account users can bypass this and enter alternate account information. This tweak forces the machine to auto logon and to ignore any bypass attempts.

Disable the Auto Logon Shift Override Feature (Windows NT/2000/XP)
When using the automatic login feature it is possible for a user to hold the Shift key to bypass the login sequence and enter a username and password. This feature disables the ability to override the function.

Show Options on Logon Dialog Box (Windows NT/2000/XP)
This setting controls whether the options to enter a domain or to log on using a dial-up connection are shown on the Windows logon box.

Use Active Authentication for Unlock and Screen Saver (Windows NT/2000/XP)
This setting controls whether a full login should be performed when a workstation is unlocked or a password is used with the screen saver. Normally Windows will not check some settings such as whether the account has been locked out.

Disable the Unread Mail Message on the Welcome Screen (Windows XP)
This setting can be used to remove the message on the Windows Welcome screen showing the number of unread e-mails.

Hide Usernames from the Logon Screen (Windows XP)
This tweak can be used to hide specific usernames from the logon screen, without removing the account completely.

Use the Classic Login Interface (Windows XP)
Windows XP includes a new log on interface to streamline the login process and display user profile information. In some circumstances the old Windows NT/2000 interface may be required in which case you can still access it using this key combination.

Command Line Option to Reboot or Log Off Windows (Windows 95/98/Me) Popular
This command allows you to create a shortcut or execute from a batch file a Windows DLL that will bypass the standard Start Menu method of shutdown and initiate a Log Off, Shutdown or Restart.

Start Windows Without Prompting for a Password (Windows 95/98/Me) Popular
Does Windows prompt you for a password every time you boot up even though you're the only one using the PC? Follow these instructions to make Windows automatically start up without prompting you for a password.

Force Users to Logon to Windows (Windows 95/98/Me) Popular
Usually users can simply press 'Cancel' at the Windows logon box to bypass the login process and gain access to the local computer. This tweak will logout the user if the authentication fails or the user clicks Cancel.

Time-out for User Profile Dialog Boxes (Windows NT/2000)
When the user is presented with a dialog box requesting User Profile information, this specifies the amount of time in seconds before the dialog box is closed and the default is accepted. The default value is 30 seconds.


Registry Guide : Windows : Start Menu and Taskbar

Home : Windows : Start Menu and Taskbar

Documents and Folders Documents and Folders
Manage Start Menu Documents and Folders
Taskbar Taskbar
Taskbar Settings and Enhancements

Remove My Computer from the Desktop and Start Menu (Windows 2000/Me/XP)
This restriction removes My Computer from the desktop and Start menu.

Enable Start Menu Scrolling (Windows 98/Me/2000/XP)
When there are more items on the Start Menu than can fit on the screen, Windows can either create a second column of items or it can create a scrolling menu. This tweak controls that functionality.

Remove Undock Computer from Start Menu (Windows XP)
This policy is used to hide or display the "Undock Computer" option on the Start Menu.

Change the Start Button Text (All Windows) Popular
Would you like to change the Start button to say something else, perhaps your name, company or any other 5 or less letter word? This article explains the procedure to manually modify the text of the Windows Start button.

Highlight New Programs on Start Menu (Windows XP)
When you install a new Windows program the icon will be highlighted on the Start Menu to allow you to quickly locate it. This tweak controls whether new programs should be highlighted.

View Enhanced Start Menu Folders (Windows XP)
These settings allow you to customize which items are shown on the Windows XP enhanced Start Menu.

Remove Set Program Access and Defaults from Start Menu (Windows 2000/XP)
This setting is used to remove the "Set Program Access and Defaults" icon from the Start Menu. This feature was introduced with Windows XP SP1 and Windows 2000 SP3 to allow users to configure the default applications used on the PC.

Remove the Disconnect Menu Item (Windows Terminal Server)
This setting is used to hide the Disconnect menu item on a terminal server Start menu.

Clear the Cached Run Commands (All Windows)
Do you have a lot of items in the run command history on Start Menu? This tweak will allow you to clear the most-recently-used (MRU) list.

Remove the Eject Option from the Start Menu (Windows 2000)
This tweak allows you to remove the "Eject PC" option from the Windows 2000 Start menu.

Show Log Off Option on the Start Menu (Windows Me/2000)
This setting controls whether the 'Log Off [Username]' option is shown on the Start Menu.

Sort Start Menu and Favorites in Alphabetical Order (All Windows)
This tweak allows you to alphabetically sort the Start Menu and Favorites Menu.

Show Programs in the Frequently Used Programs List (Windows XP)
This setting allows you to decide which programs may be shown in the most frequently used programs list on the Windows Start menu.

Show Favorites on the Start Menu (Windows 2000/XP)
This setting controls whether the Favorites folder is shown on the Start Menu.

Remove Suspend from the Start Menu (Windows 95/98/Me)
If the Suspend option doesn't work as it should, or you simply want to remove the option from the Start Menu, then use this tweak.

Remove Frequent Programs List from the Start Menu (Windows XP)
This restriction removes the list of frequently used programs from the Start menu.

Remove Pinned Programs List from the Start Menu (Windows XP)
This restriction removes the pinned programs list from the Start menu. It also removes the Internet and E-mail checkboxes from the Start menu.

Remove Username from the Start Menu (Windows XP)
This restriction hides the current username normally displayed at the top of the Windows XP Start Menu.

Remove "All Programs" Button from the Start Menu (Windows XP)
This restriction is used to remove the "All Programs" button which displays a list of all the installed applications.


Registry Guide : Windows : Start Menu and Taskbar : Documents and Folders

Home : Windows : Start Menu and Taskbar : Documents and Folders

Change the Number of Recent Documents Displayed (Windows 2000/Me/XP)
This setting is used to specify the number of documents and files that are kept in the recent documents section of the Start menu.

Hide Start Menu Subfolders (All Windows)
This setting can be used to hide any custom sub-folders from being shown in the top section of the Start Menu and therefore only displaying direct file shortcuts.

Clear Recent Documents When Windows Exits (All Windows) Popular
This restriction will clear the list of recent documents on the Start Menu when Windows exits.

Show Cascading Control Panel Items (Windows 2000/Me/XP)
This tweak controls whether the Control Panel is shown as a cascading menu or as a simple folder link on the Start Menu.

Show Cascading Network Connections (Windows 2000/Me/XP)
This tweak makes the 'Network and Dial-up Connections' folder on the Start Menu into a cascading menu instead of a simple folder link.

Show Cascading My Documents Folder (Windows 2000/Me/XP)
This tweak makes the 'My Documents' folder on the Start Menu into a cascading folder, which then give you direct access to sub-folders without having to open the main 'My Documents' directory first.

Show Cascading Printers Folder (Windows 2000/Me/XP)
This tweak controls whether the 'Printers' sub-folder under 'Settings' on the Start Menu, is displayed as a cascading folder.

Show Cascading My Pictures Folder (Windows 2000/Me/XP)
This setting causes the "My Pictures" folder on the Start Menu to act as a cascading folder.

Expand Special Folder on the Start Menu (All Windows) Popular
Want easy access to the contents of a special folder? With this tip you can add an expanding special folders to the start menu for quick shortcuts to their contents.


Registry Guide : Windows : Start Menu and Taskbar : Taskbar

Home : Windows : Start Menu and Taskbar : Taskbar

Clear Past Icons from the Tray Notification Area (Windows XP)
This tweak allows you to clear the Past Items list in the customized notifications area of the systray.

Change the Taskbar Group Size (Windows XP)
This setting defines the number of open windows of the same application before they are grouped together on the taskbar.

Disable Balloon Tips (Windows XP)
Windows sometimes offers tips and advice to new users by opening a balloon window from the taskbar. The feature can disabled using this tweak.

Automatically Hide Inactive Tray Icons (Windows XP)
This setting controls whether running tray programs should be hidden automatically when they are not active.

Remove the Start Banner on the Taskbar (All Windows) Popular
Hide the bouncing arrow and the "Click Here to Begin" caption that appear on the taskbar when you start Windows.

Group Similar Taskbar Buttons (Windows XP)
This setting is used to control whether similar items are grouped together as a single item or are displayed as individual buttons on the taskbar.

Disable Taskbar Context Menus (All Windows)
This setting removes the context menus (right click on the taskbar) for the system tray, including the Start button, Tab control, and Clock.

Lock the Size and Position of the Taskbar (Windows Me/XP)
This setting is used to lock or unlock the size and position of the taskbar on the Windows desktop.


Registry Guide : Windows : Startup and Shutdown

Home : Windows : Startup and Shutdown

Clear the Page File at System Shutdown (Windows NT/2000/XP) Popular
Windows does not normally clear or recreate the page file. On a heavily used system this can be both a security threat and performance drop. Enabling this setting will cause Windows to clear the page file whenever the system is shutdown.

Enable Font Smoothing on the Welcome Screen (Windows XP)
Windows XP includes a new feature called Clear Type which is designed to make fonts more readable on LCD and low resolution screens. This tweak allows you to enable font smoothing on the Welcome screen where it is normally disabled.

Specify the Response Time for Hung Applications (All Windows)
This setting controls the amount of time to wait for a response from a hung application before the system task manager automatically terminates the task.

Automatically Ending Hung Applications (All Windows) Popular
When this tweak is enabled it will force Windows to shutdown immediately ending all tasks without attempting to safely close any applications that have hung.

Change the Log Off and Shutdown Settings (Windows NT/2000)
These settings control what action the system should take when the Log Off and Shutdown commands are used.

Enable Quick Reboot (Windows NT/2000)
This setting allows you to use the quick reboot function to restart Windows immediately without shutting down. When enabled, press Shift + Ctrl + Alt + Delete for a quick reboot.

Manage the Windows Prefetcher Service (Windows XP)
The Windows XP Prefetcher component helps to shorten the amount of time it takes to start programs by fetching and storing commonly used files. This tweak allows you to manage the service and cache.

Manage the Programs Run at Windows Startup (All Windows) Popular
You can automatically start programs whenever Windows launches. If you have programs automatically starting that you have not loaded then you can remove them using this tip as well.

Enable Shutdown Event Tracker (Windows XP)
The Shutdown Event Tracker provides a simple and standard mechanism you can use to consistently document the reasons for shutting down or restarting your computer. The information provided is recorded in the system log in Event Viewer.

Read Environment Variables in Autoexec.bat File (Windows NT/2000/XP)
When this value is enabled the variables declared in the Autoexec.bat file will be parsed and included in the current user environment.

Control Whether the Windows Desktop is Loaded (Windows 95/98)
By default Windows automatically loads the Windows Desktop (or GUI) at startup. With this key you can control whether the GUI is loaded or if you just want the MS-DOS prompt.

Suppress Safe Mode Warning Message (Windows 95/98/Me)
Enabling this setting suppresses the safe mode warning message when booting up, and bypasses the Startup menu.

Allow Booting to the Previous Operating System (Windows 95/98/Me)
If you installed an upgrade version of Windows, you can normally press F4 to boot your previous version of Windows. This option can be disabled.

Change the Function Key Timeout (Windows 95/98/Me)
Windows normally enables the function keys during the boot sequence for 2 seconds, these keys allow you to control the boot process. The duration can be changed using this tweak.

Disable Function Keys During the Boot Sequence (Windows 95/98/Me)
By default Windows 9x enables the function keys on boot, these allow you to control the boot process. For example pressing F5 while the "Starting Windows 95..." message is displayed will boot Windows in Safe Mode.

Modify the Duration that the Startup List is Displayed (Windows NT/2000/XP) Popular
This setting allows you to change the default 30 second timeout for the Startup List which normally allows you time to choose and boot an alternative operating system.

Disable Save Settings at Exit (All Windows)
When Windows exits it normally saves the desktop layout, including icon location, appearance and other parameters. This setting disables any changes from being saved therefore allowing you to preserve a configured layout.

Control Whether Scandisk is Run Automatically (Windows 95/98/Me)
When Windows is incorrectly shutdown, or the turn is power turned off, the system will attempt to run Scandisk on the next boot. This setting control whether automatic checking is disabled, prompts before running, or runs automatically.

Show the Windows Boot Menu (Windows 95/98/Me)
Windows does not display the boot menu normally unless a key is pressed during bootup (F8 for Windows 95 or CTRL for 98/Me). The boot menu allows you to selectively boot Windows in different modes, including Safe Mode and Command Prompt Mode.

Display the Windows Splash Screen While Loading (Windows 95/98/Me) Popular
When Windows is loading normally you see the Windows clouds splash screen, this can be disabled to show the background DOS boot process.

Disable Ability to Skip Startup Programs (Windows NT/2000/XP)
Normally if you hold the Shift key while Windows is loading you can prevent the Startup applications from being launched. This setting disables the ability to by-pass these programs.

Automatically Reboot on the 'Blue Screen of Death' (Windows NT/2000/XP)
Windows will usually freeze when getting a dreaded 'Blue Screen of Death' (BSOD). Changing this setting will force Windows to automatically reboot when it crashes instead.

Power the Computer Off After Shutdown (Windows NT/2000/XP) Popular
This setting controls whether Windows should automatically power down or reboot your computer once it has finished the shutdown process.

Disable the Creation of Last Known Good (Windows NT/2000/XP)
This setting allows you to disable the creation of the LastKnownGood configuration, which stores a copy of the configuration after each successful boot-up.

Allow Portables to Undock Before Logon (Windows XP)
This setting controls whether users with portable computers have the option to undock the system before they have logged onto the computer.

Use Crtl + Alt + Delete to Restart the Computer (Windows 3.1/95/98)
Normally when you press Ctrl + Alt + Delete the Windows task list is displayed. Using this tweak the key combination will instead reboot the computer.

Disable Automatic Modem Connections at Startup (All Windows)
If remote connections are enabled in Windows, the system may try to initiate an Internet connection at Windows startup or at the start of many applications. This setting disables that behaviour.

Change the Startup and Shutdown Screens (Windows 95/98/Me) Popular
Microsoft has a knack for making the Windows startup and shutdown screens pretty boring. Luckily it's relatively easy to replace these images with pictures of your own.


Registry Guide : Windows : System

Home : Windows : System

Scripts Scripts
Enhancements and Settings for System Scripts

Services Services
Windows Service Settings and Enhancements

Windows File Checker Windows File Checker
Enhancements for the System File Checker

Change System Environment Variables (Windows NT/2000/XP)
This key contains the Windows system environment variables, the variables include Path, Temp, Windir and any other defined values.

Disable Automatic Daylight Savings Adjustment (Windows NT/2000/XP)
Windows will normally attempt to automatically adjust the system clock for daylight saving changes based on the computer timezone. This tweak allows you to disable the automatic adjustment.

Change the Number of Page Table Entries (Windows 2000/XP)
Page Table Entries (PTEs) may become depleted or fragmented on systems that perform a large number input/output (I/O) actions. When they become completely depleted the system may show a Stop error and halt. This tweak allows you to increase the number of PTEs available on the system.

Control Microsoft VM Garbage Collection (All Windows)
This tweak allows you to specify the quantity of new memory that Java can consume before garbage collection is initiated. Garbage collection (GC) consumes a lot of system resources and can severely affect performance.

Automatic Download of COM Components (Windows 2000/XP)
Windows can be configured to automatically download missing COM classes and objects over the network. This setting allows you to disable or enable this feature.

Change the Library Search Order (Windows 2000/XP)
This setting controls the order in which directories are searched for DLL (Dynamic Link Library) files. This may be useful to ensure that a local DLL is used when a program is being run over a network or to resolve issues where incompatible system DLL files are being loaded first.

Configure Windows Software Update Services (Windows 2000/XP)
These settings allow you to configure Windows client machines to use custom Microsoft Software Update Services (SUS) located on an internal corporate network instead of the Windows Update Internet site.

Disable Update Device Driver Wizard (Windows 98/Me/2000/XP)
This tweak allows you to disable the ability to use Windows Update to locate updated drivers for hardware in Device Manager.

Increase the USB Polling Interval (Windows 98/Me/2000/XP)
By default the USB polling interval is once every millisecond (ms). Even if no USB devices are connected the polling operation is still performed and the processor may not be able to enter power-saving state. Use this tweak to increase the polling interval.

Disable OS/2 and POSIX Subsystems (Windows 2000/XP)
To conserve system resources you may want to prevent the Windows session manager (SMSS) from loading any optional subsystems, such as OS/2 or POSIX. This tweak can be used to disable these optional subsystems.

Hide Computer Management Option (Windows 2000/XP)
This setting allows you to remove the "Manage" option from the My Computer context menu. The Computer Management program is used to configure the system.

Manage the CPU Task Priority (Windows 95/98/Me)
This setting allows you to manage how the system processor should prioritize foreground and background tasks.

System Board and Memory Optimizations (Windows 95/98/Me)
These settings allow you to optimize the AGP and PCI buses along with the system memory by reducing the number of wait states (idle time).

Manage Automatic Windows Updates (Windows 2000/XP)
These settings can be used to configure how Automatic Updates are applied to the Windows system. It includes the ability to disable automatic updates and to set the installation schedule.

Increase Application Keyboard Response Time (Windows 95/98/Me)
When running more than one application at a time, you may find that your system's keyboard response is slower. To alleviate this, you can adjust the amount of time allocated to processing keystrokes.

Disable the Windows Key (Windows NT/2000/XP) Popular
This tweak disables the Windows key that is found between the Ctrl and Alt keys on a Windows enhanced keyboard.

Change Power Management Configuration (All Windows)
This parameter allows you to specify the primary role of the computer so that predefined power management configurations can be used. For example a laptop will have different power saving features than a home desktop PC.

Configuring the Registry Size Limit (Windows NT/2000/XP)
The Registry Size Limit, or RSL, controls the total amount of space the may be consumed in paged pool memory and disk space by registry data. The RSL is a kind of "global quota" for registry space.

Control the Display of Popup Error Messages (Windows NT/2000/XP)
This tweak is used to control which error messages are displayed as popups, and also allows you disable the use of popup error dialog boxes entirely.

Change Foreground and Background Task Priority (Windows NT/2000)
This setting is used to manage the relative priority between foreground and background applications, this is normally accessed through Control Panel > System > Performance.

Change the Number of Spare Stack Pages (Windows 95/98/Me)
Windows sets aside a number of extra memory pages (spare stack pages) to be used temporarily to prevent a system "crash" due to a stack overflow condition. Sometimes all the spare pages can be used, and an error message is shown, this tweak allows you to increase the number available.

Show Run in Separate Memory Space Option (Windows 2000/XP)
This setting controls whether the "Run in Separate Memory Space" option is shown in the Run box, which allows you to run 16-bit programs in a dedicated Virtual DOS Machine (VDM) process.

Modify the Paged and Non Paged Pool Memory Sizes (Windows NT/2000/XP)
Windows normally calculates the paged and non paged pool memory sizes using complex algorithms based on physical memory size. These settings allow you to override and manually specify values.

Force Windows to Unload DLLs from Memory (All Windows) Popular
Windows Explorer caches DLLs (Dynamic-Link Libraries) in memory for a period of time after the application using them has been closed. This can be an inefficient use of memory on low memory systems, and may cause problems or delays for programmers developing with Windows DLL files.

Improve Core System Performance (Windows NT/2000/XP) Popular
On systems with large amount of RAM this tweak can be enabled to force the core Windows system to be kept in memory and not paged to disk.

Use an Alternative User Interface (Windows NT/2000)
This setting allows you to specify an alternate shell to use as the Windows user interface instead of the default explorer shell.

Enable Plug and Play on Windows NT (Windows NT 4.0)
Windows NT4 does not support plug-and-play devices out of the box, but it can be configured to a least partially support some PnP features with a little help.

Control the Default Virtual Machine Option (Windows NT/2000/XP)
When starting a 16bit application you have the option of running each in a separate virtual machine (VDM). With this setting you can change the default value.

View Which Hot Fix Patches Have Been Installed (Windows NT)
Periodically Microsoft releases Hot Fix's to patch bugs in Windows and other products, this key contains information about which Hot fix's have been installed.


Registry Guide : Windows : System : Scripts

Home : Windows : System : Scripts

Windows Script Host Settings (All Windows)
These settings allow you to configure some of the Windows Script Host (WSH) features, including the option to disable the engine.

Configure Windows Script Signature Security (All Windows)
This setting is used to define whether trusted and untrusted scripts should be executed when using signature verification. By requiring a signature the system will only execute scripts from verified authors.

Change the Default Action for Script Files (All Windows)
Normally scripting files are run when double clicked, once applied this tweak will cause them to be shown in Notepad instead. This is useful to avoid accidental execution especially with the prevalence of script based viruses.

Hide the Legacy Logon Scripts (Windows 2000/XP)
This setting controls whether the output from legacy Windows NT 4.0 logon scripts is displayed in a console window as the script executes.

Hide the Logon Scripts (Windows 2000/XP)
This setting controls whether the output from the logon scripts is displayed in a console window as the script executes.

Hide the Logoff Scripts (Windows 2000/XP)
This setting controls whether the output from the logoff scripts is displayed in a console window as the script executes.

Run the Logon Scripts Synchronously (Windows 2000/XP)
This setting directs the system to wait for the logon scripts to finish running before it starts the Windows Explorer interface program and creates the desktop.

Run the Startup Scripts Asynchronously (Windows 2000/XP)
Startup scripts are files that run before the user logs on. Normally the startup scripts run consecutively, but when this setting is enabled the scripts can run simultaneously.

Hide the Startup Scripts (Windows 2000/XP)
This setting controls whether the output from the startup scripts is displayed in a console window as the script executes.

Hide the Shutdown Scripts (Windows 2000/XP)
This setting controls whether the output from the shutdown scripts is displayed in a console window as the script executes.

Run Logon Scripts Synchronously (Windows NT/2000/XP)
This setting controls whether the system should wait for the logon scripts to complete before starting the users shell or whether the scripts should run asynchronously.


Registry Guide : Windows : System : Services

Home : Windows : System : Services

Disable Universal Plug and Play Services (Windows XP)
Windows XP includes support for Universal Plug and Play (UnPnP) which allows UnPnP devices to be connected over a network. There are currently limited UnPnP devices available and due to a recent security flaw it may be advisable to disable these services.

Optimize the Windows Server Service (Windows NT/2000/XP)
This setting can be used to manually optimize the Windows server functionality. By selecting the appropriate value you can optimize the service for memory usage, network throughput or a balance of both.

Change the Critical Update Notification Delay (Windows 95/98/Me)
When Windows detects that a new critical update is available it gives you the option to update now or to be reminded again in 1 day. This tweak allows you to change the default 1 day reminder period.

Disable SSDP Discovery in Windows Messenger (Windows 2000/XP)
Windows Messenger uses the Simple Service Discovery Protocol (SSDP) to attempt to locate upstream Internet gateways on UDP port 1900. This tweak allows you to disable Universal Plug and Play Network Address Translation discovery to reduce bandwidth and increase security.

Disable Network Messenger Service (Windows NT/2000/XP)
The Messenger service is normally used to transmit net send and Alerter service messages between clients and servers. Recently it has been employed by marketers for sending unsolicited advertising popups (SPAM) over the Internet. This tweak allows you to disable this service.

Modify the Internet Time Synchronization Schedule (Windows XP)
This setting is used to modify the number of seconds to wait between attempts to synchronize the system clock to an accurate time source on the Internet.

Restrict Interactive Services (Windows 2000/XP)
Windows services normally have the option of interacting with the desktop, to display information and accept input. For security reasons this tweak allows you to restrict service interactivity.

Windows Time Synchronization Settings (Windows 2000/XP)
These parameters allow you to control the synchronization settings of the W32Time service. This service ensures that computer date and time settings are correctly synchronized throughout an organization.

Enable NTP Time Server (Windows 2000/XP)
This setting is used to enable the local machine to act as a Network Time Protocol (NTP) server. When enabled other machines can synchronise their clocks with this machine.

End Tasks Without Restarting Windows (Windows 3.1/95/98)
This setting specifies whether you can press CTRL+ALT+DEL to quit applications that cause an unrecoverable errors in 386 enhanced mode, without restarting Windows.

Disable Distributed Component Object Model (DCOM) (All Windows)
Distributed Component Object Model, or DCOM, provides a method for distributed network applications to communicate with one another. This setting allow you to disable support for DCOM.

Modify the Internet Time Synchronization Servers (Windows XP)
Windows XP includes a new feature that allows it to synchronize the system clock from atomic clocks available on the Internet. This setting lets you add new servers and change the default server used.

Removing Windows Devices and Services (Windows NT/2000)
Sometimes it is possible to get orphaned services remaining in the registry. These services can be remove be modifying this key.

Changing the Startup Mode of a Service (Windows NT/2000)
All services have a setting controlling how they are started either manually, automatically or disabled. This setting can be changed through the registry.


Registry Guide : Windows : System : Windows File Checker

Home : Windows : System : Windows File Checker

Change the Size of the Windows File Protection Cache (Windows 2000/XP)
The Windows File Protection feature of Windows stores copies of common DLL files and replaces them if the original becomes damaged or lost. This tweak lets you control the maximum amount of space available to be consumed by the backup DLL's.

Disable Windows File Protection (Windows 2000/XP) Popular
Windows 2000 and XP include a feature called Windows File Protection (WFP), part of the System File Checker, which is intended to avoid some of the common DLL consistency issues. This feature may also block valid attempts to change system files and it can therefore be disabled using this tweak.

Manage Windows File Protection Scans (Windows 2000/XP)
This setting controls whether the Windows File Checker (SFC) should scan and replace the protected files during boot up.

Specify the Directory to Store Cached SFC Files (Windows 2000/XP)
This entry is used to specify which directory the Windows File Checker (SFC) should use to store the cached copies of protected files.

Display SFC Progress Meter (Windows 2000/XP)
Specifies whether the Windows File Checker (SFC) progress meter should be displayed during file checking.

Enable System File Protection Popup Notifications (Windows Me)
This tweak controls whether a popup notification message is shown when the System File Protection (SFP) service performs an action.

Windows File Checker Command-line Options (Windows 2000)
The Windows File Checker is used to scans all the protected system files and replaces incorrect versions with a cached copy of the correct version. These are the command-line options to control the Windows file protection (WFP) utility.


Registry Guide : Windows : Troubleshooting

Home : Windows : Troubleshooting

Crash Control Crash Control
Settings to manage system errors and restoration

Logging Logging
Logging and Reporting Enhancements

Repair Repair
Tweaks and settings to repair Windows Software

Automatic Administrative Logon to Recovery Console (Windows 2000/XP)
The recovery console is a command line environment that is used to recover from system problems. This setting controls whether the administrator account will be logged on automatically or be required to enter a password when the recovery console is invoked during startup.

Manage Floppy Access from Recovery Console (Windows 2000/XP)
If this setting is enabled, a user has full access to all drives on the system and can copy files from the hard drive to the floppy disk when using the Recovery Console.

Disable System Restore Tools and Settings (Windows XP)
System Restore allows users to revert Windows settings and configuration changes to an earlier point in time (called Restore Points). This tweak can be used to restrict user access to the System Restore tools and settings.

Change the Default NumLock State (Windows NT/2000/XP) Popular
The NumLock key is usually only turned on before the user has logged into the computer, this can cause problem for people with portable computers that do not check the status of the NumLock key before typing their password. The default behavior can be changed with this setting.

Enable Remote Assistance (Windows XP)
The Remote Assistance feature is a convenient way for an administrator to remotely connect to a computer and with permission view the screen, move the mouse, use the keyboard and chat online.

View Source Not Working in Internet Explorer (All Windows)
When you attempt to view the source HTML of a web page in Internet Explorer it may not be displayed for several reasons. This article describes some of the common causes of this problem.

Windows NT Failure to Open Large Files (Windows NT)
When an application tries to open large files (over 100MB), the request may fail with one of the following error messages: Insufficient Resources or Invalid Handle. This tweak can be used to resolve the problem.

Disable Warnings on Startup (Windows 2000/XP)
With this setting you can suppress any error messages that might otherwise appear at Windows startup. These popup messages normally notify you when a device or service is not functioning correctly.

Run Inserted CD-ROMs Automatically (All Windows) Popular
When you insert a data disc into the CD-ROM drive, it may not be run automatically, changing this setting should correct the problem.

Change the Icon Cache Size (All Windows)
If you desktop icons are redrawing too frequently or are corrupt, it could be because the icon cache is full. Try increasing the size by changing this setting.

Fix Problem with Athlon Hanging AGP Programs (Windows 2000/XP) Popular
Windows may stop responding when you use an Accelerated Graphics Port (AGP) program with an AMD Athlon processor. This is due to the memory allocated by the video adapter driver becoming corrupted.

Windows Error Reporting Settings (Windows XP)
When an error occurs the Windows system may attempt to send debugging information to Microsoft for analysis. These settings allow you to control the operation of this feature.

Remove Programs from the Add/Remove Programs List (All Windows) Popular
Windows compatible programs must include an uninstall program, sometimes though the program may get removed but the entry in Add/Remove programs does not. This tweak allows you to manually remove any orphaned entries.

Show Computer Manufacturer and Support Information (All Windows) Popular
This tip lets you include company and support information on the System Properties page in Control Panel. This is especially useful if you run a computer store and want your customers to be reminded where they bought their PC and where to get technical support.

PCMCIA Network Power Management (Windows 95/98/Me)
When using a PC Card network adapter you might not be able to connect the computer to the network, and under Control Panel > System there is a yellow exclamation mark "!" next to the card.

Stop Error Messages When Booting (Windows NT)
Stops the annoying Windows pop-up messages notifying you a device is not functioning when you boot-up Windows.

MS-DOS Compatibility Mode Problems with PCI IDE Controllers (Windows 95/98/Me)
If your computer contains a PCI IDE hard disk controller that employs serialization between the two IDE channels, this tip may help you resolve a MS-DOS compatibility mode problem in Device Manager.

Debug the Windows Update Process (All Windows)
This setting is used to enable a debug function, called Stepping Mode, which causes Windows Update to prompt during each step of the installation process.

Change the Active Desktop Safe Mode Background (Windows 98/Me/2000/XP)
This setting is used to change the image or web page that is shown when the active desktop is disabled due to a system error.

'Failure Writing to the System Registry...' Error Message (Windows 95)
When you run a setup program that was created using the Application Setup Wizard, you may receive an error message indicating the registry may be corrupt or you do not have the required permissions to write to the registry.

Unable to Connect More Than 10 Clients (Windows NT)
If you have a retail version of Windows NT server, and you are still unable to connect more the 10 users concurrently, then have a look at this tip.

Addition of New LAN Interface in RRAS Causes Event Message (Windows NT)
When you install an additional network interface card (NIC) and the Routing and Remote Access Service (RRAS) is already installed, you receive an error 20101 in the System Log in Event Viewer.

Delay Occurs When Unlocking Workstation (Windows NT/2000)
Sometimes a noticeable delay occurs when the logged on user or an administrator attempts to unlock a workstation. This because when you unlock the workstation Windows will update the domain list if the cached list's age exceeds two minutes (by default). This age limit can be modified.

Change the Default Mailbox Sound Setting (All Windows)
When you receive a new message, a sound may not be played even though "Play sound when new messages arrive" is enabled.

Long File Names Need to be Enabled (Windows 98)
If you are receiving an error when installing Windows 98 that long file names need to enabled in order for Windows 98 to install successfully try this.


Registry Guide : Windows : Troubleshooting : Crash Control

Home : Windows : Troubleshooting : Crash Control

Specify the Small Memory Dump Directory (Windows 2000/XP)
This setting is used to specify the location of the small dump directory which stores a small set of useful information when a system stops unexpectedly.

Enable Manual Crash Feature (Windows 2000)
Microsoft Windows 2000 includes a feature that enables you to have the system stop responding and generate a Memory.dmp file (crash to blue-screen) by using a button combination on the keyboard.

Send Administrative Alerts of System Crashes (Windows NT/2000/XP)
This setting controls whether Windows should send an alert to the Administrator when a system crashes.

Control Whether Windows Logs a System Crash (Windows NT/2000/XP)
This setting controls whether Windows logs a system crash to the event log, this will allow the exact time of the crash to be permanently recorded.

Create a System Crash Dump File (Windows NT/2000/XP)
This setting controls whether Windows creates a dump file of the computer memory when a system crashes.

Specify the System Crash Dump File Location (Windows NT/2000/XP)
This tweak is used to specify the location where the dump file should be written after a system crash.

Control the Dump Creation Method (Windows NT/2000/XP)
This tweak controls whether the system should create a new dump file and overwrite the existing file or whether it should append data to the old dump file when a system crash occurs.


Registry Guide : Windows : Troubleshooting : Logging

Home : Windows : Troubleshooting : Logging

Remote Access Service (RAS) Device Logging (Windows NT/2000)
Creates a file called DEVICE.LOG in the %SYSTEMROOT%\SYSTEM32\RAS folder for information about commands that the modem is sending and errors that are reported. This file can be very useful in debugging RAS failures.

Show Verbose Security Status Messages (Windows 2000/XP)
This setting allows you to configure Windows so that you receive verbose startup, shutdown, logon, and logoff status messages. This may be helpful to in troubleshooting slow startup, shutdown, logon, or logoff behaviour.

User Environment Event Logging (Windows 2000/XP)
These settings can be used to selectively enable the user environment event logging features available in Windows.

User Environment Debug Logging (Windows 2000/XP)
This setting enables debug logging of user profile and system policy processes which may be helpful in troubleshooting problems.

Windows Installer Logging (All Windows)
Windows Installer can use logging to help assist in troubleshooting issues with installing software packages. You can enable verbose logging with this setting.

Remote Access Service (RAS) PPP Logging (Windows NT/2000)
Creates a file called PPP.LOG in the %SYSTEMROOT%\SYSTEM32\RAS folder to help diagnose connectivity problems between a PPP server and a PPP client when one of the computers is a Windows NT Remote Access Service client.

Restrict Access to the Event Logs (Windows NT/2000/XP)
The Windows event log contains records documenting application, security and system events taking place on the machine. As these logs can contain sensitive data this tweak allows you to restrict access to administrators and system accounts only.

Create a Oakley Log for IPSec Troubleshooting (Windows 2000)
Enabling this setting causes Windows to create an Oakley.log file in the %SystemRoot%\debug folder for developers or network administrators with advanced IKE knowledge.

Change the Number of SQL Server Error Logs (Windows NT/2000/XP)
By default, Microsoft SQL Server 7.0 only stores seven error logs; Errorlog and Errorlog.1 through Errorlog.6. Since the log is re-created every time SQL Server is restarted you may want to keep more than seven logs archived.


Registry Guide : Windows : Troubleshooting : Repair

Home : Windows : Troubleshooting : Repair

Repair the Taskbar (All Windows)
If your taskbar has disappeared from the desktop or becomes hidden when you move your cursor near, it may be due to a corrupt registry key.

Repair the Icon Cache (All Windows)
Use this setting if Windows is displaying incorrect or corrupted icons for your programs and shortcuts.

Repair Dialog Boxes Sorting (All Windows)
When viewing files and folders from a Windows dialog box the items may be sorted incorrectly. For example, files may be listed before folders, items may be sorted in descending order, and so on. This tweak should resolve this problem.

Repair Internet Explorer Printing Errors
If you are using Internet Explorer and are experiencing blank pages when you print or incorrectly displayed print preview information then this tweak may resolve the problem.

Repair the Office Shortcut Bar (All Windows)
This tweak will resolve problems where you are unable to customize buttons on the Office XP Shortcut Bar or the buttons appear blank.

Repair the Registry Editor (Windows 2000/Me/XP)
This tweak allows you to reset the location and parameters of the Registry Editor (REGEDIT) back to the system defaults. This is useful if Regedit is not being displayed correctly.

Are You Missing Fonts from the Fonts Folder? (All Windows)
A font may seem to be installed correctly but does not appear in the Fonts folder because the Fonts key in the registry is missing or damaged.

New Command Missing in Windows Explorer (All Windows)
After you install Internet Explorer with the Windows Desktop Update component you may notice that the New command is missing from the right-click context menu. This tip will help you fix the problem.


Windows Registry Tutorial

Windows Registry Tutorial
by WinGuides.com

What is the Registry?
The Registry is a database used to store settings and options for the 32 bit versions of Microsoft Windows including Windows 95, 98, ME and NT/2000. It contains information and settings for all the hardware, software, users, and preferences of the PC. Whenever a user makes changes to a Control Panel settings, or File Associations, System Policies, or installed software, the changes are reflected and stored in the Registry.

The physical files that make up the registry are stored differently depending on your version of Windows; under Windows 95 & 98 it is contained in two hidden files in your Windows directory, called USER.DAT and SYSTEM.DAT, for Windows Me there is an additional CLASSES.DAT file, while under Windows NT/2000 the files are contained seperately in the %SystemRoot%\System32\Config directory. You can not edit these files directly, you must use a tool commonly known as a "Registry Editor" to make any changes (using registry editors will be discussed later in the article).

The Structure of the Registry

The Registry has a hierarchal structure, although it looks complicated the structure is similar to the directory structure on your hard disk, with Regedit being similar to Windows Explorer.

Registry Structure Each main branch (denoted by a folder icon in the Registry Editor, see left) is called a Hive, and Hives contains Keys. Each key can contain other keys (sometimes referred to as sub-keys), as well as Values. The values contain the actual information stored in the Registry. There are three types of values; String, Binary, and DWORD - the use of these depends upon the context.

There are six main branches, each containing a specific portion of the information stored in the Registry. They are as follows:

  • HKEY_CLASSES_ROOT - This branch contains all of your file association mappings to support the drag-and-drop feature, OLE information, Windows shortcuts, and core aspects of the Windows user interface.
  • HKEY_CURRENT_USER - This branch links to the section of HKEY_USERS appropriate for the user currently logged onto the PC and contains information such as logon names, desktop settings, and Start menu settings.
  • HKEY_LOCAL_MACHINE - This branch contains computer specific information about the type of hardware, software, and other preferences on a given PC, this information is used for all users who log onto this computer.
  • HKEY_USERS - This branch contains individual preferences for each user of the computer, each user is represented by a SID sub-key located under the main branch.
  • HKEY_CURRENT_CONFIG - This branch links to the section of HKEY_LOCAL_MACHINE appropriate for the current hardware configuration.
  • HKEY_DYN_DATA - This branch points to the part of HKEY_LOCAL_MACHINE, for use with the Plug-&-Play features of Windows, this section is dymanic and will change as devices are added and removed from the system.

Each registry value is stored as one of five main data types:

  • REG_BINARY - This type stores the value as raw binary data. Most hardware component information is stored as binary data, and can be displayed in an editor in hexadecimal format.
  • REG_DWORD - This type represents the data by a four byte number and is commonly used for boolean values, such as "0" is disabled and "1" is enabled. Additionally many parameters for device driver and services are this type, and can be displayed in REGEDT32 in binary, hexadecimal and decimal format, or in REGEDIT in hexadecimal and decimal format.
  • REG_EXPAND_SZ - This type is an expandable data string that is string containing a variable to be replaced when called by an application. For example, for the following value, the string "%SystemRoot%" will replaced by the actual location of the directory containing the Windows NT system files. (This type is only available using an advanced registry editor such as REGEDT32)
  • REG_MULTI_SZ - This type is a multiple string used to represent values that contain lists or multiple values, each entry is separated by a NULL character. (This type is only available using an advanced registry editor such as REGEDT32)
  • REG_SZ - This type is a standard string, used to represent human readable text values.
Other data types not available through the standard registry editors include:
  • REG_DWORD_LITTLE_ENDIAN - A 32-bit number in little-endian format.
  • REG_DWORD_BIG_ENDIAN - A 32-bit number in big-endian format.
  • REG_LINK - A Unicode symbolic link. Used internally; applications should not use this type.
  • REG_NONE - No defined value type.
  • REG_QWORD - A 64-bit number.
  • REG_QWORD_LITTLE_ENDIAN - A 64-bit number in little-endian format.
  • REG_RESOURCE_LIST - A device-driver resource list.

Editing the Registry

The Registry Editor (REGEDIT.EXE) is included with most version of Windows (although you won't find it on the Start Menu) it enables you to view, search and edit the data within the Registry. There are several methods for starting the Registry Editor, the simplest is to click on the Start button, then select Run, and in the Open box type "regedit", and if the Registry Editor is installed it should now open and look like the image below.

Picture of regedit.exe

An alternative Registry Editor (REGEDT32.EXE) is available for use with Windows NT/2000, it includes some additional features not found in the standard version, including; the ability to view and modify security permissions, and being able to create and modify the extended string values REG_EXPAND_SZ & REG_MULTI_SZ.

Create a Shortcut to Regedit
This can be done by simply right-clicking on a blank area of your desktop, selecting New, then Shortcut, then in the Command line box enter "regedit.exe" and click Next, enter a friendly name (e.g. 'Registry Editor') then click Finish and now you can double click on the new icon to launch the Registry Editor.

Using Regedit to modify your Registry
Once you have started the Regedit you will notice that on the left side there is a tree with folders, and on the right the contents (values) of the currently selected folder.

Like Windows explorer, to expand a certain branch (see the structure of the registry section), click on the plus sign [+] to the left of any folder, or just double-click on the folder. To display the contents of a key (folder), just click the desired key, and look at the values listed on the right side. You can add a new key or value by selecting New from the Edit menu, or by right-clicking your mouse. And you can rename any value and almost any key with the same method used to rename files; right-click on an object and click rename, or click on it twice (slowly), or just press F2 on the keyboard. Lastly, you can delete a key or value by clicking on it, and pressing Delete on the keyboard, or by right-clicking on it, and choosing Delete.

Note: it is always a good idea to backup your registry before making any changes to it. It can be intimidating to a new user, and there is always the possibility of changing or deleting a critical setting causing you to have to reinstall the whole operating system. It's much better to be safe than sorry!

Importing and Exporting Registry Settings

A great feature of the Registry Editor is it's ability to import and export registry settings to a text file, this text file, identified by the .REG extension, can then be saved or shared with other people to easily modify local registry settings. You can see the layout of these text files by simply exporting a key to a file and opening it in Notepad, to do this using the Registry Editor select a key, then from the "Registry" menu choose "Export Registry File...", choose a filename and save. If you open this file in notepad you will see a file similar to the example below:

REGEDIT4

[HKEY_LOCAL_MACHINE\SYSTEM\Setup]
"SetupType"=dword:00000000
"CmdLine"="setup -newsetup"
"SystemPrefix"=hex:c5,0b,00,00,00,40,36,02

The layout is quite simple, REGEDIT4 indicated the file type and version, [HKEY_LOCAL_MACHINE\SYSTEM\Setup] indicated the key the values are from, "SetupType"=dword:00000000 are the values themselves the portion after the "=" will vary depending on the type of value they are; DWORD, String or Binary.

So by simply editing this file to make the changes you want, it can then be easily distributed and all that need to be done is to double-click, or choose "Import" from the Registry menu, for the settings to be added to the system Registry.

Deleting keys or values using a REG file
It is also possible to delete keys and values using REG files. To delete a key start by using the same format as the the REG file above, but place a "-" symbol in front of the key name you want to delete. For example to delete the [HKEY_LOCAL_MACHINE\SYSTEM\Setup] key the reg file would look like this:

REGEDIT4

[-HKEY_LOCAL_MACHINE\SYSTEM\Setup]

The format used to delete individual values is similar, but instead of a minus sign in front of the whole key, place it after the equal sign of the value. For example, to delete the value "SetupType" the file would look like:

REGEDIT4

[HKEY_LOCAL_MACHINE\SYSTEM\Setup]
"SetupType"=-

Use this feature with care, as deleting the wrong key or value could cause major problems within the registry, so remember to always make a backup first.

Regedit Command Line Options
Regedit has a number of command line options to help automate it's use in either batch files or from the command prompt. Listed below are some of the options, please note the some of the functions are operating system specific.

regedit.exe [options] [filename] [regpath]
[filename] | Import .reg file into the registry
/s [filename] | Silent import, i.e. hide confirmation box when importing files
/e [filename] [regpath] | Export the registry to [filename] starting at [regpath] e.g. regedit /e file.reg HKEY_USERS\.DEFAULT
/L:system | Specify the location of the system.dat to use
/R:user | Specify the location of the user.dat to use
/C [filename] | Compress (Windows 98)
/D [regpath] | Delete the specified key (Windows 98)

Maintaining the Registry

How can you backup and restore the Registry?

Windows 95
Microsoft included a utility on the Windows 95 CD-ROM that lets you create backups of the Registry on your computer. The Microsoft Configuration Backup program, CFGBACK.EXE, can be found in the \Other\Misc\Cfgback directory on the Windows 95 CD-ROM. This utility lets you create up to nine different backup copies of the Registry, which it stores, with the extension RBK, in your \Windows directory. If your system is set up for multiple users, CFGBACK.EXE won't back up the USER.DAT file.

After you have backed up your Registry, you can copy the RBK file onto a floppy disk for safekeeping. However, to restore from a backup, the RBK file must reside in the \Windows directory. Windows 95 stores the backups in compressed form, which you can then restore only by using the CFGBACK.EXE utility.

Windows 98
Microsoft Windows 98 automatically creates a backup copy of the registry every time Windows starts, in addition to this you can manually create a backup using the Registry Checker utility by running SCANREGW.EXE from Start | Run menu.

What to do if you get a Corrupted Registry
Windows 95, 98 and NT all have a simple registry backup mechanism that is quite reliable, although you should never simply rely on it, remember to always make a backup first!

Windows 95
In the Windows directory there are several hidden files, four of these will be SYSTEM.DAT & USER.DAT, your current registry, and SYSTEM.DA0 & USER.DA0, a backup of your registry. Windows 9x has a nice reature in that every time it appears to start successfully it will copy the registry over these backup files, so just in case something goes wrong can can restore it to a known good state. To restore the registry follow these instruction:

1. Click the Start button, and then click Shut Down.

2. Click Restart The Computer In MS-DOS Mode, then click Yes.

3. Change to your Windows directory. For example, if your Windows directory is c:\windows, you would type the following:

cd c:\windows

4. Type the following commands, pressing ENTER after each one. (Note that SYSTEM.DA0 and USER.DA0 contain the number zero.)

attrib -h -r -s system.dat
attrib -h -r -s system.da0
copy system.da0 system.dat
attrib -h -r -s user.dat
attrib -h -r -s user.da0
copy user.da0 user.dat

5. Restart your computer.

Following this procedure will restore your registry to its state when you last successfully started your computer.

If all else fails, there is a file on your hard disk named SYSTEM.1ST that was created when Windows 95 was first successfully installed. If necessary you could also change the file attributes of this file from read-only and hidden to archive to copy the file to C:\WINDOWS\SYSTEM.DAT.

Windows NT
On Windows NT you can use either the "Last Known Good" option or RDISK to restore to registry to a stable working configuration.

How can I clean out old data from the Registry?
Although it's possible to manually go through the Registry and delete unwanted entries, Microsoft provides a tool to automate the process, the program is called RegClean. RegClean analyzes Windows Registry keys stored in a common location in the Windows Registry. It finds keys that contain erroneous values, it removes them from the Windows Registry after having recording those entries in the Undo.Reg file. You can download this free utility from our downloads page.


Registry Guide : Windows : Windows Explorer : Search

Home : Windows : Windows Explorer : Search

Search for All File Types (Windows XP)
Windows normally only includes registered file types when searching for files and folders. This tweak can be used to enable searching of all file types.

Change the Number of Active Directory Search Results (Windows 2000/XP)
This setting specifies the number of search results to be returned from a Active Directory query. This allows you to increase or decrease the default 10,000 objects.

Use Classic Search in Explorer (Windows XP)
This tweak allows you to disable the new Search Assistant and use the traditional search interface in Explorer.

Show Filter in Active Directory Search Results (Windows 2000/XP)
This setting controls whether a filter box, which allows you to filter based on additional parameters, is shown above the Active Directory search results.

Hide the Search Button on the Explorer Toolbar (Windows 2000/XP)
This restriction allows you to remove the search button from the "Standard Buttons" toolbar in Windows Explorer.

Change Default Search Options (Windows XP)
These settings allow you to change the default search options used to search for files and folders on Windows XP.


Registry Guide : Software : Microsoft Office : Word

Home : Software : Microsoft Office : Word

Use Auto-Complete in Word File Dialog Boxes (All Windows)
When you type a file name in the Open, Save, or Save As dialog box, Word may automatically try to complete the file name for you. This tweak can be used to enable or disable this behaviour.

Change the Cache Size for Network Word Documents (All Windows)
When Microsoft Word 2002 reads a file from a network location (UNC), it reads the file into the default 64 kilobyte (KB) page buffer memory. With larger documents this may not be sufficient and cause a delay as changes are made to the document. This tweak allows you to increase the buffer size so that the whole document can be read at once.

Configure the Network Path Preference in Word (All Windows)
This setting allows you to configure Microsoft Word to retain file path information when you work with files on a network server, either as a mapped drive (Z:\Folder_Name\File_Name) or as Universal Naming Convention (\\Share_Name\File_Name).

Reset Microsoft Word Settings and Recent Files (All Windows)
This setting can be used to reset the Word parameters back to the default if you are experiencing problems. For example if you start Word and one of your toolbars or menu bars is missing, or if your personalized settings are not retained.

Enable Wide Text Printing in Microsoft Word (All Windows)
When you print a document that contains extended characters, such as Greek symbols, to certain printers that do not support Unicode characters, the extended characters may be printed as square boxes. This tweak should resolve the problem on most printers.

Disable Multi-User Editing in Microsoft Word (All Windows)
Multi-user editing is a new feature in Word 2002 and Office XP which allows you to open a document that is locked for editing by another user, edit a local copy of the document, and then merge those changes into the original document.

Live Scrolling in Microsoft Word (All Windows)
Normally when you move through a Word document using the scroll bar the page doesn't update until you release the mouse button. With this tweak the document location is updated as you move.


Copyright Notice

Copyright Notice

All content and graphics within this software are protected by U.S. copyright and international treaties and may not be copied without the express permission of WinGuides.com, which reserves all rights. The materials herein are made available for informational and noncommercial uses offline only, provided the content and/or graphics are not modified in any way and all copyright and other notices on any copy are retained.

Permission to use content may be granted on a case-by-case basis. WinGuides.com welcomes such requests. Please direct any inquiries to info@winguides.com.

DO NOT copy or adapt the design or layout herein which is also covered by copyright. Elements of WinGuides.com websites and software are protected by trade dress, trademark, unfair competition, and other laws and may not be copied or imitated in whole or in part.

Any rights not expressly granted herein are reserved.

Microsoft, Windows, Windows NT and/or other Microsoft products referenced herein are either trademarks or registered trademarks of Microsoft. The names of actual companies and products mentioned herein may be the trademarks of their respective owners.


Hide the Last User Name (All Windows)

Hide the Last User Name (All Windows)
Category: Home > Windows > Login and Authentication

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting can be used to blank the username box on the logon screen. This will prevent people that are logging on from knowing the last user to access the system.

Open your registry and find the key for your Windows version below.

Windows 98 or Me
Open [HKEY_LOCAL_MACHINE\Network\Logon] and create new string value called "DontShowLastUser" and set it to "1" to hide the last user.

Windows 2000 or XP
Open [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\System] and create a new string value, or modify the existing value, called "DontDisplayLastUserName" and set it to "1" to enable or "0" to disable the restriction.

Windows NT
Open [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon] and create a new string value, or modify the existing value, called "DontDisplayLastUserName" and set it to "1" to enable or "0" to disable the restriction.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DontDisplayLastUserName | REG_DWORD | "1" [Windows 2K, XP] | |
| |  | DontShowLastUser | REG_SZ | "1" [Windows 98, Me] | |
-
| HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Sy... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
Name: DontDisplayLastUserName
Type: REG_SZ (String Value)
Value: (1 = remove username, 0 = display username)

Related Tweaks

  • Restrict Showing the Last Username (Windows 2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 24, 2002


Short Filenames on NTFS Partitions (Windows NT/2000/XP)

Short Filenames on NTFS Partitions (Windows NT/2000/XP)
Category: Home > Windows > File System > Files and Shortcuts

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether MS-DOS compatible 8.3 file names should be generated on NTFS partitions. Disabling this feature can increase the performance on high usage partitions that have large amount of files with long filenames.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, called "NtfsDisable8dot3NameCreation" and set it to "1" to disable 8.3 name creation.

Restart Windows for the change to take effect.

Note: Some installation programs may have problems with this option enabled, you can either re-enabled 8.3 creation during the install or use directory names in the short format i.e. "c:\progra~1\applic~1".

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NtfsDisable8dot3NameCreation | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem]
Name: NtfsDisable8dot3NameCreation
Type: REG_DWORD (DWORD Value)
Value: (0=disable, 1=enable)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 21, 2003


Enable Command Completion (Windows NT/2000/XP)

Enable Command Completion (Windows NT/2000/XP)
Category: Home > Windows > Accessories > Command Processor

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Command completion allows you to type a portion of a file name, and then have the system complete the rest by pressing the specified key. This is similar to the UNIX shell command completion feature.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, called 'CompletionChar' and set it to equal the hex value of the required control character. For example to use the TAB key set the value to '9', to use BackSpace set the value to '8', to use Ctrl-D set the value to '4' and for Ctrl-F set the value to '6'.

Exit your registry, you may need to restart Windows for the change to take effect.

Now when you type the first part of a filename then press the specified key, Windows will complete the filename for you. Pressing the key multiple times will scroll through all the options.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | CompletionChar | REG_DWORD | 0x00000009 (9) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Command Processor |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Command Processor]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Command Processor]
Name: CompletionChar
Type: REG_DWORD (DWORD Value)
Value: Hex Control Character

Related Tweaks

  • Enable Directory Completion (Windows 2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 19, 2003


Automatic Hidden Shares (Windows NT/2000/XP)

Automatic Hidden Shares (Windows NT/2000/XP)
Category: Home > Security > Network

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When networking has been installed on a Windows machine, it will automatically create hidden shares to the local disk drives. It is possible to disable the sharing at run-time, but this tweak will stop the automatic sharing altogether.

Open your registry and find the key below.

Create a new DWORD value of either 'AutoShareWks' for NT Workstation or 'AutoShareServer' for NT server. Then set the value to equal '0' to disable automatic sharing. If the values already exist then modify them to change the value.

Restart Windows and the automatic shares should not be created.

Note: The shares are normally accessed via \\server\c$ and \\server\d$ depending on the drive letter.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AutoShareWks | REG_DWORD | 0x00000000 (0) | |
| |  | AutoShareServer | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parame... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\
Parameters]
Name: AutoShareServer, AutoShareWks
Type: REG_DWORD (DWORD Value)
Value: (0 = disable shares, 1 = enable)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 3, 2002


Run Inserted CD-ROMs Automatically (All Windows)

Run Inserted CD-ROMs Automatically (All Windows)
Category: Home > Windows > Troubleshooting

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When you insert a data disc into the CD-ROM drive, it may not be run automatically, changing this setting should correct the problem.

Open your registry and find the key below.

Create a new Binary value, or modify the existing value called 'NoDriveTypeAutoRun' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoDriveTypeAutoRun | REG_BINARY | 95 00 00 00 [*Windows 95,98,Me] | |
| |  | NoDriveTypeAutoRun | REG_DWORD | 0x00000095 (149) [*Windows NT,2000,XP] | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoDriveTypeAutoRun
Type: REG_BINARY (Binary Value)
Value: 95 00 00 00

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 15, 2002


Control the CD-ROM Autorun Function (Windows NT/2000/XP)

Control the CD-ROM Autorun Function (Windows NT/2000/XP)
Category: Home > Hardware > Disk Drives

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Normally when you insert a disc into your CD-ROM drive, the contents are automatically launched. This tweak allows you to disable this behavior.

Open your registry and find the key below.

Change to value of 'Autorun', or create a new DWORD value if it doesn't already exist, and set the data to equal '0' for Autorun disabled.

Restart your computer for the changes to take effect.

Note: This method disables automatically running CD-ROMs. If you want to disable automatically running CD-ROMs depending on the CD-ROM that you insert in the CD-ROM drive, you can press and hold down one of the SHIFT key while you insert the CD-ROM.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Autorun | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\CDRom |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\CDRom]
Name: Autorun
Type: REG_DWORD (DWORD Value)
Value: (0=disable, 1=enable)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 17, 2002


Change Desktop Icon Visibility (All Windows)

Change Desktop Icon Visibility (All Windows)
Category: Home > Windows > Desktop

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak allows you to control which icons are visible on your desktop. By modifying the desktop namespace you can add and remove special icons including My Computer, Inbox and Recycle Bin.

Open your registry and find the key below.

Each sub-key is a globally unique identifier (GUID) representing an icon, and the default value is usually a human-readable name for the namespace extension.

To delete an icon from your desktop step through the sub-keys until you find the key representing the icon you want to remove. Delete the sub-key and the icon should disappear after your press F5 to refresh the desktop.

To add an icon to your desktop create a new sub-key named using the CLSID from the table below and the icon should appear after your press F5 to refresh the desktop.

Below are a list of common IDs:

Description | CLSID
Administrative Tools | {D20EA4E1-3957-11d2-A40B-0C5020524153}
Briefcase | {85BBD92O-42A0-1O69-A2E4-08002B30309D}
Control Panel | {21EC2O2O-3AEA-1O69-A2DD-08002b30309d}
Fonts | {D20EA4E1-3957-11d2-A40B-0C5020524152}
History | {FF393560-C2A7-11CF-BFF4-444553540000}
Inbox | {00020D75-0000-0000-C000-000000000046}
Microsoft Network | {00028B00-0000-0000-C000-000000000046}
My Computer | {20D04FE0-3AEA-1069-A2D8-08002B30309D}
My Documents | {450D8FBA-AD25-11D0-98A8-0800361B1103}
Network Computers | {1f4de370-d627-11d1-ba4f-00a0c91eedba}
Network Connections | {7007ACC7-3202-11D1-AAD2-00805FC1270E}
Printers and Faxes | {2227A280-3AEA-1069-A2DE-08002B30309D}
Programs Folder | {7be9d83c-a729-4d97-b5a7-1b7313c39e0a}
Recycle Bin | {645FF040-5081-101B-9F08-00AA002F954E}
Scanners and Cameras | {E211B736-43FD-11D1-9EFB-0000F8757FCD}
Scheduled Tasks | {D6277990-4C6A-11CF-8D87-00AA0060F5BF}
Start Menu Folder | {48e7caab-b918-4e58-a94d-505519c795dc}
Temporary Internet Files | {7BD29E00-76C1-11CF-9DD0-00A0C9034933}
Web Folders | {BDEADF00-C265-11d0-BCED-00A0C90AB50F}

Note: Not all icons can be successfully placed on your desktop. Right-click on the icon to display the options available.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\
Desktop\NameSpace]

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: July 31, 2002


Remove Recent Documents from the Start Menu (All Windows)

Remove Recent Documents from the Start Menu (All Windows)
Category: Home > Security > Start Menu and Taskbar > Documents and Folders

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting can be used to remove the recent Documents folder from the Start Menu.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, called 'NoRecentDocsMenu' set the value to equal '1' to enable the restriction.

Exit your registry, you may need to restart for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoRecentDocsMenu | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoRecentDocsMenu
Type: REG_DWORD (DWORD Value)
Value: (0 = display, 1 = remove)

Related Tweaks

  • Remove Favorites from the Start Menu (All Windows)
  • Change the Number of Recent Documents Displayed (Windows 2000/Me/XP)
  • Clear Recent Documents When Windows Exits (All Windows)
  • Disable Recent Documents History (All Windows)
  • Remove My Documents from the Start Menu (Windows 2000/Me/XP)
  • Remove My Pictures from the Start Menu (Windows 2000/Me/XP)
  • Remove My Music from the Start Menu (Windows 2000/Me/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 19, 2003


Remove Log Off from the Start Menu (All Windows)

Remove Log Off from the Start Menu (All Windows)
Category: Home > Security > Network

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak allows you to remove the Log Off [Username] option from the Start menu.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoLogOff' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: In older version of Windows this value may be REG_BINARY.

Note: This setting relies in Internet Explorer 4.0 or greater being installed.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoLogOff | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoLogOff
Type: REG_DWORD (DWORD Value)
Value: (1 = no log off, 0 = show log off)

Related Tweaks

  • Force Logoff on the Start Menu (Windows 2000/XP)
  • Restrict the Start Menu Log Off Option (Windows 2000/Me/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 19, 2003


Remove Favorites from the Start Menu (All Windows)

Remove Favorites from the Start Menu (All Windows)
Category: Home > Security > Start Menu and Taskbar > Documents and Folders

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak allows you to remove the Favorites folder from the Start Menu.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, called 'NoFavoritesMenu' and set the value to '1' to disable the Favorites folder.

Exit you registry and restart for the change to take effect.

Note: This restriction can be used either on a user by user basis by adding it to HKEY_CURRENT_USER or on a computer wide basis by adding it to HKEY_LOCAL_MACHINE.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoFavoritesMenu | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoFavoritesMenu
Type: REG_DWORD (DWORD Value)
Value: (0 = show favorites, 1 = no favorites)

Related Tweaks

  • Remove Recent Documents from the Start Menu (All Windows)
  • Remove My Documents from the Start Menu (Windows 2000/Me/XP)
  • Remove My Pictures from the Start Menu (Windows 2000/Me/XP)
  • Remove My Music from the Start Menu (Windows 2000/Me/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 19, 2003


Change the Command Prompt Colors (Windows NT/2000/XP)

Change the Command Prompt Colors (Windows NT/2000/XP)
Category: Home > Windows > Accessories > Command Processor

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

The value DefaultColor controls the foreground and background colors used in command prompt windows. It has a default value of 0, for standard white text on a black background.

You can replace this value with a two-digit hexadecimal number, in which the first digit selects a background color and the second a foreground color. The hexadecimal codes are:

Hexadecimal value | Color
0 | Black
1 | Blue
2 | Green
3 | Aqua
4 | Red
5 | Purple
6 | Yellow
7 | White
8 | Gray
9 | Light Blue
A | Light Green
B | Light Aqua
C | Light Red
D | Light Purple
E | Light Yellow
F | Bright White

A value of F0, for example, would give black text on a white background, and 1E would yield yellow text on a blue background.

The change should take effect the next time you open a console window.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | DefaultColor | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Command Processor |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Command Processor]
Name: DefaultColor
Type: REG_DWORD (DWORD Value)
Value: (0 = default)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 16, 2002


Automatic Logon to Windows NT, 2000 and XP (Windows NT/2000/XP)

Automatic Logon to Windows NT, 2000 and XP (Windows NT/2000/XP)
Category: Home > Security > Login and Authentication

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows includes a feature that allows you to configure the computer to automatically logon to the network, bypassing the Winlogon dialog box.

To enable this function you need to add several new values to the key below.

  1. Add a new string value named 'DefaultUserName' and set it to the username you wish to automatically logon as.
  2. Add a new string value named 'DefaultPassword' and set this to the password for the user entered above.
  3. Add a new string value named 'DefaultDomainName' and set this to the domain of the user. Ignore this value if the NT box is not participating in NT Domain security.
  4. Add a new string value named 'AutoAdminLogon' and set it to either '1' to enable auto logon or '0' to disable it.
  5. For Windows 2000 the additional ForceAutoLogon setting must be enabled to stop the tweak from resetting on reboot.
Exit and restart, Windows should not ask for a password and automatically show the desktop of the user.

Note: The password is stored in registry, which means anyone who has access to the machine has access to the password.

Note: You can bypass this function by holding down the SHIFT key during the boot or logoff process.

Note: It is also important to note that if the DontDisplayLastUserName value is enabled, the auto logon feature does not function.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AutoAdminLogon | REG_SZ | "1" | |
| |  | DefaultUserName | REG_SZ | "jbloggs" | |
| |  | DefaultPassword | REG_SZ | "blog123" | |
| |  | DefaultDomainName | REG_SZ | "BLOGLAND" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: AutoAdminLogon
Type: REG_SZ (String Value)
Value: (0=disable, 1=enable)

Related Tweaks

  • Automatic Logon to Windows 95, 98 and Me (Windows 95/98/Me)
  • Limit the Number of Automatic Logins (Windows NT/2000/XP)
  • Force the Use of Automatic Logon (Windows 2000/XP)
  • Disable the Auto Logon Shift Override Feature (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: July 4, 2003


Remote Access Service (RAS) Device Logging (Windows NT/2000)

Remote Access Service (RAS) Device Logging (Windows NT/2000)
Category: Home > Windows > Troubleshooting > Logging

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Creates a file called DEVICE.LOG in the %SYSTEMROOT%\SYSTEM32\RAS folder for information about commands that the modem is sending and errors that are reported. This file can be very useful in debugging RAS failures.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'Logging' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Logging | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RasMan\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RasMan\Parameters]
Name: Logging
Type: REG_DWORD (DWORD Value)
Value: (0=disable, 1=enable)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 16, 2002


Remote Access Service (RAS) PPP Logging (Windows NT/2000)

Remote Access Service (RAS) PPP Logging (Windows NT/2000)
Category: Home > Windows > Troubleshooting > Logging

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Creates a file called PPP.LOG in the %SYSTEMROOT%\SYSTEM32\RAS folder to help diagnose connectivity problems between a PPP server and a PPP client when one of the computers is a Windows NT Remote Access Service client.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'Logging' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Logging | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RasMan\PPP |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RasMan\PPP]
Name: Logging
Type: REG_DWORD (DWORD Value)
Value: (0=disable, 1=enable)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 14, 2002


Disable Save Password Option in Dial-Up Networking (Windows NT/2000)

Disable Save Password Option in Dial-Up Networking (Windows NT/2000)
Category: Home > Security > Network

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When you dial a phonebook entry in Dial-Up Networking (DUN), you can use the 'Save Password' option so that your DUN password is cached and you will not need to enter it on successive dial attempts. This key disables that option.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'DisableSavePassword' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DisableSavePassword | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RasMan\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RasMan\Parameters]
Name: DisableSavePassword
Type: REG_DWORD (DWORD Value)
Value: (0=disable, 1=enable)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 27, 2002


Change the Menu Show Delay (All Windows)

Change the Menu Show Delay (All Windows)
Category: Home > Windows > Appearance > Effects and Menus

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows normally delays menus before they are displayed. For regular users this delay can become annoying, with this setting you to change the delay time or remove it altogether.

Open your registry and find the key below.

Create a new string value, or modify the existing value, named 'MenuShowDelay' and set it to equal the delay you would like before the menus are shown as a time in milliseconds.

Log off or restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | MenuShowDelay | REG_SZ | "400" | |
-
| HKEY_CURRENT_USER\Control Panel\Desktop |
-

Settings:
User Key: [HKEY_CURRENT_USER\Control Panel\Desktop]
Name: MenuShowDelay
Type: REG_SZ (String Value)
Value: 0-999 (milliseconds)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 13, 2002


Active Window Tracking (All Windows)

Active Window Tracking (All Windows)
Category: Home > Hardware > Mice and Keyboards

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak allows you to bring running programs to the foreground just by moving you mouse of the application window. This is similar to the X-Mouse feature found on UNIX operating systems.

Open your registry and find the key below.

Active window tracking is controlled by the existing binary value called "UserPreferencemask" for Windows 95/98/Me or "UserPreferencesMask" for Windows 2000/XP.

To enable Active Window Tracking you need to add "0x1" hex to the existing value, to force the window to also come to the foreground you need to add "0x41" hex.

If the current value is "be, 3e, 00, 00" using a calculator add "be" (hex) and "41" (hex), the total equals "ff" (hex). Therefore change the value "be" to "ff" and it now becomes "ff, 3e, 00 00".

You can also create an additional DWORD value called "ActiveWndTrkTimeout" under [HKEY_CURRENT_USER\Control Panel\Mouse] which specifies the time (in milliseconds) that the mouse needs to remain over a window before the window is activated.

Restart Windows for the changes to take effect.

Windows NT

Open your registry and find the key [HKEY_CURRENT_USER\Control Panel\Desktop]

Create a new DWORD value, or modify the existing value, named 'ActiveWindowTracking' and set it to equal '1' for enabled or '0' for disabled.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ActiveWindowTracking | REG_DWORD | 0x00000001 (1) | |
| |  | ActiveWndTrkTimeout | REG_DWORD | 0x000003e8 (1000) | |
| |  | UserPreferencemask | REG_BINARY | ff,3e,00,00 | |
-
| HKEY_CURRENT_USER\Control Panel\Desktop |
-

Settings:
User Key: [HKEY_CURRENT_USER\Control Panel\Desktop]
Name: UserPreferencemask, UserPreferencesMask, ActiveWindowTracking, ActiveWndTrkTimeout, Focus
Value: (0=disable, 1=enable)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 10, 2002


Control the Windows Animation Function (All Windows)

Control the Windows Animation Function (All Windows)
Category: Home > Windows > Appearance > Effects and Menus

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Although the animation function can make animated Windows look good, it can also slow down your PC if you have a slower graphics card. This setting allows you to control whether the function is enabled or disabled.

Open your registry and find the key below.

Create a new string value, or modify the existing value, named "MinAnimate" and set it to '0' to disable the animation or '1' to enable it.

Restart or log off Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | MinAnimate | REG_SZ | "0" | |
-
| HKEY_CURRENT_USER\Control Panel\Desktop\WindowMetrics |
-

Settings:
User Key: [HKEY_CURRENT_USER\Control Panel\Desktop\WindowMetrics]
Name: MinAnimate
Type: REG_SZ (String Value)
Value: (0=disable, 1=enable)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 5, 2001


Change the Color of Compressed Files and Folders (Windows NT/2000/XP)

Change the Color of Compressed Files and Folders (Windows NT/2000/XP)
Category: Home > Windows > Appearance

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When a file is compressed in Windows there is an option in Explorer to display it in a different color to easily distinguish them. This setting defines what color to use, the default is blue.

Open your registry and find the key below.

Create a new binary value, or modify the existing value, named "AltColor" and set it to equal the hexadecimal RGB color value for the files and folders.

Restart Windows for the change to take effect.

Note: The option to "Display compressed files and folders with alternate color" must be enabled in explorer.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AltColor | REG_BINARY | 00 00 ff 00 | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer]
Name: AltColor
Type: REG_BINARY (Binary Value)
Value: 00 00 ff 00 (default)

Related Tweaks

  • Change the Color of Encrypted Files (Windows XP)
  • Show Compressed Files in an Alternate Color (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 19, 2002


Legal Notice Dialog Box Before Logon (All Windows)

Legal Notice Dialog Box Before Logon (All Windows)
Category: Home > Security > Login and Authentication

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Use these fields to create a dialog box that will be presented to any user before logging onto the system. This is useful where you are required by law to warn people that it is illegal to attempt to logon without being an authorized user.

Open your registry and find the appropriate key for your operating system.

Windows 95, 98 and Me:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Winlogon

Windows NT, 2000 and XP:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Modify the value named 'LegalNoticeCaption' to represent the caption on the dialog box (e.g. 'WARNING!'). If this value doesn't already exist create it.

Modify the value named 'LegalNoticeText' to represent the body of the dialog box (e.g. 'Do Not Attempt to Logon to this system unless you are an authorized user!')

Exit your registry and restart Windows, and the next time you boot up you should be presented with the dialog box before logging on.

Note: This value is limited to 256 characters, you need to install the latest Windows NT service pack to allow up to 1024 characters.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | LegalNoticeCaption | REG_SZ | "Password Required" | |
| |  | LegalNoticeText | REG_SZ | "Do not attempt to logon to..." | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
Name: LegalNoticeCaption, LegalNoticeText
Type: REG_SZ (String Value)

Related Tweaks

  • Customize the Windows Logon and Security Dialog Title (Windows NT/2000/XP)
  • Change the Message Shown on the Logon Box (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 12, 2002


Automatically View Thumbnails of Bitmap Files (All Windows)

Automatically View Thumbnails of Bitmap Files (All Windows)
Category: Home > Windows > Appearance > Fonts and Icons

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Makes Explorer show a thumbnail version of bitmaps files in the current folder rather than the generic icon ordinarily used. This is a great way to preview .BMP files without having to open them first.

Open your registry and find the key below.

Modify the value of (Default) to equal '%1'.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | "%1" | |
-
| HKEY_CLASSES_ROOT\Paint.Picture\DefaultIcon |
-

Settings:
System Key: [HKEY_CLASSES_ROOT\Paint.Picture\DefaultIcon]
Name: (Default)
Type: REG_SZ (String Value)
Value: %1

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 22, 2002


Optimize Internet Connection Speed (Windows 95/98/Me)

Optimize Internet Connection Speed (Windows 95/98/Me)
Category: Home > Network > Internet and Remote Access

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

By optimizing the MaxMTU & MaxMSS settings along with the RWIN and TTL settings you can increase dialup modem and broadband connection reliability and performance by as much as 200%.

What is the MTU and MSS?

MTU stands for Maximum Transmission Unit and in basic terms, it defines the maximum size of a packet that can be transferred in one frame over a network.

MSS or Maximum Segment Size defines how much actual data can put in that packet, and it is therefore a marginally smaller value than MTU to allow for packet addressing and other information.

Why do the default values need to be changed?

By default Windows hard codes the value of MTU to equal 1500 bytes. This value is adequate for normal LAN networking, but when your connecting to the Internet with a modem this value is too high. This can show itself in different ways, the most noticeable affect is less than peak performance.

By adjusting this value to more closely match the requirements of a modem Internet connection huge performance gains can be achieved.

Below are the instructions on how to modify these values for yourself. Please remember though, modifying the Windows registry is not for the faint hearted. Always remember to back it up first!

  1. To change the settings you first have to find the details of your Dial-Up Adapter. Open your registry and find the key [HKEY_LOCAL_MACHINE\Enum\Root\Net] and within there will be one or more sub-keys such as 0000, 0001 ... 000x

  2. Open each sub-key and find the one that contains the value of 'DeviceDesc' equal to 'Dial-Up Adapter'.

  3. Within that key there will also be another sub-key named 'Bindings'. Open the 'Bindings' sub-key and you will find a string name like 'MSTCP\0000'. Take note of the four digit number after 'MSTCP' (in this case 0000) and use it in the next step.

  4. Now go to the key [HKEY_LOCAL_MACHINE\Enum\Network\MSTCP] and expand the sub-key with the same four digit number as from the previous step.

  5. In this key you will find a value called 'Driver' and it will be equal to something similar to 'NetTrans\0002'. Take note of this four digit number (in this case 0002) and use it in the next step.

  6. Now open the key [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans] below there will be one or more sub-key's. Expand the key with the name equal to the four digit number from the previous step.

  7. Within this key create two new string value named 'MaxMTU' and 'MaxMSS' and set them to the values from the list below. Note: MaxMSS is usually equal to MaxMTU - 40 (the standard IP header size).
    • Dialup Modem
      MaxMTU = "576", MaxMSS = "536"
    • Broadband Cable or DSL
      MaxMTU = "1500", MaxMSS = "1460"
    • Broadband (with PPPOE)
      MaxMTU = "1492", MaxMSS = "1452"
Exit the registry and restart your Windows for the changes to take effect.

Note: In some versions of the Windows TCP/IP stack the MaxMSS value may be unnecessary but it is included here for completeness.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | MaxMTU | REG_SZ | "576" | |
| |  | MaxMSS | REG_SZ | "536" | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans]
Name: MaxMTU, MaxMSS
Type: REG_SZ (String Value)

Related Tweaks

  • Cable Modem and DSL Speed Tweak to Increase Performance (Windows 95/98/Me)
  • Optimize the DefaultRcvWindow & DefaultTTL Settings (Windows 95/98/Me)
  • Change the Maximum Transmission Unit (MTU) Size (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 16, 2002


Optimize the DefaultRcvWindow & DefaultTTL Settings (Windows 95/98/Me)

Optimize the DefaultRcvWindow & DefaultTTL Settings (Windows 95/98/Me)
Category: Home > Network > Internet and Remote Access

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

The optimization of RcvWindow and DefaultTTL along with other registry settings such as MaxMTU and MaxMSS can speed up TCPIP modem and Internet connections.

RWIN (Receive WINdow) is the buffer your machine waits to fill with data before attending to whatever other TCP transactions are occurring on the other threads and sockets WinSock has open while a connection is in progress.

The value of TTL (Time To Live) defines how long a packet can stay active before being discarded. The default value is '32'.

1. Open your registry and find the key below.

2. Create a new string value named 'DefaultRcvWindow' and set it to '4288'. If 'DefaultRcvWindow' already exists, then simply modify the current value.

3. Also create another string value named 'DefaultTTL' under the same key and set that to '128'. Again if it already exist, simply modify the value.

4. Exit the registry and restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | DefaultRcvWindow | REG_SZ | "4288" | |
| |  | DefaultTTL | REG_SZ | "128" | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: DefaultRcvWindow, DefaultTTL
Type: REG_SZ (String Value)

Related Tweaks

  • Optimize Internet Connection Speed (Windows 95/98/Me)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 27, 2002


Change the Registered Owner and Organization (All Windows)

Change the Registered Owner and Organization (All Windows)
Category: Home > Windows

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

If you entered the wrong registration information when you installed Windows you can change it and other miscellaneous settings such as ProductID and ProductName.

Open your registry and find the key below for your operating system.

Windows 95, 98 and Me:
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion]

Windows NT, 2000 and XP:
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion]

Modify the strings values of 'RegisteredOwner' and 'RegisteredOrganization' to equal the required owner and company names.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | RegisteredOwner | REG_SZ | "Joe Bloggs" | |
| |  | RegisteredOrganization | REG_SZ | "ACME, Inc." | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion |
-

Settings:
Name: RegisteredOwner, RegisteredOrganization
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 12, 2002


Creating a Shortcut to the System Folders (All Windows)

Creating a Shortcut to the System Folders (All Windows)
Category: Home > Windows > File System > Files and Shortcuts

This function allow you to add a shortcut to various system folders on your Desktop or Start Menu.

Create a new folder on your desktop and name it "Control Panel.{21EC2020-3AEA-1069-A2DD-08002B30309D}" It should look like the normal Control Panel icon (not a shortcut). You can now move the icon anywhere on your desktop or start menu.

The same can be achieved for others by substituting these values:

For Dial Up Networking
Dial-Up Networking.{992CFFA0-F557-101A-88EC-00DD010CCC48}

For Printers
Printers.{2227A280-3AEA-1069-A2DE-08002B30309D}

For Control Panel
Control Panel.{21EC2020-3AEA-1069-A2DD-08002B30309D}

My Computer
My Computer.{20D04FE0-3AEA-1069-A2D8-08002B30309D}

For Network Neighborhood
Network Neighborhood.{208D2C60-3AEA-1069-A2D7-08002B30309D}

For the Inbox
InBox.{00020D75-0000-0000-C000-000000000046}

For the Recycle Bin
Recycle Bin.{645FF040-5081-101B-9F08-00AA002F954E}

For more check out the HKEY_CLASSES_ROOT\CLSID key.

Settings:
System Key: [HKEY_CLASSES_ROOT\CLSID]

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 16, 1998


Display High Color Icons (All Windows)

Display High Color Icons (All Windows)
Category: Home > Windows > Appearance > Fonts and Icons

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

If you like a bit more quality and detail in your icons, then this setting allows you to change the number of colors used to display icons. Show your Windows icons in all their high resolution glory.

Open your registry and find the key below.

Create a new string value named "Shell Icon BPP" and change it to equal the color depth supported by your video card:

  • 4 - 16 colors
  • 8 - 256 colors
  • 16 - 65536 colors
  • 24 - 16.7 million colors

Restart Windows for the change to take effect.

Note: You need a graphics card capable of displaying above 256 colors for this to be effective.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Shell Icon BPP | REG_SZ | "16" | |
-
| HKEY_CURRENT_USER\Control Panel\Desktop\WindowMetrics |
-

Settings:
User Key: [HKEY_CURRENT_USER\Control Panel\Desktop\WindowMetrics]
Name: Shell Icon BPP
Type: REG_SZ (String Value)
Value: 4, 8, 16, 24 (bits per pixel)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 9, 2002


Easily Use Notepad to Open a File (All Windows)

Easily Use Notepad to Open a File (All Windows)
Category: Home > Windows > Accessories

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Enabling this setting will allow you to use Notepad to open a file by simply right clicking on the icon. Also the Notepad will be used to open the files by default if no association already exists.

Open your registry and find the key "HKEY_CLASSES_ROOT\*\shell", if it doesn't already exist then create it.

Under shell create a new key called open, and edit the string "(Default)" to read "Open With Notepad".

Under open create a new key called command, and edit the string "(Default)" to read "notepad.exe %1".

Now when you right click on a file you should see "Open with Notepad" as one of the options.

Note: This tweak may affect the Office 97 toolbar feature and stop it from working correctly. This is because when you click an icon on the Office toolbar it activates the first context menu item, which in this case is the new "Open with Notepad" command, rather than looking for the default item.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | "notepad.exe %1" | |
-
| HKEY_CLASSES_ROOT\*\shell |
-

Settings:
System Key: [HKEY_CLASSES_ROOT\*\shell]
Name: (Default)
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 22, 2002


Add Explore From Here to Every Folder (All Windows)

Add Explore From Here to Every Folder (All Windows)
Category: Home > Windows > Windows Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When you right click on any folder this will give you an option to Explore From Here, which will open up an Explorer window of that folder.

Open your registry and find the key below, if it doesn't already exist create it.

Change the value of '(Default)' to equal 'Explore From Here'.

Create a new key under the [Explore] key called command, and edit the (Default) value to equal explorer.exe /e,/root,"%1"

Exit your registry and the change should take effect immediately.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | "explorer.exe /e,/root,"%1"" | |
-
| HKEY_CLASSES_ROOT\Directory\shell\Explore |
-

Settings:
System Key: [HKEY_CLASSES_ROOT\Directory\shell\Explore]
Name: (Default)
Type: REG_SZ (String Value)
Value: explorer.exe /e,/root,"%1"

Related Tweaks

  • Add Command Prompt Option to Every Folder (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 29, 2002


Change the Location of Windows Installation Files (All Windows)

Change the Location of Windows Installation Files (All Windows)
Category: Home > Windows

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Modifying the string will change the path that the Windows setup program will look for the installation files.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'SourcePath' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SourcePath | REG_SZ | "D:\WIN95" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup]
Name: SourcePath
Type: REG_SZ (String Value)
Value: D:\WIN95

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 12, 2002


Disable Print Job Notification in Event Viewer (Windows NT/2000/XP)

Disable Print Job Notification in Event Viewer (Windows NT/2000/XP)
Category: Home > Hardware > Printers and Plotters

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

By default Windows NT server adds an entry in the event log for every print job occurring on the spooler. This can quickly fill up the event log with redundant information.

To disable this function, change the DWORD value for EventLog to "0".

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | EventLog | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Providers |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Providers]
Name: EventLog
Type: REG_DWORD (DWORD Value)
Value: (0 = disable)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 26, 2002


Disable the NTFS Last Access Time Stamp (Windows NT/2000/XP)

Disable the NTFS Last Access Time Stamp (Windows NT/2000/XP)
Category: Home > Windows > File System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When Windows accesses a directory on an NTFS volume, it updates the LastAccess time stamp on each directory it detects. Therefore, if there are a large number of directories, this can affect performance.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, named "NtfsDisableLastAccessUpdate" and set it to "1" to prevent the LastAccess time stamp from being updated.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NtfsDisableLastAccessUpdate | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem]
Name: NtfsDisableLastAccessUpdate
Type: REG_DWORD (DWORD Value)
Value: (0 = disable, 1 = enable)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 5, 2002


Hard Disk Free Space Warning (Windows NT/2000/XP)

Hard Disk Free Space Warning (Windows NT/2000/XP)
Category: Home > Hardware > Disk Drives

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

By default Windows sends an administrative alert when the amount of free space remaining on a hard disk drive falls below 10 percent. This percentage can be configured using this setting.

Open your registry and find the key below.

Create a new DWORD value called "DiskSpaceThreshold" and set it to the percentage of free disk space remaining before an alert is sent.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DiskSpaceThreshold | REG_DWORD | 0x00000005 (5) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parame... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\
Parameters]
Name: DiskSpaceThreshold
Type: REG_DWORD (DWORD Value)
Value: 0 - 99 percent (Default is 10)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 21, 2002


Change Mouse Wheel Scroll Settings (All Windows)

Change Mouse Wheel Scroll Settings (All Windows)
Category: Home > Hardware > Mice and Keyboards

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak determines the number of lines scrolled for each rotation of the mouse wheel on a Microsoft IntelliMouse (or compatible) when no modifier keys (such as [Ctrl] or [Shift]) are pressed.

If the value of this entry is 0, the screen will not scroll when the mouse wheel is turned. If the value of this entry is greater than the number of lines visible in the window, the screen will scroll up or down by one page. To direct Windows NT to interpret all wheel rotations as page-up or page-down commands, set the value of this entry to 0xffffffff.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | WheelScrollLines | REG_SZ | "3" | |
-
| HKEY_CURRENT_USER\Control Panel\Desktop |
-

Settings:
User Key: [HKEY_CURRENT_USER\Control Panel\Desktop]
Name: WheelScrollLines
Type: REG_SZ (String Value)
Value: 0 - 0xFFFFFFFF

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 12, 2002


Control Network Browser Elections (Windows NT/2000/XP)

Control Network Browser Elections (Windows NT/2000/XP)
Category: Home > Network

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

A browser election is a normal network occurrence and provides a means to guarantee there is never more than one master browser present in a domain or workgroup.

Open your registry and find the key below.

To control which computer is the Domain Master Browser, create a new string value, or modify the existing value, named "IsDomainMaster" and set the value to equal either "Yes", "No" or "Auto".

To prevent an NT Workstation or Server (non-PDC) from acting as a browser, create a new string value, or modify the existing value, named "MaintainServerList" and set it "No", the other options are "Yes", "No" or "Auto".

Restart Windows for the change to take effect.

Note: These values may also be standard boolean values in the form "True/False" or "0/1".

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | IsDomainMaster | REG_SZ | "Yes" | |
| |  | MaintainServerList | REG_SZ | "Auto" | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Browser\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Browser\Parameters]
Name: IsDomainMaster, MaintainServerList
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 16, 2002


Manage File System Caching Memory (Windows NT/2000)

Manage File System Caching Memory (Windows NT/2000)
Category: Home > Windows > File System > Caching and Memory

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows will normally limit the amount of RAM that can be locked for file system operations. This setting allows you to modify the automatic value.

Open your registry and find the key below.

Create a new DWORD value named 'IoPageLockLimit' if it does not already exist. Set the value to equal the maximum number of Kbytes to be allocated to I/O operations as per the table below:

RAM       IoPageLockLimit
(MB)       Decimal    Hex
4           4096     1000
8           8192     2000
16         16384     4000
32         32768     8000
64         65536    10000

As with all performance related changes, get a baseline measurement using performance monitor and then make your changes in small increments and retest the performance after each change.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | IoPageLockLimit | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memo... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\
Memory Management]
Name: IoPageLockLimit
Type: REG_DWORD (DWORD Value)
Value: 0 = default

Related Tweaks

  • Optimize the System Cache Size (Windows NT/2000/XP)
  • Improve Core System Performance (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 17, 2002


Increase Network Performance and Throughput (Windows NT/2000)

Increase Network Performance and Throughput (Windows NT/2000)
Category: Home > Network

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

If you increase the number of buffers that the redirector reserves for network performance, it may increase your network throughput. Each extra execution thread that you configure will take 1k of additional nonpaged pool memory, but only if your applications actually use them.

Open your registry and find the key below.

Create new DWORD values, or modify the existing values, called:

'MaxCmds' The range is 0 - 255 and the default is 15

'MaxThreads' Set it to the same value as MaxCmds

You may also want to increase the value of 'MaxCollectionCount'. This value represents the buffer for character-mode named pipes writes. The default is 16 and the range is 0 - 65535.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | MaxCmds | REG_DWORD | 0x0000001e (30) | |
| |  | MaxThreads | REG_DWORD | 0x0000001e (30) | |
| |  | MaxCollectionCount | REG_DWORD | 0x00000020 (32) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\P... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\
Parameters]
Type: REG_DWORD (DWORD Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 17, 2003


Change the Icon Cache Size (All Windows)

Change the Icon Cache Size (All Windows)
Category: Home > Windows > Troubleshooting

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

If you desktop icons are redrawing too frequently or are corrupt, it could be because the icon cache is full. Try increasing the size by changing this setting.

Open your registry and find the key below.

Create a new string value, or modify the existing value, called "Max Cached Icons" and set it to "2000". This will increase the maximum icon cache to 2MB.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Max Cached Icons | REG_SZ | "4096" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer]
Name: Max Cached Icons
Type: REG_SZ (String Value)
Value: 100 - 4096 (default = 500)

Related Tweaks

  • Repair the Icon Cache (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 9, 2002


Hide Computer from the Browser List (Windows NT/2000/XP)

Hide Computer from the Browser List (Windows NT/2000/XP)
Category: Home > Security > Network

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

If you have a secure server or workstation you wish to hide from the general browser list, then enable this setting.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, named "Hidden" and set it to "1".

Reboot the computer. It may take up to an hour for the server to disappear from the browse list.

Hint: The same result can be achieved by executing NET CONFIG SERVER /HIDDEN:YES on the workstation

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Hidden | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parame... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\
Parameters]
Name: Hidden
Type: REG_DWORD (DWORD Value)
Value: (0 = visible, 1 = hidden)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 3, 2002


Manage Windows Short File Extensions (Windows NT/2000/XP)

Manage Windows Short File Extensions (Windows NT/2000/XP)
Category: Home > Windows > File System > Files and Shortcuts

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows evaluates file extensions on the first three characters, therefore 'filename.html' is actually treated as 'filename.htm'. Therefore if you use a command such as 'del *.htm' to delete all the '.htm' files, you will also delete all '.html' files as well.

To turn this setting off, editing the key found below and set the value of 'Win95TruncatedExtensions' to '0', to turn the feature back on, set the value back to '1'.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Win95TruncatedExtensions | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem]
Name: Win95TruncatedExtensions
Type: REG_DWORD (DWORD Value)
Value: (0 = disable , 1 = enable)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 5, 2002


Remove the Content Advisor and Ratings Password (All Windows)

Remove the Content Advisor and Ratings Password (All Windows)
Category: Home > Software > Internet Explorer > Security

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

If you have forgotten the Internet Explorer content advisor password and want to change the ratings settings then follow these instructions to change the settings back to their defaults.

All the Content Advisor settings are stored in the key below. If you no longer have the password, then simply delete the key, and all the settings will be removed.

Open your registry and find the key below. Single click on the key to highlight it, press the DELETE key, or alternatively select Delete from the Edit menu.

Close Internet Explorer, re-open it, and the Content Advisor feature should now be disabled.

Settings:
User Key: [HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\
Ratings]
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\
Ratings]

Related Tweaks

  • Content Advisor Restrictions (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 11, 2002


Rename or Delete Special Folders (All Windows)

Rename or Delete Special Folders (All Windows)
Category: Home > Windows > Desktop

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allows you to rename and delete special folders (such as the Recycle Bin) as if it was a normal folder by right-clicking the icon.

Open your registry and find the key below, where GUID is the identifier for the special folder.

Description | Globally Unique Identifier (GUID)
Administrative Tools | {D20EA4E1-3957-11d2-A40B-0C5020524153}
Briefcase | {85BBD92O-42A0-1O69-A2E4-08002B30309D}
Control Panel | {21EC2O2O-3AEA-1O69-A2DD-08002b30309d}
Fonts | {D20EA4E1-3957-11d2-A40B-0C5020524152}
History | {FF393560-C2A7-11CF-BFF4-444553540000}
Inbox | {00020D75-0000-0000-C000-000000000046}
Microsoft Network | {00028B00-0000-0000-C000-000000000046}
My Computer | {20D04FE0-3AEA-1069-A2D8-08002B30309D}
My Documents | {450D8FBA-AD25-11D0-98A8-0800361B1103}
My Network Places | {208D2C60-3AEA-1069-A2D7-08002B30309D}
Network Computers | {1f4de370-d627-11d1-ba4f-00a0c91eedba}
Network Connections | {7007ACC7-3202-11D1-AAD2-00805FC1270E}
Printers and Faxes | {2227A280-3AEA-1069-A2DE-08002B30309D}
Programs Folder | {7be9d83c-a729-4d97-b5a7-1b7313c39e0a}
Recycle Bin | {645FF040-5081-101B-9F08-00AA002F954E}
Scanners and Cameras | {E211B736-43FD-11D1-9EFB-0000F8757FCD}
Scheduled Tasks | {D6277990-4C6A-11CF-8D87-00AA0060F5BF}
Start Menu Folder | {48e7caab-b918-4e58-a94d-505519c795dc}
Temporary Internet Files | {7BD29E00-76C1-11CF-9DD0-00A0C9034933}
Web Folders | {BDEADF00-C265-11d0-BCED-00A0C90AB50F}

To change the features shown on the context menu, edit the value of "Attributes" and set it to one of the values below, the default value is "40 01 00 20".

File Features

  • 50 01 00 20 - Rename
  • 60 01 00 20 - Delete
  • 70 01 00 20 - Rename and Delete

    Edit Features

  • 41 01 00 20 - Copy
  • 42 01 00 20 - Cut
  • 43 01 00 20 - Copy and Cut
  • 44 01 00 20 - Paste
  • 45 01 00 20 - Copy and Pase
  • 46 01 00 20 - Cut and Copy
  • 47 01 00 20 - Cut, Copy and Paste

    For example to add the ability to Rename and Delete the Recycle Bin open [HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\ShellFolder] and change the value of "Attributes" to "70 01 00 20".

    The changes should take effect immediately.

    Note: On Windows XP this tweak changes the File menu not the context menu. Access the features by right-clicking "Explore" -> "File" -> Rename or Delete.

    Registry Editor Example
    | Name Type Data |
    | (Default) REG_SZ (value not set) |
    | Attributes REG_BINARY 70 01 00 20 |
    -
    | HKEY_CLASSES_ROOT\CLSID\{GUID}\ShellFolder |
    -

    Settings:
    System Key: [HKEY_CLASSES_ROOT\CLSID\{GUID}\ShellFolder]
    Name: Attributes
    Type: REG_BINARY (Binary Value)
    Value: (70 01 00 20=rename/delete, 40 01 00 20=default)

    Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

    Last Modified: August 16, 2002

    • Return to Index Copyright © 1998-2003. All Rights Reserved. License


Change the Internet Explorer Window Title (All Windows)

Change the Internet Explorer Window Title (All Windows)
Category: Home > Software > Internet Explorer > Appearance

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allows you to customize Internet Explorer by using your own window title. For example you could rename IE to 'My Browser' or anything else you like!

Open your registry and find the key below.

Create a new string value, or modify the existing value, to equal the title you would like.

Note: Delete the value of 'WindowTitle' to change the title back to the default.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Window Title | REG_SZ | "My Browser" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
Name: Window Title
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2002


Remove the Tildes in Short Filenames (Windows 95/98/Me)

Remove the Tildes in Short Filenames (Windows 95/98/Me)
Category: Home > Windows > File System > Files and Shortcuts

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When long filenames are shown in an application that only supports short filenames a tilde "~" is used to convert the long name into a compatible short name. This setting removes the use of tildes.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NameNumericTail' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: Microsoft support articles Q179370 and Q148594 have details on some possible side-effects of this tweak.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NameNumericTail | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem]
Name: NameNumericTail
Type: REG_DWORD (DWORD Value)
Value: (0=disable,1=enable)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 20, 2002


Display the Contents of Moving Windows (All Windows)

Display the Contents of Moving Windows (All Windows)
Category: Home > Windows > Appearance > Effects and Menus

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When enabled, this setting will cause Windows to display the current contents of a window while it is being dragged around the screen instead of just displaying the window outline.

Open your registry and find the key below.

Create a new string value named 'DragFullWindows', or modify the existing value, to equal '1' for enabled, or '0' for disabled.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DragFullWindows | REG_SZ | "1" | |
-
| HKEY_CURRENT_USER\Control Panel\Desktop |
-

Settings:
User Key: [HKEY_CURRENT_USER\Control Panel\Desktop]
Name: DragFullWindows
Type: REG_SZ (String Value)
Value: (0=disable, 1=enable)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 5, 2003


Add a Background Bitmap to the Internet Explorer Toolbar (All Windows)

Add a Background Bitmap to the Internet Explorer Toolbar (All Windows)
Category: Home > Software > Internet Explorer > Appearance

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Want to have you own bitmap shown on the Internet Explorer toolbar? It's simple with this registry setting.

Open your registry and find the key below.

Add a new string value, or modify the existing value, named "BackBitmap" for IE4 or "BackBitmapIE5" for IE5, then set the value to the path and name of bitmap file you wish to use (e.g. "C:\WINDOWS\CLOUDS.BMP")

Exit your registry and restart Internet Explorer for the change to take effect.

Note: To remove an existing background image, simply delete these values and IE will use the default setting.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | BackBitmap | REG_SZ | "c:\windows\clouds.bmp" | |
| |  | BackBitmapIE5 | REG_SZ | "c:\windows\clouds.bmp" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Toolbar |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Toolbar]
Name: BackBitmap or BackBitmapIE5
Type: REG_SZ (String Value)

Related Tweaks

  • Display a Background Bitmap on Explorer Toolbars (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 2, 2002


Send Plain Text Passwords (All Windows)

Send Plain Text Passwords (All Windows)
Category: Home > Security > Network

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When connecting to some SMB servers, such as Samba and LAN Manager for UNIX, you may be required to send unencypted password. This setting enables that functionality.

Open your registry and find or create the key below for your Windows version.

Windows 95 (SP1), 98 and Me
[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\VNETSUP]

Windows 2000 and XP
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkStation\Parameters]

Windows NT
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Rdr\Parameters]

Create a new DWORD value, or modify the existing value, named "EnablePlainTextPassword" and set it to equal "1" to enable plain text passwords.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | EnablePlainTextPassword | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Rdr\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Rdr\Parameters]
Name: EnablePlainTextPassword
Type: REG_DWORD (DWORD Value)
Value: (0=disable, 1=enable)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 2, 2002


Internet Explorer Intercepts the FTP Command (All Windows)

Internet Explorer Intercepts the FTP Command (All Windows)
Category: Home > Software > Internet Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When you enter a FTP command such as "FTP ftp.microsoft.com" Internet Explorer may launch instead of the DOS based FTP program.

To disable this behavior, open your registry and find the key below, then delete the value of "ftp".

To re-enable, create a new string value called "ftp" and set it to equal "ftp://".

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ftp | REG_SZ | "ftp://" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\URL\Prefixes |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\URL\
Prefixes]
Name: ftp
Type: REG_SZ (String Value)
Value: ftp://

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2002


Change the Default Mailbox Sound Setting (All Windows)

Change the Default Mailbox Sound Setting (All Windows)
Category: Home > Windows > Troubleshooting

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When you receive a new message, a sound may not be played even though "Play sound when new messages arrive" is enabled.

This registry key displays the path to the Windows 9x and NT default "new mail" sound. It is recommended to first check the sound control panel to make sure a sound is selected for New Mail notification.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | "c:\windows\beep.wav" | |
-
| HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\MailBeep\.current |
-

Settings:
User Key: [HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\MailBeep\.current]
Name: (Default)
Type: REG_SZ (String Value)
Value: Filename

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 15, 1998


Change the Logon Screen Background Color (All Windows)

Change the Logon Screen Background Color (All Windows)
Category: Home > Windows > Login and Authentication

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When you change the color scheme and appearance of your desktop it does not change the background color of the logon screen to match. This tweak allows you to change that color as well.

Open your registry and find the key below.

Modify the value named 'Background' according to the color you would like in RGB (Red/Green/Blue) format. For example, "0 0 0" for black or "255 255 255" for white, and every other color in between.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Background | REG_SZ | "0 0 0" | |
-
| HKEY_USERS\.DEFAULT\Control Panel\Colors |
-

Settings:
User Key: [HKEY_USERS\.DEFAULT\Control Panel\Colors]
Name: Background
Type: REG_SZ (String Value)
Value: 0 0 0 - 255 255 255

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 16, 2002


Add Custom Folder to My Computer or the Desktop (All Windows)

Add Custom Folder to My Computer or the Desktop (All Windows)
Category: Home > Windows > Desktop

Create your own custom system folder, like "My Documents", that can not be deleted or renamed and place it on the desktop and My Computer.

Create the following series of keys and values in the registry at [HKEY_CLASSES_ROOT\CLSID] or [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID]. The GUID, globally unique identifier, can be a random number, in this example "FD4DF9E0-E3DE-11CE-BFCF-ABCD1DE12345" is used. See this article for more GUID examples.

  1. Create a new key called [HKEY_CLASSES_ROOT\CLSID\{FD4DF9E0-E3DE-11CE-BFCF-ABCD1DE12345}] and set (Default) to equal the name of the folder e.g. "My Folder".

  2. Create a new sub-key under the main key called "DefaultIcon" (i.e. [HKEY_CLASSES...ABCD1DE12345}\DefaultIcon]) and set (Default) to equal the filename for the icon you want to display e.g. "c:\windows\myicon.ico".

  3. Create a new sub-key under the main key called "InProcServer32" (i.e. [HKEY_CLASSES...ABCD1DE12345}\InProcServer32]) and set (Default) to equal "shell32.dll", also create a new String value called "ThreadingModel" and set it to "Apartment".

  4. Create a set of sub-keys starting at the main key "Shell\Open My Menu\Command" (i.e. [HKEY_CLASSES...ABCD1DE12345}\Shell\Open My Folder\Command]) and set (Default) to equal the command to execute when clicked, in this case explorer, e.g. "explorer /root,c:\MyFolder".

  5. Create a set of sub-keys starting at the main key "ShellEx\PropertySheetHandlers\{FD4DF9E0-E3DE-11CE-BFCF-ABCD1DE12345}" (i.e. [HKEY_CLASSES...ABCD1DE12345}\ShellEx\PropertySheetHandlers\{FD4DF9E0-E3DE-11CE-BFCF-ABCD1DE12345}])

  6. Create a new sub-key under the main key called "ShellFolder" (i.e. [HKEY_CLASSES...ABCD1DE12345}\ShellFolder]) and create a new Binary value called "Attributes" and set it to "00 00 00 00".

  7. (Optional) To place the folder on the desktop add the following key:
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\
    Explorer\Desktop\NameSpace\{FD4DF9E0-E3DE-11CE-BFCF-ABCD1DE12345}]

  8. (Optional) To place the folder in My Computer add the following key:
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\
    Explorer\MyComputer\NameSpace\{FD4DF9E0-E3DE-11CE-BFCF-ABCD1DE12345}]
Now the folder cannot be deleted from the desktop or My Computer, nor can it be renamed other than removing the CLSID and the entries under NAMESPACE.

Settings:
System Key: [HKEY_CLASSES_ROOT\CLSID]
Name: CLSID
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: July 13, 2001


Remove or Change the Shortcut Arrow (All Windows)

Remove or Change the Shortcut Arrow (All Windows)
Category: Home > Windows > File System > Files and Shortcuts

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Would you prefer to display your shortcuts without the arrow in the bottom left hand corner? This tip will show you how to change the arrow icon or remove it completely.

To Remove the Icon:
Open your registry and delete the value named 'IsShortCut' from the keys [HKEY_CLASSES_ROOT\lnkfile], [HKEY_CLASSES_ROOT\piffile] and [HKEY_CLASSES_ROOT\InternetShortcut].

Windows 98 Update
An updated shell32.dll file was included in the March 7, 2000 Security Update that stopped the standard method from working correctly. The method to remove them in this version has changed slightly:

Open the key [HKEY_CLASSES_ROOT\CLSID\{63B51F81-C868-11D0-999C-00C04FD655E1}\InProcServer32] and delete the current value of "(Default)". To restore set the value of "(Default)" back to "C:\\WINDOWS\\SYSTEM\\SHELL32.DLL" where WINDOWS is your Windows directory. More information can be found in this discussion.

To Change the Icon:
Open the key [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\
Explorer\Shell Icons] and create a new string value, or modify the existing value, called '29'. Set it to equal the filename, including path, for the icon you want to use for the shortcut arrow. By setting this to a blank icon it has a similar effect to the removal method above, without the side effects.

Restart Windows for the changes to take effect.

Note: This tweak effectively changes the properties of shortcuts so they are no longer considered to be shortcuts by Windows, this may have some slight side effects, such as hot keys not working as before.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | 29 | REG_SZ | "c:\windows\system\shell32.dll,21" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Sh... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\
Shell Icons]
Name: 29
Type: REG_SZ (String Value)
Value: Icon Filename

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: July 2, 2002


Clear the Cached Run Commands (All Windows)

Clear the Cached Run Commands (All Windows)
Category: Home > Security > Privacy

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Do you have a lot of items in the run command history on Start Menu? This tweak will allow you to clear the most-recently-used (MRU) list.

Delete the value corresponding to the command you want to remove, or remove the key to clear the list completely.

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
RunMRU]

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 15, 2002


Dial-Up Networking Password Box Greyed Out (Windows 95/98/Me)

Dial-Up Networking Password Box Greyed Out (Windows 95/98/Me)
Category: Home > Network > Internet and Remote Access

If you are having problems trying to get DUN to remember your password and you find the option grayed out then there are a few things you can try.

1. Make sure you have Client for Microsoft Networks installed on your system. Control Panel / Networking / Add / Client / Microsoft / Microsoft Networking.

2. Your Windows startup is configured to ask for a password and you are hitting the esc key when the logon box is displayed.

3. You have a corrupted password file. Do a search for *.pwl in the Windows folder and rename all the files you find. Note - this will force you to rebuild your password files from scratch.

4. Check the Registry:

  • Run the Registry Editor (REGEDIT.EXE).
  • Find HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Network\Real Mode Net.
  • If you see autologon (on the right side) with a value of "00 00 00 00", double-click on it, and change the value to "01 00 00 00 00".
  • Exit RegEdit and restart the PC.

    Settings:
    System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Network\
    Real Mode Net]
    Type: REG_DWORD (DWORD Value)

    Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

    Last Modified: February 21, 2003

    • Return to Index Copyright © 1998-2003. All Rights Reserved. License


Long File Names Need to be Enabled (Windows 98)

Long File Names Need to be Enabled (Windows 98)
Category: Home > Windows > Troubleshooting

If you are receiving an error when installing Windows 98 that long file names need to enabled in order for Windows 98 to install successfully try this.

Open your registry and find the key below.

Look for an entry in the right pane named "NameNumericTail" and delete it.

Exit and reboot then retry the installation.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem]
Name: NameNumericTail
Type: REG_DWORD (DWORD Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 15, 1998


Control Automatic DNS Server Cache Updates (Windows NT/2000/XP)

Control Automatic DNS Server Cache Updates (Windows NT/2000/XP)
Category: Home > Network > Servers

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This value disables that automatic cache updated from the DNS root servers. Useful when there is a problem with the root servers, or if you wish to completely control DNS updates.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, named "AutoCacheUpdate" and set it to "0" to disable automatic updates.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AutoCacheUpdate | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\DNS\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\DNS\Parameters]
Name: AutoCacheUpdate
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2002


PCMCIA Network Power Management (Windows 95/98/Me)

PCMCIA Network Power Management (Windows 95/98/Me)
Category: Home > Hardware > Network and Modems

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When using a PC Card network adapter you might not be able to connect the computer to the network, and under Control Panel > System there is a yellow exclamation mark "!" next to the card.

Open your registry and find the key below.

Modify the value named "EnablePowerManagement" and change it to '0' based on the following:

  • If the current value is '01 00 00 00' change it to '00 00 00 00' (Full Version).
  • If the current value is '0x00000001 (1)' change it to '0x00000000 (0)' (Upgrade Version)
Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | EnablePowerManagement | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\VCOMM |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\VCOMM]
Name: EnablePowerManagement
Value: (0 = disable, 1 = enable)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 14, 2002


PS2 Mouse Port Rate Adjustment (Windows NT)

PS2 Mouse Port Rate Adjustment (Windows NT)
Category: Home > Hardware > Mice and Keyboards

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Ever noticed how your mouse cursor flickers sometimes or doesn't run as smoothly as you would like? That's because the refresh rate is set too low, modify this key to speed things up and make your mouse cursor move smoothly.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, called "SampleRate" and set it to equal 60 - 200 (decimal), where a higher number means a smoother cursor.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SampleRate | REG_DWORD | 0x0000003c (60) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\i8042prt\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\i8042prt\Parameters]
Name: SampleRate
Type: REG_DWORD (DWORD Value)
Value: 0 - 200 (default = 60)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 14, 2002


New Command Missing in Windows Explorer (All Windows)

New Command Missing in Windows Explorer (All Windows)
Category: Home > Windows > Troubleshooting > Repair

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

After you install Internet Explorer with the Windows Desktop Update component you may notice that the New command is missing from the right-click context menu. This tip will help you fix the problem.

To resolve this issue, open your registry and verify that the key listed below has the value listed, and if needed, edit the value to match the value listed.

Note: This registry entry only exists if the Windows Desktop Update component is installed. If the Windows Desktop Update component is not installed, add the registry entry and (Default) value.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | {D969A300-E7FF-11d0-A93B-00A0C90F2719} | |
-
| HKEY_CLASSES_ROOT\Directory\Background\shellex\ContextMenuHandlers\New |
-

Settings:
System Key: [HKEY_CLASSES_ROOT\Directory\Background\shellex\ContextMenuHandlers\New]
Name: (Default)
Type: REG_SZ (String Value)
Value: {D969A300-E7FF-11d0-A93B-00A0C90F2719}

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: November 20, 1998


Change the Internet Explorer & Outlook Express Toolbar Logo (All Windows)

Change the Internet Explorer & Outlook Express Toolbar Logo (All Windows)
Category: Home > Software > Outlook Express

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When you browse the Internet using Internet Explorer or read messages using Outlook Express, a logo is displayed indicating whether activity is taking place. With this tweak you can modify which logo is shown, customize it or reset it to the default.

Use Your Own Animated Logo
There are two bitmap files used to display the animated logo, both can be identical except for the size, one is 38 pixels wide and the other 22 pixels.

Using an image editor, such as MS Paint, create an image similar to a roll of film, where equal sized "frames" are a stacked vertically within the one larger image. For example, a large icon, with 10 frames, would be 38 pixels wide and 380 pixels high (38 pixels x 10 frames = 380 pixels high).

When active and the logo is animated, the top frame is shown first, then the next, an so on, until the last frame is reached and the image loops. Similarly, when the application is idle, the first frame is shown statically until further activity, that is unless an alternate non-animated logo has been defined using the technique below.

Once you have created the icons you need to register them by opening the key [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Toolbar] in your registry.

Then create two new string values, or modify the existing values, named 'SmBrandBitmap' and 'BrandBitmap' and set their values to equal the full filename of the small (22 pixel) image and large (38 pixel) image respectively.

Use Your Own Non-Animated Logo
These images are shown when the application is idle, as with the method above there are two images one small 22 x 22 pixel and a larger 38 x 38 pixel. To activate them open the key [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main] and create two string values named 'SmallBitmap' and 'BigBitmap' setting the values to equal the filenames of the images.

Reset to the Default Logos
To restore the default animated logo, delete the 'BrandBitmap' and 'SmBrandBitmap' string values found under the registry key [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Toolbar].

To restore the default idle logo, delete the 'SmallBitmap' and 'BigBitmap' string values found under the registry key [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main].

Restart Internet Explorer or Outlook Express for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | BrandBitmap | REG_SZ | "c:\windows\animation.bmp" | |
| |  | SmBrandBitmap | REG_SZ | "c:\windows\animation_small.bmp" | |
| |  | BigBitmap | REG_SZ | "c:\windows\logo.bmp" | |
| |  | SmallBitmap | REG_SZ | "c:\windows\logo_small.bmp" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Outlook Express |
-

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 28, 2003


Change the Default Operating System (Windows NT/2000/XP)

Change the Default Operating System (Windows NT/2000/XP)
Category: Home > Tips and Tricks > Configuration Files > BOOT.INI

This setting in the BOOT.INI file controls which operating system the NT Boot Loader launches by default if none is selected.

Change the attributes for BOOT.INI so it is not 'Read Only', BOOT.INI is found in the root directory of the first partition. Then open the file using Notepad or another text editor (not Microsoft Word or any word processor).

Under the [boot loader] section change the 'default=' option to one of the operating systems listed under the [operating systems] section that you wish to use as the default.

For example, to load Windows NT from the first partition on the first IDE hard drive in the /WINNT directory the option would look like:

default=multi(0)disk(0)rdisk(0)partition(1)\WINNT

Settings:
Name: default

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 12, 2002


Boot Windows NT with the Default VGA Video Driver (Windows NT)

Boot Windows NT with the Default VGA Video Driver (Windows NT)
Category: Home > Tips and Tricks > Configuration Files > BOOT.INI

This explains how to create an a safe VGA video mode start-up option, especially useful when your video adapter or driver is causing problems.

Change the attributes for BOOT.INI so it is not 'Read Only', BOOT.INI is found in the root directory of the first partition. And open the file using Notepad or another text editor (not Microsoft Word or any word processor).

Listed under the [operating systems] section are all the OS's the NT boot loader can launch. To create a new safe VGA entry copy one of the existing NT entries and paste it on a new line.

At the end of the new entry add '/basevideo' (without the quotation marks), change the description of the entry to reflect that it is VGA mode.

The new entry should look similar to:
multi(0)disk(0)rdisk(0)partition(1)\WINNT="Windows NT Workstation Version 4.00 [VGA mode]" /basevideo

Changes will take place on the next reboot.

Settings:
Name: [operating systems]

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 2, 1998


Boot Windows NT in Safe Mode (Windows NT)

Boot Windows NT in Safe Mode (Windows NT)
Category: Home > Tips and Tricks > Configuration Files > BOOT.INI

Windows NT can be very temperamental sometimes are you add new software or install a new driver. The option allows you the create a Windows NT alternative to the Windows 9x Safe Mode. In this mode extra checks are performed and not all third party drivers are loaded.

Change the attributes for BOOT.INI so it is not 'Read Only', BOOT.INI is found in the root directory of the first partition. And open the file using Notepad or another text editor (not Microsoft Word or any word processor).

Listed under the [operating systems] section are all the OS's the NT boot loader can launch. To create a new safe mode entry copy one of the existing NT entries and paste it on a new line.

At the end of the new entry add '/sos' (without the quotation marks), change the description of the entry to reflect that it is safe mode. Additional adding '/basevideo' will launch NT with the default VGA driver.

The new entry should look similar to:
multi(0)disk(0)rdisk(0)partition(1)\WINNT="Windows NT Workstation Version 4.00 [Safe Mode]" /sos /basevideo

Changes will take place on the next reboot.

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 2, 1998


Disable Detection of Devices on Serial Ports (Windows NT)

Disable Detection of Devices on Serial Ports (Windows NT)
Category: Home > Tips and Tricks > Configuration Files > BOOT.INI

Windows NT attempts to probe the serial ports on boot-up to detect any serial mice. This can cause problems with other serial devices such as UPS's.

Change the attributes for BOOT.INI so it is not 'Read Only', BOOT.INI is found in the root directory of the first partition. And open the file using Notepad or another text editor (not Microsoft Word or any word processor).

Listed under the [operating systems] section are all the OS's the NT boot loader can launch.

At the end of the each entry add '/NoSerialMice' (without the quotation marks).

The new entry should look similar to:
multi(0)disk(0)rdisk(0)partition(1)\WINNT="Windows NT Workstation Version 4.00" /NoSerialMice

Changes will take place on the next reboot.

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 2, 1998


Enable the 4GT RAM Tuning Feature of NT Enterprise Edition (Windows NT)

Enable the 4GT RAM Tuning Feature of NT Enterprise Edition (Windows NT)
Category: Home > Tips and Tricks > Configuration Files > BOOT.INI

With standard Windows NT Server, the per-process address limit is 2 gigabytes (GB) of random access memory (RAM). The 4GT feature of Windows NT Server/E increases this limit to 3 GB without introducing new APIs. 4GT does this by reducing the potential RAM allocated to the Windows NT kernel from 2 GB to 1 GB.

Change the attributes for BOOT.INI so it is not 'Read Only', BOOT.INI is found in the root directory of the first partition. And open the file using Notepad or another text editor (not Microsoft Word or any word processor).

Listed under the [operating systems] section are all the OS's the NT boot loader can launch.

At the end of the each entry add '/3GB' (without the quotation marks).

The new entry should look similar to:
multi(0)disk(0)rdisk(0)partition(1)\WINNT="Windows NT Server Version 4.00" /3GB

Restart Windows for the change to take effect.

Note: This change is only effective if you are using Windows NT Server/E. On standard Windows NT, this flag will relocate the kernel, but applications will be unable to access more than 2 GB.

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 2, 1998


Disable Function Keys During the Boot Sequence (Windows 95/98/Me)

Disable Function Keys During the Boot Sequence (Windows 95/98/Me)
Category: Home > Tips and Tricks > Configuration Files > MSDOS.SYS

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

By default Windows 9x enables the function keys on boot, these allow you to control the boot process. For example pressing F5 while the "Starting Windows 95..." message is displayed will boot Windows in Safe Mode.

Change the attributes for MSDOS.SYS so it is not 'Read Only', MSDOS.SYS is found in the root directory of your C:\ drive. Open the file using Notepad or another text editor (not Microsoft Word or any word processor).

Change the value of 'BootKeys=' to 'BootKeys=1' for enabled or 'BootKeys=0' for disabled.

Changes will take place on the next reboot.

Settings:
Value: BootKeys=1 (default) or BootKeys=0 (disabled)

Related Tweaks

  • Change the Function Key Timeout (Windows 95/98/Me)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 12, 2002


Change the Function Key Timeout (Windows 95/98/Me)

Change the Function Key Timeout (Windows 95/98/Me)
Category: Home > Tips and Tricks > Configuration Files > MSDOS.SYS

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows normally enables the function keys during the boot sequence for 2 seconds, these keys allow you to control the boot process. The duration can be changed using this tweak.

Change the attributes for MSDOS.SYS so it is not 'Read Only', MSDOS.SYS is found in the root directory of your C:\ drive. Open the file using Notepad or another text editor (not Microsoft Word or any word processor).

Change the value of 'BootDelay=' to a value representing the number of seconds to make the keys available. e.g. To enable the keys for 5 seconds change the value to 'BootDelay=5'

Changes will take place on the next reboot.

Settings:
Value: BootDelay=2 (default)

Related Tweaks

  • Disable Function Keys During the Boot Sequence (Windows 95/98/Me)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 12, 2002


Control Whether the Windows Desktop is Loaded (Windows 95/98)

Control Whether the Windows Desktop is Loaded (Windows 95/98)
Category: Home > Tips and Tricks > Configuration Files > MSDOS.SYS

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

By default Windows automatically loads the Windows Desktop (or GUI) at startup. With this key you can control whether the GUI is loaded or if you just want the MS-DOS prompt.

Change the attributes for MSDOS.SYS so it is not 'Read Only', MSDOS.SYS is found in the root directory of your C:\ drive. Open the file using Notepad or another text editor (not Microsoft Word or any word processor).

Change the value of 'BootGUI=' to 'BootGUI=1' for GUI enabled or 'BootGUI=0' GUI disabled.

Changes will take place on the next reboot.

Settings:
Value: BootGUI=1 (default)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 14, 2002


Display the Windows Splash Screen While Loading (Windows 95/98/Me)

Display the Windows Splash Screen While Loading (Windows 95/98/Me)
Category: Home > Tips and Tricks > Configuration Files > MSDOS.SYS

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When Windows is loading normally you see the Windows clouds splash screen, this can be disabled to show the background DOS boot process.

Change the attributes for MSDOS.SYS so it is not 'Read Only', MSDOS.SYS is found in the root directory of your C:\ drive. Open the file using Notepad or another text editor (not Microsoft Word or any word processor).

Change the value of 'Logo=' to 'Logo=1' for splash screen enabled or 'Logo=0' for disabled.

Changes will take place on the next reboot.

Hint: Pressing [Esc] while the splash screen is showing will have the same effect for that session.

Settings:
Value: Logo=1 (default)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 7, 2002


Allow Booting to the Previous Operating System (Windows 95/98/Me)

Allow Booting to the Previous Operating System (Windows 95/98/Me)
Category: Home > Tips and Tricks > Configuration Files > MSDOS.SYS

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

If you installed an upgrade version of Windows, you can normally press F4 to boot your previous version of Windows. This option can be disabled.

Change the attributes for MSDOS.SYS so it is not 'Read Only', MSDOS.SYS is found in the root directory of your C:\ drive. Open the file using Notepad or another text editor (not Microsoft Word or any word processor).

Change the value of 'BootMulti=' to 'BootMulti=1' for F4 enabled or 'BootMulti=0' for disabled.

Changes will take place on the next reboot.

Settings:
Value: BootMulti=1 (default)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 12, 2002


Control Whether Scandisk is Run Automatically (Windows 95/98/Me)

Control Whether Scandisk is Run Automatically (Windows 95/98/Me)
Category: Home > Tips and Tricks > Configuration Files > MSDOS.SYS

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When Windows is incorrectly shutdown, or the turn is power turned off, the system will attempt to run Scandisk on the next boot. This setting control whether automatic checking is disabled, prompts before running, or runs automatically.

Change the attributes for MSDOS.SYS so it is not 'Read Only', MSDOS.SYS is found in the root directory of your C:\ drive. Open the file using Notepad or another text editor (not Microsoft Word or any word processor).

Change the value of 'AutoScan=' to:

  • AutoScan=0 : Scandisk is Disabled
  • AutoScan=1 : Scandisk Prompts First
  • AutoScan=2 : Scandisk Runs Automatically
Changes will take place on the next reboot.

Note: It is advisable to run Scandisk after an incorrect shutdown to avoid file corruption.

Note: This feature is only available on Windows 95 OSR 2 and greater.

Settings:
Value: AutoScan=1 (default)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 12, 2002


Show the Windows Boot Menu (Windows 95/98/Me)

Show the Windows Boot Menu (Windows 95/98/Me)
Category: Home > Tips and Tricks > Configuration Files > MSDOS.SYS

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows does not display the boot menu normally unless a key is pressed during bootup (F8 for Windows 95 or CTRL for 98/Me). The boot menu allows you to selectively boot Windows in different modes, including Safe Mode and Command Prompt Mode.

Change the attributes for MSDOS.SYS so it is not 'Read Only', MSDOS.SYS is found in the root directory of your C:\ drive. Open the file using Notepad or another text editor (not Microsoft Word or any word processor).

Change the value of 'BootMenu=' to 'BootMenu=1' for enabled or 'BootMenu=0' for disabled.

If the boot menu is enabled you can control how long it waits before continuing to boot with the 'BootMenuDelay=' option. Set 'BootMenuDelay=' to the amount of time to wait in seconds. i.e. 'BootMenuDelay=5' would wait 5 seconds before continuing to load Windows.

BootKeys must also be enabled for this option to function i.e. 'BootKeys=1'

Changes will take place on the next reboot.

Settings:
Value: BootMenu=0 (default)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 12, 2002


Restrict Anonymous User Access (Windows NT/2000/XP)

Restrict Anonymous User Access (Windows NT/2000/XP)
Category: Home > Security > Network

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows has a feature where anonymous users can list domain user names and enumerate share names. Users who want enhanced security may optionally restrict this functionality.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, named "RestrictAnonymous" and set it to either "0", "1" or "2" from the list below.

  • 0 - Allow anonymous users
  • 1 - Restrict anonymous users
  • 2 - Allow users with explicit anonymous permissions
Restart Windows for the change to take effect.

Note: Users must be using a minimum of Windows NT 4.0 with Service Pack 3 for this setting to be enabled.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | RestrictAnonymous | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\LSA |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\LSA]
Name: RestrictAnonymous
Type: REG_DWORD (DWORD Value)
Value: (0 = allowed, 1 = restricted, 2 = require anonymous permissions)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 11, 2002


Stop Error Messages When Booting (Windows NT)

Stop Error Messages When Booting (Windows NT)
Category: Home > Windows > Troubleshooting

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Stops the annoying Windows pop-up messages notifying you a device is not functioning when you boot-up Windows.

Create a REG_DWORD value of 'NoPopupsOnBoot' in the key below (if it doesn't already exist). Set the value to '1' to disable pop-up messages from appearing.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoPopupsOnBoot | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Windows |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Windows]
Name: NoPopupsOnBoot
Type: REG_DWORD (DWORD Value)
Value: (1 = disable messages)

Related Tweaks

  • Disable Warnings on Startup (Windows 2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 13, 2002


Change the Location of the Outlook Express Mail and News Files (All Windows)

Change the Location of the Outlook Express Mail and News Files (All Windows)
Category: Home > Software > Outlook Express

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allows you to change the location of the mail and news files stored by Outlook Express to another directory or partition.

Open your registry and find the key below.

Edit the value called 'Store Root' and set it to equal the required path name.

Then move the 'mail' and 'news' folders from the old location to the new and restart Outlook Express.

For versions of Outlook Express prior to version 5.0 the registry key is [HKEY_CURRENT_USER\Software\Microsoft\Outlook Express].

Note: The "mail" and "news" folder must be manually created or moved to the new location.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Store Root | REG_SZ | "c:\mail" | |
-
| HKEY_CURRENT_USER\Identities\{Unique Identity}\Software\Microsoft\Outloo... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Identities\{Unique Identity}\Software\Microsoft\
Outlook Express\5.0]
Name: Store Root
Type: REG_SZ (String Value)
Value: Directory Path

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 27, 2002


Change the Logon Screen Wallpaper (All Windows)

Change the Logon Screen Wallpaper (All Windows)
Category: Home > Windows > Login and Authentication

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When you setup a background wallpaper for your desktop, the initial logon screen wallpaper is not changed and stays as the default Windows appearance. This tweak allows you to change the default wallpaper.

Open your registry and find the key below.

Modify the value of 'Wallpaper' to equal the path and filename of the bitmap (BMP) file you want to use as the background (e.g. 'c:\windows\mylogo.bmp').

In the same key, you can also modify these additional values "Pattern" and "TileWallpaper" to set the background pattern and Tile mode respectively.

Restart Windows for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Wallpaper | REG_SZ | "c:\windows\mylogo.bmp" | |
| |  | Pattern | REG_SZ | "(None)" | |
| |  | TileWallpaper | REG_SZ | "0" | |
-
| HKEY_USERS\.DEFAULT\Control Panel\Desktop |
-

Settings:
System Key: [HKEY_USERS\.DEFAULT\Control Panel\Desktop]
Name: Wallpaper, TitleWallpaper
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 20, 2002


View Which Hot Fix Patches Have Been Installed (Windows NT)

View Which Hot Fix Patches Have Been Installed (Windows NT)
Category: Home > Windows > System

Periodically Microsoft releases Hot Fix's to patch bugs in Windows and other products, this key contains information about which Hot fix's have been installed.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Hotfix]

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 14, 1998


Removing Item Types from the New Menu (All Windows)

Removing Item Types from the New Menu (All Windows)
Category: Home > Windows > Windows Explorer

When you right-click on your desktop or other selected applications there is a New sub-menu which contains a list a default templates. This list can be modified to include only the templates you want.

Each template exists in the [HKEY_CLASSES_ROOT] hive associated with a file extension. Whether it is visible or not in the New menu is controlled by whether the related entry has a sub-key called 'ShellNew'.

For example on the New menu there is usually an entry for "Text Document". This is visible because of the key: [HKEY_CLASSES_ROOT\.txt\ShellNew] If you were to rename the key so it no longer had a sub-key called 'ShellNew' by changing it to [HKEY_CLASSES_ROOT\.txt\ShellNewOld] it would disappear from the New menu.

  1. Open Regedit, and using the Find function (Ctrl+F) search for any values of 'ShellNew'.
  2. Several should be found under the [HKEY_CLASSES_ROOT] hive, if you do not want them to be displayed rename 'ShellNew' to 'ShellNewOld'.
Changes should take effect immediately.

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 14, 1998


Change the Location of System and Special Folders (All Windows)

Change the Location of System and Special Folders (All Windows)
Category: Home > Windows

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows keeps a number of special folders such as "My Documents", "Desktop", "Favorites" and the "Start Menu". These folders can be moved anywhere on you system and the new location updated in this key.

Open your registry and find the key below, listed are all the Windows special folders.

Note the current location of the folder you want to move, and then using explorer move the folder to the new location.

Edit the value in the key below for the folder you moved to reflect the new directory location.

Log off or restart Windows for the changes to take effect.

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
User Shell Folders]

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 19, 2002


Set the Minimum Password Length (All Windows)

Set the Minimum Password Length (All Windows)
Category: Home > Security > Login and Authentication

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

You can force Windows to reject passwords that do not meet a minimum password length. Useful to help stop people from using trivial passwords where security is an issue.

Open your registry and find the key below, if the Network sub-key does not already exist then create it.

Create a new binary value named 'MinPwdLen', and set the data to the minimum number of characters required for a password to be accepted.

Note: This does not apply to existing passwords, only new or changed.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | MinPwdLen | REG_BINARY | 06 | |
-
| HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Net... |
-

Settings:
User Key: [HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\
Network]
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\
Network]
Name: MinPwdLen
Type: REG_BINARY (Binary Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 18, 2002


Manage the Programs Run at Windows Startup (All Windows)

Manage the Programs Run at Windows Startup (All Windows)
Category: Home > Windows > Startup and Shutdown

You can automatically start programs whenever Windows launches. If you have programs automatically starting that you have not loaded then you can remove them using this tip as well.

Add a new startup application
Open your registry and find the key [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run].

For each program you want to start automatically create a new string value using a descriptive name, and set the value of the string to the program executable.

For example, to automatically start Notepad, add a new entry of "Notepad"="c:\windows\notepad.exe".

Remove a startup application
If you're trying to remove a program and can not find it in the StartUp folder (usually C:\WINDOWS\Start Menu\Programs\StartUp), then it may be launching from one of the registry keys below. To remove it, delete the value associated with the program you want to remove.

[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run]
[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RunOnce]
[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RunServices]
[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RunServicesOnce]
[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon\Userinit]

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run]
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\RunOnce]
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\RunServices]
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\RunServicesOnce]
[HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows]

It may also be loaded from the [Load] or [Run] sections of your WIN.INI file, found in the Windows directory.

Note: Remember to include the full path to the file, if the directory is not included in your default search path.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Notepad | REG_SZ | "c:\windows\notepad.exe" | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memo... |
-

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 15, 2002


Remove Programs from the Add/Remove Programs List (All Windows)

Remove Programs from the Add/Remove Programs List (All Windows)
Category: Home > Windows > Troubleshooting

Windows compatible programs must include an uninstall program, sometimes though the program may get removed but the entry in Add/Remove programs does not. This tweak allows you to manually remove any orphaned entries.

Open your registry and find the key below. Under this key will be a number of sub-keys, each representing an installed application.

To see which application each sub-key represents, open it and there should be at least two values 'DisplayName' and 'UninstallString'. 'DisplayName' is the name used in the Add/Remove programs list and 'UninstallString' is the program used to uninstall the application.

To remove a program from the list you can simply highlight and delete the sub-key representing that program.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall]
Name: DisplayName, UninstallString

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 19, 2002


Creating Program Aliases in Windows (All Windows)

Creating Program Aliases in Windows (All Windows)
Category: Home > Windows

A hidden feature in the Windows registry allows you to create program aliases. Allowing you to create, for example, an alias called JBLOGGS.EXE that when executed actually runs another program, e.g. NOTEPAD.EXE

Open your registry and find the key below, below it should be a number of sub-keys.

To create a new alias create a sub-key, and call it the name of the alias you wish to create (e.g. "JBLOGGS.EXE").

Modify the (default) value of the sub-key to equal the fully qualified path and filename of the application you want to be launched when you execute the alias (e.g. "c:\windows\notepad.exe").

Exit your registry and to test use the Start -> Run command type in the name of your alias (i.e. "JBLOGGS.EXE") and the aliased program should be launched, in this case Notepad.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | "c:\windows\notepad.exe" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths]
Name: (Default)
Type: REG_SZ (String Value)
Value: Filename (e.g. c:\windows\notepad.exe)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 15, 1998


Change the Default Logon Screen Saver (Windows NT/2000/XP)

Change the Default Logon Screen Saver (Windows NT/2000/XP)
Category: Home > Windows > Login and Authentication

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows has a default screen saver which is shown over the login screen even when no screen saver has been selected. These settings allow you to configure the default login screen saver.

Open your registry and find the key below.

Enable or Disable the Screen Saver
Change the value of "ScreenSaveActive" to "0" to disable or "1" to enable the login screen saver.

Change the Screen Saver
Change the value of "SCRNSAVE.EXE" to the full path and filename of the screen saver .SCR file.

Change the Sreen Saver Timeout
Change the value of "ScreenSaveTimeOut" to equal the screen saver timeout in seconds.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ScreenSaveActive | REG_SZ | 1 | |
| |  | ScreenSaveTimeOut | REG_SZ | 600 | |
| |  | SCRNSAVE.EXE | REG_SZ | login.scr | |
-
| HKEY_USERS\.DEFAULT\Control Panel\Desktop |
-

Settings:
User Key: [HKEY_USERS\.DEFAULT\Control Panel\Desktop]
Name: ScreenSaveActive, SCRNSAVE.EXE, ScreenSaveTimeOut
Type: REG_SZ (String Value)
Value: (0 = disabled, 1 =enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 10, 2002


Restrict Applications Users Can Run (All Windows)

Restrict Applications Users Can Run (All Windows)
Category: Home > Security

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows gives the ability to restrict the applications that can be run by users on a workstation.

Open your registry and find the key [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion \Policies\Explorer]

Create a new DWORD value and name it "RestrictRun" set the value to "1" to enable application restrictions or "0" to allow all applications to run.

Then create a new sub-key called [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion \Policies\Explorer\RestrictRun] and define the applications that are allowed. Creating a new string value for each application, named as consecutive numbers, and setting the value to the filename to be allowed (e.g. "regedit.exe").

Restart Windows for the changes to take effect.

Note: If you are the person who applies Group Policy, do not apply this restriction to yourself. If applied too broadly, this policy can prevent administrators from running Group Policy or the registry editors. As a result, once applied, you cannot change this policy except by reinstalling Windows.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | 1 | REG_SZ | "notepad.exe" | |
| |  | 2 | REG_SZ | "regedit.exe" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: RestrictRun

Related Tweaks

  • Restrict Users from Running Specific Applications (Windows 2000/Me/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 11, 2002


Add the QuickView Option to All Files (All Windows)

Add the QuickView Option to All Files (All Windows)
Category: Home > Windows > Accessories

If you ever wanted to add QuickView to the context menu of all file types, it may be a tedious task doing so using Windows Explorer's Options - File Type window. This tip shows how to do it in a couple of easy steps.

Open your registry and create a sub-key called QuickView under [HKEY_CLASSES_ROOT\*].

Change the (Default) value of the new sub-key to equal '*'.

Close the registry and open an Explorer window. Right-click on any file and the QuickView command should now appear.

Note: You need to have QuickView installed on your PC. If not, Go to Control Panel, Add/Remove Programs and add it from the Accessories group in the Windows Setup tab.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | "*" | |
-
| HKEY_CLASSES_ROOT\*\QuickView |
-

Settings:
System Key: [HKEY_CLASSES_ROOT\*\QuickView]
Name: (Default)
Type: REG_SZ (String Value)
Value: *

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 7, 1999


Optimize Large Second Level Cache (Windows NT/2000/XP)

Optimize Large Second Level Cache (Windows NT/2000/XP)
Category: Home > Hardware > Processor and Motherboard

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows is optimized for a 256KB secondary cache by default. With most computers now having L2 caches larger than that it pays to take the time to change the setting to correspond to the size of the cache memory installed.

Open your registry and find the key below.

Create a new DWORD value, of modify the existing value, named "SecondLevelDataCache" and set it to equal your L2 cache size in Kb's (decimal).

Restart Windows for the change to take effect.

Note: This tweak is only useful for older processors with the cache located external to the CPU.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SecondLevelDataCache | REG_DWORD | 0x00000200 (512) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memo... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\
Memory Management]
Name: SecondLevelDataCache
Type: REG_DWORD (DWORD Value)
Value: Cache (in Kb) using Decimal Notation

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 4, 2002


Disable the MS-DOS Command Prompt (Windows 95/98/Me)

Disable the MS-DOS Command Prompt (Windows 95/98/Me)
Category: Home > Windows > Accessories > Command Processor

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allows you to disable the use of the MS-DOS command prompt in Windows.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, named "Disabled" and set it to "1" to disable the command prompt or to re-enable it again later change the value to "0".

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Disabled | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Win... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
WinOldApp]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
WinOldApp]
Name: Disabled
Type: REG_DWORD (DWORD Value)
Value: (0 = disable, 1 = enable)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 19, 2003


Disable Single Mode MS-DOS Applications (Windows 95/98/Me)

Disable Single Mode MS-DOS Applications (Windows 95/98/Me)
Category: Home > Windows > Accessories > Command Processor

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allows you to disable the use of real mode DOS applications from within the Windows shell.

Open your registry and find the key below.

Create a new DWORD value, called 'NoRealMode' and set it to "1" to disable real mode DOS, to re-enable it again later change the value to "0".

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoRealMode | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Win... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
WinOldApp]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
WinOldApp]
Name: NoRealMode
Type: REG_DWORD (DWORD Value)
Value: (0 = disable, 1 = enable)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 1, 2002


PC Speaker Beeping on Errors (All Windows)

PC Speaker Beeping on Errors (All Windows)
Category: Home > Hardware

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

If you get annoyed by the beeps and noises coming from your PC speaker but can't find a way to turn it off, then use this tip to disable it.

Open your registry and find the key below.

Create a new string value, or modify the existing value, named "Beep" and set it to either 'Yes' for beeping enabled or 'No' for beeping disabled.

You may need to log off or restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Beep | REG_SZ | "No" | |
-
| HKEY_CURRENT_USER\Control Panel\Sound |
-

Settings:
User Key: [HKEY_CURRENT_USER\Control Panel\Sound]
Name: Beep
Type: REG_SZ (String Value)
Value: Yes or No

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 21, 2002


Control Whether Windows Performs Smooth Scrolling (All Windows)

Control Whether Windows Performs Smooth Scrolling (All Windows)
Category: Home > Windows > Appearance

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allow you to disable the Windows smooth scrolling function, which on an low-powered system can cause performance degradation.

Open your registry and find the key below.

Modify the value, or create a new binary value, named "SmoothScroll" and set it to either '0' for disabled or '1' for enabled.

Log off or restart Windows for the change to take effect.

Note: On some versions of Windows this value may be REG_BINARY (00 00 00 00 = disabled, 01 00 00 00 = enabled) instead.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SmoothScroll | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_CURRENT_USER\Control Panel\Desktop |
-

Settings:
User Key: [HKEY_CURRENT_USER\Control Panel\Desktop]
Name: SmoothScroll
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Related Tweaks

  • Use Smooth Scrolling in Internet Explorer (All Windows)
  • Use Smooth Scrolling in Outlook Express (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 6, 2001


Hide Share Passwords with Asterisks (All Windows)

Hide Share Passwords with Asterisks (All Windows)
Category: Home > Security > Network

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether the password typed when accessing a file share is shown in clear text or as asterisks.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'HideSharePwds' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | HideSharePwds | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Net... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Network]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Network]
Name: HideSharePwds
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1=enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 3, 2002


Require Alphanumeric Windows Password (All Windows)

Require Alphanumeric Windows Password (All Windows)
Category: Home > Security > Login and Authentication

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows by default will accept anything as a password, including nothing. This setting controls whether Windows will require a alphanumeric password, i.e. a password made from a combination of alpha (A, B, C...) and numeric (1, 2 ,3 ...) characters.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'AlphanumPwds' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AlphanumPwds | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Net... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Network]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Network]
Name: AlphanumPwds
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1=enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 25, 2002


Disable Password Caching (All Windows)

Disable Password Caching (All Windows)
Category: Home > Security > Login and Authentication

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Normally Windows caches a copy of the users password on the local system to allow for additional automation, this leads to a possible security threat on some systems. Disabling caching means the users passwords are not cached locally. This setting also removes the second Windows password screen and also remove the possibility of networks passwords to get out of sync.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'DisablePwdCaching' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DisablePwdCaching | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Net... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Network]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Network]
Name: DisablePwdCaching
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1=enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 25, 2002


Automatic Logon to Windows 95, 98 and Me (Windows 95/98/Me)

Automatic Logon to Windows 95, 98 and Me (Windows 95/98/Me)
Category: Home > Security > Login and Authentication

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allows Windows clients to automatically logon without entering a user name or password, therefore bypassing the logon box.

Open your registry and find the key below.

Create a new string value called "AutoAdminLogon" and set it to "1" to enable automatic login.

Create a new string value called "DefaultUsername" and set it to username of the default user.

Create a new string value called "DefaultPassword" and set it to match the password of the default user.

Restart Windows and the system should automatically logon.

Note: As the password is stored in clear text any user with access to the local Windows registry may then be able to see the default password.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | AutoAdminLogon | REG_SZ | 1 | |
| |  | DefaultPassword | REG_SZ | secret | |
| |  | DefaultUserName | REG_SZ | John Doe | |
-
| HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Winlogon |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Winlogon]
Name: AutoAdminLogon, DefaultPassword, DefaultUserName
Type: REG_SZ (String Value)

Related Tweaks

  • Automatic Logon to Windows NT, 2000 and XP (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: July 4, 2003


Support Long Filenames on Netware Servers (Windows 95/98/Me)

Support Long Filenames on Netware Servers (Windows 95/98/Me)
Category: Home > Network > Servers

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether long filenames (LFN) are supported on Netware servers, and if supported which versions.

Open your registry and find the key below, if it doesn't already exist then create it.

Create a new DWORD value, or modify the existing value, named "SupportLFN" and set it to either '0', '1' or '2' depending on the table below:

Value   Description
-----   -----------
  0     LFN Disabled
  1     LFN Enabled on Netware 3.12 and above
  2     LFN Enabled on all Netware servers that support LFN

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SupportLFN | REG_DWORD | 0x00000002 (2) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\NWREDIR |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\NWREDIR]
Name: SupportLFN
Type: REG_DWORD (DWORD Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2002


Specifying a Preferred Netware Server (Windows 95/98/Me)

Specifying a Preferred Netware Server (Windows 95/98/Me)
Category: Home > Network

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allows you to specify a default Netware.

Open your registry and find the key below.

Create new string value named "AuthenticatingAgent" and set it to the name of your preferred Netware server.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AuthenticatingAgent | REG_SZ | "NETSERVER" | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NWNP32\NetworkProvider |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NWNP32\
NetworkProvider]
Name: AuthenticatingAgent
Type: REG_SZ (String Value)
Value: Server Name

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 26, 2002


Disable Automatic Netware Logon (Windows 95/98/Me)

Disable Automatic Netware Logon (Windows 95/98/Me)
Category: Home > Network > Clients

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting disables automatically logging on to Netware servers.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'DisableDefaultPasswords' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | DisableDefaultPasswords | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NWNP32\NetworkProvider |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NWNP32\
NetworkProvider]
Name: DisableDefaultPasswords
Type: REG_DWORD (DWORD Value)
Value: (0 = enabled, 1 = disabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2002


Disable SAP Packets for Netware Networks (Windows 95/98/Me)

Disable SAP Packets for Netware Networks (Windows 95/98/Me)
Category: Home > Network > Clients

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

By default Windows will send SAP packets to advertise available file and print shares when 'File and Print Sharing for Netware Networks' is enabled, this setting controls those packets.

Open your registry and find the key below.

Create a new string value, or modify the existing value, named "Use_Sap" and set it to "0" to disable SAP packets.

In addition you may also be required to create another key named [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NcpServer\Parameters\Ndi\Params\Use_Sap] and set the (Default) value to equal "0".

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Use_Sap | REG_SZ | "0" | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NcpServer\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NcpServer\
Parameters]
Name: Use_Sap
Type: REG_SZ (String Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2002


Require Validation by Network for Windows Access (Windows 95/98/Me)

Require Validation by Network for Windows Access (Windows 95/98/Me)
Category: Home > Security > Network

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

By default Windows 9x doesn't require a valid network username and password combination for a user to bypass the logon and gain access to the local machine. This functionality can be changed to require validation by the network before allowing access.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called "MustBeValidated" and set it to equal "1" to require successful authentication.

Restart Windows for the change to take effect.

Your machine must be part of a Windows domain for this tweak to work, as the user must be authenticated by the network.

Note: The workstation must be a member of a Windows domain for this setting to be effective.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | MustBeValidated | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\Network\Logon |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\Network\Logon]
Name: MustBeValidated
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 24, 2002


Disable Dial-In Access (Windows 95/98/Me)

Disable Dial-In Access (Windows 95/98/Me)
Category: Home > Security > Remote Access

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

It's possible for users to setup a modem on a Windows machine, and by using Dial-up Networking allow callers to connect to the internal network. Especially in a corporate environment this can cause a major security risk.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoDialIn' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoDialIn | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Net... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Network]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Network]
Name: NoDialIn
Type: REG_DWORD (DWORD Value)
Value: (0 = dial-in enabled, 1 = dial-in disabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 3, 2002


Disable File and Printer Sharing (Windows 95/98/Me)

Disable File and Printer Sharing (Windows 95/98/Me)
Category: Home > Security > Network

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When file and printer sharing is installed it allows users to make services available to other users on a network, this functionality can be disabled by changing this setting.

Open your registry and find the key below, if it doesn't already exist then create it.

Create two new DWORD values named "NoFileSharing" and "NoPrintSharing" and set the values to either '1' for sharing disabled or '0' for sharing enabled. Both settings do not have to be the same, it is possible to have one disabled and the other enabled.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoFileSharing | REG_DWORD | 0x00000001 (1) | |
| |  | NoPrintSharing | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Net... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Network]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Network]
Name: NoFileSharing, NoPrintSharing
Type: REG_DWORD (DWORD Value)
Value: (0 = file sharing, 1 = disabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 12, 2003


Display Domain Logon Confirmation (Windows 95/98/Me)

Display Domain Logon Confirmation (Windows 95/98/Me)
Category: Home > Network > Clients

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When this option is enabled, a popup dialog message is shown when the user successfully authenticates with a Windows domain.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'DomainLogonMessage' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DomainLogonMessage | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\Network\Logon |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\Network\Logon]
Name: DomainLogonMessage
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 14, 2002


Disable Caching of Domain Password (Windows 95/98/Me)

Disable Caching of Domain Password (Windows 95/98/Me)
Category: Home > Security > Network

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Enabling this setting disables the caching of the domain passwords, and therefore passwords are required to be re-entered to access any additional domain resources.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoDomainPwdCaching' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoDomainPwdCaching | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\Network\Logon |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\Network\Logon]
Name: NoDomainPwdCaching
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 3, 2002


Enable Shutdown from Authentication Dialog Box (Windows NT/2000/XP)

Enable Shutdown from Authentication Dialog Box (Windows NT/2000/XP)
Category: Home > Security > Login and Authentication

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When this setting is enabled a [Shutdown] button is displayed in authentication dialog box when the system first starts. This allows you to shutdown a system without logging in. The button is shown by default on a workstation and removed on a server installation.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'ShutdownWithoutLogon' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ShutdownWithoutLogon | REG_DWORD | "1" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\sy... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\
system]
Name: ShutdownWithoutLogon
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 11, 2003


Beep on Printer Errors (Windows NT/2000/XP)

Beep on Printer Errors (Windows NT/2000/XP)
Category: Home > Hardware > Printers and Plotters

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When this setting is enabled the machine will beep every few seconds when a remote job error occurs on a print server.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'BeepEnabled' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | BeepEnabled | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print]
Name: BeepEnabled
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 26, 2002


Number of Remote Access Authentication Attempts (Windows NT/2000/XP)

Number of Remote Access Authentication Attempts (Windows NT/2000/XP)
Category: Home > Security > Remote Access

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls the number of authentication retries before a remote access connection is terminated.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'AuthenticateRetries' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AuthenticateRetries | REG_DWORD | 0x00000003 (3) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RemoteAccess\Parame... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RemoteAccess\
Parameters]
Name: AuthenticateRetries
Type: REG_DWORD (DWORD Value)
Value: 1 to 10

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 3, 2002


Time Limit for Remote Access Authentication (Windows NT/2000/XP)

Time Limit for Remote Access Authentication (Windows NT/2000/XP)
Category: Home > Security > Remote Access

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

A time limit can be enforced on the period available to logon via remote access before the connection is terminated.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'AuthenticateTime' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AuthenticateTime | REG_DWORD | 0x0000003c (60) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RemoteAccess\Parame... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RemoteAccess\
Parameters]
Name: AuthenticateTime
Type: REG_DWORD (DWORD Value)
Value: 20 to 600 (seconds)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 3, 2002


Automatically Disconnect Remote Access Callers (Windows NT/2000/XP)

Automatically Disconnect Remote Access Callers (Windows NT/2000/XP)
Category: Home > Security > Remote Access

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Specifies the amount of idle time in minutes to wait before disconnecting the remote access client.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'AutoDisconnect' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AutoDisconnect | REG_DWORD | 0x00000005 (5) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RemoteAccess\Parame... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RemoteAccess\
Parameters]
Name: AutoDisconnect
Type: REG_DWORD (DWORD Value)
Value: Time in Minutes

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 3, 2002


Specify the Callback Pause Period (Windows NT/2000/XP)

Specify the Callback Pause Period (Windows NT/2000/XP)
Category: Home > Security > Remote Access

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When callback is required or requested this setting defines how long to wait before initiating the callback connection.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'CallbackTime' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | CallbackTime | REG_DWORD | 0x0000000c (12) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RemoteAccess\Parame... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RemoteAccess\
Parameters]
Name: CallbackTime
Type: REG_DWORD (DWORD Value)
Value: 2 - 12 (seconds)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 3, 2002


Run Logon Scripts Synchronously (Windows NT/2000/XP)

Run Logon Scripts Synchronously (Windows NT/2000/XP)
Category: Home > Windows > System > Scripts

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether the system should wait for the logon scripts to complete before starting the users shell or whether the scripts should run asynchronously.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'RunLogonScriptSync' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This restriction can be used either on a user by user basis by adding it to HKEY_CURRENT_USER or on a computer wide basis by adding it to HKEY_LOCAL_MACHINE.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | RunLogonScriptSync | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: RunLogonScriptSync
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 27, 2002


Delete Cached Copies of Roaming Profiles (Windows NT/2000/XP)

Delete Cached Copies of Roaming Profiles (Windows NT/2000/XP)
Category: Home > Network > Clients

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting enables Windows to delete the cached profile of any roaming users when they log off the system. This will help to maintain profile integrity and save disk space where that are numerous mobile users.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'DeleteRoamingCache' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DeleteRoamingCache | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: DeleteRoamingCache
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 22, 2002


Automatically Detect Slow Network Connections (Windows NT/2000)

Automatically Detect Slow Network Connections (Windows NT/2000)
Category: Home > Network

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows will normally attempt to detect the time-out on network links to determine their speed (high or low). This functionality can be disabled if Windows is having problems determining the speed of your link.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'SlowLinkDetectEnabled' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SlowLinkDetectEnabled | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: SlowLinkDetectEnabled
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 26, 2002


Define the Slow Link Time-Out (Windows NT/2000)

Define the Slow Link Time-Out (Windows NT/2000)
Category: Home > Network

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows uses this value to define what should be classified as low speed and what is a high speed connection. The default time-out is 2000 milliseconds, any connection slower is considered a low speed link.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'SlowLinkTimeOut' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SlowLinkTimeOut | REG_DWORD | 0x000003e8 (1000) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: SlowLinkTimeOut
Type: REG_DWORD (DWORD Value)
Value: Time (milliseconds)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 26, 2002


Time-out for User Profile Dialog Boxes (Windows NT/2000)

Time-out for User Profile Dialog Boxes (Windows NT/2000)
Category: Home > Windows > Login and Authentication

When the user is presented with a dialog box requesting User Profile information, this specifies the amount of time in seconds before the dialog box is closed and the default is accepted. The default value is 30 seconds.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'ProfileDlgTimeOut' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ProfileDlgTimeOut | REG_DWORD | 0x0000003c (6) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: ProfileDlgTimeOut
Type: REG_DWORD (DWORD Value)
Value: 1 to 600 (seconds)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 4, 1999


Disable the Shut Down Command (All Windows)

Disable the Shut Down Command (All Windows)
Category: Home > Security

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This option allows you to stop users from being able to shutdown the computer by disabling the shut down command.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoClose' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoClose | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoClose
Type: REG_DWORD (DWORD Value)
Value: (0 = shutdown enabled, 1 = shutdown disabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 19, 2003


Hide All Items on the Desktop (All Windows)

Hide All Items on the Desktop (All Windows)
Category: Home > Security > Desktop and Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Enabling this options hides all the items and programs on the Windows desktop.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoDesktop' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoDesktop | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoDesktop
Type: REG_DWORD (DWORD Value)
Value: (0 = disable restriction, 1 = enabled restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 22, 2002


Hide Drives in My Computer (All Windows)

Hide Drives in My Computer (All Windows)
Category: Home > Security

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allows you to control which drives are visible in My Computer and Explorer. It is possible to hide all drives or just selected ones.

Open your registry and find or create the key below.

The "NoDrives" value uses a 32-bit word to define local and network drive visibility for each logical drive in the computer. The lower 26 bits of the 32-bit word correspond to drive letters A through Z. Drives are visible when set to 0 and hidden when set to 1.

If your not happy working in Hex, add these decimal numbers to hide the drive(s):

A: 1, B: 2, C: 4, D: 8, E: 16, F: 32, G: 64, H: 128, I: 256, J: 512, K: 1024, L: 2048, M: 4096, N: 8192, O: 16384, P: 32768, Q: 65536, R: 131072, S: 262144, T: 524288, U: 1048576, V: 2097152, W: 4194304, X: 8388608, Y: 16777216, Z: 33554432, ALL: 67108863

For example to hide drive A and drive D, you would add 1 (A) + 8 (D) which means the value should be set to "9".

To disable all the drives set the value to "67108863".

Restart Windows for the change to take effect.

Note: These drives will still appear in File Manager, to remove File Manager, delete or rename winfile.exe.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoDrives | REG_DWORD | 0x03ffffff (67108863) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoDrives
Type: REG_DWORD (DWORD Value)

Related Tweaks

  • Prevent Access to the Contents of Selected Drives (Windows 2000/Me/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 20, 2002


Remove Search from the Start Menu (All Windows)

Remove Search from the Start Menu (All Windows)
Category: Home > Security > Start Menu and Taskbar

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction removes the Search feature from the Start Menu.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoFind' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoFind | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoFind
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 3, 2002


Hide the Network Neighborhood Icon (All Windows)

Hide the Network Neighborhood Icon (All Windows)
Category: Home > Security > Desktop and Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

The Network Neighborhood icon is shown on the Windows desktop whenever Windows networking is installed, by enabling this setting the icon will be hidden.

In addition this disables UNC capability from within the Explorer interface, including the Start menu's Run command, UNC paths configured by the administrator in Policies for shared folders, desktop icons, the Start command, and so forth. This does not impair the functionality of the command line Net.exe command.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoNetHood | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoNetHood
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 25, 2002


Remove Run from the Start Menu (All Windows)

Remove Run from the Start Menu (All Windows)
Category: Home > Security > Start Menu and Taskbar

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Removes the ability to launch commands or processes from the Start menu by removing the Run option.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoRun' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: If the user still has access to the MS-DOS prompt icon or command prompt, the user may start unauthorized applications.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoRun | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoRun
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 3, 2002


Disable Save Settings at Exit (All Windows)

Disable Save Settings at Exit (All Windows)
Category: Home > Windows > Startup and Shutdown

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When Windows exits it normally saves the desktop layout, including icon location, appearance and other parameters. This setting disables any changes from being saved therefore allowing you to preserve a configured layout.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoSaveSettings' set the value to equal '1' to enable the restriction.

Exit your registry, you may need to restart for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoSaveSettings | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoSaveSettings
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 12, 2002


Hide Control Panel, Printer and Network Settings (All Windows)

Hide Control Panel, Printer and Network Settings (All Windows)
Category: Home > Security > Start Menu and Taskbar

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction removes the Control Panel, Printers and Network Connection settings from the Start menu. If the Taskbar settings are also hidden it causes the Settings menu to be completely removed.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, called 'NoSetFolders' and edit the value according to the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This tweak may also disable the Windows Explorer hotkey shortcut (Windows + E).

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoSetFolders | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoSetFolders
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Related Tweaks

  • Hide the Taskbar Settings on the Start Menu (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 20, 2002


Hide the Taskbar Settings on the Start Menu (All Windows)

Hide the Taskbar Settings on the Start Menu (All Windows)
Category: Home > Security > Start Menu and Taskbar

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction removes the Taskbar and Start Menu item from the Control Panel, and it also removes the Properties item from the Start menu context menu.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoSetTaskbar' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: Removing the Taskbar, Control Panel, and Printer folders causes the Settings menu to be removed completely.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoSetTaskbar | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoSetTaskbar
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Related Tweaks

  • Hide Control Panel, Printer and Network Settings (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 20, 2002


Remove the Start Banner on the Taskbar (All Windows)

Remove the Start Banner on the Taskbar (All Windows)
Category: Home > Windows > Start Menu and Taskbar > Taskbar

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Hide the bouncing arrow and the "Click Here to Begin" caption that appear on the taskbar when you start Windows.

Open your registry and find the key below.

Create a new Binary value, or modify the existing value called 'NoStartBanner' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: On Windows XP and later this value is a DWORD type.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoStartBanner | REG_BINARY | 01 00 00 00 | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoStartBanner
Type: REG_BINARY (Binary Value)
Value: (00 = start banner, 01 = no start banner)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 17, 2002


Select the Disk Drives to Start Automatically (All Windows)

Select the Disk Drives to Start Automatically (All Windows)
Category: Home > Windows > File System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls which drives the AutoPlay feature is enabled on. When AutoRun is enabled, media is automatically started when it is inserted in the drive.

Open your registry and find or create the key below.

The "NoDriveAutoRun" value uses a 32-bit word to control which drives the AutoPlay feature is enabled on. The lower 26 bits of the 32-bit word correspond to drive letters A through Z. If a bit is set to 0, the autorun feature is enabled on that drive. If a bit is set to 1, the autorun feature is disabled on that drive.

If your not happy working in Hex, add these decimal numbers to specify the drive(s):

A: 1, B: 2, C: 4, D: 8, E: 16, F: 32, G: 64, H: 128, I: 256, J: 512, K: 1024, L: 2048, M: 4096, N: 8192, O: 16384, P: 32768, Q: 65536, R: 131072, S: 262144, T: 524288, U: 1048576, V: 2097152, W: 4194304, X: 8388608, Y: 16777216, Z: 33554432, ALL: 67108863

For example to disable AutoRun on drive A and drive D, you would add 1 (A) + 8 (D) which means the value should be set to "9".

To disable all the drives set the value to "67108863".

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoDriveAutoRun | REG_DWORD | 0x03ffffff (67108863) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoDriveAutoRun
Type: REG_DWORD (DWORD Value)
Value: 32-bit bitmask

Related Tweaks

  • Select the Drive Types to Start Automatically (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 20, 2002


Remove File Menu from Explorer (All Windows)

Remove File Menu from Explorer (All Windows)
Category: Home > Security > Desktop and Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting is used to Remove the File option from the Explorers toolbar.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoFileMenu' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This option was added in Windows NT Service Pack 2 and is standard in newer Windows versions.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoFileMenu | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoFileMenu
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 25, 2002


Remove Common Program Groups from Start Menu (All Windows)

Remove Common Program Groups from Start Menu (All Windows)
Category: Home > Security > Start Menu and Taskbar

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Disables the display of common groups when the user selects Programs from the Start menu.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoCommonGroups' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoCommonGroups | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoCommonGroups
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 13, 2002


Disable Taskbar Context Menus (All Windows)

Disable Taskbar Context Menus (All Windows)
Category: Home > Windows > Start Menu and Taskbar > Taskbar

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting removes the context menus (right click on the taskbar) for the system tray, including the Start button, Tab control, and Clock.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoTrayContextMenu' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoTrayContextMenu | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoTrayContextMenu
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 19, 2001


Disable the Ability to Right Click on the Desktop (All Windows)

Disable the Ability to Right Click on the Desktop (All Windows)
Category: Home > Security > Desktop and Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak removes the context menu that would normally appear when the user right clicks on the desktop or in the Explorer right results pane.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoViewContextMenu' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoViewContextMenu | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoViewContextMenu
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 19, 2003


Remove the Map and Disconnect Network Drive Options (Windows NT/2000/XP)

Remove the Map and Disconnect Network Drive Options (Windows NT/2000/XP)
Category: Home > Security > Network

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Prevents users from making additional network connections by removing the Map Network Drive and Disconnect Network Drive buttons from the toolbar in Explorer and also removing them from the Context menu of My Computer and the Tools menu of Explorer.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoNetConnectDisconnect' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoNetConnectDisconnect | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoNetConnectDisconnect
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 3, 2002


Read Environment Variables in Autoexec.bat File (Windows NT/2000/XP)

Read Environment Variables in Autoexec.bat File (Windows NT/2000/XP)
Category: Home > Tips and Tricks > Configuration Files > AUTOEXEC.BAT

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When this value is enabled the variables declared in the Autoexec.bat file will be parsed and included in the current user environment.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'ParseAutoexec' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ParseAutoexec | REG_SZ | "0" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: ParseAutoexec
Type: REG_SZ (String Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 27, 2002


Disable Task Manager (Windows NT/2000/XP)

Disable Task Manager (Windows NT/2000/XP)
Category: Home > Windows > Accessories

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls the ability for users to start Task Manager and view processes, running applications and make changes to the priority or state of the individual processes.

Open your registry and find the key below.

Create a new DWORD valued named "DisableTaskMgr" and set it to "1" to disable Task Manager.

You may need to log off for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DisableTaskMgr | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
Name: DisableTaskMgr
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = disable Task Manager)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 20, 2002


Disable the Printer Server Browse Thread (Windows NT/2000/XP)

Disable the Printer Server Browse Thread (Windows NT/2000/XP)
Category: Home > Hardware > Printers and Plotters

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When this option is enabled, the print spooler does not send shared printer information to other print servers.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'DisableServerThread' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DisableServerThread | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Print |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Print]
Name: DisableServerThread
Type: REG_DWORD (DWORD Value)
Value: (0 = enable server thread, 1 = disable)

Related Tweaks

  • Specify the Printer Browser Timeout (Windows NT/2000/XP)
  • Specify the Print Server Broadcast Timeout (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 26, 2002


Define the Scheduler Priority (Windows NT/2000/XP)

Define the Scheduler Priority (Windows NT/2000/XP)
Category: Home > Hardware > Printers and Plotters

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls the overall priority of the printer scheduler.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'SchedulerThreadPriority' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SchedulerThreadPriority | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Print |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Print]
Name: SchedulerThreadPriority
Type: REG_DWORD (DWORD Value)
Value: Above normal = 1; Normal = 0, Less than normal = ffffffff

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 26, 2002


Extended Characters in Short Filenames (Windows NT/2000/XP)

Extended Characters in Short Filenames (Windows NT/2000/XP)
Category: Home > Windows > File System > Files and Shortcuts

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allows extended characters to be used in 8.3 filenames. Short file names with extended characters may not be viewable on computers that do not have the same character code page.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NtfsAllowExtendedCharacterIn8dot3Name' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NtfsAllowExtendedCharacterIn8dot3Name | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem]
Name: NtfsAllowExtendedCharacterIn8dot3Name
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Related Tweaks

  • Short Filenames on NTFS Partitions (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: July 24, 2002


Deny Access to the Display Settings (All Windows)

Deny Access to the Display Settings (All Windows)
Category: Home > Security > Control Panel

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This option disables the display settings control panel icon, and stops users from accessing any display settings.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoDispCPL' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoDispCPL | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
Name: NoDispCPL
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 25, 2002


Hide the Display Appearance Page (All Windows)

Hide the Display Appearance Page (All Windows)
Category: Home > Security > Control Panel > Display

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When enabled this setting hides the display settings appearance page.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoDispAppearancePage' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoDispAppearancePage | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
Name: NoDispAppearancePage
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 25, 2002


Hide the Display Background Page (All Windows)

Hide the Display Background Page (All Windows)
Category: Home > Security > Control Panel > Display

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This option hides the background page stopping users from changing any background display settings.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoDispBackgroundPage' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoDispBackgroundPage | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
Name: NoDispBackgroundPage
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 25, 2002


Hide the Screen Saver Settings Page (All Windows)

Hide the Screen Saver Settings Page (All Windows)
Category: Home > Security > Control Panel > Display

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This option hides the screen saver page from the display settings control, which stops users having access to change screen saver settings.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoDispScrSavPage' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoDispScrSavPage | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
Name: NoDispScrSavPage
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 25, 2002


Hide the Display Settings Page (All Windows)

Hide the Display Settings Page (All Windows)
Category: Home > Security > Control Panel > Display

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This option hides the Settings page from the display properties control.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoDispSettingsPage' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoDispSettingsPage | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
Name: NoDispSettingsPage
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 25, 2002


Hide Entire Network in Network Neighborhood (All Windows)

Hide Entire Network in Network Neighborhood (All Windows)
Category: Home > Security > Network

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Entire Network is an option under Network Neighborhood that allows users to see all the Workgroups and Domains on the network. Entire Network can be disabled, so users are confined to their own Workgroup or Domain.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoEntireNetwork' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoEntireNetwork | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Net... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Network]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Network]
Name: NoEntireNetwork
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 3, 2002


Hide Workgroup Content from Network Neighborhood (All Windows)

Hide Workgroup Content from Network Neighborhood (All Windows)
Category: Home > Security > Network

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Enabling this option hides all Workgroup contents from being displayed in Network Neighborhood.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoWorkgroupContents' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoWorkgroupContents | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Net... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Network]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Network]
Name: NoWorkgroupContents
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 3, 2002


Disable Network Control Panel (Windows 95/98/Me)

Disable Network Control Panel (Windows 95/98/Me)
Category: Home > Security > Control Panel

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Enabling this option disables access to the Network Control Panel icon.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoNetSetup' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoNetSetup | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Net... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Network]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Network]
Name: NoNetSetup
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 25, 2002


Hide Network Identification Page (Windows 95/98/Me)

Hide Network Identification Page (Windows 95/98/Me)
Category: Home > Security > Control Panel > Network

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

The Network Identification page include options to set the Computer Name, Workgroup and Description, enabling this option disables access to the Network ID page.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoNetSetupIDPage' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoNetSetupIDPage | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Net... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Network]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Network]
Name: NoNetSetupIDPage
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 25, 2002


Hide Network Access Control Page (Windows 95/98/Me)

Hide Network Access Control Page (Windows 95/98/Me)
Category: Home > Security > Control Panel > Network

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

The Access Control Page, defines whether the computer support User-Level access or Share-Level access, enabling this option removes access to the Access Control Page.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoNetSetupSecurityPage' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoNetSetupSecurityPage | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Net... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Network]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Network]
Name: NoNetSetupSecurityPage
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 25, 2002


Disable Printers Control Panel Icon (Windows 95/98/Me)

Disable Printers Control Panel Icon (Windows 95/98/Me)
Category: Home > Security > Control Panel

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This option disables access to the Printers icon in control panel, therefore stopping users from changing Printer settings.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoPrinters' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoPrinters | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoPrinters
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 25, 2002


Hide the General and Details Printer Pages (Windows 95/98/Me)

Hide the General and Details Printer Pages (Windows 95/98/Me)
Category: Home > Security > Control Panel > Printers

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This option hides the printer details and general printer information pages. Once enabled this option stops users from changing specific printer settings.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoPrinterTabs' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoPrinterTabs | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoPrinterTabs
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 25, 2002


Disable the Deletion of Printers (All Windows)

Disable the Deletion of Printers (All Windows)
Category: Home > Security > Control Panel > Printers

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Printers can be deleted simply by any user pressing the delete key, enabling this setting stops users from being able to delete printers.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoDeletePrinter' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoDeletePrinter | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoDeletePrinter
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 25, 2002


Disable the Addition of Printers (All Windows)

Disable the Addition of Printers (All Windows)
Category: Home > Security > Control Panel > Printers

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Any user can add a new printer their system, this option once enabled disables the addition of new printers to the computer.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoAddPrinter' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoAddPrinter | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoAddPrinter
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 25, 2002


Restrict Access to the Passwords Control Panel (Windows 95/98/Me)

Restrict Access to the Passwords Control Panel (Windows 95/98/Me)
Category: Home > Security > Control Panel > Passwords

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This option disables access to the Passwords icon on the control panel, therefore stopping users from changing security related settings.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoSecCPL' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoSecCPL | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
Name: NoSecCPL
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 27, 2002


Hide the Change Passwords Page (Windows 95/98/Me)

Hide the Change Passwords Page (Windows 95/98/Me)
Category: Home > Security > Control Panel > Passwords

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When this setting is enabled, users are no longer able to access the Change Passwords page.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoPwdPage' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoPwdPage | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
Name: NoPwdPage
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 25, 2002


Hide the Remote Administration Page (Windows 95/98/Me)

Hide the Remote Administration Page (Windows 95/98/Me)
Category: Home > Security > Control Panel > Passwords

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Enabling this function stops users from being able to change the remote administration settings for the computer.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoAdminPage' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoAdminPage | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
Name: NoAdminPage
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 25, 2002


Hide the User Profiles Page (Windows 95/98/Me)

Hide the User Profiles Page (Windows 95/98/Me)
Category: Home > Security > Control Panel > Passwords

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

The user profile page controls whether all users share or have separate user profiles, access to this page can be disabled by enabling this setting.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoProfilePage' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoProfilePage | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
Name: NoProfilePage
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 25, 2002


Hide the Device Manager Page (Windows 95/98/Me)

Hide the Device Manager Page (Windows 95/98/Me)
Category: Home > Security > Control Panel > System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether the Device Manager is visible, under System in the Control Panel.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoDevMgrPage' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoDevMgrPage | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
Name: NoDevMgrPage
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 25, 2002


Hide the Hardware Profiles Page (Windows 95/98/Me)

Hide the Hardware Profiles Page (Windows 95/98/Me)
Category: Home > Security > Control Panel > System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting when enabled hides the Hardware Profiles page from the System icon on the Control Panel.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoConfigPage' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoConfigPage | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
Name: NoConfigPage
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 25, 2002


Hide the File System Button (Windows 95/98/Me)

Hide the File System Button (Windows 95/98/Me)
Category: Home > Security > Control Panel > System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This option hides the File System button from the System icon on the Control Panel.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoFileSysPage' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoFileSysPage | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
Name: NoFileSysPage
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 25, 2002


Hide the Virtual Memory Button (Windows 95/98/Me)

Hide the Virtual Memory Button (Windows 95/98/Me)
Category: Home > Security > Control Panel > System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This option hides the Virtual Memory button from the System icon on the Control Panel.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoVirtMemPage' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoVirtMemPage | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
Name: NoVirtMemPage
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 25, 2002


Hide the File and Printer Sharing Controls (Windows 95/98/Me)

Hide the File and Printer Sharing Controls (Windows 95/98/Me)
Category: Home > Security > Control Panel > Network

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Enabling this options hides the file and printer sharing controls, stopping users from disabling or creating new file or printer shares.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoFileSharingControl' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoFileSharingControl | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Net... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Network]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Network]
Name: NoFileSharingControl
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 25, 2002


Disable Registry Editing Tools (All Windows)

Disable Registry Editing Tools (All Windows)
Category: Home > Windows > Accessories > Registry Editor

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction disables the ability to interactively run the standard Microsoft registry editing tools such as REGEDIT and REGEDT32.

Warning: Be careful with this setting because once you enter this key into the registry you will not be able to use Regedit to undo the change. Consider wisely before using this modification so that you do not lock yourself out of the registry.

Open your registry and find the key below.

Create a new DWORD value named 'DisableRegistryTools' and set the value to '1' to disable registry editing functions. This can also be enabled on a user-by-user basis by putting the same value in the [HKEY_CURRENT_USER] hive.

Restart Windows for the change to take effect.

If you have inadvertently locked yourself out of your registry you can use usually use WinGuides Tweak Manager to unlock it. Please don't abuse this by trying to circumvent system administrator policies.

Note: This setting will disable all standard Microsoft registry editing tools, but not WinGuides Tweak Manager.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DisableRegistryTools | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System |
-

Settings:
User Key: [HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\
System]
Name: DisableRegistryTools
Type: REG_DWORD (DWORD Value)
Value: (0 = allow regedit, 1 = disable regedit)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 7, 2003


Hide the Internet Explorer Icon (All Windows)

Hide the Internet Explorer Icon (All Windows)
Category: Home > Software > Internet Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This option hides the Internet Explorer icon from the Windows desktop.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoInternetIcon' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoInternetIcon | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoInternetIcon
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 14, 2002


Change the Default Name and Company Information (All Windows)

Change the Default Name and Company Information (All Windows)
Category: Home > Software

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When you install a new application, using MS Setup, a default Name and Company are shown, these values can be changed when the details have changed or are incorrect.

Open your registry and find the key below.

Modify the two values named 'DefName' and 'DefCompany', and change the values to your current Name and Company respectively.

The next time you install a program these new values will be used as the defaults instead.

Note: This will not affect the registered names of existing applications, it only affects new installations.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DefName | REG_SZ | "Joan Bloggs" | |
| |  | DefCompany | REG_SZ | "ACME, Inc." | |
-
| HKEY_CURRENT_USER\Software\Microsoft\MS Setup (ACME)\User Info |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\MS Setup (ACME)\User Info]
Name: DefName, DefCompany
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 22, 2002


Changing the Default Printer Spool Directory (Windows NT/2000/XP)

Changing the Default Printer Spool Directory (Windows NT/2000/XP)
Category: Home > Hardware > Printers and Plotters

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows uses the hard drive to store information before sending it to a printer. If the system is acting as a print server it is possible that the default location may cause insufficient disk space.

Create a new directory to act as the Printer spool directory.

Open your registry and find the key below.

Change the value of 'DefaultSpoolDirectory" to equal the full path of the newly created directory.

Restart Windows or stop and start the 'Spooler' service.

The default directory is: %SystemRoot%\system32\spool\PRINTERS

To change the spool directory for a specific printer only, find the sub-key under the key below that corresponds to the printer required. Modify the value of 'SpoolDirectory' to equal the directory you want to use.

Note: This directory must be created manually, if the it does not exist Windows will use the default.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | DefaultSpoolDirectory | REG_SZ | "D:\SPOOLER" | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Printers |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Printers]
Name: DefaultSpoolDirectory
Type: REG_SZ (String Value)
Value: Full path to printer spool directory

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 26, 2002


Change LAN Auto-disconnect Timeout (Windows NT/2000/XP)

Change LAN Auto-disconnect Timeout (Windows NT/2000/XP)
Category: Home > Network > Servers

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows can be configured to automatically disconnect idle LAN sessions are a set number of minutes.

Open your registry and find the key below.

Modify the value, or create a new string value, called 'Autodisconnect' and set it to equal the time in minutes before a session is disconnected.

Restart Windows for the change to take effect.

Note: Set the value to 0xffffffff to disable the disconnection function.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Autodisconnect | REG_DWORD | 0xffffffff (4294967295) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parame... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\
Parameters]
Name: Autodisconnect
Type: REG_DWORD (DWORD Value)
Value: 0 to 4,294,967,295 (0xffffffff) in minutes

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2002


Changing the Behavior of the Dr Watson Utility (Windows NT/2000)

Changing the Behavior of the Dr Watson Utility (Windows NT/2000)
Category: Home > Windows > Accessories > Dr Watson

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

By default whenever an application error occurs in Windows NT, Dr Watson is launched and the debugger started automatically. The extra resources needed for the debugger can sometimes push the system over the edge. It is possible to stop the debugger from launching by changing this setting.

Open your registry and find the key below.

Change the value of 'Auto' to equal '0' to disable the automatic debugger.

Restart Windows for the change to take effect.

Note: To disable Dr. Watson completely simply delete the AeDebug subkey and then to re-enable simple execute the command 'drwtsn32 -i'.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Auto | REG_SZ | "0" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AeDebug |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AeDebug]
Name: Auto
Type: REG_SZ (String Value)
Value: (0 = message, 1 = debugger & message)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 27, 2002


Change the Default NumLock State (Windows NT/2000/XP)

Change the Default NumLock State (Windows NT/2000/XP)
Category: Home > Windows > Troubleshooting

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

The NumLock key is usually only turned on before the user has logged into the computer, this can cause problem for people with portable computers that do not check the status of the NumLock key before typing their password. The default behavior can be changed with this setting.

Open your registry and find the key below.

Change the value of 'InitialKeyboardIndicators' to either '0' for off, or '2' for on.

Note: This change will affect all users but value can also be changed on a user-by-user basis by modifying [HKEY_CURRENT_USER\Control Panel\Keyboard] using the same values.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | InitialKeyboardIndicators | REG_SZ | "2" | |
-
| HKEY_USERS\.DEFAULT\Control Panel\Keyboard |
-

Settings:
User Key: [HKEY_USERS\.DEFAULT\Control Panel\Keyboard]
Name: InitialKeyboardIndicators
Type: REG_SZ (String Value)
Value: 0 = NUMLOCK is turned off after logon, 2 = NUMLOCK is turned on after logon

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 29, 2003


Removing Windows Devices and Services (Windows NT/2000)

Removing Windows Devices and Services (Windows NT/2000)
Category: Home > Windows > System > Services

Sometimes it is possible to get orphaned services remaining in the registry. These services can be remove be modifying this key.

Open your registry and find the key below.

Under this key are subkeys representing each device and service installed on the machine.

To remove, first stop the service through Control Panel / Services, then locate the subkey corresponding to device or service and delete it.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services]

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 6, 1999


Changing the Startup Mode of a Service (Windows NT/2000)

Changing the Startup Mode of a Service (Windows NT/2000)
Category: Home > Windows > System > Services

All services have a setting controlling how they are started either manually, automatically or disabled. This setting can be changed through the registry.

Open your registry and file the key below.

Listed under this key are subkeys representing the devices and services on the system.

Open the subkey corresponding to the service you wish to change, and modify the value of 'Start' to equal either "2" (for automatic), "3" (for manual) or "4" (for disabled)

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Start | REG_DWORD | 0x00000002 (2) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services]
Name: Start
Type: REG_DWORD (DWORD Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 6, 1999


Automatically Ending Hung Applications (All Windows)

Automatically Ending Hung Applications (All Windows)
Category: Home > Windows > Startup and Shutdown

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When this tweak is enabled it will force Windows to shutdown immediately ending all tasks without attempting to safely close any applications that have hung.

Open your registry and find the key below.

Modify the value of 'AutoEndTasks' to equal '1' to automatically end tasks or '0' to prompt for action.

The default time-out before ending the task is defined by the value of 'WaitToKillAppTimeout' located in the same key, this value is in milliseconds (default = 20000 i.e. 20 seconds). You can therefore additionally change this value to speed the process up.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AutoEndTasks | REG_SZ | "1" | |
| |  | WaitToKillAppTimeout | REG_SZ | "10000" | |
-
| HKEY_CURRENT_USER\Control Panel\Desktop |
-

Settings:
User Key: [HKEY_CURRENT_USER\Control Panel\Desktop]
System Key: [HKEY_USERS\.DEFAULT\Control Panel\Desktop]
Name: AutoEndTasks
Type: REG_SZ (String Value)
Value: (0 = disabled, 1 = enabled)

Related Tweaks

  • Specify the Response Time for Hung Applications (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 19, 2002


Removing or Adding Items to Your Persistent Connections List (All Windows)

Removing or Adding Items to Your Persistent Connections List (All Windows)
Category: Home > Network

Windows stores the names of previously mapped drives in the registry, this can be a security threat if vulnerable hidden shares are listed. An advantage is that this key can also be used to set default items for list, if for example inexperienced users were required to map common drives, you could store them here.

Open your registry and find the key below depending on your Windows version.

Windows 95, 98 and Me
[HKEY_CURRENT_USER\Network\Persistent]

Windows NT, 2000 and XP
[HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Network\Persistent Connections]

Listed under this key are all the shares Windows has stored for the current user, simply delete the entries you don't want to store or add new ones by adding a new string value, and name it by incrementing the alpha values already in the list. Set the data to equal the drive share you wish to add.

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 26, 2002


Control the Default Virtual Machine Option (Windows NT/2000/XP)

Control the Default Virtual Machine Option (Windows NT/2000/XP)
Category: Home > Windows > System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When starting a 16bit application you have the option of running each in a separate virtual machine (VDM). With this setting you can change the default value.

Having a separate virtual machine, has the advantage that if the applications crashes only that one application is affected, on the down side it takes more system resources.

Open your registry and find the key and value below, if they don't already exist create them.

Change the value of 'DefaultSeparateVDM' to either 'Yes' or 'No'.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | DefaultSeparateVDM | REG_SZ | "Yes" | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\WOW |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\WOW]
Name: DefaultSeparateVDM
Type: REG_SZ (String Value)
Value: 'Yes' or 'No'

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 7, 1999


Configuring Unimodem Support (Windows NT)

Configuring Unimodem Support (Windows NT)
Category: Home > Hardware > Network and Modems

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows NT 4.0 and greater support Unimodem modems, if your device is not supported though Windows can be configured to use the MODEM.INF file instead.

Open your registry and find the key below.

Create a new DWORD value named "EnableUnimodem" and set it to equal to '0' for disabled.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | EnableUnimodem | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\RAS\PROTOCOLS |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\RAS\PROTOCOLS]
Name: EnableUnimodem
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 14, 2002


Secure Access to CD-ROM Drives (Windows NT/2000/XP)

Secure Access to CD-ROM Drives (Windows NT/2000/XP)
Category: Home > Security > System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting determines whether data in the CD-ROM drive is accessible to other users.

Because the CD-ROM drive is a volume, by default, it is shared as an administrative share on the network. If the value of this entry is 1, the CD-ROM drive is allocated to the user as part of the interactive logon process and, therefore, only the current user can access it. This prevents administrators and remote users (and even the same user at a different workstation) from accessing the drive while the current user is logged on to the computer. The drive is shared again when the current user logs off the computer.

Value Meanings:

  • '0' = Compact discs in the CD-ROM drive can be accessed by all administrators in the domain.

  • '1' = Only the user logged on locally can access data on the compact discs in the CD-ROM drive.
    •

    Note: This value entry satisfies, in part, the C2 security requirement that you must be able to secure removable media.

    Registry Editor Example
    | | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AllocateCDRoms | REG_SZ | "1" | |
    -
    | HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
    -

    Settings:
    System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
    Name: AllocateCDRoms
    Type: REG_SZ (String Value)
    Value: (0 = enabled, 1 = disabled)

    Related Tweaks

    • Secure Access to Removable Drives (Windows NT/2000/XP)
    • Secure Access to Floppy Drives (Windows NT/2000/XP)

    Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

    Last Modified: April 3, 2002


Secure Access to Floppy Drives (Windows NT/2000/XP)

Secure Access to Floppy Drives (Windows NT/2000/XP)
Category: Home > Security > System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting determines whether data in the floppy disk drive is accessible to other users.

Because the floppy disk drive is a volume, by default it is shared as an administrative share on the network. If the value of this entry is 1, the floppy disk drive is allocated to the user as part of the interactive logon process and, therefore, only the current user can access it. This prevents administrators and remote users (and even the same user at a different workstation) from accessing the drive while the current user is logged on. The drive is shared again when the current user logs off.

Value Meanings:

  • '0' = Floppy disks in the floppy disk drive can be accessed by all administrators in the domain.

  • '1' = Only the user logged on locally can access data on the floppy disks in the floppy disk drive.
    •

    Note: This value entry satisfies, in part, the C2 security requirement that you must be able to secure removable media.

    Registry Editor Example
    | | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AllocateFloppies | REG_SZ | "1" | |
    -
    | HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
    -

    Settings:
    System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
    Name: AllocateFloppies
    Type: REG_SZ (String Value)
    Value: (0 = enabled, 1 = disabled)

    Related Tweaks

    • Secure Access to Removable Drives (Windows NT/2000/XP)
    • Secure Access to CD-ROM Drives (Windows NT/2000/XP)

    Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

    Last Modified: April 3, 2002


Restart the Shell Automatically (Windows NT/2000/XP)

Restart the Shell Automatically (Windows NT/2000/XP)
Category: Home > Security > System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

By default if the Windows user interface or one of its components fails, the interface is restarted automatically, the can be changed so that you must restart the interface by logging off and logging on again manually.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'AutoRestartShell' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AutoRestartShell | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: AutoRestartShell
Type: REG_DWORD (DWORD Value)
Value: (0 = disable, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 3, 2002


Delay Occurs When Unlocking Workstation (Windows NT/2000)

Delay Occurs When Unlocking Workstation (Windows NT/2000)
Category: Home > Windows > Troubleshooting

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Sometimes a noticeable delay occurs when the logged on user or an administrator attempts to unlock a workstation. This because when you unlock the workstation Windows will update the domain list if the cached list's age exceeds two minutes (by default). This age limit can be modified.

Open your registry and find the key below..

Create a new DWORD value, or modify the existing value, named "DcacheMinInterval" and set it to equal the new cache time-out in seconds (decimal).

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DcacheMinInterval | REG_DWORD | 0x000000f0 (240) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: DcacheMinInterval
Type: REG_DWORD (DWORD Value)
Value: 120-86400 (decimal) (expressed in seconds)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 7, 1999


Automatically Use Dial-Up Networking to Logon (Windows NT/2000)

Automatically Use Dial-Up Networking to Logon (Windows NT/2000)
Category: Home > Security > Remote Access

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

There is an option that is available on the logon dialog box and allows you to dial into your logon server for authentication of your user account, this can be enabled by default.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'RasForce' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: See Microsoft Support article Q263743 for details of a bypass issue.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | RasForce | REG_SZ | "1" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: RasForce
Type: REG_SZ (String Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 3, 2002


Manage the Domain Controller Cannot Be Reached Message (Windows NT/2000/XP)

Manage the Domain Controller Cannot Be Reached Message (Windows NT/2000/XP)
Category: Home > Network

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When Windows is unable to contact a domain controller during a users login a popup error message may be displayed, this message can be controlled by modifying this setting.

To control the following message:

A domain controller for your domain could not be contacted. You have been logged on using cached account information. Changes made to your profile since you last logged on may not be available.

Per User Parameter

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, named 'ReportDC' and set it to equal '0' to suppress the message.

System-Wide Parameter

On Windows 2000 and above this message is supressed by default, to modify it open your registry and find the key:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft \Windows NT\CurrentVersion\Winlogon]

Create a new string value called "ReportControllerMissing" and set it to "TRUE" to report errors, or "FALSE" to suppress errors.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ReportDC | REG_DWORD | 0x00000001 (1) | |
| |  | ReportControllerMissing | REG_SZ | TRUE | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: ReportDC, ReportControllerMissing
Type: REG_DWORD (DWORD Value)
Value: (0 = message is suppressed, 1 = message is not suppressed)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 26, 2002


Changing the Password Expiry Warning Period (Windows NT/2000/XP)

Changing the Password Expiry Warning Period (Windows NT/2000/XP)
Category: Home > Security > Network

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This entry specifies the number of days before a user's password expires that a warning message is displayed.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'PasswordExpiryWarning' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | PasswordExpiryWarning | REG_DWORD | 0x00000007 (7) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: PasswordExpiryWarning
Type: REG_DWORD (DWORD Value)
Value: Number of Days (Default = 14)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 23, 2002


Specify Executable Files to be Lauched by Winlogon (Windows NT/2000/XP)

Specify Executable Files to be Lauched by Winlogon (Windows NT/2000/XP)
Category: Home > Security > System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting specifies a list of executable files to be run by Winlogon in the system context when Windows starts.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'System' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | System | REG_SZ | "lsass.exe" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: System
Type: REG_SZ (String Value)
Value: (default = lsass.exe)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 3, 2002


Double Buffering Hard Disk Support (Windows 95/98)

Double Buffering Hard Disk Support (Windows 95/98)
Category: Home > Windows > File System > Caching and Memory

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows 98 includes double buffering support, some systems may have an incompatibility between the computer's BIOS and the Dblbuff.sys file.

Open your MSDOS.SYS file in the root directory using Notepad.

Add a new line, or modify the existing line, "DoubleBuffer=value" where value is an number from the list below.

  • 0 - Disable double buffering
  • 1 - Use double buffering only if required
  • 2 - Always use double buffering
Restart Windows for the change to take effect.

Note: Some computers, especially those that use a SCSI or older ESDI/IDE/ATA hard disk, may require double buffering to work properly.

Settings:
Name: DoubleBuffer

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: July 24, 2002


Modifying the [Paths] Section of MSDOS.SYS (Windows 95/98/Me)

Modifying the [Paths] Section of MSDOS.SYS (Windows 95/98/Me)
Category: Home > Tips and Tricks > Configuration Files > MSDOS.SYS

The [Paths] section lists the locations for other Windows 95 files (such as the registry) and can be modified if files are moved.

The [Paths] section can contain the following settings:

HostWinBootDrv=[Root of Boot Drive]
Specifies the location for the root of the boot drive.
Default: C

UninstallDir=[Root of Boot Drive]
Specifies the location of the W95undo.dat and W95undo.ini files. These files are necessary to uninstall Windows 95 and this setting is present only if you back up your system files when you are prompted during Windows 95 Setup.
Default: C

WinBootDir=[Windows Directory]
Lists the location of the necessary files for booting.
Default: Directory specified during Setup (for example, C:\WINDOWS)

WinDir=[Windows Directory] Lists the location of the Windows 95 directory specified during Setup.
Default: Directory specified during Setup (for example, C:\WINDOWS)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 7, 1999


Force Computer to Boot in Safe Mode (Windows 95/98/Me)

Force Computer to Boot in Safe Mode (Windows 95/98/Me)
Category: Home > Tips and Tricks > Configuration Files > MSDOS.SYS

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting when enabled forces your computer to always boot in Safe Mode.

Add a new value of 'BootSafe=' to MSDOS.SYS.

Set the value to '1' to always boot in Safe mode or '0' to run normally.

Settings:
Name: BootSafe
Value: (1=enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 27, 2002


Suppress Safe Mode Warning Message (Windows 95/98/Me)

Suppress Safe Mode Warning Message (Windows 95/98/Me)
Category: Home > Tips and Tricks > Configuration Files > MSDOS.SYS

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Enabling this setting suppresses the safe mode warning message when booting up, and bypasses the Startup menu.

Add a new value of 'BootWarn=' to MSDOS.SYS.

Set the value to '1' to ignore the Safe mode warning or '0' to run normally.

Settings:
Name: BootWarn
Value: (1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 14, 2002


Load Compression Driver into Low Memory (Windows 95/98/Me)

Load Compression Driver into Low Memory (Windows 95/98/Me)
Category: Home > Tips and Tricks > Configuration Files > MSDOS.SYS

This setting controls whether double space (or drive space) is loaded into high memory. If you are having compatibility problems with software that makes assumptions about the available memory try changing this setting.

A setting of 0 does not let Windows 95 load COMMAND.COM or DRVSPACE.BIN/DBLSPACE.BIN at the top of 640K.

Change the attributes for MSDOS.SYS so it is not 'Read Only', MSDOS.SYS is found in the root directory of your C:\ drive. Open the file using Notepad or another text editor (not Microsoft Word or any word processor).

Add a new line with the following text 'LoadTop=0' to load the compression driver into low memory.

Changes will take place on the next reboot.

Settings:
Name: LoadTop
Value: (0 = load in low memory)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 7, 1999


Control Long Filename Support (All Windows)

Control Long Filename Support (All Windows)
Category: Home > Windows > File System > Files and Shortcuts

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows allows the use of long filenames on FAT partitions. Some legacy software may be incompatible with this new file system design, and may require the use of 8.3 filenames. By enabling this setting you can turn off long filename support.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'Win31FileSystem' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Win31FileSystem | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem]
Name: Win31FileSystem
Type: REG_DWORD (DWORD Value)
Value: (0 = long file names, 1 = 8.3 filenames)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 5, 2002


Configure Protected-Mode Hard Disk Interrupt Handling (Windows 95/98/Me)

Configure Protected-Mode Hard Disk Interrupt Handling (Windows 95/98/Me)
Category: Home > Hardware > Disk Drives

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This switch allows Windows to terminate interrupts from the hard disk controller, bypassing the ROM routine that handles these interrupts. Some hard drives might require that this setting be disabled in order for interrupts to be processed correctly. If this setting is disabled, the ROM routine handles the interrupts.

Open your registry and find the key below.

Create a new Binary value, or modify the existing value called 'VirtualHDIRQ' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | VirtualHDIRQ | REG_BINARY | 00 00 00 00 | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem]
Name: VirtualHDIRQ
Type: REG_BINARY (Binary Value)
Value: (00 00 00 00 = disabled, 01 00 00 00 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 14, 2002


Configure New File Sharing and Locking Semantics (Windows 95/98/Me)

Configure New File Sharing and Locking Semantics (Windows 95/98/Me)
Category: Home > Windows > File System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls the file locking mechanisms of Windows, disable this setting only if you are currently experiencing problems with specific applications.

Open your registry and find the key below.

Create a new Binary value, or modify the existing value called 'SoftCompatMode' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SoftCompatMode | REG_BINARY | 00 00 00 00 | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem]
Name: SoftCompatMode
Type: REG_BINARY (Binary Value)
Value: (00 00 00 00 = disabled, 01 00 00 00 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 14, 2002


Preserving Long Filenames for Legacy Applications (Windows 95/98/Me)

Preserving Long Filenames for Legacy Applications (Windows 95/98/Me)
Category: Home > Windows > File System > Files and Shortcuts

Windows normally preserves the long filenames of files accessed by legacy applications. This functionality can be disabled if you are experiencing LFN errors with a legacy application.

Open your registry and find the key below.

Create a new Binary value, or modify the existing value called 'PreserveLongNames' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | PreserveLongNames | REG_BINARY | 00 00 00 00 | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem]
Name: PreserveLongNames
Type: REG_BINARY (Binary Value)
Value: (00 00 00 00 = disabled, ff ff ff ff = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 12, 1999


Configure 32-bit Protected Mode IO Drivers (Windows 95/98/Me)

Configure 32-bit Protected Mode IO Drivers (Windows 95/98/Me)
Category: Home > Windows > File System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether fixed disk access is performed through Windows protected mode drivers or through real mode drivers and BIOS routines. If you are experiencing drive IO errors enabling this setting may be a possible solution.

Open your registry and find the key below.

Create a new Binary value, or modify the existing value called 'ForceRMIO' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ForceRMIO | REG_BINARY | 00 00 00 00 | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem]
Name: ForceRMIO
Type: REG_BINARY (Binary Value)
Value: (00 00 00 00 = protected mode, 01 00 00 00 = real mode)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 28, 2002


Control Write Behind Caching (Windows 95/98/Me)

Control Write Behind Caching (Windows 95/98/Me)
Category: Home > Windows > File System > Caching and Memory

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

For increased performance write behind caching is used to write data to the fixed disks, this means that in the event of a system failure there is a possibility that data would not be completely written to the disk. If you have a system critical application you can disable this functionality to be sure that data is written directly to the disk bypassing the cache.

Open your registry and find the key below.

Create a new Binary value, or modify the existing value called 'DriveWriteBehind' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DriveWriteBehind | REG_BINARY | 00 00 00 00 | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem]
Name: DriveWriteBehind
Type: REG_BINARY (Binary Value)
Value: (00 00 00 00 = disable, 01 00 00 00 = enable write behind)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 28, 2002


Use Asynchronous or Synchronous Buffer Commits (Windows 95/98/Me)

Use Asynchronous or Synchronous Buffer Commits (Windows 95/98/Me)
Category: Home > Windows > File System > Caching and Memory

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting changes function calls to the File-Commit API to return immediately back without checking the data has been correctly written to the disk drive. By default Windows uses synchronous buffer commits, this setting allows you to enable asynchronous as an alternative for applications that may need this functionality.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'AsyncFileCommit' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AsyncFileCommit | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem]
Name: AsyncFileCommit
Type: REG_DWORD (DWORD Value)
Value: (0 = sync, 1 = async)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 14, 2002


Add Your Own Tips (All Windows)

Add Your Own Tips (All Windows)
Category: Home > Windows

Are you sick of seeing the same tips again and again when you first logon to Windows? Now you can change them to whatever you want, whether it's quotes, jokes or a to-do list, anything is possible.

Open your registry and find the key below.

Create a new string valued named by incrementing the existing value names and set it to the required tip text.

To remove, highlight and delete the value.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Z | REG_SZ | "Don't forget to visit ..." | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Tips |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\
Tips]
Type: REG_SZ (String Value)
Value: Tip Text

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: November 28, 2000


'Failure Writing to the System Registry...' Error Message (Windows 95)

'Failure Writing to the System Registry...' Error Message (Windows 95)
Category: Home > Windows > Troubleshooting

When you run a setup program that was created using the Application Setup Wizard, you may receive an error message indicating the registry may be corrupt or you do not have the required permissions to write to the registry.

As the error message indicates, the problem may be due to a corrupt registry or incorrect permissions to write to the registry. In addition, the problem occurs on computers running Windows 95 when the Setup program tries to add an entry to a registry key and the key will exceed 64K in size as a result. Registry keys are limited to 64K in Windows 95.

When the problem occurs on a Windows 95 computer, it usually happens when Setup tries to add entries to the key below.

Try running the RegClean utility provided by Microsoft, a link can be found at our downloads page. Alternatively have a look at the Microsoft Knowledge Base article referenced below.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SharedDLLs]

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: November 28, 2000


Live Scrolling in Microsoft Word (All Windows)

Live Scrolling in Microsoft Word (All Windows)
Category: Home > Software > Microsoft Office > Word

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Normally when you move through a Word document using the scroll bar the page doesn't update until you release the mouse button. With this tweak the document location is updated as you move.

Open your registry and find the key below where [Office Version] is either 8.0, 9.0 or 10.0.

For Word 97 and 2000 create a new string value, or modify the existing value, named 'LiveScrolling' and set it to equal '1' for live scrolling enabled or '0' for disabled.

For Word 2002 create a new DWORD value, or modify the existing value, named 'NoLiveScrolling' and set it to equal '0' for live scrolling enabled or '1' for disabled.

Close the registry and restart Word.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | LiveScrolling | REG_SZ | 1 | |
| |  | NoLiveScrolling | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Office\[Office Version]\Word\Options |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Office\[Office Version]\Word\
Options]
Name: LiveScrolling, NoLiveScrolling
Type: REG_SZ (String Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 3, 2002


Automatically Reboot on the 'Blue Screen of Death' (Windows NT/2000/XP)

Automatically Reboot on the 'Blue Screen of Death' (Windows NT/2000/XP)
Category: Home > Windows > Startup and Shutdown

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows will usually freeze when getting a dreaded 'Blue Screen of Death' (BSOD). Changing this setting will force Windows to automatically reboot when it crashes instead.

Open your registry and find the key below.

Change the value of 'AutoReboot' to equal '1' for automatic reboot, or '0' for disabled.

Restart Windows for the change to take effect.

Note: This function can also be enabled from 'Control Panel -> System -> Startup/Shutdown -> Automatically Reboot'. This feature is enabled by default on NT server, and disabled on NT Workstation.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AutoReboot | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CrashControl |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CrashControl]
Name: AutoReboot
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 20, 2002


Disable Automatic Network Shortcut Resolution (All Windows)

Disable Automatic Network Shortcut Resolution (All Windows)
Category: Home > Windows > File System > Files and Shortcuts

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When you create a shortcut to a resource on a mapped network drive, and then remap the same drive to a different network resource, Windows attempts to connect to the original network resource when you access the shortcut.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'LinkResolveIgnoreLinkInfo' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | LinkResolveIgnoreLinkInfo | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: LinkResolveIgnoreLinkInfo
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Related Tweaks

  • Disable Tracking of Broken Shortcut Links (Windows 2000/XP)
  • Comprehensive Search for Broken Shortcuts (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 5, 2002


Speed Up ISP Logon Time (Windows 95/98/Me)

Speed Up ISP Logon Time (Windows 95/98/Me)
Category: Home > Hardware > Network and Modems

On some systems it can take a long time to connect to the Internet, you can decrease the time required to connect to your ISP by trying these simple steps.

Open the Dial-Up Networking folder, right click on the icon for your ISP and select 'Properties'.

Chose the 'Server Types' tab, and then under Advanced Options uncheck the 'Log on to network' box, and make sure that 'Enabled Software Compression' is checked. From under Allowed Network Protocols uncheck 'NetBEUI' and 'IPX/SPX Compatible'.

Next time you connect to your ISP, the connection should be a little faster.

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 20, 2001


Faster Modem Dialing (Windows 95/98/Me)

Faster Modem Dialing (Windows 95/98/Me)
Category: Home > Hardware > Network and Modems

Waiting to long for your modem to dial? This tip lets you reduce the time it takes your modem to dial, and increase your overall modem connection speed.

Open Control Panel -> Modems, select your modem and click on Properties. Select the Connection tab, and click on 'Advanced'.

In the text box that is labeled 'Extra Settings' at the following text (without the quotation marks) 'S11=40'.

The number specified after S11= (in this case 40) is the time for each tone in milliseconds. Lower numbers equals faster dialing. If your having problems connecting try increasing the number until it works.

Note: This may not work as planned in some countries and with some modems.

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 20, 2001


Re-Initialize Your Registry Without Rebooting (All Windows)

Re-Initialize Your Registry Without Rebooting (All Windows)
Category: Home > Tips and Tricks > Keyboard Shortcuts

Some registry changes require you to restart Windows before they are enabled. This tip lets you re-initialize your registry and refresh your desktop without having to leave Windows.

Save your work before attempting this tip!

Press CTRL + ALT + DELETE, to bring up the Windows task list. Highlight 'Explorer' and click on 'End Task', if the Shutdown screen is shown, click 'Cancel'. After a few seconds an error message will popup, click on 'End Task' and the Windows explorer will be reloaded along with any new registry settings.

For Windows NT or 2000, press Ctrl + Alt + Delete and select "Task Manager". Choose the "Processes" tab and locate the "explorer.exe" process, highlight it and click "End Process". Select 'File -> New Task', then enter 'explorer' and click OK.

Hint: For other ways to launch the task manager have a look at this article.

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 20, 2001


Make the Columns Fit (All Windows)

Make the Columns Fit (All Windows)
Category: Home > Tips and Tricks > Keyboard Shortcuts

Want to quickly see all the column in explorer without having to resize them individually? This tip does it for you.

Simple press CTRL + + (press the plus button twice on the numeric keypad), this will adjust the column width so you can view the info in each column.

This tip may also work with programs based on the Windows explorer interface. Try it out!

Note: You may have to expand the window borders to see all the columns.

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 2, 1999


Close Parent Windows Automatically (All Windows)

Close Parent Windows Automatically (All Windows)
Category: Home > Tips and Tricks > Keyboard Shortcuts

Have you ever had a screen full of explorer windows on your desktop after digging through heaps of directories? This tip lets you close the current window and all it's parent windows in one easy step.

To close a folder and all its open parent folders, simply press the SHIFT key while clicking on its Close box or alternatively press ALT + SHIFT + F4.

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 2, 1999


Expand and Contract Folders With Ease (All Windows)

Expand and Contract Folders With Ease (All Windows)
Category: Home > Tips and Tricks > Keyboard Shortcuts

It can be a time-consuming process to expand a folder by clicking on the (+) for each and every sub-directory. This tip lets you expand and contract them all at once, with one keystroke.

While in any application that is based on the explorer interface (e.g. Windows Explorer) simple highlight the parent folder you wish to expand and press '*' (asterix on the keypad) and all the sub folders will expand out, press '-' (minus on the keypad) and they'll all contract back again.

Hint: This works in regedit.exe as well!

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 2, 1999


Modify the Duration that the Startup List is Displayed (Windows NT/2000/XP)

Modify the Duration that the Startup List is Displayed (Windows NT/2000/XP)
Category: Home > Tips and Tricks > Configuration Files > BOOT.INI

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allows you to change the default 30 second timeout for the Startup List which normally allows you time to choose and boot an alternative operating system.

Using Windows explorer find the file called BOOT.INI on your system drive. Change the attributes of the file from read-only, by right clicking on it and choosing Properties, and then under Attributes, uncheck 'Read-only'. Then double-click on BOOT.INI and it should open in Notepad.

Under the [boot loader] section is a value called "timeout=". The number after the "=" sign is the time in seconds Windows will wait for a selection. Change the value according to the options below.

  • Set the value to the number of seconds between 1 and 999.
  • To make Windows boot instantly change this value to "0" (i.e. timeout=0).
  • To make Windows wait indefinitely change this value to "-1" (i.e. timeout=-1).
Save the file, and restart Windows for the change to take effect.

Note: The default operating system is defined with the "default=" parameter in BOOT.INI.

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 12, 2002


Clear the Page File at System Shutdown (Windows NT/2000/XP)

Clear the Page File at System Shutdown (Windows NT/2000/XP)
Category: Home > Security > Privacy

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows does not normally clear or recreate the page file. On a heavily used system this can be both a security threat and performance drop. Enabling this setting will cause Windows to clear the page file whenever the system is shutdown.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'ClearPageFileAtShutdown' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: Please note on systems with large amounts of memory, and therefore large swap-file, this tweak could cause a delay at shutdown due to the additional time taken to clear the data from the file.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ClearPageFileAtShutdown | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memo... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\
Memory Management]
Name: ClearPageFileAtShutdown
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 14, 2003


Change Directories Without Typing the Whole Name (Windows NT/2000)

Change Directories Without Typing the Whole Name (Windows NT/2000)
Category: Home > Tips and Tricks > Keyboard Shortcuts

Changing directories at the command prompt can be a hit and miss process when long filenames are involved. This tip let you change directories with ease, not matter how long the directory name.

To change a directory quickly you can use wildcards, for example, to change to the 'C:\Program Files' directory simply type:

cd c:\prog*

Note: This will work in alphabetical order, therefore if you have two directories named 'c:\dir1' and 'c:\dir2' and you type cd dir*, you will be moved to the 'c:\dir1' directory.

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 2, 1999


Launch the Task Manager Quickly (Windows NT/2000/XP)

Launch the Task Manager Quickly (Windows NT/2000/XP)
Category: Home > Tips and Tricks > Keyboard Shortcuts

Launching the Task Manager can sometimes be difficult depending on the situation. Some people didn't know that the Task Manager can actually be launched in at least three different ways to make it easier to use when you need it the most.

First Method:
Press CTRL + ALT + DELETE and click on the 'Task Manager...' button on the Windows NT Security dialog.

Second Method:
Right click on the Windows NT taskbar and chose 'Task Manager...'

Third Method:
Press CTRL + SHIFT + ESC and the Task Manager will be launched instantly.

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 2, 1999


Change the Message Shown on the Logon Box (Windows NT/2000/XP)

Change the Message Shown on the Logon Box (Windows NT/2000/XP)
Category: Home > Security > Login and Authentication

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

You can personalize (or legalize) the message displayed on the logon box above the user name and password.

Open your registry and find the key below.

Create a new string value named 'LogonPrompt' and enter the text you want to display. The default message is: 'Enter a user name and password that is valid for this system.'

This feature can be used in conjunction with the Legal Notice Dialog Box Before Logon tweak.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | LogonPrompt | REG_SZ | "Enter your name and..." | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: LogonPrompt
Type: REG_SZ (String Value)

Related Tweaks

  • Legal Notice Dialog Box Before Logon (All Windows)
  • Customize the Windows Logon and Security Dialog Title (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 22, 2002


Enable Plug and Play on Windows NT (Windows NT 4.0)

Enable Plug and Play on Windows NT (Windows NT 4.0)
Category: Home > Windows > System

Windows NT4 does not support plug-and-play devices out of the box, but it can be configured to a least partially support some PnP features with a little help.

Find the directory on your Windows NT CD-ROM called \Drvlib\Pnpisa, then open the directory for your system type (standard PC's are x86 or i386). In this directory are two files. To install plug-and-play support, right-click on the file called 'Pnpisa.inf' and select install.

Restart Windows for the changes to take effect.

Note: Windows NT should now detect PnP devices, but you may have to configure the settings manually.

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 2, 1999


Secure Network Access to the Windows Registry (Windows NT/2000/XP)

Secure Network Access to the Windows Registry (Windows NT/2000/XP)
Category: Home > Security > System

Windows supports accessing a remote registry via the Registry Editor across a network. The default setting allows for users to connect and modify data within the remote registry.

By creating the new key listed below, or modifying the existing key if it already exits, it is possible to control access to the registry remotely.

Use REGEDT32 to modify the permissions on the key below to suit your security requirements, the permissions on this key represent the remote access permissions to the registry.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurePipeServers\
winreg]

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 3, 2002


Unable to Connect More Than 10 Clients (Windows NT)

Unable to Connect More Than 10 Clients (Windows NT)
Category: Home > Windows > Troubleshooting

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

If you have a retail version of Windows NT server, and you are still unable to connect more the 10 users concurrently, then have a look at this tip.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'Users' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Users | REG_DWORD | 0xffffffff (4294967295) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parame... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\
Parameters]
Name: Users
Type: REG_DWORD (DWORD Value)
Value: (0xffffffff = unlimited)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 2, 1999


Power the Computer Off After Shutdown (Windows NT/2000/XP)

Power the Computer Off After Shutdown (Windows NT/2000/XP)
Category: Home > Hardware

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether Windows should automatically power down or reboot your computer once it has finished the shutdown process.

Open your registry and find the key below.

Create a new string value, or modify the existing value, called PowerdownAfterShutdown and set it to "1" to power off the computer at shutdown, or "0" to reboot.

Restart Windows for the change to take effect.

Note: This feature must be supported by the computer's BIOS.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | PowerdownAfterShutdown | REG_SZ | "1" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: PowerdownAfterShutdown
Type: REG_SZ (String Value)
Value: (0 = default, 1 = power down)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 20, 2002


Addition of New LAN Interface in RRAS Causes Event Message (Windows NT)

Addition of New LAN Interface in RRAS Causes Event Message (Windows NT)
Category: Home > Windows > Troubleshooting

When you install an additional network interface card (NIC) and the Routing and Remote Access Service (RRAS) is already installed, you receive an error 20101 in the System Log in Event Viewer.

This event will be logged every time RRAS starts yet does not prevent RRAS from starting properly, nor does it cause any loss of functionality within RRAS.

For each value of (x) in the key below, verify the value of 'Enabled' is equal to '1' or '0', the default is '1' Enabled.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Enabled | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Router\Interfaces\(x) |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Router\Interfaces\
(x)]
Name: Enabled
Type: REG_DWORD (DWORD Value)
Value: (0 = false, 1 = true)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 2, 1999


Avoid Accidental Registry Imports with Regedit (All Windows)

Avoid Accidental Registry Imports with Regedit (All Windows)
Category: Home > Windows > Accessories > Registry Editor

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

By default if you double-click on a file with a '.REG' extension the file will be imported into the system registry. You can change the default so it opens the file for editing instead.

You can change the default by either of the two methods below:

Through the Registry

  1. Open your registry and find the key below.
  2. Change the (Default) value to equal "edit".
  3. Exit your registry editor.
Using the GUI
From either Explorer or My Computer click on View -> Options, then the 'File Types' tab. Scroll down the list of registered file type until you find 'Registration Entries', highlight it and click 'Edit'. Listed in the 'Actions' box should be three actions: Edit, Merge and Print. Highlight 'Edit' and click 'Set Default', Edit should become Bold.

Next time you double-click on a .REG file, notepad should open instead. You can still import a file by simply right-click on it and select 'Merge'.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | "edit" | |
-
| HKEY_CLASSES_ROOT\regfile\shell |
-

Settings:
System Key: [HKEY_CLASSES_ROOT\regfile\shell]
Name: (Default)
Type: REG_SZ (String Value)
Value: edit

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 16, 2001


Change the Startup and Shutdown Screens (Windows 95/98/Me)

Change the Startup and Shutdown Screens (Windows 95/98/Me)
Category: Home > Windows > Startup and Shutdown

Microsoft has a knack for making the Windows startup and shutdown screens pretty boring. Luckily it's relatively easy to replace these images with pictures of your own.

There are three files which makeup the startup and shutdown screens, they are:

  • LOGO.SYS - The startup screen, usually located in your C:\ directory.
  • LOGOW.SYS - The 'Please wait...' screen, usually located in your c:\windows directory.
  • LOGOS.SYS - The 'It's now safe to turn off your computer.' screen, usually located in your c:\windows directory.

    • These files are standard 256 color Windows bitmap files with dimensions of 320(w) x 400(h). You can use basically any image editing program to change them (as long as it supports BMP files).

    Warning: Before getting started make sure to take a backup copy of all three files (LOGO.SYS may or may not already exist).

    1. Copy LOGOW.SYS and LOGOS.SYS to a temporary folder, and rename their extensions to .BMP

    2. Using your favorite graphics editor, open the files and modify them to your liking.

    3. Once your finished, save the files, change their extensions back to .SYS, and copy them back over the original files in the Windows directory (which you've already backed-up) and you're done.

    Alternatively you can create three new BMP files for each screen, just make sure that the proportions of 320(w) x 400(h) are maintained. The file once finished should be 129,078 bytes.

    Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

    Last Modified: February 2, 1999


Changing LAN Manager Authentication on Windows NT (Windows NT)

Changing LAN Manager Authentication on Windows NT (Windows NT)
Category: Home > Security > Network

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows NT supports two kinds of challenge/response authentication: LanManager (LM) and Windows NT (NTLM). LM authentication is not as strong as Windows NT authentication so some customers may want to disable its use, because an attacker sniffing the network traffic could possibly attack the weaker protocol.

The implementation of the NTLM Security Service Provider (SSP) in Server Pack 4 has been enhanced to allow clients to control which variants of NTLM are used, and to allow servers to control which variants they will accept.

To change the type of authentication to be used modify the key below with the following values:

Level 0 - Send LM response and NTLM response; never use NTLMv2 session security
Level 1 - Use NTLMv2 session security if negotiated
Level 2 - Send NTLM response only
Level 3 - Send NTLMv2 response only
Level 4 - DC refuses LM responses
Level 5 - DC refuses LM and NTLM responses (accepts only NTLMv2)

Note: Currently only Windows NT 4.0 (SP4 and greater) support NTLMv2.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | LMCompatibilityLevel | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa]
Name: LMCompatibilityLevel
Type: REG_DWORD (DWORD Value)
Value: 0 (default) to 5 as defined above

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 14, 2002


Add Command Prompt Option to Every Folder (All Windows)

Add Command Prompt Option to Every Folder (All Windows)
Category: Home > Windows > Accessories > Command Processor

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

If you still use the DOS prompt regularly then this setting creates a new right-click menu option to open a command prompt at the selected directory.

Open your registry and find the key below.

Create a new sub key called 'Command' under the main key (i.e. [HKEY_CLASSES_ROOT\Directory\shell\Command]). Change the value of '(Default)' within the key to equal the text you would like on the right-click menu, for example 'Command Prompt'.

Create another new sub-key under the key created above, named 'command' (i.e. [HKEY_CLASSES_ROOT\...\Command\command]). Change the value of '(Default)' within this key depending on your operating system to equal either:

Windows 95, 98 or Me
command.com /k cd "%1"

or

Windows NT, 2000 or XP
cmd.exe /k cd %1

Now right-click on a folder and the new option of 'Command Prompt' should be available.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | command.com /k cd "%1" | |
-
| HKEY_CLASSES_ROOT\Directory\shell |
-

Settings:
System Key: [HKEY_CLASSES_ROOT\Directory\shell]
Name: (Default)
Type: REG_SZ (String Value)

Related Tweaks

  • Add Explore From Here to Every Folder (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 29, 2002


Manage Partial Address Feature in Internet Explorer (All Windows)

Manage Partial Address Feature in Internet Explorer (All Windows)
Category: Home > Software > Internet Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

The Internet Explorer partial address feature, scans common domains for a match to a keyword entered in the Address bar. The feature is limited by default to searching only .COM, .NET, .ORG and .EDU domains. This tip allows you to add new domains and modify their priorities.

The values listed under the key below control which domains are auto searched for matches to the keyword entered in the Address bar.

To add a new domain simply create a new string value and name it a sequential number (e.g. '7'). Set the data of the new value to equal the domain you want to search, for example to also search .DE domains add a new value of 'www.%s.de' (%s represents the keyword).

To change their priorities, simply rename the values with sequential numbers where '1' is the site to be checked first.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | 1 | REG_SZ | "www.%s.de" | |
| |  | 2 | REG_SZ | "www.%s.com.au" | |
| |  | 3 | REG_SZ | "www.%s.com" | |
| |  | 4 | REG_SZ | "www.%s.net" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\UrlTemplate |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\UrlTemplate]
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 20, 2002


Change the Size of Desktop Icons (All Windows)

Change the Size of Desktop Icons (All Windows)
Category: Home > Windows > Appearance > Fonts and Icons

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Are your icons too small? Or too big? This setting will let you resize them to suit your desktop preference.

Open your registry and find the key below.

Create a new value named 'Shell Icon Size' and set the value, or modify the existing value, to equal the size of your icons in pixels. Smaller values = smaller icons!

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Shell Icon Size | REG_SZ | "16" | |
-
| HKEY_CURRENT_USER\Control Panel\Desktop\WindowMetrics |
-

Settings:
User Key: [HKEY_CURRENT_USER\Control Panel\Desktop\WindowMetrics]
Name: Shell Icon Size
Type: REG_SZ (String Value)
Value: Size in Pixels (Default = 32)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 8, 1999


Disable the Lock Workstation Button (Windows NT/2000/XP)

Disable the Lock Workstation Button (Windows NT/2000/XP)
Category: Home > Security > Login and Authentication

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Add this setting to the registry to stop unauthorized users from locking machines from the Windows Security dialog box.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'DisableLockWorkstation' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This functionality requires Windows NT Service Pack 4 or higher or Windows 2000.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DisableLockWorkstation | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
Name: DisableLockWorkstation
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 25, 2002


Disable the Change Password Button (Windows NT/2000)

Disable the Change Password Button (Windows NT/2000)
Category: Home > Security > Login and Authentication

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting disables the 'Change Password' button on the Windows Security dialog box. Enabling this setting stops casual users from being able to change the password.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'DisableChangePassword' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This functionality requires Windows NT Service Pack 4 or higher or Windows 2000.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DisableChangePassword | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
Name: DisableChangePassword
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 25, 2002


Optimize Windows TCP/IP Connection Retransmissions (Windows NT/2000/XP)

Optimize Windows TCP/IP Connection Retransmissions (Windows NT/2000/XP)
Category: Home > Network > Protocols > TCP-IP

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This parameter determines the number of times TCP will retransmit a connect request (SYN) before aborting the attempt. The retransmission timeout is doubled with each successive retransmission in a given connect attempt.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'TcpMaxConnectRetransmissions' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | TcpMaxConnectRetrans... | REG_DWORD | 0x00000003 (3) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]
Name: TcpMaxConnectRetransmissions
Type: REG_DWORD (DWORD Value)
Value: 0 - 0xFFFFFFFF (Default = 3)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 3, 2002


Optimize Windows TCP/IP Data Retransmissions (Windows NT/2000/XP)

Optimize Windows TCP/IP Data Retransmissions (Windows NT/2000/XP)
Category: Home > Network > Protocols > TCP-IP

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This parameter controls the number of times TCP will retransmit an individual data segment (not connection request segments) before aborting the connection.

The retransmission timeout is doubled with each successive retransmission on a connection. It is reset when responses resume. The base timeout value is dynamically determined by the measured round-trip time on the connection.

Note: The Windows NT/2000 TCP/IP implementation is largely self tuning. Adjusting registry parameters may adversely affect system performance.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | TcpMaxDataRetransmissions | REG_DWORD | 0x00000006 (6) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]
Name: TcpMaxDataRetransmissions
Type: REG_DWORD (DWORD Value)
Value: 0 - 0xFFFFFFFF (default = 5)

Related Tweaks

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 14, 2002


Optimize the Windows TCP/IP Window Size (Windows NT/2000)

Optimize the Windows TCP/IP Window Size (Windows NT/2000)
Category: Home > Network > Protocols > TCP-IP

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This parameter determines the maximum TCP receive window size offered by the system. The receive window specifies the number of bytes a sender may transmit without receiving an acknowledgment.

In general, larger receive windows will improve performance over high delay, high bandwidth networks. For greatest efficiency, the receive window should be an even multiple of the TCP Maximum Segment Size (MSS).

Reducing the TCP Window size effectively causes an acknowledgment to be sent to the sender for data received sooner. This will lower the possibility that the sender will time out while waiting for an acknowledgment. However it will also increase the amount of network traffic and cause slower throughput.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | TcpWindowSize | REG_DWORD | 0x00002238 (8760) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]
Name: TcpWindowSize
Type: REG_DWORD (DWORD Value)
Value: 0 - 0xFFFF (default = 8760 for Ethernet)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 22, 2002


Configure the TCP/IP Settings of a Network Adapter (Windows NT/2000/XP)

Configure the TCP/IP Settings of a Network Adapter (Windows NT/2000/XP)
Category: Home > Hardware > Network and Modems

These values control the TCP/IP parameters of the network interface cards. Configurable parameters include IP Address, Subnet Mask and Default Gateway.

Open your registry and find the key below, where {Adapter} equals the service name of the installed NIC. For example 3COM 905 NIC's service name is 'El90x'.

Modify the values names (listed below) in binary.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | DefaultGateway | REG_BINARY | 00 | |
| |  | IPAddress | REG_BINARY | 30 2e 30 2e 30 2e 30 00 00 | |
| |  | SubnetMask | REG_BINARY | 30 2e 30 2e 30 2e 30 00 00 | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\{Adapter}\Parameter... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\{Adapter}\
Parameters\Tcpip]
Name: IPAddress; SubnetMask; DefaultGateway
Type: REG_BINARY (Binary Value)

Related Tweaks

  • Configure the DHCP Settings of a Network Adapter (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 20, 2001


Configure the DHCP Settings of a Network Adapter (Windows NT/2000/XP)

Configure the DHCP Settings of a Network Adapter (Windows NT/2000/XP)
Category: Home > Network > Protocols > TCP-IP

This setting controls whether TCP/IP should use DHCP to automatically assign an IP address, or if it should use the statically defined address.

Open your registry and find the key below, where {Adapter} equals the service name of the installed network card.

Change the value of 'EnableDHCP' to equal either '0' for disabled, or '1' for enabled.

Note: If you change this setting to disabled, make sure you have IP addressing information defined.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | EnableDHCP | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\{Adapter}\Parameter... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\{Adapter}\
Parameters\Tcpip]
Name: EnableDHCP
Type: REG_DWORD (DWORD Value)
Value: (0 = DHCP Disabled, 1= DHCP Enabled)

Related Tweaks

  • Configure the TCP/IP Settings of a Network Adapter (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 9, 1999


Start Windows Without Prompting for a Password (Windows 95/98/Me)

Start Windows Without Prompting for a Password (Windows 95/98/Me)
Category: Home > Security > Login and Authentication

Does Windows prompt you for a password every time you boot up even though you're the only one using the PC? Follow these instructions to make Windows automatically start up without prompting you for a password.

Windows 9x passwords are recorded in a Password List file, these files are stored in the Windows directory and named according to your username, they can be recognized by their .PWL extension.

For example, if your username was 'John' then your password file would probably be 'c:\windows\john.pwl'

To remove the password prompt start by finding the PWL file relating to your username and rename it to *.old (e.g. c:\windows\john.old).

If your running a network, you then need to open 'Control Panel -> Network' and check that the 'Primary Network Logon' is set to 'Windows Logon'.

Now restart Windows and you'll be prompted for a password, leave the Password box empty then click OK, you should now not be prompted for a password again.

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 29, 2000


Repair the Taskbar (All Windows)

Repair the Taskbar (All Windows)
Category: Home > Windows > Troubleshooting > Repair

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

If your taskbar has disappeared from the desktop or becomes hidden when you move your cursor near, it may be due to a corrupt registry key.

Close any open desktop and taskbar applications, then open your registry and find the key below.

Delete the entire "StuckRects" key, or "StuckRects2" for Windows 2000/XP, and reboot.

When Windows restarts the taskbar should be set back to a default working state.

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
StuckRects]

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 7, 2002


Are You Missing Fonts from the Fonts Folder? (All Windows)

Are You Missing Fonts from the Fonts Folder? (All Windows)
Category: Home > Windows > Troubleshooting > Repair

A font may seem to be installed correctly but does not appear in the Fonts folder because the Fonts key in the registry is missing or damaged.

Move the contents of the Fonts folder to an empty folder. By opening the Fonts folder, select all the fonts, copy them, and paste them to a new folder.

Open your registry and find the key below appropriate to your operating system. Highlight the key and press DELETE. Once the key has been deleted create a new key to replace it, by selecting Edit -> New -> Key and name the new key [Fonts].

Restart the computer, then re-install the fonts by opening the Control Panel, double-click on 'Fonts'. And from the File menu select 'Install New Fonts...' adding the fonts that were previously copied to the temporary directory.

Windows 95
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Fonts]

Windows NT
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts]

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 23, 1999


Change a Users Default Printer (All Windows)

Change a Users Default Printer (All Windows)
Category: Home > Hardware > Printers and Plotters

This setting will allow you the change the default printer of a user by modifying the registry.

Open your registry and find the key appropriate for your operating system, as shown below.

Add or edit the value of 'Device', to equal the printer you want to become default for the current user.

Windows 95
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Windows]

Windows NT
[HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows]

Note: The device is the name used to represent the printer in the registry, the name can also be found in the [HKEY_CURRENT_USER\Printers\Settings] key.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Device | REG_SZ | "HP Laserjet,winspool,LPT1:" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Adv... |
-

Settings:
Name: Device
Type: REG_SZ (String Value)
Value:

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 23, 1999


Change the Maximum Transmission Unit (MTU) Size (Windows NT/2000/XP)

Change the Maximum Transmission Unit (MTU) Size (Windows NT/2000/XP)
Category: Home > Network > Protocols > TCP-IP

This parameter specifies the Maximum Transmission Unit (MTU) for a network interface. By optimizing the MTU setting you can gain substantial network performance increases, especially when using dial-up modem connections.

MTU stands for Maximum Transmission Unit and in basic terms, it defines the maximum size of a packet that can be transferred in one frame over a network.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, called "MTU" and set it to equal the required MTU size in decimal.

Recommended Values

  • 576 - Dial-up Connections
  • 1492 - PPPoE Broadband Connections
  • 1500 - Ethernet, DSL and Cable Broadband Connections

    Restart Windows for the change to take effect.

    Note: For Windows NT 4 the key is [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\ Tcpip\Parameters]

    Note: IP datagrams may span multiple packets. Values larger than the default for the underlying network will result in the transport using the network default MTU. Values smaller than 68 will result in the tranport using an MTU of 68.

    Registry Editor Example
    | Name Type Data |
    | (Default) REG_SZ (value not set) |
    | MTU REG_DWORD 0x000005dc (1500) |
    -
    | HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\ I... |
    -

    Settings:
    System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\
    Interfaces\[Adapter ID]]
    Name: MTU
    Type: REG_DWORD (DWORD Value)
    Value: Default = 0xffffffff

    Related Tweaks

    • Optimize Internet Connection Speed (Windows 95/98/Me)

    Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

    Last Modified: March 20, 2002

    • Return to Index Copyright © 1998-2003. All Rights Reserved. License


Restrict Access to Base System Objects (Windows NT/2000/XP)

Restrict Access to Base System Objects (Windows NT/2000/XP)
Category: Home > Security > System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

In Windows the core operating system libraries are kept in virtual memory and shared between the programs running on the system. This has exposed a vulnerability that could allow a user to gain administrative privileges on the computer the user is interactively logged onto.

To enable stronger protection on system base objects such as the KnownDLLs list, change the value of 'ProtectionMode' to equal '1' in the registry key below.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ProtectionMode | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager]
Name: ProtectionMode
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 3, 2002


Change System Environment Variables (Windows NT/2000/XP)

Change System Environment Variables (Windows NT/2000/XP)
Category: Home > Windows > System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This key contains the Windows system environment variables, the variables include Path, Temp, Windir and any other defined values.

Open your registry and find the key below.

Modify the value of any existing variables by double-clicking the value name. To create a new variable, select Edit -> New -> String Value.

You may be required to restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Path | REG_SZ | "c:\winnt; c:\winnt\system32" | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Envi... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\
Environment]
Type: REG_EXPAND_SZ (Expanded String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 30, 2003


MS-DOS Compatibility Mode Problems with PCI IDE Controllers (Windows 95/98/Me)

MS-DOS Compatibility Mode Problems with PCI IDE Controllers (Windows 95/98/Me)
Category: Home > Windows > Troubleshooting

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

If your computer contains a PCI IDE hard disk controller that employs serialization between the two IDE channels, this tip may help you resolve a MS-DOS compatibility mode problem in Device Manager.

To cause Windows to attempt to reinitialize the protected-mode IDE driver, remove the 'NoIDE' entry from the registry key below.

After you update the registry, restart Windows. Windows will then attempt to initialize the protected-mode driver for the controller.

Note: If no problems are encountered, the file system and virtual memory will operate in 32-bit mode, and Device Manager will not display an exclamation point in a yellow circle for the IDE channels.

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\IOS]
Name: NoIDE

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 30, 2002


Change the Internet Explorer Search Engine (All Windows)

Change the Internet Explorer Search Engine (All Windows)
Category: Home > Software > Internet Explorer > Search Features

Normally when you type 'go keyword' in the Internet Explorer address bar IE will search the web using a Microsoft selected search engine. By modifying this key you can select which search engine to use.

Open your registry and find the key below.

Modify the value of default to equal the URL for the search engine you want to use, substituting '%s' to represent the keywords.

For example, to use AltaVista the value would be:
http://www.altavista.com/cgi-bin/query?q=%s

And to use Yahoo! the value would be:
http://search.yahoo.com/bin/search?p=%s

Note: This tweak only works on Internet Explorer 4.0.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | "http://www.altavista.com/cgi-bin/query?q=%s" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\SearchUrl |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\SearchUrl]
Name: (Default)
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2002


Change the Position of the Desktop Wallpaper (All Windows)

Change the Position of the Desktop Wallpaper (All Windows)
Category: Home > Windows > Appearance

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Unfortunately Windows only gives you the limited options of center or tile for the placement of the desktop wallpaper. With this setting you can move the image anyway on your desktop.

Open your registry and find the key below.

Create two new string values of 'Wallpaperoriginx' and 'Wallpaperoriginy'. If the values already exist then you simply modify them.

Set the value of 'Wallpaperoriginx' to equal the horizontal offset, and set the value of 'Wallpaperoriginy' to equal the vertical offset. Then either restart Windows, or change your background image through the Control Panel.

Note: The image is offset from the center of your desktop, so you can use positive and negative values.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Wallpaperoriginx | REG_SZ | "100" | |
| |  | Wallpaperoriginy | REG_SZ | "300" | |
-
| HKEY_CURRENT_USER\Control Panel\Desktop |
-

Settings:
User Key: [HKEY_CURRENT_USER\Control Panel\Desktop]
Name: Wallpaperoriginx, Wallpaperoriginy
Type: REG_SZ (String Value)
Value: Distance in Pixels

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 30, 2003


Change the Recycle Bin Icons (All Windows)

Change the Recycle Bin Icons (All Windows)
Category: Home > Windows > Appearance > Fonts and Icons

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Would you like to make you Recycle Bin into something a bit more exciting? Maybe a glowing toxic waste bin? With this tweak you can change the icon to be whatever you like.

Open your registry and find the key below.

Within the key are three values: '(Default)', 'Empty' and 'Full'. Set the values to equal the icon you'd like to display for the various states of the Recycle Bin.

These changes should take effect immediately, you may need to refresh your desktop by clicking on a blank area and pressing F5.

Note: When you use icons not found in the shell32.dll library you may need to press F5 to refresh the desktop icons.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | "c:\icons\toxic.ico" | |
| |  | Empty | REG_SZ | "c:\icons\toxic.ico" | |
| |  | Full | REG_SZ | "c:\icons\toxic_full.ico" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\CLS... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\DefaultIcon]
System Key: [HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\
DefaultIcon]
Name: (Default), Empty, Full
Type: REG_SZ (String Value)
Value: Icon Filenames

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 12, 2003


Proxy Server Configuration (All Windows)

Proxy Server Configuration (All Windows)
Category: Home > Software > Internet Explorer > Network and Connections

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak allows you to configure the proxy server settings for all programs that use the standard Windows Internet API, including Internet Explorer.

Open your registry and find the key below.

The values that configure the Internet proxy setup are located in this key. To change which proxy server is used, modify the value of 'ProxyServer' to equal the server and port combination. For example if your proxy server was called \PROXY and it was running on port 80 then the setting would equal 'PROXY:80'.

You may also need to set the value of 'ProxyEnable' to equal '1' for proxy enabled or '0' for disabled. Setting the value of 'ProxyOverride' to equal '<local>' will stop internal addresses from going through the proxy.

Changes should take effect immediately.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ProxyEnable | REG_BINARY | 01 00 00 00 | |
| |  | ProxyOverride | REG_SZ | "" | |
| |  | ProxyServer | REG_SZ | "PROXY:80" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Set... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\
Internet Settings]
Name: ProxyServer, ProxyEnable, ProxyOverride
Type: REG_SZ (String Value)
Value: Server:Port

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 6, 2002


Show Computer Manufacturer and Support Information (All Windows)

Show Computer Manufacturer and Support Information (All Windows)
Category: Home > Tips and Tricks > Customization

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tip lets you include company and support information on the System Properties page in Control Panel. This is especially useful if you run a computer store and want your customers to be reminded where they bought their PC and where to get technical support.

To add the manufacturer and support information you need to create two new files in the Windows system directly, normally "C:\WINDOWS\SYSTEM" for Windows 95, 98 and Me and "C:\WINNT\SYSTEM32" for Windows NT and 2000.

The first file is a text file called "OEMINFO.INI". To create the file open notepad and copy the template below, make any changes and save the file in the System directory.

OEMINFO.INI Template

[General]
Manufacturer=Your Company, Inc.
Model=Your Computer Model
SupportURL=http://your.support.site/
LocalFile=c:\your\local\support\file.htm

[Support Information]
Line1=first line of support information
Line2=second line
Line3=third line
Line4=fourth line
...
LineN=nth line
; Create as many lines as you need by incrementing the Line number

The other file you need to create is a logo file. This is a standard Windows bitmap file (172 x 172 pixels), saved as "OEMLOGO.BMP" in the Windows System directory.

Once you have created both these files open System Properties from Control Panel and your company information and logo will be displayed. The details you entered in the [Support Information] section will show up when you click on the Support Information button.

Note: To display a logo you must create a 172x172 (pixel) bitmap image and save it as OEMLOGO.BMP in the Windows system directory.

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 19, 2002


Expand Special Folder on the Start Menu (All Windows)

Expand Special Folder on the Start Menu (All Windows)
Category: Home > Windows > Start Menu and Taskbar > Documents and Folders

Want easy access to the contents of a special folder? With this tip you can add an expanding special folders to the start menu for quick shortcuts to their contents.

The first step is find the system ID of the folder you want to add, these ID's can be found under the [HKEY_CLASSES_ROOT\CLSID] key. The Control Panel's key is called [HKEY_CLASSES_ROOT\CLSID\{21EC2020-3AEA-1069-A2DD-08002B30309D}] and the ID is the last set of number after CLSID, in this case '{21EC2020-3AEA-1069-A2DD-08002B30309D}'.

Once you've found the ID the hard work is done, now all you need to do is right-click on the Start button and chose open.

Now create a new folder with the name of the folder followed by a dot and the folder ID. For Control Panel create a new folder called 'Control Panel.{21EC2020-3AEA-1069-A2DD-08002B30309D}'. The new folder should now change into the Control Panel logo. Close the explorer window and click on the Start button, and there should now be a new expanding folder for the Control Panel.

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 28, 1999


Display Host in List (pcAnywhere) (All Windows)

Display Host in List (pcAnywhere) (All Windows)
Category: Home > Software > pcAnywhere

The registry entry allows the host to respond to remote requests for names. Thus, by disabling the registry item, you can hide the host from users scanning the network.

Use this setting so the host will not appear in a remote's list when the remote is scanning the network.

If the remote specifies the name of a host that has the DisplayHostInList option disabled, the host will appear in the remote's list, but the name displayed in the remote's list will not change from whatever the remote user entered.

Note: This item currently only refers to TCP/IP hosts.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System]
Name: DisplayHostInList
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Add an Additional Delay to Browse Packets (pcAnywhere) (All Windows)

Add an Additional Delay to Browse Packets (pcAnywhere) (All Windows)
Category: Home > Software > pcAnywhere

Use this setting when remotes display an incomplete list of TCP/IP hosts in the host list over a WAN or LAN connection.

The entry allows you to set the amount of delay used to create the remote's browse list. Technically, it adds 0.01 seconds between broadcast packets, and waits one additional second for the host's response for each unit of delay set.

For example, a setting of 2 means wait .02 additional seconds between each packet and an additional 2 seconds to receive the response from those broadcasts.

If you are having problems over a WAN connection, start with a setting of 1. If the setting does not work correctly, increase the number until the entire host list is displayed.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System]
Name: TCPIPBrowseDelay
Type: REG_DWORD (DWORD Value)
Value: Delay in Milliseconds

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Connect to TCP/IP Hosts With Unknown Status (pcAnywhere) (All Windows)

Connect to TCP/IP Hosts With Unknown Status (pcAnywhere) (All Windows)
Category: Home > Software > pcAnywhere

This registry entry allows a remote to try to connect to a host if the host's status is unknown. The usual reason for not knowing the host's status is that direct packets have been filtered by a firewall between the host and the remote.

An unfortunate side effect of enabling this key is that if the host's status is unknown to the remote, but the host is actually busy, the remote will receive a blank screen when it tries to connect. The remote can cancel from this screen and make another connection without difficulty. Sometimes, due to the length of time that the browse list updates take, updates will be turned off. By setting this item, you ensure that the list delays will not be turned off due to the length of time they take.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System]
Name: TCPIPConnectIfUnknown
Type: REG_DWORD (DWORD Value)
Value: (0 = Use UDP directed packets, 1 = Do not use UDP directed packets)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Configure the TCP/IP Data Port (pcAnywhere) (All Windows)

Configure the TCP/IP Data Port (pcAnywhere) (All Windows)
Category: Home > Software > pcAnywhere

Use this setting to select which TCP data port pcANYWHERE32 uses.

Open your registry and find the key below.

Create a new Binary value, or modify the existing value called 'TCPIPDataPort' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: Version 7.52's remote always uses the value in this registry entry. Version 8.0 remotes only use this entry if the TCPIPNetBroadcast entry equals 1.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System]
Name: TCPIPDataPort
Type: REG_BINARY (Binary Value)
Value: 15FF (HEX) = Registered Port (Default)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Configure the TCP/IP Status Port (pcAnywhere) (All Windows)

Configure the TCP/IP Status Port (pcAnywhere) (All Windows)
Category: Home > Software > pcAnywhere

Use this setting to select which TCP status port pcAnywhere uses.

Open your registry and find the key below.

Create a new Binary value, or modify the existing value called 'TCPIPStatusPort' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: The default is the port for pcAnywhere is 1600 (hex). For compatibility with previous versions, change the port number to 0016 (hex).

Note: Version 7.52's remote always uses the value in this registry entry. Version 8.0 remote only uses this entry if the TCPIPNetBroadcast entry equals 1.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System]
Name: TCPIPStatusPort
Type: REG_BINARY (Binary Value)
Value: 1600 (HEX) (Default)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Port Compatibility with Legacy Versions (pcAnywhere) (All Windows)

Port Compatibility with Legacy Versions (pcAnywhere) (All Windows)
Category: Home > Software > pcAnywhere

pcANYWHERE32 8.0 hosts and remotes can connect to earlier hosts and remotes without any registry changes. You may want to turn off compatibility to limit network traffic or allow third party applications that have registered the ports that earlier versions of pcANYWHERE32 7.x and pcAnywhere 2.0 were using.

If compatibility is set to OFF, then the pcANYWHERE32 8.0 host opens one TCP (TCPIPDataPort) and one UDP (TCPIPStatusPort) port. Remotes query and try to connect to one set of TCP and UDP ports.

If compatibility is set to ON, then the pcANYWHERE32 8.0 host opens the TCP port defined in TCPIPDataPort and port 65301, and the UDP port defined in TCPIPStatusPort and port 22. Remotes query and try to connect to the ports defined in the registry and ports 65301 and 22.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System]
Name: TCPIPPortCompatibility
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


TCP/IP Broadcast Mode (pcAnywhere) (All Windows)

TCP/IP Broadcast Mode (pcAnywhere) (All Windows)
Category: Home > Software > pcAnywhere

Use this setting to turn off or modify pcANYWHERE32's broadcast options to limit network traffic when the remote browses for a host.

If this is set to '0', only the hosts specified in Applications Options - TCP/IP host list will appear in a remote's TCP/IP browse list.

If this is set to '1' the default, pcANYWHERE32 sends 254 UDP packets per network. This setting is best when accessing pcAnywhere TCP/IP hosts through the Internet and on wide area networks. However, this option does send the most TCP/IP packets on the network.

If this is set to '2', pcANYWHERE32 sends one UDP broadcast packet per network. However, if the router filters broadcast packets, you will not see pcANYWHERE32 hosts across the router.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System]
Name: TCPIPNetBroadcast
Type: REG_DWORD (DWORD Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


TCP/IP Query Interval (pcAnywhere) (All Windows)

TCP/IP Query Interval (pcAnywhere) (All Windows)
Category: Home > Software > pcAnywhere

Use this setting to limit network traffic. Sometimes the additional network queries to refresh the browse list will interfere with getting status lights or making connections.

Set this registry item to a high value if you get a message that a known ready host is busy when you try to connect to the host, and direct packets are not filtered. It is especially important to increase this value if the TCPIPBrowseDelay value has been increased, because it is difficult to connect if the network query is going on at the same time.

The default is 50 seconds. The minimum setting is 30 seconds. A setting of zero turns off all list updates.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System]
Name: TCPIPQueryInterval
Type: REG_DWORD (DWORD Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Configure the Winsock Buffer Size (pcAnywhere) (All Windows)

Configure the Winsock Buffer Size (pcAnywhere) (All Windows)
Category: Home > Software > pcAnywhere

Use this registry item to set the size in bytes of TCP's Winsock buffer. Using a large value may increase the throughput of connections where the delay is large in relation to the bandwidth. This includes Internet, ISDN, RAS, dial-up networking, WAN and satellite connections.

For example, if the delay between two end points is 500 msec (.5 sec), the default throughput will be limited to 8K / .5 sec = 16K/sec. By increasing the value to its maximum setting, the theoretical throughput will be 65535 / .5 sec = 128K/sec.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System]
Name: TCPIPWSDataBuf
Type: REG_DWORD (DWORD Value)
Value: 1 - 65535 (Default = 8000)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Compatibility with the OnNet 2.1 TCP/IP Stack (pcAnywhere) (All Windows)

Compatibility with the OnNet 2.1 TCP/IP Stack (pcAnywhere) (All Windows)
Category: Home > Software > pcAnywhere

This registry item resolves an issue where pcAnywhere displayed the wrong host IP address when using FTP's OnNet 2.1 TCP/IP stack.

When this is set to 1, pcANYWHERE32 8.0 uses the default IP address as defined by the FTP software.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\Host]
Name: OnNet
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Prompt for TCP/IP Host (pcAnywhere) (All Windows)

Prompt for TCP/IP Host (pcAnywhere) (All Windows)
Category: Home > Software > pcAnywhere

This registry item allows a TCP/IP remote to specify an IP address or name when you leave the "Host To Connect To" field blank.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'PromptForTCPIPHost' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\
Remote Control]
Name: PromptForTCPIPHost
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Adapter Binding Mode (pcAnywhere) (All Windows)

Adapter Binding Mode (pcAnywhere) (All Windows)
Category: Home > Software > pcAnywhere

This registry item allows a waiting host to bind to a new adapter, such as a dial-up adapter, without reinitializing the host.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'TCPIPHostAdapterMode' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System]
Name: TCPIPHostAdapterMode
Type: REG_DWORD (DWORD Value)
Value: (0 = bind to the default network adapter, 1 = bind to all network adapters)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


TCP/IP Host Binding Mode (pcAnywhere) (All Windows)

TCP/IP Host Binding Mode (pcAnywhere) (All Windows)
Category: Home > Software > pcAnywhere

This registry item allows you to specify whether the host will wait on the first TCP/IP address given by the operating system, or whether it will wait on the TCP/IP index as indicated by TCPIPHostAddressIndex.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'TCPIPHostBindMode' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: Requires version 8.02 or higher.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System]
Name: TCPIPHostBindMode
Type: REG_DWORD (DWORD Value)
Value: (0 = Use first or default TCP/IP address, 2 = Use TCP/IP address index as indicated by TCPIPHostAddressIndex)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Specify Host Mode TCP/IP Address (pcAnywhere) (All Windows)

Specify Host Mode TCP/IP Address (pcAnywhere) (All Windows)
Category: Home > Software > pcAnywhere

This registry item allows you to specify which TCP/IP address index the host will wait on.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'TCPIPHostAddressIndex' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System]
Name: TCPIPHostAddressIndex
Type: REG_DWORD (DWORD Value)
Value: TCP/IP address index to wait on

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Multicast Packet Delay (pcAnywhere) (All Windows)

Multicast Packet Delay (pcAnywhere) (All Windows)
Category: Home > Software > pcAnywhere

This sets the delay in milliseconds between each send. This is useful if multicast error correction is disabled.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'TCPIPMcastDataDelay' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System]
Name: TCPIPMcastDataDelay
Type: REG_DWORD (DWORD Value)
Value: Delay in Milliseconds (0 = disabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Configure the Multicast Data Port (pcAnywhere) (All Windows)

Configure the Multicast Data Port (pcAnywhere) (All Windows)
Category: Home > Software > pcAnywhere

This setting selects the port that the multicast data is sent to.

Open your registry and find the key below.

Create a new Binary value, or modify the existing value called 'TCPIPMcastDataPort' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System]
Name: TCPIPMcastDataPort
Type: REG_BINARY (Binary Value)
Value: (0x15ff = Default)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Multicast Error Correction (pcAnywhere) (All Windows)

Multicast Error Correction (pcAnywhere) (All Windows)
Category: Home > Software > pcAnywhere

This sets the level of error correction used on the host. The host specifies which level of error correction the remotes will use.

If you set this to '0' (disabled), you should use TCPIPMcastDataDelay to slow the sends from the host to minimize the loss on slow remotes.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System]
Name: TCPIPMcastErrorCorrect
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 2 = Full error correction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Multicast Adapter Selection (pcAnywhere) (All Windows)

Multicast Adapter Selection (pcAnywhere) (All Windows)
Category: Home > Software > pcAnywhere

Use this registry item for a multihomed, multicast host that is not binding to the correct network card. This can be why none of the remotes receive the multicast packets.

To specify a particular network card, specify its number. For example, to force the multicast packet to be sent from the second network card, set this registry item to 2. Although the network card order is fairly stable, the order may change according to current DHCP and RAS status. To display the current network card order, run WINIPCFG.EXE for Windows 95, or IPCONFIG.EXE for Windows NT.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System]
Name: TCPIPMcastInterface
Type: REG_DWORD (DWORD Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Configure Multicast Send and Receive Buffers (pcAnywhere) (All Windows)

Configure Multicast Send and Receive Buffers (pcAnywhere) (All Windows)
Category: Home > Software > pcAnywhere

These registry items set the number of receive and send buffers when using an error correction multicast session. For slow remotes, a larger value may lead to less data loss.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'TCPIPMcastHostNumRecvBuf, TCPIPMcastHostNumSendBuf, TCPIPMcastRemNumRecvBuf, TCPIPMcastRemNumSendBuf' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System]
Name: TCPIPMcastHostNumRecvBuf, TCPIPMcastHostNumSendBuf, TCPIPMcastRemNumRecvBuf, TCPIPMcastRemNumSendBuf
Type: REG_DWORD (DWORD Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Multicast Maximum Transmission Unit (pcAnywhere) (All Windows)

Multicast Maximum Transmission Unit (pcAnywhere) (All Windows)
Category: Home > Software > pcAnywhere

This registry item sets the Maximum Transmission Unit (MTU) in bytes. The MTU is the maximum bytes that may be sent as one IP multicast packet.

The largest supported value is 10,239. Do not set this value below its default of 1400 bytes.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System]
Name: TCPIPMcastMTU
Type: REG_DWORD (DWORD Value)
Value: 1400 - 10,239 bytes

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Multicast Winsock Receive Buffer (pcAnywhere) (All Windows)

Multicast Winsock Receive Buffer (pcAnywhere) (All Windows)
Category: Home > Software > pcAnywhere

This registry item sets the size in bytes of the Winsock receive buffer.

If error correction is off, set this value to 16384 bytes to minimize loss of data on the view-only remotes.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System]
Name: TCPIPMcastWSRecvBuf
Type: REG_DWORD (DWORD Value)
Value: Size in Bytes (Default = 8000)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Ignore DSR on Serial Devices (pcAnywhere) (All Windows)

Ignore DSR on Serial Devices (pcAnywhere) (All Windows)
Category: Home > Software > pcAnywhere

Use this item for modems or other serial devices that do not initialize correctly because their DSR is not initially set. It is also useful if the modem connection does not have a DSR line.

This registry item forces the computer to ignore the DSR setting of the attached modem or serial device. Thus, you can get around the requirement of setting a modem's DSR high.

The default is to ignore the DSR. To respect the DSR, add the registry item as a DWORD and set it to a value of zero.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System]
Name: SerialIgnoreDSR
Type: REG_DWORD (DWORD Value)
Value: (0 = Respect DSR, 1= Ignore DSR)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Change Serial 56K Connection Speed (pcAnywhere) (All Windows)

Change Serial 56K Connection Speed (pcAnywhere) (All Windows)
Category: Home > Software > pcAnywhere

Use this item when a serial connection can be made at 38,400 bps and 115,000 bps, but not at 57,600 bps.

This setting changes the default serial speed from 57,600 bps to 56,000 bps when you select 57,600 bps. It does not affect TAPI serial speeds.

The default is not to change the serial speed. To use 56,000 bps instead of 57,600 bps, add the registry item as a DWORD and set it to a value other than zero.

Note: Use only for Digiboards under Windows NT.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System]
Name: SerialUse56000
Type: REG_DWORD (DWORD Value)
Value: (0 = Do not change, 1 = Change)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


TAPI Modem Errors (pcAnywhere) (All Windows)

TAPI Modem Errors (pcAnywhere) (All Windows)
Category: Home > Software > pcAnywhere

Each time you add a TAPI modem, it generates a unique TAPI Permanent Line ID which is stored in pcANYWHERE32's connection items. If you no longer have a modem with this unique ID, pcANYWHERE32 displays an error message. This registry key tells pcANYWHERE32 how to handle this situation.

The options are:

  • 0 = Always error if TAPI ID does not match.
  • 1 = Error if TAPI ID does not match and more than one TAPI modem is present. If only one TAPI modem is installed, then use it if the TAPI IDs do not match.
  • 2 = Always use the first TAPI modem if the TAPI ID does not match
    •

    Settings:
    System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System]
    Name: UseFirstTapiModem
    Type: REG_DWORD (DWORD Value)

    Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

    Last Modified: March 1, 1999


Configure IPX Search Mode (pcAnywhere) (All Windows)

Configure IPX Search Mode (pcAnywhere) (All Windows)
Category: Home > Software > pcAnywhere

This registry item enables the SAP method of network search instead of using the bindery when making IPX connections.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'IPXUseNBSapMethod' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System]
Name: IPXUseNBSapMethod
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Hide the Record Session Button (pcAnywhere) (All Windows)

Hide the Record Session Button (pcAnywhere) (All Windows)
Category: Home > Software > pcAnywhere

Use this registry key to hide the Record Session icon from the remote session toolbar.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'HideRecordingButton' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\
Remote Control]
Name: HideRecordingButton
Type: REG_DWORD (DWORD Value)
Value: (0 = Visible, 1 = Hidden)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Remote Printer Inactivity Time-out (pcAnywhere) (All Windows)

Remote Printer Inactivity Time-out (pcAnywhere) (All Windows)
Category: Home > Software > pcAnywhere

Use this setting if a print job is being separated into multiple jobs during remote printing. This item sets the inactivity time-out for the remote printing facility.

If there is no activity on the port being captured for remote printing, pcANYWHERE32 assumes the printing job is done and stop spooling. This may cause a print job to be separated into multiple jobs if there is a long delay during the printing. This DWORD registry item allows you to adjust the length in seconds of the inactivity on the captured port before pcAnywhere assumes a print job has stopped spooling.

The default is 30 seconds. To adjust the inactivity time-out, add the registry item as a DWORD set to the number of seconds you want.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\
Remote Control]
Name: PrinterFlushTimeout
Type: REG_DWORD (DWORD Value)
Value: Seconds before assuming print job has completed

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Configure Legacy Remote Print Mode (pcAnywhere) (All Windows)

Configure Legacy Remote Print Mode (pcAnywhere) (All Windows)
Category: Home > Software > pcAnywhere

This setting specifies the default print destination when connecting to a pcAnywhere 2.0 or 5.0 host.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\
Remote Control]
Name: Print
Value: (0 = Discard, 1 = Host, 2 = Remote, 3 = Host and Remote)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Show Full Screen Reminder Message (pcAnywhere) (All Windows)

Show Full Screen Reminder Message (pcAnywhere) (All Windows)
Category: Home > Software > pcAnywhere

This setting turns the Full Screen Reminder Message on or off.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'ShowAltEnterMsg' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\
Remote Control]
Name: ShowAltEnterMsg
Type: REG_DWORD (DWORD Value)
Value: (0 =disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Host Connection Time-Out (pcAnywhere) (All Windows)

Host Connection Time-Out (pcAnywhere) (All Windows)
Category: Home > Software > pcAnywhere

If pcAnywhere host does not respond, hang up. This is useful for scripts that call systems where a modem will answer, but the pcAnywhere host may not be running.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NonPCAHostTimeout' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\
Remote Control]
Name: NonPCAHostTimeout
Type: REG_DWORD (DWORD Value)
Value: Time in Seconds (0 = Forever)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Run Smart Setup (pcAnywhere) (All Windows)

Run Smart Setup (pcAnywhere) (All Windows)
Category: Home > Software > pcAnywhere

This setting controls whether SmartSetup is run when pcAnywhere is loaded for the first time.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'SmartSetup' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\System]
Name: SmartSetup
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Run the pcAnywhere Service in Stealth Mode (pcAnywhere) (All Windows)

Run the pcAnywhere Service in Stealth Mode (pcAnywhere) (All Windows)
Category: Home > Software > pcAnywhere

Use this setting to hide the Host Waiting icon and Waiting dialog.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'ServiceStealthMode' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\Host]
Name: ServiceStealthMode
Type: REG_DWORD (DWORD Value)
Value: (0 = Show Icon, 1 = Hide Icon)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Use Computer Name Instead of Caller Name (pcAnywhere) (All Windows)

Use Computer Name Instead of Caller Name (pcAnywhere) (All Windows)
Category: Home > Software > pcAnywhere

When this key is set, if a host has the "Prompt to confirm connection" option checked, the host computer's prompt dialog will display the remote's computer name instead of the caller's name when a connection is made.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'ConfirmComputerName' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\Host]
Name: ConfirmComputerName
Type: REG_DWORD (DWORD Value)
Value: (0 = Use Caller name, 1 = Use remote's Computer name)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Wait for Call After Disconnect (pcAnywhere) (All Windows)

Wait for Call After Disconnect (pcAnywhere) (All Windows)
Category: Home > Software > pcAnywhere

If enabled, the host will not wait for a call when the remote disconnects.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'OnlyOneGoodConnection' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\Host]
Name: OnlyOneGoodConnection
Type: REG_DWORD (DWORD Value)
Value: (0 = Host waits for a call after each connection, 1 = Do not wait for a call)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Configure Persistent Cache (pcAnywhere) (All Windows)

Configure Persistent Cache (pcAnywhere) (All Windows)
Category: Home > Software > pcAnywhere

This setting turns pcAnywhere's persistent cache feature on or off.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'PersistentCache' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\Host]
Name: PersistentCache
Type: REG_DWORD (DWORD Value)
Value: (0 = Off, 1 = On)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Multi-Processor Options (pcAnywhere) (All Windows)

Multi-Processor Options (pcAnywhere) (All Windows)
Category: Home > Software > pcAnywhere

This registry item specifies which processors pcANYWHERE32 8.0 will run on.

To have pcANYWHERE32 8.0 run on a specific processor, set this value according to the table below. If you want pcANYWHERE32 8.0 to run on several specific processors, then set this value to the sum of the values below.

   Value     Processor
   -----     ---------
   0         All
   1         1
   2         2
   4         3
   8         4
   16        5
   32        6
   64        7
   128       8

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\Host]
Name: ProcessorMask
Type: REG_DWORD (DWORD Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Prompt If Logged Out (pcAnywhere) (All Windows)

Prompt If Logged Out (pcAnywhere) (All Windows)
Category: Home > Software > pcAnywhere

This registry key allows you to specify how pcANYWHERE32 will handle a remote connection when the pcANYWHERE32 host is waiting at the Windows NT login screen and the "Prompt On Connection" and "Disconnect On Timeout" options have been checked.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'PromptIfLoggedOut' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\Host]
Name: PromptIfLoggedOut
Type: REG_DWORD (DWORD Value)
Value: (0 = User Will Connect, 1 = User Won't Connect)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Speed Send File Size Limits (pcAnywhere) (All Windows)

Speed Send File Size Limits (pcAnywhere) (All Windows)
Category: Home > Software > pcAnywhere

The minimum size a file must be for SpeedSend to work is 10K. You can change this value.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'SpeedSend Minimum Size' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\
File Transfer]
Name: SpeedSend Minimum Size
Type: REG_DWORD (DWORD Value)
Value: Size in KB (Default = 10)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Confirm File Send (pcAnywhere) (All Windows)

Confirm File Send (pcAnywhere) (All Windows)
Category: Home > Software > pcAnywhere

When this setting is disabled, the remote does not display the confirm prompt when sending a file.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'ConfirmSend' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\
File Transfer]
Name: ConfirmSend
Type: REG_DWORD (DWORD Value)
Value: (0 = Disabled, 1 = Enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Confirm File Delete (pcAnywhere) (All Windows)

Confirm File Delete (pcAnywhere) (All Windows)
Category: Home > Software > pcAnywhere

When this setting is disabled, the remote does not display the confirm prompt when deleting a file.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'ConfirmDelete' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\pcANYWHERE\CurrentVersion\
File Transfer]
Name: ConfirmDelete
Type: REG_DWORD (DWORD Value)
Value: (0 = Disabled, 1 = Enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 1, 1999


Use Windows Update Without Registration (Windows 98/Me/2000/XP)

Use Windows Update Without Registration (Windows 98/Me/2000/XP)
Category: Home > Windows

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows Update is a useful feature but to ensure your privacy you may not want to register your personal details before being able to use it. With this tip you can bypass the registration process.

Open your registry and find the key below for your Windows version.

Windows 2000 and XP
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion]

Windows 98 and Me
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion]

Create a new string value called 'RegDone', or modify the existing value, to equal '1'.

Check that the key [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Welcome\RegWiz] exists, if it doesn't then create a new key.

Next time you run Windows Update it should not ask you to complete the registration process.

Note: This will not bypass Windows XP product activation which is compulsory on all consumer versions of Windows XP Home and Professional.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | RegDone | REG_SZ | "1" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion]
Name: RegDone
Type: REG_SZ (String Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 11, 2002


Remove the 'Shortcut to...' Prefix on Shortcuts (All Windows)

Remove the 'Shortcut to...' Prefix on Shortcuts (All Windows)
Category: Home > Windows > File System > Files and Shortcuts

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Don't like having 'Shortcut to...' appended to every Shortcut? You're not alone. With this tip you can stop Windows for adding this text when creating links.

Open your registry and find the key below.

Create a new BINARY value name 'link', of modify the existing value, to equal '00 00 00 00' to have the Shortcut text disabled.

Restart Windows before creating any new shortcuts.

Note: This restriction can be used either on a user by user basis by adding it to HKEY_CURRENT_USER or on a computer wide basis by adding it to HKEY_LOCAL_MACHINE.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | link | REG_BINARY | 00 00 00 00 | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer]
Name: link
Type: REG_BINARY (Binary Value)
Value: (00 00 00 00 = No Shortcut Text)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 13, 2002


Change the Alignment of Drop-Down Menus (All Windows)

Change the Alignment of Drop-Down Menus (All Windows)
Category: Home > Windows > Appearance > Effects and Menus

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

By default, Windows drop-down menus are aligned to the left, with this tweak you can change the default behavior to align the menus to the right instead.

Open your registry and find the key below.

Create a new string value, or modify the existing value, named 'MenuDropAlignment' and set it to equal '1' for right alignment or '0' for left alignment.

Restart or logoff Windows for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | MenuDropAlignment | REG_SZ | "1" | |
-
| HKEY_CURRENT_USER\Control Panel\Desktop |
-

Settings:
User Key: [HKEY_CURRENT_USER\Control Panel\Desktop]
Name: MenuDropAlignment
Type: REG_SZ (String Value)
Value: (0 = left, 1 = right)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 29, 2002


Change Mouse Double-Click Sensitivity (All Windows)

Change Mouse Double-Click Sensitivity (All Windows)
Category: Home > Hardware > Mice and Keyboards

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls the amount of mouse movement allowed between clicks, for two consecutive clicks to be registered as a double-click.

Open your registry and find the key below.

Create two new string values named 'DoubleClickHeight' and 'DoubleClickWidth'. Set the these values to equal the size in pixels of the double-click area.

Logoff, or restart Windows for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DoubleClickHeight | REG_SZ | "30" | |
| |  | DoubleClickWidth | REG_SZ | "30" | |
-
| HKEY_CURRENT_USER\Control Panel\Mouse |
-

Settings:
User Key: [HKEY_CURRENT_USER\Control Panel\Mouse]
Name: DoubleClickHeight, DoubleClickWidth
Type: REG_SZ (String Value)
Value: Size in Pixels

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 12, 2002


Change the Outlook Express Window Title (All Windows)

Change the Outlook Express Window Title (All Windows)
Category: Home > Software > Outlook Express

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allows you to customize Outlook Express by using your own window title. For example you could rename Outlook Express to 'My Mail Reader' or anything else you like!

Open your registry and find the key below.

Create a new string value, or modify the existing value, to equal the title you would like.

For Outlook Express 5.0 and 6.0 the location of the key has changed to: [HKEY_CURRENT_USER\Identities\{** Identity ID **}\Software\Microsoft\Outlook Express\5.0]

Note: Delete the value of 'WindowTitle' to change the title back to the default.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | WindowTitle | REG_SZ | "My Mail Reader" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Outlook Express |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Outlook Express]
Name: WindowTitle
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 11, 2000


Colorful Message Backgrounds in Outlook Express (All Windows)

Colorful Message Backgrounds in Outlook Express (All Windows)
Category: Home > Software > Outlook Express

When enabled this setting allows the use of colorful message backgrounds in Outlook Express 4.0 or below.

Open your registry and find the key below.

Change the value of 'ColorCycle' to equal '1' for enabled.

Close the registry and open Outlook Express. Open a new message and hold down CTRL + SHIFT, then press the 'Z' key to cycle through the colored backgrounds.

Note: This setting only works with Outlook Express version 4.0 and below.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ColorCycle | REG_SZ | 1 | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Internet Mail and News |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Internet Mail and News]
Name: ColorCycle
Type: REG_SZ (String Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 7, 1999


Optimize the Contiguous File Allocation Size (Windows 95/98/Me)

Optimize the Contiguous File Allocation Size (Windows 95/98/Me)
Category: Home > Windows > File System > Maintenance

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting optimizes the file system by specifying the minimum amount of free contiguous space needed before writing a file. Larger values are especially useful for disk intensive applications to reduce fragmentation.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'ContigFileAllocSize' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ContigFileAllocSize | REG_DWORD | 0x00000200 (512) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem]
Name: ContigFileAllocSize
Type: REG_DWORD (DWORD Value)
Value: Size in KB (default = 512 decimal)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 5, 2002


Disable the Outlook Express Splash Screen (All Windows)

Disable the Outlook Express Splash Screen (All Windows)
Category: Home > Software > Outlook Express

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Sick of seeing the Outlook Express splash screen every time you open the program? This settings will allow you to remove it.

Open your registry and create a new value called 'NoSplash' in the key below.

Change the value to equal '1' to disable the splash screen.

Exit the registry and restart Outlook Express.

Note: For Outlook 4.0 and below the key is [HKEY_CURRENT_USER\Software\Microsoft\Outlook Express]

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoSplash | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Identities\{Unique Identity}\Software\Microsoft\Outloo... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Identities\{Unique Identity}\Software\Microsoft\
Outlook Express\5.0]
Name: NoSplash
Type: REG_DWORD (DWORD Value)
Value: 1 = no splash screen, 0 = splash screen

Related Tweaks

  • Disable the Internet Explorer Splash Screen (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 23, 2002


Disable the Office Assistants (All Windows)

Disable the Office Assistants (All Windows)
Category: Home > Software > Microsoft Office

Are you annoyed by those office assistants always popping-up when you least expect it? This tweak will let you remove them for good!

Open your registry and find the key below where [ver] is the Office version number ("8.0" = Office 97, "9.0" = Office 2000 and "10.0" = Office XP). Then delete all the values under the key.

Settings:
System Key: [HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\[ver]\Common\Assistant]

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 14, 2002


Restrict Access to the Event Logs (Windows NT/2000/XP)

Restrict Access to the Event Logs (Windows NT/2000/XP)
Category: Home > Security > System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

The Windows event log contains records documenting application, security and system events taking place on the machine. As these logs can contain sensitive data this tweak allows you to restrict access to administrators and system accounts only.

Open your registry and find the key below.

Under this key are three sub-keys: Application, Security and System. These subkeys represent each section of the event log. To restrict access to each section create a new DWORD value of 'RestrictGuestAccess' under each sub-key and set it to equal '1'. To restrict access to only certain sections, then only add the value to that specific key.

Restart Windows for change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | RestrictGuestAccess | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\EventLog |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\EventLog]
Name: RestrictGuestAccess
Type: REG_DWORD (DWORD Value)
Value: (0 = guest access, 1 = restricted access)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 30, 2002


Change the ICQ Email Tagline (All Windows)

Change the ICQ Email Tagline (All Windows)
Category: Home > Software

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Newer versions of ICQ come with a handy email client. Unfortunately they add "Download ICQ at ..." to the end of every outgoing message. You can remove or change this in the registry to whatever you like.

Open your registry and find the key below.

Change the value of the setting name to whatever you like. You may also want to hold on to the "double bars" as they represent carriage returns.

Settings:
User Key: [HKEY_CURRENT_USER\Software\Mirabilis\ICQ\DefaultPrefs]
Name: Email Message
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: July 4, 2003


Disable TCP/IP Source Routing (Windows NT 4.0)

Disable TCP/IP Source Routing (Windows NT 4.0)
Category: Home > Security > Network

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Normally, on a computer running Windows NT 4.0, you cannot disable the source routing feature for the TCP/IP protocol. By using this tweak it is possible to disable it.

Open your registry and find the key below.

Create a new DWORD value named 'DisableIPSourceRouting' and set the value to either '1' to disable source routing, or '0' to enable source routing.

Restart Windows for the change to take effect.

Note: You must have Windows NT Service Pack 5 or greater installed for this setting to work.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DisableIPSourceRouting | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]
Name: DisableIPSourceRouting
Type: REG_DWORD (DWORD Value)
Value: '0' or '1'

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 14, 2002


Show User and Computer Name on Desktop (Windows NT/2000/XP)

Show User and Computer Name on Desktop (Windows NT/2000/XP)
Category: Home > Windows > Desktop

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak will rename "My Computer" to "Username on Computername" making it simple to determine which computer you are logged on to and which username you are logged on as.

Using REGEDT32.EXE (this is necessary for REG_EXPAND_SZ) open your registry and find the key in the settings section below. Then continue following the steps for your Windows version.

For Windows NT
Delete the existing value called "No Name" and add a new REG_EXPAND_SZ value with an empty value name and set the value to "%USERNAME% on %COMPUTERNAME%".

For Windows 2000
Rename the value named "LocalizedString" to "LocalizedString.old". Create a new REG_EXPAND_SZ value named "LocalizedString", and copy the contents of the original value to the new value except change the words "My Computer" to equal "%USERNAME% on %COMPUTERNAME%". For example, the new "LocalizedString" value may equal "@C:\WINNT\system32\shell32.dll,-9216@1033,%USERNAME% on %COMPUTERNAME%".

For Windows XP or Internet Explorer 6.0+
Rename the value named "LocalizedString" to "LocalizedString.old". Create a new REG_EXPAND_SZ value named "LocalizedString", and set the value to "%USERNAME% on %COMPUTERNAME%".

Exit the registry editor, click on your desktop and press F5 (for refresh). The "My Computer" icon should now be rename to "Username on Computername".

Note: Users of Internet Explorer 6.0 or greater should use the method for Windows XP.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | LocalizedString | REG_EXPAND_SZ | %USERNAME% on %COMPUTERNAME% | |
-
| HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D} |
-

Settings:
System Key: [HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}]
Type: REG_EXPAND_SZ (Expanded String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: July 24, 2002


Improve Core System Performance (Windows NT/2000/XP)

Improve Core System Performance (Windows NT/2000/XP)
Category: Home > Hardware > Processor and Motherboard

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

On systems with large amount of RAM this tweak can be enabled to force the core Windows system to be kept in memory and not paged to disk.

Open your registry and find the value in the key below.

Change the value to '1' enable the tweak and stop the core process from being paged, or set it to '0' for the default.

Restart Windows for the change to take effect.

Note: This tweak may effect some software that relies directly on the Windows swap file such as Adobe Photoshop.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DisablePagingExecutive | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memo... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\
Memory Management]
Name: DisablePagingExecutive
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = disable system paging)

Related Tweaks

  • Optimize the System Cache Size (Windows NT/2000/XP)
  • Manage File System Caching Memory (Windows NT/2000)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 18, 2001


Remove Suspend from the Start Menu (Windows 95/98/Me)

Remove Suspend from the Start Menu (Windows 95/98/Me)
Category: Home > Windows > Start Menu and Taskbar

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

If the Suspend option doesn't work as it should, or you simply want to remove the option from the Start Menu, then use this tweak.

Open your registry and find the key and value below.

Change the value of 'APMMenuSuspend' to equal '00', restart the machine and the suspend option should have disappeared.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | APMMenuSuspend | REG_BINARY | 00 | |
-
| HKEY_LOCAL_MACHINE\Enum\Root\*PNP0C05\0000 |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\Enum\Root\*PNP0C05\0000]
Name: APMMenuSuspend
Type: REG_BINARY (Binary Value)
Value: (00 = not visible, 01 = visible)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 18, 2002


Restrict Access to the Windows Update Feature (All Windows)

Restrict Access to the Windows Update Feature (All Windows)
Category: Home > Security

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

The Windows Update feature allows users to easily update Windows components and software over the Internet. These settings allow can be used to grant or restrict access to this function.

Open your registry and find the keys below.

Create a new DWORD (or Binary for Windows 98) value named "NoWindowsUpdate" and set the new value to equal "1".

This restriction may also be enforced by using the "DisableWindowsUpdateAccess" DWORD value in the [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\WindowsUpdate] key.

Refresh your desktop, or restart your Windows session for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoWindowsUpdate | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoWindowsUpdate
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = disabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 20, 2002


Internet Explorer Restrictions (All Windows)

Internet Explorer Restrictions (All Windows)
Category: Home > Software > Internet Explorer > Security

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

These settings and restrictions allow you to selectively control a range of features available in Microsoft Internet Explorer 5 and 6.

Open your registry and find or create the key below.

Create a new DWORD value based on the options below, and set the new value to "1" to enable the restriction or "0" to disable the restriction.

  • AlwaysPromptWhenDownload - Always prompt user when downloading files.
  • NoBrowserBars - Disable changes to browsers bars.
  • NoBrowserClose - Disable the option of closing Internet Explorer.
  • NoBrowserContextMenu - Disable right-click context menu.
  • NoBrowserOptions - Disable the Tools > Internet Options menu.
  • NoBrowserSaveAs - Disable the ability to Save As.
  • NoFavorites - Disable the Favorites.
  • NoFileNew - Disable the File > New command.
  • NoFileOpen - Disable the File > Open command.
  • NoFindFiles - Disable the Find Files command.
  • NoNavButtons - Disables the Forward and Back navigation buttons
  • NoOpeninNewWnd - Disable Open in New Window option.
  • NoPrinting - Remove Print and Print Preview from the File menu.
  • NoSelectDownloadDir - Disable the option of selecting a download directory.
  • NoTheaterMode - Disable the Full Screen view option.
  • NoViewSource - Disable the ability to view the page source HTML.
  • RestGoMenu - Remove Mail and News menu item.

Restart Internet Explorer for the restrictions to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AlwaysPromptWhenDownload | REG_DWORD | 0x00000001 (1) | |
| |  | NoBrowserBars | REG_DWORD | 0x00000001 (1) | |
| |  | NoBrowserClose | REG_DWORD | 0x00000001 (1) | |
| |  | NoBrowserContextMenu | REG_DWORD | 0x00000001 (1) | |
| |  | NoBrowserOptions | REG_DWORD | 0x00000001 (1) | |
| |  | NoBrowserSaveAs | REG_DWORD | 0x00000001 (1) | |
| |  | NoFavorites | REG_DWORD | 0x00000001 (1) | |
| |  | NoFileNew | REG_DWORD | 0x00000001 (1) | |
| |  | NoFileOpen | REG_DWORD | 0x00000001 (1) | |
| |  | NoFindFiles | REG_DWORD | 0x00000001 (1) | |
| |  | NoNavButtons | REG_DWORD | 0x00000001 (1) | |
| |  | NoOpeninNewWnd | REG_DWORD | 0x00000001 (1) | |
| |  | NoPrinting | REG_DWORD | 0x00000001 (1) | |
| |  | NoSelectDownloadDir | REG_DWORD | 0x00000001 (1) | |
| |  | NoTheaterMode | REG_DWORD | 0x00000001 (1) | |
| |  | NoViewSource | REG_DWORD | 0x00000001 (1) | |
| |  | RestGoMenu | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Restrict... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\
Restrictions]
System Key: [HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Internet Explorer\
Restrictions]
Type: REG_DWORD (DWORD Value)
Value: (0 = disable restriction, 1 = enable restriction)

Related Tweaks

  • Internet Explorer Toolbar Restrictions (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: November 9, 2002


Active Desktop Restrictions (All Windows)

Active Desktop Restrictions (All Windows)
Category: Home > Security > Active Desktop

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Features of the Windows Active Desktop can be selectively controlled by modifying options in the Windows registry. Following the instructions in this tweak.

Open your registry and find the key below.

Create a new DWORD value based on the options below, and set the new value to equal "1" to enable the restriction or "0" to disable the restriction.

  • NoChangingWallpaper - Disable the ability to change wallpapers.
  • NoComponents - Disable components.
  • NoAddingComponents - Disable the ability to add components.
  • NoDeletingComponents - Disable the ability to delete components.
  • NoEditingComponents - Disable the ability to edit components.
  • NoCloseDragDropBands
  • NoMovingBands - retrict adjustments to desktop toolbars
  • NoHTMLWallPaper - only allow bitmaps (BMP) as wallpaper

These restrictions can be used either on a user by user basis by adding it to HKEY_CURRENT_USER or on a computer wide basis by adding it to HKEY_LOCAL_MACHINE.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoChangingWallpaper | REG_DWORD | 0x00000001 (1) | |
| |  | NoComponents | REG_DWORD | 0x00000001 (1) | |
| |  | NoAddingComponents | REG_DWORD | 0x00000001 (1) | |
| |  | NoDeletingComponents | REG_DWORD | 0x00000001 (1) | |
| |  | NoEditingComponents | REG_DWORD | 0x00000001 (1) | |
| |  | NoCloseDragDropBands | REG_DWORD | 0x00000001 (1) | |
| |  | NoMovingBands | REG_DWORD | 0x00000001 (1) | |
| |  | NoHTMLWallPaper | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Act... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
ActiveDesktop]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
ActiveDesktop]
Type: REG_DWORD (DWORD Value)
Value: (0 = disable restriction, 1 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 18, 2002


Remove Active Desktop Options from the Settings Menu (All Windows)

Remove Active Desktop Options from the Settings Menu (All Windows)
Category: Home > Security > Active Desktop

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

The tweak will remove the Active Desktop options from Settings on the Start Menu.

Open your registry and find the key below.

Create a new DWORD value named "NoSetActiveDesktop", and set the new value to equal "1" to enable the restriction or "0" to disable the restriction.

This restriction can be used either on a user by user basis by adding it to HKEY_CURRENT_USER or on a computer wide basis by adding it to HKEY_LOCAL_MACHINE.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoSetActiveDesktop | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoSetActiveDesktop
Type: REG_DWORD (DWORD Value)
Value: (0 = disable restriction, 1 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 25, 2002


Disable Drag-and-Drop on the Start Menu (Windows 98/Me/2000/XP)

Disable Drag-and-Drop on the Start Menu (Windows 98/Me/2000/XP)
Category: Home > Security > Start Menu and Taskbar

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction prevents users from modifying the Start menu by dragging and dropping items.

Open your registry and find the key below.

Create a new DWORD value named "NoChangeStartMenu", and set the new value to equal "1" to enable the restriction or "0" to disable the restriction.

This restriction can be used either on a user by user basis by adding it to HKEY_CURRENT_USER or on a computer wide basis by adding it to HKEY_LOCAL_MACHINE.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoChangeStartMenu | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoChangeStartMenu
Type: REG_DWORD (DWORD Value)
Value: (0 = disable restriction, 1 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 3, 2002


Modify the Internet Auto-Dial Settings (All Windows)

Modify the Internet Auto-Dial Settings (All Windows)
Category: Home > Network > Internet and Remote Access

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows has the option to automatically dial your Internet Service Provider (ISP) to establish an Internet connection. This option can be controlled using this tweak.

Open your registry and find the key below.

Create a new DWORD value (or Binary on Windows 95) named "EnableAutodial", and set the new value to equal "1" to enable autodial or "0" to disable it.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | EnableAutodial | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Set... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\
Internet Settings]
Name: EnableAutodial
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2002


Enable Internet Mail Logging in Outlook 2000 (All Windows)

Enable Internet Mail Logging in Outlook 2000 (All Windows)
Category: Home > Software > Microsoft Office > Outlook

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

To help diagnose POP3, SMTP and Internet mail problems, Microsoft included a logging option for Outlook 2000. This feature can be enabled through the registry.

Open your registry and find the key below.

Create a new DWORD value and name it 'Logging' set the value to '1' to enable logging, or '0' to disable it.

Restart Outlook for the changes to take effect.

Note: After you establish or attempt to establish an Internet Mail session, three files will be created. The location of these files depends on the operating system you are running. Windows 98/Me - 'C:\Windows\Temp\Outlook Logging' or Windows NT/2000/XP - 'C:\Documents and Settings\USERNAME\Local Settings\Temp\Outlook Logging\ProfileName'

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Logging | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Outlook\Options\Mail |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Outlook\Options\Mail]
Name: Logging
Type: REG_DWORD (DWORD Value)
Value: 1 = logging enabled, 0 = logging disabled

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 5, 2000


Change the Registered Owner in Microsoft Office (All Windows)

Change the Registered Owner in Microsoft Office (All Windows)
Category: Home > Software > Microsoft Office

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

With previous versions of Microsoft Office it was necessary to re-install Office to change the registered company as shown on the splash screen and in the About dialog box. With Office 2000 and XP it can be changed in the registry.

Open your registry and find the key below for your version.

Office 2000
[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\ Uninstall\{00000409-78E1-11D2-B60F-006097C998E7}]

Office XP
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\ Uninstall\{90280409-6000-11D3-8CFE-0050048383C9}]

Change the value of "RegCompany" and "RegOwner" to the required registered company and user names.

Then find the following registry key for your Office version.

Office 2000
[HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Common]

Office XP
[HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Common]

And rename the sub-key called "UserInfo" to "OldUserInfo".

Exit your registry, close all the Office programs and restart one. The registered company should now be changed on both the splash screen and in the About dialog box.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | RegCompany | REG_SZ | "My Company, Inc" | |
| |  | RegOwner | REG_SZ | "Joe Blogs" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Access\Settings |
-

Settings:
Name: RegCompany, RegOwner
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 18, 2002


Setting the Windows Temporary Directory (All Windows)

Setting the Windows Temporary Directory (All Windows)
Category: Home > Tips and Tricks > Configuration Files > AUTOEXEC.BAT

Depending on which version of Windows you run, temporary files are usually stored in C:\WINDOWS\TEMP. This tweak shows how to move the location of the temporary file directory.

Open up AUTOEXEC.BAT with a text editor, it is normally found at C:\AUTOEXEC.BAT. If you're run Windows 9x it maybe possible to right-click the file in explorer and choose 'Edit'.

Add two new lines, or modify the existing lines if they are already there, as follows:

SET TEMP=[directory]
SET TMP=[directory]

e.g. SET TEMP=C:\GARBAGE

Save AUTOEXEC.BAT, create the directory entered above and reboot.

Settings:
Name: SET TEMP and SET TMP

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 17, 2000


Disable the Automatic Creation of a Default Network Route (Windows NT)

Disable the Automatic Creation of a Default Network Route (Windows NT)
Category: Home > Security > Network

This tweak controls the default behavior of Windows to add a network route to 0.0.0.0 on multi-homed machines (e.g. proxy or firewall).

Open your registry and the key below.

Create a new DWORD value named 'DontAddDefaultRoute' in the key below.

Set the value to '1' to enable the restriction.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | DontAddDefaultRoute | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\{Adapter}\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\{Adapter}\
Parameters]
Name: DontAddDefaultRoute
Type: REG_DWORD (DWORD Value)
Value: (0 = disable restriction, 1 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 11, 2000


Reset Internet Explorer Window Location (All Windows)

Reset Internet Explorer Window Location (All Windows)
Category: Home > Software > Internet Explorer > Appearance

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Sometimes Internet Explorer may have problems with the location of the explorer window, possibly placing the window off the screen or only allowing you to minimize or maximize the window. This tweak should reset Internet Explorer to the default position.

Exit Internet explorer, then open your registry and find the key below.

Find the value named 'Window_Placement' and delete it, make sure you have highlighted the correct value as there is no Undo function.

Restart Internet Explorer and it should now be located in the default position.

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
Name: Window_Placement
Type: REG_BINARY (Binary Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 3, 2002


Outlook Express and IMAP Settings (All Windows)

Outlook Express and IMAP Settings (All Windows)
Category: Home > Software > Outlook Express

This tweak allows you to correctly setup Outlook Express to use folders on the IMAP server for Drafts and Sent Mail instead of duplicating them with local folders.

Open your registry and find the key below. Where {Account ID} is the number relating to the IMAP account (e.g. 00000001). You may have to open a few sub-folders to find the correct one.

From your network administrator find out the name of the root IMAP folder (e.g. INBOX), the Drafts folder (e.g. Drafts) and the Sent Items folder (e.g. SentMail).

Create new string values (or modify existing value) named 'IMAP Root Folder', 'IMAP Drafts Folder' and 'IMAP Sent Items Folder'. Set the values to equal the details obtained in the previous step.

Exit the registry and restart Outlook Express.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | IMAP Root Folder | REG_SZ | "INBOX" | |
| |  | IMAP Drafts Folder | REG_SZ | "Drafts" | |
| |  | IMAP Sent Items Folder | REG_SZ | "Sent Items" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Internet Account Manager\Accounts\{... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Internet Account Manager\Accounts\
{Account ID}]
Name: IMAP Root Folder, IMAP Drafts Folder, IMAP Sent Items Folder
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 7, 2001


Disable Active Desktop (All Windows)

Disable Active Desktop (All Windows)
Category: Home > Security > Active Desktop

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak will disable the use of the Active Desktop feature.

Open your registry and find the key below.

Create a new DWORD value named "NoActiveDesktop", and set the new value to equal "1" to enable the restriction or "0" to disable the restriction.

This restriction can be used either on a user by user basis by adding it to HKEY_CURRENT_USER or on a computer wide basis by adding it to HKEY_LOCAL_MACHINE.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoActiveDesktop | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoActiveDesktop
Type: REG_DWORD (DWORD Value)
Value: (0 = disable restriction, 1 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 24, 2002


Show Cascading Control Panel Items (Windows 2000/Me/XP)

Show Cascading Control Panel Items (Windows 2000/Me/XP)
Category: Home > Windows > Start Menu and Taskbar > Documents and Folders

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak controls whether the Control Panel is shown as a cascading menu or as a simple folder link on the Start Menu.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'CascadeControlPanel' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This can be used either on a user by user basis by adding it to HKEY_CURRENT_USER or on a computer wide basis by adding it to HKEY_LOCAL_MACHINE.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | CascadeControlPanel | REG_SZ | Yes | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Adv... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
Advanced]
Name: CascadeControlPanel
Type: REG_SZ (String Value)
Value: "Yes" or "No"

Related Tweaks

  • Show Cascading Network Connections (Windows 2000/Me/XP)
  • Show Cascading My Documents Folder (Windows 2000/Me/XP)
  • Show Cascading Printers Folder (Windows 2000/Me/XP)
  • Show Cascading My Pictures Folder (Windows 2000/Me/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 19, 2001


Show Cascading Network Connections (Windows 2000/Me/XP)

Show Cascading Network Connections (Windows 2000/Me/XP)
Category: Home > Windows > Start Menu and Taskbar > Documents and Folders

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak makes the 'Network and Dial-up Connections' folder on the Start Menu into a cascading menu instead of a simple folder link.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'CascadeNetworkConnections' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This setting can be used either on a user by user basis by adding it to HKEY_CURRENT_USER or on a computer wide basis by adding it to HKEY_LOCAL_MACHINE.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | CascadeNetworkConnections | REG_SZ | Yes | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Adv... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
Advanced]
Name: CascadeNetworkConnections
Type: REG_SZ (String Value)
Value: "Yes" or "No"

Related Tweaks

  • Show Cascading Control Panel Items (Windows 2000/Me/XP)
  • Show Cascading My Documents Folder (Windows 2000/Me/XP)
  • Show Cascading Printers Folder (Windows 2000/Me/XP)
  • Show Cascading My Pictures Folder (Windows 2000/Me/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 19, 2001


Show Cascading My Documents Folder (Windows 2000/Me/XP)

Show Cascading My Documents Folder (Windows 2000/Me/XP)
Category: Home > Windows > Start Menu and Taskbar > Documents and Folders

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak makes the 'My Documents' folder on the Start Menu into a cascading folder, which then give you direct access to sub-folders without having to open the main 'My Documents' directory first.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'CascadeMyDocuments' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This setting can be used either on a user by user basis by adding it to HKEY_CURRENT_USER or on a computer wide basis by adding it to HKEY_LOCAL_MACHINE.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | CascadeMyDocuments | REG_SZ | Yes | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Adv... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
Advanced]
Name: CascadeMyDocuments
Type: REG_SZ (String Value)
Value: "Yes" or "No"

Related Tweaks

  • Show Cascading Control Panel Items (Windows 2000/Me/XP)
  • Show Cascading Network Connections (Windows 2000/Me/XP)
  • Show Cascading Printers Folder (Windows 2000/Me/XP)
  • Show Cascading My Pictures Folder (Windows 2000/Me/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 19, 2001


Use Personalized Menus (Windows 2000/Me/XP)

Use Personalized Menus (Windows 2000/Me/XP)
Category: Home > Windows > Appearance > Effects and Menus

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows 2000 included a new feature called Personalized Menus, which remembers which items you use regularly and hides less used items. This tweak allows you to enable or disable this functionality.

Open your registry and find the key mentioned below.

Create a new string value, or modify the existing value, named 'IntelliMenus'. Modify the value to equal 'YES' to enable smart menus or 'NO' to disable them.

Exit your registry and log off for the changes to take effect.

Note: By using the same key except under the [HKEY_LOCAL_MACHINE] tree the tweak can be enforced system wide, instead of only user based.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | IntelliMenus | REG_SZ | "No" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Adv... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
Advanced]
Name: IntelliMenus
Type: REG_SZ (String Value)
Value: Yes or No

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 12, 2002


Hide or Display Administrative Tools Menu (Windows 2000/XP)

Hide or Display Administrative Tools Menu (Windows 2000/XP)
Category: Home > Security > Start Menu and Taskbar

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

As with Windows NT, Windows 2000 has an 'Administrative Tools' folder on the Start Menu. This folder contains powerful administration utilities and therefore can be hidden to avoid accidental use.

Open your registry and find the key mentioned below.

Create a new string value, or modify the existing value, named 'StartMenuAdminTools'. Modify the value to equal 'YES' to show the administrative tools folder or 'NO' to hide it.

Exit your registry and log off for the changes to take effect.

Note: Hiding the item will not stop the use of the tools, it only make it more difficult to locate them.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | StartMenuAdminTools | REG_SZ | "Yes" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Adv... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
Advanced]
Name: StartMenuAdminTools
Type: REG_SZ (String Value)
Value: Yes or No

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: November 14, 2002


Enable Start Menu Scrolling (Windows 98/Me/2000/XP)

Enable Start Menu Scrolling (Windows 98/Me/2000/XP)
Category: Home > Windows > Start Menu and Taskbar

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When there are more items on the Start Menu than can fit on the screen, Windows can either create a second column of items or it can create a scrolling menu. This tweak controls that functionality.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'StartMenuScrollPrograms' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | StartMenuScrollPrograms | REG_SZ | Yes | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Adv... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
Advanced]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\
Advanced]
Name: StartMenuScrollPrograms
Type: REG_SZ (String Value)
Value: "Yes" or "No"

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 29, 2003


Show Cascading Printers Folder (Windows 2000/Me/XP)

Show Cascading Printers Folder (Windows 2000/Me/XP)
Category: Home > Windows > Start Menu and Taskbar > Documents and Folders

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak controls whether the 'Printers' sub-folder under 'Settings' on the Start Menu, is displayed as a cascading folder.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'CascadePrinters' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This setting can be used either on a user by user basis by adding it to HKEY_CURRENT_USER or on a computer wide basis by adding it to HKEY_LOCAL_MACHINE.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | CascadePrinters | REG_SZ | Yes | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Adv... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
Advanced]
Name: CascadePrinters
Type: REG_SZ (String Value)
Value: Yes or No

Related Tweaks

  • Show Cascading Control Panel Items (Windows 2000/Me/XP)
  • Show Cascading Network Connections (Windows 2000/Me/XP)
  • Show Cascading My Documents Folder (Windows 2000/Me/XP)
  • Show Cascading My Pictures Folder (Windows 2000/Me/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 19, 2001


Show Log Off Option on the Start Menu (Windows Me/2000)

Show Log Off Option on the Start Menu (Windows Me/2000)
Category: Home > Windows > Start Menu and Taskbar

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether the 'Log Off [Username]' option is shown on the Start Menu.

Open your registry and find the key mentioned below.

Create a new DWORD value, or modify the existing value, named 'StartMenuLogoff'. Modify the value to equal '1' to enable the Log Off option or '0' to disable it.

Exit your registry and log off for the changes to take effect.

Note: This restriction can be used either on a user by user basis by adding it to HKEY_CURRENT_USER or on a computer wide basis by adding it to HKEY_LOCAL_MACHINE.

Note: Value is a DWORD on Windows Me.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | StartMenuLogoff | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Adv... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
Advanced]
Name: StartMenuLogoff
Type: REG_DWORD (DWORD Value)
Value: 0 = disable, 1 = enabled

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 12, 2002


Show Favorites on the Start Menu (Windows 2000/XP)

Show Favorites on the Start Menu (Windows 2000/XP)
Category: Home > Windows > Start Menu and Taskbar

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether the Favorites folder is shown on the Start Menu.

Open your registry and find the key mentioned below.

Create a new DWORD value, or modify the existing value, named 'StartMenuFavorites'. Modify the value to equal '1' to enable Favorites or '0' to disable them.

Exit your registry and log off for the changes to take effect.

Note: This restriction can be used either on a user by user basis by adding it to HKEY_CURRENT_USER or on a computer wide basis by adding it to HKEY_LOCAL_MACHINE.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | StartMenuFavorites | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Adv... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
Advanced]
Name: StartMenuFavorites
Type: REG_DWORD (DWORD Value)
Value: 0 = disable, 1 = enabled

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 14, 2002


Show Friendly HTTP Error Messages (All Windows)

Show Friendly HTTP Error Messages (All Windows)
Category: Home > Software > Internet Explorer > Appearance

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

By default Internet Explorer will show a friendly version of any HTTP errors it receives, for example Error 404 Page Moved. This tweak controls that functionality allowing it to be enabled or disabled.

Open your registry and find the key mentioned below.

Create a new string value, or modify the existing value, named 'Friendly http errors'. Modify the value to equal 'YES' to enable friendly errors or 'NO' to disable them.

Exit your registry and restart IE for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Friendly http errors | REG_SZ | "Yes" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
Name: Friendly http errors
Type: REG_SZ (String Value)
Value: Yes or No

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2002


Use Personalized Favorites Menu (All Windows)

Use Personalized Favorites Menu (All Windows)
Category: Home > Software > Internet Explorer > Appearance

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Internet Explorer has a feature that automatically hides site that are rarely visited from the Favorites menu. This setting allows you to enable or disable the personalized menu feature.

Open your registry and find the key mentioned below.

Create a new string value, or modify the existing value, named 'FavIntelliMenus'. Modify the value to equal 'YES' to enable smart menus or 'NO' to disable them.

Exit your registry and log off for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | FavIntelliMenus | REG_SZ | "No" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
Name: FavIntelliMenus
Type: REG_SZ (String Value)
Value: Yes or No

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 13, 2002


Hide Control Panel Applets (Windows NT/2000/XP)

Hide Control Panel Applets (Windows NT/2000/XP)
Category: Home > Security > Control Panel

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak allows you to show or hide specific applets found in the Windows Control Panel.

Open your registry and find the key below.

For each applet you want to hide create a new string value and call it the filename of the applet to be hidden (for example 'fax.cpl'). Set the value to equal 'No' to hide the applet or delete tha value to display it.

Common Control Panel Applets:

  • access.cpl - Accessibility Applet
  • appwiz.cpl - Add/Remove Programs Applet
  • console.cpl - Console Applet
  • timedate.cpl - Date and Time Applet
  • desk.cpl - Display Applet
  • fax.cpl - Fax Applet
  • hdwwiz.cpl - Hardware Wizard Applet
  • irprops.cpl - Infrared Port Applet
  • intl.cpl - International and Regional Applet
  • inetcpl.cpl - Internet Settings Applet
  • joy.cpl - Joystick Applet
  • liccpa.cpl - Licensing Applet
  • main.cpl - Mouse and Keyboard Applet
  • mlcfg32.cpl - Mail Applet
  • mmsys.cpl - Sound and Multimedia Applet
  • modem.cpl - Modem and Phone Applet
  • ncpa.cpl - Network and connectivity Applet
  • netcpl.cpl - Network and Dial-up Connectivity Applet
  • nwc.cpl - Netware Client Applet
  • odbccp32.cpl - ODBC Applet
  • devapps.cpl - PC Card Applet
  • ports.cpl - Ports Applet
  • powercfg.cpl - Power Management Applet
  • sticpl.cpl - Scanner and Camera Applet
  • srvmgr.cpl - Server Manager Applet
  • sapi.cpl - Speech Properties Applet
  • sysdm.cpl - System Applet
  • telephon.cpl - Telephony Applet
  • tweakui.cpl - TweakUI Applet
  • nusrmgr.cpl - User Manager Applet
  • wspcpl32.cpl - WSP Client Applet
  • quicktime.cpl - QuickTime Applet
  • S32LUCP1.cpl - Norton Live Update Applet
  • cpqmgmt.cpl - Compaq Insight Agents Applet
Exit the registry and either logout or restart Windows.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | fax.cpl | REG_SZ | "No" | |
| |  | powercfg.cpl | REG_SZ | "No" | |
-
| HKEY_CURRENT_USER\Control Panel\don't load |
-

Settings:
User Key: [HKEY_CURRENT_USER\Control Panel\don't load]
Type: REG_SZ (String Value)
Value: Yes or No

Related Tweaks

  • Hide Control Panel Applets (Windows 95/98/Me)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 20, 2002


Use Personalized Menus in Microsoft Office 2000 (All Windows)

Use Personalized Menus in Microsoft Office 2000 (All Windows)
Category: Home > Software > Microsoft Office

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Microsoft Office 2000 introduced personalized menus (or adaptive menus) that remembers which items you use regularly and hides items you don't. This tweak allows you to enable or control this functionality.

Exit all open Office 2000 applications, including Word, Excel, Access and Outlook.

Open your registry and find the key below, if it does not exist create it.

Create a new DWORD value named 'AdaptiveMenus' and set the value to '0' for disabled and '1' for enabled.

Exit the registry and restart the Office applications for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AdaptiveMenus | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Common\Toolbars |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Common\Toolbars]
Name: AdaptiveMenus
Type: REG_DWORD (DWORD Value)
Value: 0 = disabled, 1 = enabled

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 13, 2002


Change the Number of Simultaneous HTTP Sessions (All Windows)

Change the Number of Simultaneous HTTP Sessions (All Windows)
Category: Home > Software > Internet Explorer > Network and Connections

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows normally limits the number of simultaneous connections made to a single web server. This behavior can be seen in Internet Explorer when downloading multiple files from a web site and only a certain number will be active at any one time.

Windows will limit connections to a single HTTP 1.0 server to four simultaneous connections. Connections to a single HTTP 1.1 server will be limited to two simultaneous connections. The HTTP 1.1 specification (RFC2068) mandates the two connection limit while the four connection limit for HTTP 1.0 is a self-imposed restriction which coincides with the standard used by a number of popular Web browsers.

Open your registry and find the key below.

Create two new values, or modify the existing values, called 'MaxConnectionsPerServer' and 'MaxConnectionsPer1_0Server'. Change the values to equal the number of simultaneous requests allowed to a single HTTP server, the default values are 2 and 4 respectively.

Restart Windows for the change to take effect.

Note: By changing these settings you are causing Windows to break the HTTP protocol specification for any Internet applications running on your machine.

Note: This affects all Windows Internet applications that use the standard API, including Internet Explorer.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | MaxConnectionsPerServer | REG_DWORD | 0x00000005 (5) | |
| |  | MaxConnectionsPer1_0Server | REG_DWORD | 0x00000005 (5) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Set... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\
Internet Settings]
Name: MaxConnectionsPerServer, MaxConnectionsPer1_0Server
Type: REG_DWORD (DWORD Value)
Value: Number of Simultaneous Connections

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 12, 2002


Internet Explorer Control Panel Restrictions (Part 1) (All Windows)

Internet Explorer Control Panel Restrictions (Part 1) (All Windows)
Category: Home > Software > Internet Explorer > Security

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

These tweaks allows you to control access to the Internet Explorer setup and control panel functions (found under Tools -> Internet Options).

Open your registry and find the key below.

Create a new DWORD value based on the options below, and set the new value to equal "1" to enable the restriction or "0" to disable the restriction.

  • Advanced - Prevent changes to advanced settings
  • Autoconfig - Prevent changes to Automatic Configuration
  • Cache - Prevent changes to temporary file settings
  • CalendarContact - Prevent changes to calender and contacts
  • Certificates - Prevent changes to security certificates
  • Check_If_Default - Prevent changes to default browser check
  • Colors - Prevent Color changes
  • Connection Settings - Prevent changes to connection settings
  • Connection Wizard - Disable the Connection Wizard
  • Fonts - Disable font changes
  • History - Disable changes to History settings
  • HomePage - Disable changes to Home Page settings
  • Languages - Disable Language changes
  • Links - Disable Links changes
  • Messaging - Disable Messaging changes
  • Profiles - Disable changes to Profiles
  • Proxy - Disable changes to Proxy settings
  • Ratings - Disable Ratings changes
  • Wallet - Disable changes to Wallet settings

Restart Internet Explorer for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Advanced | REG_DWORD | 0x00000001 (1) | |
| |  | Autoconfig | REG_DWORD | 0x00000001 (1) | |
| |  | Cache | REG_DWORD | 0x00000001 (1) | |
| |  | CalendarContact | REG_DWORD | 0x00000001 (1) | |
| |  | Certificates | REG_DWORD | 0x00000001 (1) | |
| |  | Check_If_Default | REG_DWORD | 0x00000001 (1) | |
| |  | Colors | REG_DWORD | 0x00000001 (1) | |
| |  | Connection Settings | REG_DWORD | 0x00000001 (1) | |
| |  | Connection Wizard | REG_DWORD | 0x00000001 (1) | |
| |  | Fonts | REG_DWORD | 0x00000001 (1) | |
| |  | History | REG_DWORD | 0x00000001 (1) | |
| |  | HomePage | REG_DWORD | 0x00000001 (1) | |
| |  | Languages | REG_DWORD | 0x00000001 (1) | |
| |  | Links | REG_DWORD | 0x00000001 (1) | |
| |  | Messaging | REG_DWORD | 0x00000001 (1) | |
| |  | Profiles | REG_DWORD | 0x00000001 (1) | |
| |  | Proxy | REG_DWORD | 0x00000001 (1) | |
| |  | Ratings | REG_DWORD | 0x00000001 (1) | |
| |  | Wallet | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control ... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\
Control Panel]
System Key: [HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Internet Explorer\
Control Panel]
Type: REG_DWORD (DWORD Value)
Value: (0 = disable restriction, 1 = enable restriction)

Related Tweaks

  • Internet Explorer Control Panel Restrictions (Part 2) (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 20, 2002


Show Windows Version on Desktop (All Windows)

Show Windows Version on Desktop (All Windows)
Category: Home > Windows > Desktop

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Early versions of Windows showed the version number on the desktop, this feature was removed in the released version. This tweak can be used to enable the feature and allow you to quickly locate which version of Windows is running.

Open your registry and find the key below.

Create a new DWORD (or String on Windows 98 and Me) value, or modify the existing value called 'PaintDesktopVersion' set the value to equal '1' to display the version.

Exit the registry, you may need to restart for the change to take effect.

Note: The Windows version may be hidden behind the taskbar when you have Active Desktop enabled. If this is the case disable Active Desktop to view the label.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | PaintDesktopVersion | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Control Panel\Desktop |
-

Settings:
User Key: [HKEY_CURRENT_USER\Control Panel\Desktop]
Name: PaintDesktopVersion
Type: REG_DWORD (DWORD Value)
Value: (0 = disable, 1 = enable)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 21, 2002


Change the Application Focus Settings (All Windows)

Change the Application Focus Settings (All Windows)
Category: Home > Windows > Desktop

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When Windows applications require user input or focus, they will either pop-up over the existing window, or their icon will flash on the taskbar waiting for user action. This tweak controls that behavior.

This tweak requires the modification of two values, depending on the way you would like applications to take the focus. The first setting controls whether applications simply steal the focus, that is pop-up over the existing in focus window, or if instead they wait in the background and flash the taskbar icon. The second setting controls the flashing of the icon.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value named 'ForegroundLockTimeout', change the value to either the timeout required, or to '0' which causes the application to take the focus instantly. The default value is '200000' (0x00030d40 hex).

The other settings affects the number of times the icon flashes if above value was not set to zero.

Create a new DWORD value, or modify the existing value called 'ForegroundFlashCount' set the value (in decimal) to the number times to flash the taskbar icon, setting the value to '0' cases the icon to flash infinitely. The default value is '3'.

Exit your registry, you may need to restart for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ForegroundFlashCount | REG_DWORD | 0x00000003 (3) | |
| |  | ForegroundLockTimeout | REG_DWORD | 0x00030d40 (200000) | |
-
| HKEY_CURRENT_USER\Control Panel\Desktop |
-

Settings:
User Key: [HKEY_CURRENT_USER\Control Panel\Desktop]
Type: REG_DWORD (DWORD Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 12, 2002


Restrict Changes to Active Desktop Settings (All Windows)

Restrict Changes to Active Desktop Settings (All Windows)
Category: Home > Security > Active Desktop

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak allows you to have Active Desktop enabled, but to restrict any changes to the settings.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoActiveDesktopChanges' set the value to equal '1' to enable the restriction.

Exit your registry, you may need to restart for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoActiveDesktopChanges | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoActiveDesktopChanges
Type: REG_DWORD (DWORD Value)
Value: (0 = disable restriction, 1 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 25, 2002


Hide Computers Near Me in Network Places (Windows 2000/Me/XP)

Hide Computers Near Me in Network Places (Windows 2000/Me/XP)
Category: Home > Security > Network

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allows you to show or hide the computers listed Near Me in My Network Places.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoComputersNearMe' set the value to equal '1' to enable the restriction.

Exit your registry, you may need to restart for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoComputersNearMe | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoComputersNearMe
Type: REG_DWORD (DWORD Value)
Value: (0 = disable restriction, 1 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 3, 2002


Disable Control Panel (Windows 2000/Me/XP)

Disable Control Panel (Windows 2000/Me/XP)
Category: Home > Security > Control Panel

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allows you to restrict user access to the Control Panel options and settings.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoControlPanel' set the value to equal '1' to enable the restriction.

Exit your registry, you may need to restart for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoControlPanel | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoControlPanel
Type: REG_DWORD (DWORD Value)
Value: (0 = disable restriction, 1 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 25, 2002


Remove Network Connections from the Start Menu (Windows 2000/Me/XP)

Remove Network Connections from the Start Menu (Windows 2000/Me/XP)
Category: Home > Security > Start Menu and Taskbar > Documents and Folders

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak allows you to hide the Network and Dial-up Connections option on the Start Menu.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoNetworkConnections' set the value to equal '1' to enable the restriction.

Exit your registry, you may need to restart for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoNetworkConnections | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoNetworkConnections
Type: REG_DWORD (DWORD Value)
Value: (0 = disable restriction, 1 = enable restriction)

Related Tweaks

  • Remove My Computer from the Desktop and Start Menu (Windows 2000/Me/XP)
  • Remove Favorites from the Start Menu (All Windows)
  • Remove Recent Documents from the Start Menu (All Windows)
  • Remove My Documents from the Start Menu (Windows 2000/Me/XP)
  • Remove My Pictures from the Start Menu (Windows 2000/Me/XP)
  • Remove My Music from the Start Menu (Windows 2000/Me/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 3, 2002


Disable Recent Documents History (All Windows)

Disable Recent Documents History (All Windows)
Category: Home > Security > Start Menu and Taskbar > Documents and Folders

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Normally when you open or access a document or file it is added to the list of recent documents on the Start Menu. This tweak will stop files from being added to the list.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoRecentDocsHistory' set the value to equal '1' to enable the restriction.

Exit your registry, you may need to restart for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoRecentDocsHistory | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoRecentDocsHistory
Type: REG_DWORD (DWORD Value)
Value: (0 = disable restriction, 1 = enable restriction)

Related Tweaks

  • Remove Recent Documents from the Start Menu (All Windows)
  • Change the Number of Recent Documents Displayed (Windows 2000/Me/XP)
  • Clear Recent Documents When Windows Exits (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 3, 2002


Clear Recent Documents When Windows Exits (All Windows)

Clear Recent Documents When Windows Exits (All Windows)
Category: Home > Windows > Start Menu and Taskbar > Documents and Folders

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction will clear the list of recent documents on the Start Menu when Windows exits.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'ClearRecentDocsOnExit' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ClearRecentDocsOnExit | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: ClearRecentDocsOnExit
Type: REG_DWORD (DWORD Value)
Value: (0 = disable, 1 = enable)

Related Tweaks

  • Remove Recent Documents from the Start Menu (All Windows)
  • Change the Number of Recent Documents Displayed (Windows 2000/Me/XP)
  • Disable Recent Documents History (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 9, 2002


Remove the Help Option from the Start Menu (Windows 2000/Me/XP)

Remove the Help Option from the Start Menu (Windows 2000/Me/XP)
Category: Home > Security > Start Menu and Taskbar

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction removes the Help option from the Start Menu.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoSMHelp' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoSMHelp | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoSMHelp
Type: REG_DWORD (DWORD Value)
Value: (0 = disable restriction, 1 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 3, 2002


Remove My Documents from the Start Menu (Windows 2000/Me/XP)

Remove My Documents from the Start Menu (Windows 2000/Me/XP)
Category: Home > Security > Start Menu and Taskbar > Documents and Folders

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction removes My Documents which is shown under the Documents folder on the Start Menu.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoSMMyDocs' set the value to equal '1' to enable the restriction.

Exit your registry, you may need to restart for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoSMMyDocs | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoSMMyDocs
Type: REG_DWORD (DWORD Value)
Value: (0 = disable restriction, 1 = enable restriction)

Related Tweaks

  • Remove Favorites from the Start Menu (All Windows)
  • Remove Recent Documents from the Start Menu (All Windows)
  • Remove My Pictures from the Start Menu (Windows 2000/Me/XP)
  • Remove My Music from the Start Menu (Windows 2000/Me/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 3, 2002


Disable the Windows Hotkeys (All Windows)

Disable the Windows Hotkeys (All Windows)
Category: Home > Security

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction allows you to disable the use of the Windows hotkey combinations that provide shortcuts to the Start Menu and task swapping.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoWinKeys' set the value to equal '1' to enable the restriction.

Exit your registry, you may need to restart for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoWinKeys | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoWinKeys
Type: REG_DWORD (DWORD Value)
Value: (0 = disable restriction, 1 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 19, 2002


Hide Links Folder on Favorites Menu (All Windows)

Hide Links Folder on Favorites Menu (All Windows)
Category: Home > Software > Internet Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Internet Explorer persistently creates a Links folder on the Favorites menu, this tweak allows you to remove it.

There are two methods that can be used to hide the Links folder, one using the registry and the other using file attributes. Both methods are detailed below:

Using the Registry
Open your registry and find the key below.

Set the value of "LinksFolderName" to equal a blank string. Open IE and delete the Links folder from the Favorites menu.

The next time you start Internet Explorer the Links folder will not be recreated.

Using File Attributes
Using Explorer find the location of your Favorites folder (e.g. C:\Documents and Settings\Joe Bloggs\Favorites) within that folder will be a sub-folder named Links.

Select the Links folder and right-click (or secondary click) and select Properties, check the Hidden checkbox and click OK.

From now on the Links folder should be hidden from the Favorites list. This works for any other folder or link on the favorites menu as well.

Note: The Links folder must be manually deleted from the favorites menu. This tweak stops it being automatically recreated.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | LinksFolderName | REG_SZ | "" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Toolbar |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Toolbar]
Name: LinksFolderName
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 18, 2003


Change the Number of Spare Stack Pages (Windows 95/98/Me)

Change the Number of Spare Stack Pages (Windows 95/98/Me)
Category: Home > Tips and Tricks > Configuration Files > SYSTEM.INI

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows sets aside a number of extra memory pages (spare stack pages) to be used temporarily to prevent a system "crash" due to a stack overflow condition. Sometimes all the spare pages can be used, and an error message is shown, this tweak allows you to increase the number available.

If you receive the following error message, it means Windows has detected that it has run out of spare stack pages. Windows should continue to operate normally unless a device driver encounters a stack overflow condition when there are no free spare stack pages.

Error: There are no spare stack pages. It may be necessary to increase the setting named 'MinSPs' in System.ini to prevent possible stack faults. There are currently [xxx] SPs allocated.

To increase the number of available spare pages follow these instructions:

Open the file SYSTEM.INI located in your Windows directory (usually C:\WINDOWS\SYSTEM.INI) using a text editor (e.g. Notepad).

Add the following line to the [386Enh] section of the file and then restart your computer:

MinSPs=4

If the problem persists, increase the number of spare stack pages in increments of 4 (for example: 8, 12, 16). Each spare stack page requires 4 kilobytes of memory.

Settings:
Name: MinSPs

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 12, 2002


Show Attributes Column in Explorer (Windows 98/Me/2000/XP)

Show Attributes Column in Explorer (Windows 98/Me/2000/XP)
Category: Home > Windows > Windows Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

If you like to view your files using the detailed view option you may have noticed that the attributes column has disappeared. With the introduction of Windows 98 it was removed by default, this tweak adds it back.

Open your registry and find the key below.

Create a new DWORD value called 'ShowAttribCol' and set the value to '1' to enable the attributes column.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ShowAttribCol | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Adv... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
Advanced]
Name: ShowAttribCol
Type: REG_DWORD (DWORD Value)
Value: (0 = disable, 1 = enable)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 13, 2002


Disables DHCP Router Discovery (All Windows)

Disables DHCP Router Discovery (All Windows)
Category: Home > Security > Network

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

The ICMP Router Discovery Protocol (IRDP) comes enabled by default for Windows clients using DHCP. This can be a security issue because by spoofing IRDP Router Advertisements, an attacker can remotely add default route entries on a remote system.

Open your registry and find the key below for your operating system.

Windows 95, 98 and Me
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Class\NetTrans\####]

Where #### is the protocol binding for TCP/IP. More than one TCP/IP binding may exist.

Windows NT, 2000 and XP [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]

Create a new DWORD value called "PerformRouterDiscovery" and set the value to equal "0" to disable router discovery.

Restart Windows for the change to take effect.

Note: It is recommended that you disable this value as it is a possible security flaw in the DHCP service.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | PerformRouterDiscovery | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]
Name: PerformRouterDiscovery
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 19, 2002


Disable Expanding Internet Explorer New Menu (All Windows)

Disable Expanding Internet Explorer New Menu (All Windows)
Category: Home > Software > Internet Explorer > Appearance

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Usually when you click on the New menu in Internet Explorer it is expanded to include options like New Window, Message, Post and Internet Call. Using this tweak will stop the menu expanding and therefore only display the "New Window" option.

Open your registry and find the key below.

Create a new DWORD value called 'NoExpandedNewMenu' and set the value to '1' to stop the expanded menu from displaying.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoExpandedNewMenu | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoExpandedNewMenu
Type: REG_DWORD (DWORD Value)
Value: (0 = expanded, 1 = not expanded)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2002


Disable Folder Options Menu (All Windows)

Disable Folder Options Menu (All Windows)
Category: Home > Security > Desktop and Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak allows you to hide the Folder Options function from the folder Tools menu. Allowing you to restrict access to numerous advanced folder features.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value named "NoFolderOptions" and set it to equal "1" to hide the options or "0" to show the options.

Log-off or restart Windows for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoFolderOptions | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoFolderOptions
Type: REG_DWORD (DWORD Value)
Value: (0 = show options, 1 = hide options)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 25, 2002


Optimize Swap File Performance (Windows 98/Me)

Optimize Swap File Performance (Windows 98/Me)
Category: Home > Windows > File System > Caching and Memory

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

On systems with larger amounts of memory, more than 128Mb, the hard disk based swap file is not needed as much. This tweak optimizes the use of the swap file on such systems.

Using notepad open the SYSTEM.INI file in your Windows directory.

Find the [386Enh] section and add a new line reading "ConservativeSwapfileUsage=1".

Save the file and restart Windows for the change to take effect.

Settings:
Name: ConservativeSwapfileUsage
Value: 1

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 12, 2002


Show Super Hidden File Extensions (All Windows)

Show Super Hidden File Extensions (All Windows)
Category: Home > Windows > File System > Files and Shortcuts

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Even when you have configured Windows to display all file extensions, there are still some which remain hidden. This allows potentially dangerous files to be masked as safe files, fooling the user into executing them. This tweak helps expose those file extensions.

It is possible for a malicious user to name a file so that it looks safe to open, when in fact it may be executable containing dangerous content.

For example, a file could be displayed as "readme.txt" in explorer, when it fact it is really name "readme.txt.shs" but since the ".shs" portion of the filename is hidden it is impossible to tell it apart from a simple text file. Then once a user double-clicks to open this file, instead of seeing a text page as expected, the file will be executed by Windows as a scrap object and potentially harm the system.

To remove the potential to hide files, open your registry and using the search function find each occurance of a value named "NeverShowExt".

When this value is present the associated file extension will not be shown. To display the file extension highlight the "NeverShowExt" value and press Delete. Repeat this process for each extension you want to display.

Some common hidden extensions include:

Document Shortcut (.SHB)
[HKEY_CLASSES_ROOT\DocShortcut]

Internet Shortcut (.URL)
[HKEY_CLASSES_ROOT\InternetShortcut]

File Shortcut (.LNK)
[HKEY_CLASSES_ROOT\lnkfile]

DOS Shortcut (.PIF)
[HKEY_CLASSES_ROOT\piffile]

Explorer Command (.SCF)
[HKEY_CLASSES_ROOT\SHCmdFile]

Shell Scrap Object (.SHS)
[HKEY_CLASSES_ROOT\ShellScrap]

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NeverShowExt | REG_SZ |  | |
-
| HKEY_CLASSES_ROOT |
-

Settings:
System Key: [HKEY_CLASSES_ROOT]
Name: NeverShowExt
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 18, 2002


Automatic Window Refresh (Windows 95/98/Me)

Automatic Window Refresh (Windows 95/98/Me)
Category: Home > Windows > Appearance > Effects and Menus

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Normally when the contents of a window change you may need to wait a few seconds, or press F5, to refresh the display to see the updated information. This tweak configures the system to perform faster automatic updates.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, named "UpdateMode" and set it to equal "0" for faster updates.

Restart Windows for the change to take effect.

Note: This setting also affects how system policies are applied; you should disable this tweak if you have issues with system policies.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | UpdateMode | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Update |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Update]
Name: UpdateMode
Type: REG_DWORD (DWORD Value)
Value: default = 1

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 1, 2002


Force Users to Logon to Windows (Windows 95/98/Me)

Force Users to Logon to Windows (Windows 95/98/Me)
Category: Home > Security > Login and Authentication

Usually users can simply press 'Cancel' at the Windows logon box to bypass the login process and gain access to the local computer. This tweak will logout the user if the authentication fails or the user clicks Cancel.

Like all registry tweaks, this is for advanced users, please do not attempt to try this if you are not confident with the Windows registry and recovering from any subsequent problems.

Firstly, setup your computer for multiple users by using the 'Users' wizard in the Control Panel. Create a new user in addition to any existing users, then restart Windows and login as the new user (this will become your new default account).

While you are logged in open your registry and expand the [HKEY_USERS] key, there should be several sub-folders including ".DEFAULT", "Software" and a folder corresponding to the new username you created above.

Open the key listed below (if the 'Run' key does not already exist then create it), and create a new string value named "NoLogon", and set the value to equal "RUNDLL32 shell32,SHExitWindowsEx 0".

Log-off and now when you login using the new username you should gain access to the desktop, but when you press Cancel or enter the wrong password the desktop should partially load, and then the computer should return to the login screen.

Note: If you have problems with this tweak, press F8 while the "Starting Windows 98..." boot-up message is showing, and select Safe Mode. Then open your registry and delete the "NoLogon" key created above.

Note: Once this tweak has been implemented any subsequent users accounts that are created will inherit the 'NoLogon' value and therefore reboot when they login. To avoid this; when you first create a new user, open the key below for the newly created account name (e.g. [HKEY_USERS\jdoe]) and remove the 'NoLogon' value.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoLogon | REG_SZ | "RUNDLL32 shell32,SHExitWindowsEx 0" | |
-
| HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Run |
-

Settings:
User Key: [HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Run]
Name: NoLogon
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 11, 2000


Clear the Internet Explorer Typed Address History (All Windows)

Clear the Internet Explorer Typed Address History (All Windows)
Category: Home > Security > Privacy

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Internet Explorer caches any URLs that are typed into the address bar. This may become a privacy issue on a shared computer, or a nuisance if there is a particular URL you want to remove without clearing the whole history.

Open your registry and find the key below and delete any value you want to remove. Or remove the entire key to delete all entries.

Restart Internet Explorer for the change to take effect.

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\TypedURLs]

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 15, 2002


Windows Netmeeting Policies and Restrictions (All Windows)

Windows Netmeeting Policies and Restrictions (All Windows)
Category: Home > Software > Netmeeting

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

These restrictions and policies can be used to disable or restrict access to certain features of Windows Netmeeting.

Open your registry and find the key below.

Create a new DWORD value and name it according to the list of values below. Set the value to equal "1" to enable the setting.

  • CallSecurity
  • IntranetWebDirURL
  • MaximumBandwidth
  • NoAddingDirectoryServers
  • NoAdvancedAudio
  • NoAdvancedCalling
  • NoAllowControl
  • NoAppSharing
  • NoAudio
  • NoAudioPage
  • NoAutoAcceptCalls
  • NoChangeDirectSound
  • NoChangingCallMode
  • NoChat
  • NoDirectoryServices
  • NoFullDuplex
  • NoGeneralPage
  • NoNewWhiteBoard
  • NoOldWhiteBoard
  • NoReceivingFiles
  • NoReceivingVideo
  • NoSecurityPage
  • NoSendingFiles
  • NoSendingVideo
  • NoSharing
  • NoSharingDesktop
  • NoSharingDosWindows
  • NoSharingExplorer
  • NoTrueColorSharing
  • NoVideoPage
  • NoWebDirectory
  • ShowFirstTimeURL
  • Use AutoConfig

Restart Netmeeting for the changes to take effect.

Settings:
User Key: [HKEY_CURRENT_USER\SOFTWARE\Policies\Microsoft\Conferencing]
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Conferencing]
Type: REG_DWORD (DWORD Value)
Value: (0 = disable policy, 1 = enable policy)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 27, 2002


Netmeeting Logging (All Windows)

Netmeeting Logging (All Windows)
Category: Home > Software > Netmeeting

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting enables the debug logging functions in Microsoft Netmeeting. This may be useful to diagnose faults or connection issues.

Open your registry and find the key below.

Create a new DWORD value named "RetailLog" and set the value to "1" to enable logging.

Restart Netmeeting for the change to take effect.

Note: The log file will written to [NM_Directory]/nmLog.txt

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | RetailLog | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Conferencing\Debug |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Conferencing\Debug]
Name: RetailLog
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enable logging)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 27, 2002


Change the Default Gatekeeper Discovery TTL (All Windows)

Change the Default Gatekeeper Discovery TTL (All Windows)
Category: Home > Software > Netmeeting

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls the default Time-to-Live (TTL) for the gatekeeper multicast discovery packets in Microsoft Netmeeting.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'GKMCastTTL' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Conferencing\GatekeeperDLL]
Name: GKMCastTTL
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 27, 2002


Disable the Ability to Customize Toolbars (All Windows)

Disable the Ability to Customize Toolbars (All Windows)
Category: Home > Software > Internet Explorer > Security

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

By right clicking on a toolbar you are usually given the option to Customize, which allows you to change which functions are available from the toolbar. This tweak allows you to disable that function.

Open your registry and find the key below.

Create a new DWORD value named "NoToolbarCustomize" and set the value to "1" to disable the ability to customize the toolbars.

You may need to log-off for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoToolbarCustomize | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoToolbarCustomize
Type: REG_DWORD (DWORD Value)
Value: (1 = enable restriction)

Related Tweaks

  • Remove the Option to Change or Hide Toolbars (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2002


Remove the Option to Change or Hide Toolbars (All Windows)

Remove the Option to Change or Hide Toolbars (All Windows)
Category: Home > Software > Internet Explorer > Security

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

By default users are able to select which toolbars are displayed either be right clicking the toolbar itself, or by changing the options from the View menu. This tweak locks the toolbars, removing the ability to change which are displayed.

Open your registry and find the key below.

Create a new value named "NoBandCustomize" and set it to equal "1" to enable the restriction.

You may need to log-off for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoBandCustomize | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoBandCustomize
Type: REG_DWORD (DWORD Value)
Value: (1 = enable restriction)

Related Tweaks

  • Disable the Ability to Customize Toolbars (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2002


Disable User Tracking (Windows 2000/XP)

Disable User Tracking (Windows 2000/XP)
Category: Home > Security > Privacy

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting stops Windows from recording user tracking information including which applications a user runs and which files and documents are being accessed.

Open your registry and find the key below.

Create a new DWORD value named "NoInstrumentation" and set the value equal to "1" to enable the restriction.

You may need to log-off for the change to take effect.

Note: If this restriction is enabled customized menus and other features that require user tracking information are disabled.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoInstrumentation | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoInstrumentation
Type: REG_DWORD (DWORD Value)
Value: (1 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 30, 2002


Force the Use of Active Desktop (All Windows)

Force the Use of Active Desktop (All Windows)
Category: Home > Security > Active Desktop

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

The user is normally given the option of disabling Active Desktop through the display properties. This tweak removes the ability to disable Active Desktop.

Open your registry and find the key below.

Create a new DWORD value named "ForceActiveDesktopOn" and set the value to "1" to force the use of Active Desktop.

Note: You must have Internet Explorer 4.0 or greater installed for this option to be available.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ForceActiveDesktopOn | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: ForceActiveDesktopOn
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 14, 2002


Change the Size of the Virtual Disk Cache (Windows 95/98/Me)

Change the Size of the Virtual Disk Cache (Windows 95/98/Me)
Category: Home > Windows > File System > Caching and Memory

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak allows you control the minimum and maximum amount of memory being allocated as disk cache. It can be used to speed up your system and possibly avoid some memory problems.

Using notepad or another text editor, open your SYSTEM.INI file from your Windows directory.

Find the section starting with [vcache], and add the following two lines, or modify them if they already exist.

MinFileCache=0
MaxFileCache=4096

These values set the amount of memory in kilobytes to be used for disk caching, if you have more the 16Mb of RAM you may want to increase the MaxFileCache size, to about 25% of your total RAM (i.e. if you have 128Mb use "MaxFileCache=32768")

Restart Windows for the change to take effect.

Note: If you are receiving an error like "Error: An I/O subsystem driver failed to load" try increasing the maximum size to 6144.

Settings:
Name: MinFileCache, MaxFileCache

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 12, 2002


Internet Explorer FTP Mode (All Windows)

Internet Explorer FTP Mode (All Windows)
Category: Home > Software > Internet Explorer > Network and Connections

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Internet Explorer has the ability to display FTP sites as if they were local folders. This tweak controls which mode IE uses for FTP.

Open your registry and find the key below.

Set the value named "Use Web Based FTP" to equal "no" for the folder view or "yes" for the traditional view.

Restart IE for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Use Web Based FTP | REG_SZ | "No" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Ftp |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Ftp]
Name: Use Web Based FTP
Type: REG_SZ (String Value)
Value: Yes or No

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2002


Optimize Broadband Cable Modem and DSL Connections (Windows 2000/XP)

Optimize Broadband Cable Modem and DSL Connections (Windows 2000/XP)
Category: Home > Network > Internet and Remote Access

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

These settings allow you to boost the speed of your broadband Internet connection when using a Cable Modem or DSL Router with Windows 2000 and Windows XP.

Open your registry and find the key below.

Create the following DWORD values, as most of these values will not already exist you will need to create them by clicking on 'Edit -> New -> DWORD Value' and then set the value as shown below.

DefaultTTL = "80" hex (or 128 decimal)
Specifies the default time to live (TTL) for TCP/IP packets. The default is 32.

EnablePMTUBHDetect = "0"
Specifies whether the stack will attempt to detect Maximum Transmission Unit (MTU) routers that do not send back ICMP fragmentation-needed messages. The default is 0.

EnablePMTUDiscovery = "1"
Specifies whether the TCP/IP stack will attempt to perform path MTU discovery as specified in RFC 1191. The default is 1.

GlobalMaxTcpWindowSize = "7FFF" hex (or 32767 decimal)
Specifies the system maximum receive window size advertised by the TCP/IP stack.

TcpMaxDupAcks = "2"
Determines the number of duplicate ACKs that must be received for the same sequence number of sent data before "fast retransmit" is triggered.

SackOpts = "1"
Enables support for selective acknowledgements as documented by Request for Comment (RFC) 2018. Default is 0.

Tcp1323Opts = "1"
Controls RFC 1323 time stamps and window scaling options. Possible values are: "0" = disable RFC 1323 options, "1" = window scale enabled only, "2" = time stamps enabled only and "3" = both options enabled.

TcpWindowSize = "7FFF" hex (or 32767 decimal)
Specifies the receive window size advertised by the TCP/IP stack. If you have a latent network you can try increasing the value to 93440, 186880, or 372300.

Exit your registry and restart Windows for the changes to take effect.

Note: These optimized settings may not work with all ISP configurations, in which case the parameters should be returned to the default values.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DefaultTTL | REG_DWORD | 0x00000080 (128) | |
| |  | EnablePMTUBHDetect | REG_DWORD | 0x00000000 (0) | |
| |  | EnablePMTUDiscovery | REG_DWORD | 0x00000001 (1) | |
| |  | GlobalMaxTcpWindowSize | REG_DWORD | 0x00007fff (32767) | |
| |  | TcpMaxDupAcks | REG_DWORD | 0x00000002 (2) | |
| |  | SackOpts | REG_DWORD | 0x00000001 (1) | |
| |  | Tcp1323Opts | REG_DWORD | 0x00000001 (1) | |
| |  | TcpWindowSize | REG_DWORD | 0x00007fff (32767) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]
Type: REG_DWORD (DWORD Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 19, 2002


Cable Modem and DSL Speed Tweak to Increase Performance (Windows 95/98/Me)

Cable Modem and DSL Speed Tweak to Increase Performance (Windows 95/98/Me)
Category: Home > Network > Internet and Remote Access

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

These settings allow you to boost the speed of your broadband Internet connection when using a Cable Modem or DSL Router with Windows 95, 98 and Millennium Edition.

Open your registry and find the key below.

Create the following values, as most of these values will not already exist you will need to create them by clicking on Edit -> New -> DWORD or String Value and then set the value as shown below.

DefaultTTL = "128" (String Value)
Specifies the default time to live (TTL) for TCP/IP packets. The default is 32.

DefaultRcvWindow = "32767" (String Value)
Specifies the default receive window advertised by the TCP/IP stack. The default is 8192. If you're using Windows 98, Me or 2000 and have a latent network, you can try increasing the value to 93440, 186880, or 372300.

PMTUBlackHoleDetect = "0" (String Value)
Specifies whether the stack will attempt to detect Maximum Transmission Unit (MTU) routers that do not send back ICMP fragmentation-needed messages. The default is 0.

PMTUDiscovery = "1" (String Value)
Specifies whether the TCP/IP stack will attempt to perform path MTU discovery as specified in RFC 1191. The default is 1.

SackOpts = "1" (String Value)
Enables support for selective acknowledgements as documented by Request for Comment (RFC) 2018. Default is 0.

Tcp1323Opts = "1" (String Value)
Controls RFC 1323 time stamps and window scaling options. Possible values are: "0" = disable RFC 1323 options, "1" = window scale enabled only, "2" = time stamps enabled only and "3" = both options enabled.

To increase performance even further follow the instructions here and increase the MaxMTU to 1500 (or 1492 if your provider uses PPPoE).

Exit your registry and restart Windows for the change to take effect.

Note: If you are using Windows 95, first download and install the Winsock Update from Microsoft before proceeding with this tweak.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DefaultTTL | REG_SZ | "128" | |
| |  | DefaultRcvWindow | REG_SZ | "32767" | |
| |  | PMTUBlackHoleDetect | REG_SZ | "0" | |
| |  | PMTUDiscovery | REG_SZ | "1" | |
| |  | SackOpts | REG_SZ | "1" | |
| |  | Tcp1323Opts | REG_SZ | "1" | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 17, 2003


Change the Number of SQL Server Error Logs (Windows NT/2000/XP)

Change the Number of SQL Server Error Logs (Windows NT/2000/XP)
Category: Home > Windows > Troubleshooting > Logging

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

By default, Microsoft SQL Server 7.0 only stores seven error logs; Errorlog and Errorlog.1 through Errorlog.6. Since the log is re-created every time SQL Server is restarted you may want to keep more than seven logs archived.

Open your registry and find the key below.

Create a new DWORD value called 'NumErrorLogs' and set it to equal the number of archived logs you want to keep.

You may need to restart SQL for the change to become effective.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NumErrorLogs | REG_DWORD | 0x00000014 (20) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\MSSQLServer |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\MSSQLServer]
Name: NumErrorLogs
Type: REG_DWORD (DWORD Value)
Value: default = 7

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 5, 2000


Change the Keyboard Buffer Size (Windows NT/2000/XP)

Change the Keyboard Buffer Size (Windows NT/2000/XP)
Category: Home > Hardware > Mice and Keyboards

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Occasionally Windows may report an error relating to an overflow in the keyboard buffer. This tweak can be used to increase the size of the buffer, and avoid this problem.

Open your registry and find the key below.

Modify the value of 'KeyboardDataQueueSize' to equal the size of the queue buffer to use, .

Exit your registry and restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | KeyboardDataQueueSize | REG_DWORD | 0x00000064 (100) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Kbdclass\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Kbdclass\Parameters]
Name: KeyboardDataQueueSize
Type: REG_DWORD (DWORD Value)

Related Tweaks

  • Change the Mouse Buffer Size (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 13, 2002


Change the Mouse Buffer Size (Windows NT/2000/XP)

Change the Mouse Buffer Size (Windows NT/2000/XP)
Category: Home > Hardware > Mice and Keyboards

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Occasionally Windows may report an error relating to an overflow in the mouse buffer. This tweak can be used to increase the size of the buffer, and avoid this problem.

Open your registry and find the key below.

Modify the value of 'MouseDataQueueSize' to equal the size of the queue buffer to use, for example 64 hex (100 decimal).

Exit your registry and restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | MouseDataQueueSize | REG_DWORD | 0x00000064 (100) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Mouclass\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Mouclass\Parameters]
Name: MouseDataQueueSize
Type: REG_DWORD (DWORD Value)

Related Tweaks

  • Change the Keyboard Buffer Size (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 13, 2002


Remove the Ability to Right Click on the Start Button (All Windows)

Remove the Ability to Right Click on the Start Button (All Windows)
Category: Home > Security > Start Menu and Taskbar

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Usually when a user right clicks on the start button they are able to select Open, Explore or Find. Use this tweak to remove these options and secure your desktop.

Open your registry and find the key [HKEY_CLASSES_ROOT\Directory\shell] then rename it from 'shell' to 'shell.old'.

Do the same with the key [HKEY_CLASSES_ROOT\Folder\shell] and rename it to [...\shell.old].

Once complete the two original keys should now be called [HKEY_CLASSES_ROOT\Directory\shell.old] and [HKEY_CLASSES_ROOT\Folder\shell.old] respectively.

Now when you right click on the start button, you should no longer be given the option to Open, Explore or Find.

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 24, 2002


Use Smooth Scrolling in Telnet (All Windows)

Use Smooth Scrolling in Telnet (All Windows)
Category: Home > Windows > Accessories

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak enables the smooth scrolling function in Windows Telnet.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, named 'SmoothScroll' and set the value to '1' to enable or '0' to disable.

Restart Telnet for the change to take effect.

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Telnet]
Name: SmoothScroll
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Related Tweaks

  • Use Smooth Scrolling in Internet Explorer (All Windows)
  • Use Smooth Scrolling in Outlook Express (All Windows)
  • Control Whether Windows Performs Smooth Scrolling (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 27, 2002


Enable the GSM Audio Codec in Netmeeting 2.1

Enable the GSM Audio Codec in Netmeeting 2.1
Category: Home > Software > Netmeeting

By default Netmeeting does not include the GSM audio codec, this tweak enables the GSM codec to enhance interoperability with other GSM capable applications.

Download the netmeeting-gsm.reg registry file to a temporary directory.

Right click on the downloaded file, and choose 'Merge'.

Restart Netmeeting for the change to take effect.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Audio\ACMH323Encodings]
Name: GSM 6.10, 8 000 Hz; Mono_8000_0_13000
Type: REG_DWORD (DWORD Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 17, 2000


Display a Background Bitmap on Explorer Toolbars (All Windows)

Display a Background Bitmap on Explorer Toolbars (All Windows)
Category: Home > Software > Internet Explorer > Appearance

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak allows you to choose a a bitmap image to display as the background for the explorer toolbars.

Open your registry and find the key below.

Create a new string value, or modify the existing value, named 'BackBitmapShell' and set the value to the location & filename of the bitmap file you want to use.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | BackBitmapShell | REG_SZ | "c:\windows\soapbu~1.bmp" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Toolbar |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Toolbar]
Name: BackBitmapShell
Type: REG_SZ (String Value)

Related Tweaks

  • Add a Background Bitmap to the Internet Explorer Toolbar (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 2, 2002


Force Windows to Unload DLLs from Memory (All Windows)

Force Windows to Unload DLLs from Memory (All Windows)
Category: Home > Windows > System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows Explorer caches DLLs (Dynamic-Link Libraries) in memory for a period of time after the application using them has been closed. This can be an inefficient use of memory on low memory systems, and may cause problems or delays for programmers developing with Windows DLL files.

Open your registry and find the key [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer].

Create a new sub-key named 'AlwaysUnloadDLL' and set the default value to equal '1' to disable Windows caching the DLL in memory.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | "1" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Al... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\
AlwaysUnloadDLL]
Name: Default
Type: REG_SZ (String Value)
Value: (1 = enable)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 21, 2001


Disable Task Scheduler (Windows 95/98/Me)

Disable Task Scheduler (Windows 95/98/Me)
Category: Home > Windows > Accessories > Task Scheduler

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Task Scheduler is automatically installed in some versions of Windows, and also when you install Internet Explorer. This tweak will remove it from your system.

Open your registry and find the key below.

There should be a value named 'SchedulingAgent' which is set to equal 'mstask.exe', this is the entry that loads the Task Scheduler. Delete this value to stop the task manager loading again.

Note: You must also uninstall the Microsoft Windows Critical Update Notification from Add/Remove programs to completely remove Task Scheduler. See Microsoft support article Q195933 for more information.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SchedulingAgent | REG_SZ | mstask.exe | |
-
| HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RunServices |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\RunServices]
Name: SchedulingAgent
Type: REG_SZ (String Value)
Value: mstask.exe

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: July 7, 2002


Control Active Server Pages Browser Buffering (All Windows)

Control Active Server Pages Browser Buffering (All Windows)
Category: Home > Software

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether Active Server Pages (ASP) buffers output to a browser. If this setting is enabled then all output is collected before any is sent to the browser. This fixes some problems with incomplete and random data being sent to a browser using Internet Information Server (IIS).

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, named 'BufferingOn' and set the value to '1' to enable buffering.

Exit your registry editor, you should not need to restart any services for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | BufferingOn | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W3SVC\ASP\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W3SVC\ASP\
Parameters]
Name: BufferingOn
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = buffering enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 27, 2002


Change the Vertical Icon Spacing (Windows NT/2000)

Change the Vertical Icon Spacing (Windows NT/2000)
Category: Home > Windows > Appearance > Fonts and Icons

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting specifies the number of pixels that appear vertically between icons. Windows determines the default based on the icon title font and the display you are using.

Open your registry and find the key below.

Create a new string value, or modify the existing value, named 'IconVerticalSpacing' and set the value to equal the number of pixel to appears vertically between icons, for example '62'.

You may need to restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | IconVerticalSpacing | REG_SZ | "62" | |
-
| HKEY_CURRENT_USER\Control Panel\Desktop |
-

Settings:
User Key: [HKEY_CURRENT_USER\Control Panel\Desktop]
Name: IconVerticalSpacing
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 14, 2002


Configuring the Registry Size Limit (Windows NT/2000/XP)

Configuring the Registry Size Limit (Windows NT/2000/XP)
Category: Home > Windows > System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

The Registry Size Limit, or RSL, controls the total amount of space the may be consumed in paged pool memory and disk space by registry data. The RSL is a kind of "global quota" for registry space.

Open your registry and find the key below.

Create new DWORD value, or modify the existing value, named 'RegistrySizeLimit' and set the value to equal the desired RSL in bytes.

RegistrySizeLimit must have a type of REG_DWORD, and a data length of 4 bytes, or it is ignored. If you set the value RegistrySizeLimit to less than 4 megabytes (MB), it is forced up to 4 MB. If you set it to greater than about 80 percent of the size of paged pool, it is set down to 80 percent of the size of paged pool (it is assumed that paged pool is always more than 5 MB). If you set it to 0xffffffff the maximum size allowable (or 80 percent of paged pool, up to 102 MB) is set.

Shutdown and restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | RegistrySizeLimit | REG_DWORD | 0xffffffff (4294967295) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control]
Name: RegistrySizeLimit
Type: REG_DWORD (DWORD Value)
Value: (0xffffffff = maximum)

Related Tweaks

  • Modify the Paged and Non Paged Pool Memory Sizes (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 14, 2002


Load DOS Command Processor into High Memory (Windows 95/98/Me)

Load DOS Command Processor into High Memory (Windows 95/98/Me)
Category: Home > Tips and Tricks > Configuration Files > CONFIG.SYS

DOS is limited to 640kb low memory, as more device drivers are loaded that space is used up leaving less available memory for applications. This setting loads the DOS command processor into high memory, freeing some low memory for other applications.

Open the CONFIG.SYS file found in the root directory of your C: drive using Notepad or another text editor (not Microsoft Word or any word processor).

Add a new line with the text "DOS=HIGH,UMB", or modify the exiting line beginning with "DOS=" and change it to "DOS=HIGH,UMB" to load the DOS processor into high memory.

Make sure the following lines also exist at the top of the file, without them DOS can not be loaded into upper memory.

DEVICE=C:\WINDOWS\HIMEM.SYS
DEVICE=C:\WINDOWS\EMM386.EXE NOEMS

These changes will take place on the next reboot.

Settings:
Value: DOS=HIGH,UMB

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 17, 2000


Increase the Number Disk Buffers (Windows 3.1/DOS)

Increase the Number Disk Buffers (Windows 3.1/DOS)
Category: Home > Tips and Tricks > Configuration Files > CONFIG.SYS

This setting can be used to increase the number of disk buffers available to DOS.

Open the CONFIG.SYS file found in the root directory of your C: drive using Notepad or another text editor (not Microsoft Word or any word processor).

Add a new line with the text "buffers=40", or modify the exiting line beginning with "buffers=" and change it to "buffers=40" where '40' is the number of disk buffers. Alternatively use "buffershigh=40" to cause the reserved memory to be taken out of the upper memory area instead.

These changes will take place on the next reboot.

Settings:
Name: buffers or buffershigh

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 17, 2000


Load Device Drivers into Memory (Windows 3.1/DOS)

Load Device Drivers into Memory (Windows 3.1/DOS)
Category: Home > Tips and Tricks > Configuration Files > CONFIG.SYS

This setting is used to load specified device drivers into memory (or high memory).

Open the CONFIG.SYS file found in the root directory of your C: drive using Notepad or another text editor (not Microsoft Word or any word processor).

Add a new line with the text "device=xxxxxxx.sys" where 'xxxxxxx.sys' is the device to be loaded. Alternatively use "devicehigh=xxxxxxx.sys" command to cause the device to be loaded into the upper memory area instead.

These changes will take place on the next reboot.

Settings:
Name: device or devicehigh

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 17, 2000


Control the Number of File Control Blocks (FCBs) (Windows 3.1/DOS)

Control the Number of File Control Blocks (FCBs) (Windows 3.1/DOS)
Category: Home > Tips and Tricks > Configuration Files > CONFIG.SYS

This setting specifies the number of file control blocks (FCBs) that the operating system can have open at the same time.

Open the CONFIG.SYS file found in the root directory of your C: drive using Notepad or another text editor (not Microsoft Word or any word processor).

Add a new line with the text "fcbs=xx" where 'xx' is the number of fcbs to have open simultaneously. Alternatively use "fcbshigh=xx" command to cause the reserved memory to be taken out of the upper memory area instead.

These changes will take place on the next reboot.

Settings:
Name: fcbs or fcbshigh

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 17, 2000


Controls the Number of Simultaneous Files (Windows 3.1/DOS)

Controls the Number of Simultaneous Files (Windows 3.1/DOS)
Category: Home > Tips and Tricks > Configuration Files > CONFIG.SYS

This setting specifies the number of files that the operating system can access at one time.

Open the CONFIG.SYS file found in the root directory of your C: drive using Notepad or another text editor (not Microsoft Word or any word processor).

Add a new line with the text "files=xx" where 'xx' is the maximum number of files to have open simultaneously (for example files=60). Alternatively use "fileshigh=xx" command to cause the reserved memory to be taken out of the upper memory area instead.

These changes will take place on the next reboot.

Settings:
Name: files or fileshigh

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 17, 2000


Specify the Maximum Number of Drive Letters (Windows 3.1/DOS)

Specify the Maximum Number of Drive Letters (Windows 3.1/DOS)
Category: Home > Tips and Tricks > Configuration Files > CONFIG.SYS

This setting control the maximum number of drivers accessible by a drive letter.

Open the CONFIG.SYS file found in the root directory of your C: drive using Notepad or another text editor (not Microsoft Word or any word processor).

Add a new line with the text "lastdrive=?" where '?' is the last accessible driver letter (for example lastdrive=Z). Alternatively use "lastdrivehigh=?" command to cause the reserved memory to be taken out of the upper memory area instead.

These changes will take place on the next reboot.

Settings:
Name: lastdrive or lastdrivehigh

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 17, 2000


Control the Number of Data Stacks (Windows 3.1/DOS)

Control the Number of Data Stacks (Windows 3.1/DOS)
Category: Home > Tips and Tricks > Configuration Files > CONFIG.SYS

Support the dynamic use of data stacks to handle hardware interrupts.

Open the CONFIG.SYS file found in the root directory of your C: drive using Notepad or another text editor (not Microsoft Word or any word processor).

Add a new line with the text "stacks=xx" where 'xx' is the number of data stacks (for example stacks=9,256). Alternatively use "stackshigh=" command to cause the reserved memory to be taken out of the upper memory area instead.

These changes will take place on the next reboot.

Settings:
Name: stacks or stackshigh

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 17, 2000


Use Extended Memory (Windows 3.1/DOS)

Use Extended Memory (Windows 3.1/DOS)
Category: Home > Tips and Tricks > Configuration Files > CONFIG.SYS

Himem, an extended-memory manager, is a program that coordinates the use of your computer's extended memory, including the high memory area (HMA). It must be loaded before any application or device drivers can use extended memory.

Open the CONFIG.SYS file found in the root directory of your C: drive using Notepad or another text editor (not Microsoft Word or any word processor).

At the top of the file add a line with the text "device=c:\windows\himem.sys" where 'c:\windows' is the path to the himem.sys file.

These changes will take place on the next reboot.

Settings:
Value: device=himem.sys

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 17, 2000


Enable the Ability to Load Devices into Upper Memory (Windows 3.1/DOS)

Enable the Ability to Load Devices into Upper Memory (Windows 3.1/DOS)
Category: Home > Tips and Tricks > Configuration Files > CONFIG.SYS

Originally EMM386 was required to provide EMS memory, an alternate form of extended memory. Now with the sparse use of EMS, it's primary purpose is to provide support for loading real-mode device drivers in the upper memory area.

Open the CONFIG.SYS file found in the root directory of your C: drive using Notepad or another text editor (not Microsoft Word or any word processor).

At the top of the file, after the HIMEM device, add a line with the text "device=c:\windows\emm386.exe NOEMS" where 'c:\windows' is the path to the himem.sys file.

These changes will take place on the next reboot.

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 17, 2000


Load Drivers and Programs into High Memory (Windows 3.1/DOS)

Load Drivers and Programs into High Memory (Windows 3.1/DOS)
Category: Home > Tips and Tricks > Configuration Files > AUTOEXEC.BAT

Programs and device drivers loaded from the AUTOEXEC.BAT file are normally loaded straight into low memory. This change allows them to be loaded high.

Open the AUTOEXEC.BAT file found in the root directory of your C: drive using Notepad or another text editor (not Microsoft Word or any word processor).

In front of any lines loaded applications or drivers, for example MSCDEX.EXE, appended "LH" (for Load High), for example:

LH C:\WINDOWS\COMMAND\MSCDEX /D:MSCD001

These changes will take place on the next reboot.

Settings:
Name: lh

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 17, 2000


Remove Command Echoing (Windows 95/98/Me)

Remove Command Echoing (Windows 95/98/Me)
Category: Home > Tips and Tricks > Configuration Files > AUTOEXEC.BAT

Normally when commands are read and executed from the AUTOEXEC.BAT file, there are echoed back to the screen. This setting turns the echo off, which means only message text will be shown, and not the originating command.

Open the AUTOEXEC.BAT file found in the root directory of your C: drive using Notepad or another text editor (not Microsoft Word or any word processor).

At the top of the file add a new line equal to "@echo off", this will remove the command echo.

These changes will take place on the next reboot.

Settings:
Name: @echo off

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 17, 2000


Cable Modem and DSL Speed Tweak to Increase Performance (Windows NT)

Cable Modem and DSL Speed Tweak to Increase Performance (Windows NT)
Category: Home > Network > Internet and Remote Access

Use these settings with your Cable Modem or DSL broadband Internet connection, to boost network throughput performance with Windows NT.

Open your registry and find the key below.

Create the following DWORD values, as most of these values will not already exist you will need to create them by clicking on 'Edit -> New -> DWORD Value' and then set the value as shown below.

DefaultTTL = "80" hex (or 128 decimal)
Specifies the default time to live (TTL) for TCP/IP packets. The default is 32.

EnablePMTUBHDetect = "0"
Specifies whether the stack will attempt to detect Maximum Transmission Unit (MTU) routers that do not send back ICMP fragmentation-needed messages. The default is 0.

EnablePMTUDiscovery = "1"
Specifies whether the TCP/IP stack will attempt to perform path MTU discovery as specified in RFC 1191. The default is 1.

TcpWindowSize = "faf0" hex (or 64240 decimal)
Specifies the receive window size advertised by the TCP/IP stack.

Exit your registry and restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DefaultTTL | REG_DWORD | 0x00000080 (128) | |
| |  | EnablePMTUBHDetect | REG_DWORD | 0x00000000 (0) | |
| |  | EnablePMTUDiscovery | REG_DWORD | 0x00000001 (1) | |
| |  | TcpWindowSize | REG_DWORD | 0x0000faf0 (64240) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]
Type: REG_DWORD (DWORD Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 18, 2000


Enable DVD Features in Media Player (All Windows)

Enable DVD Features in Media Player (All Windows)
Category: Home > Software > Media Player

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allows you to use Microsoft Media Player to Play and Open DVDs.

Open your registry and find the key below.

Create a new string value called "EnableDVDUI" and set it to "yes" to enable DVD functionality.

Restart Media Player for the change to take effect.

Note: You must have a Windows compatible DVD drive installed in your computer for these features to work.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | EnableDVDUI | REG_SZ | "Yes" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\MediaPlayer\Player\Settings |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\MediaPlayer\Player\Settings]
Name: EnableDVDUI
Type: REG_SZ (String Value)
Value: Yes or No

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 3, 2002


Override the Default Broadcast Address (Windows 95/98/Me)

Override the Default Broadcast Address (Windows 95/98/Me)
Category: Home > Network > Protocols > TCP-IP

This setting overrides the default broadcast address that is derived from the IP address and subnet mask. Primarily the broadcast address is used for NetBIOS name queries.

Open your registry and find the key below.

Create a new DWORD value (or string for Windows 98), named "BroadcastAddress" and set it to the broadcast address in hexadecimal form.

Restart Windows for the change to take effect.

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: BroadcastAddress
Type: REG_DWORD (DWORD Value)
Value: broadcast address in hexadecimal

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 18, 2000


Specify the Number of Broadcast Name Resolution Attempts (Windows 95/98/Me)

Specify the Number of Broadcast Name Resolution Attempts (Windows 95/98/Me)
Category: Home > Network > Protocols

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls the number of attempts to resolve a NetBIOS name using a broadcast query.

Open your registry and find the key below.

Create a new string value (or DWORD for Windows 95), called "BcastNameQueryCount" and set it to equal the number of attempts.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | BcastNameQueryCount | REG_DWORD | 0x00000005 (5) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: BcastNameQueryCount
Type: REG_DWORD (DWORD Value)
Value: Number of Attempts (Default = 3)

Related Tweaks

  • Specify the NetBIOS Name Cache Timeout Period (Windows 95/98/Me)
  • Specify the Timeout Period for Broadcast Queries (Windows 95/98/Me)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 14, 2002


Specify the Timeout Period for Broadcast Queries (Windows 95/98/Me)

Specify the Timeout Period for Broadcast Queries (Windows 95/98/Me)
Category: Home > Network > Protocols

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allows you to specify the period of time the system will wait before timing out broadcast name queries.

Open your registry and find the key below.

Create a new string value (or DWORD for Windows 95) called "BcastQueryTimeout", and set it to equal the period of time in milliseconds (minimum 100).

Restart Windows for the change to take effect.

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: BcastQueryTimeout
Type: REG_DWORD (DWORD Value)
Value: Time in milliseconds (Default =750)

Related Tweaks

  • Specify the NetBIOS Name Cache Timeout Period (Windows 95/98/Me)
  • Specify the Number of Broadcast Name Resolution Attempts (Windows 95/98/Me)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 14, 2002


Control Windows Treatment of Priority TCP/IP Data (Windows 95/98/Me)

Control Windows Treatment of Priority TCP/IP Data (Windows 95/98/Me)
Category: Home > Network > Protocols > TCP-IP

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This value specifies how Windows should handle urgent data transfers, either in a same manner to some UNIX systems or as specified by RFC 1122.

Open your registry and find the key below.

Create a new string value (or DWORD for Windows 95) called "BSDUrgent" and set it to equal "0" to use the RFC 1122 method or "1" to use the default UNIX method.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | BSDUrgent | REG_DWORD | 1 | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: BSDUrgent
Type: REG_SZ (String Value)
Value: (0 = use RFC1122 method, 1 = default)

Related Tweaks

  • Control Windows Treatment of Priority TCP/IP Data (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 13, 2002


Specify the NetBIOS Name Cache Timeout Period (Windows 95/98/Me)

Specify the NetBIOS Name Cache Timeout Period (Windows 95/98/Me)
Category: Home > Network > Protocols

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting specifies the period that NetBIOS names are cached before requiring an additional name query.

Open your registry and find the key below.

Create a new string value (or DWORD for Windows 95) called "CacheTimeout" and set it to equal the number of milliseconds to cache NetBIOS names (minimum 60,000 - 1 minute).

Restart Windows for the change to take effect.

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: CacheTimeout
Type: REG_DWORD (DWORD Value)
Value: Time in milliseconds (Default =360,000)

Related Tweaks

  • Specify the Timeout Period for Broadcast Queries (Windows 95/98/Me)
  • Specify the Number of Broadcast Name Resolution Attempts (Windows 95/98/Me)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 14, 2002


Enable Dead Gateway Detection (Windows 95/98/Me)

Enable Dead Gateway Detection (Windows 95/98/Me)
Category: Home > Network > Protocols > TCP-IP

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting specifies whether Windows should automatically detect and use an alternate gateway in the event of a failed gateway.

Open your registry and find the key below.

Create a new string value (or DWORD for Windows 95) called "DeadGWDetect" and set it to equal "0" to disable dead gateway detection or "1" to enable it.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DeadGWDetect | REG_SZ | 1 | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: DeadGWDetect
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Related Tweaks

  • Enable Dead Gateway Detection (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 14, 2002


Specify the TCP/IP Receive Window Size (Windows 95/98/Me)

Specify the TCP/IP Receive Window Size (Windows 95/98/Me)
Category: Home > Network > Protocols > TCP-IP

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls the size of the TCP/IP receive Window. In general, larger receive windows work better with high-delay, high-bandwidth data.

For added efficiency, the receive window should also be an even multiple of the TCP Maximum Segment Size (MSS).

Open your registry and find the key below.

Create a new string value (or DWORD for Windows 95) called "DefaultRcvWindow" and set it to equal the required window size in bytes.

Restart Windows for the change to take effect.

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: DefaultRcvWindow
Type: REG_DWORD (DWORD Value)
Value: size in bytes (Default = 8192)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 12, 2002


Specify the Default TCP/IP Type of Service (TOS) (Windows 95/98/Me)

Specify the Default TCP/IP Type of Service (TOS) (Windows 95/98/Me)
Category: Home > Network > Protocols > TCP-IP

This setting specifies the default type of service (TOS) for IP packets generated by the TCP/IP stack. This can be used to manage quality of service (QOS) throughout a network.

Open your registry and find the key below.

Create a new DWORD value called "DefaultTOS" and set it to the 8 bit number represent the default TOS for IP packets.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | DefaultTOS | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: DefaultTOS
Type: REG_DWORD (DWORD Value)
Value: 8-bit number (Default = 0)

Related Tweaks

  • Specify the Default TCP/IP Time to Live (Windows 95/98/Me)
  • Specify the Default TCP/IP Type of Service (TOS) (Windows NT)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 19, 2000


Specify the Default TCP/IP Time to Live (Windows 95/98/Me)

Specify the Default TCP/IP Time to Live (Windows 95/98/Me)
Category: Home > Network > Protocols > TCP-IP

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting specifies the default time to live (TTL) value for IP packets generated by the Windows TCP/IP stack.

Open your registry and find the key below.

Create new string value named "DefaultTTL" and set it to equal the required TTL.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | DefaultTTL | REG_SZ | "32" | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: DefaultTTL
Type: REG_SZ (String Value)
Value: (Default = 32)

Related Tweaks

  • Specify the Default Time to Live for TCP/IP Packets (Windows NT/2000/XP)
  • Specify the Default TCP/IP Type of Service (TOS) (Windows 95/98/Me)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 24, 2002


Control the DNS Port Used for Lookups (Windows 95/98/Me)

Control the DNS Port Used for Lookups (Windows 95/98/Me)
Category: Home > Network > Clients

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls which port is used for DNS lookup requests. The default is port 53, but in some firewall situations the settings can be useful to specify an alternate port.

Open your registry and find the key below.

Create a new String value (or DWORD value for Windows 95) called "DnsServerPort" and set it to equal the required port address.

Restart Windows for the change to take effect.

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: DnsServerPort
Type: REG_SZ (String Value)
Value: Port Number (Default = 53)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2002


Enable WINS Proxy Agent (Windows 95/98/Me)

Enable WINS Proxy Agent (Windows 95/98/Me)
Category: Home > Network > Protocols > WINS

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether the current computer should act as a WINS proxy agent and forward WINS name queries.

Open your registry and find the key below.

Create a new string value (or DWORD value for Windows 95) called "EnableProxy" and set it to "1" to enable the proxy service.

Restart Windows for the change to take effect.

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: EnableProxy
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 14, 2002


Specify the Conformance Level for IP Multicast (Windows 95/98/Me)

Specify the Conformance Level for IP Multicast (Windows 95/98/Me)
Category: Home > Network > Protocols > TCP-IP

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This parameter determines to what extent the system supports IP multicasting and participates in the Internet Group Management Protocol, RFC 1112.

There are three levels or conformance:

  • Level 0: no support for IP multicasting
  • Level 1: support for sending but not receiving multicast IP datagrams
  • Level 2: full support for IP multicasting

Open your registry and find the key below.

Create a new string value (or DWORD value for Windows 95) called "IGMPLevel" and set it to either 0, 1 or 2 accord to the level required above.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | IGMPLevel | REG_DWORD | 0x00000002 (2) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: IGMPLevel
Type: REG_DWORD (DWORD Value)
Value: 0, 1 or 2 (Default = 2)

Related Tweaks

  • Specify the Conformance Level for IP Multicast (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 14, 2002


Control the WINS Refresh Period (Windows 95/98/Me)

Control the WINS Refresh Period (Windows 95/98/Me)
Category: Home > Network > Protocols > WINS

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting control the initial WINS refresh timeout value.

Open your registry and find the key below.

Create a new string value (or DWORD value for Windows 95) called "InitialRefreshT.O." and set it to equal the timeout in milliseconds. The minimum and default timeout is 960,000 milliseconds (approx 16 minutes) and the maximum is 4,294,967,295 milliseconds (approx 50 days).

Restart Windows for the change to take effect.

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: InitialRefreshT.O.
Type: REG_DWORD (DWORD Value)
Value: Time in milliseconds (Default =960,000)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 14, 2002


Control Keep Alive Parameters (Windows 95/98/Me)

Control Keep Alive Parameters (Windows 95/98/Me)
Category: Home > Network > Clients

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

These settings control how Windows manages connection keep alive transmissions. Including the timeout before keepalives are sent, the interval between keepalive transmissions and how often to send session keepalive packets on active sessions.

Open your registry and find the key below.

Create new DWORD value named "KeepAliveTime" and set it to equal the number of milliseconds to wait before sending keep alive packets (the default is 2 hours - 7,200,000 milliseconds).

Also create a new DWORD value (or string value for Windows 98) called "KeepAliveInterval" and set it to equal the time in milliseconds between retransmissions of keepalives, once the KeepAliveTime has expired (the default is 1 second - 1000 milliseconds).

Also create a new string value (or DWORD value for Windows 95) called "SessionKeepAlive" and set it to equal the time in seconds between keepalive packets on active sessions (the default is 3600 second - 1 hour).

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | KeepAliveTime | REG_SZ | 7200000 | |
| |  | KeepAliveInterval | REG_SZ | 1000 | |
| |  | SessionKeepAlive | REG_SZ | 3600 | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: KeepAliveTime, KeepAliveInterval, SessionKeepAlive
Type: REG_SZ (String Value)

Related Tweaks

  • Control Keep Alive Parameters (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 7, 2002


Control the Timeout for LMHOST Name Resolution (Windows 95/98/Me)

Control the Timeout for LMHOST Name Resolution (Windows 95/98/Me)
Category: Home > Network > Clients

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls the period of time the system will wait before timing out when seeking LMHOSTS for name resolution.

Open your registry and find the key below.

Create a new string value (or DWORD value for Windows 95) called "LmhostsTimeout" and set it to equal the timeout period in milliseconds, the minimum value is 1000 (1 second).

Restart Windows for the change to take effect.

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: LmhostsTimeout
Type: REG_SZ (String Value)
Value: Time in milliseconds (Default = 10,000)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2002


Change the Number of Simultaneous Connections (Windows 95/98/Me)

Change the Number of Simultaneous Connections (Windows 95/98/Me)
Category: Home > Network > Clients

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting specifies the maximum number of concurrent connections accepted.

Open your registry and find the key below.

Create a new string value named "MaxConnections" and set it to equal the number of connections, the default is 100.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | MaxConnections | REG_SZ | 100 | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: MaxConnections
Type: REG_SZ (String Value)
Value: 32-bit Number

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2002


Control the Number of TCP/IP Connection Attempts (Windows 95/98/Me)

Control the Number of TCP/IP Connection Attempts (Windows 95/98/Me)
Category: Home > Network > Protocols > TCP-IP

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls the number of TCP/IP connection attempts (SYN packets) to be transmitted before timing out.

Open your registry and find the key below.

Create a new string value named "MaxConnectRetries" and set it to the number or retires, the default is 3.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | MaxConnectRetries | REG_SZ | 5 | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: MaxConnectRetries
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 14, 2002


Control the Number of TCP/IP Transmission Retries (Windows 95/98/Me)

Control the Number of TCP/IP Transmission Retries (Windows 95/98/Me)
Category: Home > Network > Protocols > TCP-IP

This setting defines the number of transmission retries will be transmitted before the connection is aborted.

Open your registry and find the key below.

Create a new string value named "MaxDataRetries" and set it to equal the number of retries, the default is 5.

Restart Windows for the change to take effect.

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: MaxDataRetries
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 19, 2000


Specify the WINS Port Number (Windows 95/98/Me)

Specify the WINS Port Number (Windows 95/98/Me)
Category: Home > Network > Protocols > WINS

This setting allows you to specify an alternate port number to use with all WINS name queries and registration requests.

Open your registry and find the key below.

Create a new DWORD value (or string value for Windows 98) called "NameServerPort" and set it to equal the required port number, the default is 137.

Restart Windows for the change to take effect.

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: NameServerPort
Type: REG_DWORD (DWORD Value)
Value: (Default = 137)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 19, 2000


Control WINS Query Settings (Windows 95/98/Me)

Control WINS Query Settings (Windows 95/98/Me)
Category: Home > Network > Protocols > WINS

These settings control the WINS query parameters including the number of query attempts and query timeout.

Open your registry and find the key below.

Create a new string value called "NameSrvQueryCount" and set it to the number of query retries, the default is 3.

Create a DWORD value (or string value for Windows 98) called "NameSrvQueryTimeout" and set it to the number of milliseconds to wait before timing out a name server query, the default is 750.

Restart Windows for the changes to take effect.

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: NameSrvQueryCount, NameSrvQueryTimeout

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 19, 2000


Specify the Number of NetBIOS Entries to Store (Windows 95/98/Me)

Specify the Number of NetBIOS Entries to Store (Windows 95/98/Me)
Category: Home > Network > Protocols

These settings control the maximum number of NetBIOS entries to store in the name and session tables.

Open your registry and find the key below.

Create a new DWORD value (or string value for Windows 98) called "NameTableSize" and set it to equal the number of entries in the name table to a maximum of 255, the default is 17.

Create a new DWORD value (or string value for Windows 98) called "SessionTableSize" and set it to equal the number of entries in the session table to a maximum of 255, the default is 255.

Restart Windows for the change to take effect.

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: NameTableSize, SessionTableSize
Type: REG_DWORD (DWORD Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 19, 2000


Specify the NetBIOS Name Resolution Mode (Windows 95/98/Me)

Specify the NetBIOS Name Resolution Mode (Windows 95/98/Me)
Category: Home > Network > Protocols

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

There are several modes used in the resolution of NetBIOS, including WINS and LMHOSTS lookups and broadcast queries. This setting controls which mode is used.

Open your registry and find the key below.

Create a new string value called "NodeType" and set it to equal either 1, 2, 4, or 8 where 1 = b-node, 2 = p-node, 4 = m-node, and 8 = h-node. This value can also be specified using DHCP.

Restart Windows for the change to take effect.

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: NodeType
Type: REG_SZ (String Value)
Value: 1, 2, 4, or 8

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 14, 2002


Enable MTU Black Hole Detection (Windows 95/98/Me)

Enable MTU Black Hole Detection (Windows 95/98/Me)
Category: Home > Network > Protocols > TCP-IP

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Specifies whether the stack will attempt to detect Maximum Transmission Unit (MTU) routers that do not send back ICMP fragmentation-needed messages.

Open your registry and find the key below.

Create a new string value (or DWORD value for Windows 95) named "PMTUBlackHoleDetect" and set it to either "1" to enable detection or "0" to disable it.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | PMTUBlackHoleDetect | REG_SZ | 1 | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: PMTUBlackHoleDetect
Type: REG_SZ (String Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 13, 2002


Enable MTU Discovery (Windows 95/98/Me)

Enable MTU Discovery (Windows 95/98/Me)
Category: Home > Network > Protocols > TCP-IP

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting specifies whether the TCP/IP stack will attempt to perform path MTU discovery as specified in RFC 1191.

Open your registry and find the key below.

Create a new string value (or DWORD value for Windows 95) named "PMTUDiscovery" and set it to equal "1" to enable discovery or "0" to disable it.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | PMTUDiscovery | REG_SZ | 1 | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: PMTUDiscovery
Type: REG_SZ (String Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 13, 2002


Enable Random Adapter Responses (Windows 95/98/Me)

Enable Random Adapter Responses (Windows 95/98/Me)
Category: Home > Hardware > Network and Modems

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

For a computer with multiple network adapters, this setting specifies whether to respond with an IP address selected randomly from the range of addresses on the computer or whether to return the IP address of the adapter that the request came in upon.

Open your registry and find the key below.

Create a new DWORD value (or string value for Windows 98) named "RandomAdapter" and set it to "1" to enable random adapter addresses or "0" to disable them (the default).

Restart Windows for the change to take effect.

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: RandomAdapter
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 22, 2002


Control TCP/IP Routing Parameters (Windows 95/98/Me)

Control TCP/IP Routing Parameters (Windows 95/98/Me)
Category: Home > Network > Protocols > TCP-IP

These settings control IP routing features including the total amount of buffer space to allocate for routing packets and the maximum number of packets that can be routed simultaneously.

Open your registry and find the key below.

Create a DWORD value (or string value for Windows 98) called "RoutingBufSize" and set it equal the amount of buffer space to allocate for routing packets, the default is 73,216.

Create another DWORD value (or string value for Windows 98) called "RoutingPackets" and set it to equal the number of packets that can be routed simultaneously, the default is 50.

Restart Windows for the changes to take effect.

Note: These settings are ignored if EnableRouting = 0.

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: RoutingBufSize, RoutingPackets
Type: REG_DWORD (DWORD Value)
Value: 32-bit number

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 19, 2000


Specify Response Mode for Multi-Adapter Computers (Windows 95/98/Me)

Specify Response Mode for Multi-Adapter Computers (Windows 95/98/Me)
Category: Home > Network > Protocols > WINS

For a computer with multiple network adapters, this setting specifies whether to send all IP addresses on a name query request from WINS.

Open your registry and find the key below.

Create a new DWORD value (or string value for Windows 98) called "SingleResponse" and set it to equal "1" to send only one address is a name response or "0" to send all addresses.

Restart Windows for the change to take effect.

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: SingleResponse
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 19, 2000


Control RFC 1323 Time Stamp and Window Scaling Options (Windows 95/98/Me)

Control RFC 1323 Time Stamp and Window Scaling Options (Windows 95/98/Me)
Category: Home > Network > Protocols > TCP-IP

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls RFC 1323 time stamps and window scaling options for TCP/IP packets.

This feature has four modes of operation:

  • 0 = disable RFC 1323 options
  • 1 = window scale enabled only
  • 2 = time stamps enabled only
  • 3 = both options enabled
Open your registry and find the key below.

Create a new DWORD value named "Tcp1323Opts" and set it to equal 0, 1, 2 or 3 depending on the required mode listed above.

Restart Windows for the change to take effect.

Note: Some versions of Windows 95 and 98 may require a fix from Microsoft for this option to work. See Microsoft Support article Q239705.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Tcp1323Opts | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: Tcp1323Opts
Type: REG_DWORD (DWORD Value)
Value: 0, 1, 2 or 3

Related Tweaks

  • Control RFC 1323 Time Stamp and Window Scaling (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 13, 2002


Control the Internet Explorer Script Debugger (All Windows)

Control the Internet Explorer Script Debugger (All Windows)
Category: Home > Software > Internet Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When an Internet Explorer detects an error on a page it has the ability to launch a script debugger to diagnose the problem. This setting controls the use of the Internet Explorer script debugging functions.

Open your registry and find the key below.

Create a new string value, or modify the existing value, named "Disable Script Debugger" and set it to either "yes" to disable the debugger or "no" to enable it.

Restart Internet Explorer for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Disable Script Debugger | REG_SZ | "yes" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
Name: Disable Script Debugger
Type: REG_SZ (String Value)
Value: yes or no

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2002


Disable the Norton AntiVirus Splash Screen (All Windows)

Disable the Norton AntiVirus Splash Screen (All Windows)
Category: Home > Software

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting will stop the Norton AntiVirus Scanner startup logo from being shown.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, named "DisableSplashScreen" and set it to equal "1" to disable the splash screen.

The next time Norton AV is run the splash screen should not be display.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\Norton AntiVirus\Clinic]
Name: DisableSplashScreen
Type: REG_DWORD (DWORD Value)
Value: (0 = enable splash, 1 = disabled splash)

Related Tweaks

  • Disable the Norton Utilities Splash Screen (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 27, 2002


Change the IRP Stack Size (Windows NT)

Change the IRP Stack Size (Windows NT)
Category: Home > Network

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When you access shares on a computer running Windows NT Server from a Windows NT client and the IRPstackSize parameter is set too low on the server, you may receive the following error message: "Not enough server storage is available to process this command." This tweak should resolve the problem.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, named "IRPstackSize" and set it to equal the required stack size between 1 and 12, the default is 4.

Restart Windows for the change to take effect.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\
Parameters]
Name: IRPstackSize
Type: REG_DWORD (DWORD Value)
Value: 1 - 12 (default = 4)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 27, 2002


Configure Symantec Live Update to Use Passive FTP (All Windows)

Configure Symantec Live Update to Use Passive FTP (All Windows)
Category: Home > Software

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Norton LiveUpdate 1.3 and higher defaults to using active FTP. This tweak allows you to configure it to use passive FTP instead.

Open your registry and find the key below.

Create a new DWORD value named "UsePassiveFtpMode" and set it to equal "1" to enable passive FTP mode.

Restart Live Update for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | UsePassiveFtpMode | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\LiveUpdate\Preferences |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\LiveUpdate\Preferences]
Name: UsePassiveFtpMode
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 27, 2002


Disable User Profiles (Windows 95/98/Me)

Disable User Profiles (Windows 95/98/Me)
Category: Home > Security

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting can be used to disable the use of user profiles.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, named "UserProfiles" and set it to equal "0" to disable user profiles.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | UserProfiles | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\Network\Logon |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\Network\Logon]
Name: UserProfiles
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 21, 2002


Disable the Norton Utilities Splash Screen (All Windows)

Disable the Norton Utilities Splash Screen (All Windows)
Category: Home > Software

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting will disable the Norton Utilities splash screen from being shown whenever the applications are run.

Open your registry and find the key below.

Create new string value called "DisableSplashScreen" and set it to "1" to disable the splash screen.

Note, for Norton Utilities 5 the value is located in [HKEY_CURRENT_USER\SOFTWARE\Symantec\Norton Utilities]

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DisableSplashScreen | REG_SZ | "1" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\Norton Utilities |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Symantec\Norton Utilities]
Name: DisableSplashScreen
Type: REG_SZ (String Value)
Value: (0 = enable splash, 1 = disabled splash)

Related Tweaks

  • Disable the Norton AntiVirus Splash Screen (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 27, 2002


Control the Office Assistants (All Windows)

Control the Office Assistants (All Windows)
Category: Home > Software > Microsoft Office

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

These settings control the features and behavior of the Assistants in Office 97, 2000 and XP.

Office XP
Open your registry and find the key:
[HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Common\Assistant].

Office 2000
Open your registry and find the key:
[HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Common\Assistant].

Office 97
Open your registry and find the key:
[HKEY_CURRENT_USER\Software\Microsoft\Office\8.0\Common\Assistant].

Create new DWORD values, or modify the existing values, according to the list below.

  • AsstAssistWithWizards - Should the assistants help with Office wizards.
  • AsstAssistWithHelp - Should the assistants assist with help.
  • AsstAssistWithAlerts - Should the assistants be opened for Office alerts.
  • AsstGuessHelp - Should the assistants guess which help topics are shown.
  • AsstKeyboardShortcutTips - Specifies if tips about keyboard shortcuts should be shown.
  • AsstFeatureTips - Specifies if tips about using features more effectively should be shown.
  • AsstMouseTips - Specifies if tips about using the mouse more effectively should be shown.
  • AsstMoveWhenInTheWay - Should the assistants move when in the way.
  • AsstOnlyHighPriorityTips - Specifies if only high priority tips should be shown.
  • AsstSearchInProgram - Specifies if the assistants can search for product help while in programming mode.
  • AsstShowTipOfDay - Shows the tip of the day at startup.
  • AsstSounds - Specifies whether the assistants can makes sounds.
  • AsstTipTimeout - Specifies the number of seconds before tip bulb is brought down.
  • AsstTop - Specifies top position of the window.
  • AsstLeft - Specifies left position of the window.

Restart any office applications for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AsstAssistWithWizards | REG_DWORD | 0x00000001 (1) | |
| |  | AsstAssistWithHelp | REG_DWORD | 0x00000001 (1) | |
| |  | AsstAssistWithAlerts | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Office\[version]\Common\Assistant |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Office\[version]\Common\Assistant]
Type: REG_DWORD (DWORD Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 13, 2002


Enable Four Digit Year in Microsoft Excel 2000 (All Windows)

Enable Four Digit Year in Microsoft Excel 2000 (All Windows)
Category: Home > Software > Microsoft Office

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When Excel formats a date, it uses one of several default formats, the most common is the system short date (yy). Therefore when a user types a 4-digit year (yyyy) date in Excel, it may be displayed in a 2-digit year (yy) format. This tweak changes to default the 4-digit format.

Open your registry and find the key below.

Create a new DWORD value named "EnableFourDigitYearDisplay" and set it to equal "1" to enable 4-digit dates.

Restart Excel for the change to take effect.

Settings:
User Key: [HKEY_CURRENT_USER\Software\ Microsoft\Office\9.0\Excel\Options]
Name: EnableFourDigitYearDisplay
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 14, 2002


Show File and Folder Names Using the Correct Case (Windows 95/98/Me/2000/XP)

Show File and Folder Names Using the Correct Case (Windows 95/98/Me/2000/XP)
Category: Home > Windows > File System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Some versions of Windows will attempt to adjust the capitalization of files and folders that are in all uppercase to make them more visually pleasing. For example, if you create a folder named "C:\ALLINCAPS" Windows will actually display it as "C:\Allincaps". This feature can be disabled using this tweak.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, called "DontPrettyPath" and set it to equal "1" to display the file using their original capitalization or "0" to adjust the caps.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DontPrettyPath | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Adv... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
Advanced]
Name: DontPrettyPath
Type: REG_DWORD (DWORD Value)
Value: (0 = adjust caps, 1 = show caps)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 12, 2002


Launch Folder Windows in a Separate Process (All Windows)

Launch Folder Windows in a Separate Process (All Windows)
Category: Home > Windows > Windows Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether each folder window is launched as a separate explorer task. The benefit of this method is that if one window has an error and crashes the others should be not be affected. The disadvantage is that it takes more system resources for each folder.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, named "SeparateProcess" and set it to "0" to disable separate processes or "1" to enable them.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SeparateProcess | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Adv... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
Advanced]
Name: SeparateProcess
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Related Tweaks

  • Launch Browser Windows in a Separate Process (All Windows)
  • Launch Windows Desktop in a Separate Process (Windows 98/Me/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: July 24, 2002


Show Compressed Files in an Alternate Color (Windows NT/2000/XP)

Show Compressed Files in an Alternate Color (Windows NT/2000/XP)
Category: Home > Windows > Appearance

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether compressed files and folders are shown in explorer using a different color to make them easily distinguishable.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, named "ShowCompColor" and set it to equal "1" to enable the use of alternate colors or "0" to use the default colors.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ShowCompColor | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Adv... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
Advanced]
Name: ShowCompColor
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Related Tweaks

  • Change the Color of Compressed Files and Folders (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 5, 2002


Change the Color of Active File and Folder Links (All Windows)

Change the Color of Active File and Folder Links (All Windows)
Category: Home > Windows > Appearance

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls the link color of the active files and folders when using the web view (single-click) display method.

Open your registry and find the key below.

Create a new string value, or modify the existing value, named "HotTrackingColor" and set it to equal an RGB color value. For example red is "255 0 0" and the default blue is "0 0 255".

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | HotTrackingColor | REG_SZ | "0 0 255" | |
-
| HKEY_CURRENT_USER\Control Panel\Colors |
-

Settings:
User Key: [HKEY_CURRENT_USER\Control Panel\Colors]
Name: HotTrackingColor
Type: REG_SZ (String Value)
Value: Color in RGB

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 16, 2002


Change the Auto Complete Mode (All Windows)

Change the Auto Complete Mode (All Windows)
Category: Home > Software > Internet Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether the automatic text completion (AutoComplete) feature of Windows Explorer appends the suggested text to the words as you are typing as well as showing a drop-down list of available values.

Open your registry and find the key below.

Create a new string value, or modify the existing value, named "Append Completion" and set it to "yes" to append the suggested text as you are typing or "no" to only show a drop-down list.

Restart Windows for the change to take effect.

Note: This setting also changes the auto complete functionality of Internet Explorer.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Append Completion | REG_SZ | "Yes" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Aut... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
AutoComplete]
Name: Append Completion
Type: REG_SZ (String Value)
Value: yes or no

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 12, 2002


Use an Alternate Source Viewer with Internet Explorer (All Windows)

Use an Alternate Source Viewer with Internet Explorer (All Windows)
Category: Home > Software > Internet Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

By default when you use the View Source feature of Internet Explorer it launches Windows notepad as the text editor. This tweak lets you choose which editor to use.

Open your registry and create the key below if it does not already exist.

Set the (Default) value to equal the full path and filename of the required text editor.

Restart Internet Explorer for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | "c:\windows\notepad.exe" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\View Source Edit... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\
View Source Editor\Editor Name]
Name: (Default)
Type: REG_SZ (String Value)
Value: Path and Filename of Editor

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2002


Enable Print Job Notification Messages (Windows NT/2000/XP)

Enable Print Job Notification Messages (Windows NT/2000/XP)
Category: Home > Hardware > Printers and Plotters

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

By default Windows notifies a user with a popup message that their print job has been completed on the printer. This setting controls that behavior.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, named "NetPopup" and set it to equal "0" to disable notification or "1" to enable it.

Restart the printer spooler service or restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NetPopup | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Providers |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Providers]
Name: NetPopup
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Related Tweaks

  • Specify Where to Display Printer Notifications (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 26, 2002


Force the Use of Automatic Logon (Windows 2000/XP)

Force the Use of Automatic Logon (Windows 2000/XP)
Category: Home > Security > Login and Authentication

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Normally when a Windows machine is configured to automatically logon to a specified account users can bypass this and enter alternate account information. This tweak forces the machine to auto logon and to ignore any bypass attempts.

Open your registry and find the key below.

Create a new string value called "ForceAutoLogon" and set it to equal "1" to force automatic logons or "0" to allow alternate users.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ForceAutoLogon | REG_SZ | "1" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: ForceAutoLogon
Type: REG_SZ (String Value)
Value: (0 = disabled, 1 = enabled)

Related Tweaks

  • Automatic Logon to Windows NT, 2000 and XP (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 25, 2002


Enable UDMA66 Mode on Intel Chipsets (Windows 2000/XP)

Enable UDMA66 Mode on Intel Chipsets (Windows 2000/XP)
Category: Home > Hardware > Processor and Motherboard

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

If you have a computer with an Intel chipset that supports UDMA66, you will still find that UDMA66 mode is disabled by default on Windows 2000 computers. This tweak allows you to enable or disable it.

Open your registry and find the key below.

Create a new DWORD value called "EnableUDMA66" and set it to "1" to enable UDMA66 or "0" to disable it.

Restart Windows for the change to take effect.

Note: Before you enable UDMA66 mode make sure that the device supports UDMA66 mode and use an 80-pin IDE cable with the proper pin cut.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | EnableUDMA66 | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class\{4D36E96A-E325... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class\
{4D36E96A-E325-11CE-BFC1-08002BE10318}\0000]
Name: EnableUDMA66
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 27, 2002


Enable Font Smoothing (All Windows)

Enable Font Smoothing (All Windows)
Category: Home > Windows > Appearance > Fonts and Icons

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether fonts are anti-aliased to appear smoother when displayed within Windows.

Open your registry and find the key below.

Create a new string value, or modify the existing value, called "FontSmoothing" and set it to "2" to enable font smoothing or "0" to disable it.

Log off or restart Windows for the change to take effect.

Note: Font smoothing is only effective when using high color video modes.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | FontSmoothing | REG_SZ | "2" | |
-
| HKEY_CURRENT_USER\Control Panel\Desktop |
-

Settings:
User Key: [HKEY_CURRENT_USER\Control Panel\Desktop]
Name: FontSmoothing
Type: REG_SZ (String Value)
Value: (0 = disabled, 2 = enabled)

Related Tweaks

  • Control the Font Smoothing Mode (Windows XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: November 1, 2000


Configure CoolSwitch Application Swapping (All Windows)

Configure CoolSwitch Application Swapping (All Windows)
Category: Home > Windows

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

CoolSwitch is a feature available within Windows to quickly switch between tasks and programs by using the Alt + TAB keys.

Open your registry and find the key below.

Modify the value named "CoolSwitch" and set it to "0" to disable task switching or "1" to enable it.

To change the size of the CoolSwitch popup modify the values named "CoolSwitchColumns" and "CoolSwitchRows".

Logoff or restart Windows for the changes to take effect.

Note: If you don't want to switch applications you can cancel a CoolSwitch at any time by pressing Escape.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | CoolSwitch | REG_SZ | 1 | |
| |  | CoolSwitchColumns | REG_SZ | 7 | |
-
| HKEY_CURRENT_USER\Control Panel\Desktop |
-

Settings:
User Key: [HKEY_CURRENT_USER\Control Panel\Desktop]
Name: CoolSwitch, CoolSwitchColumns, CoolSwitchRows
Type: REG_SZ (String Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 11, 2002


Check for Internet Explorer Updates (All Windows)

Check for Internet Explorer Updates (All Windows)
Category: Home > Software > Internet Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Internet Explorer 5 and higher has the ability to automatically check for software updates. This tweak controls that feature.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, called "NoUpdateCheck" and set it to "1" to disable the update check or "0" to enable it.

Restart Internet Explorer for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoUpdateCheck | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
Name: NoUpdateCheck
Type: REG_DWORD (DWORD Value)
Value: (0 = enable checks, 1 = disable checks)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2002


Disable Account Changes in Outlook Express (All Windows)

Disable Account Changes in Outlook Express (All Windows)
Category: Home > Software > Outlook Express

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting disables the ability for users to create or modify any mail, news or directory accounts in Outlook Express.

Open your registry and find the key below.

Create new DWORD value called "No Modify Accts" and set it to "1" to enable the restriction or "0" to allow users to modify accounts.

Restart Outlook Express for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | No Modify Accts | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Outlook Express |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Outlook Express]
Name: No Modify Accts
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 12, 2002


Repair Dialog Boxes Sorting (All Windows)

Repair Dialog Boxes Sorting (All Windows)
Category: Home > Windows > Troubleshooting > Repair

When viewing files and folders from a Windows dialog box the items may be sorted incorrectly. For example, files may be listed before folders, items may be sorted in descending order, and so on. This tweak should resolve this problem.

This behavior can occur if the sort order in Windows Explorer is changed from the default order.

To resolve this behavior, and reset the default sort order:

  1. Right-click Start, click Explore, and then click drive C.
  2. On the View menu, click Details.
  3. Click the Name column to sort items by name, press and hold down the CTRL key, and then quit Windows Explorer by clicking Close in the upper-right corner of the screen.
  4. Release the CTRL key.
  5. Restart your computer.

Note: You must perform these steps exactly as they are listed. For example, do not quit Windows Explorer by clicking Exit on the File menu.

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 9, 2002


Reverse the Mouse Buttons (All Windows)

Reverse the Mouse Buttons (All Windows)
Category: Home > Hardware > Mice and Keyboards

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

By default the left mouse button is the primary mouse button and the right is the secondary. This tweak lets you swap those buttons around to make the right the primary, which may be useful for left handed users.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'SwapMouseButtons' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SwapMouseButtons | REG_SZ | "1" | |
-
| HKEY_CURRENT_USER\Control Panel\Mouse |
-

Settings:
User Key: [HKEY_CURRENT_USER\Control Panel\Mouse]
Name: SwapMouseButtons
Type: REG_SZ (String Value)
Value: (0 for normal, 1 = swap buttons)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 21, 2002


Disable the Ability to Remotely Shutdown the Computer Browser Service (Windows NT/2000/XP)

Disable the Ability to Remotely Shutdown the Computer Browser Service (Windows NT/2000/XP)
Category: Home > Security > Network

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

It is possible for a malicious user to shut down a computer browser, or all computer browsers, on the same subnet. If all of the computers on the same subnet are shut down, they can then declare their own computer the new master browser.

Firstly download and install the patch below for your operating system:

  • Windows 2000
  • Windows NT 4.0 (Intel)
  • Windows NT 4.0 (Alpha)

Open you registry and find the key below.

Create a new DWORD value called "RefuseReset" and set it to "1" to ignore the ResetBrowser frames request.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | RefuseReset | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MrxSmb\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MrxSmb\Parameters]
Name: RefuseReset
Type: REG_DWORD (DWORD Value)
Value: (0 = normal, 1 = refuse reset)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 3, 2002


Disable Windows File Protection (Windows 2000/XP)

Disable Windows File Protection (Windows 2000/XP)
Category: Home > Windows > System > Windows File Checker

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows 2000 and XP include a feature called Windows File Protection (WFP), part of the System File Checker, which is intended to avoid some of the common DLL consistency issues. This feature may also block valid attempts to change system files and it can therefore be disabled using this tweak.

Open your registry and find the key below.

Change the value of "SFCDisable" to equal "ffffff9d" to disable WFS or "0" to enable it. The other valid hexadecimal values are:

  • 1 - disabled, prompt at boot to re-enable
  • 2 - disabled at next boot only, no prompt to re-enable
  • 4 - enabled, with popups disabled
  • ffffff9d - for completely disabled

    Restart Windows for the change to take effect.

    Additional Steps for Windows 2000 Service Pack 2 and Windows XP
    This setting is disabled in Windows 2000 SP2 and Windows XP, and needs to re-enabled using a hex editor and changing SFC.DLL (or SFC_OS.DLL for Windows XP) following these instructions:

    Windows 2000 SP2

    1. Make a backup the SFC.DLL in the C:\WINNT\SYSTEM32 directory.
    2. Make an additional copy of SFC.DLL called SFC1.DLL and open it in a hex editor.
    3. At offset 00006211 (6211h) you should find the values "8B" and "C6". Do not continue if you are unable to find these values.
    4. Change the values "8B C6" to read "90 90" and save the changes.
    5. Run these commands to update the system files:
      copy c:\winnt\system32\sfc1.dll c:\winnt\system32\sfc.dll /y
copy c:\winnt\system32\sfc1.dll c:\winnt\system32\dllcache\sfc.dll /y
    6. If you are prompted to insert the Windows CD, click Cancel.
    7. Restart Windows for the change to take effect.

    Windows XP

    1. Make a backup the SFC_OS.DLL in the C:\WINDOWS\SYSTEM32 directory.
    2. Make an additional copy of SFC_OS.DLL called SFC_OS1.DLL and open it in a hex editor.
    3. Windows XP (no Service Pack)
      At offset 0000E2B8 (0E2B8h) you should find the values "8B" and "C6".
      Windows XP (Service Pack 1)
      At offset 0000E3BB (0E3BBh) you should find the values "8B" and "C6".
    4. Do not continue if you are unable to find these values.
    5. Change the values "8B C6" to read "90 90" and save the changes.
    6. Run these commands to update the system files:
      copy c:\windows\system32\sfc_os1.dll c:\windows\system32\sfc_os.dll /y
copy c:\windows\system32\sfc_os1.dll c:\windows\system32\dllcache\sfc_os.dll /y
    7. If you are prompted to insert the Windows CD, click Cancel.
    8. Restart Windows for the change to take effect.

    Once these files have been updated apply the registry setting above.

    Note: You must manually modify the operating system files using a hex editor to allow this tweak to disable SFC on Windows 2000 (SP1+) or Windows XP.

    Registry Editor Example
    | Name Type Data |
    | (Default) REG_SZ (value not set) |
    | SFCDisable REG_DWORD 0xffffff9d (4294967197) |
    -
    | HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
    -

    Settings:
    System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
    Name: SFCDisable
    Type: REG_DWORD (DWORD Value)
    Value: 0 = enabled (default), ffffff9d = disabled

    Related Tweaks

    • Change the Size of the Windows File Protection Cache (Windows 2000/XP)
    • Manage Windows File Protection Scans (Windows 2000/XP)
    • Specify the Directory to Store Cached SFC Files (Windows 2000/XP)
    • Display SFC Progress Meter (Windows 2000/XP)
    • Windows File Checker Command-line Options (Windows 2000)

    Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

    Last Modified: January 6, 2003

    • Return to Index Copyright © 1998-2003. All Rights Reserved. License


Change the Start Button Text (All Windows)

Change the Start Button Text (All Windows)
Category: Home > Tips and Tricks > Customization

Would you like to change the Start button to say something else, perhaps your name, company or any other 5 or less letter word? This article explains the procedure to manually modify the text of the Windows Start button.

Manually changing the Start button requires the use of a binary file editor (or hex editor) to alter a critical Windows system file, it is therefore not recommended for inexperienced users. This method has been successfully tested on Windows 95, 98, ME, 2000 and XP and therefore should be quite safe, although we do not accept any responsibility for system problems or data loss.

As mentioned before you will need to have a hex editor installed, there are many different products available and if you don't have one already a quick search of a shareware site should provide many choices, for this tweak we only require basic features.

  1. The file that needs to be changed is Windows Explorer, and it is essential to make a backup before you modify anything. "Explorer.exe" can be found in the Windows directory, usually C:\WINDOWS for Windows 95, 98, Me & XP and C:\WINNT for Windows NT/2000. Make a copy of "Explorer.exe" and place it into another directory, C:\BACKUP might be a good choice.

  2. Make another copy of the original "Explorer.exe" and name it "Explorer1.exe", then open "Explorer1.exe" in your hex editor.

  3. You now need to find the word "Start", although there are many entries for "Start" in the file only one is used for to label the Start button. Use the search function in the hex editor to find all the strings equal to "S t a r t" which is represented as "53 00 74 00 61 00 72 00 74" in hex values. As there are many different "Start" strings keep searching until you find one located just before this text "There was an internal error and one of the windows you were using has been closed.". Below is a list of offsets to help you locate the correct text.

    • Windows 98
      Offset: 0x00028D6E - 0x00028D76
    • Windows NT4
      Offset: 0x00028BEE - 0x00028BF6
    • Windows ME
      Offset: 0x00033DDE - 0x00033DE6
    • Windows 2000
      Offset: 0x0003860E - 0x00038616
    • Windows XP (Enhanced Start Menu)
      Offset: 0x000412B6 - 0x000412BE
    • Windows XP (Classic Start Menu)
      Offset: 0x0004158A - 0x00041592
    • Windows XP SP1 (Enhanced Start Menu)
      Offset: 0x0004208E - 0x00042096
    • Windows XP SP1 (Classic Start Menu)
      Offset: 0x0004259A - 0x000425A2

    The result should look similar to the image below, depending on the display from your hex editor.

    Hex editor display of Start text

  4. Once you have located the string, you can then replace the letters in "Start" with five other characters. You must use exactly five characters, if the word you want to use is less, replace the remaining characters with the space key. In this example we have replaced "Start" with "Guide", alternatively a three-letter word would look like "A B C" (note the spaces). Once you have changed the letters the result should look similar to the image below.

    Hex editor display of replacement text

  5. Now save the modified "Explorer1.exe" in the Windows directory, and confirm that you now have the two Explorer files in the Windows directory, they both should be the same file size but have different modified dates.

  6. The next step is different depending on your operating system. Only do the step required for your version.

    • Windows 95, 98 & ME
      Exit to DOS (or use a boot disk for Windows ME) and at the command prompt change to the Windows directory and rename "explorer.exe" to "explorer.old". Then copy the newly modified Explorer "explorer1.exe" to "explorer.exe". Do a directory listing and confirm that "explorer.exe" has the most recent modified date and time. Restart the computer and Windows should reload along with the new Start button text.

    • Windows NT
      First close any open applications and open a new Command Prompt window, then switch back to the GUI and open the Task Manager. Find the "explorer.exe" process and end it, you should now be left with only the command prompt and task manager. Switch back to the command prompt and change to the Windows directory, rename "explorer.exe" to "explorer.old", and copy the newly modified Explorer "explorer1.exe" to "explorer.exe". Do a directory listing and confirm that "explorer.exe" has the most recent modified date and time. Switch back to Task Manager and launch a "New Task" called "explorer.exe" this should reload the shell along with your modified "Start" button.

    • Windows 2000 and XP
      Open your registry editor and find the key [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]. Find the value named "Shell" and change it to equal the filename of the new explorer "explorer1.exe". Exit your registry editor and restart Windows for the change to take effect. To reverse the change, modify the value of "Shell" and set it back to "explorer.exe".

    Registry Editor Example
    | Name Type Data |
    | (Default) REG_SZ (value not set) |
    | Shell REG_SZ explorer1.exe |
    -
    | HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
    -

  7. If everything has gone successfully you will now have a new Start button, and also hopefully learnt something about the Explorer file structure. If you do have problems replace the faulty Explorer with the backup made during the first step.

    Windows start menu

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 13, 2002


Internet Explorer Help Menu Restrictions (All Windows)

Internet Explorer Help Menu Restrictions (All Windows)
Category: Home > Software > Internet Explorer > Security

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

The menu items with the Internet Explorer "Help" menu can be individually removed or the menu disabled completely using this tweak.

Open your registry and find the key below.

Create new DWORD values, or modify the existing values, from the list below setting them to equal "1" to enable the restriction or "0" to disable the restriction.

  • NoHelpMenu - Disable the entire help menu
  • NoHelpItemNetscapeHelp - Remove the "For Netscape Users" menu item
  • NoHelpItemSendFeedback - Remove the "Send Feedback" menu item
  • NoHelpItemTipOfTheDay - Remove the "Tip of the Day" menu item
  • NoHelpItemTutorial - Remove the "Tour" (Tutorial) menu item
Restart Internet Explorer for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoHelpMenu | REG_DWORD | 0x00000001 (1) | |
| |  | NoHelpItemNetscapeHelp | REG_DWORD | 0x00000001 (1) | |
| |  | NoHelpItemSendFeedback | REG_DWORD | 0x00000001 (1) | |
| |  | NoHelpItemTipOfTheDay | REG_DWORD | 0x00000001 (1) | |
| |  | NoHelpItemTutorial | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Restrict... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\
Restrictions]
System Key: [HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Internet Explorer\
Restrictions]
Type: REG_DWORD (DWORD Value)
Value: (0 = restriction disabled, 1 = restriction enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 3, 2002


Manage Attachment Security in Outlook (All Windows)

Manage Attachment Security in Outlook (All Windows)
Category: Home > Software > Microsoft Office > Outlook

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

New security measures that improve the dialog box warnings for attachments were included in Microsoft Outlook beginning with Outlook 2000 (SR-1). The file extensions that trigger the more secure warnings can be managed through the registry.

Open your registry and find the key below, if the 'Security' sub-key does not already exist then create it.

Create two new string values, or modify the existing values, called "AddWarningFileTypes" and "RemoveWarningFileTypes".

To include additional file extensions to receive the warning, add the extensions, seperated by a semicolon, to the "AddWarningFileTypes" value. r example, to add Word and Excel documents to this list you would set the value to equal "DOC;XLS".

Removing warnings is the same but in reverse, for example, to remove the warning for registry files and VBScript files your would set the "RemoveWarningFileTypes" value to equal "REG;VBS".

Restart Outlook for the changes to take effect.

Note: Do not include the leading period (".") in the front of the extension, only include the alphanumeric characters.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AddWarningFileTypes | REG_SZ | "DOC;XLS" | |
| |  | RemoveWarningFileTypes | REG_SZ | "REG;VBS" | |
-
| HKEY_LOCAL_MACHINE\Software\Microsoft\Office\9.0\Outlook\Security |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Office\9.0\Outlook\Security]
Name: AddWarningFileTypes, RemoveWarningFileTypes
Type: REG_SZ (String Value)
Value: File Extensions (Seperated a Semicolon)

Related Tweaks

  • Modify the Outlook 2002 and Office XP Attachment Restrictions (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 2, 2003


Disable the "Log on using dial-up connection" Check Box (Windows NT/2000)

Disable the "Log on using dial-up connection" Check Box (Windows NT/2000)
Category: Home > Security > Remote Access

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

During logon Windows allows users to optionally connect to a Windows domain using dial-up networking, this tweak can be used to disable that option.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'RasDisable' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: See Microsoft Support article Q263743 for details of a bypass issue.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | RasDisable | REG_SZ | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: RasDisable
Type: REG_SZ (String Value)
Value: (0 = restriction disabled, 1 = restriction enabled)

Related Tweaks

  • Automatically Use Dial-Up Networking to Logon (Windows NT/2000)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 3, 2002


Change the Size of the Windows File Protection Cache (Windows 2000/XP)

Change the Size of the Windows File Protection Cache (Windows 2000/XP)
Category: Home > Windows > System > Windows File Checker

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

The Windows File Protection feature of Windows stores copies of common DLL files and replaces them if the original becomes damaged or lost. This tweak lets you control the maximum amount of space available to be consumed by the backup DLL's.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, called "SfcQuota" and set it to the allowable disk space in megabytes (decimal mode). For example, 50Mb would be 0x00000032 (50) and 200Mb would be 0x000000c8 (200). The default value is 0xffffffff (or approximately 300 MB).

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SfcQuota | REG_DWORD | 0x000000c8 (200) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: SfcQuota
Type: REG_DWORD (DWORD Value)
Value: Size in Megabytes (0xffffffff = default)

Related Tweaks

  • Disable Windows File Protection (Windows 2000/XP)
  • Manage Windows File Protection Scans (Windows 2000/XP)
  • Specify the Directory to Store Cached SFC Files (Windows 2000/XP)
  • Display SFC Progress Meter (Windows 2000/XP)
  • Windows File Checker Command-line Options (Windows 2000)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 20, 2003


Binding Multiple IP Address to a Single Network Card (Windows 95/98/Me)

Binding Multiple IP Address to a Single Network Card (Windows 95/98/Me)
Category: Home > Network > Clients

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

The Windows 9x GUI does not accept having multiple IP addresses specified for a single network adapter. This tweak allows you to add additional IP addresses using the registry.

Open your registry and find the key below where the final four digits represents the network adapter. If you only have one adapter the digits will be 0000.

Within this key will be two values called "IPAddress" and "IPMask". To add additional IP addresses add the comma-separated IP and subnet mask values to both these keys respectively without using spaces.

Exit your registry and reboot for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | IPAddress | REG_SZ | "192.168.0.5,10.0.0.30" | |
| |  | IPMask | REG_SZ | "255.255.255.0,255.0.0.0" | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans\0000 |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans\0000]
Name: IPAddress, IPMask
Type: REG_SZ (String Value)
Value: Comma-separated IP and Subnet Masks

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2002


Internet Explorer Control Panel Restrictions (Part 2) (All Windows)

Internet Explorer Control Panel Restrictions (Part 2) (All Windows)
Category: Home > Software > Internet Explorer > Security

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

The features available within the Internet Explorer control panel (Tools -> Internet Options) can be individually managed and disabled using this tweak.

Open you registry and find the key below.

Create a new DWORD value for each restriction from the list below, set the value to equal '1' to enable the restriction or '0' to disable it.

  • Accessibility - disables all options under Accessibility
  • GeneralTab - removes General tab
  • SecurityTab - removes Security tab
  • ContentTab - removes Content tab
  • ConnectionsTab - removes Connections tab
  • ProgramsTab - removes Programs tab
  • PrivacyTab - removes Privacy tab
  • AdvancedTab - removes Advanced tab
  • CertifPers - prevents changing Personal Certificate options
  • CertifSite - prevents changing Site Certificate options
  • CertifPub - prevents changing Publisher Certificate options
  • SecChangeSettings - prevents changing Security Levels for the Internet Zone
  • SecAddSites - prevents adding Sites to any zone
  • Privacy Settings - prevents changs to privacy settings
  • FormSuggest - disables AutoComplete for forms
  • FormSuggest Passwords - prevents Prompt me to save password from being displayed
  • Connwiz Admin Lock - disables the Internet Connection Wizard
  • Settings - prevents any changes to Temporary Internet Files
  • ResetWebSettings - disables the Reset web Setting button

Restart Internet Explorer for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Accessibility | REG_DWORD | 0x00000001 (1) | |
| |  | GeneralTab | REG_DWORD | 0x00000001 (1) | |
| |  | SecurityTab | REG_DWORD | 0x00000001 (1) | |
| |  | ContentTab | REG_DWORD | 0x00000001 (1) | |
| |  | ConnectionsTab | REG_DWORD | 0x00000001 (1) | |
| |  | ProgramsTab | REG_DWORD | 0x00000001 (1) | |
| |  | AdvancedTab | REG_DWORD | 0x00000001 (1) | |
| |  | CertifPers | REG_DWORD | 0x00000001 (1) | |
| |  | CertifSite | REG_DWORD | 0x00000001 (1) | |
| |  | SecChangeSettings | REG_DWORD | 0x00000001 (1) | |
| |  | SecAddSites | REG_DWORD | 0x00000001 (1) | |
| |  | FormSuggest | REG_DWORD | 0x00000001 (1) | |
| |  | FormSuggest Passwords | REG_DWORD | 0x00000001 (1) | |
| |  | Connwiz Admin Lock | REG_DWORD | 0x00000001 (1) | |
| |  | Settings | REG_DWORD | 0x00000001 (1) | |
| |  | ResetWebSettings | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control ... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\
Control Panel]
System Key: [HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Internet Explorer\
Control Panel]
Type: REG_DWORD (DWORD Value)
Value: (0 = disable restriction, 1 = enable restriction)

Related Tweaks

  • Internet Explorer Control Panel Restrictions (Part 1) (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 20, 2002


Fix Problem with Athlon Hanging AGP Programs (Windows 2000/XP)

Fix Problem with Athlon Hanging AGP Programs (Windows 2000/XP)
Category: Home > Hardware > Video and Graphics

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows may stop responding when you use an Accelerated Graphics Port (AGP) program with an AMD Athlon processor. This is due to the memory allocated by the video adapter driver becoming corrupted.

Open your registry and find the key below.

Create a new DWORD value called "LargePageMinimum" and set it to equal "0xffffffff" (or 4294967295 in decimal).

Restart Windows for the change to take effect.

Note: This behavior is known to occur with Nvidia GeForce 256 and Matrox G400 video adapters on computers with AMD Athlon processors. This behavior is not specific to any particular video adapter type.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | LargePageMinimum | REG_DWORD | 0xffffffff (4294967295) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memo... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\
Memory Management]
Name: LargePageMinimum
Type: REG_DWORD (DWORD Value)
Value: 0xffffffff (4294967295 decimal)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: July 28, 2002


Change the Internet Explorer User Agent String (All Windows)

Change the Internet Explorer User Agent String (All Windows)
Category: Home > Software > Internet Explorer > Network and Connections

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Whenever a web browser is used to connect to a remote web server it includes a User Agent string that contains details about browser and operating system. This tweak allows you to add or remove additional information from this string.

A standard user agent string would look similar to:

Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Which means Internet Explorer 5.5 running on Windows 2000.

Changing the Default User Agent Values
Open your registry and find the key below. If it does not already exist then create it.

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\5.0\User Agent]

Create three new string values called "Compatible", "Version" and "Platform". Set them to equal what you would like to be displayed instead of "compatible", "MSIE 5.5" and "Windows NT 5.0" respectively in the example above.

You can also modify the value of "(Default)" to change the browser name "Mozilla/4.0" in the example above.

Changing the Branded User Agent String
In addition when a customized user agent string is used it may contain additional information set by the company that created a branded version of the browser. For example a branded version from an ISP may look like:

Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; Your_ISP_Name)

Since this information is sent to the remote web server it may be stored in the web server log files and therefore possibly used to track branded versions of a web browser.

To change it open your registry and find the key [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\User Agent\Post Platform].

Each value name listed in this key will be sent to the remote web server as an additional entry in the user agent string. To remove any additional information delete the values within the [Post Platform] key. To add additional entries create a string value and name it the string you want to be sent.

Restart Internet Explorer for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | {Default) | REG_SZ | Mozilla/4.0 | |
| |  | Compatible | REG_SZ | compatible | |
| |  | Version | REG_SZ | MSIE 5.5 | |
| |  | Platform | REG_SZ | Windows NT 5.0 | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Se... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\
Internet Settings\5.0\User Agent]
Name: (Default), Compatible, Version, Platform
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 6, 2002


Change the Title of Windows Media Player (All Windows)

Change the Title of Windows Media Player (All Windows)
Category: Home > Software > Media Player

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak allows you to customize the title bar text shown on Windows Media Player.

Open your registry and find the key below.

Create a new string value called "TitleBar" and set it to the text you would like display in the title.

Restart Media Player for the change the take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | TitleBar | REG_SZ | "My Media Player" | |
-
| HKEY_CURRENT_USER\Software\Policies\Microsoft\WindowsMediaPlayer |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Policies\Microsoft\WindowsMediaPlayer]
Name: TitleBar
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 3, 2002


Remove the Minimize, Maximize and Close Tooltips (All Windows)

Remove the Minimize, Maximize and Close Tooltips (All Windows)
Category: Home > Windows > Appearance > Effects and Menus

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When you move your mouse over the three control boxes on a standard Window frame it will show tooltip text for each item. This tweak controls that function.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'MinMaxClose' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Settings:
User Key: [HKEY_CURRENT_USER\Control Panel\Desktop]
Name: MinMaxClose
Type: REG_SZ (String Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 28, 2001


Remove the Hand Icon for Shared Resources (All Windows)

Remove the Hand Icon for Shared Resources (All Windows)
Category: Home > Network

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Normally when you share a local resource on the network a hand icon is placed under the item to show it is shared. With this tweak you can remove the icon.

Open your registry and find the [SharingHandler] key below.

To remove the icon clear the current data from the "(Default)" value. To restore the icon to the default enter one of the filenames listed below for your OS.

Restart Windows for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | "" | |
-
| HKEY_CLASSES_ROOT\Network\SharingHandler |
-

Settings:
System Key: [HKEY_CLASSES_ROOT\Network\SharingHandler]
Name: (Default)
Type: REG_SZ (String Value)
Value: (blank = No Icon, "msshrui.dll" for Windows 9x/Me, "ntshrui.dll" for Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 26, 2002


Change the Number of Undo Levels in Microsoft Excel (All Windows)

Change the Number of Undo Levels in Microsoft Excel (All Windows)
Category: Home > Software > Microsoft Office

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak lets you modify the amount of undo history information that Excel will track. Increasing this value allows you to undo more than the default number of changes.

Open your registry and find the key below where [version] is "9.0" for Excel 2000 and "10.0" for Excel 2002.

Create a new DWORD value, or modify the existing value, named "UndoHistory" and set it to the number of undo levels between 0 and 100.

Restart Excel for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | UndoHistory | REG_DWORD | 0x00000064 (100) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Office\[Version]\Excel\Options |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Office\[Version]\Excel\Options]
Name: UndoHistory
Type: REG_DWORD (DWORD Value)
Value: Number of Undo Levels

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 8, 2002


Enable System File Protection Popup Notifications (Windows Me)

Enable System File Protection Popup Notifications (Windows Me)
Category: Home > Windows > System > Windows File Checker

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak controls whether a popup notification message is shown when the System File Protection (SFP) service performs an action.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'ShowPopups' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ShowPopups | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\SystemFileP... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\
SystemFileProtection]
Name: ShowPopups
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 27, 2001


Windows File Checker Command-line Options (Windows 2000)

Windows File Checker Command-line Options (Windows 2000)
Category: Home > Windows > System > Windows File Checker

The Windows File Checker is used to scans all the protected system files and replaces incorrect versions with a cached copy of the correct version. These are the command-line options to control the Windows file protection (WFP) utility.

The System File Checker is initiated with using the "SFC" command. Below are the command-line option which can be used with this utility.

/SCANNOW     Scans all protected system files immediately.
/SCANONCE    Scans all protected system files once at the next boot.
/SCANBOOT    Scans all protected system files at every boot.
/CANCEL      Cancels all pending scans of protected system files.
/QUIET       Replaces all incorrect file versions without prompting
             the user.
/ENABLE      Enables Windows File Protection for normal operation
/PURGECACHE  Purges the file cache and scans all protected system
             files immediately.
/CACHESIZE=x Sets the file cache size

Related Tweaks

  • Change the Size of the Windows File Protection Cache (Windows 2000/XP)
  • Disable Windows File Protection (Windows 2000/XP)
  • Manage Windows File Protection Scans (Windows 2000/XP)
  • Specify the Directory to Store Cached SFC Files (Windows 2000/XP)
  • Display SFC Progress Meter (Windows 2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 27, 2001


Specify the Dr Watson Log Directory (Windows NT/2000/XP)

Specify the Dr Watson Log Directory (Windows NT/2000/XP)
Category: Home > Windows > Accessories > Dr Watson

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak is used to set the directory that stores the log files created by the Dr. Watson utility.

Open your registry and find the key below.

Create a new Expanded String value, or modify the existing value called 'LogFilePath' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | LogFilePath | REG_SZ | "C:\WINNT\LOGS" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DrWatson |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DrWatson]
Name: LogFilePath
Type: REG_EXPAND_SZ (Expanded String Value)
Value: Directory Path

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 27, 2002


Control the Log File Creation Method of Dr Watson (Windows NT/2000/XP)

Control the Log File Creation Method of Dr Watson (Windows NT/2000/XP)
Category: Home > Windows > Accessories > Dr Watson

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak controls whether the Dr. Watson utility creates a new log file or appends data to the old log file for each application error that occurs.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'AppendToLogFile' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AppendToLogFile | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DrWatson |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DrWatson]
Name: AppendToLogFile
Type: REG_DWORD (DWORD Value)
Value: (0 = new, 1 = append)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 27, 2002


Control Whether Dr Watson Creates a Crash Dump (Windows NT/2000/XP)

Control Whether Dr Watson Creates a Crash Dump (Windows NT/2000/XP)
Category: Home > Windows > Accessories > Dr Watson

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak controls whether the Dr. Watson utility creates a crash dump file after an application crash has occured.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'CreateCrashDump' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DrWatson]
Name: CreateCrashDump
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 27, 2002


Specify the Location of the Dump File (Windows NT/2000/XP)

Specify the Location of the Dump File (Windows NT/2000/XP)
Category: Home > Windows > Accessories > Dr Watson

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak allows you to specify the path and filename to use when creating a crash dump file.

Open your registry and find the key below.

Create a new Expanded String value, or modify the existing value called 'CrashDumpFile' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | CrashDumpFile | REG_SZ | "C:\WINNT\DUMP\APP.DMP" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DrWatson |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DrWatson]
Name: CrashDumpFile
Type: REG_EXPAND_SZ (Expanded String Value)
Value: File Location

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 27, 2002


Control Whether Dr Watson Alerts Using Sound (Windows NT/2000/XP)

Control Whether Dr Watson Alerts Using Sound (Windows NT/2000/XP)
Category: Home > Windows > Accessories > Dr Watson

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak controls whether the Dr. Watson utility uses sound notification, i.e. a WAV file, to alert during an application error.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'SoundNotification' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SoundNotification | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DrWatson |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DrWatson]
Name: SoundNotification
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 27, 2002


Control Whether Dr Watson Alerts Using Popups (Windows NT/2000/XP)

Control Whether Dr Watson Alerts Using Popups (Windows NT/2000/XP)
Category: Home > Windows > Accessories > Dr Watson

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak controls whether the Dr. Watson utility display a message box when it encounters an application error.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'VisualNotification' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | VisualNotification | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DrWatson |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DrWatson]
Name: VisualNotification
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 27, 2002


Specify the Wave File for Sound Notification (Windows NT/2000/XP)

Specify the Wave File for Sound Notification (Windows NT/2000/XP)
Category: Home > Windows > Accessories > Dr Watson

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak is used to specify the path and filename of the wave file to be played during an application error if sound notification has been enabled.

Open your registry and find the key below.

Create a new Expanded String value, or modify the existing value called 'WaveFile' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | WaveFile | REG_SZ | "C:\MEDIA\ALERT.WAV" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DrWatson |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DrWatson]
Name: WaveFile
Type: REG_EXPAND_SZ (Expanded String Value)
Value: File Location

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 27, 2002


Control Thread Dumping in Dr Watson (Windows NT/2000/XP)

Control Thread Dumping in Dr Watson (Windows NT/2000/XP)
Category: Home > Windows > Accessories > Dr Watson

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak controls whether the Dr. Watson utility should dump the contents of all threads during an application error.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'DumpAllThreads' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DumpAllThreads | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DrWatson |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DrWatson]
Name: DumpAllThreads
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 27, 2002


Control Symbol Dumping in Dr Watson (Windows NT/2000/XP)

Control Symbol Dumping in Dr Watson (Windows NT/2000/XP)
Category: Home > Windows > Accessories > Dr Watson

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak controls whether the Dr. Watson should dump the contents of the symbol tables during an application error.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'DumpSymbols' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DumpSymbols | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DrWatson |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DrWatson]
Name: DumpSymbols
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 27, 2002


Specify the Number of Instructions to Record (Windows NT/2000/XP)

Specify the Number of Instructions to Record (Windows NT/2000/XP)
Category: Home > Windows > Accessories > Dr Watson

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak specifies the number of instructions for Dr. Watson to record during an application error.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'Instructions' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Instructions | REG_DWORD | 0x0000000a (10) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DrWatson |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DrWatson]
Name: Instructions
Type: REG_DWORD (DWORD Value)
Value: Number

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 27, 2002


Control the Display of Popup Error Messages (Windows NT/2000/XP)

Control the Display of Popup Error Messages (Windows NT/2000/XP)
Category: Home > Windows > System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak is used to control which error messages are displayed as popups, and also allows you disable the use of popup error dialog boxes entirely.

Open your registry and find the key below.

Modify the value of "ErrorMode" according to the options below.

Value  Description
-----  -----------
  0    All errors appear in popups (Default)
  1    System errors disabled, application errors still
       using popups
  2    Neither system or application errors use popups

Note: This setting does not affect error logging, any errors will still be logged as normal.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ErrorMode | REG_DWORD | 0x00000002 (2) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Windows |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Windows]
Name: ErrorMode
Type: REG_DWORD (DWORD Value)
Value: (0 = all errors, 1 = application errors, 2 = no popups)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 14, 2002


Reboot Windows After a Crash (Windows NT/2000/XP)

Reboot Windows After a Crash (Windows NT/2000/XP)
Category: Home > Security > System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This parameter controls whether Windows should automatically reboot after a system failure or if the blue crash screen should be displayed.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'AutoReboot' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AutoReboot | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CrashControl |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CrashControl]
Name: AutoReboot
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = auto reboot)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: July 20, 2002


Send Administrative Alerts of System Crashes (Windows NT/2000/XP)

Send Administrative Alerts of System Crashes (Windows NT/2000/XP)
Category: Home > Windows > Troubleshooting > Crash Control

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether Windows should send an alert to the Administrator when a system crashes.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'SendAlert' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SendAlert | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CrashControl |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CrashControl]
Name: SendAlert
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Related Tweaks

  • Specify the Small Memory Dump Directory (Windows 2000/XP)
  • Control Whether Windows Logs a System Crash (Windows NT/2000/XP)
  • Create a System Crash Dump File (Windows NT/2000/XP)
  • Specify the System Crash Dump File Location (Windows NT/2000/XP)
  • Control the Dump Creation Method (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 28, 2001


Control Whether Windows Logs a System Crash (Windows NT/2000/XP)

Control Whether Windows Logs a System Crash (Windows NT/2000/XP)
Category: Home > Windows > Troubleshooting > Crash Control

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether Windows logs a system crash to the event log, this will allow the exact time of the crash to be permanently recorded.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'LogEvent' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | LogEvent | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CrashControl |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CrashControl]
Name: LogEvent
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Related Tweaks

  • Specify the Small Memory Dump Directory (Windows 2000/XP)
  • Send Administrative Alerts of System Crashes (Windows NT/2000/XP)
  • Create a System Crash Dump File (Windows NT/2000/XP)
  • Specify the System Crash Dump File Location (Windows NT/2000/XP)
  • Control the Dump Creation Method (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 28, 2001


Create a System Crash Dump File (Windows NT/2000/XP)

Create a System Crash Dump File (Windows NT/2000/XP)
Category: Home > Windows > Troubleshooting > Crash Control

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether Windows creates a dump file of the computer memory when a system crashes.

Open your registry and find the key below.

Change the value of "CrashDumpEnabled" according to the options in the table below.

  • 0 = None
  • 1 = Complete memory dump
  • 2 = Kernel memory dump
  • 3 = Small memory dump (64KB)

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | CrashDumpEnabled | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CrashControl |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CrashControl]
Name: CrashDumpEnabled
Type: REG_DWORD (DWORD Value)

Related Tweaks

  • Specify the Small Memory Dump Directory (Windows 2000/XP)
  • Send Administrative Alerts of System Crashes (Windows NT/2000/XP)
  • Control Whether Windows Logs a System Crash (Windows NT/2000/XP)
  • Specify the System Crash Dump File Location (Windows NT/2000/XP)
  • Control the Dump Creation Method (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 28, 2001


Specify the System Crash Dump File Location (Windows NT/2000/XP)

Specify the System Crash Dump File Location (Windows NT/2000/XP)
Category: Home > Windows > Troubleshooting > Crash Control

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak is used to specify the location where the dump file should be written after a system crash.

Open your registry and find the key below.

Create a new Expanded String value, or modify the existing value called 'DumpFile' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DumpFile | REG_SZ | C:\WINDOWS\MEMORY.DMP | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CrashControl |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CrashControl]
Name: DumpFile
Type: REG_EXPAND_SZ (Expanded String Value)
Value: File Location

Related Tweaks

  • Specify the Small Memory Dump Directory (Windows 2000/XP)
  • Send Administrative Alerts of System Crashes (Windows NT/2000/XP)
  • Control Whether Windows Logs a System Crash (Windows NT/2000/XP)
  • Create a System Crash Dump File (Windows NT/2000/XP)
  • Control the Dump Creation Method (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 28, 2001


Control the Dump Creation Method (Windows NT/2000/XP)

Control the Dump Creation Method (Windows NT/2000/XP)
Category: Home > Windows > Troubleshooting > Crash Control

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak controls whether the system should create a new dump file and overwrite the existing file or whether it should append data to the old dump file when a system crash occurs.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'Overwrite' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Overwrite | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CrashControl |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CrashControl]
Name: Overwrite
Type: REG_DWORD (DWORD Value)
Value: (0 = append, 1 = overwrite)

Related Tweaks

  • Specify the Small Memory Dump Directory (Windows 2000/XP)
  • Send Administrative Alerts of System Crashes (Windows NT/2000/XP)
  • Control Whether Windows Logs a System Crash (Windows NT/2000/XP)
  • Create a System Crash Dump File (Windows NT/2000/XP)
  • Specify the System Crash Dump File Location (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 28, 2001


Run Startup Programs in a Command Prompt (Windows 2000/XP)

Run Startup Programs in a Command Prompt (Windows 2000/XP)
Category: Home > Windows > Accessories > Command Processor

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allows you to specify commands or programs to be automatically executed whenever a command processor is launched. For example, to set environment variables or parameters using a batch file.

Open your registry and find the key below.

Create a new string value called "AutoRun" and set the value to equal the commands to be automatically executed. Multiple commands should be seperated by double ampersands e.g. "command1 && command2".

The changes will take effect the next time the command processor is used.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AutoRun | REG_SZ | "c:\batch\environ.bat" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Command Processor |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Command Processor]
Name: AutoRun
Type: REG_SZ (String Value)
Value: Command to Execute

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 13, 2002


Disable Command Processor Extensions (Windows 2000/XP)

Disable Command Processor Extensions (Windows 2000/XP)
Category: Home > Windows > Accessories > Command Processor

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether command extensions are enabled or disabled. When command extensions are used they change the behaviour of various standard command processor functions such as CD, MD, DEL, PROMPT and SET.

Open your registry and find the key below.

Create a new DWORD value called "EnableExtensions" and set it "1" to enable extensions or "0" to disable them (default is enabled).

The command extensions involve changes and/or additions to the following commands:

DEL or ERASE
COLOR
CD or CHDIR
MD or MKDIR
PROMPT
PUSHD
POPD
SET
SETLOCAL
ENDLOCAL
IF
FOR
CALL
SHIFT
GOTO
START
ASSOC
FTYPE

To get specific details, type commandname /? to view the help.

Note: This setting can also be used as a system wide policy under the HKEY_LOCAL_MACHINE hive.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | EnableExtensions | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Command Processor |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Command Processor]
Name: EnableExtensions
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 8, 2001


Enable Delayed Environment Variable Expansion (Windows 2000/XP)

Enable Delayed Environment Variable Expansion (Windows 2000/XP)
Category: Home > Windows > Accessories > Command Processor

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allows you to enable or disable delayed environment variable expansion in the command processor. If this feature is enabled then exclaimation characters can be used to substitute the value of an environment variable at execution time.

Open your registry and find the key below.

Create a new DWORD value called "DelayedExpansion" and set it to equal "1" to enabled variable expansion or "0" to disable it.

Delayed expansion will be available the next time the command processor is used. To access variables surround the variable name with exclaimation characters i.e. "!varname!". For example to echo the PATH variable you could use the following command:

echo !path!

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DelayedExpansion | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Command Processor |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Command Processor]
Name: DelayedExpansion
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 8, 2001


Enable Directory Completion (Windows 2000/XP)

Enable Directory Completion (Windows 2000/XP)
Category: Home > Windows > Accessories > Command Processor

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Directory completion allows you to specify a key, that when pressed, completes the remainder of a directory name, you can press the key multiple times to scroll through the choices.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, called 'PathCompletionChar' and set it to equal the hex value of the required control character. For example to use the TAB key set the value to '9', to use Ctrl-D set the value to '4' and for Ctrl-F set the value to '6'.

Now when you are using a command prompt and type the first part of a directory name then press the specified key, Windows will complete the remainder of the path for you.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | PathCompletionChar | REG_DWORD | 0x00000009 (9) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Command Processor |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Command Processor]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Command Processor]
Name: PathCompletionChar
Type: REG_DWORD (DWORD Value)
Value: Hex Control Character

Related Tweaks

  • Enable Command Completion (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 5, 2002


Prevent Uploading Folders to a Users Server Profile (Windows NT/2000/XP)

Prevent Uploading Folders to a Users Server Profile (Windows NT/2000/XP)
Category: Home > Network > Clients

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When profiles are used and a user logs off from a Windows domain certain folders are uploaded to the central user profile on the server. This setting allows you to stop any time consuming or non-essential folders (e.g. Temporary Internet Files) from being transferred.

Open your registry and find the key below.

Create a new string value called "ExcludeProfileDirs" and set it to equal the directory names to be excluded from the upload.

Restart Windows for the change to take effect.

Note: The directory names should be entered relative to the root of the profile, and must be separated by semicolons.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ExcludeProfileDirs | REG_SZ | Temporary Internet Files;Personal | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: ExcludeProfileDirs
Type: REG_SZ (String Value)
Value: Directories to Exclude

Related Tweaks

  • Delete Cached Copies of Roaming Profiles (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 26, 2002


Change the Number of Recent Documents Displayed (Windows 2000/Me/XP)

Change the Number of Recent Documents Displayed (Windows 2000/Me/XP)
Category: Home > Windows > Start Menu and Taskbar > Documents and Folders

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting is used to specify the number of documents and files that are kept in the recent documents section of the Start menu.

Open your registry and find the key below.

Create a new DWORD value called "MaxRecentDocs" and set it to equal the number of documents to display in the recent documents list, the default is 15.

Restart Windows for the change to take efftec.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | MaxRecentDocs | REG_DWORD | 0x0000001e (30) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: MaxRecentDocs
Type: REG_DWORD (DWORD Value)
Value: Number of Documents (32-bit)

Related Tweaks

  • Remove Recent Documents from the Start Menu (All Windows)
  • Clear Recent Documents When Windows Exits (All Windows)
  • Disable Recent Documents History (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 12, 2002


Control the Mouse "Snap To" Feature (All Windows)

Control the Mouse "Snap To" Feature (All Windows)
Category: Home > Hardware > Mice and Keyboards

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When enabled, this setting causes the mouse pointer to snap-to the default button of the active application window.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'SnapToDefaultButton' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | SnapToDefaultButton | REG_SZ | "1" | |
-
| HKEY_CURRENT_USER\Control Panel\Mouse |
-

Settings:
User Key: [HKEY_CURRENT_USER\Control Panel\Mouse]
Name: SnapToDefaultButton
Type: REG_SZ (String Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 21, 2002


View System BIOS Information (Windows NT/2000/XP)

View System BIOS Information (Windows NT/2000/XP)
Category: Home > Hardware > Processor and Motherboard

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This registry key stores information about the system BIOS, including the release date, version number and video BIOS date.

Open your registry and find the key below for information on the system BIOS.

These values are read-only and can not be changed.

Note: These values are read-only and can only be viewed and not edited.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SystemBiosDate | REG_SZ | "12/30/99" | |
| |  | SystemBiosVersion | REG_SZ | "TECRA 8100 v2.30" | |
| |  | VideoBiosDate | REG_SZ | "03/01/00" | |
-
| HKEY_LOCAL_MACHINE\HARDWARE\DESCRIPTION\System |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\HARDWARE\DESCRIPTION\System]
Name: SystemBiosDate, SystemBiosVersion, VideoBiosDate
Type: REG_SZ (String Value)

Related Tweaks

  • Show Options on Logon Dialog Box (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 23, 2002


Specify Users to Receive Administrative Alerts (Windows NT/2000/XP)

Specify Users to Receive Administrative Alerts (Windows NT/2000/XP)
Category: Home > Security > Network

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting is used to specify a list of users and/or computers that should receive administrative alerts.

Open your registry using REGEDT32 and find the key below.

Modify the REG_MULTI_SZ value called "AlertNames" and on a seperate line enter each user or computer to receive the alerts.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AlertNames | REG_MULTI_SZ | "jsmith jdoe" | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Alerter\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Alerter\Parameters]
Name: AlertNames
Type: REG_MULTI_SZ (Multi-String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 26, 2002


Specify the Schedule for Alerter Service (Windows NT/2000/XP)

Specify the Schedule for Alerter Service (Windows NT/2000/XP)
Category: Home > Network

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting is used to specify how often the server checks alert conditions and sends any required alert messages to administrative users.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'AlertSched, ErrorThreshold, NetworkErrorThreshold' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: By default alert messages are sent every 5 minutes, unless 10 alerts are pending or 5% of all network operations generate an error.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AlertSched | REG_DWORD | 0x00000005 (5) | |
| |  | ErrorThreshold | REG_DWORD | 0x0000000A (10) | |
| |  | NetworkErrorThreshold | REG_DWORD | 0x00000005 (5) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parame... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\
Parameters]
Name: AlertSched, ErrorThreshold, NetworkErrorThreshold
Type: REG_DWORD (DWORD Value)
Value: 1 to 65535 minutes

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 26, 2002


Specify the Server Announcement Frequency (Windows NT/2000/XP)

Specify the Server Announcement Frequency (Windows NT/2000/XP)
Category: Home > Network > Servers

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Specifies how often a non-hidden server announces itself to the network. More frequent announcements keep client server tables more up to date, but may increase network overhead and processing on client computers, because the clients must process every announcement.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'Announce' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Announce | REG_DWORD | 0x000000f0 (240) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parame... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\
Parameters]
Name: Announce
Type: REG_DWORD (DWORD Value)
Value: 1 to 65535 seconds (Default is 240)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2002


Specify the Server Announcement Variation (Windows NT/2000/XP)

Specify the Server Announcement Variation (Windows NT/2000/XP)
Category: Home > Network > Servers

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This parameter specifies the time by which the server announcement period can vary. This helps to prevent several servers from continuously announcing simultaneously, thereby reducing network load peaks.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'AnnDelta' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AnnDelta | REG_DWORD | 0x00000bb8 (3000) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parame... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\
Parameters]
Name: AnnDelta
Type: REG_DWORD (DWORD Value)
Value: 0 to 65535 milliseconds (Default is 3000)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2002


Include a Comment in the Server Announcement (Windows NT/2000/XP)

Include a Comment in the Server Announcement (Windows NT/2000/XP)
Category: Home > Network > Servers

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allows you to specify a comment which is sent in server announcements and returned to NetServerGetInfo requests.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'Comment' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Comment | REG_SZ | "Primary Mail Server" | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parame... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\
Parameters]
Name: Comment
Type: REG_SZ (String Value)
Value: Text String

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2002


Specify the Idle Timeout for Server Connnections (Windows NT/2000/XP)

Specify the Idle Timeout for Server Connnections (Windows NT/2000/XP)
Category: Home > Network > Servers

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Specifies the amount of idle time that a circuit is allowed before being disconnected. If this parameter is set to a low value, it saves server resources but reduces performance because of client overhead in reconnecting.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'Disc' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Disc | REG_DWORD | 0x0000000F (15) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parame... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\
Parameters]
Name: Disc
Type: REG_DWORD (DWORD Value)
Value: 0 to infinite minutes (Default is 15)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2002


Control MS-DOS File Control Blocks (FCBs) Usage on Servers (Windows NT/2000)

Control MS-DOS File Control Blocks (FCBs) Usage on Servers (Windows NT/2000)
Category: Home > Network > Servers

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Specifies whether MS-DOS File Control Blocks (FCBs) are folded together, so multiple remote opens are performed as a single open on the server to save resources.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'EnableFCBopens' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | EnableFCBopens | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parame... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\
Parameters]
Name: EnableFCBopens
Type: REG_DWORD (DWORD Value)
Value: 0 = disabled, 1 = enabled (Default is 1)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2002


Control the Ability to Use HTTP Mail in Outlook Express (All Windows)

Control the Ability to Use HTTP Mail in Outlook Express (All Windows)
Category: Home > Software > Outlook Express

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak is used to specify whether HTTP mail servers, such as Hotmail, can be used or created in Outlook Express.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'HTTP Mail Enabled' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | HTTP Mail Enabled | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Outlook Express |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Outlook Express]
Name: HTTP Mail Enabled
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2001


Manage Windows File Protection Scans (Windows 2000/XP)

Manage Windows File Protection Scans (Windows 2000/XP)
Category: Home > Windows > System > Windows File Checker

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether the Windows File Checker (SFC) should scan and replace the protected files during boot up.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'SFCScan' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SFCScan | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: SFCScan
Type: REG_DWORD (DWORD Value)
Value: 0 = disabled, 1 = scan every boot, 2 = scan once

Related Tweaks

  • Change the Size of the Windows File Protection Cache (Windows 2000/XP)
  • Disable Windows File Protection (Windows 2000/XP)
  • Specify the Directory to Store Cached SFC Files (Windows 2000/XP)
  • Display SFC Progress Meter (Windows 2000/XP)
  • Windows File Checker Command-line Options (Windows 2000)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 14, 2002


Specify the Directory to Store Cached SFC Files (Windows 2000/XP)

Specify the Directory to Store Cached SFC Files (Windows 2000/XP)
Category: Home > Windows > System > Windows File Checker

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This entry is used to specify which directory the Windows File Checker (SFC) should use to store the cached copies of protected files.

Open your registry and find the key below.

Create a new Expanded String value, or modify the existing value called 'SFCDllCacheDir' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SFCDllCacheDir | REG_SZ | %SystemRoot%\System32 | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: SFCDllCacheDir
Type: REG_EXPAND_SZ (Expanded String Value)
Value: Qualified Directory

Related Tweaks

  • Change the Size of the Windows File Protection Cache (Windows 2000/XP)
  • Disable Windows File Protection (Windows 2000/XP)
  • Manage Windows File Protection Scans (Windows 2000/XP)
  • Display SFC Progress Meter (Windows 2000/XP)
  • Windows File Checker Command-line Options (Windows 2000)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2001


Display SFC Progress Meter (Windows 2000/XP)

Display SFC Progress Meter (Windows 2000/XP)
Category: Home > Windows > System > Windows File Checker

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Specifies whether the Windows File Checker (SFC) progress meter should be displayed during file checking.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'SFCShowProgress' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SFCShowProgress | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: SFCShowProgress
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Related Tweaks

  • Change the Size of the Windows File Protection Cache (Windows 2000/XP)
  • Disable Windows File Protection (Windows 2000/XP)
  • Manage Windows File Protection Scans (Windows 2000/XP)
  • Specify the Directory to Store Cached SFC Files (Windows 2000/XP)
  • Windows File Checker Command-line Options (Windows 2000)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2001


Specify the Default Internet Explorer Download Directory (All Windows)

Specify the Default Internet Explorer Download Directory (All Windows)
Category: Home > Software > Internet Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting is used to specify which directory should be used as the default location to save downloaded files retrieved using Internet Explorer.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'Download Directory' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Download Directory | REG_SZ | "C:\My Files" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer]
Name: Download Directory
Type: REG_SZ (String Value)
Value: Qualified Directory

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2002


Specify the Print Server Broadcast Timeout (Windows NT/2000/XP)

Specify the Print Server Broadcast Timeout (Windows NT/2000/XP)
Category: Home > Hardware > Printers and Plotters

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting is used to specify the timeout period between broadcasts of a print servers resources.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, named "ServerThreadTimeout" and set it to equal the time in milliseconds between broadcasts, the default is 600,000 (10 minutes).

Restart Windows or the service for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ServerThreadTimeout | REG_DWORD | 0x000927C0 (600000) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print]
Name: ServerThreadTimeout
Type: REG_DWORD (DWORD Value)
Value: Timeout in milliseconds

Related Tweaks

  • Disable the Printer Server Browse Thread (Windows NT/2000/XP)
  • Specify the Printer Browser Timeout (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 26, 2002


Specify the Printer Browser Timeout (Windows NT/2000/XP)

Specify the Printer Browser Timeout (Windows NT/2000/XP)
Category: Home > Hardware > Printers and Plotters

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting is used to specify the time a network printer should remain in the browse list before it is removed.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NetPrinterDecayPeriod' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NetPrinterDecayPeriod | REG_DWORD | 0x00036EE80 (3600000) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print]
Name: NetPrinterDecayPeriod
Type: REG_DWORD (DWORD Value)
Value: 0 to 4294967295 milliseconds (Default is 3,600,000)

Related Tweaks

  • Disable the Printer Server Browse Thread (Windows NT/2000/XP)
  • Specify the Print Server Broadcast Timeout (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 26, 2002


Hide the Search Button on the Explorer Toolbar (Windows 2000/XP)

Hide the Search Button on the Explorer Toolbar (Windows 2000/XP)
Category: Home > Windows > Windows Explorer > Search

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction allows you to remove the search button from the "Standard Buttons" toolbar in Windows Explorer.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoShellSearchButton' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoShellSearchButton | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoShellSearchButton
Type: REG_DWORD (DWORD Value)
Value: (0 = display, 1 = remove)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 25, 2002


Disable ScanDisk After Improper Shutdown (Windows Me)

Disable ScanDisk After Improper Shutdown (Windows Me)
Category: Home > Windows > File System > Maintenance

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Normally if a system is shutdown improperly scandisk will run on the next reboot to ensure the contents of the hard disk are valid. This setting stops scandisk from running automatically when restarting.

Open your registry and find the key below.

Create a new Binary value, or modify the existing value called 'DisableScandiskOnBoot' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DisableScandiskOnBoot | REG_BINARY | 00 00 00 00 | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem]
Name: DisableScandiskOnBoot
Type: REG_BINARY (Binary Value)
Value: 01 = disable, 00 = enable

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 28, 2002


Disable Tracking of Broken Shortcut Links (Windows 2000/XP)

Disable Tracking of Broken Shortcut Links (Windows 2000/XP)
Category: Home > Windows > File System > Files and Shortcuts

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

The NTFS File System in Windows XP and Windows 2000 automatically attempts to locate broken shortcut destinations by searching all paths that are associated with it. This setting can be used to disable that feature.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoResolveTrack' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This applies only to target files on NTFS partitions. File allocation table (FAT) partitions do not have this ID tracking and search capability.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoResolveTrack | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoResolveTrack
Type: REG_DWORD (DWORD Value)
Value: (0 = resolve, 1 = do not resolve)

Related Tweaks

  • Comprehensive Search for Broken Shortcuts (Windows NT/2000/XP)
  • Disable Automatic Network Shortcut Resolution (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 3, 2002


Dynamic Domain Name Updates (Windows 2000/XP)

Dynamic Domain Name Updates (Windows 2000/XP)
Category: Home > Network > Clients

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows 2000 and XP support dynamic Domain Name System (DDNS) updates and is enabled by default. This setting allows you to control whether network adapters should send updates.

Open your registry and find the key below.

Create a new DWORD value, or modify the value named "DisableDynamicUpdate" and set it to equal "1" to disable the use of dynamic updates.

This can also be controlled on a per adapter basis by modifying the same value at HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\ Parameters\Interfaces\[Adapter ID].

Restart Windows for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DisableDynamicUpdate | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]
Name: DisableDynamicUpdate
Type: REG_DWORD (DWORD Value)
Value: (0 = enable updates, 1 = disable updates)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: July 24, 2002


Implement a User Based Custom Shell (Windows 2000/XP)

Implement a User Based Custom Shell (Windows 2000/XP)
Category: Home > Security

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows allows you to selectively specify the system shell based on the logged in user. For example this allows one user to use the standard explorer interface and another to use the legacy progman shell.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'Shell' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Shell | REG_SZ | progman.exe | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
Name: Shell
Type: REG_SZ (String Value)
Value: Filename of Replacement Shell

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 21, 2002


Use an Alternative User Interface (Windows NT/2000)

Use an Alternative User Interface (Windows NT/2000)
Category: Home > Windows > System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allows you to specify an alternate shell to use as the Windows user interface instead of the default explorer shell.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'Shell' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Shell | REG_SZ | explorer.exe | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: Shell
Type: REG_SZ (String Value)
Value: Filename of Replacement Shell

Related Tweaks

  • Implement a User Based Custom Shell (Windows 2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 20, 2001


Disable the Creation of Last Known Good (Windows NT/2000/XP)

Disable the Creation of Last Known Good (Windows NT/2000/XP)
Category: Home > Windows > Startup and Shutdown

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allows you to disable the creation of the LastKnownGood configuration, which stores a copy of the configuration after each successful boot-up.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'ReportBootOk' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ReportBootOk | REG_SZ | "0" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: ReportBootOk
Type: REG_SZ (String Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 20, 2002


Remove the Ability to Modify File Types (Windows 2000/XP)

Remove the Ability to Modify File Types (Windows 2000/XP)
Category: Home > Security > Desktop and Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allows you to remove the ability to change, add or delete file types using explorer the Folder Options interface.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoFileAssociate' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoFileAssociate | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoFileAssociate
Type: REG_DWORD (DWORD Value)
Value: (0 = buttons enabled, 1 = buttons disabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 25, 2002


Remove the Windows Security on Start Menu (Windows Terminal Server)

Remove the Windows Security on Start Menu (Windows Terminal Server)
Category: Home > Security > Start Menu and Taskbar

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting is used to hide the Windows NT Security menu item on the Start Menu of a terminal server session.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoNtSecurity' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoNtSecurity | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoNtSecurity
Type: REG_DWORD (DWORD Value)
Value: (0 = display, 1 = remove)

Related Tweaks

  • Remove the Disconnect Menu Item (Windows Terminal Server)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 29, 2002


Remove the Disconnect Menu Item (Windows Terminal Server)

Remove the Disconnect Menu Item (Windows Terminal Server)
Category: Home > Windows > Start Menu and Taskbar

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting is used to hide the Disconnect menu item on a terminal server Start menu.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoDisconnect' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoDisconnect | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoDisconnect
Type: REG_DWORD (DWORD Value)
Value: (0 = display, 1 = remove)

Related Tweaks

  • Remove the Windows Security on Start Menu (Windows Terminal Server)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 29, 2002


Manage the Reserved QoS Bandwidth (Windows 2000/XP)

Manage the Reserved QoS Bandwidth (Windows 2000/XP)
Category: Home > Network

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting determines the percentage of connection bandwidth that the system can reserve for QoS traffic. By default, the Packet Scheduler limits the system to 20 percent of the bandwidth of a connection.

Open your registry and find or create the key below.

Create a new DWORD value called "NonBestEffortLimit" and set it to the percentage (in decimal) of bandwidth to reserve for QoS packets.

Restart Windows for the change to take effect.

Note: This can be change on an adapter-by-adapter basis by creating the same value in [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Psched\Parameters\Adapters\{Adpater-ID}].

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NonBestEffortLimit | REG_DWORD | 0x00000032 (50) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Psched |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Psched]
Name: NonBestEffortLimit
Type: REG_DWORD (DWORD Value)
Value: Decimal Percentage (default = 20)

Related Tweaks

  • Manage the QoS Packet Queuing (Windows 2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 26, 2002


Enable Manual Crash Feature (Windows 2000)

Enable Manual Crash Feature (Windows 2000)
Category: Home > Windows > Troubleshooting > Crash Control

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Microsoft Windows 2000 includes a feature that enables you to have the system stop responding and generate a Memory.dmp file (crash to blue-screen) by using a button combination on the keyboard.

This "feature" is disabled by default. To enable this feature, open your registry and find the key below.

Create a new DWORD value called "CrashOnCtrlScroll" and set it to "1" to enable keyboard initiated crashes.

After restarting the computer, you can generate a system to stop responding by holding down the right CTRL key and pressing the SCROLL LOCK key twice.

Note: Pressing left CTRL key does not generate the system to stop responding.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | CrashOnCtrlScroll | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\i8042prt\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\i8042prt\Parameters]
Name: CrashOnCtrlScroll
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 20, 2001


Create a Oakley Log for IPSec Troubleshooting (Windows 2000)

Create a Oakley Log for IPSec Troubleshooting (Windows 2000)
Category: Home > Windows > Troubleshooting > Logging

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Enabling this setting causes Windows to create an Oakley.log file in the %SystemRoot%\debug folder for developers or network administrators with advanced IKE knowledge.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'EnableLogging' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | EnableLogging | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\PolicyAgent\Oakley |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\PolicyAgent\Oakley]
Name: EnableLogging
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 20, 2001


Specify an Alternate Debugging Utility (Windows NT/2000/XP)

Specify an Alternate Debugging Utility (Windows NT/2000/XP)
Category: Home > Windows > Accessories > Dr Watson

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

By default Windows uses Dr Watson as the debugger when a system crash occurs. This setting allows you to specify an alternate utility such as Visual Studio or Norton CrashGuard.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'Debugger' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Debugger | REG_SZ | "drwtsn32 -p %ld -e %ld -g" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AeDebug |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AeDebug]
Name: Debugger
Type: REG_SZ (String Value)
Value: Filename

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 27, 2002


Specify the Program to Play Inserted Audio CDs (All Windows)

Specify the Program to Play Inserted Audio CDs (All Windows)
Category: Home > Windows > Accessories

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This value is used to specify which program should be used to play an audio CD when it is inserted and the autostart feature is enabled.

Open your registry and find the key below.

Create a new String value, or modify the existing value called '(Default)' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | wmplayer.exe /prefetch:3 /device:AudioCD "%L" | |
-
| HKEY_CLASSES_ROOT\AudioCD\Shell\Play\Command |
-

Settings:
System Key: [HKEY_CLASSES_ROOT\AudioCD\Shell\Play\Command]
Name: (Default)
Type: REG_SZ (String Value)
Value: Command-line to Execute

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 20, 2001


Use High Memory for DOS Drivers (Windows 95/98/Me)

Use High Memory for DOS Drivers (Windows 95/98/Me)
Category: Home > Tips and Tricks > Configuration Files > SYSTEM.INI

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting causes Windows to load the local DOS devices into high memory and freeing up more low memory for DOS applications.

Open your SYSTEM.INI and add the line:

LocalLoadHigh=1
Under the [386Enh] section.

Settings:
Name: LocalLoadHigh
Value: 1

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 12, 2002


Open and Save Dialog Box Customization (Windows 2000/Me/XP)

Open and Save Dialog Box Customization (Windows 2000/Me/XP)
Category: Home > Windows > Appearance

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

These settings allow you to remove the places bar, most-recently-used (MRU) list and the back button from the common dialog boxes.

Open your registry and find the key below.

Create a new DWORD value named according to the table below and set it to "1" to hide the button.

  • NoBackButton - Hides the back button
  • NoFileMRU - Hides the most-recently-used (MRU) list
  • NoPlacesBar - Hides the places bar

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoBackButton | REG_DWORD | 0x00000001 (1) | |
| |  | NoFileMRU | REG_DWORD | 0x00000001 (1) | |
| |  | NoPlacesBar | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Com... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Comdlg32]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Comdlg32]
Name: NoFileMRU, NoBackButton, NoPlacesBar
Type: REG_DWORD (DWORD Value)
Value: (0 = display, 1 = remove)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 20, 2002


Remove Items from Office Places Bar (All Windows)

Remove Items from Office Places Bar (All Windows)
Category: Home > Software > Microsoft Office

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak is used to remove items from the Places Bar in the Office 2000/XP Open and Save As dialog boxes.

Open your registry and find the key below, where [version] is the Office version number ("9.0" for Office 2000 and "10.0" for Office XP).

Below this key is a series of sub-key representing the items on the Places Bar. Open each item you want to hide and add a new DWORD value named "Show" and set it to "0" to hide that item.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Show | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Office\[version]\Common\Open Find\P... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Office\[version]\Common\Open Find\
Places\StandardPlaces]
Name: Show
Type: REG_DWORD (DWORD Value)
Value: (0 = hide, 1 = show)

Related Tweaks

  • Add Custom Places to the Office Dialog Box (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 14, 2002


Add Custom Places to the Office Dialog Box (All Windows)

Add Custom Places to the Office Dialog Box (All Windows)
Category: Home > Software > Microsoft Office

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak can be used to add your own custom Places to the Office 2000 and Office XP "Open" and "Save As" dialog boxes.

Open your registry and find the key below. For Office 2000 replace [version] with "9.0" in the registry key, or "10.0" for Office XP which is internally known as Office 10.

For each custom place create a new sub-key called "PlaceX" where X is a unique number starting at 1 (i.e. Place1, Place2 ...). Open the new sub-key and create two new string values called "Name" and "Path" and set them to equal the display name and folder path respectively.

Restart Office for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Name | REG_SZ | "My Music Folder" | |
| |  | Path | REG_SZ | "c:\music" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Office\[Version]\Common\Open Find\P... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Office\[Version]\Common\Open Find\
Places\UserDefinedPlaces]
Name: Name, Path
Type: REG_SZ (String Value)

Related Tweaks

  • Remove Items from Office Places Bar (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 18, 2002


Hide the Office Clipboard Toolbar (All Windows)

Hide the Office Clipboard Toolbar (All Windows)
Category: Home > Software > Microsoft Office

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When you copy multiple items in any of the Microsoft Office programs, the Office Clipboard appears, allowing you to collect and paste multiple items stored in the toolbar. This tweak allows you to prevent the toolbar from automatically appearing.

Open your registry and find the key below where [version] is either "9.0" for Office 2000 or "10.0" for Office XP.

Create or modify the value called "AcbControl" and set it to "1" to disable the toolbar, or "0" to enable it.

Restart Microsoft Office for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AcbControl | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Office\[version]\Common\General |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Office\[version]\Common\General]
Name: AcbControl
Type: REG_DWORD (DWORD Value)
Value: (0 = appears, 1 = disabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 10, 2002


Disable Office 2000 Tune Up (All Windows)

Disable Office 2000 Tune Up (All Windows)
Category: Home > Software > Microsoft Office

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting is used to disable the automatic Office 2000 tune up feature.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'Disabled' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Disabled | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\Software\Microsoft\Office\9.0\Common\TuneUp |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Office\9.0\Common\TuneUp]
Name: Disabled
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = disabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 14, 2002


Disable Media Player Upgrade Message (All Windows)

Disable Media Player Upgrade Message (All Windows)
Category: Home > Software > Media Player

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allows you to disable the automatic Media Player upgrade message that appears when a new version of the player has been released.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'AskMeAgain' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AskMeAgain | REG_SZ | "no" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MediaPlayer\PlayerUpgrade |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MediaPlayer\PlayerUpgrade]
Name: AskMeAgain
Type: REG_SZ (String Value)
Value: "yes" or "no"

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 3, 2002


Remove Items from Media Player (All Windows)

Remove Items from Media Player (All Windows)
Category: Home > Software > Media Player

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak allows you to remove the Radio Bar, Media Favorites and Finding New Station from Windows Media Player.

Open your registry and find the key below.

For each item you want to remove create a new DWORD value according to the values below and set it to equal "1" for disabled.

Restart Media Player for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoRadioBar | REG_DWORD | 0x00000001 (1) | |
| |  | NoMediaFavorites | REG_DWORD | 0x00000001 (1) | |
| |  | NoFindNewStations | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Policies\Microsoft\WindowsMediaPlayer |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Policies\Microsoft\WindowsMediaPlayer]
System Key: [HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\WindowsMediaPlayer]
Name: NoRadioBar, NoMediaFavorites, NoFindNewStations
Type: REG_DWORD (DWORD Value)
Value: (0 = appears, 1 = disabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 3, 2002


Disable the Custom Search Page in Internet Explorer (All Windows)

Disable the Custom Search Page in Internet Explorer (All Windows)
Category: Home > Software > Internet Explorer > Search Features

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allows you to disable the use of the custom search page in Internet Explorer.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'Use Custom Search URL' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Use Custom Search URL | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
Name: Use Custom Search URL
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 28, 2002


Disable the Go Button in Internet Explorer (All Windows)

Disable the Go Button in Internet Explorer (All Windows)
Category: Home > Software > Internet Explorer > Appearance

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting is used to remove the "Go" button from the Internet Explorer toolbar.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'ShowGoButton' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ShowGoButton | REG_SZ | "no" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
Name: ShowGoButton
Type: REG_SZ (String Value)
Value: "yes" or "no"

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2002


Disable Internet Explorer Download Notification (All Windows)

Disable Internet Explorer Download Notification (All Windows)
Category: Home > Software > Internet Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting is used to disable download completion notification in Internet Explorer.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'NotifyDownloadComplete' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NotifyDownloadComplete | REG_SZ | "no" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
Name: NotifyDownloadComplete
Type: REG_SZ (String Value)
Value: "yes" or "no"

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2002


Disable Document Editing Time Tracking (All Windows)

Disable Document Editing Time Tracking (All Windows)
Category: Home > Software > Microsoft Office

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Whenever you open a Office document the time open is tracked and added to the total "Edit Time". This tweak disables that tracking.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoTrack' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoTrack | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Common\General |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Common\General]
Name: NoTrack
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = disable tracking)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 14, 2002


Configure Office to Use the Standard System Font (All Windows)

Configure Office to Use the Standard System Font (All Windows)
Category: Home > Software > Microsoft Office

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allows you to configure Microsoft Office to use the standard system font for the user interface instead of the default Office font.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'UseOfficeUIFont' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | UseOfficeUIFont | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Office\[Version]\Common\General |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Office\[Version]\Common\General]
Name: UseOfficeUIFont
Type: REG_DWORD (DWORD Value)
Value: (0 = system font, 1 = Office font)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 18, 2002


Change the MSN Messenger Background Image (All Windows)

Change the MSN Messenger Background Image (All Windows)
Category: Home > Software > Windows Messenger

This tweak allows you to change the background bitmap image in the MSN Messenger service.

Locate the installation directory for MSN Messenger on your system (e.g. "C:\Program Files\Messenger"). This location can also be found in the registry in the "InstallationDirectory" value at [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MessengerService].

Rename the "lvback.gif" file in the installation directory to "lvback.old". Then copy and rename the new background GIF file to the same directory as "lvback.gif".

Restart MSN Messenger for the change to take effect.

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 27, 2002


Change the Start Page for Outlook Express (All Windows)

Change the Start Page for Outlook Express (All Windows)
Category: Home > Software > Outlook Express

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting can be used to change the page that Outlook Express loads in the right-hand window when it first starts-up.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'FrontPagePath' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | FrontPagePath | REG_SZ | "http://www.winguides.com/" | |
-
| HKEY_CURRENT_USER\Identities\[Identity]\Software\Microsoft\Outlook Expre... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Identities\[Identity]\Software\Microsoft\
Outlook Express\5.0]
Name: FrontPagePath
Type: REG_SZ (String Value)
Value: URL or Filename

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 21, 2001


Create a Desktop Shortcut to Hotmail (All Windows)

Create a Desktop Shortcut to Hotmail (All Windows)
Category: Home > Windows > Desktop

This tweak can be used to create a shortcut directly to your Hotmail e-mail account on your desktop.

Right-click on your desktop and create a new shortcut. For Windows NT/2000 set the target to:

%windir%\System32\rundll32.exe
"%ProgramFiles%\Internet Explorer\hmmapi.dll",OpenInboxHandler

for Windows 9x/Me set it to:

rundll32 "C:\Program
Files\Internet Explorer\hmmapi.dll",OpenInboxHandler

Click "Finish" and click the icon to launch Hotmail.

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 31, 2001


Disable Run Commands Specified in the Registry (Windows 98/Me/2000/XP)

Disable Run Commands Specified in the Registry (Windows 98/Me/2000/XP)
Category: Home > Security

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction is used to disable the ability to run startup programs specified in the registry when Windows launches.

Open your registry and find the key below.

Create a new DWORD value for each of the optional values below depending on which Run function to stop and set the value to "1" to disable.

Restart Windows for change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DisableLocalMachineRun | REG_DWORD | 0x00000001 (1) | |
| |  | DisableLocalMachineRunOnce | REG_DWORD | 0x00000001 (1) | |
| |  | DisableCurrentUserRun | REG_DWORD | 0x00000001 (1) | |
| |  | DisableCurrentUserRunOnce | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: DisableLocalMachineRun, DisableLocalMachineRunOnce, DisableCurrentUserRun, DisableCurrentUserRunOnce
Type: REG_DWORD (DWORD Value)
Value: (0 = enable run, 1 = disable run)

Related Tweaks

  • Manage the Programs Run at Windows Startup (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 19, 2001


Change Foreground and Background Task Priority (Windows NT/2000)

Change Foreground and Background Task Priority (Windows NT/2000)
Category: Home > Windows > System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting is used to manage the relative priority between foreground and background applications, this is normally accessed through Control Panel > System > Performance.

Open your registry and find the key below.

Modify the existing value, or create a new value, called "Win32PrioritySeparation" and set it to a valid DWORD value from the information below.

Windows NT Workstation

  • 0 - foreground and background threads get the same amount of processor time
  • 1 - foreground processes get more processor time than background processes
  • 2 - Foreground processes get much more processor time than background processes

Windows NT Server

The processor time that threads receive is fixed and the value instead determines the priority boost given to foreground processes, with 2 being the highest boost.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Win32PrioritySeparation | REG_DWORD | 0x00000002 (2) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\PriorityControl |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\PriorityControl]
Name: Win32PrioritySeparation
Type: REG_DWORD (DWORD Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 13, 2002


Change the TIME_WAIT Timeout to Increase Connections (Windows NT/2000/XP)

Change the TIME_WAIT Timeout to Increase Connections (Windows NT/2000/XP)
Category: Home > Network > Protocols > TCP-IP

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting determines the length of time that a connection will stay in the TIME_WAIT state before being closed. The default is 240 seconds which on a busy server will limit the maximum connections to around 200/sec. Reducing this setting will increase the maximum connection limit.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'TcpTimedWaitDelay' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | TcpTimedWaitDelay | REG_DWORD | 0x0000001e (30) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]
Name: TcpTimedWaitDelay
Type: REG_DWORD (DWORD Value)
Value: 30-300 seconds (decimal)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 18, 2003


Modify the Initial Retransmission Timeout (Windows NT/2000)

Modify the Initial Retransmission Timeout (Windows NT/2000)
Category: Home > Network > Protocols > TCP-IP

This parameter controls the initial retransmission timeout used by TCP on each new connection. It applies to the connection request (SYN) and to the first data segment(s) sent on each connection.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'InitialRtt' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | InitialRtt | REG_DWORD | 0x00000bb8 (3000) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters]
Name: InitialRtt
Type: REG_DWORD (DWORD Value)
Value: 0-65535 milliseconds (decimal)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 20, 2001


Specify the WinSock Database Files Location (Windows NT/2000/XP)

Specify the WinSock Database Files Location (Windows NT/2000/XP)
Category: Home > Network > Clients

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This parameter specifies the path to the standard internet database files (HOSTS, LMHOSTS, NETWORKS, PROTOCOLS) used by the Windows Sockets interface.

Open your registry and find the key below.

Create a new Expanded String value, or modify the existing value called 'DatabasePath' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This directory must be created and any files moved manually.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DatabasePath | REG_EXPAND_SZ | %SystemRoot%\system32\drivers\etc | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters]
Name: DatabasePath
Type: REG_EXPAND_SZ (Expanded String Value)
Value: Filename

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 26, 2002


Change TCP/IP Broadcast Address (Windows NT/2000)

Change TCP/IP Broadcast Address (Windows NT/2000)
Category: Home > Network > Protocols > TCP-IP

This setting allows Windows to be configured to use zeros-broadcasts (0.0.0.0) instead of ones-broadcasts (255.255.255.255). Most systems use ones-broadcasts, but some systems derived from BSD implementations use zeros-broadcasts.

Open your registry and find the key below. For Windows 2000 instead use the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ Tcpip\Parameters\Interfaces\[Adapter ID] key.

Create a new DWORD value called "UseZeroBroadcast" and set it to "1" to enable 0.0.0.0 broadcasts.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | UseZeroBroadcast | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\[Adapter Name]\Para... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\[Adapter Name]\
Parameters\Tcpip]
Name: UseZeroBroadcast
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = use 0.0.0.0 broadcast)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 20, 2001


Enable Source Routing on Token Ring Networks (Windows NT/2000)

Enable Source Routing on Token Ring Networks (Windows NT/2000)
Category: Home > Network > Protocols > TCP-IP

Setting this parameter to 1 will force TCP/IP to transmit ARP queries with source routing enabled on Token Ring networks. By default, the stack transmits ARP queries without source routing first and retries with source routing enabled if no reply was received.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'ArpAlwaysSourceRoute' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ArpAlwaysSourceRoute | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters]
Name: ArpAlwaysSourceRoute
Type: REG_DWORD (DWORD Value)
Value: (0 = false, 1 = true)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 21, 2001


Transmit Ethernet Packets Using 802.3 SNAP Encoding (Windows NT/2000)

Transmit Ethernet Packets Using 802.3 SNAP Encoding (Windows NT/2000)
Category: Home > Network > Protocols > TCP-IP

Enabling this setting forces TCP/IP to transmit Ethernet packets using 802.3 SNAP encoding. By default, the stack transmits packets in DIX Ethernet format. It will always receive both formats.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'ArpUseEtherSNAP' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ArpUseEtherSNAP | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters]
Name: ArpUseEtherSNAP
Type: REG_DWORD (DWORD Value)
Value: (0 = false, 1 = true)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 20, 2001


Specify the Default TCP/IP Type of Service (TOS) (Windows NT)

Specify the Default TCP/IP Type of Service (TOS) (Windows NT)
Category: Home > Network > Protocols > TCP-IP

This setting specifies the default type of service (TOS) for IP packets generated by the TCP/IP stack. This can be used to manage quality of service (QOS) throughout a network.

Open your registry and find the key below.

Create a new DWORD value called "DefaultTOS" and set it to the 8 bit number represent the default TOS for IP packets.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | DefaultTOS | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters]
Name: DefaultTOS
Type: REG_DWORD (DWORD Value)
Value: 0 - 255 (See RFC 791 for a definition of the values)

Related Tweaks

  • Specify the Default TCP/IP Type of Service (TOS) (Windows 95/98/Me)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 20, 2001


Specify the Default Time to Live for TCP/IP Packets (Windows NT/2000/XP)

Specify the Default Time to Live for TCP/IP Packets (Windows NT/2000/XP)
Category: Home > Network > Protocols > TCP-IP

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Specifies the default Time To Live (TTL) value set in the header of outgoing IP packets. The TTL determines the maximum amount of time an IP packet may live in the network without reaching its destination. It is effectively a limit on the number of routers an IP packet may pass through before being discarded.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'DefaultTTL' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | DefaultTTL | REG_DWORD | 0x00000080 (128) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters]
Name: DefaultTTL
Type: REG_DWORD (DWORD Value)
Value: 1-255 hops

Related Tweaks

  • Specify the Default TCP/IP Time to Live (Windows 95/98/Me)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 13, 2002


Enable Dead Gateway Detection (Windows NT/2000/XP)

Enable Dead Gateway Detection (Windows NT/2000/XP)
Category: Home > Network > Protocols > TCP-IP

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting specifies whether Windows should automatically detect and use an alternate gateway in the event of transmiting a segment several times without receiving a response.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'EnableDeadGWDetect' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | EnableDeadGWDetect | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters]
Name: EnableDeadGWDetect
Type: REG_DWORD (DWORD Value)
Value: (0 = false, 1 = true)

Related Tweaks

  • Enable Dead Gateway Detection (Windows 95/98/Me)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 20, 2002


Detect Black Hole Routers During Path MTU Discovery (Windows NT/2000/XP)

Detect Black Hole Routers During Path MTU Discovery (Windows NT/2000/XP)
Category: Home > Network > Protocols > TCP-IP

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Specifies whether the stack will attempt to detect Maximum Transmission Unit (MTU) routers that do not send back ICMP fragmentation-needed messages.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'EnablePMTUBHDetect' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | EnablePMTUBHDetect | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters]
Name: EnablePMTUBHDetect
Type: REG_DWORD (DWORD Value)
Value: (0 = false, 1 = true)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 14, 2002


Enable Path MTU Discovery (Windows NT/2000/XP)

Enable Path MTU Discovery (Windows NT/2000/XP)
Category: Home > Network > Protocols > TCP-IP

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Enabling the setting causes TCP to attempt to discover the Maximum Transmission Unit (MTU or largest packet size) over the path to a remote host. By discovering the Path MTU and limiting TCP segments to this size, TCP can eliminate fragmentation at routers along the path that connect networks with different MTUs.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'EnablePMTUDiscovery' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | EnablePMTUDiscovery | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters]
Name: EnablePMTUDiscovery
Type: REG_DWORD (DWORD Value)
Value: (0 = false, 1 = true)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 14, 2002


Specify the Router Buffer Size (Windows NT/2000/XP)

Specify the Router Buffer Size (Windows NT/2000/XP)
Category: Home > Network > Protocols > TCP-IP

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This parameter determines how much memory IP allocates to store packet data in the router packet queue. When this buffer space is filled, the router begins discarding packets at random from its queue.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'ForwardBufferMemory' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: Packet queue data buffers are 256 bytes in length, so the value of this parameter should be a multiple of 256. Multiple buffers are chained together for larger packets. The IP header for a packet is stored separately. This parameter is ignored and no buffers are allocated if the IP router is not enabled.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ForwardBufferMemory | REG_DWORD | 0x00012200 (74240) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters]
Name: ForwardBufferMemory
Type: REG_DWORD (DWORD Value)
Value: 0 - 0xFFFFFFFF Buffer Size in Bytes

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 6, 2002


Specify the Conformance Level for IP Multicast (Windows NT/2000/XP)

Specify the Conformance Level for IP Multicast (Windows NT/2000/XP)
Category: Home > Network > Protocols > TCP-IP

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This parameter determines to what extent the system supports IP multicasting and participates in the Internet Group Management Protocol, RFC 1112.

There are three levels or conformance:

  • Level 0: no support for IP multicasting
  • Level 1: support for sending but not receiving multicast IP datagrams
  • Level 2: full support for IP multicasting

Open your registry and find the key below.

Create a new DWORD value called "IGMPLevel" and set it to either 0, 1 or 2 accord to the level required above.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | IGMPLevel | REG_DWORD | 0x00000002 (2) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters]
Name: IGMPLevel
Type: REG_DWORD (DWORD Value)
Value: 0, 1 or 2 (Default = 2)

Related Tweaks

  • Specify the Conformance Level for IP Multicast (Windows 95/98/Me)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 20, 2002


Control Keep Alive Parameters (Windows NT/2000/XP)

Control Keep Alive Parameters (Windows NT/2000/XP)
Category: Home > Network > Protocols > TCP-IP

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

These settings control how Windows manages connection keep alive transmissions. Including the timeout before keepalives are sent and the interval between keepalive transmissions.

Open your registry and find the key below.

Create new DWORD value named "KeepAliveTime" and set it to equal the number of milliseconds to wait before sending keep alive packets (the default is 2 hours - 7,200,000 milliseconds).

Also create a new DWORD value called "KeepAliveInterval" and set it to equal the time in milliseconds between retransmissions of keepalives, once the KeepAliveTime has expired (the default is 1 second - 1000 milliseconds).

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | KeepAliveTime | REG_DWORD | 0x006DDD00 (7200000) | |
| |  | KeepAliveInterval | REG_DWORD | 0x000003e8 (1000) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters]
Name: KeepAliveTime, KeepAliveInterval
Type: REG_DWORD (DWORD Value)

Related Tweaks

  • Control Keep Alive Parameters (Windows 95/98/Me)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 20, 2002


Specify the Router Packet Queue Size (Windows NT/2000/XP)

Specify the Router Packet Queue Size (Windows NT/2000/XP)
Category: Home > Network > Protocols > TCP-IP

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This parameter determines the number of IP packet headers allocated for the router packet queue. When all headers are in use, the router will begin to discard packets at random from the queue.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NumForwardPackets' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NumForwardPackets | REG_DWORD | 0x00000032 (50) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters]
Name: NumForwardPackets
Type: REG_DWORD (DWORD Value)
Value: 1 - 0xFFFFFFFF

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 20, 2002


Specify the Maximum Number of TCP/IP Connections (Windows NT/2000)

Specify the Maximum Number of TCP/IP Connections (Windows NT/2000)
Category: Home > Network > Protocols > TCP-IP

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This parameter specifies the maximum number of connections that TCP may have open simultaneously.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'TcpNumConnections' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | TcpNumConnections | REG_DWORD | 0x00fffffe (16777214) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters]
Name: TcpNumConnections
Type: REG_DWORD (DWORD Value)
Value: 0 - 0xfffffe

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 14, 2002


Control Windows Treatment of Priority TCP/IP Data (Windows NT/2000/XP)

Control Windows Treatment of Priority TCP/IP Data (Windows NT/2000/XP)
Category: Home > Network > Protocols > TCP-IP

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This parameter determines whether TCP uses the RFC 1122 specification for urgent data or the mode used by BSD- derived systems. The two mechanisms interpret the urgent pointer in the TCP header and the length of the urgent data differently.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'TcpUseRFC1122UrgentPointer' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | TcpUseRFC1122UrgentPointer | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters]
Name: TcpUseRFC1122UrgentPointer
Type: REG_DWORD (DWORD Value)
Value: (0 = false, 1 = use RFC1122 method)

Related Tweaks

  • Control Windows Treatment of Priority TCP/IP Data (Windows 95/98/Me)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 20, 2002


Control Selective Acknowledgement (SACK) Operation (Windows NT/2000/XP)

Control Selective Acknowledgement (SACK) Operation (Windows NT/2000/XP)
Category: Home > Network > Protocols > TCP-IP

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This parameter controls whether or not Selective ACK (SACK - RFC 2018) support is enabled. With SACK enabled (default), a packet or series of packets can be dropped, and the receiver informs the sender which data has been received, and where there may be "holes" in the data.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'SackOpts' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SackOpts | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters]
Name: SackOpts
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 20, 2002


Control RFC 1323 Time Stamp and Window Scaling (Windows NT/2000/XP)

Control RFC 1323 Time Stamp and Window Scaling (Windows NT/2000/XP)
Category: Home > Network > Protocols > TCP-IP

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls RFC 1323 timestamps and window scaling options. Timestamps and Window scaling are enabled by default, but can be manipulated with flag bits.

This feature has four modes of operation:

  • 0 = disable RFC 1323 options
  • 1 = window scale enabled only
  • 2 = time stamps enabled only
  • 3 = both options enabled
Open your registry and find the key below.

Create a new DWORD value named "Tcp1323Opts" and set it to equal 0, 1, 2 or 3 depending on the required mode listed above.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Tcp1323Opts | REG_DWORD | 0x00000003 (3) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters]
Name: Tcp1323Opts
Type: REG_DWORD (DWORD Value)
Value: 0,1,2 or 3

Related Tweaks

  • Control RFC 1323 Time Stamp and Window Scaling Options (Windows 95/98/Me)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 20, 2002


Specify System-wide TCP Receive Window Size (Windows 2000/XP)

Specify System-wide TCP Receive Window Size (Windows 2000/XP)
Category: Home > Network > Protocols > TCP-IP

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

The TcpWindowSize parameter can be used to set the receive window on a per-interface basis. This parameter can be used to set a global limit for the TCP window size on a system-wide basis.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'GlobalMaxTcpWindowSize' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | GlobalMaxTcpWindowSize | REG_DWORD | 0x00007fff (32767) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters]
Name: GlobalMaxTcpWindowSize
Type: REG_DWORD (DWORD Value)
Value: 0–0x3FFFFFFF

Related Tweaks

  • Optimize the Windows TCP/IP Window Size (Windows NT/2000)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 14, 2002


Specify System-wide TCP Receive Window Size (Windows 98)

Specify System-wide TCP Receive Window Size (Windows 98)
Category: Home > Network > Protocols > TCP-IP

The TcpWindowSize parameter can be used to set the receive window on a per-interface basis. This parameter can be used to set a global limit for the TCP window size on a system-wide basis.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, called 'GlobalMaxTcpWindoSize' and edit the value according to the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This value is not a spelling mistake, Windows 98 contains a TCP stack bug which looks for the wrong value name (see KB article Q239731) instead of "GlobalMaxTcpWindowSize".

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | GlobalMaxTcpWindoSize | REG_DWORD | 0x00007fff (32767) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\VxD\MSTCP\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\VxD\MSTCP\
Parameters]
Name: GlobalMaxTcpWindoSize
Type: REG_DWORD (DWORD Value)

Related Tweaks

  • Specify System-wide TCP Receive Window Size (Windows 2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 21, 2001


Modify the Number of Duplicate ACKs for Fast Retransmit (Windows 2000/XP)

Modify the Number of Duplicate ACKs for Fast Retransmit (Windows 2000/XP)
Category: Home > Network > Protocols > TCP-IP

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This parameter determines the number of duplicate ACKs that must be received for the same sequence number of sent data before "fast retransmit" is triggered to resend the segment that has been dropped in transit.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'TcpMaxDupAcks' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | TcpMaxDupAcks | REG_DWORD | 0x00000002 (2) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters]
Name: TcpMaxDupAcks
Type: REG_DWORD (DWORD Value)
Value: 1-3 (default =2)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 14, 2002


Command Line Option to Reboot or Log Off Windows (Windows 95/98/Me)

Command Line Option to Reboot or Log Off Windows (Windows 95/98/Me)
Category: Home > Windows > Login and Authentication

This command allows you to create a shortcut or execute from a batch file a Windows DLL that will bypass the standard Start Menu method of shutdown and initiate a Log Off, Shutdown or Restart.

For Windows 98 & Me
Either execute the following command from a batch file or create a new shortcut, by right-clicking on the descktop and selecting New -> Shortcut. With the command:

C:\WINDOWS\RUNDLL32.EXE shell32.dll,SHExitWindowsEx x

Where x is either 0, 1, 2, 4 or 8 (or a combination) based on the following table:

0 - Log off: Shuts down all running processes, then logs the user off.
1 - Shutdown: Shuts down the system to a point at which it is safe to turn off the power. All file buffers have been flushed to disk, and all running processes have stopped.
2 - Reboot: Shut down and restart the system.
4 - Force (Win98 Only): Forces processes to terminate. When this flag is set, Windows does not query running applications to inform them that Windows is shutting down. This can cause the applications to lose data, therefore, you should only use this flag in an emergency.
8 - Power Off (Win98 Only): Shuts down the system and turns off the power. The system must support the power-off feature.

Click Next and enter the name you want to call the icon (e.g. Shutdown).

For Windows 95
Repeat the steps above but use the command below for the target.

C:\WINDOWS\Rundll32.exe User,ExitWindows

Note: The values above can be combined together to achieve different results. For example, to restart Windows forcefully, without querying any running programs, use the following command line: "rundll32.exe shell32.dll,SHExitWindowsEx 6" (i.e. 2 + 4)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 29, 2001


Disable File Download in Internet Explorer (All Windows)

Disable File Download in Internet Explorer (All Windows)
Category: Home > Software > Internet Explorer > Security

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allows you to restrict the ability to download files using Internet Explorer.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called '1803' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | 1803 | REG_DWORD | 0x00000003 (3) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Set... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\
Internet Settings\Zones\3]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\
Internet Settings\Zones\3]
Name: 1803
Type: REG_DWORD (DWORD Value)
Value: (0 = downloads enabled, 3 = downloads disabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 3, 2002


Disable the Windows Key (Windows NT/2000/XP)

Disable the Windows Key (Windows NT/2000/XP)
Category: Home > Hardware > Mice and Keyboards

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak disables the Windows key that is found between the Ctrl and Alt keys on a Windows enhanced keyboard.

Open your registry and find the key below.

Create a new Binary value, or modify the existing value called 'Scancode Map' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Scancode Map | REG_BINARY | 00 00 00 00 00 00 00... | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
Name: Scancode Map
Type: REG_BINARY (Binary Value)
Value: 00 00 00 00 00 00 00 00 03 00 00 00 00 00 5B E0 00 00 5C E0 00 00 00 00

Related Tweaks

  • Disable the Windows Hotkeys (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 11, 2002


Remove the Eject Option from the Start Menu (Windows 2000)

Remove the Eject Option from the Start Menu (Windows 2000)
Category: Home > Hardware

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak allows you to remove the "Eject PC" option from the Windows 2000 Start menu.

By setting the "EjectableDocks" value to 0x00000000 (0) in the key below the "Eject PC" option will be removed from the start menu next time you log into the system.

As this is a dynamic value it is detected and updated automatically by the system whenever the computer is restarted. To maintain it's state set at "0" a reg file must be imported automatically on every restart.

To automatically run this tweak on startup, save the noeject.reg file to your Windows directory. Then add a new string value called "NoEject" at [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run] and set the value to "regedit /s c:\winnt\noeject.reg" (changing the filename and path as needed).

Restart your computer for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | EjectableDocks | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\IDConfigDB\CurrentDo... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\IDConfigDB\
CurrentDockInfo]
Name: EjectableDocks
Type: REG_DWORD (DWORD Value)
Value: (0 = disable Eject PC, 1 = default)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 20, 2002


Disable Menu Bars and the Start Button (Windows 95/98/Me/2000/XP)

Disable Menu Bars and the Start Button (Windows 95/98/Me/2000/XP)
Category: Home > Security > Start Menu and Taskbar

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak can be used to disable the menu bar in standard Windows applications and the Start Button.

Open your registry and find the key below.

Rename the key by placing a dash "-" in front of the GUID (i.e. {-5b4dae26-b807-11d0-9815-00c04fd91972}).

Restart Windows for the change to take effect.

Note: This tweak may cause a problem with the taskbar appearance when Internet Explorer 5.0 or greater is installed. If you experience a problem please reverse the tweak to restore the original setting.

Settings:
System Key: [HKEY_CLASSES_ROOT\CLSID\{5b4dae26-b807-11d0-9815-00c04fd91972}]

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 14, 2003


Disable the New Menu Item (All Windows)

Disable the New Menu Item (All Windows)
Category: Home > Security > Desktop and Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak can be used to disable the ability to use the New menu item to create new objects using explorer.

Open your registry and find the key below.

Rename the key by placing a dash "-" in front of the GUID (i.e. {-D969A300-E7FF-11d0-A93B-00A0C90F2719}).

Restart Windows for the change to take effect.

Settings:
System Key: [HKEY_CLASSES_ROOT\CLSID\{D969A300-E7FF-11d0-A93B-00A0C90F2719}]

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 14, 2002


Modifying the Autocheck Time-out Value (Windows NT/2000/XP)

Modifying the Autocheck Time-out Value (Windows NT/2000/XP)
Category: Home > Windows > File System > Maintenance

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When Windows is not shutdown correctly it will perform an AutoCheck using CHKDSK on the next restart. This setting controls the time delay before running Autochk or whether it is run at all.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'AutoChkTimeOut' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AutoChkTimeOut | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager]
Name: AutoChkTimeOut
Type: REG_DWORD (DWORD Value)
Value: Time in Seconds or 0 to disable (default = 10)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 15, 2002


Hide Control Panel Applets (Windows 95/98/Me)

Hide Control Panel Applets (Windows 95/98/Me)
Category: Home > Security > Control Panel

This tweak allows you to show or hide any of the applets found in the Windows Control Panel.

Open CONTROL.INI (usually found in the C:\WINDOWS) and add the following lines under the "[don't load]" subsection. If the "[don't load]" section doesn't already exist then create it be adding it on a new line at the end of the file.

For each control panel applet to be hidden add a new line with text in the format "applet.cpl=no" (e.g. fax.cpl=no).

Common Control Panel Applets:

  • access.cpl - Accessibility Applet
  • appwiz.cpl - Add/Remove Programs Applet
  • console.cpl - Console Applet
  • timedate.cpl - Date and Time Applet
  • desk.cpl - Display Applet
  • fax.cpl - Fax Applet
  • hdwwiz.cpl - Hardware Wizard Applet
  • irprops.cpl - Infrared Port Applet
  • intl.cpl - International and Regional Applet
  • inetcpl.cpl - Internet Settings Applet
  • joy.cpl - Joystick Applet
  • liccpa.cpl - Licensing Applet
  • main.cpl - Mouse and Keyboard Applet
  • mlcfg32.cpl - Mail Applet
  • mmsys.cpl - Sound and Multimedia Applet
  • modem.cpl - Modem and Phone Applet
  • ncpa.cpl - Network and connectivity Applet
  • netcpl.cpl - Network and Dial-up Connectivity Applet
  • nwc.cpl - Netware Client Applet
  • odbccp32.cpl - ODBC Applet
  • devapps.cpl - PC Card Applet
  • ports.cpl - Ports Applet
  • powercfg.cpl - Power Management Applet
  • sticpl.cpl - Scanner and Camera Applet
  • srvmgr.cpl - Server Manager Applet
  • sapi.cpl - Speech Properties Applet
  • sysdm.cpl - System Applet
  • telephon.cpl - Telephony Applet
  • tweakui.cpl - TweakUI Applet
  • nusrmgr.cpl - User Manager Applet
  • wspcpl32.cpl - WSP Client Applet
  • quicktime.cpl - QuickTime Applet
  • S32LUCP1.cpl - Norton Live Update Applet
  • cpqmgmt.cpl - Compaq Insight Agents Applet
Exit the registry and restart Windows for the change to take effect.

Related Tweaks

  • Hide Control Panel Applets (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: July 30, 2001


Disable ICQ Auto Update (All Windows)

Disable ICQ Auto Update (All Windows)
Category: Home > Software

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When ICQ 2000 starts it checks whether a new update is available, depending on your network connection this may increase the time it takes to load. This setting lets you disable that check function.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'Auto Update' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Auto Update | REG_SZ | "No" | |
-
| HKEY_CURRENT_USER\Software\Mirabilis\ICQ\DefaultPrefs |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Mirabilis\ICQ\DefaultPrefs]
Name: Auto Update
Type: REG_SZ (String Value)
Value: "Yes" or "No"

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 27, 2002


Increase Transfer Rates with ICS and Broadband Connections (Windows 98)

Increase Transfer Rates with ICS and Broadband Connections (Windows 98)
Category: Home > Network > Internet and Remote Access

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

If you are using Internet Connection Sharing ("ICS") with a broadband connection then remove this key to increase the performance.

Open your registry and find the key below.

Delete the value named "InternetMTU" and restart Windows for the change to take effect.

Note: This will only increase the internal performance with a broadband Internet connection (i.e. Cable or DSL). Do not use this tweak with modem connections.

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\ICSharing\Settings\
General]
Name: InternetMTU

Related Tweaks

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 22, 2002


Change Drive Name and Icon (All Windows)

Change Drive Name and Icon (All Windows)
Category: Home > Hardware > Disk Drives

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak allows you to change the name and icon shown in Explorer for a specific drive letter.

Open your registry and find the key below. If the key does not already exist then create it.

Within the main key create a new sub-key with a single letter representing the drive letter of the drive to be modified. (e.g. [HKEY...\DriveIcons\D])

Within the drive letter key create another sub-key called "DefaultIcon" (e.g. [HKEY...\DriveIcons\D\DefaultIcon]) and set the "(Default)" value to equal the fully qualified name of the icon file. If the file contains more that one icon follow it with a comma and the zero-based index of the icon (e.g. "c:\icons\myicons.dll,4").

Create another sub-key within the drive letter key called "DefaultLabel" (e.g. [HKEY...\DriveIcons\D\DefaultLabel]) and set it's "(Default)" value to equal the label for the drive letter (e.g. "My ZIP Drive").

For example:
HKEY_LOCAL_MACHINE
Software
Microsoft
Windows
CurrentVersion
Explorer
DriveIcons
D
DefaultIcon
(Default) = c:\icons\myicons.dll,4
DefaultLabel
(Default) = My ZIP Drive

You may need to restart Windows for the change to take effect, or press F5 to refresh My Computer.

Note: The "DefaultLabel" value only works with Windows 2000 and higher.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\
DriveIcons]
Name: Default
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: July 4, 2003


Speed-up Browsing Remote Computers (Windows 2000/XP)

Speed-up Browsing Remote Computers (Windows 2000/XP)
Category: Home > Network > Clients

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When you browse a Windows 95, 98 or Me machine from a Windows 2000 or XP computer extra time is taken to determine if any scheduled tasks or printers are enabled on the destination computer.

Open your registry and find the key below.

To disable checking for scheduled tasks delete the {D6277990-4C6A-11CF-8D87-00AA0060F5BF} sub-key.

To disable checking for printers delete the {2227A280-3AEA-1069-A2DE-08002B30309D} sub-key.

The change should take effect immediately.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\
RemoteComputer\NameSpace]

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: July 24, 2002


Control Security Settings Feature in Outlook 98 (All Windows)

Control Security Settings Feature in Outlook 98 (All Windows)
Category: Home > Software > Microsoft Office > Outlook

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

The Outlook 98 service packs introduced a security feature that disabled the ability to directly open executable (EXE) file. This tweak allows you to disable that functionality.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'CheckAdminSettings' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | CheckAdminSettings | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Policies\Microsoft\Security |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Policies\Microsoft\Security]
System Key: [HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Security]
Name: CheckAdminSettings
Type: REG_DWORD (DWORD Value)
Value: (0 = Lock-down mode, 1 = Custom Security Settings)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 20, 2002


Allow Portables to Undock Before Logon (Windows XP)

Allow Portables to Undock Before Logon (Windows XP)
Category: Home > Security > Login and Authentication

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether users with portable computers have the option to undock the system before they have logged onto the computer.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'UndockWithoutLogon' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | UndockWithoutLogon | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System |
-

Settings:
User Key: [HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\
System]
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\
System]
Name: UndockWithoutLogon
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Related Tweaks

  • Enable Shutdown from Authentication Dialog Box (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 20, 2002


Group Similar Taskbar Buttons (Windows XP)

Group Similar Taskbar Buttons (Windows XP)
Category: Home > Windows > Start Menu and Taskbar > Taskbar

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting is used to control whether similar items are grouped together as a single item or are displayed as individual buttons on the taskbar.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'TaskbarGlomming' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | TaskbarGlomming | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Adv... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
Advanced]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\
Advanced]
Name: TaskbarGlomming
Type: REG_DWORD (DWORD Value)
Value: (0 = not grouped, 1 = grouped)

Related Tweaks

  • Change the Taskbar Group Size (Windows XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 8, 2002


Lock the Size and Position of the Taskbar (Windows Me/XP)

Lock the Size and Position of the Taskbar (Windows Me/XP)
Category: Home > Windows > Start Menu and Taskbar > Taskbar

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting is used to lock or unlock the size and position of the taskbar on the Windows desktop.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'TaskbarSizeMove' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | TaskbarSizeMove | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Adv... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
Advanced]
Name: TaskbarSizeMove
Type: REG_DWORD (DWORD Value)
Value: (0 = locked, 1 = unlocked)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 6, 2001


Automatically Hide Inactive Tray Icons (Windows XP)

Automatically Hide Inactive Tray Icons (Windows XP)
Category: Home > Windows > Start Menu and Taskbar > Taskbar

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether running tray programs should be hidden automatically when they are not active.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'EnableAutoTray' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | EnableAutoTray | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer]
Name: EnableAutoTray
Type: REG_DWORD (DWORD Value)
Value: (0 = display inactive icons, 1 = hide inactive icons)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 14, 2002


Control the Font Smoothing Mode (Windows XP)

Control the Font Smoothing Mode (Windows XP)
Category: Home > Windows > Appearance > Fonts and Icons

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls what type of font smoothing is used. This allows you to select either Microsoft ClearType or the standard anti-aliased fonts.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'FontSmoothingType' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | FontSmoothingType | REG_DWORD | 0x00000002 (2) | |
-
| HKEY_CURRENT_USER\Control Panel\Desktop |
-

Settings:
User Key: [HKEY_CURRENT_USER\Control Panel\Desktop]
Name: FontSmoothingType
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = standard, 2 = ClearType)

Related Tweaks

  • Enable Font Smoothing (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 6, 2001


Change the Transition Effect for Menus and Tooltips (Windows XP)

Change the Transition Effect for Menus and Tooltips (Windows XP)
Category: Home > Windows > Appearance > Effects and Menus

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This value controls which type of transitional effect to use when displaying Menus and Tooltips, allowing you to choose either the fade effect or the scroll effect.

Open your registry and find the key below.

Double-click on the "UserPreferencesMask" value to open the Edit Binary Value screen. Press the right arrow to move over to the second set of digits. Press the delete key to remove the digits and type either '28' for the scroll effect or '3e' for the fade effect.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | UserPreferencesMask | REG_BINARY | 3e 3e 01 80 | |
-
| HKEY_CURRENT_USER\Control Panel\Desktop |
-

Settings:
User Key: [HKEY_CURRENT_USER\Control Panel\Desktop]
Name: UserPreferencesMask
Type: REG_BINARY (Binary Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 20, 2002


Clear the Netmeeting Call History (All Windows)

Clear the Netmeeting Call History (All Windows)
Category: Home > Security > Privacy

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak allows you to clear the stored call history in the Netmeeting drop down list.

Open your registry and delete the key below.

Restart Netmeeting for the change to take effect.

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Conferencing\UI\CallMRU]

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 27, 2002


Configuring Netmeeting to Use a Gatekeeper (All Windows)

Configuring Netmeeting to Use a Gatekeeper (All Windows)
Category: Home > Software > Netmeeting

These settings allow you to configure Netmeeting to use a H.323 gatekeeper to manage call addressing, billing and security.

Open your registry and find the key below.

Create a new string value called "Gatekeeper" and set it to equal the IP address or hostname of the gatekeeper.

Create a new binary value called "CallingMethod" and set it to "01 00 00 00" to enable the gatekeeper or "00 00 00 00" to disable it.

If your gatekeeper requires you to log on using an account name or phone number then also create the following value:

Create a new binary value called "GateKeeperAddressing" and set it to "01 00 00 00" to log on using a phone number, "02 00 00 00" to log on using a account name, or "03 00 00 00" to log on using both a phone number and an account name.

Specify an account name or phone number using this setting.

Restart Netmeeting for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | CallingMethod | REG_BINARY | 01 00 00 00 | |
| |  | Gatekeeper | REG_SZ | "192.168.1.1" | |
| |  | GateKeeperAddressing | REG_BINARY | "03 00 00 00" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Conferencing |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Conferencing]
Name: Gatekeeper, CallingMethod, GateKeeperAddressing

Related Tweaks

  • Configure Netmeeting to Use a Gateway (All Windows)
  • Specify the User Parameters for Netmeeting (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 8, 2001


Configure Netmeeting to Use a Gateway (All Windows)

Configure Netmeeting to Use a Gateway (All Windows)
Category: Home > Software > Netmeeting

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

These settings allow you to configure Netmeeting to use a H.323 gateway to place calls to a standard telephone over the PSTN.

Open your registry and find the key below.

Create a new binary value called "Enable H.323 Gateway" and set it to "01 00 00 00" to enable the gateway or "00 00 00 00" to disable it.

Create a new string value called "H.323 Gateway" and set it to the IP address or hostname of the H.323 gateway.

Restart Netmeeting for the changes to take effect.

Note: Netmeeting can not be configured to use both a gatekeeper and gateway at the same time.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Enable H.323 Gateway | REG_BINARY | 01 00 00 00 | |
| |  | H.323 Gateway | REG_SZ | "192.168.1.1" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Conferencing |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Conferencing]
Name: Enable H.323 Gateway, H.323 Gateway

Related Tweaks

  • Configuring Netmeeting to Use a Gatekeeper (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: July 24, 2002


Specify the User Parameters for Netmeeting (All Windows)

Specify the User Parameters for Netmeeting (All Windows)
Category: Home > Software > Netmeeting

These values allow you to specify the user parameters, such as name, e-mail and account, for use in Netmeeting.

Open your registry and find the key below.

Create a new string value, or modify the existing values, for each item listed in the table below and set the value data accordingly.

  • Account - Account name (used to log onto gatekeeper)
  • Comments - General comments field
  • Email Name - E-mail Address
  • First Name
  • Last Name
  • Location
  • Phonenum - Phone number (used to log onto gatekeeper)
  • User Name - Displayed when connecting to other H.323 devices

Restart Netmeeting for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Account | REG_SZ | "jdoe" | |
| |  | Comments | REG_SZ | "Staff Member" | |
| |  | Email Name | REG_SZ | "jdoe@company.com" | |
| |  | First Name | REG_SZ | "Joan" | |
| |  | Last Name | REG_SZ | "Doe" | |
| |  | Location | REG_SZ | "New York, NY" | |
| |  | Phonenum | REG_SZ | "212-555-5555" | |
| |  | User Name | REG_SZ | "jdoe" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\User Location Service\Client |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\User Location Service\Client]
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 8, 2001


Repair Internet Explorer Printing Errors

Repair Internet Explorer Printing Errors
Category: Home > Windows > Troubleshooting > Repair

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

If you are using Internet Explorer and are experiencing blank pages when you print or incorrectly displayed print preview information then this tweak may resolve the problem.

Open your registry and find the key below.

Find the value named "Use StyleSheets" and either delete it, or set it to equal "Yes".

Restart Internet Explorer for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Use StyleSheets | REG_SZ | "Yes" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
Name: Use StyleSheets
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 9, 2002


Customize the Windows Logon and Security Dialog Title (Windows NT/2000/XP)

Customize the Windows Logon and Security Dialog Title (Windows NT/2000/XP)
Category: Home > Security > Login and Authentication

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allows you to add additional text to the title of the standard Windows Logon and Windows Security dialog boxes.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'Welcome' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Welcome | REG_SZ | "by WinGuides.com" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: Welcome
Type: REG_SZ (String Value)
Value: Text to display

Related Tweaks

  • Legal Notice Dialog Box Before Logon (All Windows)
  • Change the Message Shown on the Logon Box (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 30, 2002


Disable Mapped Drive Reconnect Warning (Windows 95/98/Me)

Disable Mapped Drive Reconnect Warning (Windows 95/98/Me)
Category: Home > Network

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting is used to disable the mapped drive reconnect warning shown at startup when a network drive is unavailable.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'RestoreDiskChecked' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | RestoreDiskChecked | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_CURRENT_USER\Network |
-

Settings:
User Key: [HKEY_CURRENT_USER\Network]
Name: RestoreDiskChecked
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 26, 2002


Change the Maximum Number of AOL Buddies (All Windows)

Change the Maximum Number of AOL Buddies (All Windows)
Category: Home > Software

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak allows you to increase (or decrease) the maximum number of AOL buddies allowed from the default of 160 on AOL Instant Messenger.

Open your registry and find the key below.

Edit the exisiting value named MaxBuddies and set it to the required maximum number of buddies. The default is 160.

Restart AOL Instant Messenger for the change to take effect.

Note: This does not work with older v4.3.x clients which will automatically change the value back to 160.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | MaxBuddies | REG_DWORD | 0x0000012c (300) | |
-
| HKEY_CURRENT_USER\Software\America Online\AOL Instant Messenger (TM)\Cur... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\America Online\AOL Instant Messenger (TM)\
CurrentVersion\Buddy]
Name: MaxBuddies
Type: REG_DWORD (DWORD Value)
Value: 1-999 (decimal)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 27, 2002


Modify the Outlook 2002 and Office XP Attachment Restrictions (All Windows)

Modify the Outlook 2002 and Office XP Attachment Restrictions (All Windows)
Category: Home > Software > Microsoft Office > Outlook

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Microsoft Outlook 2002, included with Office XP, introduced new restrictions to stop possible unsafe e-mail attachments from being opened or saved. This tweak allows you to override those restrictions.

Open your registry and find the key below.

Create a new String value, or modify the existing value, called "Level1Remove" and set it to equal a semi-colon separated list of the extension you want to allow.

Restart Outlook for the change to take effect.

Note: Any files with the following extensions are normally prohibited from being opened or saved when received as e-mail attachments: "ade, adp, asx, bas, bat, chm, cmd, com, cpl, crt, exe, hlp, hta, inf, ins, isp, js, jse, lnk, mda, mdb, mde, mdz, msc, msi, msp, mst, pcd, pif, prf, reg, scf, scr, sct, shb, shs, url, vb, vbe, vbs, wsc, wsf, wsh"

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Level1Remove | REG_SZ | "bat;exe;hlp" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Outlook\Security |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Outlook\Security]
Name: Level1Remove
Type: REG_SZ (String Value)

Related Tweaks

  • Manage Attachment Security in Outlook (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 13, 2002


Optimize Broadband PPPoE Connections (Windows Me)

Optimize Broadband PPPoE Connections (Windows Me)
Category: Home > Network > Internet and Remote Access

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting optimized the IP MTU value so that there is reduced packet fragmentation when using a broadband connection with PPPoE (Point-to-Point Protocol over Ethernet).

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'IPMTU' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | IPMTU | REG_SZ | 1492 | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans\0000 |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\NetTrans\0000]
Name: IPMTU
Type: REG_SZ (String Value)
Value: 1492

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 30, 2002


Optimize the System Cache Size (Windows NT/2000/XP)

Optimize the System Cache Size (Windows NT/2000/XP)
Category: Home > Windows > File System > Caching and Memory

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether the system cache is optimized for a Desktop computer or network server. Network servers usually require more memory dedicated to file caching, while desktop computers require more memory for running software applications.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'LargeSystemCache' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: Some programs, such as SQL Server and Exchange Server, will set this value during an installation and override the change.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | LargeSystemCache | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\ Session Manager\Mem... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\ Session Manager\
Memory Management]
Name: LargeSystemCache
Type: REG_DWORD (DWORD Value)
Value: "0" for Desktops; "1" for Servers

Related Tweaks

  • Optimize the Windows Server Service (Windows NT/2000/XP)
  • Manage File System Caching Memory (Windows NT/2000)
  • Improve Core System Performance (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 28, 2003


Automatic Boot Disk Optimization (Windows XP)

Automatic Boot Disk Optimization (Windows XP)
Category: Home > Windows > File System > Maintenance

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows XP includes a new feature that will automatically optimize the the disks on boot if required. This setting controls whether this feature is enabled.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'Enable' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Enable | REG_SZ | "Y" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Dfrg\BootOptimizeFunction |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Dfrg\BootOptimizeFunction]
Name: Enable
Type: REG_SZ (String Value)
Value: (Y = enabled, N = disabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: July 24, 2002


Specify the Response Time for Hung Applications (All Windows)

Specify the Response Time for Hung Applications (All Windows)
Category: Home > Windows > Startup and Shutdown

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls the amount of time to wait for a response from a hung application before the system task manager automatically terminates the task.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'HungAppTimeout' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | HungAppTimeout | REG_SZ | "1000" | |
-
| HKEY_CURRENT_USER\Control Panel\Desktop |
-

Settings:
User Key: [HKEY_CURRENT_USER\Control Panel\Desktop]
System Key: [HKEY_USERS\.DEFAULT\Control Panel\Desktop]
Name: HungAppTimeout
Type: REG_SZ (String Value)
Value: Time in milliseconds (1000 = 1 second)

Related Tweaks

  • Automatically Ending Hung Applications (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 19, 2002


Modify the Internet Time Synchronization Servers (Windows XP)

Modify the Internet Time Synchronization Servers (Windows XP)
Category: Home > Windows > System > Services

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows XP includes a new feature that allows it to synchronize the system clock from atomic clocks available on the Internet. This setting lets you add new servers and change the default server used.

Open your registry and find the key below.

To add a new NTP server simply create a new string value and name it the next sequential number (e.g. '3'). Set the data of the new value to equal the hostname or IP address of the server.

You can also change the default server by setting the value of "(Default)" to the entry number of the required server.

Changes will take effect on the next use of the Internet time feature.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | "3" | |
| |  | 1 | REG_SZ | "time.windows.com" | |
| |  | 2 | REG_SZ | "time.nist.gov" | |
| |  | 3 | REG_SZ | "time.yourisp.com" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\DateTime\Se... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\DateTime\
Servers]
Name: (Default)
Type: REG_SZ (String Value)
Value: Server Hostname or IP Address

Related Tweaks

  • Modify the Internet Time Synchronization Schedule (Windows XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 15, 2002


Disable the Splash Screen on Adaptec DirectCD

Disable the Splash Screen on Adaptec DirectCD
Category: Home > Software

The setting allows you to disable the splash screen shown when launching Adaptec DirectCD.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'StartupBanner' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | StartupBanner | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Adaptec\DirectCD\[Version] |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Adaptec\DirectCD\[Version]]
Name: StartupBanner
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = show splash)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 20, 2001


Change Internet Explorer to Appear as a Different Version (Pocket PC)

Change Internet Explorer to Appear as a Different Version (Pocket PC)
Category: Home > Software > Windows CE

These settings allows you to change the way Pocket Internet Explorer appears to remote web sites. As some web site base the availability of SSL and other display parameters on this version information.

Open your registry and find the key below.

To make your browser appear to be Internet Explorer 6.0, running on Windows 2000 change the following values.

Change the value of (Default) to equal "Mozilla/4.0", change the value of Version to equal "MSIE 6.0" and the value of Platform to equal "Windows NT 5.0".

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | "Mozilla/4.0" | |
| |  | Version | REG_SZ | "MSIE 6.0" | |
| |  | Platform | REG_SZ | "Windows NT 5.0" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Se... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\
Internet Settings\User Agent]
Name: (Default), Version, Platform
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 20, 2001


Control Windows Animation on Handheld Devices (Pocket PC)

Control Windows Animation on Handheld Devices (Pocket PC)
Category: Home > Software > Windows CE

The animation feature can make animated Windows look good, but it can also substantially slow down your handheld device. This setting allows you to control whether the function is enabled or disabled.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'Animate' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Animate | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\GWE |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\GWE]
Name: Animate
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 20, 2001


Modify the Graphic Cache Size (Pocket PC)

Modify the Graphic Cache Size (Pocket PC)
Category: Home > Software > Windows CE

This setting controls the size of the glyph cache, by increasing this value you can increase graphics rendering speed by several times.

Open your registry and find the key below. Create a new sub-key called "GlyphCache".

Within the new sub-key create a new DWORD value named "Limit" and set it to equal "32768".

Reset your device for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Limit | REG_DWORD | 0x00008000 (32768) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\GDI |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\GDI]
Name: Limit
Type: REG_DWORD (DWORD Value)
Value: Size (Default = 8192)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 20, 2001


Automatically Hide the Taskbar (Pocket PC)

Automatically Hide the Taskbar (Pocket PC)
Category: Home > Software > Windows CE

This setting controls whether the taskbar should be automatically hidden when not being accessed.

Open your registry and find the key below. If it does not exist then create it.

Set the value of Default to equal either "0" or "1" as shown below.

Rest your device for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | "1" | |
-
| HKEY_LOCAL_MACHINE\Software\Microsoft\Shell\AutoHide |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Shell\AutoHide]
Name: (Default)
Type: REG_SZ (String Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 20, 2001


Control Script Errors on Pocket Internet Explorer (Pocket PC)

Control Script Errors on Pocket Internet Explorer (Pocket PC)
Category: Home > Software > Windows CE

This setting allow you to control whether script errors generate a warning message on Pocket Internet Explorer.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'ShowScriptErrors' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ShowScriptErrors | REG_SZ | "1" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
Name: ShowScriptErrors
Type: REG_SZ (String Value)
Value: (0 = disabled, 1 = show errors)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 20, 2001


Enable ClearType Technology (Pocket PC)

Enable ClearType Technology (Pocket PC)
Category: Home > Software > Windows CE

This setting controls the use of Clear Type text when rendering HTML documents with Pocket Internet Explorer.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'ClearTypeText' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ClearTypeText | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Set... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\
Internet Settings]
Name: ClearTypeText
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 20, 2001


Control Internet Explorer Error Reporting (All Windows)

Control Internet Explorer Error Reporting (All Windows)
Category: Home > Software > Internet Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allows you to control whether the error reporting tool, which reports browser debugging errors to Microsoft, is active in Internet Explorer 6.0.

Open your registry and find the key below.

Create a new DWORD value called "IEWatsonDisabled" and set it to "1". Create another DWORD value called "IEWatsonEnabled" and set it to "0".

Restart Internet Explorer for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | IEWatsonDisabled | REG_DWORD | 0x00000001 (1) | |
| |  | IEWatsonEnabled | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main]
Name: IEWatsonDisabled, IEWatsonEnabled
Type: REG_DWORD (DWORD Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 16, 2001


Disable the Recycle Bin (Windows 98/Me/2000/XP)

Disable the Recycle Bin (Windows 98/Me/2000/XP)
Category: Home > Windows > File System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting is used to disable the use of the recycle bin and permanently remove all deleted items instead. This enables the same functionality as holding the Shift key while deleting items.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NukeOnDelete' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NukeOnDelete | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Bi... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\
BitBucket]
Name: NukeOnDelete
Type: REG_DWORD (DWORD Value)
Value: (0 = use recycle bin, 1 = permanently delete)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 29, 2001


Change the Internet Explorer Navigation Sound

Change the Internet Explorer Navigation Sound
Category: Home > Software > Internet Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When you start navigating a web site with Internet Explorer it plays a WAV file, by default a click sound. This setting lets you change or remove that sound.

Open your registry and find the key below.

Create a new String value, or modify the existing value called '(Default)' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | "c:\windows\mysound.wav" | |
-
| HKEY_CURRENT_USER\AppEvents\Schemes\Apps\Explorer\Navigating\.current |
-

Settings:
User Key: [HKEY_CURRENT_USER\AppEvents\Schemes\Apps\Explorer\Navigating\.current]
Name: (Default)
Type: REG_SZ (String Value)
Value: Sound Filename (Empty for no sound)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2002


Specify a Replacement GINA Authentication DLL (Windows NT/2000/XP)

Specify a Replacement GINA Authentication DLL (Windows NT/2000/XP)
Category: Home > Security > System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows is shipped to load and execute the standard Microsoft GINA DLL (Graphical Identification and Authentication dynamic-link library) called MSGina.dll. You can specify a replacement GINA DLL using this setting.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'GinaDLL' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | GinaDLL | REG_SZ | "c:\winnt\system32\mygina.dll" | |
-
| HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: GinaDLL
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 3, 2002


Disable the Auto Logon Shift Override Feature (Windows NT/2000/XP)

Disable the Auto Logon Shift Override Feature (Windows NT/2000/XP)
Category: Home > Security > Login and Authentication

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When using the automatic login feature it is possible for a user to hold the Shift key to bypass the login sequence and enter a username and password. This feature disables the ability to override the function.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'IgnoreShiftOverride' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | IgnoreShiftOverride | REG_SZ | "1" | |
-
| HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: IgnoreShiftOverride
Type: REG_SZ (String Value)
Value: (1 = Ignore Shift)

Related Tweaks

  • Automatic Logon to Windows NT, 2000 and XP (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 25, 2002


Limit the Number of Automatic Logins (Windows NT/2000/XP)

Limit the Number of Automatic Logins (Windows NT/2000/XP)
Category: Home > Security > Login and Authentication

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting is used to limit the number of automatic logins, once the limit has been reached the auto logon feature will be disabled and the system will display the standard authentication box.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'AutoLogonCount' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This value is a DWORD when using Windows XP

Note: Each time the system is rebooted, the value of AutoLogonCount will be decremented by one, until it reaches zero. When AutoLogonCount reaches zero, no account will be logged on automatically, the AutoLogonCount and DefaultPassword key values will be deleted from the registry, and AutoAdminLogon will be set to zero.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AutoLogonCount | REG_SZ | "5" | |
-
| HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: AutoLogonCount
Type: REG_DWORD (DWORD Value)
Value: Number of Automatic Logins

Related Tweaks

  • Automatic Logon to Windows NT, 2000 and XP (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 12, 2002


Use the Classic Login Interface (Windows XP)

Use the Classic Login Interface (Windows XP)
Category: Home > Windows > Login and Authentication

Windows XP includes a new log on interface to streamline the login process and display user profile information. In some circumstances the old Windows NT/2000 interface may be required in which case you can still access it using this key combination.

  1. Press and hold the Ctrl + Alt keys
  2. Press the Delete key twice
The login screen will now revert back to the previous logon box display, you can switch back to the Windows XP interface by clicking the Cancel button.

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 5, 2001


Change the Active Desktop Safe Mode Background (Windows 98/Me/2000/XP)

Change the Active Desktop Safe Mode Background (Windows 98/Me/2000/XP)
Category: Home > Windows > Troubleshooting

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting is used to change the image or web page that is shown when the active desktop is disabled due to a system error.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'Wallpaper' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Wallpaper | REG_SZ | "c:\windows\Web\SafeMode.htt" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Desktop\SafeMode\... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Desktop\SafeMode\
General]
Name: Wallpaper
Type: REG_SZ (String Value)
Value: Wallpaper Filename

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 21, 2001


Launch Windows Desktop in a Separate Process (Windows 98/Me/2000/XP)

Launch Windows Desktop in a Separate Process (Windows 98/Me/2000/XP)
Category: Home > Windows > Desktop

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

By default Windows creates one multi-threaded Explorer process which contains the Desktop, Taskbar and all other explorer instances. If one of these instances fails, all instances will fail. When enabled, this setting causes Windows to create separate processes insulating them from other failures.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'DesktopProcess' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: When this tweak is enabled with Internet Explorer 5.0 it may cause Explorer to open after startup.

Note: On some IE 4.01 systems, launching folders results a message box saying "SHDOCVW.DLL can't be opened" or a Notepad window displaying the file SHDOCVW.DLL. On these systems it is recommened that you disable this tweak.

Note: This may not work when Active Desktop is enabled.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DesktopProcess | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer]
Name: DesktopProcess
Type: REG_DWORD (DWORD Value)
Value: (1 = Separate Process, 0 = Default)

Related Tweaks

  • Launch Folder Windows in a Separate Process (All Windows)
  • Launch Browser Windows in a Separate Process (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: July 24, 2002


Load Balance Network Adapters (Windows NT/2000/XP)

Load Balance Network Adapters (Windows NT/2000/XP)
Category: Home > Hardware > Network and Modems

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

If you have two or more network cards in your system this setting allows you to distribute the number of connections, or sessions among the adapters according to a randomizing algorithm.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'RandomAdapter' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: The Single Response setting should also be enable for this setting to be effective.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | RandomAdapter | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NetBT\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NetBT\Parameters]
Name: RandomAdapter
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Related Tweaks

  • Control Network Adapter Responses to a WINS Query (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: July 24, 2002


Control Network Adapter Responses to a WINS Query (Windows NT/2000/XP)

Control Network Adapter Responses to a WINS Query (Windows NT/2000/XP)
Category: Home > Network > Protocols > WINS

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

In computers with multiple network adapters this setting specifies whether to send all IP addresses or only one IP address in response to a WINS query request.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'SingleResponse' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This setting should be enabled (1) when network adapters are configured for load balancing.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SingleResponse | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NetBT\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NetBT\Parameters]
Name: SingleResponse
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Related Tweaks

  • Load Balance Network Adapters (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 14, 2002


Control Network Adapter Responses to a WINS Query (Windows 95/98/Me)

Control Network Adapter Responses to a WINS Query (Windows 95/98/Me)
Category: Home > Network > Protocols > WINS

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

In computers with multiple network adapters this setting specifies whether to send all IP addresses or only one IP address in response to a WINS query request.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'SingleResponse' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: For Windows 98, the Data Type is a String value.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SingleResponse | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\MSTCP]
Name: SingleResponse
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 20, 2002


Enable the Network Adapter Onboard Processor (Windows 2000/XP)

Enable the Network Adapter Onboard Processor (Windows 2000/XP)
Category: Home > Hardware > Network and Modems

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

If your network adapter has an onboard processor, designed to offload network processing from the system CPU, it is disabled by default. This setting allows you to enable it and increase the processing speed of your system.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'DisableTaskOffload' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DisableTaskOffload | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]
Name: DisableTaskOffload
Type: REG_DWORD (DWORD Value)
Value: (0 = Use NIC Processor, 1 = Disable NIC Processor)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 21, 2002


Minimize Outlook to System Tray

Minimize Outlook to System Tray
Category: Home > Software > Microsoft Office > Outlook

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Like most applications Outlook 2002 (from Office XP) will normally minimize to the taskbar. This setting changes the default behaviour so that it will minimize to the system tray (next to the clock) instead.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'MinToTray' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | MinToTray | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Outlook\Preferences |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Outlook\Preferences]
Name: MinToTray
Type: REG_DWORD (DWORD Value)
Value: (1 = System Tray, 0 = Taskbar)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: November 25, 2001


Specify the Location of the Online Support Site (All Windows)

Specify the Location of the Online Support Site (All Windows)
Category: Home > Software > Internet Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When a user selects "Online Support" from the Internet Explorer help menu they are usually redirected to a Microsoft web page. This tweak allows you to specify an alternate URL and web site.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'Online_Support' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This tweak can also be applied on a per-user basis under the [HKEY_CURRENT_USER] hive.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Online_Support | REG_SZ | "http://www.winguides.com/forums/" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Help_Menu_Urls |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Help_Menu_Urls]
Name: Online_Support
Type: REG_SZ (String Value)
Value: Support URL

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2002


Change the Default Internet Explorer Search Page (All Windows)

Change the Default Internet Explorer Search Page (All Windows)
Category: Home > Software > Internet Explorer > Search Features

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

By default a Microsoft search page is shown when a user clicks on the "Search" toolbar button in Internet Explorer. This tweak allows you to specify an alternate search URL.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'Search Bar' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This tweak can also be applied on a per-user basis under the [HKEY_CURRENT_USER] hive.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Search Bar | REG_SZ | "http://www.winguides.com/search.php" | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main]
Name: Search Bar
Type: REG_SZ (String Value)
Value: Search URL

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: November 26, 2001


Force Windows to Use the Classic Desktop (Windows 95/98/Me/NT/2000)

Force Windows to Use the Classic Desktop (Windows 95/98/Me/NT/2000)
Category: Home > Windows > Desktop

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak disables the various enhanced features of the Windows shell which are included in newer releases of Windows and Internet Explorer. It will remove features including Active Desktop, Web view, thumbnail views and the quick launch toolbar.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'ClassicShell' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: Requires Internet Explorer 4.0 or greater.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ClassicShell | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: ClassicShell
Type: REG_DWORD (DWORD Value)
Value: (0 = Default, 1 = Classic Desktop)

Related Tweaks

  • Disable Web Content in Explorer and Desktop (Windows XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 16, 2003


Disable Access to File URLs in Internet Explorer (All Windows)

Disable Access to File URLs in Internet Explorer (All Windows)
Category: Home > Software > Internet Explorer > Security

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Normally you can use the Internet Explorer address bar to access standard files and folders. This setting disables that functionality and only allows access to Internet URLs.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoFileUrl' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: Requires Internet Explorer 4.0 or higher.

Note: Some browser versions may also require the NoRun setting enabled to activate this restriction.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoFileUrl | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoFileUrl
Type: REG_DWORD (DWORD Value)
Value: (0 = Enable File URLs, 1 = Disable)

Related Tweaks

  • Remove Run from the Start Menu (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 3, 2002


Search for Network Folders and Printers (All Windows)

Search for Network Folders and Printers (All Windows)
Category: Home > Network > Servers

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether Windows should automatically attempt to locate available file shares and printers by crawling the local network.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoNetCrawling' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoNetCrawling | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Adv... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
Advanced]
Name: NoNetCrawling
Type: REG_DWORD (DWORD Value)
Value: (0 = Search Enabled, 1 = Search Disabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2002


Show Hidden Operating System Files (All Windows)

Show Hidden Operating System Files (All Windows)
Category: Home > Windows > Windows Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether the normally hidden operating system files should be displayed when using explorer to browse the file system.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'ShowSuperHidden' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ShowSuperHidden | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Adv... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
Advanced]
Name: ShowSuperHidden
Type: REG_DWORD (DWORD Value)
Value: ( 0 = Hide Files, 1 = Show Files)

Related Tweaks

  • Show Hidden Folders and Files (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 12, 2002


Remove My Documents from the Desktop (All Windows)

Remove My Documents from the Desktop (All Windows)
Category: Home > Windows > Desktop

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting is used to remove the My Documents folder from the Windows desktop.

Open your registry and find the key below for your OS version.

Windows 95, 98 and Me
[HKEY_CURRENT_USER\Software\Classes\CLSID\{450D8FBA-AD25-11D0-98A8-0800361B1103}\ShellFolder]

Windows NT, 2000 and XP
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\CLSID\{450D8FBA-AD25-11D0-98A8-0800361B1103}\ShellFolder]

Modify the value called "Attributes" and set it to either "0xf0500174" to hide or "0xf0400174" to display My Documents.

Click on a blank area of desktop and press F5 to refresh for the change to take effect.

Note: This tweak can also by used on a system wide basis by entering the same values under the [HKEY_LOCAL_MACHINE] hive.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Attributes | REG_DWORD | 0xf0500174 (4031775092) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\CLS... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
CLSID\{450D8FBA-AD25-11D0-98A8-0800361B1103}\ShellFolder]
Name: Attributes
Type: REG_DWORD (DWORD Value)
Value: (0xf0500174 = Hidden, 0xf0400174 = Default)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 14, 2001


Show Pop-up Descriptions for Explorer and Desktop Items (All Windows)

Show Pop-up Descriptions for Explorer and Desktop Items (All Windows)
Category: Home > Windows > Desktop

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether pop-up tool tip information and descriptions are shown when the mouse is hovered over desktop and explorer items.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'ShowInfoTip' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ShowInfoTip | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Adv... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
Advanced]
Name: ShowInfoTip
Type: REG_DWORD (DWORD Value)
Value: (0 = Disabled, 1 = Show Tool Tips)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 27, 2002


Launch Browser Windows in a Separate Process (All Windows)

Launch Browser Windows in a Separate Process (All Windows)
Category: Home > Software > Internet Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting specifies whether a new process is created for each instance of Internet Explorer that you start. This can prevent one instance of Explorer from affecting other instances if it stops responding.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'BrowseNewProcess' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: Normally this is automatically enabled or disabled based on the amount of random access memory (RAM) that is installed in the computer. If the computer has less than 32 megabytes (MBs) of RAM installed, this setting is disabled. If there is 32 MBs of RAM or more installed on the computer, the setting is enabled.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | BrowseNewProcess | REG_SZ | "Yes" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Bro... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
BrowseNewProcess]
Name: BrowseNewProcess
Type: REG_SZ (String Value)
Value: Yes or No

Related Tweaks

  • Launch Folder Windows in a Separate Process (All Windows)
  • Launch Windows Desktop in a Separate Process (Windows 98/Me/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: July 24, 2002


Detect Accidental Double Clicks (All Windows)

Detect Accidental Double Clicks (All Windows)
Category: Home > Hardware > Mice and Keyboards

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting is used to control whether explorer should attempt to automatically detect accidental double mouse clicks.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'UseDoubleClickTimer' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | UseDoubleClickTimer | REG_SZ | "1" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Adv... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
Advanced]
Name: UseDoubleClickTimer
Type: REG_SZ (String Value)
Value: (1 = Enabled, 0 = Disabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 27, 2002


Wrap Icon Titles (All Windows)

Wrap Icon Titles (All Windows)
Category: Home > Windows > Appearance > Fonts and Icons

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether the icon titles should be word wrapped over multiple lines or shown in one longer line.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'IconTitleWrap' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | IconTitleWrap | REG_SZ | "1" | |
-
| HKEY_CURRENT_USER\Control Panel\Desktop\WindowMetrics |
-

Settings:
User Key: [HKEY_CURRENT_USER\Control Panel\Desktop\WindowMetrics]
Name: IconTitleWrap
Type: REG_SZ (String Value)
Value: (1 = Enabled, 0 = Disabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 27, 2002


Control Error Reporting with Office XP (All Windows)

Control Error Reporting with Office XP (All Windows)
Category: Home > Software > Microsoft Office

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Office XP includes a feature which will send debug information to Microsoft if an error occurs in one of the Office XP applications. This can be disabled using this tweak.

Open your registry and find the key below, creating it if necessary.

Create the following DWORD values and set them to "1".

  • DWNeverUpload
  • DWNoExternalURL
  • DWNoFileCollection
  • DWNoSecondLevelCollection
Restart Office for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DWNeverUpload | REG_DWORD | 0x00000001 (1) | |
| |  | DWNoExternalURL | REG_DWORD | 0x00000001 (1) | |
| |  | DWNoFileCollection | REG_DWORD | 0x00000001 (1) | |
| |  | DWNoSecondLevelCollection | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\10.0\Common |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\10.0\Common]
System Key: [HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Office\10.0\Common]
Name: DWNeverUpload, DWNoExternalURL, DWNoFileCollection, DWNoSecondLevelCollection
Type: REG_DWORD (DWORD Value)
Value: (1 = disable error reporting)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 16, 2001


Remove Selected Internet Explorer Toolbar Buttons (All Windows)

Remove Selected Internet Explorer Toolbar Buttons (All Windows)
Category: Home > Software > Internet Explorer > Appearance

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

These settings allow you to hide and disable specific buttons on the Internet Explorer toolbar.

Open your registry and find the key below, creating it if it does not already exist.

Create a new DWORD value called "SpecifyDefaultButtons" and set it to "1" to enable the removal of buttons.

In addition create a new DWORD value and set the value to "2" for each button you want to remove from the list below.

  • Btn_Back
  • Btn_Forward
  • Btn_Stop
  • Btn_Refresh
  • Btn_Home
  • Btn_Search
  • Btn_Folders
  • Btn_Favorites
  • Btn_Media
  • Btn_History
  • Btn_Fullscreen
  • Btn_Tools
  • Btn_MailNews
  • Btn_Size
  • Btn_Print
  • Btn_Edit
  • Btn_Discussions
  • Btn_Cut
  • Btn_Copy
  • Btn_Paste
  • Btn_Encoding
  • Btn_PrintPreview

Restart Internet Explorer for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | SpecifyDefaultButtons | REG_DWORD | 0x00000001 (1) | |
| |  | Btn_Back | REG_DWORD | 0x00000002 (2) | |
| |  | Btn_Refresh | REG_DWORD | 0x00000002 (2) | |
| |  | Btn_Search | REG_DWORD | 0x00000002 (2) | |
| |  | Btn_Print | REG_DWORD | 0x00000002 (2) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: SpecifyDefaultButtons
Type: REG_DWORD (DWORD Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 18, 2002


Restrict Users from Running Specific Applications (Windows 2000/Me/XP)

Restrict Users from Running Specific Applications (Windows 2000/Me/XP)
Category: Home > Security

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allows you to specify applications and filenames that users are restricted from running.

Open your registry and find the key [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion \Policies\Explorer]

Create a new DWORD value and name it "DisallowRun" set the value to "1" to enable application restrictions or "0" to allow all applications to run.

Then create a new sub-key called [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion \Policies\Explorer\DisallowRun] and define the applications the are to be restricted. Creating a new string value for each application, named as consecutive numbers, and setting the value to the filename to be restriced (e.g. "regedit.exe").

Restart Windows for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | 1 | REG_SZ | "badapp.exe" | |
| |  | 2 | REG_SZ | "restrict.exe" | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: DisallowRun

Related Tweaks

  • Restrict Applications Users Can Run (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 19, 2001


Hide the Taskbar Clock (Windows XP)

Hide the Taskbar Clock (Windows XP)
Category: Home > Security > Start Menu and Taskbar

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allows you to remove the clock from the system tray on the taskbar.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'HideClock' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | HideClock | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: HideClock
Type: REG_DWORD (DWORD Value)
Value: (0 = Show Clock, 1 = Hide Clock)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 18, 2001


Require Users to Press Ctrl+Alt+Delete Before Logon (Windows 2000/XP)

Require Users to Press Ctrl+Alt+Delete Before Logon (Windows 2000/XP)
Category: Home > Security > Login and Authentication

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether users are required to press Ctrl + Alt + Delete as a security precaution before logging into the system.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'DisableCAD' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: Windows XP systems must be configured to use the classic login method for this setting to work.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DisableCAD | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: DisableCAD
Type: REG_DWORD (DWORD Value)
Value: (0 = Require Ctrl+Alt+Delete, 1 = Disable)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 25, 2002


Change the Login Window (Windows XP)

Change the Login Window (Windows XP)
Category: Home > Windows > Login and Authentication

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls which type of logon screen is shown, either the classic Windows NT/2000 format or the Windows XP welcome screen.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'LogonType' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: Using the classic logon method will also disable the use of fast user switching, where applications remain active in other users sessions.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | LogonType | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: LogonType
Type: REG_DWORD (DWORD Value)
Value: (0 = Classic Mode, 1 = Welcome Screen)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 7, 2003


Allow Fast User Switching (Windows XP)

Allow Fast User Switching (Windows XP)
Category: Home > Windows > Login and Authentication

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Fast user switching allows you to quickly switch to another user account without having to close any programs. This setting controls whether fast user switching is available.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'AllowMultipleTSSessions' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: Windows XP users must use the standard Welcome Screen logon method.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AllowMultipleTSSessions | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: AllowMultipleTSSessions
Type: REG_DWORD (DWORD Value)
Value: (0 = Disable Fast User Switching, 1= Enable)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 7, 2003


Restrict the Start Menu Log Off Option (Windows 2000/Me/XP)

Restrict the Start Menu Log Off Option (Windows 2000/Me/XP)
Category: Home > Security > Start Menu and Taskbar

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction removes the ability for a user to enable the "Log Off..." option on the Start Menu.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'StartMenuLogoff' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | StartMenuLogoff | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: StartMenuLogoff
Type: REG_DWORD (DWORD Value)
Value: (0 = show log off, 1 = remove log off)

Related Tweaks

  • Remove Log Off from the Start Menu (All Windows)
  • Force Logoff on the Start Menu (Windows 2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 3, 2002


Force the Use of the Classic Start Menu (Windows XP)

Force the Use of the Classic Start Menu (Windows XP)
Category: Home > Security > Start Menu and Taskbar

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction forces users to use the classic Windows start menu, instead of the new format introduced with Windows XP.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoSimpleStartMenu' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoSimpleStartMenu | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoSimpleStartMenu
Type: REG_DWORD (DWORD Value)
Value: (1 = force classic menu, 0 = default)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 19, 2001


Remove My Pictures from the Start Menu (Windows 2000/Me/XP)

Remove My Pictures from the Start Menu (Windows 2000/Me/XP)
Category: Home > Security > Start Menu and Taskbar > Documents and Folders

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction removes My Pictures from the Documents folder on the Start Menu.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoSMMyPictures' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoSMMyPictures | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoSMMyPictures
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = remove folder)

Related Tweaks

  • Remove Favorites from the Start Menu (All Windows)
  • Remove Recent Documents from the Start Menu (All Windows)
  • Remove My Documents from the Start Menu (Windows 2000/Me/XP)
  • Remove My Music from the Start Menu (Windows 2000/Me/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 3, 2002


Show Cascading My Pictures Folder (Windows 2000/Me/XP)

Show Cascading My Pictures Folder (Windows 2000/Me/XP)
Category: Home > Windows > Start Menu and Taskbar > Documents and Folders

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting causes the "My Pictures" folder on the Start Menu to act as a cascading folder.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'CascadeMyPictures' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This can be used either on a user by user basis by adding it to HKEY_CURRENT_USER or on a computer wide basis by adding it to HKEY_LOCAL_MACHINE.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | CascadeMyPictures | REG_SZ | Yes | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Adv... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
Advanced]
Name: CascadeMyPictures
Type: REG_SZ (String Value)
Value: "Yes" or "No"

Related Tweaks

  • Show Cascading Control Panel Items (Windows 2000/Me/XP)
  • Show Cascading Network Connections (Windows 2000/Me/XP)
  • Show Cascading My Documents Folder (Windows 2000/Me/XP)
  • Show Cascading Printers Folder (Windows 2000/Me/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 19, 2001


Lock the Taskbar (Windows XP)

Lock the Taskbar (Windows XP)
Category: Home > Security > Start Menu and Taskbar

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction is used to force the locking of the taskbar and restrict users from making any changes to its position.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'LockTaskbar' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | LockTaskbar | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: LockTaskbar
Type: REG_DWORD (DWORD Value)
Value: (0 = Unlocked, 1 = Locked)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 21, 2001


Disable CD Burning (Windows XP)

Disable CD Burning (Windows XP)
Category: Home > Hardware > Disk Drives

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction is used to disable the use of the inbuilt CD recording functions of Windows.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoCDBurning' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoCDBurning | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoCDBurning
Type: REG_DWORD (DWORD Value)
Value: (0 = Allow CDR, 1 = Disable CDR)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 21, 2001


Remove Properties from My Computer (Windows XP)

Remove Properties from My Computer (Windows XP)
Category: Home > Security > Desktop and Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction remove the properties option from My Computer and hides the "System Properties" screen.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoPropertiesMyComputer' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoPropertiesMyComputer | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoPropertiesMyComputer
Type: REG_DWORD (DWORD Value)
Value: (0 = Properties, 1 = No Properties)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 25, 2002


Disable MSN Instant Messenger (All Windows)

Disable MSN Instant Messenger (All Windows)
Category: Home > Software > Windows Messenger

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction is used to disable the ability to run the Microsoft MSN Instant Messenger client.

Open you registry and find the key below.

Create a new DWORD value for each of the optional restrictions from the table below. Set the value to "1" to enable the restriction or "0" to disable it.

  • PreventAutoRun - Do not automatically start Messenger
  • PreventRun - Do not allow Messenger to run
Restart Messenger for the changes to take effect.

Note: This tweak is applicable to MSN Messenger 4.x, this restriction has been removed from version 5 of the software.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | PreventAutoRun | REG_DWORD | 0x00000001 (1) | |
| |  | PreventRun | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Policies\Microsoft\Messenger\Client |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Policies\Microsoft\Messenger\Client]
System Key: [HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Messenger\Client]
Name: PreventAutoRun, PreventRun
Type: REG_DWORD (DWORD Value)
Value: (1 = enable restriction, 0 = default)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 14, 2002


MSN Instant Messenger Restrictions (All Windows)

MSN Instant Messenger Restrictions (All Windows)
Category: Home > Software > Windows Messenger

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

These restrictions are used to disable various features of the Microsoft MSN Instant Messenger client.

Open your registry and find the key below.

For each restriction from the list below create a new DWORD value and set the value to "1" to enable the restriction.

  • DisableCollaborationApps
  • DisableFileTransfer
  • DisablePC2PCAudio
  • DisablePC2Phone
  • DisableVideo
  • PreventAutoUpdate
  • PreventBackgroundDownload
  • PreventConsumerVersion
Restart MSN Messenger for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DisableCollaborationApps | REG_DWORD | 0x00000001 (1) | |
| |  | DisableFileTransfer | REG_DWORD | 0x00000001 (1) | |
| |  | DisablePC2PCAudio | REG_DWORD | 0x00000001 (1) | |
| |  | DisablePC2Phone | REG_DWORD | 0x00000001 (1) | |
| |  | DisableVideo | REG_DWORD | 0x00000001 (1) | |
| |  | PreventAutoUpdate | REG_DWORD | 0x00000001 (1) | |
| |  | PreventBackgroundDownload | REG_DWORD | 0x00000001 (1) | |
| |  | PreventConsumerVersion | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Policies\Microsoft\Messenger\Client |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Policies\Microsoft\Messenger\Client]
System Key: [HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Messenger\Client]
Type: REG_DWORD (DWORD Value)
Value: (1 = enable restriction, 0 = default)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 27, 2002


Remove Tray Items from Taskbar (Windows XP)

Remove Tray Items from Taskbar (Windows XP)
Category: Home > Security > Start Menu and Taskbar

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting removes and restricts access to the tray icons normally found next to the clock on the taskbar.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoTrayItemsDisplay' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoTrayItemsDisplay | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoTrayItemsDisplay
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 11, 2002


Remove the Toolbars on the Taskbar (Windows XP)

Remove the Toolbars on the Taskbar (Windows XP)
Category: Home > Security > Start Menu and Taskbar

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction is used to remove all the toolbars, including Quick Launch, from the taskbar. It also restricts the ability to re-enable them.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoToolbarsOnTaskbar' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoToolbarsOnTaskbar | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoToolbarsOnTaskbar
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 11, 2002


Modify the Internet Time Synchronization Schedule (Windows XP)

Modify the Internet Time Synchronization Schedule (Windows XP)
Category: Home > Windows > System > Services

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting is used to modify the number of seconds to wait between attempts to synchronize the system clock to an accurate time source on the Internet.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'SpecialPollInterval' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SpecialPollInterval | REG_DWORD | 0x00000e10 (3600) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time\TimeProvide... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time\
TimeProviders\NtpClient]
Name: SpecialPollInterval
Type: REG_DWORD (DWORD Value)
Value: Seconds in Decimal

Related Tweaks

  • Modify the Internet Time Synchronization Servers (Windows XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 12, 2002


Hide Usernames from the Logon Screen (Windows XP)

Hide Usernames from the Logon Screen (Windows XP)
Category: Home > Windows > Login and Authentication

This tweak can be used to hide specific usernames from the logon screen, without removing the account completely.

Open your registry and find the key below.

For each user you want to hide create a new DWORD value named after the username and set the value to "0".

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | John Bloggs | REG_DWORD | 0x00000000 (0) | |
| |  | Joan Smith | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\
SpecialAccounts\UserList]
Name:
Type: REG_DWORD (DWORD Value)
Value: 0 = hide the account

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 15, 2002


Manage Native Processor Performance Control (Windows XP)

Manage Native Processor Performance Control (Windows XP)
Category: Home > Hardware > Processor and Motherboard

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows includes built-in processor performance control to manage the microprocessor so it is more efficiently utilized. This tweak allows you to modify this feature.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, called 'HackFlags' and edit the value according to the settings below.

  • 0 = disable native XP support
  • 1 = use settings inherited from Intel software during XP upgrade
  • 5 = system can support all modes when running on battery

Restart Windows for the change to take effect.

Note: This tweak only applies to processors with either Intel SpeedStep or AMD PowerNow! processor performance control technologies.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | HackFlags | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\P3\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\P3\Parameters]
Name: HackFlags
Type: REG_DWORD (DWORD Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 21, 2002


Restrict Showing the Last Username (Windows 2000/XP)

Restrict Showing the Last Username (Windows 2000/XP)
Category: Home > Security > Login and Authentication

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction removes the ability to view which user was last logged onto a computer by clearing the username box on the login screen.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'DontDisplayLastUserName' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DontDisplayLastUserName | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System |
-

Settings:
User Key: [HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\
System]
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\
System]
Name: DontDisplayLastUserName
Type: REG_DWORD (DWORD Value)
Value: (1 = remove username)

Related Tweaks

  • Hide the Last User Name (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 25, 2002


Remove Windows Messenger from Outlook Express (All Windows)

Remove Windows Messenger from Outlook Express (All Windows)
Category: Home > Software > Windows Messenger

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak is used to remove MSN Instant Messenger functionality and integration from Outlook Express.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'Hide Messenger' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This tweak should also remove AOL Instant Messenger 5 integration.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Hide Messenger | REG_DWORD | 0x00000002 (2) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Outlook Express |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Outlook Express]
Name: Hide Messenger
Type: REG_DWORD (DWORD Value)
Value: (2 = remove messenger)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 25, 2003


Change Default Search Options (Windows XP)

Change Default Search Options (Windows XP)
Category: Home > Windows > Windows Explorer > Search

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

These settings allow you to change the default search options used to search for files and folders on Windows XP.

Open your registry and find the key below.

Modify the following values, setting them to "1" to select the parameter as a default or "0" as unselected.

  • CaseSensitive - Case sensitive
  • IncludeSubFolders - Search subfolders
  • SearchHidden - Search hidden files and folders
  • SearchSlowFiles - Search tape backup
  • SearchSystemDirs - Search system folders
You may need to log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | CaseSensitive | REG_DWORD | 0x00000001 (1) | |
| |  | IncludeSubFolders | REG_DWORD | 0x00000001 (1) | |
| |  | SearchHidden | REG_DWORD | 0x00000001 (1) | |
| |  | SearchSlowFiles | REG_DWORD | 0x00000001 (1) | |
| |  | SearchSystemDirs | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer]
Type: REG_DWORD (DWORD Value)
Value: (0 = unselected, 1 = selected)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 23, 2002


Enable Advanced File System and Sharing Security (Windows XP Professional)

Enable Advanced File System and Sharing Security (Windows XP Professional)
Category: Home > Security > Desktop and Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting is used to enable the ability to control advanced NTFS permissions on local and shared files.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'ForceGuest' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This tweak is only available for Windows XP Professional Edition, due to restrictions users of the XP Home Edition are not able to access NFTS permissions through the GUI.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ForceGuest | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa]
Name: ForceGuest
Type: REG_DWORD (DWORD Value)
Value: (1 = default, 0 = advanced permissions)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 10, 2003


Disable Outlook Today Page (All Windows)

Disable Outlook Today Page (All Windows)
Category: Home > Software > Microsoft Office > Outlook

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction is used to disable the "Outlook Today" page in Microsoft Outlook 2002. When this setting is applied the option to view Outlook Today will be removed.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'Disable' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Disable | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Outlook\Today |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Outlook\Today]
Name: Disable
Type: REG_DWORD (DWORD Value)
Value: (0 = enable today, 1 = disable today)

Related Tweaks

  • Modify the Outlook Today Location (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 20, 2002


Modify the Outlook Today Location (All Windows)

Modify the Outlook Today Location (All Windows)
Category: Home > Software > Microsoft Office > Outlook

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allows you to specify an alternate URL to show instead of the default Outlook Today page in Microsoft Outlook 2000 and 2002.

Open your registry and find the key below for your Outlook version.

Outlook 2000
[HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Outlook\Today]

Outlook 2002 (XP)
[HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Outlook\Today]

Create a new string value called "Url" and set it to the location of the required today page. This be either an Internet or Intranet address.

Restart Outlook for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Url | REG_SZ | http://www.winguides.com/ | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Office\[version]\Outlook\Today |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Office\[version]\Outlook\Today]
Name: Url
Type: REG_SZ (String Value)
Value: URL of alternate page

Related Tweaks

  • Disable Outlook Today Page (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 14, 2002


Disable the Thumbnail Cache (Windows XP)

Disable the Thumbnail Cache (Windows XP)
Category: Home > Windows > Windows Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting is used to stop explorer from caching thumbnail pictures and instead refresh any images every time a folder is opened.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'DisableThumbnailCache' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DisableThumbnailCache | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Adv... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
Advanced]
Name: DisableThumbnailCache
Type: REG_DWORD (DWORD Value)
Value: (0 = enabled, 1 = disable cache)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 14, 2002


Disable Desktop Cleanup Wizard (Windows XP)

Disable Desktop Cleanup Wizard (Windows XP)
Category: Home > Windows > Desktop

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

By default Windows will run the Desktop Cleanup Wizard every 60 days to remove unused desktop items and shortcuts. This setting will disable it from running automatically.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoRun' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoRun | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Des... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
Desktop\CleanupWiz]
Name: NoRun
Type: REG_DWORD (DWORD Value)
Value: (0 = enabled, 1= disable wizard)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 14, 2002


Disable Compressed Folders (Windows Me/XP)

Disable Compressed Folders (Windows Me/XP)
Category: Home > Windows > Windows Explorer

Windows Me and XP include a built-in feature to manage compressed ZIP files and folders. This tweak allows you to disable it and install a third-party application.

To disable the compressed folder feature click on Start -> Run and enter the following command:

regsvr32 /u zipfldr.dll

To enable ZIP folder support run this command:

regsvr32 zipfldr.dll

Restart Windows for the change to take effect.

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 4, 2002


Disable Balloon Tips (Windows XP)

Disable Balloon Tips (Windows XP)
Category: Home > Windows > Start Menu and Taskbar > Taskbar

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows sometimes offers tips and advice to new users by opening a balloon window from the taskbar. The feature can disabled using this tweak.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'EnableBalloonTips' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | EnableBalloonTips | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Adv... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
Advanced]
Name: EnableBalloonTips
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 14, 2002


Disable Automatic Modem Connections at Startup (All Windows)

Disable Automatic Modem Connections at Startup (All Windows)
Category: Home > Hardware > Network and Modems

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

If remote connections are enabled in Windows, the system may try to initiate an Internet connection at Windows startup or at the start of many applications. This setting disables that behaviour.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'EnableRemoteConnect' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | EnableRemoteConnect | REG_SZ | N | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Ole |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Ole]
Name: EnableRemoteConnect
Type: REG_SZ (String Value)
Value: "Y" = enable automatic connections, "N" = disabled

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 12, 2002


Disable Distributed Component Object Model (DCOM) (All Windows)

Disable Distributed Component Object Model (DCOM) (All Windows)
Category: Home > Windows > System > Services

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Distributed Component Object Model, or DCOM, provides a method for distributed network applications to communicate with one another. This setting allow you to disable support for DCOM.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'EnableDCOM' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | EnableDCOM | REG_SZ | N | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Ole |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Ole]
Name: EnableDCOM
Type: REG_SZ (String Value)
Value: "Y" = enabled, "N" = disabled

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 13, 2002


Use Crtl + Alt + Delete to Restart the Computer (Windows 3.1/95/98)

Use Crtl + Alt + Delete to Restart the Computer (Windows 3.1/95/98)
Category: Home > Tips and Tricks > Configuration Files > SYSTEM.INI

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Normally when you press Ctrl + Alt + Delete the Windows task list is displayed. Using this tweak the key combination will instead reboot the computer.

Open the SYSTEM.INI file found in the Windows directory using Notepad.

Under the [386Enh] section create or modify the value named "KybdReboot". Set the value to equal "True" to cause the system to reboot on the key combination or "False" to show the task list. For example:

[386Enh]
KybdReboot=False
Restart Windows for the change to take effect.

Note: By default this is true on Windows 3.1. On Windows 95 and higher the default is false.

Related Tweaks

  • End Tasks Without Restarting Windows (Windows 3.1/95/98)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 14, 2002


End Tasks Without Restarting Windows (Windows 3.1/95/98)

End Tasks Without Restarting Windows (Windows 3.1/95/98)
Category: Home > Tips and Tricks > Configuration Files > SYSTEM.INI

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting specifies whether you can press CTRL+ALT+DEL to quit applications that cause an unrecoverable errors in 386 enhanced mode, without restarting Windows.

Open the SYSTEM.INI file found in the Windows directory using Notepad.

Under the [386Enh] section create or modify the value named "LocalReboot". Set the value to equal "On" to cause the system to end the task on the key combination or "Off" to restart the computer. For example:

[386Enh]
LocalReboot=On
Restart Windows for the change to take effect.

Note: By default this is "On" in Windows 3.1. In Windows 95 and higher the default is "Off".

Related Tweaks

  • Use Crtl + Alt + Delete to Restart the Computer (Windows 3.1/95/98)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 14, 2002


Hide the Office XP Toolbar Help (All Windows)

Hide the Office XP Toolbar Help (All Windows)
Category: Home > Software > Microsoft Office

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

These settings can be used to hide the toolbar help feature in Office XP applications. Shown in the top right corner it normally allows users to "Type a question for help".

Open your registry and find the key below.

Create a new DWORD value from the table below for each application where the toolbar help should be hidden.

  • Microsoft Access AWDropdownHidden - Hide in Microsoft Access
  • Microsoft Excel AWDropdownHidden - Hide in Microsoft Excel
  • Microsoft Outlook AWDropdownHidden - Hide in Microsoft Outlook
  • Microsoft Powerpoint AWDropdownHidden - Hide in Microsoft Powerpoint
  • Microsoft Word AWDropdownHidden - Hide in Microsoft Word
Restart any Office XP applications for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Microsoft Access AWDropdownHidden | REG_DWORD | 0x00000001 (1) | |
| |  | Microsoft Excel AWDropdownHidden | REG_DWORD | 0x00000001 (1) | |
| |  | Microsoft Outlook AWDropdownHidden | REG_DWORD | 0x00000001 (1) | |
| |  | Microsoft Powerpoint AWDropdownHidden | REG_DWORD | 0x00000001 (1) | |
| |  | Microsoft Word AWDropdownHidden | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Common\Toolbars\Settings |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Common\Toolbars\
Settings]
Type: REG_DWORD (DWORD Value)
Value: (0 = display, 1 = hidden)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 18, 2002


Debug the Windows Update Process (All Windows)

Debug the Windows Update Process (All Windows)
Category: Home > Windows > Troubleshooting

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting is used to enable a debug function, called Stepping Mode, which causes Windows Update to prompt during each step of the installation process.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'SteppingMode' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: Once you have turned on Stepping Mode, you can proceed with normal download and installation from the Windows Update site. During the download and installation process you will be prompted with a dialog box after each step. You must click OK in each dialog box to continue with the setup.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SteppingMode | REG_SZ | Y | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Active Setup |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Active Setup]
Name: SteppingMode
Type: REG_SZ (String Value)
Value: (Y = enable debug, N = disable debug)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 22, 2002


Add a Menu Option to Move or Copy to a Folder (All Windows)

Add a Menu Option to Move or Copy to a Folder (All Windows)
Category: Home > Windows > Windows Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak allows you to easily move and copy files and folders by adding two new right-click menu options to "Move To Folder..." and "Copy To Folder...". Simply highlight the file, right-click the option and select the destination folder.

Open your registry and find the key below.

To enable the Copy To Folder menu option create a new subkey called "Copy To" and set the (Default) value to "{C2FBB630-2971-11d1-A18C-00C04FD75D13}".

To enable the Move To Folder menu option create a new subkey called "Move To" and set the (Default) value to "{C2FBB631-2971-11d1-A18C-00C04FD75D13}".

Changes should take effect immediately, right click on folder to view the new options.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | {C2FBB630-2971-11d1-A18C-00C04FD75D13} | |
-
| HKEY_CLASSES_ROOT\AllFilesystemObjects\shellex\ContextMenuHandlers |
-

Settings:
System Key: [HKEY_CLASSES_ROOT\AllFilesystemObjects\shellex\ContextMenuHandlers]
Name: (Default)
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 29, 2002


Add a Menu Option to Open Shortcuts in a New Window (All Windows)

Add a Menu Option to Open Shortcuts in a New Window (All Windows)
Category: Home > Software > Internet Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak adds a right-click menu option to enable you to open Internet shortcuts in a new Explorer window.

Open your registry and create the key below.

Set the (Default) value to "rundll32.exe shdocvw.dll,OpenURL %l".

Apply this tweak or open Internet Explorer and click on Tools -> Internet Options -> Advanced and uncheck "Reuse windows for launching shortcuts".

Exit Internet Explorer and right-click on a shortcut to use the new option.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | rundll32.exe shdocvw.dll,OpenURL %l | |
-
| HKEY_CLASSES_ROOT\InternetShortcut\shell\Open in New Window\command |
-

Settings:
System Key: [HKEY_CLASSES_ROOT\InternetShortcut\shell\Open in New Window\command]
Name: (Default)
Type: REG_SZ (String Value)
Value: rundll32.exe shdocvw.dll,OpenURL %l

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 22, 2002


Open Internet Explorer Shortcuts in a New Window (All Windows)

Open Internet Explorer Shortcuts in a New Window (All Windows)
Category: Home > Software > Internet Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether Internet shortcuts are opened in an existing available Internet Explorer window or whether a new window should be spawned.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'AllowWindowReuse' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AllowWindowReuse | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
Name: AllowWindowReuse
Type: REG_DWORD (DWORD Value)
Value: (0 = new window, 1 = existing window)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 30, 2003


Show Hidden Folders and Files (All Windows)

Show Hidden Folders and Files (All Windows)
Category: Home > Windows > Windows Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether hidden files and folders are displayed in explorer when browsing the file system.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'Hidden' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
Advanced]
Name: Hidden
Type: REG_DWORD (DWORD Value)
Value: (1 = show hidden, 2 = do not show)

Related Tweaks

  • Show Hidden Operating System Files (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 24, 2002


Use Smooth Scrolling in Outlook Express (All Windows)

Use Smooth Scrolling in Outlook Express (All Windows)
Category: Home > Software > Outlook Express

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether smooth scrolling is used when viewing messages in Microsoft Outlook Express 5.0 and 6.0.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'SmoothScroll' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This feature may slow down Outlook Express when navigating messages with lots of graphics.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SmoothScroll | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Identities\{Unique Identity}\Software\Microsoft\Outloo... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Identities\{Unique Identity}\Software\Microsoft\
Outlook Express\5.0\Trident\Main]
Name: SmoothScroll
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Related Tweaks

  • Use Smooth Scrolling in Internet Explorer (All Windows)
  • Control Whether Windows Performs Smooth Scrolling (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 2, 2002


Disable the Unread Mail Message on the Welcome Screen (Windows XP)

Disable the Unread Mail Message on the Welcome Screen (Windows XP)
Category: Home > Windows > Login and Authentication

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting can be used to remove the message on the Windows Welcome screen showing the number of unread e-mails.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'MessageExpiryDays' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | MessageExpiryDays | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\UnreadMail |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\UnreadMail]
Name: MessageExpiryDays
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 3 = default)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 2, 2002


Specify the Small Memory Dump Directory (Windows 2000/XP)

Specify the Small Memory Dump Directory (Windows 2000/XP)
Category: Home > Windows > Troubleshooting > Crash Control

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting is used to specify the location of the small dump directory which stores a small set of useful information when a system stops unexpectedly.

Open your registry and find the key below.

Create a new Expanded String value, or modify the existing value called 'MinidumpDir' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | MinidumpDir | REG_EXPAND_SZ | %SystemRoot%\Minidump | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CrashControl |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\CrashControl]
Name: MinidumpDir
Type: REG_EXPAND_SZ (Expanded String Value)

Related Tweaks

  • Send Administrative Alerts of System Crashes (Windows NT/2000/XP)
  • Control Whether Windows Logs a System Crash (Windows NT/2000/XP)
  • Create a System Crash Dump File (Windows NT/2000/XP)
  • Specify the System Crash Dump File Location (Windows NT/2000/XP)
  • Control the Dump Creation Method (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 4, 2002


Disable Warnings on Startup (Windows 2000/XP)

Disable Warnings on Startup (Windows 2000/XP)
Category: Home > Windows > Troubleshooting

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

With this setting you can suppress any error messages that might otherwise appear at Windows startup. These popup messages normally notify you when a device or service is not functioning correctly.

Open your registry and find the key below.

Create a new DWORD value or modify the existing value called "NoPopUpsOnBoot" and set it to "1" to disable the popups.

Create an additional DWORD value called "Error Mode" and set it according to the table below to control which messages are suppressed.

  • 0 = No Error Suppression
  • 1 = Suppress System Errors
  • 2 = Suppress All Errors
Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoPopUpsOnBoot | REG_DWORD | 0x00000001 (1) | |
| |  | Error Mode | REG_DWORD | 0x00000002 (2) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows]
Name: NoPopUpsOnBoot, Error Mode
Type: REG_DWORD (DWORD Value)

Related Tweaks

  • Stop Error Messages When Booting (Windows NT)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 19, 2002


Read Messages as Plain Text in Outlook 2002 (All Windows)

Read Messages as Plain Text in Outlook 2002 (All Windows)
Category: Home > Software > Microsoft Office > Outlook

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction is used to specify that all non-digitally-signed messages should be read as plain text. This is useful in avoiding a large number of security vulnerabilities caused by HTML viruses.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'ReadAsPlain' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This feature was added in Microsoft Office XP Service Pack 1 (SP-1).

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ReadAsPlain | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Outlook\Options\Mail |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Outlook\Options\Mail]
Name: ReadAsPlain
Type: REG_DWORD (DWORD Value)
Value: (1 = enabled, 0 = disabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 1, 2002


Restrict Web Sites from Installing Software (All Windows)

Restrict Web Sites from Installing Software (All Windows)
Category: Home > Software > Internet Explorer > Security

These restrictions allow you to block unwanted web sites from downloading software onto your system. This can be useful in disabling the installation of some common "cursor" programs.

Open your registry and find the key below.

Create a new sub-key for each site you want to block, naming it based on the top-level domain for the site. For example to block www.restricted.com you would create a new sub-key called:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\ZoneMap\Domains\restricted.com]

Under the sub-key create a new DWORD value called "*" and set it to equal "4".

Restart Internet Explorer for the change to take effect.

Note: This setting can also be applied on a user-by-user basis by modifing the same key under the HKEY_CURRENT_USER hive.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | * | REG_DWORD | 0x00000004 (4) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Se... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\
Internet Settings\ZoneMap\Domains]
Name: *
Type: REG_DWORD (DWORD Value)
Value: (4 = restricted)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 6, 2002


Block Comet Cursor (All Windows)

Block Comet Cursor (All Windows)
Category: Home > Software > Internet Explorer > Security

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

These settings allow you to block the installation of the Comet Cursor program which is sometimes installed automatically as an ActiveX control.

Open your registry and find the key below.

Create the following sub-keys to block the primary domains that the cursor is installed from.

[HKEY_LOCAL_MACHINE\Software\...\ZoneMap\Domains\cometcursor.com]
[HKEY_LOCAL_MACHINE\Software\...\ZoneMap\Domains\cometsystems.com]
[HKEY_LOCAL_MACHINE\Software\...\ZoneMap\Domains\cometzone.com]
[HKEY_LOCAL_MACHINE\Software\...\ZoneMap\Domains\livecursors.com]

Under each key create a new DWORD value called "*" and set the value to "4".

Restart Internet Explorer for the changes to take effect.

Note: This setting can also be applied on a user-by-user basis by modifing the same key under the HKEY_CURRENT_USER hive.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | * | REG_DWORD | 0x00000004 (4) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Se... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\
Internet Settings\ZoneMap\Domains]
Name: *
Type: REG_DWORD (DWORD Value)
Value: 4

Related Tweaks

  • Restrict Web Sites from Installing Software (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 6, 2002


Modify the Paged and Non Paged Pool Memory Sizes (Windows NT/2000/XP)

Modify the Paged and Non Paged Pool Memory Sizes (Windows NT/2000/XP)
Category: Home > Hardware > Processor and Motherboard

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows normally calculates the paged and non paged pool memory sizes using complex algorithms based on physical memory size. These settings allow you to override and manually specify values.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'PagedPoolSize, NonPagedPoolSize' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: Having invalid or values too small may cause Windows to display this error "Not enough server storage is available to process this command."

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | PagedPoolSize | REG_DWORD | 0x00000000 (0) | |
| |  | NonPagedPoolSize | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memo... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\
Memory Management]
Name: PagedPoolSize, NonPagedPoolSize
Type: REG_DWORD (DWORD Value)
Value: size of paged pool in bytes (default = 0)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 7, 2002


Control How NTFS Reserves Space for its Master File Table (Windows NT/2000/XP)

Control How NTFS Reserves Space for its Master File Table (Windows NT/2000/XP)
Category: Home > Windows > File System > Maintenance

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

The NTFS file system contains at its core a file called the master file table (MFT). For every file on an NTFS volume there is at least one entry in the MFT. This setting controls the amount of space reserved for the MFT so that it does not become fragmented and slow system performance.

Open your registry and find the key below.

Create a new DWORD value called "NtfsMftZoneReservation" and set it to one of the values from the table below.

  • 1 - Small Zone Reservation (Default)
  • 2 - Medium Zone Reservation
  • 3 - Large Zone Reservation
  • 4 - Maximum Zone Reservation

    Restart Windows for the change to take effect.

    Note: This is a run-time parameter and does not affect the format of a volume. Rather, it affects the way NTFS allocates space on all volumes on a given system. Therefore, to be completely effective, the parameter must be in effect from the time that a volume is formatted throughout the life of the volume.

    Registry Editor Example
    | Name Type Data |
    | (Default) REG_SZ (value not set) |
    | NtfsMftZoneReservation REG_DWORD 0x00000001 (1) |
    -
    | HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem |
    -

    Settings:
    System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem]
    Name: NtfsMftZoneReservation
    Type: REG_DWORD (DWORD Value)
    Value: 1 (default) - 4 (maximum)

    Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

    Last Modified: March 9, 2002

    • Return to Index Copyright © 1998-2003. All Rights Reserved. License


Automatically Resize Images in Internet Explorer (All Windows)

Automatically Resize Images in Internet Explorer (All Windows)
Category: Home > Software > Internet Explorer > Appearance

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether Internet Explorer attempts to automatically resize an image to fit within the window.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'Enable AutoImageResize' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This setting is only applicable to Internet Explorer 5.0 and above.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Enable AutoImageResize | REG_SZ | No | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
Name: Enable AutoImageResize
Type: REG_SZ (String Value)
Value: Yes or No

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 10, 2002


Use Smooth Scrolling in Internet Explorer (All Windows)

Use Smooth Scrolling in Internet Explorer (All Windows)
Category: Home > Software > Internet Explorer > Appearance

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether the smooth scrolling function is used in Internet Explorer to increase the readability while navigating a page.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'SmoothScroll' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This setting is only applicable to Internet Explorer 5.0 and above.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SmoothScroll | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
Name: SmoothScroll
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Related Tweaks

  • Use Smooth Scrolling in Outlook Express (All Windows)
  • Control Whether Windows Performs Smooth Scrolling (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 10, 2002


Show Expanded Add to Favorites Dialog Box (All Windows)

Show Expanded Add to Favorites Dialog Box (All Windows)
Category: Home > Software > Internet Explorer > Appearance

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether an expanded or smaller dialog box is shown when a site is added to the Internet Explorer favorites.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'AddToFavoritesExpanded' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This setting is only applicable to Internet Explorer 5.0 and above.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AddToFavoritesExpanded | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
Name: AddToFavoritesExpanded
Type: REG_DWORD (DWORD Value)
Value: (0 = small, 1 = expanded)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 10, 2002


User Environment Debug Logging (Windows 2000/XP)

User Environment Debug Logging (Windows 2000/XP)
Category: Home > Windows > Troubleshooting > Logging

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting enables debug logging of user profile and system policy processes which may be helpful in troubleshooting problems.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'UserEnvDebugLevel' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: The log file is written to the %SystemRoot%\Debug\UserMode\Userenv.log file.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | UserEnvDebugLevel | REG_DWORD | 0x00010002 (65538) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: UserEnvDebugLevel
Type: REG_DWORD (DWORD Value)
Value: Enabled = 65538 (decimal)

Related Tweaks

  • User Environment Event Logging (Windows 2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: July 28, 2002


Repair the Office Shortcut Bar (All Windows)

Repair the Office Shortcut Bar (All Windows)
Category: Home > Windows > Troubleshooting > Repair

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak will resolve problems where you are unable to customize buttons on the Office XP Shortcut Bar or the buttons appear blank.

Open your registry and find the key below.

Delete the "Shortcut Bar" sub-key and restart any Office applications.

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Shortcut Bar]

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 9, 2002


Display Mouse Pointer Trails (All Windows)

Display Mouse Pointer Trails (All Windows)
Category: Home > Hardware > Mice and Keyboards

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allows you to control whether trails are shown behind the movement of the mouse pointer to increase visibility.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'MouseTrails' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | MouseTrails | REG_SZ | 1 | |
-
| HKEY_CURRENT_USER\Control Panel\Mouse |
-

Settings:
User Key: [HKEY_CURRENT_USER\Control Panel\Mouse]
Name: MouseTrails
Type: REG_SZ (String Value)
Value: (0 =default, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 21, 2002


View System Processor Information (Windows NT/2000/XP)

View System Processor Information (Windows NT/2000/XP)
Category: Home > Hardware > Processor and Motherboard

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

These values contain information about the system processor, including speed, brand and model.

Open your registry and find the key below to view the current values.

Note: These values are read-only and can only be viewed and not edited.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ~MHz | REG_DWORD | 0x00000028A (650) | |
| |  | Identifier | REG_SZ | x86 Family 6 Model 8 Stepping 1 | |
| |  | VendorIdentifier | REG_SZ | GenuineIntel | |
-
| HKEY_LOCAL_MACHINE\HARDWARE\DESCRIPTION\System\CentralProcessor\0 |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\HARDWARE\DESCRIPTION\System\CentralProcessor\0]
Name: ~MHz, Identifier, VendorIdentifier

Related Tweaks

  • View System BIOS Information (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 23, 2002


Use Active Authentication for Unlock and Screen Saver (Windows NT/2000/XP)

Use Active Authentication for Unlock and Screen Saver (Windows NT/2000/XP)
Category: Home > Security > Login and Authentication

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether a full login should be performed when a workstation is unlocked or a password is used with the screen saver. Normally Windows will not check some settings such as whether the account has been locked out.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'ForceUnlockLogon' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: For Windows XP this behavior only happens when you have Fast User Switching disabled.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ForceUnlockLogon | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: ForceUnlockLogon
Type: REG_DWORD (DWORD Value)
Value: 0 = default authentication, 1 = online authentication

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 23, 2002


Modify the Number of Cached Logins (Windows NT/2000/XP)

Modify the Number of Cached Logins (Windows NT/2000/XP)
Category: Home > Security > Login and Authentication

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This value controls the number of allowable cached login attempts when the network domain controller is unavailable.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'CachedLogonsCount' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: With caching disabled or the maximum has been reached, the user is prompted with this message: "The system cannot log you on now because the domain [DOMAIN_NAME] is not available."

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | CachedLogonsCount | REG_SZ | 0 | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: CachedLogonsCount
Type: REG_SZ (String Value)
Value: 0 - 50 (0 = disabled, 10 = default)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 12, 2002


Show Options on Logon Dialog Box (Windows NT/2000/XP)

Show Options on Logon Dialog Box (Windows NT/2000/XP)
Category: Home > Windows > Login and Authentication

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether the options to enter a domain or to log on using a dial-up connection are shown on the Windows logon box.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'ShowLogonOptions' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ShowLogonOptions | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: ShowLogonOptions
Type: REG_DWORD (DWORD Value)
Value: (0 = hide options, 1 = display options)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 23, 2002


Specify Where to Display Printer Notifications (Windows NT/2000/XP)

Specify Where to Display Printer Notifications (Windows NT/2000/XP)
Category: Home > Hardware > Printers and Plotters

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether print job notification should be sent to the local computer or the computer that the user first logged on to.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NetPopupToComputer' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NetPopupToComputer | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Providers |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Providers]
Name: NetPopupToComputer
Type: REG_DWORD (DWORD Value)
Value: (0 = local computer, 1 = users computer)

Related Tweaks

  • Enable Print Job Notification Messages (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 26, 2002


Manage Persistent Connections (Windows NT/2000/XP)

Manage Persistent Connections (Windows NT/2000/XP)
Category: Home > Network > Clients

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether new network mappings should be created as persistent connections that are automatically reconnected at logon.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'SaveConnections' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SaveConnections | REG_SZ | yes | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Network\P... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Network\
Persistent Connections]
Name: SaveConnections
Type: REG_SZ (String Value)
Value: yes or no

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 26, 2002


Sort Start Menu and Favorites in Alphabetical Order (All Windows)

Sort Start Menu and Favorites in Alphabetical Order (All Windows)
Category: Home > Software > Internet Explorer > Appearance

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak allows you to alphabetically sort the Start Menu and Favorites Menu.

Open your registry and find the key below.

To sort the Favorites menu hightlight the "Favorites" sub-key and delete it.

To sort the Start Menu hightlight the "Start Menu" sub-key and delete it.

Changes will take effect after you restart Windows and Internet Explorer.

Note: With Internet Explorer 5 or later you can also sort by right-clicking any item on the menu, and then select Sort by Name.

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
MenuOrder]

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 6, 2002


Send User Identifier in Media Player (All Windows)

Send User Identifier in Media Player (All Windows)
Category: Home > Software > Media Player

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether Windows Media Player will send a globally unique identifier (GUID) when communicating with a remote media source.

Open your registry and find the key below.

Create a new Binary value, or modify the existing value called 'SendUserGUID' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SendUserGUID | REG_BINARY | 00 00 00 00 | |
-
| HKEY_CURRENT_USER\Software\Microsoft\MediaPlayer\Preferences |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\MediaPlayer\Preferences]
Name: SendUserGUID
Type: REG_BINARY (Binary Value)
Value: (00 00 00 00 = disabled, 01 00 00 00 = default)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 3, 2002


Remove Undock Computer from Start Menu (Windows XP)

Remove Undock Computer from Start Menu (Windows XP)
Category: Home > Windows > Start Menu and Taskbar

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This policy is used to hide or display the "Undock Computer" option on the Start Menu.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoStartMenuEjectPC' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This option is only displayed for portable computers with docking stations.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoStartMenuEjectPC | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoStartMenuEjectPC
Type: REG_DWORD (DWORD Value)
Value: (0 = show undock, 1 = hide undock)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 19, 2003


Remove "All Programs" Button from the Start Menu (Windows XP)

Remove "All Programs" Button from the Start Menu (Windows XP)
Category: Home > Windows > Start Menu and Taskbar

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction is used to remove the "All Programs" button which displays a list of all the installed applications.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoStartMenuMorePrograms' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This setting only applies to the Windows XP Start Menu, not the Classic Start Menu.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoStartMenuMorePrograms | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoStartMenuMorePrograms
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = disable button)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 30, 2002


Remove Username from the Start Menu (Windows XP)

Remove Username from the Start Menu (Windows XP)
Category: Home > Windows > Start Menu and Taskbar

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction hides the current username normally displayed at the top of the Windows XP Start Menu.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoUserNameInStartMenu' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This setting only applies to the Windows XP Start Menu, not the Classic Start Menu.

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoUserNameInStartMenu
Type: REG_DWORD (DWORD Value)
Value: (0 = display username, 1 = hide username)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 30, 2002


Remove Pinned Programs List from the Start Menu (Windows XP)

Remove Pinned Programs List from the Start Menu (Windows XP)
Category: Home > Windows > Start Menu and Taskbar

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction removes the pinned programs list from the Start menu. It also removes the Internet and E-mail checkboxes from the Start menu.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoStartMenuPinnedList' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This setting only applies to the Windows XP Start Menu, not the Classic Start Menu.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoStartMenuPinnedList | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoStartMenuPinnedList
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1= enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 30, 2002


Remove Frequent Programs List from the Start Menu (Windows XP)

Remove Frequent Programs List from the Start Menu (Windows XP)
Category: Home > Windows > Start Menu and Taskbar

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction removes the list of frequently used programs from the Start menu.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoStartMenuMFUprogramsList' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This setting only applies to the Windows XP Start Menu, not the Classic Start Menu.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoStartMenuMFUprogramsList | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoStartMenuMFUprogramsList
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 30, 2002


Show Run in Separate Memory Space Option (Windows 2000/XP)

Show Run in Separate Memory Space Option (Windows 2000/XP)
Category: Home > Windows > System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether the "Run in Separate Memory Space" option is shown in the Run box, which allows you to run 16-bit programs in a dedicated Virtual DOS Machine (VDM) process.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'MemCheckBoxInRunDlg' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | MemCheckBoxInRunDlg | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: MemCheckBoxInRunDlg
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = show checkbox)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 30, 2002


Restrict Changes to User Folder Locations (Windows 2000/Me/XP)

Restrict Changes to User Folder Locations (Windows 2000/Me/XP)
Category: Home > Security

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

These restrictions disable the ability for users to change the location of user-specific folders such as My Documents, My Pictures, My Music and Favorites.

Open your registry and find the key below.

For each folder create a new DWORD value from the list below and set it to equal "1" to restrict changes or "0" to allow them.

  • DisablePersonalDirChange - Restrict changes to My Documents
  • DisableMyPicturesDirChange - Restrict changes to My Pictures
  • DisableMyMusicDirChange - Restrict changes to My Music
  • DisableFavoritesDirChange - Restrict changes to Favorites
Log off or restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DisablePersonalDirChange | REG_DWORD | 0x00000001 (1) | |
| |  | DisableMyPicturesDirChange | REG_DWORD | 0x00000001 (1) | |
| |  | DisableMyMusicDirChange | REG_DWORD | 0x00000001 (1) | |
| |  | DisableFavoritesDirChange | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: DisablePersonalDirChange, DisableMyPicturesDirChange, DisableMyMusicDirChange, DisableFavoritesDirChange
Type: REG_DWORD (DWORD Value)
Value: (0 = allow changes, 1 = restrict changes)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 30, 2002


Prompt for Password on Resume (Windows XP)

Prompt for Password on Resume (Windows XP)
Category: Home > Security > System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allows you to configure the computer to always lock and require a password after resuming from hibernate or suspend mode.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'PromptPasswordOnResume' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | PromptPasswordOnResume | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\System\Power |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\System\Power]
System Key: [HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\System\Power]
Name: PromptPasswordOnResume
Type: REG_DWORD (DWORD Value)
Value: (0 = no prompt, 1 = prompt)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 30, 2002


Add or Remove Programs Restrictions (Windows 2000/XP)

Add or Remove Programs Restrictions (Windows 2000/XP)
Category: Home > Security > Control Panel

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

These restrictions apply to the Add/Remove Programs feature of Control Panel. They allow you to entirely or individually disable components.

Open your registry and find the key below.

Create a new DWORD value for each restriction required according to the table below. Set the value to equal "1" to enable the restriction or "0" to disable it.

  • NoAddRemovePrograms - Disable Add/Remove Programs
  • NoRemovePage - Disable Change and Remove Programs
  • NoAddPage - Disable Add Programs
  • NoWindowsSetupPage - Disable Windows Components Wizard
  • NoAddFromCDorFloppy - Hide "Add a program from CD-ROM or disk" option
  • NoAddFromInternet - Hide "Add programs from Microsoft" option
  • NoAddFromNetwork - Hide "Add programs from your network" option
  • NoServices - Go directly to Windows Components Wizard
  • NoSupportInfo - Disable Support Information
You may need to restart Windows for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoAddRemovePrograms | REG_DWORD | 0x00000001 (1) | |
| |  | NoRemovePage | REG_DWORD | 0x00000001 (1) | |
| |  | NoAddPage | REG_DWORD | 0x00000001 (1) | |
| |  | NoWindowsSetupPage | REG_DWORD | 0x00000001 (1) | |
| |  | NoAddFromCDorFloppy | REG_DWORD | 0x00000001 (1) | |
| |  | NoAddFromInternet | REG_DWORD | 0x00000001 (1) | |
| |  | NoAddFromNetwork | REG_DWORD | 0x00000001 (1) | |
| |  | NoServices | REG_DWORD | 0x00000001 (1) | |
| |  | NoSupportInfo | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Uni... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Uninstall]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Uninstall]
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 18, 2002


Remove My Music from the Start Menu (Windows 2000/Me/XP)

Remove My Music from the Start Menu (Windows 2000/Me/XP)
Category: Home > Security > Start Menu and Taskbar > Documents and Folders

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction removes My Music from the Documents folder on the Start Menu.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoStartMenuMyMusic' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoStartMenuMyMusic | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoStartMenuMyMusic
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = remove folder)

Related Tweaks

  • Remove Favorites from the Start Menu (All Windows)
  • Remove Recent Documents from the Start Menu (All Windows)
  • Remove My Documents from the Start Menu (Windows 2000/Me/XP)
  • Remove My Pictures from the Start Menu (Windows 2000/Me/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 3, 2002


Remove My Computer from the Desktop and Start Menu (Windows 2000/Me/XP)

Remove My Computer from the Desktop and Start Menu (Windows 2000/Me/XP)
Category: Home > Windows > Start Menu and Taskbar

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction removes My Computer from the desktop and Start menu.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called '{20D04FE0-3AEA-1069-A2D8-08002B30309D}' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | {20D04FE0-3AEA-1069-A2D8-08002B30309D} | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Non... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
NonEnum]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
NonEnum]
Name: {20D04FE0-3AEA-1069-A2D8-08002B30309D}
Type: REG_DWORD (DWORD Value)
Value: (0 = show, 1 = remove)

Related Tweaks

  • Remove Favorites from the Start Menu (All Windows)
  • Remove Recent Documents from the Start Menu (All Windows)
  • Remove My Documents from the Start Menu (Windows 2000/Me/XP)
  • Remove My Pictures from the Start Menu (Windows 2000/Me/XP)
  • Remove My Music from the Start Menu (Windows 2000/Me/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 16, 2003


Remove My Network Places from the Start Menu (Windows XP)

Remove My Network Places from the Start Menu (Windows XP)
Category: Home > Security > Start Menu and Taskbar

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction hides the My Network Places button on the Windows XP simple Start menu.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoStartMenuNetworkPlaces' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoStartMenuNetworkPlaces | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoStartMenuNetworkPlaces
Type: REG_DWORD (DWORD Value)
Value: (0 = show, 1 = remove)

Related Tweaks

  • Remove My Computer from the Desktop and Start Menu (Windows 2000/Me/XP)
  • Remove Favorites from the Start Menu (All Windows)
  • Remove Recent Documents from the Start Menu (All Windows)
  • Remove Network Connections from the Start Menu (Windows 2000/Me/XP)
  • Remove My Documents from the Start Menu (Windows 2000/Me/XP)
  • Remove My Pictures from the Start Menu (Windows 2000/Me/XP)
  • Remove My Music from the Start Menu (Windows 2000/Me/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 29, 2002


Disable Recent Shares in Network Places (Windows 2000/XP)

Disable Recent Shares in Network Places (Windows 2000/XP)
Category: Home > Security > Network

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction stops remote shared folders from being added to Network Places whenever you open a document in the shared folder.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoRecentDocsNetHood' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoRecentDocsNetHood | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoRecentDocsNetHood
Type: REG_DWORD (DWORD Value)
Value: (0 = track shares, 1 = disable tracking)

Related Tweaks

  • Remove My Network Places from the Start Menu (Windows XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 9, 2002


Force Logoff on the Start Menu (Windows 2000/XP)

Force Logoff on the Start Menu (Windows 2000/XP)
Category: Home > Security > Start Menu and Taskbar

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting forces the Logoff button to appear on the Start menu and prevents users from removing or hiding it.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'ForceStartMenuLogoff' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ForceStartMenuLogoff | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: ForceStartMenuLogoff
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1= force logoff button)

Related Tweaks

  • Remove Log Off from the Start Menu (All Windows)
  • Restrict the Start Menu Log Off Option (Windows 2000/Me/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 3, 2002


Network Connection Restrictions (Windows 2000/XP)

Network Connection Restrictions (Windows 2000/XP)
Category: Home > Security > Network

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

These restrictions control access to the features and properties of LAN, RAS and other network connections.

Open your registry and find the key below.

Create a new DWORD value for each required restriction from the list below. Set the value to "0" to enable the restriction or delete the value to disable it.

  • NC_AddRemoveComponents - Restrict add and remove network components
  • NC_AdvancedSettings - Restrict changes to Advanced Settings
  • NC_AllowAdvancedTCPIPConfig - Restrict changes to advanced TCPIP configuration
  • NC_ChangeBindState - Restrict changes to protocol and service bindings
  • NC_DeleteAllUserConnection - Restrict deletion of public RAS connections
  • NC_DeleteConnection - Restrict deletion of RAS connections
  • NC_DialupPrefs - Restrict changes to the Dial-up Preferences
  • NC_EnableAdminProhibits - Enable Windows 2000 network connections for administrators
  • NC_LanChangeProperties - Restrict access to component properties of a LAN connection
  • NC_LanConnect - Restrict connecting and disconnecting a LAN connection
  • NC_LanProperties - Restrict access to properties of a LAN connection
  • NC_NewConnectionWizard - Disable the Network Connection wizard
  • NC_RasAllUserProperties - Restrict access to properties of public RAS connections
  • NC_RasChangeProperties - Restrict access to properties of a RAS connection
  • NC_RasConnect - Restrict connecting and disconnecting a RAS connection
  • NC_RasMyProperties - Restrict access to private RAS connection properties
  • NC_RenameAllUserRasConnection - Restrict renaming of public RAS connections
  • NC_RenameConnection - Restrict renaming of connections
  • NC_RenameLanConnection - Restrict renaming of LAN connections
  • NC_RenameMyRasConnection - Restrict renaming of private RAS connections
  • NC_Statistics - Disable status statistics for an active connection
Restart Windows for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NC_AddRemoveComponents | REG_DWORD | 0x00000000 (0) | |
| |  | NC_AdvancedSettings | REG_DWORD | 0x00000000 (0) | |
| |  | NC_AllowAdvancedTCPIPConfig | REG_DWORD | 0x00000000 (0) | |
| |  | NC_ChangeBindState | REG_DWORD | 0x00000000 (0) | |
| |  | NC_DeleteAllUserConnection | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Network Connections |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\
Network Connections]
Type: REG_DWORD (DWORD Value)
Value: (0 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 26, 2003


Secure Access to Removable Drives (Windows NT/2000/XP)

Secure Access to Removable Drives (Windows NT/2000/XP)
Category: Home > Security > System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting determines whether the ability to access removable drives is available to other users.

Open your registry and find the key below.

Create a new string value, or modify the existing value, called "AllocateDASD" and set it according to the table below.

  • 0 - Administrators only
  • 1 - Administrators and power users
  • 2 - Administrators and the interactive user
Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AllocateDASD | REG_SZ | 1 | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: AllocateDASD
Type: REG_SZ (String Value)

Related Tweaks

  • Secure Access to Floppy Drives (Windows NT/2000/XP)
  • Secure Access to CD-ROM Drives (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: November 14, 2002


Remove Windows Messenger from Internet Explorer (All Windows)

Remove Windows Messenger from Internet Explorer (All Windows)
Category: Home > Software > Windows Messenger

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak can be used to remove the integration of Windows Messenger into Internet Explorer. It will remove both the toolbar icon and Tools menu item.

Open your registry and find the key below.

Highlight the key and select Edit | Rename, add a minus symbol ("-") to the start of the key name so that it is now called "-{FB5F1910-F110-11d2-BB9E-00C04F795683}".

Restart Internet Explorer for the change to take effect. To re-enable Messenger integration rename the key and remove the minus symbol.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Extensions\
{FB5F1910-F110-11d2-BB9E-00C04F795683}]

Related Tweaks

  • Remove Windows Messenger from Outlook Express (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 16, 2002


Change the Search Assistant in Internet Explorer (All Windows)

Change the Search Assistant in Internet Explorer (All Windows)
Category: Home > Software > Internet Explorer > Search Features

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak allows you to specify an alternate search assistant page, such as Google, in Internet Explorer.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'SearchAssistant' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: To use the Google search assistant page enter "http://www.google.com/ie" as the URL.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SearchAssistant | REG_SZ | http://www.google.com/ie | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Search |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Search]
Name: SearchAssistant
Type: REG_SZ (String Value)
Value: Search URL

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 29, 2002


Disable Low Disk Space Notification (Windows XP)

Disable Low Disk Space Notification (Windows XP)
Category: Home > Windows > File System > Maintenance

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether you receive a "Low Disk Space" warning when free disk space reaches less than 200 megabytes.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoLowDiskSpaceChecks' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoLowDiskSpaceChecks | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoLowDiskSpaceChecks
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = disable messages)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 8, 2002


Change the Taskbar Group Size (Windows XP)

Change the Taskbar Group Size (Windows XP)
Category: Home > Windows > Start Menu and Taskbar > Taskbar

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting defines the number of open windows of the same application before they are grouped together on the taskbar.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'TaskbarGroupSize' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | TaskbarGroupSize | REG_DWORD | 0x00000006 (6) | |
-
| HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Adv... |
-

Settings:
User Key: [HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\
Advanced]
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\
Advanced]
Name: TaskbarGroupSize
Type: REG_DWORD (DWORD Value)
Value: Number of windows (default = 3)

Related Tweaks

  • Group Similar Taskbar Buttons (Windows XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 12, 2002


Disable Codec Downloads in Media Player (All Windows)

Disable Codec Downloads in Media Player (All Windows)
Category: Home > Software > Media Player

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction prevents audio and video codecs from being downloaded in Windows Media Player. When enabled it also restricts the ability to re-enable downloads.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'PreventCodecDownload' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: Requires Windows Media Player 8.0 or greater.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | PreventCodecDownload | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Policies\Microsoft\WindowsMediaPlayer |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Policies\Microsoft\WindowsMediaPlayer]
System Key: [HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\WindowsMediaPlayer]
Name: PreventCodecDownload
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 15, 2002


Lock the Selected Media Player Skin (All Windows)

Lock the Selected Media Player Skin (All Windows)
Category: Home > Software > Media Player

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction allows you to define and lock the Windows Media Player skin. In addition the user cannot switch the player to full mode or use any features that are not available within the specified skin.

Open your registry and fine the key below.

Create a new string value called "DefaultSkin" and set it to equal the name of the required skin.

Create a new DWORD value called "SetAndLockSkin" and set it to "1" to enable the restriction.

Restart Media Player for the change to take effect.

Note: Requires Windows Media Player 8.0 or greater.

Note: You must use the complete file name for the skin (for example classic.wmz)

Registry Editor Example
| | Name |  | Type | Data | |
| |  | DefaultSkin | REG_SZ | Classic.wmz | |
| |  | SetAndLockSkin | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Policies\Microsoft\WindowsMediaPlayer |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Policies\Microsoft\WindowsMediaPlayer]
System Key: [HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\WindowsMediaPlayer]
Name: SetAndLockSkin, DefaultSkin

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 15, 2002


Hide Anchor Window in Media Player (All Windows)

Hide Anchor Window in Media Player (All Windows)
Category: Home > Software > Media Player

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting hides the anchor window which is normally shown when using Windows Media Player in compact or skin mode. It also restricts users from re-enabling the window.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'DoNotShowAnchor' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: Requires Windows Media Player 8.0 or greater.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DoNotShowAnchor | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Policies\Microsoft\WindowsMediaPlayer |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Policies\Microsoft\WindowsMediaPlayer]
System Key: [HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\WindowsMediaPlayer]
Name: DoNotShowAnchor
Type: REG_DWORD (DWORD Value)
Value: (0 = show anchor, 1 = hide anchor)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 15, 2002


Disable Ability to Skip Startup Programs (Windows NT/2000/XP)

Disable Ability to Skip Startup Programs (Windows NT/2000/XP)
Category: Home > Windows > Startup and Shutdown

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Normally if you hold the Shift key while Windows is loading you can prevent the Startup applications from being launched. This setting disables the ability to by-pass these programs.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'IgnoreShiftOveride' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | IgnoreShiftOveride | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: IgnoreShiftOveride
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = ignore shift)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 17, 2002


Change the Number of Active Directory Search Results (Windows 2000/XP)

Change the Number of Active Directory Search Results (Windows 2000/XP)
Category: Home > Windows > Windows Explorer > Search

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting specifies the number of search results to be returned from a Active Directory query. This allows you to increase or decrease the default 10,000 objects.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'QueryLimit' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | QueryLimit | REG_DWORD | 0x00002710 (10000) | |
-
| HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Directory UI |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Directory UI]
Name: QueryLimit
Type: REG_DWORD (DWORD Value)
Value: Number of Results (0 = unlimited)

Related Tweaks

  • Hide the Active Directory Folder in My Network Places (Windows 2000)
  • Show Filter in Active Directory Search Results (Windows 2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 12, 2002


Show Filter in Active Directory Search Results (Windows 2000/XP)

Show Filter in Active Directory Search Results (Windows 2000/XP)
Category: Home > Windows > Windows Explorer > Search

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether a filter box, which allows you to filter based on additional parameters, is shown above the Active Directory search results.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'EnableFilter' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | EnableFilter | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Directory UI |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Directory UI]
Name: EnableFilter
Type: REG_DWORD (DWORD Value)
Value: (0 = disable filter, 1 = enable)

Related Tweaks

  • Change the Number of Active Directory Search Results (Windows 2000/XP)
  • Hide the Active Directory Folder in My Network Places (Windows 2000)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 18, 2002


Hide the Active Directory Folder in My Network Places (Windows 2000)

Hide the Active Directory Folder in My Network Places (Windows 2000)
Category: Home > Security > Network

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction is used to remove the Active Directory folder from My Network Places. This still allows users to search but not browse the Active Directory.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'HideDirectoryFolder' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | HideDirectoryFolder | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Directory UI |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Directory UI]
Name: HideDirectoryFolder
Type: REG_DWORD (DWORD Value)
Value: (0 = display, 1 = hide)

Related Tweaks

  • Change the Number of Active Directory Search Results (Windows 2000/XP)
  • Show Filter in Active Directory Search Results (Windows 2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 19, 2002


Restrict Changes to Animation Settings (Windows 2000/XP)

Restrict Changes to Animation Settings (Windows 2000/XP)
Category: Home > Security > Control Panel > Display

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction prevents users from selecting the option to animate the movement of windows and menus.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoChangeAnimation' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoChangeAnimation | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoChangeAnimation
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = enable restriction)

Related Tweaks

  • Control the Windows Animation Function (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 27, 2002


Hide the Keyboard Navigation Settings (Windows 2000/XP)

Hide the Keyboard Navigation Settings (Windows 2000/XP)
Category: Home > Security > Control Panel > Display

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction disables the "Hide keyboard navigation indicators until I use the ALT key" option in the Display Control Panel.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoChangeKeyboardNavigationIndicators' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoChangeKeyboardNavigationIndicators | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoChangeKeyboardNavigationIndicators
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 27, 2002


Change Alternate Installation Credential Settings (Windows 2000/XP)

Change Alternate Installation Credential Settings (Windows 2000/XP)
Category: Home > Security

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

These settings control whether users are prompted to enter alternate logon credentials when installing software as a non administrative user.

Open your registry and find the key below.

Create new DWORD values according to the options below.

NoRunasInstallPrompt

  • "1" - Disable alternate credentials option
  • "0" (Default) - Request alternate credentials

    PromptRunasInstallNetPath

  • "1" - Request alternate credentails when installing from a network share.
  • "0" (Default) - Disable alternate credentials option

    Restart Windows for the change to take effect.

    Registry Editor Example
    | Name Type Data |
    | (Default) REG_SZ (value not set) |
    | NoRunasInstallPrompt REG_DWORD 0x00000000 (0) |
    | PromptRunasInstallNetPath REG_DWORD 0x00000001 (1) |
    -
    | HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
    -

    Settings:
    User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
    Explorer]
    System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
    Explorer]
    Name: NoRunasInstallPrompt, PromptRunasInstallNetPath
    Type: REG_DWORD (DWORD Value)
    Value: (0 = default, 1 = enable)

    Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

    Last Modified: April 27, 2002

    • Return to Index Copyright © 1998-2003. All Rights Reserved. License


Clear the Recent Play List in Media Player (All Windows)

Clear the Recent Play List in Media Player (All Windows)
Category: Home > Security > Privacy

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak allows you to clear the recent files, URL history and radio stations in Windows Media Player.

Open your registry and find the key below.

To remove content that has been streamed from a particular Web site, clear the [...\RecentURLList] sub-key.

To remove the entire file list that you recently played, clear the [...\RecentFileList] sub-key.

To remove entries from the radio toolbar clear the [HKEY_CURRENT_USER\Software\Microsoft\MediaPlayer\Radio\MRUList] key.

Restart Windows Media Player for the change to take effect.

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\MediaPlayer\Player]

Related Tweaks

  • Disable Recent Files in Media Player (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 4, 2002


Change the Color of Encrypted Files (Windows XP)

Change the Color of Encrypted Files (Windows XP)
Category: Home > Windows > Appearance

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When a file or folder is encrypted it is normally shown using a different color in Explorer. This setting defines which color to use.

Open your registry and find the key below.

Create a new Binary value, or modify the existing value called 'AltEncryptionColor' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AltEncryptionColor | REG_BINARY | 00 80 40 00 | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer]
Name: AltEncryptionColor
Type: REG_BINARY (Binary Value)
Value: RR GG BB 00 (default = 00 80 40 00)

Related Tweaks

  • Change the Color of Compressed Files and Folders (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 1, 2002


Search from the Address Bar in Internet Explorer (All Windows)

Search from the Address Bar in Internet Explorer (All Windows)
Category: Home > Software > Internet Explorer > Search Features

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Save time with this tweak that allows you to specify the search engine to query by typing a request directly into the Internet Explorer address bar.

Once you have defined the search engines you can then search by typing the shortcut name followed by the keywords. For example you could search Google for "regedit" with the command "google regedit".

Open you registry and find the key below.

For each search engine you wish to add follow these steps:

  1. Create a new sub key and name it after the shortcut you'd like to type in the address bar to access the engine. For example; "google" to access Google or "yahoo" to access Yahoo!
  2. Open the new sub key and set the value of (Default) to equal the search engine query URL, inserting "%s" in place of the keywords. For example:
    • Google = "http://www.google.com/search?q=%s"
    • Yahoo = "http://search.yahoo.com/bin/search?p=%s"
    • AltaVista = "http://www.altavista.com/q?q=%s"
Restart Internet Explorer for the changes to take effect.

Note: This tweak only applies to Internet Explorer 6.0 and above.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | (Default) | REG_SZ | http://www.google.com/search?q=%s | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\SearchUrl |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\SearchUrl]

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 3, 2002


Change the Thumbnail Image Settings (Windows XP)

Change the Thumbnail Image Settings (Windows XP)
Category: Home > Windows > Appearance

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

These settings control the format of the saved thumbnail images, including the image size and quality.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value, called "ThumbnailSize" and set it to the size of the image in pixels. The default is 96.

Create another new DWORD value, or modify the existing value, called "ThumbnailQuality" and set a number that represents the quality percentage between 50% and 100%, the higher quality the larger the file. The default is 90.

Restart Windows for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ThumbnailQuality | REG_DWORD | 0x0000005a (90) | |
| |  | ThumbnailSize | REG_DWORD | 0x00000060 (96) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer]
Name: ThumbnailSize, ThumbnailQuality
Type: REG_DWORD (DWORD Value)
Value: Size in pixels, Quality Percentage

Related Tweaks

  • Disable the Thumbnail Cache (Windows XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 11, 2002


Use Classic Search in Explorer (Windows XP)

Use Classic Search in Explorer (Windows XP)
Category: Home > Windows > Windows Explorer > Search

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak allows you to disable the new Search Assistant and use the traditional search interface in Explorer.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'Use Search Asst' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Use Search Asst | REG_SZ | no | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Cab... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
CabinetState]
Name: Use Search Asst
Type: REG_SZ (String Value)
Value: yes or no (default = yes)

Related Tweaks

  • Use Classic Search in Internet Explorer (Windows XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 4, 2002


Use Classic Search in Internet Explorer (Windows XP)

Use Classic Search in Internet Explorer (Windows XP)
Category: Home > Software > Internet Explorer > Search Features

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak allows you to disable the new Search Assistant and use the traditional search interface in Internet Explorer.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'Use Search Asst' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Use Search Asst | REG_SZ | no | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
Name: Use Search Asst
Type: REG_SZ (String Value)
Value: yes or no (default = yes)

Related Tweaks

  • Use Classic Search in Explorer (Windows XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 4, 2002


Disable Multi-User Editing in Microsoft Word (All Windows)

Disable Multi-User Editing in Microsoft Word (All Windows)
Category: Home > Software > Microsoft Office > Word

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Multi-user editing is a new feature in Word 2002 and Office XP which allows you to open a document that is locked for editing by another user, edit a local copy of the document, and then merge those changes into the original document.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoPromptToForkDocuments' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoPromptToForkDocuments | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Options |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Options]
Name: NoPromptToForkDocuments
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = disable multi-user editing)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 8, 2002


Modify the Number of File Handles for DOS Programs (Windows Me)

Modify the Number of File Handles for DOS Programs (Windows Me)
Category: Home > Tips and Tricks > Configuration Files > SYSTEM.INI

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls the number of file handles available to MS-DOS programs run in each virtual machine. In Windows Me, each MS-DOS VM is given the default value of 30 file handles.

Using notepad open the SYSTEM.INI file in your Windows directory.

Add the following line to the [386Enh] section:

PerVMFiles= number
Restart Windows for the change to take effect.

Settings:
Value: Set "PerVMFiles" to the Number of Files

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 12, 2002


Change Wheel Mouse Detection (Windows NT/2000/XP)

Change Wheel Mouse Detection (Windows NT/2000/XP)
Category: Home > Hardware > Mice and Keyboards

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether the driver should attempt to detect and enable the wheel on the mouse device. The mouse wheel provides rapid scrolling and other control features.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'EnableWheelDetection' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\i8042prt\Parameters]
Name: EnableWheelDetection
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = automatic, 2 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 14, 2002


Remove Deleted Information from Outlook (All Windows)

Remove Deleted Information from Outlook (All Windows)
Category: Home > Software > Microsoft Office > Outlook

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Even though an item may have been deleted in Outlook some remnants of it could still remain accessible in the raw data files. This setting causes Outlook 2000 and 2002 (XP) to completely remove all deleted data when it is shut down.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'PSTNullFreeOnClose' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This feature was first made available in Microsoft Office 2000 Service Release 1 (SR-1).

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | PSTNullFreeOnClose | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Office\[office version]\Outlook\PST |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Office\[office version]\Outlook\PST]
Name: PSTNullFreeOnClose
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = clear deleted data)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: November 24, 2002


Disable Password Caching in Office 2000 (All Windows)

Disable Password Caching in Office 2000 (All Windows)
Category: Home > Software > Microsoft Office

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Office 2000 normally attempts to cache user authentication information when establishing connections with external data sources. Because the password is saved into a text file, this creates a potential security problem.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'DisablePwdCaching' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This primarily affects new database queries used to retrieve data from external sources into Microsoft Excel.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DisablePwdCaching | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\Software\Microsoft\Office\9.0\Common\Security |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Office\9.0\Common\Security]
Name: DisablePwdCaching
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = disable caching)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 16, 2002


Disable Secondary Credentials Dialog Box in Outlook (All Windows)

Disable Secondary Credentials Dialog Box in Outlook (All Windows)
Category: Home > Software > Microsoft Office > Outlook

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allows you to disable the secondary credentials dialog box that is displayed when you start Outlook 2002 and log on to a Microsoft Exchange Server computer that is in a different domain than the client.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'DisablePWDialog' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This setting requires that Office XP Service Pack 1 (SP-1) or greater has been installed.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DisablePWDialog | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Outlook\RPC |
-

Settings:
System Key: [HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Outlook\RPC]
Name: DisablePWDialog
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = disable secondary box)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 27, 2002


Disable Save As Web Page Complete (All Windows)

Disable Save As Web Page Complete (All Windows)
Category: Home > Software > Internet Explorer > Security

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction disables the ability to save complete web pages including images, scripts, linked files and other elements in Internet Explorer.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoBrowserSaveWebComplete' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This option is only available in Internet Explorer 5.01 or greater.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoBrowserSaveWebComplete | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Infodeli... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\
Infodelivery\Restrictions]
System Key: [HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Internet Explorer\
Infodelivery\Restrictions]
Name: NoBrowserSaveWebComplete
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 22, 2002


Restrict Desktop Theme Controls (Windows XP)

Restrict Desktop Theme Controls (Windows XP)
Category: Home > Security > Control Panel > Display

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

These restrictions control access to the desktop theme settings including the Windows styles, buttons, schemes and fonts.

Open your registry and find the key below.

For each required restriction create a new DWORD value from the list below and set the value to "1" to enable it.

  • NoVisualStyleChoice - Disable the "Windows and buttons" style control
  • NoColorChoice - Disable the "Color scheme" control
  • NoSizeChoice - Disable the "Font size" control
To specify the default style create a new string value called "SetVisualStyle" and set it to the full path and filename of the required .msstyles file.

Changes should take effect immediately.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoColorChoice | REG_DWORD | 0x00000001 (1) | |
| |  | NoSizeChoice | REG_DWORD | 0x00000001 (1) | |
| |  | NoVisualStyleChoice | REG_DWORD | 0x000000001 (1) | |
| |  | SetVisualStyle | REG_SZ | C:\WINDOWS\Resources\Themes\Lun... | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
Name: NoColorChoice, NoSizeChoice, NoVisualStyleChoice, SetVisualStyle

Related Tweaks

  • Hide the Themes Settings Page (Windows XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 2, 2002


Hide the Themes Settings Page (Windows XP)

Hide the Themes Settings Page (Windows XP)
Category: Home > Security > Control Panel > Display

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This option hides the Themes tag which prevents the user from selecting an alternate theme. Themes normally include a background plus sounds, icons and other elements.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoThemesTab' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoThemesTab | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoThemesTab
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = enable restriction)

Related Tweaks

  • Restrict Desktop Theme Controls (Windows XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 22, 2002


Restrict Task Creation and Deletion (Windows 2000/Me/XP)

Restrict Task Creation and Deletion (Windows 2000/Me/XP)
Category: Home > Windows > Accessories > Task Scheduler

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

These settings allow you to restrict the creation and deletion of items in Task Scheduler.

Open your registry and find the key below. You may need to create the key if it does not already exist.

Create two new DWORD values called 'Task Creation' and 'Task Deletion' and set them to '1' to disable task creation or task deletion respectively.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: These settings do not prevent administrators from using the AT.EXE program to create new tasks.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Task Creation | REG_DWORD | 0x00000001 (1) | |
| |  | Task Deletion | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Task Scheduler5.0 |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Task Scheduler5.0]
System Key: [HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\Task Scheduler5.0]
Name: Task Creation, Task Deletion
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 24, 2002


Disable Changes to Task Properties (Windows 2000/Me/XP)

Disable Changes to Task Properties (Windows 2000/Me/XP)
Category: Home > Windows > Accessories > Task Scheduler

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting restricts users from changing the properties of an existing item in Task Scheduler.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'Property Pages' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This setting only applies to existing tasks, users may still specify advanced properties on new tasks.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Property Pages | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Task Scheduler5.0 |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Task Scheduler5.0]
System Key: [HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\Task Scheduler5.0]
Name: Property Pages
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = enable restriction)

Related Tweaks

  • Remove Advanced Option from Task Scheduler Wizard (Windows 2000/Me/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 24, 2002


Remove Advanced Option from Task Scheduler Wizard (Windows 2000/Me/XP)

Remove Advanced Option from Task Scheduler Wizard (Windows 2000/Me/XP)
Category: Home > Windows > Accessories > Task Scheduler

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting removes the "Open advanced properties for this task when I click Finish" checkbox from the task creation wizard. This should be enabled to simplify the process for novice users.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'Disable Advanced' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This setting does not prevent users from changing the properties of an existing task.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Disable Advanced | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Task Scheduler5.0 |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Task Scheduler5.0]
System Key: [HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\Task Scheduler5.0]
Name: Disable Advanced
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = enable restriction)

Related Tweaks

  • Disable Changes to Task Properties (Windows 2000/Me/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 24, 2002


Disable Changes to Task Run Command (Windows 2000/Me/XP)

Disable Changes to Task Run Command (Windows 2000/Me/XP)
Category: Home > Windows > Accessories > Task Scheduler

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting restricts changes to the run command and disables the Browse button in the Task Scheduler properties.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'Allow Browse' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Allow Browse | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Task Scheduler5.0 |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Task Scheduler5.0]
System Key: [HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\Task Scheduler5.0]
Name: Allow Browse
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 24, 2002


Disable Drag and Drop Task Scheduling (Windows 2000/Me/XP)

Disable Drag and Drop Task Scheduling (Windows 2000/Me/XP)
Category: Home > Windows > Accessories > Task Scheduler

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction disables the ability to drag and drop programs into the Scheduled Tasks folder. This also disables the functionality of the Cut, Copy and Paste shortcut items.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'DragAndDrop' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DragAndDrop | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Task Scheduler5.0 |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Task Scheduler5.0]
System Key: [HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\Task Scheduler5.0]
Name: DragAndDrop
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 27, 2002


Disable Manual Task Control (Windows 2000/Me/XP)

Disable Manual Task Control (Windows 2000/Me/XP)
Category: Home > Windows > Accessories > Task Scheduler

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction disables the ability for users to manually start and stop scheduled tasks. Tasks will continue to run automatically as configured.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'Execution' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Execution | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Task Scheduler5.0 |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Task Scheduler5.0]
System Key: [HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\Task Scheduler5.0]
Name: Execution
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 24, 2002


Force the Control Panel Display Style (Windows XP)

Force the Control Panel Display Style (Windows XP)
Category: Home > Security > Control Panel

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting specifies the visual style of the Control Panel. Allowing you to either force the use of the new XP style, classic style or allow the user to select the preferred style.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'ForceClassicControlPanel' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ForceClassicControlPanel | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: ForceClassicControlPanel
Type: REG_DWORD (DWORD Value)
Value: (0 = force new, 1 = force classic)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 24, 2002


Run the Logon Scripts Synchronously (Windows 2000/XP)

Run the Logon Scripts Synchronously (Windows 2000/XP)
Category: Home > Windows > System > Scripts

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting directs the system to wait for the logon scripts to finish running before it starts the Windows Explorer interface program and creates the desktop.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'RunLogonScriptSync' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: If you enable this setting, Windows Explorer does not start until the logon scripts have finished running. This setting ensures that logon script processing is complete before the user starts working, but it can delay the appearance of the desktop.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | RunLogonScriptSync | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System |
-

Settings:
User Key: [HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\
System]
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\
System]
Name: RunLogonScriptSync
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = synchronously)

Related Tweaks

  • Run Logon Scripts Synchronously (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 27, 2002


Run the Startup Scripts Asynchronously (Windows 2000/XP)

Run the Startup Scripts Asynchronously (Windows 2000/XP)
Category: Home > Windows > System > Scripts

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Startup scripts are files that run before the user logs on. Normally the startup scripts run consecutively, but when this setting is enabled the scripts can run simultaneously.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'RunStartupScriptSync' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | RunStartupScriptSync | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Sy... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\
System]
Name: RunStartupScriptSync
Type: REG_DWORD (DWORD Value)
Value: (0 = asynchronously, 1 = synchronously)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 27, 2002


Hide the Shutdown Scripts (Windows 2000/XP)

Hide the Shutdown Scripts (Windows 2000/XP)
Category: Home > Windows > System > Scripts

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether the output from the shutdown scripts is displayed in a console window as the script executes.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'HideShutdownScripts' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | HideShutdownScripts | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Sy... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\
System]
Name: HideShutdownScripts
Type: REG_DWORD (DWORD Value)
Value: (0 = display, 1 = hide)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 27, 2002


Hide the Startup Scripts (Windows 2000/XP)

Hide the Startup Scripts (Windows 2000/XP)
Category: Home > Windows > System > Scripts

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether the output from the startup scripts is displayed in a console window as the script executes.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'HideStartupScripts' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | HideStartupScripts | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Sy... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\
System]
Name: HideStartupScripts
Type: REG_DWORD (DWORD Value)
Value: (0 = display, 1 = hide)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 27, 2002


Hide the Welcome Screen (Windows 2000)

Hide the Welcome Screen (Windows 2000)
Category: Home > Windows > Login and Authentication

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting hides the welcome screen that is normally displayed each time the user logs on to Windows 2000 or XP Professional.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoWelcomeScreen' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: Users can still display the welcome screen by selecting it on the Start menu or by typing "Welcome" in the Run dialog box.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoWelcomeScreen | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Ex... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoWelcomeScreen
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = hide)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 5, 2003


Hide the Logon Scripts (Windows 2000/XP)

Hide the Logon Scripts (Windows 2000/XP)
Category: Home > Windows > System > Scripts

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether the output from the logon scripts is displayed in a console window as the script executes.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'HideLogonScripts' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | HideLogonScripts | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System |
-

Settings:
User Key: [HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\
System]
Name: HideLogonScripts
Type: REG_DWORD (DWORD Value)
Value: (0 = display, 1 = hide)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 27, 2002


Hide the Logoff Scripts (Windows 2000/XP)

Hide the Logoff Scripts (Windows 2000/XP)
Category: Home > Windows > System > Scripts

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether the output from the logoff scripts is displayed in a console window as the script executes.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'HideLogoffScripts' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | HideLogoffScripts | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System |
-

Settings:
User Key: [HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\
System]
Name: HideLogoffScripts
Type: REG_DWORD (DWORD Value)
Value: (0 = display, 1 = hide)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 27, 2002


Hide the Legacy Logon Scripts (Windows 2000/XP)

Hide the Legacy Logon Scripts (Windows 2000/XP)
Category: Home > Windows > System > Scripts

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether the output from legacy Windows NT 4.0 logon scripts is displayed in a console window as the script executes.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'HideLegacyLogonScripts' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | HideLegacyLogonScripts | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System |
-

Settings:
User Key: [HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\
System]
Name: HideLegacyLogonScripts
Type: REG_DWORD (DWORD Value)
Value: (0 = display, 1 = hide)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 27, 2002


Remove the Hardware Tab (Windows 2000/XP)

Remove the Hardware Tab (Windows 2000/XP)
Category: Home > Security > Desktop and Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction removes the hardware tab from applicable items in the Control Panel and from the local drive properties. This prevents users from changing the hardware device properties.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoHardwareTab' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoHardwareTab | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoHardwareTab
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 27, 2002


Remove the Security Tab (Windows XP)

Remove the Security Tab (Windows XP)
Category: Home > Security > Desktop and Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction removes the Security tab from Windows explorer which prevents users from accessing or changing the security permissions of folder and file objects.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoSecurityTab' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoSecurityTab | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoSecurityTab
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 27, 2002


Remove the Distributed File System Tab (Windows 2000/XP)

Remove the Distributed File System Tab (Windows 2000/XP)
Category: Home > Security > Desktop and Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction removes the Distributed File System (DFS) tab from Windows explorer. This prevents users from viewing or changing the properties of local DFS shares.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoDFSTab' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoDFSTab | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoDFSTab
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 27, 2002


Enable Shutdown Event Tracker (Windows XP)

Enable Shutdown Event Tracker (Windows XP)
Category: Home > Windows > Startup and Shutdown

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

The Shutdown Event Tracker provides a simple and standard mechanism you can use to consistently document the reasons for shutting down or restarting your computer. The information provided is recorded in the system log in Event Viewer.

Open your registry and find the key below.

Create a new DWORD value or modify the existing value named "ShutdownReasonUI" and set it to "1" to enable shutdown event tracking.

When enabled an additional drop-down option box will be displayed with various planned and unplanned shutdown reasons.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ShutdownReasonUI | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Reliability |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Reliability]
Name: ShutdownReasonUI
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 6, 2002


Specify the Background Image and Wallpaper Style (Windows 2000/Me/XP)

Specify the Background Image and Wallpaper Style (Windows 2000/Me/XP)
Category: Home > Security > Desktop and Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

These settings allow you to specify the background wallpaper and display style. When this setting is defined users can not choose an alternative background image.

Open your registry and find the key below.

To specify the wallpaper create a new string value called "Wallpaper" and set it to the full path and filename of the image.

Additionally, to specify the display style, create a new string value called "WallpaperStyle" and set it to either "0", "1" or "2" according to the list below.

  • 0 - Centered (Default)
  • 1 - Tiled
  • 2 - Stretched

You may need to restart Windows for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Wallpaper | REG_SZ | C:\Windows\Logo.bmp | |
| |  | WallpaperStyle | REG_SZ | 2 | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
System]
Name: Wallpaper, WallpaperStyle
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 21, 2002


Content Advisor Restrictions (All Windows)

Content Advisor Restrictions (All Windows)
Category: Home > Software > Internet Explorer > Security

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

These settings allow you to control the Content Advisor feature of Internet Explorer. Including the option to disable Content Advisor, require a supervisor password and view unrated content.

Open your registry and find the key below, create it if it does not already exist.

Create a new DWORD value for each required restriction from the list below.

  • Enabled - (1 = enable content advisor, 0 = disable)
  • Allow_Unknowns - (1 = display unrated sites, 0 = restrict unrated sites)
  • PleaseMom - (1 = allow supervisor password, 0 = no supervisor override)
Restart Internet Explorer for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Allow_Unknowns | REG_DWORD | 0x00000001 (1) | |
| |  | Enabled | REG_DWORD | 0x00000001 (1) | |
| |  | PleaseMom | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Ra... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\
Ratings\.Default]
Name: Allow_Unknowns, Enabled, PleaseMom
Type: REG_DWORD (DWORD Value)
Value: (0 = disable, 1 = enable restriction)

Related Tweaks

  • Remove the Content Advisor and Ratings Password (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 11, 2002


Keep Remote Connections Active After Logging Off (Windows NT/2000/XP)

Keep Remote Connections Active After Logging Off (Windows NT/2000/XP)
Category: Home > Network > Internet and Remote Access

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When you log off from a Windows client any Remote Access Service (RAS) connections will be automatically disconnected. Enable this setting to remain connected after logging off.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'KeepRasConnections' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This behavior is different from versions of Windows NT RAS earlier than Windows NT 4.0; earlier version of Windows NT remain connected when logging off from the local computer.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | KeepRasConnections | REG_SZ | 1 | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: KeepRasConnections
Type: REG_SZ (String Value)
Value: ("0" = disconnect, "1" = remain connected)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 16, 2002


Show "Send to" Context Menu (All Windows)

Show "Send to" Context Menu (All Windows)
Category: Home > Windows > Windows Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allows you to control whether the "Send to" context menu is displayed when a file or directory object is right-clicked in Explorer.

Open your registry and find the key below.

Create a new String value, or modify the existing value called '(Default)' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
-
| HKEY_CLASSES_ROOT\AllFilesystemObjects\shellex\ContextMenuHandlers\Send To |
-

Settings:
System Key: [HKEY_CLASSES_ROOT\AllFilesystemObjects\shellex\ContextMenuHandlers\
Send To]
Name: (Default)
Type: REG_SZ (String Value)
Value: (empty = disabled, "{7BA4C740-9E81-11CF-99D3-00AA004AE837}" = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 18, 2002


Specify Unknown File Type Options (All Windows)

Specify Unknown File Type Options (All Windows)
Category: Home > Windows > Windows Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

These settings allow you to specify a description and the application to launch to view files with an unknown extension.

Open your registry and find the key below.

Set the "(Default)" value to equal the description you want to use for unknown file types.

Create a new sub-key called [HKEY_CLASSES_ROOT\Unknown\shell\Open\Command] and set the "(Default)" value to equal the command used to view unknown file types. Substitute the symbol "%1" to represent the filename in the command (e.g. "notepad.exe %1").

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | Unknown File Type | |
-
| HKEY_CLASSES_ROOT\Unknown |
-

Settings:
System Key: [HKEY_CLASSES_ROOT\Unknown]
Name: (Default)
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 18, 2002


Change the Default Action for Script Files (All Windows)

Change the Default Action for Script Files (All Windows)
Category: Home > Windows > System > Scripts

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Normally scripting files are run when double clicked, once applied this tweak will cause them to be shown in Notepad instead. This is useful to avoid accidental execution especially with the prevalence of script based viruses.

Open your registry and for each key below change the value of "(Default)" to equal "Edit". This will change the default action so that the script will be loaded in Notepad.exe (or another specified text editor).

JS Files
[HKEY_CLASSES_ROOT\JSFile\Shell]

JSE Files
[HKEY_CLASSES_ROOT\JSEFile\Shell]

VBE Files
[HKEY_CLASSES_ROOT\VBEFile\Shell]

VBS Files
[HKEY_CLASSES_ROOT\VBSFile\Shell]

WSH Files
[HKEY_CLASSES_ROOT\WSHFile\Shell]

WSF Files
[HKEY_CLASSES_ROOT\WSFFile\Shell]

In addition you can change the default editor for each script type be changing the "(Default)" value under the [...\Shell\Edit\Command] sub-key.

Restart Windows for the change to take effect.

Note: Scripts can still be executed normally by right-clicking the file and selecting "Open" from the context menu.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | Edit | |
-
| HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows Script Host\Settings |
-

Settings:
Name: (Default)
Type: REG_SZ (String Value)
Value: ("Edit" = set Edit as default)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 18, 2002


Change the PPPOE MTU Size (Windows XP)

Change the PPPOE MTU Size (Windows XP)
Category: Home > Network > Protocols > TCP-IP

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

By default, a Windows XP PPPoE connection uses an MTU size that is 20 bytes less than the IP MTU of the LAN adapter over which the PPPoE packets are sent, which in most cases is 1480 bytes. If a lower MTU is required, then this tweak can be used to change the value.

Open your registry and find the key below.

Create three new DWORD values called "ProtocolType", "PPPProtocolType" and "ProtocolMTU". Set their values according to the table below.

  • ProtocolType = "2048" (in decimal)
  • PPPProtocolType = "33" (in decimal)
  • ProtocolMTU = to the required MTU size. (Windows will use the lesser of this value and the default.)
Restart Windows for the change to take effect.

Note: The default and maximum PPPoE MTU size in Windows XP is 1,480 bytes.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ProtocolType | REG_DWORD | 0x00000800 (2048) | |
| |  | PPPProtocolType | REG_DWORD | 0x00000021 (33) | |
| |  | ProtocolMTU | REG_DWORD | 0x000005c8 (1480) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Ndiswan\Parameters\... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Ndiswan\Parameters\
Protocols\0]
Name: ProtocolType, PPPProtocolType, ProtocolMTU
Type: REG_DWORD (DWORD Value)

Related Tweaks

  • Optimize Broadband PPPoE Connections (Windows Me)
  • Change the Maximum Transmission Unit (MTU) Size (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 19, 2002


Show Encryption Commands on the Shortcut Menu (Windows 2000/XP)

Show Encryption Commands on the Shortcut Menu (Windows 2000/XP)
Category: Home > Windows > Windows Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

You may find it easier to use the Encrypting File System (EFS) by placing "Encrypt" and "Decrypt" commands on the Windows Explorer context menu when a file is right-clicked with the mouse.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'EncryptionContextMenu' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | EncryptionContextMenu | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Ad... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\
Advanced]
Name: EncryptionContextMenu
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = enabled)

Related Tweaks

  • Manage the Encrypting File System (Windows 2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 8, 2002


Change Power Management Configuration (All Windows)

Change Power Management Configuration (All Windows)
Category: Home > Windows > System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This parameter allows you to specify the primary role of the computer so that predefined power management configurations can be used. For example a laptop will have different power saving features than a home desktop PC.

Open your registry and find the key below.

Modify the existing value, or create a new string value, called "CurrentPowerPolicy" and set it to a value (0 to 5) from the table below.

  • 0 - Home/Office desktop
  • 1 - Portable/Laptop computer
  • 2 - Monitor on for presentations
  • 3 - Network computer (no Wake-on-LAN)
  • 4 - Optimized for high performance
  • 5 - Optimized for power saving
Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | CurrentPowerPolicy | REG_SZ | 1 | |
-
| HKEY_CURRENT_USER\Control Panel\PowerCfg |
-

Settings:
User Key: [HKEY_CURRENT_USER\Control Panel\PowerCfg]
System Key: [HKEY_USERS\.DEFAULT\Control Panel\PowerCfg]
Name: CurrentPowerPolicy
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 25, 2002


Show All Hidden Devices in Device Manager (Windows 2000/XP)

Show All Hidden Devices in Device Manager (Windows 2000/XP)
Category: Home > Windows > Accessories

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Devices that are installed but are not currently connected to the computer (such as a Universal Serial Bus (USB) device or "ghosted" devices) are not normally displayed in Device Manager. This tweak causes all devices to be shown.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'DEVMGR_SHOW_NONPRESENT_DEVICES' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DEVMGR_SHOW_NONPRESE... | REG_SZ | 1 | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Envi... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\
Environment]
Name: DEVMGR_SHOW_NONPRESENT_DEVICES
Type: REG_SZ (String Value)
Value: (1 = show all hidden devices)

Related Tweaks

  • Show Detailed Information in Device Manager (Windows 2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 9, 2002


Change the MP3 Encoding Rates in Media Player (All Windows)

Change the MP3 Encoding Rates in Media Player (All Windows)
Category: Home > Software > Media Player

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

These settings allow you to change the MP3 encoding rates in Windows Media Player. The default is 56Kbps which is quite low quality, this tweak allows you to add higher rates such as 128Kbps or 192Kbps.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'LowRate, MediumRate, MediumHighRate, HighRate' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | HighRate | REG_SZ | 0x0004e200 (320000) | |
| |  | LowRate | REG_SZ | 0x0000fa00 (64000) | |
| |  | MediumHighRate | REG_SZ | 0x0002ee00 (192000) | |
| |  | MediumRate | REG_SZ | 0x0001f400 (128000) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MediaPlayer\Settings\MP3Encoding |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MediaPlayer\Settings\MP3Encoding]
Name: LowRate, MediumRate, MediumHighRate, HighRate
Type: REG_DWORD (DWORD Value)
Value: Rate in Bits per Second (bps)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 25, 2002


Disable Processing of HTML Scripts in Media Files (All Windows)

Disable Processing of HTML Scripts in Media Files (All Windows)
Category: Home > Software > Media Player

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting is an optional security configuration feature that you can use to turn off the processing of HTML scripts that are contained in Windows Media files.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'PlayerScriptCommandsEnabled' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This optional feature is added in the Microsoft Q320920 Media Player update.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | PlayerScriptCommandsEnabled | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\MediaPlayer\Preferences |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\MediaPlayer\Preferences]
Name: PlayerScriptCommandsEnabled
Type: REG_DWORD (DWORD Value)
Value: (0 = disable script, 1 = enable script)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 27, 2002


Automatic Logon for Novell Netware Clients (All Windows)

Automatic Logon for Novell Netware Clients (All Windows)
Category: Home > Network > Clients

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

These settings allow you to configure the Novell NetWare client to automatically logon to a Windows network.

Windows 95, 98 and Me
Open your registry and find the key [HKEY_LOCAL_MACHINE\Network\Logon]. Create two new string values, or modify the existing values, called "Username" and "NetWareUsername" and set them to your Windows username and NetWare username respectively. Then follow the steps below.

All Windows Versions
Open the [HKEY_LOCAL_MACHINE\Software\Novell\Login] key and create these new strings values:

  • The first called "AutoAdminLogon" should be set to "1" to enable automatic logon or "0" to disable it.
  • The second called "DefaultLocationProfile" should be set the your default location profile (e.g. "Default").
  • The third called "DefaultPassword" should be set to your NetWare password.
  • The fourth optional value called "DefaultUserName" should be set to your NetWare username for Novell Client versions prior to 4.6 SP1.
Restart Windows for the change to take effect.

Note: The password is stored in clear text, therefore anyone with access to the registry can see the default password.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AutoAdminLogon | REG_SZ | 1 | |
| |  | DefaultLocationProfile | REG_SZ | Default | |
| |  | DefaultPassword | REG_SZ | password | |
-
| HKEY_LOCAL_MACHINE\Software\Novell\Login |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\Software\Novell\Login]
Name: AutoAdminLogon
Type: REG_SZ (String Value)

Related Tweaks

  • Automatic Logon to Windows 95, 98 and Me (Windows 95/98/Me)
  • Automatic Logon to Windows NT, 2000 and XP (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: July 4, 2003


Internet Explorer Toolbar Restrictions (All Windows)

Internet Explorer Toolbar Restrictions (All Windows)
Category: Home > Software > Internet Explorer > Security

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

These restrictions allow you to selectively control which toolbars are available in Internet Explorer, including the Address, Tool and Links bars.

Open your registry and find the key below. Create the key if it does not already exist.

Create a new DWORD value based on the options below, and set the new value to equal "1" to enable the restriction or "0" to disable the restriction.

  • NoToolbarOptions - Disable the ability to change toolbar selection.
  • NoAddressBar - Disable the address bar.
  • NoToolBar - Disable the tool bar.
  • NoLinksBar - Disable the links bar.

Restart Internet Explorer for the restrictions to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoToolbarOptions | REG_DWORD | 0x00000001 (1) | |
| |  | NoAddressBar | REG_DWORD | 0x00000001 (1) | |
| |  | NoToolBar | REG_DWORD | 0x00000001 (1) | |
| |  | NoLinksBar | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Toolbars... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Toolbars\
Restrictions]
System Key: [HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Internet Explorer\
Toolbars\Restrictions]
Type: REG_DWORD (DWORD Value)
Value: (0 = disable restriction, 1 = enable restriction)

Related Tweaks

  • Internet Explorer Restrictions (All Windows)
  • Disable the Ability to Customize Toolbars (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 23, 2003


Hide Computer Management Option (Windows 2000/XP)

Hide Computer Management Option (Windows 2000/XP)
Category: Home > Windows > System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allows you to remove the "Manage" option from the My Computer context menu. The Computer Management program is used to configure the system.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoManageMyComputerVerb' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: The computer management application can still be used by running "compmgmt.msc".

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoManageMyComputerVerb | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoManageMyComputerVerb
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = remove "Manage")

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 2, 2002


Automatically Expand Folders in Explorer (All Windows)

Automatically Expand Folders in Explorer (All Windows)
Category: Home > Windows > Windows Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When using Windows Explorer the selected folder is automatically expanded in the left-hand folder list. This setting allows you to control that functionality.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'FriendlyTree' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | FriendlyTree | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Adv... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
Advanced]
Name: FriendlyTree
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: July 18, 2002


Show or Hide "Open With" Program Checkbox (All Windows)

Show or Hide "Open With" Program Checkbox (All Windows)
Category: Home > Windows > Windows Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allows you to control whether the checkbox to save the "Open With" program is available when an unknown file type is opened.

Open your registry and find the key below.

To disable the check box change the value of "(Default)" to "rundll32.exe shell32.dll,OpenAs_RunDLL %1 %2".

To enable the checkbox change the value to "rundll32.exe shell32.dll,OpenAs_RunDLL %1".

Return to the desktop and press F5 for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | rundll32.exe shell32.dll,OpenAs_RunDLL %1 | |
-
| HKEY_CLASSES_ROOT\Unknown\shell\openas\command |
-

Settings:
System Key: [HKEY_CLASSES_ROOT\Unknown\shell\openas\command]
Name: (Default)
Type: REG_SZ (String Value)

Related Tweaks

  • Show Programs in the Open With Selection Box (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: July 19, 2002


Enable 48-bit LBA Support for Large Hard Drives (Windows 2000/XP)

Enable 48-bit LBA Support for Large Hard Drives (Windows 2000/XP)
Category: Home > Hardware > Disk Drives

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

By default Windows 2000 SP2, Windows XP and earlier versions of Windows do not support 48-bit Logical Block Addressing (LBA) for drives larger than 137GB as defined in the ATA/ATAPI 6.0 specification.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'EnableBigLba' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: Please see Microsoft support article Q305098 for important information regarding this setting.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | EnableBigLba | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Atapi\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Atapi\Parameters]
Name: EnableBigLba
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: July 19, 2002


Disable PC Card Removal Warnings (All Windows)

Disable PC Card Removal Warnings (All Windows)
Category: Home > Hardware

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting can be used to disable the PC Card warning messages shown when a PCMCIA device is removed from the socket without first being stopped.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'PCMCIAFlags' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | PCMCIAFlags | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Applets\SysTray |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Applets\
SysTray]
Name: PCMCIAFlags
Type: REG_DWORD (DWORD Value)
Value: (0 = no warnings, 1 = show warnings)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: July 19, 2002


Enable NTP Time Server (Windows 2000/XP)

Enable NTP Time Server (Windows 2000/XP)
Category: Home > Windows > System > Services

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting is used to enable the local machine to act as a Network Time Protocol (NTP) server. When enabled other machines can synchronise their clocks with this machine.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'LocalNTP' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | LocalNTP | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time\Parameters]
Name: LocalNTP
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: July 19, 2002


Windows Time Synchronization Settings (Windows 2000/XP)

Windows Time Synchronization Settings (Windows 2000/XP)
Category: Home > Windows > System > Services

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

These parameters allow you to control the synchronization settings of the W32Time service. This service ensures that computer date and time settings are correctly synchronized throughout an organization.

Open your registry and find the key below.

Create any of the optional values below to control the clock synchronization settings.

NtpServer (REG_SZ)
Used to manually configure the time source. Set this to the DNS name or IP address of the NTP server to synchronize from.

Period (REG_DWORD)
Used to control how often the time service synchronizes.

  • 0 - once a day
  • 65535 - once every 2 days
  • 65534 - once every 3 days
  • 65533 - once every week (7 days)
  • 65532 - once every 45 minutes until 3 good synchronizations occur, then once every 8 hours (3 per day) [default]
  • 65531 - once every 45 minutes until 1 good synchronization occurs, then once every day

    ReliableTimeSource (REG_DWORD)
    Used to indicate that this computer has reliable time.

  • 0 - do not mark this computer as having reliable time [default]
  • 1 - mark this computer as having reliable time (this is only useful on a domain controller)

    Type (REG_SZ)
    Used to control how a computer synchronizes.

  • Nt5DS - synchronize to domain hierarchy [default]
  • NTP - synchronize to manually configured source
  • NoSync - do not synchronize time

    Stop and restart the W32Time service for the change to take effect.

    Registry Editor Example
    | Name Type Data |
    | (Default) REG_SZ (value not set) |
    | NtpServer REG_SZ time.windows.com |
    | Period REG_DWORD 0x00000000 (0) |
    | ReliableTimeSource REG_DWORD 0x00000001 (1) |
    | Type REG_SZ NTP |
    -
    | HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time\Parameters |
    -

    Settings:
    System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time\Parameters]

    Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

    Last Modified: July 19, 2002

    • Return to Index Copyright © 1998-2003. All Rights Reserved. License


Disable Screen Saver When Disk Defragmenter Active (Windows 95/98/Me)

Disable Screen Saver When Disk Defragmenter Active (Windows 95/98/Me)
Category: Home > Windows > File System > Maintenance

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

If the screen saver becomes active while using the disk defragmenter it can slow and interrupt the process. This tweak disables the screen saver when defrag is being used.

Open your registry and find the key below.

Create a new String value, or modify the existing value called '(Default)' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | YES | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Applets\Defr... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Applets\
Defrag\Settings\DisableScreenSaver]
Name: (Default)
Type: REG_SZ (String Value)
Value: "YES" or "NO"

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: July 20, 2002


Disk Defragmenter Options (Windows 95/98/Me)

Disk Defragmenter Options (Windows 95/98/Me)
Category: Home > Windows > File System > Maintenance

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

These settings allow you to control the default options for the disk defragmenter (DEFRAG) utility.

Open your registry and find or create the key below.

To control the defragmentation method create a new sub-key called "method" and set "(Default)" to an item from the list below:

  • FULL - Defragment files, space and optimize programs.
  • FULLNOAPPLOG - Defragment files and space.
  • FILES - Defragment files only.
  • SPACE - Defragment space only.
To control whether scandisk is run before the defrag starts create a new sub-key called "scandisk" and set "(Default)" to equal TRUE or FALSE.

Restart the disk defragmenter for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | FULL | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Applets\Defr... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Applets\
Defrag\Settings]
Name: (Default)
Type: REG_SZ (String Value)

Related Tweaks

  • Disable Screen Saver When Disk Defragmenter Active (Windows 95/98/Me)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: July 24, 2002


Configure Windows Script Signature Security (All Windows)

Configure Windows Script Signature Security (All Windows)
Category: Home > Security > System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting is used to define whether trusted and untrusted scripts should be executed when using signature verification. By requiring a signature the system will only execute scripts from verified authors.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'TrustPolicy' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | TrustPolicy | REG_DWORD | 0x00000002 (2) | |
-
| HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows Script Host\Settings |
-

Settings:
User Key: [HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows Script Host\Settings]
Name: TrustPolicy
Type: REG_DWORD (DWORD Value)
Value: "0" = all, "1" = prompt, "2" = only trusted

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: July 20, 2002


Windows Script Host Settings (All Windows)

Windows Script Host Settings (All Windows)
Category: Home > Windows > System > Scripts

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

These settings allow you to configure some of the Windows Script Host (WSH) features, including the option to disable the engine.

Open your registry and find or create the key below.

Create any of the values below to enable the options:

Enable (REG_DWORD)

  • "0" - disabled
  • "1" - enabled

    Remote (REG_DWORD)

  • "0" - disable remote scripts
  • "1" - allow remote scripts

    DisplayLogo (REG_SZ)

  • "0" - no logo
  • "1" - display logo

    Restart Windows for the changes to take effect.

    Registry Editor Example
    | Name Type Data |
    | (Default) REG_SZ (value not set) |
    | Enable REG_DWORD 0x00000001 (1) |
    | Remote REG_DWORD 0x00000001 (1) |
    | DisplayLogo REG_SZ 1 |
    -
    | HKEY_LOCAL_MACHINE\Software\Microsoft\Windows Script Host\Settings |
    -

    Settings:
    System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows Script Host\Settings]
    Name: Enable, Remote, DisplayLogo

    Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

    Last Modified: July 20, 2002

    • Return to Index Copyright © 1998-2003. All Rights Reserved. License


Windows Error Reporting Settings (Windows XP)

Windows Error Reporting Settings (Windows XP)
Category: Home > Windows > Troubleshooting

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When an error occurs the Windows system may attempt to send debugging information to Microsoft for analysis. These settings allow you to control the operation of this feature.

Open your registry and find or create the key below.

Create or modify the DWORD values below and set them to "1" to enable the setting or "0" to disable it.

  • DoReport - Enable error reporting
  • ShowUI - Show user interface
  • IncludeKernelFaults - Include kernel errors in the report
  • IncludeMicrosoftApps - Include Microsoft applications in the report
  • IncludeWindowsApps - Include Windows components in the report
Restart Windows for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DoReport | REG_DWORD | 0x00000001 (1) | |
| |  | IncludeKernelFaults | REG_DWORD | 0x00000001 (1) | |
| |  | IncludeMicrosoftApps | REG_DWORD | 0x00000001 (1) | |
| |  | IncludeWindowsApps | REG_DWORD | 0x00000001 (1) | |
| |  | ShowUI | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PCHealth\ErrorReporting |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PCHealth\ErrorReporting]
Name: DoReport, ShowUI, IncludeKernelFaults, IncludeMicrosoftApps, IncludeWindowsApps
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: July 22, 2002


Automatic Download of COM Components (Windows 2000/XP)

Automatic Download of COM Components (Windows 2000/XP)
Category: Home > Windows > System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows can be configured to automatically download missing COM classes and objects over the network. This setting allows you to disable or enable this feature.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'COMClassStore' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: In some circumstances enabling this tweak could cause an extra delay when starting Windows Media Player.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | COMClassStore | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\App Management |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\App Management]
System Key: [HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\App Management]
Name: COMClassStore
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 24, 2003


Windows Registry Checker Settings (Windows 98/Me)

Windows Registry Checker Settings (Windows 98/Me)
Category: Home > Windows > Accessories > Registry Editor

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows 98 and Me include the Registry Checker tool which makes a daily backup copy of registry and other system files. These settings allow you to configure the behaviour of the Scanreg utility.

The Registry Checker is normally started through the registry. You can change whether it is launched by changing following these steps.

  1. Open your registry and find the key [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run].
  2. To enable the Registry Checker create a string value called "ScanRegistry" and set it to "C:\Windows\Scanregw.exe /autorun".
  3. To disable the Registry Checker delete the string value called "ScanRegistry".
  4. The change will take effect the next time the system is started.
The other configuration options for the Registry Checker are stored in the SCANREG.INI file found in the Windows directory (e.g. "C:\Windows\Scanreg.ini"). To change these parameters open the INI file using a text editor such as Windows Notepad.

Each parameter is listed in the format Option=Value, to change a value edit the text after the equals sign for the options below.

Backup=
A value of 1 (default) causes a backup copy of your registry to be made the first time you start your computer on any given day (determined by the system clock).
A value of 0 disables registry backup (not recommended).

Optimize=
A value of 1 (default) automatically optimizes your current registry if it contains 500 kilobytes (KB) of unused space.
A value of 0 does not automatically optimize your current registry.

MaxBackupCopies=
A value between 0 and 99 (default is 5) saves the last 5 registry backups in the backup folder. Only five backups are displayed using the Registry Checker for MS-DOS, higher numbers can be restored manually.

BackupDirectory=
To change the location in which registry backups are saved, type the full path to the folder. By default, this entry does not contain a value, and registry backups are automatically saved in the Windows\Sysbckup folder.

Files=
This entry does not exist by default, and is used to specify additional files you want to back up in the .cab file. To specify additional files to be backed up, type Files=[folder code],[file name], where [folder code] is the numerical code for the folder in which the file you want to back up is located, and [file name] is the name of the file you want to back up. If you want to back up multiple files in the same location, separate each file name using a comma (,) and no spaces.

The following table lists the possible folder codes:

Code | Folder
10 | Windows directory (e.g. C:\Windows)
11 | Windows System directory (e.g. C:\Windows\System)
30 | Root directory (e.g. C:\)
31 | Root host directory (e.g. C:\)

For example, if you want to back up the WIN.INI and CONTROL.INI files located in the Windows folder, include the following line:

Files=10,win.ini,control.ini
Or if you want to back up the AUTOEXEC.BAT and CONFIG.SYS files located in the root directory, include the following line:
Files=30,autoexec.bat,config.sys

Restart Windows for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ScanRegistry | REG_SZ | C:\Windows\Scanregw.exe /autorun | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run]
Name: ScanRegistry
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 17, 2002


DirectDraw and Direct3D Settings (Windows 98/Me/2000/XP)

DirectDraw and Direct3D Settings (Windows 98/Me/2000/XP)
Category: Home > Hardware > Video and Graphics

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

These DirectX settings allow you to change some of the DirectDraw and Direct3D video acceleration parameters.

Open your registry and find or create the key below.

Create a new DWORD value for each optional item from the list below and set it to "1" to enable the setting or "0" to disable it.

  • DisableAGPSupport - Disable AGP support
  • DisableMMX - Disable MMX processor extensions
  • DisableWiderSurfaces - Disable Wider Surfaces support
  • DisableInactivate - Disable dual-head video card debugging
  • EnablePrintScreen - Enable Print Screen capture
  • ModeXOnly - Use Mode-X for older video cards
  • ShowFrameRate - Display the frame rate (if supported)
  • DisableNoSysLock - Disable long-duration locks on video memory
  • ForceNoSysLock - Force use of long-duration locks on video memory
  • EmulationOnly - Enable software emulation layer for older video cards
Open the [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Direct3D] key and change the value of DisableDP2 to "1" to disable Direct3D, or "0" to enable it.

Open the [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Direct3D\Drivers] key and change the value of SoftwareOnly to "1" to use software emulation or "0" to disable it.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DisableAGPSupport | REG_DWORD | 0x00000000 (0) | |
| |  | DisableMMX | REG_DWORD | 0x00000000 (0) | |
| |  | DisableWiderSurfaces | REG_DWORD | 0x00000000 (0) | |
| |  | DisableInactivate | REG_DWORD | 0x00000000 (0) | |
| |  | EnablePrintScreen | REG_DWORD | 0x00000001 (1) | |
| |  | ModeXOnly | REG_DWORD | 0x00000000 (0) | |
| |  | ShowFrameRate | REG_DWORD | 0x00000001 (1) | |
| |  | DisableNoSysLock | REG_DWORD | 0x00000000 (0) | |
| |  | ForceNoSysLock | REG_DWORD | 0x00000001 (1) | |
| |  | EmulationOnly | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DirectDraw |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DirectDraw]
Type: REG_DWORD (DWORD Value)
Value: (0 or 1)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: July 24, 2002


Windows Installer Logging (All Windows)

Windows Installer Logging (All Windows)
Category: Home > Windows > Accessories > Windows Installer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows Installer can use logging to help assist in troubleshooting issues with installing software packages. You can enable verbose logging with this setting.

Open your registry and find or create the key below.

Create a new string value called "Logging" and set it to a combination of the letters below to enable the logging options. A value of "voicewarmup" will enable all the logging options.

Letter | Option
v | Verbose output
o | Out-of-disk-space messages
i | Status messages
c | Initial UI parameters
e | All error messages
w | Non-fatal warnings
a | Start up of actions
r | Action-specific records
m | Out-of-memory or fatal exit information
u | User requests
p | Terminal properties
+ | Append to existing file
! | Flush each line to the log

The next time Windows Installer is used a log will be created.

Note: Windows Installer will store the logs in the TEMP directory. The filename is random, but begins with the letters "Msi" and end with a .log extension.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Logging | REG_SZ | voicewarmup | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer]
Name: Logging
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: July 24, 2002


User Environment Event Logging (Windows 2000/XP)

User Environment Event Logging (Windows 2000/XP)
Category: Home > Windows > Troubleshooting > Logging

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

These settings can be used to selectively enable the user environment event logging features available in Windows.

Open your registry and find or create the key below.

Create new DWORD values from the list below and set them to "1" enable logging or "0" to disable.

  • RunDiagnosticLoggingGlobal - Enable all user environment event logging
  • RunDiagnosticLoggingGroupPolicy - Enable event logging for group policies
  • RunDiagnosticLoggingAppDeploy - Enable event logging for application deployment
  • RunDiagnosticLoggingIntelliMirror - Enable event logging for remote boot
Restart Windows for the changes to take effect.

Note: Logged information is stored in the Windows NT event log so that an administrator can view events either locally or remotely using Event Viewer.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | RunDiagnosticLoggingGlobal | REG_DWORD | 0x00000001 (1) | |
| |  | RunDiagnosticLoggingGroupPo... | REG_DWORD | 0x00000001 (1) | |
| |  | RunDiagnosticLoggingAppDeploy | REG_DWORD | 0x00000001 (1) | |
| |  | RunDiagnosticLoggingIntelliMirror | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Diagnostics |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\
Diagnostics]
Name: RunDiagnosticLoggingGlobal, RunDiagnosticLoggingGroupPolicy, RunDiagnosticLoggingAppDeploy, RunDiagnosticLoggingIntelliMirror
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Related Tweaks

  • User Environment Debug Logging (Windows 2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: July 28, 2002


Secure Desktop Restriction (Windows 2000/XP)

Secure Desktop Restriction (Windows 2000/XP)
Category: Home > Security > Desktop and Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction is used to stop interactive users from snooping on other user sessions by exploiting a Windows vulnerability. This feature is enabled by default but may interfere with some software applications.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'SecureDesktop' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This fix was first included in Windows 2000 Service Pack 1.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SecureDesktop | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows]
Name: SecureDesktop
Type: REG_DWORD (DWORD Value)
Value: (0 = insecure, 1 = secure)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: July 25, 2002


Reset the Screen Saver Password (Windows 95/98/Me)

Reset the Screen Saver Password (Windows 95/98/Me)
Category: Home > Security

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

If you have misplaced your Windows screen saver password you can reset it by using this tweak.

Open your registry and find the key below.

Delete the value "ScreenSave_Data" to reset the password.

The change should become effective immediately.

Settings:
User Key: [HKEY_CURRENT_USER\Control Panel\Desktop]
Name: ScreenSave_Data
Type: REG_BINARY (Binary Value)
Value: Encoded Password

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: July 25, 2002


Disable Universal Plug and Play Services (Windows XP)

Disable Universal Plug and Play Services (Windows XP)
Category: Home > Hardware

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows XP includes support for Universal Plug and Play (UnPnP) which allows UnPnP devices to be connected over a network. There are currently limited UnPnP devices available and due to a recent security flaw it may be advisable to disable these services.

Disable Universal Plug and Play Device Host
Open your registry and find the key [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\upnphost]. Set the value of "Start" to "4" to disable the service, or "3" to enable it.

Disable UnPnP Discovery Service
Open your registry and find the key [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SSDPSRV]. Set the value of "Start" to "4" to disable the service, or "3" to enable it.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Start | REG_DWORD | 0x00000004 (4) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\upnphost |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\upnphost]
Name: Start
Type: REG_DWORD (DWORD Value)
Value: (3 = enabled, 4 = disabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 21, 2003


Restrict Interactive Services (Windows 2000/XP)

Restrict Interactive Services (Windows 2000/XP)
Category: Home > Windows > System > Services

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows services normally have the option of interacting with the desktop, to display information and accept input. For security reasons this tweak allows you to restrict service interactivity.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoInteractiveServices' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoInteractiveServices | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Windows |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Windows]
Name: NoInteractiveServices
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = restrict interactive services)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: July 25, 2002


Use System-based Internet Restrictions (All Windows)

Use System-based Internet Restrictions (All Windows)
Category: Home > Software > Internet Explorer > Security

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Internet restrictions are normally dynamically loaded for each user, therefore settings for one user do not affect the settings of another. This tweak forces Windows to use the local machine settings rather than those of the current user.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'Security_HKLM_only' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Security_HKLM_only | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\CurrentVersion\In... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\CurrentVersion\
Internet Settings]
Name: Security_HKLM_only
Type: REG_DWORD (DWORD Value)
Value: (0 = user setting, 1 = machine settings)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: July 25, 2002


Show Programs in the Frequently Used Programs List (Windows XP)

Show Programs in the Frequently Used Programs List (Windows XP)
Category: Home > Windows > Start Menu and Taskbar

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allows you to decide which programs may be shown in the most frequently used programs list on the Windows Start menu.

Open your registry and find the key [HKEY_CLASSES_ROOT\Applications]. Under this key are a series of sub-keys representing the installed applications.

To stop a specific application appearing on the MFU program list open its sub-key and create a new empty string value called "NoStartPage".

To allow an application to be shown in the list delete the "NoStartPage" value.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoStartPage | REG_SZ |  | |
-
| HKEY_CLASSES_ROOT\Applications |
-

Settings:
System Key: [HKEY_CLASSES_ROOT\Applications]
Name: NoStartPage
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: July 31, 2002


Show Programs in the Open With Selection Box (All Windows)

Show Programs in the Open With Selection Box (All Windows)
Category: Home > Windows > Windows Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allows you to decide which programs are listed in "Open With" dialog box which is shown when an unknown file type is opened.

Open your registry and find the key [HKEY_CLASSES_ROOT\Applications]. Under this key are a series of sub-keys representing the installed applications.

To stop a specific application appearing in the "Open With" list select the associated sub-key and create a new empty string value called "NoOpenWith".

To allow an application to be shown in the list delete the "NoOpenWith" value.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoOpenWith | REG_SZ |  | |
-
| HKEY_CLASSES_ROOT\Applications |
-

Settings:
System Key: [HKEY_CLASSES_ROOT\Applications]
Name: NoOpenWith
Type: REG_SZ (String Value)

Related Tweaks

  • Show or Hide "Open With" Program Checkbox (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: July 31, 2002


Show Verbose Security Status Messages (Windows 2000/XP)

Show Verbose Security Status Messages (Windows 2000/XP)
Category: Home > Security > Login and Authentication

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allows you to configure Windows so that you receive verbose startup, shutdown, logon, and logoff status messages. This may be helpful to in troubleshooting slow startup, shutdown, logon, or logoff behaviour.

Open your registry and find or create the key below.

To enable verbose status messages create a new DWORD value called "verbosestatus" and set it to "1".

An additional value called "DisableStatusMessages" forces status messages to be disabled, make sure this value does not exist or is set to "0".

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | verbosestatus | REG_DWORD | 0x00000001 (1) | |
| |  | DisableStatusMessages | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Sy... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\
System]
Name: verbosestatus
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = enable versbose status)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 9, 2002


Change Program and Common Files Directory (All Windows)

Change Program and Common Files Directory (All Windows)
Category: Home > Windows > Windows Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak allows you to change the directory used as the default location for software applications and shared files.

Open your registry and find the key below.

Change the value of "ProgramFilesDir" and "CommonFilesDir" to the desired Program Files and Common Files directories.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | CommonFilesDir | REG_SZ | C:\Program Files\Common Files | |
| |  | ProgramFilesDir | REG_SZ | C:\Program Files | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion]
Name: CommonFilesDir, ProgramFilesDir
Type: REG_SZ (String Value)
Value: Directory Name

Related Tweaks

  • Change the Location of System and Special Folders (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: July 29, 2002


Customize Microsoft Access Identification (All Windows)

Customize Microsoft Access Identification (All Windows)
Category: Home > Software > Microsoft Office

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

These settings allow you to change the title, icon, startup screen and help file of Microsoft Access. This is particularly useful if distributing an application and you want to modify Access to look like your product.

Open your registry and find or create the key:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\X.X\Access\Run-Time Options]

Where X.X is your Access version number; "8.0" for Access 97, "9.0" for Access 2000 and "10.0" for Access XP.

Create any or all of the values below to customize the identification and branding of the application.

  • Titlebar - text shown in the window title
  • StartupScreen - image (.BMP) shown when Access is loading
  • Icon - icon (.ICO) shown in the title bar and task bar
  • AppHelpFile - the help file to use in the application.
Restart Access for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AppHelpFile | REG_SZ | C:\App\help.hlp | |
| |  | Icon | REG_SZ | C:\App\myicon.ico | |
| |  | StartupScreen | REG_SZ | C:\App\Splash.bmp | |
| |  | Titlebar | REG_SZ | My Custom Application | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\X.X\Access\Run-Time Options |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\X.X\Access\Run-Time Options]
Name: Titlebar, StartupScreen, Icon, AppHelpFile
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: July 31, 2002


Change the RPC Packet Size (Windows 2000/XP)

Change the RPC Packet Size (Windows 2000/XP)
Category: Home > Network > Protocols

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allows you to modify the size limit of incoming Microsoft Remote Procedure Call (RPC) packets.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'MaxRpcSize' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | MaxRpcSize | REG_DWORD | 0x00100000 (1048576) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Rpc |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Rpc]
Name: MaxRpcSize
Type: REG_DWORD (DWORD Value)
Value: Size in bytes

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 9, 2002


Select the Drive Types to Start Automatically (All Windows)

Select the Drive Types to Start Automatically (All Windows)
Category: Home > Windows > File System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When using AutoRun Windows can detect and automatically start programs when new media is inserted into a drive. By default, CD-ROM and hard drives will automatically launch, but removable and network drives will not.

Open your registry and find or create the key below.

Create or modify a DWORD value for Windows 2000 and XP or binary value for Windows 95, 98 and Me called "NoDriveTypeAutoRun". This value is an 8-bit number that specifies which drive types AutoRun is disabled on. Each bit represents a different drive type.

Bit | Drive Types
0 | Unknown drives
1 | No root directory
2 | Removable drives (Floppy, ZIP)
3 | Hard disk drives
4 | Network drives
5 | CD-ROM drives
6 | RAM disk drives
7 | Reserved

The default value is "149" (decimal) which is equal to "95" (hex) and "10010101" (binary). In binary this specifies that AutoRun should be disabled on Unknown (bit 0), Removable (bit 2), Network (bit 4) and Reserved (bit 7) drive types. (i.e. REG_DWORD: "0x00000095 (149)" or REG_BINARY: "95 00 00 00")

Therefore to disable AutoRun on CD-ROM drives as well you would set enable bit 5 so that the value becomes "10110101" (binary), "181" (decimal) or "B5" (hex). (i.e. REG_DWORD: "0x000000B5 (181)" or REG_BINARY: "B5 00 00 00")

To disable AutoRun on all drive types you would set this value to "11111111" (binary), "255" (decimal) or "FF" (hex). (i.e. REG_DWORD: "0x000000FF (255)" or REG_BINARY: "FF 00 00 00")

To enabled AutoRun on all drive types you would set this value to "10000000" (binary), "128" (decimal) or "80" (hex). Bit 7 is left enabled because it is reserved. (i.e. REG_DWORD: "0x00000080 (128)" or REG_BINARY: "80 00 00 00")

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoDriveTypeAutoRun | REG_DWORD | 0x00000095 (149) [Windows 2000, XP] | |
| |  | NoDriveTypeAutoRun | REG_BINARY | 95 00 00 00 [Windows 95, 98, Me] | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoDriveTypeAutoRun
Value: Bit-mask of Drive Types

Related Tweaks

  • Select the Disk Drives to Start Automatically (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 20, 2002


Disable Command Prompt and Batch Files (Windows 2000/XP)

Disable Command Prompt and Batch Files (Windows 2000/XP)
Category: Home > Windows > Accessories > Command Processor

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction allows you to selectively disable the Command Prompt (CMD) and the ability to execute DOS batch files.

Open your registry and find or create the key below.

Create or modify the DWORD value "DisableCMD" and set it to a number from the list below.

  • 0 - (default) enable command prompt and batch files
  • 1 - disable command prompt and batch files
  • 2 - disable command prompt but allow batch files
The change should take effect immediately.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DisableCMD | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\System |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\System]
Name: DisableCMD
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = disabled, 2 = disabled but allow batch)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 5, 2002


Block Executable Attachments in Outlook Express (All Windows)

Block Executable Attachments in Outlook Express (All Windows)
Category: Home > Software > Outlook Express

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Outlook Express normally allows you to view and save all e-mail attachments. This tweak blocks executable files that potentially contain harmful viruses.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'BlockExeAttachments' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | BlockExeAttachments | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Outlook Express |
-

Settings:
User Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Outlook Express]
Name: BlockExeAttachments
Type: REG_DWORD (DWORD Value)
Value: (0 = disable restriction, 1 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 22, 2003


Change Default Administrator Ownership (Windows XP)

Change Default Administrator Ownership (Windows XP)
Category: Home > Security > System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows XP may assign the ownership of some file system objects to the Administrator account, instead of the Administrators group. This behaviour may not be desirable where there are multiple administrative users.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoDefaultAdminOwner' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | NoDefaultAdminOwner | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa]
Name: NoDefaultAdminOwner
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = default)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 1, 2002


Disable the Internet Explorer Splash Screen (All Windows)

Disable the Internet Explorer Splash Screen (All Windows)
Category: Home > Software > Internet Explorer > Appearance

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When this setting is enabled the splash screen will not be shown when Internet Explorer is started.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoSplash' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoSplash | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Internet Explorer\Infodel... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Internet Explorer\
Infodelivery\Restrictions]
Name: NoSplash
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = disable splash)

Related Tweaks

  • Disable the Outlook Express Splash Screen (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 2, 2002


Use System-Wide Proxy Settings (All Windows)

Use System-Wide Proxy Settings (All Windows)
Category: Home > Software > Internet Explorer > Network and Connections

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allows you to change the scope of the Internet proxy configuration and specify whether all users should share system-wide or individual settings.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'ProxySettingsPerUser' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ProxySettingsPerUser | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\CurrentVersion\In... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\CurrentVersion\
Internet Settings]
Name: ProxySettingsPerUser
Type: REG_DWORD (DWORD Value)
Value: (0 = whole machine, 1 = per user)

Related Tweaks

  • Use System-based Internet Restrictions (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 2, 2002


Disable Windows Installer (All Windows)

Disable Windows Installer (All Windows)
Category: Home > Windows > Accessories > Windows Installer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction allows you to prevent users from adding and removing software applications with Windows Installer.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'DisableMSI' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DisableMSI | REG_DWORD | 0x00000002 (2) | |
-
| HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\Installer |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\Installer]
Name: DisableMSI
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = admin only, 2 = disabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 31, 2002


Remote Administration of Windows Installer (Windows 2000/XP)

Remote Administration of Windows Installer (Windows 2000/XP)
Category: Home > Windows > Accessories > Windows Installer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allows administrators using Windows Terminal Services to remotely install and configure software using Windows Installer.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'EnableAdminTSRemote' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This setting affects system administrators only. Other users cannot install programs remotely.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | EnableAdminTSRemote | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer]
Name: EnableAdminTSRemote
Type: REG_DWORD (DWORD Value)
Value: (0 = disable, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 5, 2002


Comprehensive Search for Broken Shortcuts (Windows NT/2000/XP)

Comprehensive Search for Broken Shortcuts (Windows NT/2000/XP)
Category: Home > Windows > File System > Files and Shortcuts

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When the system cannot find the target file of a shortcut it searches all the associated paths. If still not found it performs a comprehensive search of the drive to locate the file. This setting can be used to disable the final search.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoResolveSearch' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This applies only to target files on NTFS partitions. File allocation table (FAT) partitions do not have this ID tracking and search capability.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoResolveSearch | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoResolveSearch
Type: REG_DWORD (DWORD Value)
Value: (0 = search, 1 = no search)

Related Tweaks

  • Disable Tracking of Broken Shortcut Links (Windows 2000/XP)
  • Disable Automatic Network Shortcut Resolution (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 5, 2002


Quick Edit the Command Prompt (Windows NT/2000/XP)

Quick Edit the Command Prompt (Windows NT/2000/XP)
Category: Home > Windows > Accessories > Command Processor

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Quick Edit allows you to easily cut and paste text in the command prompt window using the mouse. The ability to use the Edit menu options is still possible.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'QuickEdit' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | QuickEdit | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Console |
-

Settings:
User Key: [HKEY_CURRENT_USER\Console]
System Key: [HKEY_USERS\.DEFAULT\Console]
Name: QuickEdit
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 5, 2002


Manage the Encrypting File System (Windows 2000/XP)

Manage the Encrypting File System (Windows 2000/XP)
Category: Home > Windows > File System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When you use Encrypting File System (EFS), you can store data securely because selected NTFS file system files and folders can be encrypted. This setting allows you to enable or disable EFS.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'EfsConfiguration' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | EfsConfiguration | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\EFS |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\EFS]
Name: EfsConfiguration
Type: REG_DWORD (DWORD Value)
Value: (1 = disable EFS, 0 = enable EFS)

Related Tweaks

  • Show Encryption Commands on the Shortcut Menu (Windows 2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 8, 2002


Repair the Icon Cache (All Windows)

Repair the Icon Cache (All Windows)
Category: Home > Windows > Troubleshooting > Repair

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Use this setting if Windows is displaying incorrect or corrupted icons for your programs and shortcuts.

Windows maintains a cached copy of all the icons on the system to avoid having to reload the icons every time they are displayed. If this icon cache becomes corrupt then the wrong icons may be shown.

To clear the icons cache make sure you can view hidden files and then open your Windows directory in Explorer and delete the file called "ShellIconCache".

When you restart Windows the icon cache file will be automatically recreated.

Related Tweaks

  • Change the Icon Cache Size (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 23, 2002


Repair the Registry Editor (Windows 2000/Me/XP)

Repair the Registry Editor (Windows 2000/Me/XP)
Category: Home > Windows > Troubleshooting > Repair

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak allows you to reset the location and parameters of the Registry Editor (REGEDIT) back to the system defaults. This is useful if Regedit is not being displayed correctly.

Open your registry and find the key below.

Make a backup of the key and then delete the values: "FindFlags", "LastKey" and "View".

Restart the Registry Editor.

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Applets\
Regedit]

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 9, 2002


Force Plain Text Format in Internet Explorer (All Windows)

Force Plain Text Format in Internet Explorer (All Windows)
Category: Home > Software > Internet Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Internet Explorer may not use the "Text/Plain" Content-Type header field to properly open a text file on a Web site. This setting forces IE to treat those files as text files.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'IsTextPlainHonored' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This setting applies to Internet Explorer version 5 or greater.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | IsTextPlainHonored | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Set... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\
Internet Settings]
Name: IsTextPlainHonored
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = treat as text file)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 11, 2002


Increase Application Keyboard Response Time (Windows 95/98/Me)

Increase Application Keyboard Response Time (Windows 95/98/Me)
Category: Home > Hardware > Mice and Keyboards

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When running more than one application at a time, you may find that your system's keyboard response is slower. To alleviate this, you can adjust the amount of time allocated to processing keystrokes.

To increase the priority of the foreground application's scanning of the keyboard, add the KeyBoostTime= setting to the [386Enh] section of the SYSTEM.INI file. You can do this with a text editor such as Notepad.

The KeyBoostTime default setting is:

KeyBoostTime=.001

The recommended value is:

KeyBoostTime=.005

Increase the setting in small increments until you achieve the desired response.

Restart Windows for the change to take effect.

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 17, 2002


Prevent Access to the Contents of Selected Drives (Windows 2000/Me/XP)

Prevent Access to the Contents of Selected Drives (Windows 2000/Me/XP)
Category: Home > Security

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction prevents users from using My Computer or Explorer to access the content of selected drives. Also, they cannot use Run, Map Network Drive, or the Dir command to view the directories on these drives.

Open your registry and find or create the key below.

The "NoViewOnDrive" value uses a 32-bit bitmask to define local and network drive access for each logical drive in the computer. The lower 26 bits of the 32-bit word correspond to drive letters A through Z. Drives are visible when set to 0 and hidden when set to 1.

If your not happy working in Hex, add these decimal numbers to hide the drive(s):

A: 1, B: 2, C: 4, D: 8, E: 16, F: 32, G: 64, H: 128, I: 256, J: 512, K: 1024, L: 2048, M: 4096, N: 8192, O: 16384, P: 32768, Q: 65536, R: 131072, S: 262144, T: 524288, U: 1048576, V: 2097152, W: 4194304, X: 8388608, Y: 16777216, Z: 33554432, ALL: 67108863

For example to hide drive A and drive D, you would add 1 (A) + 8 (D) which means the value should be set to "9".

To disable all the drives set the value to "67108863".

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoViewOnDrive | REG_DWORD | 0x00000004 (4) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoViewOnDrive
Type: REG_DWORD (DWORD Value)
Value: 32-bit bitmask

Related Tweaks

  • Hide Drives in My Computer (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 13, 2003


Automatically Start CD-R and DVD-R Disks (All Windows)

Automatically Start CD-R and DVD-R Disks (All Windows)
Category: Home > Windows > File System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This settings controls whether CD-R(W) and DVD-R(W) disks are automatically started when loaded into the computer.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'CDRAutoRun' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: The tweak requires that compatible CD-R(W) and/or DVD-R(W) software is installed on the system.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | CDRAutoRun | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: CDRAutoRun
Type: REG_DWORD (DWORD Value)
Value: (1 = enabled CDR auto run)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 26, 2002


Use Connected Web Files and Folders (Windows 2000/Me/XP)

Use Connected Web Files and Folders (Windows 2000/Me/XP)
Category: Home > Windows > File System > Files and Shortcuts

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

The Windows file system includes a feature to connect web documents and their associated files. If an HTML document is moved or copied all its associated files, including images, JavaScript and style sheets, can also be automatically relocated.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoFileFolderConnection' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: To create a group of connected files, the primary document must have an .htm or .html file name extension. Create a subfolder with the same name as the primary document, except instead of a .htm or .html extension, name it with a .files extension. For instance, if the primary document is named MyDoc.htm, naming the subfolder "MyDoc.files" defines the subfolder as the container for the document's connected files. If the primary document is moved or copied, the subfolder and its files are moved or copied as well.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoFileFolderConnection | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer]
Name: NoFileFolderConnection
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = disable connected folders)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 26, 2002


Manage the Windows Prefetcher Service (Windows XP)

Manage the Windows Prefetcher Service (Windows XP)
Category: Home > Windows > Startup and Shutdown

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

The Windows XP Prefetcher component helps to shorten the amount of time it takes to start programs by fetching and storing commonly used files. This tweak allows you to manage the service and cache.

Open your registry and find or create the key below.

Create a new DWORD value, or modify the existing value, called "EnablePrefetcher" and set it according to the value data below.

To clear the Prefetcher cache, delete all the files in the Prefetch sub-directory (e.g. "C:\Windows\Prefetch").

Exit your registry and restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | EnablePrefetcher | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memo... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\
Memory Management\PrefetchParameters]
Name: EnablePrefetcher
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = Application launch prefetching, 2 = Boot prefetching, 3 = Both prefetching)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 26, 2002


Disable Group Policy Objects (Windows 2000/XP)

Disable Group Policy Objects (Windows 2000/XP)
Category: Home > Security > System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting is used to disable the use of group policy objects on the local computer.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'DisableGPO' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DisableGPO | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\System |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\System]
Name: DisableGPO
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = disable group policy)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 26, 2002


Manage the QoS Packet Queuing (Windows 2000/XP)

Manage the QoS Packet Queuing (Windows 2000/XP)
Category: Home > Network

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting specifies the maximum number of outstanding packets permitted on the system. When the number of outstanding packets reaches this limit, the Packet Scheduler postpones all submissions to network adapters until the number falls below this limit.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'MaxOutstandingSends' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | MaxOutstandingSends | REG_DWORD | 0x0000ffff (65535) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Psched |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Psched]
Name: MaxOutstandingSends
Type: REG_DWORD (DWORD Value)
Value: Maximum Packets (default = 65535)

Related Tweaks

  • Manage the Reserved QoS Bandwidth (Windows 2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 26, 2002


Show My Pictures Toolbar in Internet Explorer (All Windows)

Show My Pictures Toolbar in Internet Explorer (All Windows)
Category: Home > Software > Internet Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When displaying an image in Internet Explorer a floating toolbar is shown that allows you to Save, Print, E-mail or Open the My Pictures folder. This setting allows you to hide the toolbar.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'MyPics_Hoverbar' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This setting requires Internet Explorer 5.5 or greater.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | MyPics_Hoverbar | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\PhotoSup... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\
PhotoSupport]
Name: MyPics_Hoverbar
Type: REG_DWORD (DWORD Value)
Value: (0 = show bar, 1 = hide bar)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 26, 2002


Speed-up Modem and Serial Connections (Windows 95/98/Me)

Speed-up Modem and Serial Connections (Windows 95/98/Me)
Category: Home > Hardware > Network and Modems

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows is normally limited to a default maximum speed of 115,200 bps for serial communications. By using compression and high-speed UARTS modern modems may reach this limit and not be allowed to operate at full speed. This tweak allows Windows to communicate with speeds of 230400, 460800 and 921600 bps.

Open your registry and find the key below. If you have more than one modem there will be multiple sub-keys 0000, 0001, 0002...000x representing each modem. Check under each sub-key until you find the modem you want to speed-up then continue with the step below.

Make a backup of "Properties" value before it is modified. Then double-click on "Properties" and notice that the 51st, 52nd, 53rd and 54th digits will currently show "C2 01" or "84 03". Highlight these digits and then change them to "10 0e", do not change any other digits.

Click OK and exit the registry editor.

Now if you open "Control Panel -> Modems -> Your Modem -> Properties -> General" three new Maximum speed settings will be available: 230400, 460800 and 921600. Select the required speed and test with you modem to make sure it is compatible with the higher speed.

Note: Once enabled open Control Panel -> Modems -> Your Modem -> Properties -> General and set the required maximum speed.

Note: Some older slower modems may not be able to operate at these speeds, if your modem experiences problems switch back to a lower speed.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Properties | REG_BINARY | c0,01,00,00,ff,00,00,00,ff,00,00,00... | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\Modem\0000 |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\Modem\0000]
Name: Properties
Type: REG_BINARY (Binary Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 3, 2002


Show Administrator on the Welcome Screen (Windows XP Professional)

Show Administrator on the Welcome Screen (Windows XP Professional)
Category: Home > Windows > Login and Authentication

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When logging into Windows the Administrator account is not normally available on the Welcome screen. This tweak adds it to the Welcome screen and allows you to login like a normal account.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'Administrator' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This tweak will not work if you have renamed the Administrator account.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Administrator | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\
SpecialAccounts\UserList]
Name: Administrator
Type: REG_DWORD (DWORD Value)
Value: (1 = show Administrator)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: August 28, 2002


Manage System Policy Updates (Windows NT/2000/XP)

Manage System Policy Updates (Windows NT/2000/XP)
Category: Home > Security

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows normally makes a connection to the NETLOGON share of the validating domain controller and checks for the existence of the policy file. These settings control how system policies are applied to a Windows machine when on a network.

Open your regsitry and find the key below.

Optionally create or modify the following values:

Value | Type | Value
UpdateMode | REG_DWORD | Disabled=0, Automatic=1 or Manual=2
NetworkPath | REG_SZ | UNC path for manual updates
Verbose | REG_DWORD | Off = 0 or On = 1
LoadBalance | REG_DWORD | Off = 0 or On = 1

Restart Windows for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | UpdateMode | REG_DWORD | 0x00000002 (2) | |
| |  | NetworkPath | REG_SZ | \\Server\Policy | |
| |  | Verbose | REG_DWORD | 0x00000001 (1) | |
| |  | LoadBalance | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Update |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Update]
Name: UpdateMode, NetworkPath, Verbose, LoadBalance

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 1, 2002


Hide Start Menu Subfolders (All Windows)

Hide Start Menu Subfolders (All Windows)
Category: Home > Windows > Start Menu and Taskbar > Documents and Folders

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting can be used to hide any custom sub-folders from being shown in the top section of the Start Menu and therefore only displaying direct file shortcuts.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoStartMenuSubFolders' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoStartMenuSubFolders | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoStartMenuSubFolders
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 1, 2002


Enforce Shell Extension Security (All Windows)

Enforce Shell Extension Security (All Windows)
Category: Home > Security > Desktop and Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction can be used to limit the system to only run files that have an approved shell extension.

Open your registry and find or create the key below.

Create or modify the DWORD value called "EnforceShellExtensionSecurity" and set it to "1" to enable the restriction or "0" to disable it.

The approved shell extenstions are defined under the [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Shell Extensions\Approved] key.

Restart Windows for any changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | EnforceShellExtensionSecurity | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: EnforceShellExtensionSecurity
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = enable security)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 2, 2002


Enable Quick Reboot (Windows NT/2000)

Enable Quick Reboot (Windows NT/2000)
Category: Home > Windows > Startup and Shutdown

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allows you to use the quick reboot function to restart Windows immediately without shutting down. When enabled, press Shift + Ctrl + Alt + Delete for a quick reboot.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'EnableQuickReboot' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This method of rebooting should only be used when the system has stopped responding as some shutdown and clean-up functions will not be run.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | EnableQuickReboot | REG_SZ | 1 | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: EnableQuickReboot
Type: REG_SZ (String Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 2, 2002


Change the Log Off and Shutdown Settings (Windows NT/2000)

Change the Log Off and Shutdown Settings (Windows NT/2000)
Category: Home > Windows > Startup and Shutdown

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

These settings control what action the system should take when the Log Off and Shutdown commands are used.

Open your registry and find or create the key below.

Create or modify the two DWORD values called "LogoffSetting" and "ShutdownSetting" according the values from the list below.

  • 0 - Log Off
  • 1 - Shutdown
  • 2 - Shutdown and Restart
  • 3 - Shutdown and Power Off

Log off or restart Windows for the changes to take effect.

Note: Power off is only available when supported by the system BIOS and hardware.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | LogoffSetting | REG_DWORD | 0x00000000 (0) | |
| |  | ShutdownSetting | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Shutdown |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Shutdown]
Name: LogoffSetting, ShutdownSetting
Type: REG_DWORD (DWORD Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 2, 2002


Enable IP Packet Forwarding (Windows NT/2000/XP)

Enable IP Packet Forwarding (Windows NT/2000/XP)
Category: Home > Network > Internet and Remote Access

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

By default, TCP/IP forwarding is not enabled in Windows, this setting can be used to enable TCP/IP forwarding for all network connections that are installed and used by the computer.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'IPEnableRouter' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | IPEnableRouter | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]
Name: IPEnableRouter
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 6, 2002


Offload IP Security Task Processing (Windows 2000/XP)

Offload IP Security Task Processing (Windows 2000/XP)
Category: Home > Security > Network

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting is used to control whether IP Security (IPSEC) tasks should be offloaded to a network card with IP security capabilities.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'EnabledOffload' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | EnabledOffload | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Ipsec |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Ipsec]
Name: EnabledOffload
Type: REG_DWORD (DWORD Value)
Value: (0 = disable offload, 1 = enable)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 6, 2002


Empty Temporary Internet Files on Exit (All Windows)

Empty Temporary Internet Files on Exit (All Windows)
Category: Home > Security > Privacy

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether Internet Explorer should delete all of the temporary Internet files stored during the session when the browser is closed.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'Persistent' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Persistent | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Set... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\
Internet Settings\Cache]
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\
Internet Settings\Cache]
Name: Persistent
Type: REG_DWORD (DWORD Value)
Value: (0 = empty, 1 = do not empty)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 19, 2002


Disable Caching of Secure Web Pages (All Windows)

Disable Caching of Secure Web Pages (All Windows)
Category: Home > Software > Internet Explorer > Security

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether web pages encrypted using Secure Sockets Layer (SSL) should be stored on the hard disk in the temporary Internet cache.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'DisableCachingOfSSLPages' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DisableCachingOfSSLPages | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Set... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\
Internet Settings]
Name: DisableCachingOfSSLPages
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = disabled caching)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 10, 2002


Show Detailed Information in Device Manager (Windows 2000/XP)

Show Detailed Information in Device Manager (Windows 2000/XP)
Category: Home > Windows > Accessories

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

If you require additional information about a device that is not typically displayed in Device Manager, you can use this tweak to make Device Manager show detailed device information.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'DEVMGR_SHOW_DETAILS' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: In Device Manager the properties for a device should now provide a Details tab that contains additional information about the device.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DEVMGR_SHOW_DETAILS | REG_SZ | 1 | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Envi... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\
Environment]
Name: DEVMGR_SHOW_DETAILS
Type: REG_SZ (String Value)
Value: (0 = default, 1 = show detailed info)

Related Tweaks

  • Show All Hidden Devices in Device Manager (Windows 2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 10, 2002


Manage Automatic Windows Updates (Windows 2000/XP)

Manage Automatic Windows Updates (Windows 2000/XP)
Category: Home > Windows > System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

These settings can be used to configure how Automatic Updates are applied to the Windows system. It includes the ability to disable automatic updates and to set the installation schedule.

Open your registry and find or create the key below.

Create the required DWORD values from table below:

Value: NoAutoUpdate

  • 0 - Enable Automatic Updates (Default)
  • 1 - Disable Automatic Updates

    Value: AUOptions

  • 2 - Notify for download and notify for install
  • 3 - Auto download and notify for install
  • 4 - Auto download and schedule the install

    Value: ScheduledInstallDay

  • 0 - Install every day
  • 1 to 7 - Install on specific day of the week from Sunday (1) to Saturday (7).

    Value: ScheduledInstallTime

  • 0 to 23 - Install time of day in 24-hour format

    Restart Windows for the changes to take effect.

    Registry Editor Example
    | Name Type Data |
    | (Default) REG_SZ (value not set) |
    | NoAutoUpdate REG_DWORD 0x00000000 (0) |
    | AUOptions REG_DWORD 0x00000002 (2) |
    | ScheduledInstallDay REG_DWORD 0x00000000 (0) |
    | ScheduledInstallTime REG_DWORD 0x0000012 (18) |
    -
    | HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\WindowsUpdate\AU |
    -

    Settings:
    System Key: [HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\WindowsUpdate\AU]
    Name: NoAutoUpdate, AUOptions, ScheduledInstallDay, ScheduledInstallTime
    Type: REG_DWORD (DWORD Value)

    Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

    Last Modified: September 10, 2002

    • Return to Index Copyright © 1998-2003. All Rights Reserved. License


Change the Keyboard Preferences (All Windows)

Change the Keyboard Preferences (All Windows)
Category: Home > Hardware > Mice and Keyboards

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

These settings allow you to configure the repeat rate, blink rate and repeat delay of your keyboard.

Open your registry and find or create the key below.

To set the keyboard delay create a new DWORD value, or modify the existing value, called "KeyboardDelay" and set it to either 1, 2, 3 or 4 where 0 = ¼ second , 1 = ¾ second, 2 = 1¼ seconds, 3 = 2 second delay.

To change the number of keys inserted during a repeat operation create a new DWORD value, or modify the existing value, called "KeyboardSpeed" and set it a number between 0 and 31 with 31 being the fastest repeat.

Restart Windows for the changes to take effect.

Note: People who experience seizures in response to flashing lights or patterns may have problems with the blink rate of the insertion point if it is set at a frequency above 3 to 5 times per second.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | KeyboardDelay | REG_SZ | 1 | |
| |  | KeyboardSpeed | REG_SZ | 30 | |
-
| HKEY_CURRENT_USER\Control Panel\Keyboard |
-

Settings:
User Key: [HKEY_CURRENT_USER\Control Panel\Keyboard]
Name: KeyboardDelay, KeyboardSpeed, CursorBlinkRate
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 11, 2002


Change the Cache Write Delay (Windows 98/Me)

Change the Cache Write Delay (Windows 98/Me)
Category: Home > Windows > File System > Caching and Memory

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

During the shutdown process the contents of the virtual cache are written to the hard drives. This setting specifies the timeout to wait for the cache to be written to the drive.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'CacheWriteDelay' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This can be used to solve the problem where ScanDisk runs at startup even though Windows was shut down correctly. More information in Microsoft article Q273017.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | CacheWriteDelay | REG_DWORD | 2000 | |
-
| HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion]
Name: CacheWriteDelay
Type: REG_DWORD (DWORD Value)
Value: Timeout in milliseconds (2000 recommended)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 16, 2002


Manage the CPU Task Priority (Windows 95/98/Me)

Manage the CPU Task Priority (Windows 95/98/Me)
Category: Home > Hardware > Processor and Motherboard

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allows you to manage how the system processor should prioritize foreground and background tasks.

Open your registry and find the key below.

Create a new DWORD value and set it according to the table below.

  • 1 - Foreground tasks have maximum priority
  • 2 - Foreground tasks have higher priority than background tasks
  • 3 - (Default) Foreground and background tasks have equal priority.
  • 0 - (Not Recommended) Foreground tasks run in real-time. Warning this could make other tasks and your system hang.
Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | CPUPriority | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\BIOS |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\BIOS]
Name: CPUPriority
Type: REG_DWORD (DWORD Value)
Value: 1, 2 or 3

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 16, 2002


System Board and Memory Optimizations (Windows 95/98/Me)

System Board and Memory Optimizations (Windows 95/98/Me)
Category: Home > Hardware > Processor and Motherboard

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

These settings allow you to optimize the AGP and PCI buses along with the system memory by reducing the number of wait states (idle time).

Open your registry and find the key below.

To decrease the PCI bus wait states create a new DWORD value called "PCIConcur" and set it to "1".

To decrease the AGP bus wait states create a new DWORD value called "AGPConcur" and set it to "1".

To decrease the DRAM memory wait states create a new DWORD value called "FastDRAM" and set it to "1".

Restart Windows for the change to take effect.

Note: Wait states are periods when the CPU or bus remain idle to allow other system components to catch-up. Therefore decreasing the wait states reduces the amount of time the CPU or bus stays idle.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AGPConcur | REG_DWORD | 0x00000001 (1) | |
| |  | FastDRAM | REG_DWORD | 0x00000001 (1) | |
| |  | PCIConcur | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\BIOS |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\BIOS]
Name: PCIConcur, FastDRAM, AGPConcur
Type: REG_DWORD (DWORD Value)
Value: 1 = reduce wait states

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 16, 2002


Open TIF Images with Internet Explorer (All Windows)

Open TIF Images with Internet Explorer (All Windows)
Category: Home > Software > Internet Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When you click a link to download a Tagged Information File Format (TIFF) image from a Web site, the Open button in the File Download dialog box may be disabled. This tweak allows you to open the file using Internet Explorer.

Open your registry and find the key [HKEY_CLASSES_ROOT\.tif]. Change the value of "(Default)" to the data below for your Windows version.

Imaging.Document - Windows 2000, 98, Me and XP

WangImage.Document - Windows 95 and NT.

Repeat the change under the [HKEY_CLASSES_ROOT\.tiff] sub-key.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | Imaging.Document | |
-
| HKEY_CLASSES_ROOT\.tif |
-

Settings:
System Key: [HKEY_CLASSES_ROOT\.tif]
Name: (Default)
Type: REG_SZ (String Value)
Value: Imaging.Document or WangImage.Document

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 18, 2002


Connect to Unicode Addresses with Internet Explorer (All Windows)

Connect to Unicode Addresses with Internet Explorer (All Windows)
Category: Home > Software > Internet Explorer > Network and Connections

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allows you to control whether Internet Explorer should be able to connect to sites that use multibyte characters in the URL. This is useful when connecting to some foreign language sites.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'MBCSServername' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | MBCSServername | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\CurrentVersion\Int... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\CurrentVersion\
Internet Settings]
Name: MBCSServername
Type: REG_DWORD (DWORD Value)
Value: (0 = allow multibyte, 1 = restrict multibyte)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 18, 2002


Block Linked Images in Office XP Documents (All Windows)

Block Linked Images in Office XP Documents (All Windows)
Category: Home > Software > Microsoft Office

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

As an added security measure you can configure Office XP to block linked Hypertext Transfer Protocol (HTTP) images that are placed in documents. This is useful to avoid to ability for documents to be tracked using hidden images.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'BlockHTTPImages' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: You must have Microsoft Office XP Service Pack 2 (SP-2) or greater installed before this tweak will function.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | BlockHTTPImages | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Common |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Common]
Name: BlockHTTPImages
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = block linked images)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 19, 2002


Support Browse Lists for Multiple Domains (Windows NT/2000/XP)

Support Browse Lists for Multiple Domains (Windows NT/2000/XP)
Category: Home > Network > Servers

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

By default, the Computer Browser service only maintains a list of servers on the local network. To allow clients to browse computers on other domains you may need to add the other domains names using this tweak.

Open your registry using REGEDT32 (Windows NT/2000) or Regedit (Windows XP) and find the key below.

Modify or create a new REG_MULTI_SZ value called "OtherDomains" and edit this value to add the names of the domains you want to browse.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | OtherDomains | REG_MULTI_SZ | DOMAIN1 DOMAIN2 | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\P... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\
Parameters]
Name: OtherDomains
Type: REG_MULTI_SZ (Multi-String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 19, 2002


Display Configure Your Server Wizard (Windows 2000)

Display Configure Your Server Wizard (Windows 2000)
Category: Home > Network > Servers

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

You can modify your user profile to determine whether the "Windows 2000 Configure Your Server" dialog box appears at startup.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'srvwiz' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: The user may at any time display the wizard by choosing Programs\Administrative Tools\Configure Your Server from the Start menu.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | srvwiz | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Setup\Wel... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Setup\
Welcome]
Name: srvwiz
Type: REG_DWORD (DWORD Value)
Value: (0 = disable, 1 = display wizard)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 19, 2002


Configure DHCP Server for Unicast (Windows NT/2000/XP)

Configure DHCP Server for Unicast (Windows NT/2000/XP)
Category: Home > Network > Protocols > TCP-IP

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

By default, the Windows DHCP server sends all DHCP responses as IP broadcasts to the limited broadcast address (255.255.255.255). However, the DHCP server can be configured send to unicast responses by applying this tweak.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'IgnoreBroadcastFlag' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: Versions of the DHCP server prior to Windows NT 4.0 ignored the broadcast flag in client DHCP packets, and broadcast all replies.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | IgnoreBroadcastFlag | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\CurrentControlSet\Services\DHCPServer\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\CurrentControlSet\Services\DHCPServer\Parameters]
Name: IgnoreBroadcastFlag
Type: REG_DWORD (DWORD Value)
Value: (1 = always broadcast (default), 0 = only broadcast if client requests)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: September 24, 2002


Restrict ActiveX Applets in Internet Explorer (All Windows)

Restrict ActiveX Applets in Internet Explorer (All Windows)
Category: Home > Software > Internet Explorer > Security

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak allows you to stop specific ActiveX controls from running in Internet Explorer. When the "kill bit" is set the specified ActiveX control will never be called or shown by Internet Explorer.

The CLSID for an ActiveX control is a globally unique identifier (GUID) for that control. You can prevent an ActiveX control from running in Internet Explorer by setting the "kill bit" so that the control is never called by Internet Explorer. The "kill bit" is a specific value for the Compatibility Flags DWORD value for the ActiveX control in the registry. Note that this is different than revoking the "safe for scripting" option in an ActiveX control. When the "safe for scripting" option is revoked, Internet Explorer still calls for the control and then prompts you with a warning message that the ActiveX control may be unsafe. Depending on the choice you make, the control may be run. However, after the "kill bit" is set for an ActiveX control, that control is not called by Internet Explorer at all. To set the "kill bit" so that an ActiveX control is never called by Internet Explorer:

  1. Determine the CLSID for the ActiveX control that you want to disable. If you are not sure of the CLSID for the control, contact the manufacturer. If the control is installed, you may be able to determine its CLSID if you know its friendly name. To do this, examine the Default string value for the ProgID key for each of the CLSID keys in HKEY_CLASSES_ROOT\CLSID. You may need to remove as many ActiveX controls as possible, except for the one that you want to disable, in order to make it easier to identify the appropriate CLSID. For additional information about how to remove ActiveX controls, click the article number below to view the article in the Microsoft Knowledge Base:
  2. Use Registry Editor to view the data value of the Compatibility Flags DWORD value of the ActiveX object CLSID in the following registry key:

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\ActiveX Compatibility\CLSID of the ActiveX control]

    where CLSID of the ActiveX Control is the class identifier of the appropriate ActiveX control.

  3. Change the value of the Compatibility Flags DWORD value to 0x400 (in hex) or 1024 (in decimal).
  4. Restart Internet Explorer.

    Note: It is not recommended to re-enable an ActiveX control unless you are sure of the purpose. If you do so, you may create security vulnerabilities. The kill bit is normally set for a reason that may be critical, and because of this, extreme care must be used when you unkill an ActiveX control.

    Registry Editor Example
    | Name Type Data |
    | (Default) REG_SZ (value not set) |
    | Compatibility Flags REG_DWORD 0x00000400 (1024) |
    -
    | HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\ActiveX Compatib... |
    -

    Settings:
    System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\
    ActiveX Compatibility\{CLSID of the ActiveX control}]
    Name: Compatibility Flags
    Type: REG_DWORD (DWORD Value)
    Value: (0 = allow, 1024 (400hex) = disable)

    Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

    Last Modified: September 30, 2002


Screen Saver Password Protection Policy (Windows 2000/XP)

Screen Saver Password Protection Policy (Windows 2000/XP)
Category: Home > Security > Desktop and Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction determines whether the screen saver is password protected and prevents users from changing the password-protection setting.

Open your registry and find the key below.

Create a new DWORD valued called "ScreenSaverIsSecure" and set it to a value from the table below.

  • (Not in registry) - Users can turn password-protection on and off.
  • 0 - Screen savers are not password-protected.
  • 1 - All screen savers are password-protected.

    Restart Windows for the change to take effect.

    Registry Editor Example
    | Name Type Data |
    | (Default) REG_SZ (value not set) |
    | ScreenSaverIsSecure REG_DWORD 0x00000001 (1) |
    -
    | HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Control Panel\Desktop |
    -

    Settings:
    User Key: [HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Control Panel\
    Desktop]
    Name: ScreenSaverIsSecure
    Type: REG_DWORD (DWORD Value)

    Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

    Last Modified: September 30, 2002

    • Return to Index Copyright © 1998-2003. All Rights Reserved. License


Restrict the Screen Saver (Windows 2000/XP)

Restrict the Screen Saver (Windows 2000/XP)
Category: Home > Security > Desktop and Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction can be used to specify the screen saver or to stop screen savers from running. Also, the Screen Saver settings page is disabled, so users cannot change the screen saver options.

Open your registry and find or create the key below.

Create a new DWORD value called "ScreenSaveActive" and set it to "0" to disable all screen savers.

Alternatively create a new string value called "SCRNSAVE.EXE" and set it to the executable name of a valid Windows screen saver file, including the .scr extension. This will only be used if "ScreenSaveActive" is set to "1" or deleted from the registry.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ScreenSaveActive | REG_DWORD | 0x00000001 (1) | |
| |  | SCRNSAVE.EXE | REG_SZ | login.scr | |
-
| HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Control Panel\Desktop |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Control Panel\
Desktop]
Name: ScreenSaveActive, SCRNSAVE.EXE
Type: REG_DWORD (DWORD Value)
Value: (0 = disable screen savers, 1 = default)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 9, 2002


Change the Screen Saver Grace Period (Windows NT/2000/XP)

Change the Screen Saver Grace Period (Windows NT/2000/XP)
Category: Home > Windows > Desktop

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting determines when password protection of a screen saver becomes effective. By default, a brief period elapses within which the user can use the mouse or the keyboard to stop the screen saver without entering the password.

Open your registry and find or create the key below.

Create a new string value, or modify the existing value, called "ScreenSaverGracePeriod" and set it according to the value data below. On some versions of Windows this may be a DWORD value, if REG_SZ does not work correctly retry with DWORD.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ScreenSaverGracePeriod | REG_SZ | 5 | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
Name: ScreenSaverGracePeriod
Type: REG_SZ (String Value)
Value: 0 - 2,147,483 seconds (approximately 24 days)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 18, 2003


Change the Download Location for ActiveX Files (All Windows)

Change the Download Location for ActiveX Files (All Windows)
Category: Home > Software > Internet Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak allows you to change the default folder to which ActiveX files are installed when you download an ActiveX control. The default path of this folder is "Windows\Downloaded Program Files."

Open your registry and find the key [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings] and change the value of "ActiveXCache" to the requested download location.

Repeat the step and change the value of "0" in [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\ActiveX Cache] to the same directory.

Restart Internet Explorer for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ActiveXCache | REG_SZ | C:\WINDOWS\Downloaded Program Files | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Se... |
-

Settings:
User Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\
Internet Settings]
Name: ActiveXCache
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 3, 2002


Change the Scheduler Log File Settings (All Windows)

Change the Scheduler Log File Settings (All Windows)
Category: Home > Windows > Accessories > Task Scheduler

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

These settings specify where the Scheduling Agent (Task Scheduler) should write the log file and the maximum log file size (in KB).

Open your registry and find the key below.

Change the string value called "LogPath" to equal the required log filename (default is C:\Windows\SchedLgU.Txt).

Change the DWORD value called "MaxLogSizeKB" to equal the maximum size of the log file in KB.

Restart Windows for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | LogPath | REG_SZ | %SystemRoot%\SchedLgU.Txt | |
| |  | MaxLogSizeKB | REG_DWORD | 0x00000020 (32) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SchedulingAgent |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SchedulingAgent]
Name: LogPath, MaxLogSizeKB

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 3, 2002


Lock the Internet Explorer Toolbars (All Windows)

Lock the Internet Explorer Toolbars (All Windows)
Category: Home > Software > Internet Explorer > Appearance

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allows you to lock the Internet Explorer toolbars in place so they can not be moved by clicking-and-dragging.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'Locked' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Locked | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Toolbar |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Toolbar]
Name: Locked
Type: REG_DWORD (DWORD Value)
Value: (0 = unlocked, 1 = locked)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 3, 2002


Disable Recent Files in Media Player (All Windows)

Disable Recent Files in Media Player (All Windows)
Category: Home > Security > Privacy

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction will stop Windows Media Player from storing the names of the played media in the recent file list.

Open your registry and find the key below.

Create a new Binary value, or modify the existing value called 'AddToMRU' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This setting only effects Windows Media Player 8.0 or greater.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AddToMRU | REG_BINARY | 00 | |
-
| HKEY_CURRENT_USER\Software\Microsoft\MediaPlayer\Preferences |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\MediaPlayer\Preferences]
Name: AddToMRU
Type: REG_BINARY (Binary Value)
Value: 00 = disabled, 01 = enabled

Related Tweaks

  • Clear the Recent Play List in Media Player (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 4, 2002


Change the Windows Address Book Location (All Windows)

Change the Windows Address Book Location (All Windows)
Category: Home > Software > Outlook Express

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting is used to specify the location of the Windows Address Book (WAB). The Windows Address Book is used by Outlook Express and Internet Mail and News to store contact details.

Open your registry and find the key below.

Create a new String value, or modify the existing value called '(Default)' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: The Windows Address Book used by Outlook Express is normally located in the [Windows]\Application Data\Microsoft\Address Book folder.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | C:\Documents and Settings\My Username\App... | |
-
| HKEY_CURRENT_USER\Software\Microsoft\WAB\WAB4\Wab File Name |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\WAB\WAB4\Wab File Name]
Name: (Default)
Type: REG_SZ (String Value)
Value: Filename

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 8, 2002


Disable Web Printing (Windows 2000/XP)

Disable Web Printing (Windows 2000/XP)
Category: Home > Hardware > Printers and Plotters

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction enables and disables server support for Internet printing. Internet printing lets you display printers on Web pages so they can be viewed, managed, and used across the Internet or an intranet.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'DisableWebPrinting' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DisableWebPrinting | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\Printers |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\Printers]
Name: DisableWebPrinting
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = disable web printing)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 9, 2002


Disable Auto Upgrade with Windows Media Player (All Windows)

Disable Auto Upgrade with Windows Media Player (All Windows)
Category: Home > Software > Media Player

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When Windows Media Player is used it will periodically check for newer versions via the Internet. This tweak allows you to turn off this checking and notification.

Windows Media Player 7.0, 7.1 and Media Player for Windows XP (8.0)
Open your registry and find or create the key [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\WindowsMediaPlayer]. Create a new DWORD value called "DisableAutoUpdate" and set it to "1" to disable updates.

Windows Media Player 6.4
Open your registry and find or create the key [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MediaPlayer]. Create a new string value called "EnableAutoUpgrade" and set it to "No" to disable updates.

Restart Windows Media Player for the changes to take effect.

Note: This tweak affects Windows Media Player 6.4, 7.0, 7.1 and Media Player for Windows XP (8.0).

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DisableAutoUpdate | REG_DWORD | 0x00000001 (1) | |
| |  | EnableAutoUpgrade | REG_SZ | No | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\WindowsMediaPlayer |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\WindowsMediaPlayer]
Name: DisableAutoUpdate, EnableAutoUpgrade

Related Tweaks

  • Disable Media Player Upgrade Message (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 10, 2002


Prevent Regedit from Saving the Last Location (Windows 2000/XP)

Prevent Regedit from Saving the Last Location (Windows 2000/XP)
Category: Home > Windows > Accessories > Registry Editor

By default, when you start Regedit.exe, it displays the last key you accessed the last time you ran Regedit. This tweak describes how to prevent this behavior.

  1. Open your registry using Regedt32.exe and find the key:
    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Applets\Regedit]
  2. Double-click the "LastKey" value, clear the entry in the String box, and then click OK.
  3. Highlight the key, and then click Permissions on the Security menu.
  4. Remove Full Control access for any user who does not want Regedit to display the last key the user accessed in the previous Regedit session, and then click OK. (Please note that if permissions cannot be removed, they may need to be denied.)
  5. Quit Regedt32.exe.

Note: If you do not want to deny access to users, there is an easy way to close all keys and hives after you start Regedit. After you start Regedit, press and hold down SHIFT+LEFT ARROW to collapse all the entries back to the My Computer entry. You must do this each time you start Regedit.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | LastKey | REG_SZ |  | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Applets\Regedit |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Applets\
Regedit]
Name: LastKey
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 10, 2002


Clear Download Accelerator History (All Windows)

Clear Download Accelerator History (All Windows)
Category: Home > Security > Privacy

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Download Accelerator Plus (DAP) is a tool used to retrieve files from Internet servers. It stores a history of the files downloaded and URLs visited. To increase privacy and security this tweak allows you to clear the history.

Open your registry and find the key [HKEY_LOCAL_MACHINE\SOFTWARE\SpeedBit\Download Accelerator\FileList].

Delete the sub-keys under the key to clear the download history.

Open your registry and find the key [HKEY_CURRENT_USER\Software\SpeedBit\Download Accelerator\HistoryCombo].

Delete the data in the value called "URLHistory" to clear the URL combobox history.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | URLHistory | REG_SZ | http://www.download.com/file1.zip | |
-
| HKEY_CURRENT_USER\Software\SpeedBit\Download Accelerator\HistoryCombo |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\SpeedBit\Download Accelerator\HistoryCombo]
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\SpeedBit\Download Accelerator\FileList]
Name: URLHistory
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 14, 2002


Disable OS/2 and POSIX Subsystems (Windows 2000/XP)

Disable OS/2 and POSIX Subsystems (Windows 2000/XP)
Category: Home > Windows > System

To conserve system resources you may want to prevent the Windows session manager (SMSS) from loading any optional subsystems, such as OS/2 or POSIX. This tweak can be used to disable these optional subsystems.

Warning: Make sure you use REGEDT32 to changes this value. Using Regedit may cause the system to crash.

Open your registry using REGEDT32 and find the key below.

When the OS/2 and Posix sub-systems are enabled the value called "Optional" will be set to "Posix" or "OS2 Posix". To disable those sub-systems double-click on the "Optional" value and delete the "Posix" data in the window.

Restart Windows for the change to take effect.

Note: The benefits of not loading these subsystems can be increased memory and system resources.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Optional | REG_MULTI_SZ | OS2 Posix | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\SubS... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\
SubSystems]
Name: Optional
Type: REG_MULTI_SZ (Multi-String Value)
Value: Empty to disable OS/2 and Posix

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 14, 2002


Change the Client-Side DNS Caching Timeouts (Windows 2000/XP/.NET)

Change the Client-Side DNS Caching Timeouts (Windows 2000/XP/.NET)
Category: Home > Network > Clients

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows contains a client-side Domain Name System (DNS) cache with stores recent domain lookup entries. If you are experiencing caching or lookup problems you can disable or change the cache timeout.

Open your registry and find the key below.

To change the DNS cache timeout for positive responses (where a lookup was successful).

Windows 2000 - Create or modify the DWORD value called "MaxCacheEntryTtlLimit".

Windows XP and .NET Server 2003 - Create or modify the DWORD value called "MaxCacheTtl".

Set the value to equal the required timeout in seconds the default is 86400 (1 day).

To change the DNS cache timeout for negative responses (where a lookup failed).

Windows 2000 - Create or modify the DWORD value called "NegativeCacheTime".

Windows XP and .NET Server 2003 - Create or modify the DWORD value called "MaxNegativeCacheTtl".

Set the value to equal the required timeout in seconds the default is 300 (5 minutes).

Restart Windows for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | MaxCacheEntryTtlLimit | REG_DWORD | 0x00000001 (1) | |
| |  | NegativeCacheTime | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Dnscache\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Dnscache\Parameters]
Name: MaxCacheEntryTtlLimit, NegativeCacheTime
Type: REG_DWORD (DWORD Value)
Value: Time in Seconds

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 4, 2003


Convert an IEEE 1394 Device to a Dynamic Disk Drive (Windows XP)

Convert an IEEE 1394 Device to a Dynamic Disk Drive (Windows XP)
Category: Home > Hardware > Disk Drives

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak allows you to convert an Institute of Electrical and Electronics Engineers, Inc. (IEEE) 1394 (FireWire) disk drive to a dynamic disk drive.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'EnableDynamicConversionFor1394' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: Do not convert IEEE 1394 disk drives to dynamic disk drives if they are going to be moved to other hosts. This setting must only be used for drives that remain with a single host.

Note: Dynamic disks are not supported on portable computers or Microsoft Windows XP Home Edition.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | EnableDynamicConversionFor1394 | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Dmadmin\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Dmadmin\Parameters]
Name: EnableDynamicConversionFor1394
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 17, 2002


Disable Encryption for Files Copied to a Server (Windows 2000)

Disable Encryption for Files Copied to a Server (Windows 2000)
Category: Home > Windows > File System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak allows you to prevent Encrypting File System (EFS) files from being copied to a server in an encrypted format. This provides the ability to share files on a central server in an unencrypted state.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'NtfsEncryptionService' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: You may want to have files in an encrypted state by using the Windows Encrypting File System (EFS) feature, such as on a laptop computer, while still having the ability to copy these files in an unencrypted state to a central server to share with other users.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NtfsEncryptionService | REG_SZ | Efs | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem]
Name: NtfsEncryptionService
Type: REG_SZ (String Value)
Value: Delete value to disable ("Efs" = default)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 17, 2002


Increase Cache for Customized Folders (Windows XP)

Increase Cache for Customized Folders (Windows XP)
Category: Home > Security > Start Menu and Taskbar > Documents and Folders

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows XP normally remembers the customized settings of a maximum of 400 folders. This tweak allows you to increase the number of folders that can be individually customized.

Open your registry and find the key below.

Create a new DWORD value called "BagMRU Size" and set it to the number of folders that Windows should save settings for (e.g. 1000).

Repeat the step for the same value at [HKEY_CURRENT_USER\Software\Microsoft\Windows\ShellNoRoam].

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | BagMRU Size | REG_DWORD | 0x000003E8 (1000) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell]
Name: BagMRU Size
Type: REG_DWORD (DWORD Value)
Value: Default = 400 folders

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 29, 2002


Disable Image Preview (Windows XP)

Disable Image Preview (Windows XP)
Category: Home > Windows > Appearance

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When you open an image file in Windows XP the default action is to "Preview" it using the Windows Picture and Fax Viewer. This tweak can be used to disable the Preview image option.

Open your registry and find the key below.

Clear the value of "(Default)" to disable the default image preview action. You can restore the preview action by set the value to "{e84fda7c-1d6a-45f6-b725-cb260c236066}".

The change should take effect immediately.

Note: This will only remove Preview for image formats that are associated with an alternate viewer. File types that are associated with Windows Picture and Fax Viewer will still show the Preview option.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ |  | |
-
| HKEY_CLASSES_ROOT\SystemFileAssociations\image\ShellEx\ContextMenuHandle... |
-

Settings:
System Key: [HKEY_CLASSES_ROOT\SystemFileAssociations\image\ShellEx\
ContextMenuHandlers\ShellImagePreview]
Name: (Default)
Type: REG_SZ (String Value)
Value: Blank or {e84fda7c-1d6a-45f6-b725-cb260c236066}

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 21, 2002


Show "Shortcut to" Label on Internet Explorer Links (All Windows)

Show "Shortcut to" Label on Internet Explorer Links (All Windows)
Category: Home > Software > Internet Explorer > Appearance

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

By default when you hover the mouse over a link in Internet Explorer it will display "Shortcut to filename.htm" in the status bar. This tweak controls that behaviour so that the full URL can be shown instead.

Open your registry and find the key below.

Modify the value called "Show_FullURL" and set it to "0" to show the full URL or "1" to show "Shortcut to ...".

For versions of Internet Explorer prior to 6.0 also open the key [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main] and set the same value to "no" or "yes".

Restart Internet Explorer for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Show_FullURL | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer]
Name: Show_FullURL
Type: REG_DWORD (DWORD Value)
Value: (0 = show full URL, 1 = show "Shortcut to")

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 29, 2002


Speed-up Access to AVI Media Files (Windows XP)

Speed-up Access to AVI Media Files (Windows XP)
Category: Home > Software > Media Player

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows XP can run slowly when attempting to access a folder that contains a large number of AVI (Audio Video Interleave) media files. This tweak speeds the process up by stopping Windows from extracting file information from AVIs.

Open you registry and find the key below.

To disable file information extraction rename the key and place a minus sign infront of the current name (i.e. "-{87D62D94-71B3-4b9a-9489-5FE6850DC73E}").

Restart Windows for the change to take effect.

Settings:
System Key: [HKEY_CLASSES_ROOT\CLSID\{87D62D94-71B3-4b9a-9489-5FE6850DC73E}]

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 29, 2002


Increase the USB Polling Interval (Windows 98/Me/2000/XP)

Increase the USB Polling Interval (Windows 98/Me/2000/XP)
Category: Home > Hardware > Processor and Motherboard

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

By default the USB polling interval is once every millisecond (ms). Even if no USB devices are connected the polling operation is still performed and the processor may not be able to enter power-saving state. Use this tweak to increase the polling interval.

Open your registry and find the key below for your Windows version.

Windows 98 and Windows Millennium Edition
[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\Usb\0000]

Windows 2000 and Windows XP
[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Class\{36FC9E60-C465-11CF-8056-444553540000}\0000]

Create a new DWORD value called "IdleEnable" and set it to "1" to enable USB idling and increase the polling interval.

Restart Windows for the change to take effect.

Note: This tweak should resolve the issue of laptop computers unable to enter the C3 processor power-saving state. By increasing the USB polling interval from one ms to five ms the processor can enter a C3 power-saving state during its inactivity and extend the battery life of the computer.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | IdleEnable | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\Usb\0000 |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Class\Usb\0000]
Name: IdleEnable
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = enable idle)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: October 30, 2002


Remove Set Program Access and Defaults from Start Menu (Windows 2000/XP)

Remove Set Program Access and Defaults from Start Menu (Windows 2000/XP)
Category: Home > Windows > Start Menu and Taskbar

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting is used to remove the "Set Program Access and Defaults" icon from the Start Menu. This feature was introduced with Windows XP SP1 and Windows 2000 SP3 to allow users to configure the default applications used on the PC.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoSMConfigurePrograms' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoSMConfigurePrograms | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoSMConfigurePrograms
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = remove icon)

Related Tweaks

  • Hide Set Program Access and Defaults in Add/Remove Programs (Windows 2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: November 2, 2002


Hide Set Program Access and Defaults in Add/Remove Programs (Windows 2000/XP)

Hide Set Program Access and Defaults in Add/Remove Programs (Windows 2000/XP)
Category: Home > Security > Control Panel

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction is used to hide "Set Program Access and Defaults" on the Add or Remove Programs page. This feature was introduced with Windows XP SP1 and Windows 2000 SP3 to allow users to configure the default applications used on the PC.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoChooseProgramsPage' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoChooseProgramsPage | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Uni... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Uninstall]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Uninstall]
Name: NoChooseProgramsPage
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = hide on add/remove page)

Related Tweaks

  • Remove Set Program Access and Defaults from Start Menu (Windows 2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: November 2, 2002


Enable Remote Assistance (Windows XP)

Enable Remote Assistance (Windows XP)
Category: Home > Network > Internet and Remote Access

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

The Remote Assistance feature is a convenient way for an administrator to remotely connect to a computer and with permission view the screen, move the mouse, use the keyboard and chat online.

Open you registry and find the key below.

To Enable Remote Assitance
Create or modify the following DWORD values:

  • AllowTSConnections set it to "1"
  • fDenyTSConnections set it to "0"
  • fAllowToGetHelp set it to "1"

    To Disable Remote Assitance
    Create or modify the following DWORD values:

  • AllowTSConnections set it to "0"
  • fDenyTSConnections set it to "1"
  • fAllowToGetHelp set it to "0"

    Restart Windows for the changes to take effect.

    Registry Editor Example
    | Name Type Data |
    | (Default) REG_SZ (value not set) |
    | AllowTSConnections REG_DWORD 0x00000001 (1) |
    | fDenyTSConnections REG_DWORD 0x00000000 (0) |
    | fAllowToGetHelp REG_DWORD 0x00000001 (1) |
    -
    | HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server |
    -

    Settings:
    System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server]
    Name: AllowTSConnections, fDenyTSConnections, fAllowToGetHelp
    Type: REG_DWORD (DWORD Value)

    Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

    Last Modified: January 29, 2003

    • Return to Index Copyright © 1998-2003. All Rights Reserved. License


Change the Messenger Warning Message (All Windows)

Change the Messenger Warning Message (All Windows)
Category: Home > Software > Windows Messenger

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When you start a chat in Windows Messenger a warning is shown that says "Never give out your password or credit card number in an instant message conversation". This tweak allows you to customize this message for example to display your company chat policy.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'IMWarning' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | IMWarning | REG_SZ | Never give out your password or credit car... | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MessengerService\Policies |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MessengerService\Policies]
Name: IMWarning
Type: REG_SZ (String Value)
Value: Warning Text

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 21, 2003


Restrict the Language and Locale Region (Windows 2000/XP)

Restrict the Language and Locale Region (Windows 2000/XP)
Category: Home > Security > System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction is used to set the language used in menus and dialog boxes in Windows and prevent users from changing it. When enabled the system disables the menus and dialog boxes in the Regional Options in Control Panel.

Open your registry and find or create the key below.

Create a new DWORD value called "MultiUILanguageID" and set it to a value from the table below to restrict the system to that language.

Language | Decimal | Hexadecimal
Arabic | 1025 | 0x401
Brazilian | 1046 | 0x416
Chinese (Simplified) | 2052 | 0x804
Chinese (Traditional) | 1028 | 0x404
Czech | 1029 | 0x405
Danish | 1030 | 0x406
Dutch | 1043 | 0x413
English (Default) | 1033 | 0x409
Finnish | 1035 | 0x40b
French | 1036 | 0x40c
German | 1031 | 0x407
Greek | 1032 | 0x408
Hebrew | 1037 | 0x40d
Hungarian | 1038 | 0x40e
Italian | 1040 | 0x410
Japanese | 1041 | 0x411
Korean | 1042 | 0x412
Norwegian | 1044 | 0x414
Polish | 1045 | 0x415
Portuguese | 2070 | 0x816
Russian | 1049 | 0x419
Spanish | 3082 | 0xc0a
Swedish | 1053 | 0x41D
Turkish | 1055 | 0x41f

Restart Windows for the change to take effect.

Note: If the language specified in this entry is not installed on the system Windows uses U.S. English.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | MultiUILanguageID | REG_DWORD | 0x00000409 (1033) | |
-
| HKEY_CURRENT_USER\Software\Policies\Microsoft\Control Panel\Desktop |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Policies\Microsoft\Control Panel\Desktop]
Name: MultiUILanguageID
Type: REG_DWORD (DWORD Value)
Value: Language Identifier

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: November 6, 2002


Save Changes to Notepad Configuration (All Windows)

Save Changes to Notepad Configuration (All Windows)
Category: Home > Windows > Accessories

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

The Notepad text editor included with Windows lets you configure the page setup including headers, footers and margins. These options are not normally saved between sessions but with this tweak Notepad can be made to save any changes.

Open your registry and find or create the key below.

Create a new DWORD value called "fSavePageSettings" and set it to "1" to save the page setup settings.

Create a new DWORD value called "fSaveWindowPositions" and set it to "1" to save the window position.

Restart Windows for the change to take effect.

Note: These settings work on specific versions of Notepad included with Microsoft Windows. Although they are supported by most versions of Notepad some versions may not support all options.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | fSavePageSettings | REG_DWORD | 0x00000001 (1) | |
| |  | fSaveWindowPositions | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Notepad |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Notepad]
Name: fSavePageSettings, fSaveWindowPositions
Type: REG_DWORD (DWORD Value)
Value: (0 = disabled, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: November 7, 2002


Disable Update Device Driver Wizard (Windows 98/Me/2000/XP)

Disable Update Device Driver Wizard (Windows 98/Me/2000/XP)
Category: Home > Windows > System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak allows you to disable the ability to use Windows Update to locate updated drivers for hardware in Device Manager.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoDevMgrUpdate' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoDevMgrUpdate | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoDevMgrUpdate
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = remove update)

Related Tweaks

  • Restrict Access to the Windows Update Feature (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: November 14, 2002


View Enhanced Start Menu Folders (Windows XP)

View Enhanced Start Menu Folders (Windows XP)
Category: Home > Windows > Start Menu and Taskbar

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

These settings allow you to customize which items are shown on the Windows XP enhanced Start Menu.

Open your registry and find the key below.

Create a new DWORD value or modify the values from the list below setting them to either: "0" to disable the item, "1" to show the item or "2" to expand the contents.

  • Start_ShowControlPanel - Control Panel
  • Start_ShowMyComputer - My Computer
  • Start_ShowMyDocs - My Documents
  • Start_ShowMyMusic - My Music
  • Start_ShowMyPics - My Pictures
  • Start_ShowNetConn - Network Connections

    You may need to restart Windows for the changes to take effect.

    Note: These settings will not effect the Start Menu in Classic mode.

    Registry Editor Example
    | Name Type Data |
    | (Default) REG_SZ (value not set) |
    | Start_ShowControlPanel REG_DWORD 0x00000001 (1) |
    | Start_ShowMyComputer REG_DWORD 0x00000001 (1) |
    | Start_ShowMyDocs REG_DWORD 0x00000001 (1) |
    | Start_ShowMyMusic REG_DWORD 0x00000001 (1) |
    | Start_ShowMyPics REG_DWORD 0x00000001 (1) |
    | Start_ShowNetConn REG_DWORD 0x00000001 (1) |
    -
    | HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Adv... |
    -

    Settings:
    User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
    Advanced]
    Name: Start_ShowControlPanel, Start_ShowMyComputer, Start_ShowMyDocs, Start_ShowMyMusic, Start_ShowMyPics, Start_ShowNetConn
    Type: REG_DWORD (DWORD Value)
    Value: (0 = hidden, 1 = open when clicked, 2 = expand contents)

    Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

    Last Modified: November 14, 2002

    • Return to Index Copyright © 1998-2003. All Rights Reserved. License


Choose the First Desktop Icon (Windows 2000/Me/XP)

Choose the First Desktop Icon (Windows 2000/Me/XP)
Category: Home > Windows > Desktop

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak allows you to choose the icon that you want to appear first on the desktop either My Documents or My Computer.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'SortOrderIndex' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This change will only take effect when using "Auto Arrange" with the desktop icons.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SortOrderIndex | REG_DWORD | 0x00000048 (72) | |
-
| HKEY_CLASSES_ROOT\CLSID\{450D8FBA-AD25-11D0-98A8-0800361B1103} |
-

Settings:
System Key: [HKEY_CLASSES_ROOT\CLSID\{450D8FBA-AD25-11D0-98A8-0800361B1103}]
Name: SortOrderIndex
Type: REG_DWORD (DWORD Value)
Value: (0x48 = My Documents, 0x54 = My Computer)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: November 17, 2002


Remove Shared Documents from My Computer (Windows XP)

Remove Shared Documents from My Computer (Windows XP)
Category: Home > Windows > Windows Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

The Shared Documents folder allows users to easily share files and folders over a network. This restriction will remove the "Shared Documents" object from My Computer.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoSharedDocuments' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoSharedDocuments | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoSharedDocuments
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: November 18, 2002


Highlight New Programs on Start Menu (Windows XP)

Highlight New Programs on Start Menu (Windows XP)
Category: Home > Windows > Start Menu and Taskbar

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When you install a new Windows program the icon will be highlighted on the Start Menu to allow you to quickly locate it. This tweak controls whether new programs should be highlighted.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'Start_NotifyNewApps' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This only effects the Enhanced Windows XP Start Menu, it will not effect the "Classic" version.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Start_NotifyNewApps | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Adv... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
Advanced]
Name: Start_NotifyNewApps
Type: REG_DWORD (DWORD Value)
Value: (0 = no, 1 = yes)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: November 18, 2002


Restore Folder Windows at Startup (Windows XP)

Restore Folder Windows at Startup (Windows XP)
Category: Home > Windows > Windows Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This option controls whether Windows will attempt to re-open any folders that were already open when the system was last shutdown.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'PersistBrowsers' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | PersistBrowsers | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Adv... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
Advanced]
Name: PersistBrowsers
Type: REG_DWORD (DWORD Value)
Value: (0 = do not re-open, 1 = re-open windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: November 18, 2002


Set the Temporary Attachment Directory for Outlook (All Windows)

Set the Temporary Attachment Directory for Outlook (All Windows)
Category: Home > Software > Microsoft Office > Outlook

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When you open an attachment in an Outlook the temporary attachment file is created in a known folder, this may present a possible security problem. This tweak allows you to change the temporary directory used for storing attachments.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'OutlookSecureTempFolder' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | OutlookSecureTempFolder | REG_SZ | C:\Temp\Attachments\ | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Office\[version]\Outlook\Security |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Office\[version]\Outlook\Security]
Name: OutlookSecureTempFolder
Type: REG_SZ (String Value)
Value: Temporary Folder Name

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: November 21, 2002


Change Copy and Move NTFS Permissions (Windows NT/2000/XP)

Change Copy and Move NTFS Permissions (Windows NT/2000/XP)
Category: Home > Windows > File System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When you copy or move a file or folder to another volume, the object inherits the permissions of its new folder. This setting allows you to force Windows to preserve the current permissions instead.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'ForceCopyAclwithFile' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: By default, an object inherits permissions from its parent object, either at the time of creation or when it is copied or moved to its parent folder. The only exception to this rule occurs when you move an object to a different folder on the same volume. In this case, the original permissions are retained.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ForceCopyAclwithFile | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: ForceCopyAclwithFile
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = preserve original permissions)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 2, 2002


Optimize Find Fast Index Updates (All Windows)

Optimize Find Fast Index Updates (All Windows)
Category: Home > Software > Microsoft Office

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Microsoft Office includes a Find Fast Indexer to increase file searching speed. On large drives performance may be impacted when creating or updating an index. This setting is used to delay indexing for a specified amount of time between index updates and therefore minimize system activity and increase performance.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'SlowDown' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SlowDown | REG_DWORD | 0x000003E8 (1000) | |
-
| HKEY_LOCAL_MACHINE\Software\Microsoft\Office\9.0\Find Fast |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Office\9.0\Find Fast]
Name: SlowDown
Type: REG_DWORD (DWORD Value)
Value: Delay period in milliseconds (default = 1000)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: November 28, 2002


Reset Microsoft Word Settings and Recent Files (All Windows)

Reset Microsoft Word Settings and Recent Files (All Windows)
Category: Home > Software > Microsoft Office > Word

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting can be used to reset the Word parameters back to the default if you are experiencing problems. For example if you start Word and one of your toolbars or menu bars is missing, or if your personalized settings are not retained.

Open your registry and find the key below where office version is either "9.0" for Office 2000 or "10.0" for Office XP.

With the "Data" folder selected, click Rename on the Edit menu. Type a new name for the Data folder (for example, type OldData) and then press ENTER.

Restart Word for the changes to take effect.

Note: This tweak will also clear the Most Recently Used (MRU) file list on the File menu.

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Office\[office version]\Word\Data]

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 2, 2002


Enable Wide Text Printing in Microsoft Word (All Windows)

Enable Wide Text Printing in Microsoft Word (All Windows)
Category: Home > Software > Microsoft Office > Word

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When you print a document that contains extended characters, such as Greek symbols, to certain printers that do not support Unicode characters, the extended characters may be printed as square boxes. This tweak should resolve the problem on most printers.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'NoWideTextPrinting' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: Due to the method required the printing quality may be lower than when using direct Unicode support.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoWideTextPrinting | REG_SZ | 1 | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Office\[office version]\Word\Options |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Office\[office version]\Word\
Options]
Name: NoWideTextPrinting
Type: REG_SZ (String Value)
Value: (0 = default, 1 = enabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: November 28, 2002


Disable Network Messenger Service (Windows NT/2000/XP)

Disable Network Messenger Service (Windows NT/2000/XP)
Category: Home > Security > Privacy

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

The Messenger service is normally used to transmit net send and Alerter service messages between clients and servers. Recently it has been employed by marketers for sending unsolicited advertising popups (SPAM) over the Internet. This tweak allows you to disable this service.

Open your registry and find the key below.

Change the value of "Start" to "4" to disable the Messenger service.

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Start | REG_DWORD | 0x00000004 (4) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Messenger |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Messenger]
Name: Start
Type: REG_DWORD (DWORD Value)
Value: (2 = automatic, 3 = enabled, 4 = disabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 2, 2002


Restrict Shortcut and WinHelp Commands (Windows NT/2000/XP)

Restrict Shortcut and WinHelp Commands (Windows NT/2000/XP)
Category: Home > Security > System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction can be used to specify which directories contain Help files that can use the Shortcut and WinHelp commands. By clearing this setting you can also completely disable the help commands on the system.

Open your registry and find the key below.

Create a new Expanded String value, or modify the existing value called 'HelpQualifiedRootDir' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: With features in HTML Help, you can run executable programs from a help (.chm) file. The Shortcut command is used to run an executable program that is external to the Help file. The WinHelp command is used to run Winhlp32.exe to display a Winhelp (.hlp) file. This article describes how to restrict the Help files that are allowed to use the Shortcut and WinHelp commands.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | HelpQualifiedRootDir | REG_EXPAND_SZ | %windir%\help;%windir%\pchealth\helpctr;%program files% | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\System |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\System]
Name: HelpQualifiedRootDir
Type: REG_EXPAND_SZ (Expanded String Value)
Value: Allowed Help File Directories (semi-colon delimiter)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 9, 2002


Backup Outlook Express Blocked Senders and Mail Rules (All Windows)

Backup Outlook Express Blocked Senders and Mail Rules (All Windows)
Category: Home > Software > Outlook Express

This article describes how to backup and restore your Blocked Senders list and other mail rules in Outlook Express 5 and later.

How to Back Up Blocked Senders List and Other Mail Rules

The Blocked Senders List

  1. Open your registry and find the key below where GUID represents the unique user identifier.

    [HKEY_CURRENT_USER\Identities\{GUID}\Software\Microsoft\Outlook Express\5.0\Block Senders]

  2. On the Registry menu, click Export Registry File.
  3. Save the file to a location where it can be easily restored.
Other Mail Rules
  1. Open your registry and find the key below where GUID represents the unique user identifier.

    [HKEY_CURRENT_USER\Identities\{GUID}\Software\Microsoft\Outlook Express\5.0\Rules\Mail]

  2. On the Registry menu, click Export Registry File.
  3. Save the file to a location where it can be easily restored.

Note: If multiple Identities are in use for Outlook Express, these steps should be repeated for each Identity, and the backup data segregated accordingly.

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 16, 2002


Windows NT Failure to Open Large Files (Windows NT)

Windows NT Failure to Open Large Files (Windows NT)
Category: Home > Windows > Troubleshooting

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When an application tries to open large files (over 100MB), the request may fail with one of the following error messages: Insufficient Resources or Invalid Handle. This tweak can be used to resolve the problem.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'DisablePagedPoolHint' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This fix requires Windows NT 4.0 service pack 4 or greater.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DisablePagedPoolHint | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memo... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\
Memory Management]
Name: DisablePagedPoolHint
Type: REG_DWORD (DWORD Value)
Value: (1 = enable fix)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 18, 2002


Configure the Network Path Preference in Word (All Windows)

Configure the Network Path Preference in Word (All Windows)
Category: Home > Software > Microsoft Office > Word

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allows you to configure Microsoft Word to retain file path information when you work with files on a network server, either as a mapped drive (Z:\Folder_Name\File_Name) or as Universal Naming Convention (\\Share_Name\File_Name).

Open your registry and find or create the key below.

Create a new DWORD value, or modify the existing value, called "VolumePref" and set it according to the value data below.

  • 0 - Use the drive letter or UNC as typed (default)
  • 1 - Convert UNC to drive letter if a drive is mapped
  • 2 - Convert the drive letter to UNC
Restart Word for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | VolumePref | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\[Version]\Word\Options |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\[Version]\Word\
Options]
Name: VolumePref
Type: REG_DWORD (DWORD Value)
Value: 0 (default), 1 or 2

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 18, 2002


Change the Cache Size for Network Word Documents (All Windows)

Change the Cache Size for Network Word Documents (All Windows)
Category: Home > Software > Microsoft Office > Word

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When Microsoft Word 2002 reads a file from a network location (UNC), it reads the file into the default 64 kilobyte (KB) page buffer memory. With larger documents this may not be sufficient and cause a delay as changes are made to the document. This tweak allows you to increase the buffer size so that the whole document can be read at once.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'CACHESIZE' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | CACHESIZE | REG_DWORD | 0x00000200 (512) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Options |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Options]
Name: CACHESIZE
Type: REG_DWORD (DWORD Value)
Value: Size of cache 64 - 1024KB (in multiples of 64)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 18, 2002


Disable the Windows XP Tour (Windows XP)

Disable the Windows XP Tour (Windows XP)
Category: Home > Windows > Accessories

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

After installing Windows XP you are prompted to run the Tour the first three times you log into the system. This tweak can be used to suppress the balloon prompts.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'RunCount' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | RunCount | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Applets\Tour |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Applets\Tour]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Applets\
Tour]
Name: RunCount
Type: REG_DWORD (DWORD Value)
Value: Remaining times to prompt (0 = disabled)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 8, 2003


Disable SSDP Discovery in Windows Messenger (Windows 2000/XP)

Disable SSDP Discovery in Windows Messenger (Windows 2000/XP)
Category: Home > Software > Windows Messenger

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows Messenger uses the Simple Service Discovery Protocol (SSDP) to attempt to locate upstream Internet gateways on UDP port 1900. This tweak allows you to disable Universal Plug and Play Network Address Translation discovery to reduce bandwidth and increase security.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'UPnPMode' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | UPnPMode | REG_DWORD | 0x00000002 (2) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DirectPlayNATHelp\DPNHUPnP |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\DirectPlayNATHelp\DPNHUPnP]
Name: UPnPMode
Type: REG_DWORD (DWORD Value)
Value: (2 = disable UPnP broadcasts)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 19, 2002


Protect Against SYN Flood Attacks (Windows NT/2000/XP)

Protect Against SYN Flood Attacks (Windows NT/2000/XP)
Category: Home > Security > Network

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows includes protection that allows it to detect and adjust when the system is being targeted with a SYN flood attack (a type of denial of service attack). When enabled the connection responses time out more quickly in the event of an attack.

Open your registry and find the key below.

Create a new DWORD value called "SynAttackProtect" and set it to either 0, 1 or 2 based on the table below.

This value causes Transmission Control Protocol (TCP) to adjust retransmission of SYN-ACKS. When you configure this value, the connection responses time out more quickly in the event of a SYN attack (a type of denial of service attack).

  • 0 (default) - typical protection against SYN attacks
  • 1 - better protection against SYN attacks that uses the advanced values below.
  • 2 (recommended) - best protection against SYN attacks. This value adds additional delays to connection indications, and TCP connection requests quickly timeout when a SYN attack is in progress.
Optional Advanced Values

For extra control you can create these additional DWORD values in the same key for each of the items below. They are not required for SynAttackProtect to be effective.

  • TcpMaxHalfOpen - default value is "100"
  • TcpMaxHalfOpenRetried - default value is "80"
  • TcpMaxPortsExhausted - default value is "5"
  • TcpMaxConnectResponseRetransmissions - default value is "3"

Restart Windows for the changes to take effect.

Note: When SynAttackProtect is using the best protection option then Scalable windows and TCP parameters that are configured on each adapter (including Initial RTT and window size) are no longer available.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SynAttackProtect | REG_DWORD | 0x00000002 (2) | |
| |  | TcpMaxHalfOpen | REG_DWORD | 0x00000064 (100) | |
| |  | TcpMaxHalfOpenedRetried | REG_DWORD | 0x00000050 (64) | |
| |  | TcpMaxPortsExhausted | REG_DWORD | 0x00000005 (5) | |
| |  | TcpMaxConnectResponseRetrans... | REG_DWORD | 0x00000003 (3) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]
Name: SynAttackProtect,
Type: REG_DWORD (DWORD Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 19, 2002


Harden the TCP/IP Stack for Denial of Service Attacks (Windows 2000/XP)

Harden the TCP/IP Stack for Denial of Service Attacks (Windows 2000/XP)
Category: Home > Security > Network

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Denial of service attacks are network attacks that are aimed at making a computer or a particular service unavailable to network users. These settings can be used to increase the ability for Windows to defend against these attacks when connected directly to the Internet.

Open your registry and find the key below.

Create the following DWORD values and set them according to the table below.

  • EnableDeadGWDetect = "0" (default = 1)
    Disables dead-gateway detection as an attack could force the server to switch gateways.
  • EnableICMPRedirect = "0" (default = 1)
    Stops Windows from altering its route table in response to ICMP redirect messages. Some documentation has this listed as "EnableICMPRedirects" but according to Microsoft it should be "EnableICMPRedirect" no "s".
  • EnablePMTUDiscovery = "0" (default = 1)
    Disables maximum transmission unit (MTU) discovery as an attacker could force the MTU value to a very small value and overwork the stack.
  • KeepAliveTime = "300,000" (default = 7,200,000)
    Reduces how often TCP attempts to verify that an idle connection is still intact by sending a keep-alive packet.
  • NoNameReleaseOnDemand = "1" (default = 0)
    Protects the computer against malicious NetBIOS name-release attacks.
  • PerformRouterDiscovery = "0" (default = 1)
    Disables ICMP Router Discovery Protocol (IRDP) where an an attacker may remotely add default route entries on a remote system.
  • SynAttackProtect = "2" (default = 0)
    Automatically adds additional delays to connection indications, and TCP connection requests quickly timeout when a SYN attack is in progress.
Restart Windows for the changes to take effect.

Note: These values will not give the best performance due to additional checking and less optimization, but they will provide greater protection against attacks.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | EnableDeadGWDetect | REG_DWORD | 0x00000000 (0) | |
| |  | EnableICMPRedirect | REG_DWORD | 0x00000000 (0) | |
| |  | EnablePMTUDiscovery | REG_DWORD | 0x00000000 (0) | |
| |  | KeepAliveTime | REG_DWORD | 0x000493e0 (300000) | |
| |  | NoNameReleaseOnDemand | REG_DWORD | 0x00000001 (1) | |
| |  | PerformRouterDiscovery | REG_DWORD | 0x00000000 (0) | |
| |  | SynAttackProtect | REG_DWORD | 0x00000002 (2) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]
Name: EnableDeadGWDetect, EnableICMPRedirect, EnablePMTUDiscovery, KeepAliveTime, NoNameReleaseOnDemand, PerformRouterDiscovery, SynAttackProtect
Type: REG_DWORD (DWORD Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 19, 2002


Clear Past Icons from the Tray Notification Area (Windows XP)

Clear Past Icons from the Tray Notification Area (Windows XP)
Category: Home > Windows > Start Menu and Taskbar > Taskbar

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak allows you to clear the Past Items list in the customized notifications area of the systray.

Open your registry and find the key below.

To clear the notification history delete the values called "IconStreams" and "PastIconsStream".

Open Task Manager, click the Processes tab, click Explorer.exe, and then click End Process.

In Task Manager, click File, click New Task, type explorer, and then click OK.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | IconStreams | REG_BINARY |  | |
| |  | PastIconsStream | REG_BINARY |  | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Tra... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\
TrayNotify]
Name: IconStreams, PastIconsStream
Type: REG_BINARY (Binary Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 20, 2002


Remove the Menu Sliding Animation (Pocket PC 2002)

Remove the Menu Sliding Animation (Pocket PC 2002)
Category: Home > Software > Windows CE

This tweak will remove the animated sliding menu effect found on the Pocket PC.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'AniType' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | AniType | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\GWE\Menu |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\GWE\Menu]
Name: AniType
Type: REG_DWORD (DWORD Value)
Value: (0 = disable, 6 = default)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 20, 2002


Change Windows Update Text in Internet Explorer (All Windows)

Change Windows Update Text in Internet Explorer (All Windows)
Category: Home > Software > Internet Explorer > Appearance

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak allows you to rename or remove the "Windows Update" menu item by entering a custom text value.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'Windows Update Menu Text' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: Leaving the value blank will remove it from the menu.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Windows Update Menu Text | REG_SZ | Update IE | |
-
| HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer]
Name: Windows Update Menu Text
Type: REG_SZ (String Value)

Related Tweaks

  • Restrict Access to the Windows Update Feature (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 20, 2002


Configure Windows Software Update Services (Windows 2000/XP)

Configure Windows Software Update Services (Windows 2000/XP)
Category: Home > Security > System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

These settings allow you to configure Windows client machines to use custom Microsoft Software Update Services (SUS) located on an internal corporate network instead of the Windows Update Internet site.

Open your registry and find or create the key below.

[HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\WindowsUpdate\AU]

Create a new DWORD value called "UseWUServer" and set it to "1" to use custom update servers or delete the value to use the default Internet site.

Then open the key

[HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\WindowsUpdate]

and create two new string values called "WUServer" and "WUStatusServer", set these values to the names of the custom update servers (e.g. "http://intranetupdate").

Restart Windows for the changes to take effect.

Note: Information in Microsoft Software Update Services (SUS) can be found online at http://www.microsoft.com/windows2000/windowsupdate/sus/

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | WUServer | REG_SZ | http://intranetupdate | |
| |  | WUStatusServer | REG_SZ | http://intranetupdate | |
-
| HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\WindowsUpdate |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\WindowsUpdate]
Name: UseWUServer, WUServer, WUStatusServer

Related Tweaks

  • Manage Automatic Windows Updates (Windows 2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 21, 2002


Disable Password Caching in Internet Explorer (All Windows)

Disable Password Caching in Internet Explorer (All Windows)
Category: Home > Software > Internet Explorer > Security

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When you attempt to view a password-protected site, you are normally prompted to type your username and password with an option to "Save this password in your password list". This tweak can be used to disable the ability for users to save passwords.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'DisablePasswordCaching' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DisablePasswordCaching | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Set... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\
Internet Settings]
Name: DisablePasswordCaching
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = disable password cache)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 27, 2002


Use Auto-Complete in Word File Dialog Boxes (All Windows)

Use Auto-Complete in Word File Dialog Boxes (All Windows)
Category: Home > Software > Microsoft Office > Word

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When you type a file name in the Open, Save, or Save As dialog box, Word may automatically try to complete the file name for you. This tweak can be used to enable or disable this behaviour.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'Use AutoComplete' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: If you are using Microsoft Office 2000 you should install the Office 2000 SR-1/SR-1a Update before this tweak will take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Use AutoComplete | REG_SZ | No | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Office\[version]\Common\General |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Office\[version]\Common\General]
Name: Use AutoComplete
Type: REG_SZ (String Value)
Value: "Yes" or "No"

Related Tweaks

  • Change the Auto Complete Mode (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 27, 2002


Change the Library Search Order (Windows 2000/XP)

Change the Library Search Order (Windows 2000/XP)
Category: Home > Windows > System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls the order in which directories are searched for DLL (Dynamic Link Library) files. This may be useful to ensure that a local DLL is used when a program is being run over a network or to resolve issues where incompatible system DLL files are being loaded first.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'SafeDllSearchMode' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: Service pack 3 (SP3) or greater should be installed when using with Windows 2000.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SafeDllSearchMode | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager]
Name: SafeDllSearchMode
Type: REG_DWORD (DWORD Value)
Value: (1 = search System and Windows directories first, 0 = search current directory first)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: December 31, 2002


Manage Network Bridge Feature (Windows XP)

Manage Network Bridge Feature (Windows XP)
Category: Home > Network

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows XP includes a new feature called Network Bridge, which lets you connect disparate media types into one seamless network. This tweak allows you to control forwarding and settings associated with this feature.

Open your registry and find the key below.

Create or modify the DWORD values from the table and set them to "1" to disable the feature, or "0" (default) to enable it.

  • DisableForwarding - disable forwarding
  • DisableSTA - disable spanning tree algorithm
Restart Windows for the change to take effect.

Note: This Microsoft article provides further information on the Windows XP Network Bridging feature: http://www.microsoft.com/WindowsXP/pro/techinfo/administration/homenetbridge/default.asp

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DisableForwarding | REG_DWORD | 0x00000001 (1) | |
| |  | DisableSTA | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\BridgeMP |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\BridgeMP]
Name: DisableForwarding, DisableSTA
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = disable features)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 1, 2003


View Source Not Working in Internet Explorer (All Windows)

View Source Not Working in Internet Explorer (All Windows)
Category: Home > Software > Internet Explorer

When you attempt to view the source HTML of a web page in Internet Explorer it may not be displayed for several reasons. This article describes some of the common causes of this problem.

There are a number of reasons that the Internet Explorer View Source feature may not function correctly, below is a list of the most common causes.

  1. Temporary Files Full
    When the Internet Explorer disk cache becomes full it may stop the View Source function from working. To resolve, open Internet Explorer and click "Tools" > "Internet Options" > "Delete Files".

  2. Cookie Folder Location
    This issue can also occur if your Cookies folder is located on an NTFS partition and you do not have at least Change permissions for the Cookies folder. To resolve, make sure your account has sufficient permissions on the Cookies folder.

  3. Missing Notepad.exe
    The View Source function uses Notepad to display the HTML, if "notepad.exe" is missing from the Windows directory then it will not work. To resolve, ensure a copy of Notepad.exe is in the Windows directory.

  4. Incomplete Page Download
    If you press the ESC key before the page has completed loading then the "View Source" menu item may not be displayed.

  5. View Source Restriction
    The View Source function may have been restricted by your Administrator. To resolve, see the "NoViewSource" registry value in Internet Explorer Restrictions.

  6. Invalid Temporary Directory
    You may also receive this error if the path specified for the TMP environment variable is invalid. To resolve, make sure that the TEMP directory is a valid directory and that there is sufficient space on the drive.

  7. Invalid View Source Program
    If you have specified an alternate program to view the source code (see Use an Alternate Source Viewer with Internet Explorer). To resolve, make sure that the alternate viewer is valid and operational.

  8. Right-click disabled by Web Page
    Some web pages may implement a restriction to stop visitors from right-clicking on the web page. The source may still be viewed by clicking the main "View" menu, then "Source".
Restart Internet Explorer for most of these changes to take effect.

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 3, 2003


Allow UNC Paths at the Command Prompt (Windows NT/2000/XP)

Allow UNC Paths at the Command Prompt (Windows NT/2000/XP)
Category: Home > Windows > Accessories > Command Processor

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

The Command Processor normally checks and disallows UNC names from being used for the current directory in the Command Prompt as they may cause problems with launched child processes. This tweak can be used to allow UNC paths and remove the warning message.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'DisableUNCCheck' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: If you enable this feature and start a Console that has a current directory of an UNC name, start applications from that Console, and then close the Console, it could cause problems in the applications started from that Console.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DisableUNCCheck | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Command Processor |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Command Processor]
Name: DisableUNCCheck
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = allow UNC)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 8, 2003


Change the Default Disk Utilities (All Windows)

Change the Default Disk Utilities (All Windows)
Category: Home > Windows > File System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

These settings control the default tools used for Windows disk management including Backup, Defrag, Repair and Cleanup. Changing these values will alter the programs used when you right-click a disk in My Computer and select Properties > Tools.

Open your registry and find the key [HKEY_LOCAL_MACHINE \SOFTWARE \Microsoft \Windows \CurrentVersion \Explorer \MyComputer].

Under this key are four sub-keys representing each tool (the key may not already exist and may need to be created manually). The "(Default)" value in each key is used to specify the program to use for that function. The sub-keys are:

  • [..\BackupPath] - For the file backup utility.
    Default NT/2000/XP: "%SystemRoot%\system32\ntbackup.exe"
    Default W9x/WME: "C:\Windows\Backup.exe"

  • [..\ChkDskPath] - For the disk repair utility (chkdsk)
    Default NT/2000/XP: "%SystemRoot%\system32\chkdsk.exe %c:"
    Default W9x/WME: "C:\Windows\chkdsk.exe"

  • [..\CleanupPath] - For the disk cleanup utility
    Default NT/2000/XP: "%SystemRoot%\system32\cleanmgr.exe /D %c"
    Default W9x/WME: "C:\Windows\CleanMgr.exe"

  • [..\DefragPath] - For the disk defragmenter
    Default NT/2000/XP: "%systemroot%\system32\dfrg.msc %c:"
    Default W9x/WME: "C:\Windows\Defrag.exe"
To return the value to the default either set it to a value above or delete the entire sub-key.

Changes take effect immediately and can be accessed by right-clicking a disk drive in My Computer and selecting Properties > Tools.

Note: If you set the value to an invalid path or filename Windows will show an error when you attempt to launch the tool.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | %SystemRoot%\system32\ntbackup.exe | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\My... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\
MyComputer\{utility key}]
Name: (Default)
Type: REG_SZ (String Value)
Value: Program filename

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 8, 2003


Search for All File Types (Windows XP)

Search for All File Types (Windows XP)
Category: Home > Windows > Windows Explorer > Search

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows normally only includes registered file types when searching for files and folders. This tweak can be used to enable searching of all file types.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'FilterFilesWithUnknownExtensions' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | FilterFilesWithUnknownExtensions | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\ContentIndex |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\ContentIndex]
Name: FilterFilesWithUnknownExtensions
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = all file types)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 23, 2003


Restrict Import and Export of Internet Explorer Settings (All Windows)

Restrict Import and Export of Internet Explorer Settings (All Windows)
Category: Home > Software > Internet Explorer > Security

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction can be used to disable the import and export of Internet Explorer cookies and favorites. When users utilize the "Import and Export" wizard on the File menu they will be shown a message when clicking "Finish".

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'DisableImportExportFavorites' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DisableImportExportFavorites | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer]
Name: DisableImportExportFavorites
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = restrict import and export)

Related Tweaks

  • Internet Explorer Restrictions (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: January 29, 2003


Change the Command Prompt (Windows NT/2000/XP)

Change the Command Prompt (Windows NT/2000/XP)
Category: Home > Windows > Accessories > Command Processor

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allows you to change the format of the command prompt to show additional information instead of just the current drive and path ("C:\>").

Open your registry and find the key below.

Create or modify a REG_EXPAND_SZ string called "PROMPT" and set it to the required prompt format including any special codes or variables below.

Special Codes

  • $A - & (Ampersand)
  • $B - | (pipe)
  • $C - ( (Left parenthesis)
  • $D - Current date
  • $E - Escape code (ASCII code 27)
  • $F - ) (Right parenthesis)
  • $G - > (greater-than sign)
  • $H - Backspace (erases previous character)
  • $L - < (less-than sign)
  • $N - Current drive
  • $P - Current drive and path
  • $Q - = (equal sign)
  • $S - (space)
  • $T - Current time
  • $V - Windows XP version number
  • $_ - Carriage return and linefeed
  • $$ - $ (dollar sign)

    Variables

  • %USERNAME% - Current Username
  • %COMPUTERNAME% - Local computer name
  • %USERDOMAIN% - Local domain name

    The default prompt is "$P$G" (e.g. "C:\>"), some alternatives include:

  • [%computername%]$S$P$G to show the computer, drive and path
  • [%username%]$S$P$G to show the current user, drive and path

    Restart or log-off Windows for the change to take effect.

    Registry Editor Example
    | Name Type Data |
    | (Default) REG_SZ (value not set) |
    | PROMPT REG_EXPAND_SZ [%username%]$S$P$G |
    -
    | HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Envi... |
    -

    Settings:
    System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\
    Environment]
    Name: PROMPT
    Type: REG_EXPAND_SZ (Expanded String Value)
    Value: Prompt Text (e.g. $P$G)

    Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

    Last Modified: January 29, 2003

    • Return to Index Copyright © 1998-2003. All Rights Reserved. License


Disable Secure E-mail Certificate Checking (All Windows)

Disable Secure E-mail Certificate Checking (All Windows)
Category: Home > Software > Microsoft Office > Outlook

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When you send a secure message in Outlook 2002 or Outlook 2000, you may need to use a certificate that does not match your e-mail address. This tweak allows you to turn off e-mail matching for certificates.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'SupressNameChecks' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SupressNameChecks | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\[version]\Outlook\Security |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\[version]\Outlook\Security]
Name: SupressNameChecks
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = supress checks)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 8, 2003


Enable the Scheduled Tasks Icon (Windows Me)

Enable the Scheduled Tasks Icon (Windows Me)
Category: Home > Windows > Accessories

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak allows you to configure your computer so that the Scheduled Tasks icon is displayed on the taskbar in Windows Millennium Edition (Me).

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'EnableTrayIcon' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | EnableTrayIcon | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\Software\Microsoft\Plus!\System Agent |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Plus!\System Agent]
Name: EnableTrayIcon
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = enable icon)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 6, 2003


Display Network Error Statistics (Windows 2000/XP)

Display Network Error Statistics (Windows 2000/XP)
Category: Home > Network

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak allows you display error statistics on the Network Connection Status page for LAN and WAN connections. This information may be useful in diagnosing the network reliability.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'ShowLanErrors' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ShowLanErrors | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network\Connections\... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network\Connections\
StatMon]
Name: ShowLanErrors
Type: REG_DWORD (DWORD Value)
Value: (0 = default, 1 = enable error count)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 6, 2003


Disable Passport Balloon Reminder (Windows XP)

Disable Passport Balloon Reminder (Windows XP)
Category: Home > Windows > Login and Authentication

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When you install Windows XP a balloon reminder is shown to prompt you to enter a Microsoft .NET Passport. This reminder can be disabled if you are not using Passport or MSN Messenger.

Open your registry and find the key below.

Create a new Binary value, or modify the existing value called 'PassportBalloon' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | PassportBalloon | REG_BINARY | 0a 00 00 00 | |
-
| HKEY_CURRENT_USER\Software\Microsoft\MessengerService |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\MessengerService]
Name: PassportBalloon
Type: REG_BINARY (Binary Value)
Value: "0a 00 00 00" = disabled

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 6, 2003


Configure Internet Connection Sharing (ICS) (Windows 98/Me)

Configure Internet Connection Sharing (ICS) (Windows 98/Me)
Category: Home > Network > Internet and Remote Access

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows 98SE and Me include a feature called Internet Connection Sharing (ICS) which enables networked PCs to easily share a single Internet connection. These settings allow you to configure some ICS parameters.

Open your registry and find the key below.

Change the values from the table below according to your requirements:

  • Enabled (DWORD) - "1" = enable ICS, "0" = disable
  • EnabledDHCP (DWORD) - "1" = enable DHCP server, "0" = disable
  • EnabledDNS (DWORD) - "1" = enable DNS server, "0" = disable
  • IntranetInfo (String) - comma-separated IP address of ICS host and the subnet mask (e.g. "192.168.0.1,255.255.255.0").
Restart Windows for the changes to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Enabled | REG_DWORD | 0x00000001 (1) | |
| |  | EnableDHCP | REG_DWORD | 0x00000001 (1) | |
| |  | EnableDNS | REG_DWORD | 0x00000001 (1) | |
| |  | IntranetInfo | REG_SZ | 192.168.0.1,255.255.255.0 | |
-
| HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\ICSharing\Settings\... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\ICSharing\Settings\
General]
Name: Enabled, IntranetInfo, EnableDHCP, EnableDNS

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 6, 2003


Specify Anonymous Remote Registry Access (Windows NT/2000/XP)

Specify Anonymous Remote Registry Access (Windows NT/2000/XP)
Category: Home > Windows > Accessories > Registry Editor

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak allows you to specify which keys under the HKEY_LOCAL_MACHINE hive that anonymous users are allowed to access remotely. This is useful because some services require remote access to the registry to function correctly.

Open your registry and find the key below.

Create a new Multi-String value, or modify the existing value called 'Machine' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: These keys will bypass general access restrictions but will still be restricted if an explicit access restriction exists for that location.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Machine | REG_MULTI_SZ | System\CurrentControlSet\Control\ProductOptions System\Pr.. | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurePipeServers\wi... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurePipeServers\
winreg\AllowedPaths]
Name: Machine
Type: REG_MULTI_SZ (Multi-String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 6, 2003


Control Microsoft VM Garbage Collection (All Windows)

Control Microsoft VM Garbage Collection (All Windows)
Category: Home > Windows > System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak allows you to specify the quantity of new memory that Java can consume before garbage collection is initiated. Garbage collection (GC) consumes a lot of system resources and can severely affect performance.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'Generation0Size' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: Only functions with Microsoft VM build 3229 or greater.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Generation0Size | REG_DWORD | 0x00040000 (262144) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Java VM |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Java VM]
Name: Generation0Size
Type: REG_DWORD (DWORD Value)
Value: Size in bytes (max = 4194304)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 8, 2003


Change the File Attribute for System Folders (Windows 95/98/Me/NT/2000)

Change the File Attribute for System Folders (Windows 95/98/Me/NT/2000)
Category: Home > Windows > File System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows Explorer normally uses the Read-Only attribute to determine whether a folder is customized. This may cause file saving problems with some programs and not allow you to remove the attribute. This tweak allows you to force Windows to use the alternate System attribute.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'UseSystemForSystemFolders' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | UseSystemForSystemFolders | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer]
Name: UseSystemForSystemFolders
Type: REG_DWORD (DWORD Value)
Value: (1 = use system attribute)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 12, 2003


Allow Uninstall of Windows Components (Windows XP)

Allow Uninstall of Windows Components (Windows XP)
Category: Home > Windows > Accessories

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows includes a number of system components that are normally not available on the Add/Remove Windows Components list. This tweak allows you to display these items and therefore have the option to uninstall.

Open the SYSOC.INF file in the Windows\INF sub-directory (e.g. C:\Windows\INF).

Under the [Components] heading are the system components installed on the computer. The items that have the word "HIDE" or "hide" in them are not displayed on the Add/Remove Programs list. e.g. the WordPad program is usally not shown because it contains "HIDE"

MSWordPad=ocgen.dll,OcEntry,wordpad.inf,HIDE,7

To change an item so it is shown remove the "hide" text, leaving the surrounding commas. For example you would change the WordPad entry from:

MSWordPad=ocgen.dll,OcEntry,wordpad.inf,HIDE,7

To:

MSWordPad=ocgen.dll,OcEntry,wordpad.inf,,7

The main hidden Windows components in Windows XP are:

Accessibility Wizard
AccessOpt=ocgen.dll,OcEntry,optional.inf,HIDE,7

Automatic Windows Update
AutoUpdate=ocgen.dll,OcEntry,au.inf,hide,7

COM+
com=comsetup.dll,OcEntry,comnt5.inf,hide,7

Communications components (including Chat, Hyperterminal, and Phone Dialer)
CommApps=ocgen.dll,OcEntry,communic.inf,HIDE,7

Distributed Transaction Coordinator
dtc=msdtcstp.dll,OcEntry,dtcnt5.inf,hide,7

Windows Messenger
msmsgs=msgrocm.dll,OcEntry,msmsgs.inf,hide,7

WordPad
MSWordPad=ocgen.dll,OcEntry,wordpad.inf,HIDE,7

Multimedia components (including Media Player, Volume Control, and Sound Recorder)
MultiM=ocgen.dll,OcEntry,multimed.inf,HIDE,7

Pinball game
Pinball=ocgen.dll,OcEntry,pinball.inf,HIDE,7

Tablet PC
TabletPC=tabletoc.dll,TabletSetupProc,Tabletpc.inf,HIDE,7

Terminal Server
TerminalServer=TsOc.dll, HydraOc, TsOc.inf,hide,2

Windows Management Instrumentation
WBEM=ocgen.dll,OcEntry,wbemoc.inf,hide,7

Save the file and reopen the Add/Remove Windows Components listing for the change to take effect.

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 12, 2003


Change the Default Keep-Alive Time-Out in Internet Explorer (All Windows)

Change the Default Keep-Alive Time-Out in Internet Explorer (All Windows)
Category: Home > Software > Internet Explorer > Network and Connections

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When Internet Explorer establishes a persistent HTTP connection with a Web server it reuses the same TCP/IP socket until the connection is idle for one minute. This tweak allows you to change the time-out period which is useful if you experience connection problems.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'KeepAliveTimeout' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | KeepAliveTimeout | REG_DWORD | 0x0001D4C0 (120000) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Set... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\
Internet Settings]
Name: KeepAliveTimeout
Type: REG_DWORD (DWORD Value)
Value: Time in milliseconds (default = 120,000)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 19, 2003


Change the Default Mail Client (All Windows)

Change the Default Mail Client (All Windows)
Category: Home > Software

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

The setting allows you to change which program is opened and used to send an e-mail messages when you click on a "mailto:" link in a web page.

Open your registry and find the key below.

Create a new String value, or modify the existing value called '(Default)' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | "C:\program files\Outlook Express\msimn.exe" %1 | |
-
| HKEY_CLASSES_ROOT\mailto\shell\open\command |
-

Settings:
System Key: [HKEY_CLASSES_ROOT\mailto\shell\open\command]
Name: (Default)
Type: REG_SZ (String Value)
Value: Mail program command-line

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 24, 2003


Change the Critical Update Notification Delay (Windows 95/98/Me)

Change the Critical Update Notification Delay (Windows 95/98/Me)
Category: Home > Windows > System > Services

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When Windows detects that a new critical update is available it gives you the option to update now or to be reminded again in 1 day. This tweak allows you to change the default 1 day reminder period.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'CurrentDelayInterval' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | CurrentDelayInterval | REG_DWORD | 0x00015180 (86400) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsUpdate\Critical Update |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsUpdate\Critical Update]
Name: CurrentDelayInterval
Type: REG_DWORD (DWORD Value)
Value: Time in seconds (Default = 86,400)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: February 24, 2003


Optimize the Windows Server Service (Windows NT/2000/XP)

Optimize the Windows Server Service (Windows NT/2000/XP)
Category: Home > Network > Servers

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting can be used to manually optimize the Windows server functionality. By selecting the appropriate value you can optimize the service for memory usage, network throughput or a balance of both.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'Size' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Size | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parame... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\
parameters]
Name: Size
Type: REG_DWORD (DWORD Value)
Value: "1" = minimize memory, "2" = balance or "3" = maximize network throughput

Related Tweaks

  • Optimize the System Cache Size (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 4, 2003


Disable Windows Messenger in Outlook (All Windows)

Disable Windows Messenger in Outlook (All Windows)
Category: Home > Software > Microsoft Office > Outlook

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting can be used to disable the integration of Windows (MSN) Messenger so that is does not start when using Microsoft Outlook.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'ForceDisableIM' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ForceDisableIM | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\10.0\Outlook\Instan... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\10.0\Outlook\
InstantMessaging]
Name: ForceDisableIM
Type: REG_DWORD (DWORD Value)
Value: 1 = enable restriction

Related Tweaks

  • Remove Windows Messenger from Outlook Express (All Windows)
  • Disable MSN Instant Messenger (All Windows)
  • Remove Windows Messenger from Internet Explorer (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 5, 2003


Disable Password Caching for Outlook Internet Mail (All Windows)

Disable Password Caching for Outlook Internet Mail (All Windows)
Category: Home > Software > Microsoft Office > Outlook

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

As a security precaution, you may want to disable the password caching ability for all Internet mail protocols (IMAP, POP and Hotmail) in Outlook 2002. This setting will cause Outlook to request a password on each attempt to retrieve new mail.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'EnableRememberPwd' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: To enable this feature, you need to install Office XP SP1 or greater.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | EnableRememberPwd | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\10.0\Outlook\Security |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\10.0\Outlook\
Security]
Name: EnableRememberPwd
Type: REG_DWORD (DWORD Value)
Value: (0 = disable password caching)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 5, 2003


Using BOOT.INI Startup Switches (Windows NT/2000/XP)

Using BOOT.INI Startup Switches (Windows NT/2000/XP)
Category: Home > Tips and Tricks > Configuration Files > BOOT.INI

Windows NT, 2000 and XP use a configuration file called BOOT.INI to control how the operating system is booted and any startup options. By modifying the startup switches you can manage the boot process including booting Windows in Safe mode, creating a log file, or disabling the splash screen.

Open you the root partition of your hard drive (normally C:\) and find the file called "BOOT.INI". You may need to enable hidden files under Folder > Options.

Right-click on the file, select Properties and uncheck "Read-only" then click OK. You may like to make a backup of the file at this point to allow you to restore if you experience problems.

Open the file in Notepad and under the [operating systems] section you will find a list of all the installed operating systems. For example:

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /fastdetect
To enable or disable startup options simply change or add any of the switches listed below to the default command-line. For example you could add "/SOS" to the command-line above to display the splash screen and view the drivers being loaded.

  • /3GB - New to Service Pack 3. This causes the split between user and system portions of the Windows NT map to become 3GB for user applications, 1GB for System. To take advantage of this the system must be part of the NT Enterprise suite and the application must be flagged as a 3GB aware application.

  • /BASEVIDEO - The computer starts up using the standard VGA video driver. Use this if you have installed a graphics driver that is not working.

  • /BAUDRATE - Specifies the baud rate to be used for debugging. If you do not set the baud rate, the default baud rate is 9600 if a modem is attached, and 19200 for a null-modem cable.

  • /BOOTLOG - Makes 2000 write a log of the boot to the file %SystemRoot%\NTBTLOG.TXT Windows 2000/XP Only.

  • /BURNMEMORY=x - Makes NT forget about the given amount of memory in MB. If /burnmemory=64 was given then 64MB of memory would be unavailable.

  • /CRASHDEBUG - The debugger is loaded when you start Windows NT, but remains inactive unless a Kernel error occurs. This mode is useful if you are experiencing random, unpredictable Kernel errors.

  • /DEBUG - The debugger is loaded when you start Windows NT, and can be activated at any time by a host debugger connected to the computer. This is the mode to use when you are debugging problems that are regularly reproducible.

  • /DEBUGPORT=comx - Specifies the com port to use for debugging, where x is the communications port that you want to use.

  • /FASTDETECT - Specifying FASTDETECT causes NTDETECT to skip parallel and serial device enumeration for a boot into Win2K, whereas omitting the switch has NTDETECT perform enumeration for a boot into NT 4.0. Win2K setup automatically recognizes dual-boot configurations and sets this switch for BOOT.INI lines that specify a Win2K boot. Windows 2000/XP Only.

  • /HAL=<hal> - Allows you to override the HAL used, for example using a checked version.

  • /INTAFFINITY - Sets the multiprocessor HAL (HALMPS.DLL) to set interrupt affinities such that only the highest numbered processor in an SMP will receive interrupts. Without the switch the HAL defaults to its normal behavior of letting all processors receive interrupts. Windows 2000/XP Only.

  • /KERNEL=<kernel> - Same as above but for the kernel.

  • /MAXMEM:n - Specifies the maximum amount of RAM that Windows NT can use. This switch is useful if you suspect a memory chip is bad.

  • /NODEBUG - No debugging information is being used.

  • /NOGUIBOOT - When this option is specified the VGA video driver responsible for presenting bit mapped graphics during Win2K's boot process is not initialized. The driver is used to display boot progress information, as well as to print the Blue Screen crash screen, so disabling it will disable Win2K's ability to do those things as well. Windows 2000/XP only.

  • /NOSERIALMICE=[COMx | COMx,y,z...] - Disables serial mouse detection of the specified COM port(s). Use this switch if you have a component other than a mouse attached to a serial port during the startup sequence. If you use /NOSERIALMICE without specifying a COM port, serial mouse detection is disabled on all COM ports.

  • /NUMPROC=n - Only enables the first n processors on a multiple processor system.

  • /ONECPU - Only use the first CPU in a multiple processor system.

  • /PCILOCK - Stops Windows NT from dynamically assigning IO/IRQ resources to PCI devices and leaves the devices configured by the BIOS.

  • /SAFEBOOT - This is an automatic switch which NTLDR should complete for you when you use the F8 menu to perform a safe boot. Following the colon in the option you must specify one of three additional switches: MINIMAL, NETWORK, or DSREPAIR. The MINIMAL and NETWORK flags correspond to safe boot with no network and safe boot with network support. The safe boot is a boot where Windows 2000/XP only loads drivers and services that are specified by name or group in the Minimal or Network Registry keys under HKLM\System\CurrentControlSet\Control\SafeBoot. The DSREPAIR (Directory Services Repair) switch causes NT to boot into a mode where it restores the Active Directory from a backup medium you present. An additional option that you can append is "(ALTERNATESHELL)". This tells NT to use the program specified by HKLM\System\CurrentControlSet\SafeBoot\AlternateShell as the graphical shell, rather than to use the default which is Explorer. Windows 2000/XP only.

  • /SOS - Displays the driver names while they are being loaded. Use this switch if Windows NT won’t start up and you think a driver is missing. This option is configured by default on the [VGA] option on the boot menu.

  • /WIN95 - This switch is only pertinent on a triple-boot system that has DOS, Win9x and Windows NT installed. Specifying the /WIN95 switch directs NTLDR to boot the Win9x boot sector stored in BOOTSECT.W40. See Microsoft KB Article Q157992 for more information.

  • /WIN95DOS - This switch is only pertinent on a triple-boot system that has DOS, Win9x and Windows NT installed. Specifying the /WIN95DOS switch directs NTLDR to boot the DOS boot sector stored in BOOTSECT.DOS. See Microsoft KB Article Q157992 for more information.

  • /YEAR= - Specifying this value causes NT/Windows 2000 core time function to ignore the year that the computer's real-time clock reports and instead use the one indicated. Thus, the year used in the switch affects every piece of software on the system, including the NT kernel. Example: /YEAR=2005. Note: this option is only available on NT 4.0 Service Pack 4 and Windows 2000/XP.

    Save the file and restart Windows for the change to take effect.

    Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

    Last Modified: March 10, 2003

    • Return to Index Copyright © 1998-2003. All Rights Reserved. License


Change the Number of Undo Levels in Access (All Windows)

Change the Number of Undo Levels in Access (All Windows)
Category: Home > Software > Microsoft Office

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting allows you to modify the maximum number of commands and operations that can be reversed using the Undo function in Microsoft Access 2002.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'Number of Undos' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Number of Undos | REG_DWORD | 0x00000005 (5) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Access\Settings |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Access\Settings]
Name: Number of Undos
Type: REG_DWORD (DWORD Value)
Value: 1 to 20 undo levels

Related Tweaks

  • Change the Number of Undo Levels in Microsoft Excel (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: March 13, 2003


Configure Remote Access Client Account Lockout (Windows 2000/XP)

Configure Remote Access Client Account Lockout (Windows 2000/XP)
Category: Home > Security > Remote Access

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

You can use the remote access account lockout feature to specify how many times a remote access authentication has to fail against a valid user account before the user is denied access. Use this tweak to set the number of failed logins before the account is locked-out and the time before the lockout is reset.

Open your registry and find the key below.

Create a new DWORD value or modify the existing value called "MaxDenials" and set it to the number of failed logins to lockout the account (or 0 to disable lockout).

Create another DWORD value or modify the existing value called "ResetTime (mins)" and set it to the time in minutes that an account should remained locked-out. The default is 2,880 minutes (two days).

Restart Windows or the Remote Access services for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | MaxDenials | REG_DWORD | 0x00000005 (5) | |
| |  | ResetTime (mins) | REG_DWORD | 0x00000b40 (2880) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RemoteAccess\Parame... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RemoteAccess\
Parameters\AccountLockout]
Name: MaxDenials, ResetTime (mins)
Type: REG_DWORD (DWORD Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 1, 2003


Change the Printer Spooler Priority (Windows NT/2000/XP)

Change the Printer Spooler Priority (Windows NT/2000/XP)
Category: Home > Hardware > Printers and Plotters

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Normally the printer spooler runs at the same priority as other services on a system. If your system is being mainly used for printing or handles a large number of print jobs you can use this tweak to change the priority class the print spooler.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'SpoolerPriority' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SpoolerPriority | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print]
Name: SpoolerPriority
Type: REG_DWORD (DWORD Value)
Value: 0 = Normal priority, 1 = High priority, 0xFFFFFFFF = Idle priority

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 16, 2003


Disable the Internet Explorer HTML Source Editor Check (All Windows)

Disable the Internet Explorer HTML Source Editor Check (All Windows)
Category: Home > Software > Internet Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Internet Explorer will normally attempt to detect the program originally used to create a HTML document and modify the "Edit" option to use the same program for future editing. This tweak can be used to enable or disable the checking.

Open your registry and find the key below.

Create a new String value, or modify the existing value called 'CheckDocumentForProgID' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: Disabling this feature will cause Internet Explorer to use the default editor for all editing.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | CheckDocumentForProgID | REG_SZ | no | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
Name: CheckDocumentForProgID
Type: REG_SZ (String Value)
Value: "yes" or "no"

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 24, 2003


Disable System Restore Tools and Settings (Windows XP)

Disable System Restore Tools and Settings (Windows XP)
Category: Home > Security > System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

System Restore allows users to revert Windows settings and configuration changes to an earlier point in time (called Restore Points). This tweak can be used to restrict user access to the System Restore tools and settings.

Open your registry and find or create the key below.

Disable System Restore on Start Menu
Create a new DWORD value called "DisableSR" and set it to "1" to disable the System Restore tools on the Start menu (Start > Programs > Accessories > System Tools > System Restore).

Restrict Access to System Restore Settings
Create a new DWORD value called "DisableConfig" and set it to "1" to disable System Restore Settings link in the System Restore interface and the Control Panel > System > System Restore page.

Changes take effect immediately.

Note: These settings will not stop Windows from making automatic System Checkpoints, but will disable access to restore them.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DisableConfig | REG_DWORD | 0x00000001 (1) | |
| |  | DisableSR | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\SystemRestore |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\SystemRestore]
Name: DisableConfig, DisableSR
Type: REG_DWORD (DWORD Value)
Value: (1 = enable restriction)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 24, 2003


Enable Font Smoothing on the Welcome Screen (Windows XP)

Enable Font Smoothing on the Welcome Screen (Windows XP)
Category: Home > Windows > Startup and Shutdown

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows XP includes a new feature called Clear Type which is designed to make fonts more readable on LCD and low resolution screens. This tweak allows you to enable font smoothing on the Welcome screen where it is normally disabled.

Open your registry and find the key below.

To enable font smoothing, set the value of "FontSmoothing" to "2" and the value of "FontSmoothingType" to "2".

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | FontSmoothing | REG_SZ | 2 | |
| |  | FontSmoothingType | REG_DWORD | 0x00000002 (2) | |
-
| HKEY_CURRENT_USER\Control Panel\Desktop |
-

Settings:
User Key: [HKEY_CURRENT_USER\Control Panel\Desktop]
System Key: [HKEY_USERS\.DEFAULT\Control Panel\Desktop]
Name: FontSmoothing, FontSmoothingType
Value: (0 = disabled, 2 = enabled)

Related Tweaks

  • Control the Font Smoothing Mode (Windows XP)
  • Enable Font Smoothing (All Windows)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 24, 2003


Enable Monitor Power-off on the Logon Screen (All Windows)

Enable Monitor Power-off on the Logon Screen (All Windows)
Category: Home > Windows > Login and Authentication

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Normally Windows will not automatically turn off the monitor if the system is waiting at the logon screen. This setting can be used to cause the monitor to be powered-down when not in use as per the default power-saving profile.

Open your registry and find the key [HKEY_USERS\.DEFAULT\Control Panel\Desktop].

To enable power-off on logon screen
Modify the value of "PowerOffActive" and set it to "1".

Modify the value of "ScreenSaveActive" and set it to "1".

Modify the value of "SCRNSAVE.EXE" and set it to "(None)".

Open the key [HKEY_USERS\.DEFAULT\Control Panel\PowerCfg].

Modify the value of "CurrentPowerPolicy" and set it to "0".

Restart Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | PowerOffActive | REG_SZ | 1 | |
| |  | ScreenSaveActive | REG_SZ | 1 | |
| |  | SCRNSAVE.EXE | REG_SZ | (None) | |
-
| HKEY_USERS\.DEFAULT\Control Panel\Desktop |
-

Settings:
System Key: [HKEY_USERS\.DEFAULT\Control Panel\Desktop]
Name: PowerOffActive, ScreenSaveActive, SCRNSAVE.EXE
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: April 24, 2003


Configure Notepad to use Word Wrap (All Windows)

Configure Notepad to use Word Wrap (All Windows)
Category: Home > Windows > Accessories

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls whether text is wrapped onto the next line when the screen in full in Notepad. Although it can be configured by using the Edit menu in Notepad, this tweak allows you to change the word-wrap feature through the registry.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'fWrap' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | fWrap | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Notepad |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Notepad]
Name: fWrap
Type: REG_DWORD (DWORD Value)
Value: (0 = off, 1= on)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 7, 2003


Change the Number of Page Table Entries (Windows 2000/XP)

Change the Number of Page Table Entries (Windows 2000/XP)
Category: Home > Windows > System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Page Table Entries (PTEs) may become depleted or fragmented on systems that perform a large number input/output (I/O) actions. When they become completely depleted the system may show a Stop error and halt. This tweak allows you to increase the number of PTEs available on the system.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'SystemPages' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SystemPages | REG_DWORD | 0x0000C350 (50000) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memo... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\
Memory Management]
Name: SystemPages
Type: REG_DWORD (DWORD Value)
Value: (0 = system default, 110000 = maximum)

Related Tweaks

  • Modify the Paged and Non Paged Pool Memory Sizes (Windows NT/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 7, 2003


Remove GoTo Option on Explorer Menu (Windows NT/2000)

Remove GoTo Option on Explorer Menu (Windows NT/2000)
Category: Home > Windows > Windows Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This restriction can be used to remove the the GoTo menu from Tools in Explorer.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NoGoTo' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: Requires Service Pack 4 for Windows NT 4.0 or Windows 2000.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoGoTo | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoGoTo
Type: REG_DWORD (DWORD Value)
Value: (0 = show, 1 = hide)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 7, 2003


Receive Notification of Missed Tasks (All Windows)

Receive Notification of Missed Tasks (All Windows)
Category: Home > Windows > Accessories > Task Scheduler

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

By default when you are using Task Scheduler to automatically run programs you will not receive notification if a task is not run. This tweak can be used to cause Windows to show a pop-up message with the option to re-run any missed tasks.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'NotifyOnTaskMiss' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NotifyOnTaskMiss | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SchedulingAgent |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SchedulingAgent]
Name: NotifyOnTaskMiss
Type: REG_DWORD (DWORD Value)
Value: (0 = no notify, 1 = notify)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 7, 2003


Show Administrative Tools in Control Panel (Windows XP)

Show Administrative Tools in Control Panel (Windows XP)
Category: Home > Security > Control Panel

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak allows you to change whether the "Administrative Tools" applet is shown in the Control Panel.

Open your registry and find the key below.

Locate the sub-key "{D20EA4E1-3957-11d2-A40B-0C5020524153}" and to hide the Administrative Tools add a minus sign in-front of the sub-key renaming it to "-{D20EA4E1-3957-11d2-A40B-0C5020524153}".

Reopen the Control Panel for the change to take effect.

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\
ControlPanel\NameSpace]
Name: (Default)
Type: REG_SZ (String Value)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 7, 2003


Disable Web Content in Explorer and Desktop (Windows XP)

Disable Web Content in Explorer and Desktop (Windows XP)
Category: Home > Windows > Desktop

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak can be used to disable the web content and tasks in Explorer, it will also remove the "Desktop" item from Display Properties.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'ClassicShell' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ClassicShell | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: ClassicShell
Type: REG_DWORD (DWORD Value)
Value: (0 = Default, 1 = Classic Desktop)

Related Tweaks

  • Force Windows to Use the Classic Desktop (Windows 95/98/Me/NT/2000)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 16, 2003


Disable Automatic Daylight Savings Adjustment (Windows NT/2000/XP)

Disable Automatic Daylight Savings Adjustment (Windows NT/2000/XP)
Category: Home > Windows > System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows will normally attempt to automatically adjust the system clock for daylight saving changes based on the computer timezone. This tweak allows you to disable the automatic adjustment.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'DisableAutoDaylightTimeSet' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DisableAutoDaylightTimeSet | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation]
Name: DisableAutoDaylightTimeSet
Type: REG_DWORD (DWORD Value)
Value: (1 = disable daylight-savings adjustment)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 21, 2003


Disable Internet Explorer Automatic Proxy Caching (All Windows)

Disable Internet Explorer Automatic Proxy Caching (All Windows)
Category: Home > Software > Internet Explorer > Network and Connections

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When you configure Internet Explorer to use automatic proxy configuration it caches the returned information. If a proxy server fails you may therefore get an error message even though others are available. With this setting you can disable caching to ensure the browser always checks for the latest proxy information.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'EnableAutoProxyResultCache' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: This tweak is only applicable for Internet Explorer 5.5 or greater. If you disable automatic proxy caching, Internet Explorer performance may be affected.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | EnableAutoProxyResultCache | REG_DWORD | 0x0000000 (0) | |
-
| HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\CurrentVersion\Int... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\CurrentVersion\
Internet Settings]
Name: EnableAutoProxyResultCache
Type: REG_DWORD (DWORD Value)
Value: 0 = disable caching

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 21, 2003


Configure LMHOSTS Lookup Options (Windows NT/2000/XP)

Configure LMHOSTS Lookup Options (Windows NT/2000/XP)
Category: Home > Network > Protocols > WINS

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

The LMHOSTS file is used within Windows networking to specify domain resolution and lookup information. These settings allow you to configure the use of the LMHOSTS file.

Open your registry and find the key below.

Create or modify the following DWORD values as necessary:

EnableLMHOSTS - 1 = enable LMHOSTS use, 0 = disable

MaxPreLoad - specify the number of #PRE entries to load (default = 100)

NodeType - specify the WINS query type

  • 1 = if no WINS servers are configured (B-node/broadcast)
  • 4 = perform a broadcast before querying name servers (M-mode/mixed)
  • 8 = at least one WINS server is configured (H-node/queries)

    Restart Windows for the changes to take effect.

    Registry Editor Example
    | Name Type Data |
    | (Default) REG_SZ (value not set) |
    | EnableLMHOSTS REG_DWORD 0x00000001 (1) |
    | MaxPreLoad REG_DWORD 0x000000c8 (200) |
    | NodeType REG_DWORD 0x00000008 (8) |
    -
    | HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NetBT\Parameters |
    -

    Settings:
    System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NetBT\Parameters]
    Name: EnableLMHOSTS, MaxPreLoad, NodeType
    Type: REG_DWORD (DWORD Value)

    Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

    Last Modified: May 21, 2003

    • Return to Index Copyright © 1998-2003. All Rights Reserved. License


Disable Storage of Credentials and .NET Passwords (Windows XP)

Disable Storage of Credentials and .NET Passwords (Windows XP)
Category: Home > Security > System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This setting controls the storage of authentication credentials and .NET passwords on the local system. By disabling this feature, passwords will not be stored.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'DisableDomainCreds' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DisableDomainCreds | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa]
Name: DisableDomainCreds
Type: REG_DWORD (DWORD Value)
Value: (0 = enable storage (default), 1 = disable storage)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 21, 2003


Disable Internet Access (All Windows)

Disable Internet Access (All Windows)
Category: Home > Software > Internet Explorer > Network and Connections

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

By using this tweak you are able to restrict access to the Internet when using Internet Explorer and other Microsoft compatible products such as Office.

Open your registry and find the key below.

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings]

Change the value of "ProxyEnable" and set it to "1". Change the value of "ProxyServer" and set it to an IP address and port that is invalid on your network such as "10.0.0.1:5555" (i.e. "IP:Port").

By changing these settings Internet access will be disabled for any applications that rely of the Microsoft proxy server information such as Internet Explorer, Microsoft Office, Opera browser.

To stop users from modifying the proxy settings add these restrictions to disable changes to the Internet configuration.

Find or create the key below:

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Control Panel]

Create two DWORD values named "Connection Settings" and "Connwiz Admin Lock" and set them both to "1".

To remove the restriction, set the proxy settings back to their original values and delete the policy values.

Note: The change will take effect immediately for any new browser windows, existing Internet Explorer sessions will not be affected until the browser is closed and reopened.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | ProxyEnable | REG_DWORD | 0x00000001 (1) | |
| |  | ProxyServer | REG_SZ | 10.0.0.1:5555 | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Set... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\
Internet Settings]
Name: ProxyEnable, ProxyServer

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 26, 2003


Automatic Administrative Logon to Recovery Console (Windows 2000/XP)

Automatic Administrative Logon to Recovery Console (Windows 2000/XP)
Category: Home > Security > Login and Authentication

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

The recovery console is a command line environment that is used to recover from system problems. This setting controls whether the administrator account will be logged on automatically or be required to enter a password when the recovery console is invoked during startup.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'SecurityLevel' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SecurityLevel | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Setup\Re... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Setup\
RecoveryConsole]
Name: SecurityLevel
Type: REG_DWORD (DWORD Value)
Value: (0 = require password, 1 = no password)

Related Tweaks

  • Manage Floppy Access from Recovery Console (Windows 2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 26, 2003


Manage Floppy Access from Recovery Console (Windows 2000/XP)

Manage Floppy Access from Recovery Console (Windows 2000/XP)
Category: Home > Windows > Troubleshooting

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

If this setting is enabled, a user has full access to all drives on the system and can copy files from the hard drive to the floppy disk when using the Recovery Console.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'SetCommand' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Note: When this setting is disabled, copying files from the hard drive to the floppy drive is prohibited. In addition, the directories and drives that can be accessed are also limited.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | SetCommand | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Setup\Re... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Setup\
RecoveryConsole]
Name: SetCommand
Type: REG_DWORD (DWORD Value)
Value: (0 = restrict, 1 = allow)

Related Tweaks

  • Automatic Administrative Logon to Recovery Console (Windows 2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: May 26, 2003


Disable Local Stylesheets in Internet Explorer (All Windows)

Disable Local Stylesheets in Internet Explorer (All Windows)
Category: Home > Software > Internet Explorer > Security

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Internet Explorer includes an option to load a local stylesheet to set browser based preferences for web page styles. This feature can be exploited by unauthorized programs to implement unrequested popups and malicious tracking of user activity. This tweak allows you to disable local stylesheets.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'Use My Stylesheet' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | Use My Stylesheet | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Styles |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Styles]
Name: Use My Stylesheet
Type: REG_DWORD (DWORD Value)
Value: (0 = disable local stylesheet, 1 = enable)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 20, 2003


Do Not Move Deleted Files to the Recycle Bin (Windows XP)

Do Not Move Deleted Files to the Recycle Bin (Windows XP)
Category: Home > Windows > File System

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

When a file or folder is deleted in Windows Explorer, a copy of the file or folder is placed in the Recycle Bin. Using this setting, you can change this behavior.

Open your registry and find the key below.

If you enable this setting by creating a DWORD value called "NoRecycleFiles" and setting it to "1" then files and folders that are deleted using Windows Explorer will not be placed in the Recycle Bin and will therefore be permanently deleted.

If you disable or do not configure this setting, files and folders deleted using Windows Explorer will be placed in the Recyele Bin.

Logoff for the change to take effect.

Note: This setting applies to all hard drive partitions on the computer.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoRecycleFiles | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoRecycleFiles
Type: REG_DWORD (DWORD Value)
Value: (1 = enabled restriction)

Related Tweaks

  • Disable the Recycle Bin (Windows 98/Me/2000/XP)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 20, 2003


Change Sort Order in Windows Explorer (All Windows)

Change Sort Order in Windows Explorer (All Windows)
Category: Home > Windows > Windows Explorer

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

Windows XP introduced a different ordering method when sorting numeric file listings in Windows Explorer. Instead of sorting character-by-character in the file name, any numeric string is now handled as a number.

If you have folders whose name contains digits, the sort order is different in Microsoft Windows 2000 and Windows XP. In Windows 2000, the following file and folder names are sorted as shown:

Ie4_01
Ie4_128
Ie401sp2
Ie5
Ie501sp2
Ie6

In Windows XP, the same files and folders are sorted as:

Ie4_01
Ie4_128
Ie5
Ie6
Ie401sp2
Ie501sp2

To change this behaviour open your registry and find the key below.

Create a new DWORD value named "NoStrCmpLogical" and set it to "1" to use the Windows 2000 sorting method.

Restart Explorer for the changes to take effect.

Note: This tweak is available only with Windows XP Service Pack 1 or greater installed on the system.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | NoStrCmpLogical | REG_DWORD | 0x00000001 (1) | |
-
| HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Exp... |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\
Explorer]
Name: NoStrCmpLogical
Type: REG_DWORD (DWORD Value)
Value: (1 = Windows 2000 method)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 26, 2003


Disable Background Notification Balloon in Messenger (All Windows)

Disable Background Notification Balloon in Messenger (All Windows)
Category: Home > Software > Windows Messenger

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

This tweak can be used to disable the popup message that notifies the user that Windows (MSN) Messenger is still running in the background when you close it.

Open your registry and find the key below.

Create a new Binary value, or modify the existing value called 'DSBkgndMode' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | DSBkgndMode | REG_BINARY | 01 00 00 00 | |
-
| HKEY_CURRENT_USER\Software\Microsoft\MessengerService |
-

Settings:
User Key: [HKEY_CURRENT_USER\Software\Microsoft\MessengerService]
Name: DSBkgndMode
Type: REG_BINARY (Binary Value)
Value: (00 00 00 00 = default, 01 00 00 00 = disable message)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: June 26, 2003


Disable File Caching for the Workstation Service (Windows 2000/XP)

Disable File Caching for the Workstation Service (Windows 2000/XP)
Category: Home > Network > Clients

Download this tweak with Tweak Manager! This tweak can be easily applied using WinGuides Tweak Manager.
Download a free trial now!

If you are experiencing problems with workstations flushing data to the server, then you can use this tweak to disable or enable file caching.

Open your registry and find the key below.

Create a new DWORD value, or modify the existing value called 'UtilizeNtCaching' using the settings below.

Exit your registry, you may need to restart or log out of Windows for the change to take effect.

Registry Editor Example
| | Name |  | Type | Data | |
| |  | (Default) | REG_SZ | (value not set) | |
| |  | UtilizeNtCaching | REG_DWORD | 0x00000000 (0) | |
-
| HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanworkstation\p... |
-

Settings:
System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanworkstation\
parameters]
Name: UtilizeNtCaching
Type: REG_DWORD (DWORD Value)
Value: (0 = disable, 1 = enable)

Disclaimer: Modifying the registry can cause serious problems that may require you to reinstall your operating system. We cannot guarantee that problems resulting from modifications to the registry can be solved. Use the information provided at your own risk.

Last Modified: July 14, 2003


License Agreement

License Agreement

LICENSE: WinGuides.com grants you a nonexclusive license to use the accompanying copyrighted software program(s) (the "SOFTWARE"), which includes any associated software components, and any online or electronic documentation, subject to the terms and restrictions set forth in this License Agreement. By installing, copying, or otherwise using the SOFTWARE, you agree to be bound by the terms of this License Agreement. You are not permitted to lease, rent, distribute or sublicense the Software or to use the Software in a time-sharing arrangement or in any other unauthorized manner. Further, no license is granted to you in the human readable code of the Software (source code). Except as provided below, this License Agreement does not grant you any rights to patents, copyrights, trade secrets, trademarks, or any other rights in respect to the Software.

RESTRICTIONS: Modification, reverse engineering, reverse compiling, or disassembly of the SOFTWARE is expressly prohibited, except and only to the extent that such activity is expressly permitted by applicable law.

NO WARRANTY: THE SOFTWARE AND DOCUMENTATION ARE PROVIDED ON AN "AS IS" BASIS AND ALL RISK IS WITH YOU. BECAUSE THE SOFTWARE AND DOCUMENTATION ARE PROVIDED TO YOU FREE OF CHARGE, WINGUIDES.COM MAKES NO WARRANTIES, EXPRESS, IMPLIED OR STATUTORY, AS TO ANY MATTER WHATSOEVER. IN PARTICULAR, ANY AND ALL WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE OR NON-INFRINGEMENT OF THIRD PARTIES RIGHTS ARE EXPRESSLY EXCLUDED. FURTHER, WINGUIDES.COM MAKES NO REPRESENTATIONS OR WARRANTIES THAT THE SOFTWARE AND DOCUMENTATION PROVIDED ARE FREE OF ERRORS OR VIRUSES OR THAT THE SOFTWARE AND DOCUMENTATION ARE SUITABLE FOR YOUR INTENDED USE.

LIMITATION OF LIABILITY: IN NO EVENT SHALL WINGUIDES.COM OR ITS SUPPLIERS BE LIABLE TO YOU OR ANY OTHER PARTY FOR ANY INCIDENTAL, SPECIAL OR CONSEQUENTIAL DAMAGES, LOSS OF DATA OR DATA BEING RENDERED INACCURATE, LOSS OF PROFITS OR REVENUE, OR INTERRUPTION OF BUSINESS IN ANY WAY ARISING OUT OF OR RELATED TO THE USE OR INABILITY TO USE THE SOFTWARE AND/OR DOCUMENTATION, REGARDLESS OF THE FORM OF ACTION, WHETHER IN CONTRACT, TORT (INCLUDING NEGLIGENCE), STRICT PRODUCT LIABILITY OR OTHERWISE, EVEN IF ANY REPRESENTATIVE OF WINGUIDES.COM OR ITS SUPPLIERS HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. THIS DISCLAIMER OF LIABILITY FOR DAMAGES WILL NOT BE AFFECTED BY ANY FAILURE OF THE SOLE AND EXCLUSIVE REMEDIES HEREUNDER.

Should you have any questions concerning this License Agreement, or if you desire to contact WinGuides.com for any reason, please contact WinGuides.com by electronic mail at: info@winguides.com.